Introduction

Answer files are text files that are used to automate the installation of Microsoft® Windows®. They provide the answers to some or all of the prompts that the end user must respond to during Setup and Sysprep. The answer file is specified with the /unattend option to the winnt32.exe command. This hands-free method of installing is convenient for original equipment manufacturers (OEMs), administrators in corporations, value added resellers (VARs), and other end users.

The simplest answer file specifies which features you want to include in the installation. However, you can also use the answer file to display company information during GUI-mode Setup, to specify a keyboard layout, to join a domain or workgroup, and to install device drivers, protocols, or network adapters.

This Windows Preinstallation Reference (Ref.chm) documents the syntax of the various answer files that you use when preinstalling Windows. This Reference is used by both OEMs and corporate administrators. The set of permitted OEM customizations corresponds only to a subset of the answer file entries documented in the Windows Preinstallation Reference.

Note

  • Do not edit undocumented entries; doing so can cause unpredictable results.

Winnt32.exe Command-line Options

From a command prompt, use Winnt32.exe to start Windows Setup from a computer that is running one of the following operating systems:

  • Windows Preinstallation Environment (Windows PE)
  • Windows XP
  • Windows 2000
  • Windows NT
  • Windows Millennium Edition
  • Windows 98
  • Windows 95

Note

  • On an Itanium-based computer, the winnt32 command can be run from Windows XP only (not from an earlier operating system). Also, on an Itanium-based computer, /cmdcons, /syspart, and options relating to upgrades are not available.

The syntax of the winnt32 command is as follows:

winnt32 [/checkupgradeonly] [/cmd:command_line] [/cmdcons] [/copydir:{i386|ia64}\folder_name] [/copysource:folder_name] [/debug[level]:[filename]] [/dudisable] [/duprepare:pathname] [/dushare:pathname] [/emsport:{com1|com2|usebiossettings|off}] [/emsbaudrate:baudrate] [/m:folder_name] [/makelocalsource] [/noreboot] [/s:sourcepath] [/syspart:drive_letter:] [/tempdrive:drive_letter:] [/udf:id [,UDB_file]] [/unattend[num]:[answer_file]]

Option | Action
/checkupgradeonly Checks your computer for upgrade compatibility with this version of Windows.

If you use this option with /unattend, no user input is required. Otherwise, the results are displayed on the screen, and you can save them under the file name that you specify. The default file name is Upgrade.txt in the %SYSTEMROOT% folder.
/cmd:command_line | Instructs Setup to execute a specific command before the final phase of Setup. This occurs after your computer has restarted and after Setup has collected the necessary configuration information, but before Setup finishes.
/cmdcons | Installs the Recovery Console as a startup option on a functioning x86-based computer. The Recovery Console is a command-line interface from which you can perform tasks such as starting and stopping services and accessing the local drive (including drives formatted with NTFS). You can use the /cmdcons option only after normal Setup finishes.
/copydir:{i386|ia64}\folder_name Creates an additional folder within the folder in which the Windows files are installed.

Folder_name refers to a folder that you have created to hold modifications just for your site. For example, for x86-based computers, create a folder called Private_drivers within the i386 source folder for your installation, and place driver files in the folder. Type /copydir:i386\Private_drivers to have Setup copy that folder to your newly installed computer, making the new folder location %SYSTEMROOT%\Private_drivers. You can use /copydir to create as many additional folders as you want.
/copysource:folder_name Creates a temporary additional folder within the folder in which the Windows files are installed.

Folder_name refers to a folder that you have created to hold modifications just for your site. For example, create a folder called Private_drivers within the source folder for your installation, and place driver files in the folder. Type /copysource:Private_drivers to have Setup copy that folder to your newly installed computer and use its files during Setup, making the temporary folder location %SYSTEMROOT%\Private_drivers. You can use /copysource to create as many additional folders as you want. Unlike the folders /copydir creates, /copysource folders are deleted after Setup finishes.
/debug[level]:[filename] | Creates a debug log at the level specified, for example, /debug4:Debug.log. The default log file is C:\%SYSTEMROOT%\Winnt32.log, and the default debug level is 2. The log levels are as follows: 0 represents severe errors, 1 represents errors, 2 represents warnings, 3 represents information, and 4 represents detailed information for debugging. Each level includes the levels below it.
/dudisable | Prevents Dynamic Update from running. Without Dynamic Update, Setup runs only with the original Setup files. This option disables Dynamic Update even if you set DUDisable equal to No in the [Unattended] section of the Unattend.txt file.
/duprepare:pathname | Prepares an installation share to be used with Dynamic Update files that you downloaded from the Windows Update Web site. Use this share for installing Windows for multiple clients.
/dushare:pathname | Specifies a share on which you previously downloaded Dynamic Update files (updated files for use with Setup) from the Windows Update Web site, and on which you previously ran /duprepare:pathname. When run on a client, specifies that the client installation uses the updated files on the share specified in pathname.
/emsport:{com1|com2|usebiossettings|off} Enables or disables Emergency Management Services (EMS) during Setup and after a member of the Windows Server 2003 family has been installed. With EMS, you can remotely manage a server in emergency situations that typically require a local keyboard, mouse, and monitor, such as when the network is unavailable or the server does not function properly. EMS has specific hardware requirements, and is available only for products in the Windows Server 2003 family.

The values com1 and com2 are applicable only for x86-based computers (not Itanium-based computers).

Usebiossettings is the default value, and uses the setting specified in the BIOS Serial Port Console Redirection (SPCR) table, or, in Itanium-based systems, through the Extensible Firmware Interface (EFI) console device path. If you specify usebiossettings and there is no SPCR table or appropriate EFI console device path, EMS is not enabled.

If you disable EMS by specifying /emsport:off, you can later enable it by modifying the boot settings. For information about modifying boot settings, see the Windows Resource Kits.
/emsbaudrate:baudrate For x86-based computers, specifies the baud rate for EMS. (The option is not applicable for Itanium-based computers.) Must be used with /emsport:com1 or /emsport:com2 (otherwise, /emsbaudrate is ignored).

Baudrate can be 9600, 19200, 57600, or 115200. 9600 is the default.
/m:folder_name | Specifies that Setup copies replacement files from an alternate location. Instructs Setup to look in the alternate location first, and if files are present, to use them instead of the files from the default location.
/makelocalsource | Instructs Setup to copy all installation source files to your local hard disk. Use /makelocalsource when installing from a CD to provide installation files when the CD is not available later in the installation.
/noreboot | Instructs Setup not to restart the computer after the file copy phase of Setup finishes so that you can execute another command.
/s:sourcepath Specifies the location of the Windows files. To copy files simultaneously from multiple servers, type the /s:sourcepath option multiple times (up to a maximum of eight). For example:
winnt32 /s:server1 /s:server2

If you type the option multiple times, the first server specified must be available, or Setup fails.
/syspart:drive_letter: On an x86-based computer, specifies that you can copy Setup startup files to a hard disk, mark the disk as active, and then install the disk into another computer. When you start that computer, it automatically starts with the next phase of Setup. You must always use the /tempdrive parameter with the /syspart parameter.

You can start winnt32 with the /syspart option on an x86-based computer running Windows NT 4.0, Windows 2000, or Windows XP. The computer cannot be running Windows 95, Windows 98, or Windows Millennium Edition.
/tempdrive:drive_letter: Directs Setup to place temporary files on the specified partition. For a new installation, Windows will also be installed on the specified partition. For an upgrade, the /tempdrive option affects the placement of temporary files only; the operating system will be upgraded in the partition from which you run winnt32.
/udf:id[,UDB_file] Indicates an identifier (id) that Setup uses to specify how a Uniqueness Database (UDB) file modifies an answer file (see the /unattend entry).

The UDB overrides values in the answer file, and the identifier determines which values in the UDB file are used. For example, /udf:RAS_user,Our_company.udb overrides settings specified for the RAS_user identifier in the Our_company.udb file. If no UDB_file is specified, Setup prompts the user to insert a disk that contains the $Unique$.udb file.

If you start the computer from the Windows product CD and run an unattended Setup, you cannot use the /udf command-line option for Winnt32.exe.
/unattend | Upgrades your previous version of Windows 98, Windows Millennium Edition, Windows NT 4.0, or Windows 2000 in unattended Setup mode. Setup downloads the Dynamic Update files from Windows Update and includes these files in the installation. All user settings are taken from the previous installation, so no user intervention is required during Setup.
/unattend[num]:[answer_file] Performs a fresh installation of Windows in unattended Setup mode. Setup downloads the Dynamic Update files from the Windows Update Web site and includes these files in the installation. The specified answer_file provides Setup with your custom specifications. num

The number of seconds between the time that Setup finishes copying the files and the time Setup restarts. You can use num on any computer running Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, or Windows XP.

answer_file

The name of the answer file. For more information about answer files, see the Microsoft Windows XP Deployment Guide.

Using the /unattend command-line option to automate Setup affirms that you have read and accepted the End-User License Agreement (EULA) for Windows. Before using this command-line option to install Windows on behalf of an organization other than your own, you must confirm that the end user (whether an individual or a single entity) has received, read, and accepted the terms of the Microsoft End-User License Agreement for Windows. OEMs who use this option must run Sysprep on the resulting installation before distribution to the end user. Sysprep will clear the product key, so that on the next boot of the system, the end user will have the opportunity to accept the EULA.

Return to top

Unattended Setup on a Remote Installation Server

When using the Remote Installation Server (RIS) to install Windows on a computer that has a bootable network card, specify the network card as the first bootable device and demote all others. You then provide the maximum possible number of methods for successfully deploying Windows to computers in your environment. For more information about using RIS, see [RemoteInstall].

One method to simplify this process is to modify the basic input/output system (BIOS) to specify the CD-ROM as the first bootable device in the computer, the floppy disk as the second device, and the hard disk as the third.


Changes in Answer Files

This topic lists the changes made in the answer files for Microsoft® Windows® XP and the Windows Server 2003 family.

Unattend.txt

The following sections are new in Unattend.txt:

  • [IEHardening] section
  • [WindowsFirewall]
  • [WindowsFirewall.profile_name]
  • [WindowsFirewall.program_name]
  • [WindowsFirewall.service_name]
  • [WindowsFirewall.portopening_name]
  • [WindowsFirewall.icmpsetting_name]

Entries have been added to the following sections:

[Components] section

  • IEHardenAdmin: Applies the Enhanced Security Configuration to members of the Administrators and Power Users groups.
  • IEHardenUser: Applies the Enhanced Security Configuration to members of the Restricted Users and Guests groups.
  • WbemCrrl: Specifies whether to install the Windows Management Instrumentation (WMI) event correlation component.
  • WbemFwrd: Specifies whether to install the Windows Management Instrumentation (WMI) event forwarding components.
  • WbemMSI: Specifies whether to install the Windows Management Instrumentation (WMI) Windows installer provider.

[Data] section

  • AutomaticUpdates: Specifies whether to enable Automatic Updates.

[GuiUnattended] section

  • EMSSkipUnattendProcessing: Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to an EMS server.

[Unattended] section

  • DUStopOnError: Specifies whether to stop the Windows Update process when an error is detected.

Entries have been deleted from the following sections:

[Components] section

  • iis_www_vdir_scripts
  • AutoUpdate

Sysprep.inf

The following section is new in Sysprep.inf:

  • [IEHardening] section

Entries have been added to the following sections:

[GuiUnattended] section

  • EMSSkipUnattendProcessing: Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to an EMS server.


Changes in Windows Welcome Files (Oobeinfo.ini)

banner

Changes in Windows Welcome Files

This topic lists the changes in Oobeinfo.ini and Windows Welcome Application Programming Interfaces (APIs) since the release of Windows Server 2003.

Changes in Oobeinfo.ini

Entries have been added to the following sections:

[Options] section

  • SkipAutoUpdate: Specifies whether to display the Help Protect Your PC page in Windows Welcome. This page enables end users to schedule Automatic Updates.


Conventions and Syntax

Use the following conventions to help you locate and identify information quickly.

  • Typographical Conventions
  • Standard .ini File Conventions
  • Documentation of .ini-Format Files
  • Sample .ini-Format File and Corresponding Documentation

Typographical Conventions

Type Style | Definition
bold Names of sections and entries in files following the .ini format, command names, command-line options, and any text you must type exactly as it appears. For example:

To determine your IP address, type IPconfig, and then press ENTER.
italic Parameter variables, titles, and definitions. In the case of parameters, you can supply the text for any item shown in italic. For example:

filename
ellipsis (...) | Parameters that can be repeated several times.
between brackets ([]) | Optional items.
between braces ({}); choices separated by pipe (|). Set of choices from which you must choose only one. For example:

{Even | Odd}

monospace
 Code samples and syntax examples.
ALL CAPITALIZED LETTERS | Acronyms and key names.

Standard .ini File Conventions

Several text files used in preinstalling and deploying Windows are structured in the same manner as Windows .ini files. This set of files includes Oobeinfo.ini, Unattend.txt, Sysprep.inf, and Winbom.ini.

Windows .ini files are text files that have the following characteristics:

  • An .ini file is divided into sections.
  • Section headers are enclosed in square brackets. For example, [Name] is the Name section header.
  • Section headers can be either predefined or user-defined.
  • Each section can contain multiple entries.
  • Entry names can be either predefined or user-defined.
  • Each entry appears on a separate line in the form:

    EntryName = EntryValue

  • Sections and their associated entries are delimited by one blank line.
  • The order of sections is not important. A particular section can be located anywhere in the .ini file.
  • Do not use "REM" to begin comments in an .ini file. Begin comments with a semicolon (;) instead.

Documentation of .ini-Format Files

This documentation uses the following conventions for the syntax of these files:

  • Section headers and entry names are bold unless the name is a link.
  • Values for section headers or entries are italicized.
  • Unless indicated, all listed entries are required in a particular section.
  • If you do not include a specific entry in the file, the OPK tools assume that the file contains the given default value.

Sample .ini-Format File and Corresponding Documentation

The following example is an excerpt from an Unattend.txt file that automates the setup of Windows on a computer named "computer2", used by Chris Preston who works at Fabrikam, Inc.:

[UserData]

Answer File = Unattend.txt and Sysprep.inf

The [UserData] section contains entries for specifying user settings during Setup.

ComputerName

Specifies the computer name.

Value | computer_name
Registry subkey | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ ComputerName\ComputerName
Comments | If the ComputerName entry is empty or missing, the end user must enter a computer name. If the value is *, Setup generates a random computer name based on the organization name specified. If computer_name is longer than 63 characters, the string truncates to 63 characters.

FullName

Specifies the end user’s full name.

Value | string
Registry key | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\ CurrentVersion\RegisteredOwner
Comment | If the entry is empty or missing, the end user must enter a name, so that Setup can finish unattended.

OrgName

Specifies an organization’s name.

Value | string
Registry subkey | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\ CurrentVersion\RegisteredOrganization


Unattend.txt

Unattend.txt is the answer file for Setup. An answer file is a way to script the answers for a series of graphical user interface (GUI) dialog boxes. Unattend.txt tells Setup how to interact with the distribution folders and files you create, and supplies Setup with all of the information that the end user provides during a typical Microsoft® Windows® setup. For example, Unattend.txt contains a FullName entry in the [UserData] section that instructs Windows Setup to prompt the end user to provide a full name.

Although the answer file for Setup is commonly called Unattend.txt, for a network preinstallation you can name the file anything you like. For a CD-based Setup, you must name the answer file Winnt.sif.

You can create or modify an Unattend.txt file by using a text editor or Setup Manager.

Note

  • Do not edit undocumented entries; doing so can cause unpredictable results.

Required Sections and Entries

A fully unattended Setup requires the following sections and entries:

Required section | Required entries in that section | Comments
[GuiUnattended] | AdminPassword | Required for all products except Windows XP Home Edition.
 | TimeZone |
[Identification] | JoinWorkgroup | For all products except Windows XP Home Edition, you may instead specify JoinDomain, DomainAdmin, and DomainAdminPassword.
[LicenseFilePrintData] | AutoMode | Required only for the Windows Server 2003 family.
 | AutoUsers | Required only for the Windows Server 2003 family. Requires AutoUsers if AutoMode = PerServer.
[Networking] | No entries in this section. | Required if you want to configure network protocols.
[Unattended] | UnattendMode |
 | TargetPath |
[UserData] | ComputerName |
 | FullName |

All Unattend.txt Sections

In Unattend.txt, you can include the following sections, which are grouped by category. Many sections and entries in Unattend.txt are interdependent.

Hardware Configuration

  • [MassStorageDrivers]
  • [OEMBootFiles]

Setup Configuration

  • [Data]
  • [GuiUnattended]
  • [Unattended]

Operating System Configuration

  • [Display]
  • [GuiRunOnce]
  • [LicenseFilePrintData]
  • [PCHealth]
  • [RegionalSettings]
  • [Shell]
  • [SystemFileProtection]
  • [SystemRestore]
  • [TapiLocation]
  • [UserData]
  • [Win9xUpg]

Internet Explorer Configuration

  • [Branding]
  • [FavoritesEx]
  • [IEHardening]
  • [Proxy]
  • [URL]

Networking Configuration

  • [adapter_specific_protocol_section]
  • [Homenet]
  • [Identification]
  • [MS_AppleTalk parameters]
  • [MS_ATMArps parameters]
  • [MS_ATMLANE parameters]
  • [MS_ATMUni parameters]
  • [MS_L2TP parameters]
  • [MS_MSClient parameters]
  • [MS_NetMon parameters]
  • [MS_NWClient parameters]
  • [MS_NWIPX parameters]
  • [MS_NwSapAgent parameters]
  • [MS_PPTP parameters]
  • [MS_Psched parameters]
  • [MS_RAS parameters]
  • [MS_RasSrv parameters]
  • [MS_Server parameters]
  • [MS_TCPIP parameters]
  • [MS_WLBS parameters]
  • [NetAdapters]
  • [NetBindings]
  • [NetClients]
  • [NetOptionalComponents]
  • [NetProtocols]
  • [NetServices]
  • [Networking]
  • [params.adapter instance]
  • [protocol parameters section]

Services Configuration

  • [DCInstall]
  • [Fax]
  • [InternetServer]
  • [OsChooser]
  • [RemoteInstall]
  • [SNMP]
  • [TerminalServices]

Optional Components

  • [Certsrv_Client]
  • [CertSrv_Server]
  • [Components]

Similarities and Differences Between Unattend.txt Syntax and Sysprep.inf Syntax

The [Unattended] and [GuiUnattended] sections support the following entries in Unattend.txt and Sysprep.inf:

Section Comparison between Unattend.txt and Sysprep.inf
[Unattended] Both Unattend.txt and Sysprep.inf support the following entries:
  • ExtendOemPartition
  • OemPnPDriversPath
  • OemSkipEula
  • UpdateHAL
  • UpdateUPHAL

Only Unattend.txt supports the following entries:

  • AutoActivate
  • ComputerType
  • CrashDumpSetting
  • DUDisable
  • DriverSigningPolicy
  • FactoryMode
  • FileSystem
  • Hibernation
  • KeyboardLayout
  • NtUpgrade
  • OemFilesPath
  • OemPreinstall
  • OverwriteOemFilesOnUpgrade
  • Repartition
  • TargetPath
  • UnattendMode
  • UnattendSwitch
  • Win9xUpgrade
[GuiUnattended] Both Unattend.txt and Sysprep.inf support the following entries:
  • AdminPassword
  • AutoLogon
  • AutoLogonCount
  • EncryptedAdminPassword
  • OemSkipRegional
  • OemSkipWelcome
  • TimeZone

Only Unattend.txt supports the following entries:

  • Arguments
  • DetachedProgram
  • ProfilesDir

The following sections and entries are exactly the same in both Unattend.txt and Sysprep.inf:

  • [Display]
  • [GuiRunOnce]
  • [Identification]
  • [LicenseFilePrintData]
  • [Networking]
  • [RegionalSettings]
  • [TapiLocation]
  • [UserData]

Important

  • Any settings specified in the [RegionalSettings] section in Unattend.txt do not persist if you run Sysprep on the computer. If the first-run experience is Windows Welcome, specify the corresponding settings in the [Options] section of Oobeinfo.ini. If the first-run experience is Mini-Setup, specify the corresponding settings in the [RegionalSettings] section of Sysprep.inf.

Similarities and Differences Between Unattend.txt Syntax and Winbom.ini Syntax

The [Shell] section supports the following entries in Unattend.txt and Winbom.ini:

Section Comparison between Unattend.txt and Winbom.ini
[Shell] Both Unattend.txt and Winbom.ini support the following entries:
  • CustomDefaultThemeFile
  • DefaultStartPanelOff
  • DefaultThemesOff

Only Winbom.ini supports the following entries:

  • DefaultClientStartMenuInternet
  • DefaultClientMail
  • DefaultClientMedia
  • DefaultClientIM
  • DefaultClientJavaVM
  • MSNExplorer


Winnt.sif

Start the computer from a Windows product CD and perform unattended Setup from that CD. You must name the answer file Winnt.sif. The syntax of Winnt.sif is the same as the syntax of a general Unattend.txt file.

Here is a sample Winnt.sif file that performs a fully unattended CD-based Setup:

[Data]
AutoPartition = 1
MsDosInitiated = 0
UnattendedInstall = Yes

[Unattended]
UnattendMode = FullUnattended
OemSkipEula = Yes
OemPreinstall = No

[GuiUnattended]
AdminPassword = *
AutoLogon = Yes
AutoLogonCount = 5
OEMSkipRegional = 1
TimeZone = 85
OemSkipWelcome = 1

[UserData]
FullName = string_value
OrgName = string_value
ComputerName = string_value

[Identification]
JoinWorkgroup = string_value

[Networking]

;For Server installations only
[LicenseFilePrintData]
AutoMode = PerSeat

;Installs the necessary files for the designated Optional Components
[Components]
Certsrv = Off
Certsrv_client = Off
Certsrv_doc = Off
Certsrv_server = Off
Iis_common = On
Iis_inetmgr = On
Iis_ftp = On
Iis_htmla = On
Iis_doc = On
Iis_pwmgr = On
Iis_smtp = On
Iis_smtp_docs = On
Iis_www = On
Indexsrv_system = On
Msmq = Off
Mts_core = On
Reminst = Off
Rstorage = Off
Terminalservices = Off

[InternetServer]
;Without these keys, IIS will use the default settings
;PathFTPRoot = "%SYSTEMDRIVE%\Custom\FTPRoot"
;PathWWWRoot = "%SYSTEMDRIVE%\Custom\WWWRoot"


Sample Unattend.txt Files (Unattend.txt)

banner

Sample Unattend.txt Files

The following sample files illustrate different ways you can configure an unattended Setup. The Setup answer file is most commonly called Unattend.txt; if you do a network installation, you can name this file anything you like. If you use the CD Boot method, you must name the answer file Winnt.sif.

Sample 1

Installs Microsoft® Windows® XP Professional with the default settings.

[Unattended]
FileSystem = LeaveAlone
TargetPath = *

[UserData]
ComputerName = OEM_Computer
FullName = "User Name"
OrgName = "Microsoft"

[Display]
BitsPerPel = 16
Vrefresh = 70
Xresolution = 800
Yresolution = 600

[Networking]

[Identification]
DomainAdmin = "admin"
DomainAdminPassword = "adminpassword"
JoinDomain = ntwksta

Sample 2

Installs a member of the Windows Server 2003 family with two network adapters: one using Dynamic Host Configuration Protocol (DHCP) and the other using static information.

[Unattended]
FileSystem = LeaveAlone
TargetPath = Windows

[GuiUnattended]
AdminPassword = *
OemSkipWelcome = 1
TimeZone = 04

[LicenseFilePrintData]
AutoMode = PerServer
AutoUsers = 8000

[UserData]
ComputerName = computer2
FullName = "User Name"
OrgName = "Microsoft"

;High color 1024 X 768
[Display]
BitsPerPel = 16
Vrefresh = 70
XResolution = 1024
YResolution = 768

[Networking]

[Identification]
JoinWorkgroup = ntdev

;We'll have two network adapters - Adapter01 and Adapter02.
;Note: The adapter specified here as No.1 may not be
;LAN connection No.1 in the user interface.
[NetAdapters]
Adapter01 = params.Adapter01
Adapter02 = params.Adapter02

;Specify the network card used by network adapter No. 1.
[params.Adapter01]
INFID = "pci\ven_0e11&dev_ae32"

;Specify the network card used by network adapter No. 2.
[params.Adapter02]
INFID = "pci\ven_8086&dev_1229&subsys_00018086"

;Install client for MS networks.
[NetClients]
MS_MSClient = params.MS_MSClient

[params.MS_MSClient]

;Only install TCP.
[NetProtocols]
MS_TCPIP = params.MS_TCPIP

[params.MS_TCPIP]
;TCP/IP properties
AdapterSections = params.MS_TCPIP.Adapter01,params.MS_TCPIP.Adapter02

;Card 1 using DHCP server info
[params.MS_TCPIP.Adapter01]
DHCP = Yes
SpecificTo = Adapter01

;Card 2 using static info
[params.MS_TCPIP.Adapter02]
DefaultGateway = 2.2.2.2
DHCP = No
IPAddress = 1.1.1.1
SpecificTo = Adapter02
SubnetMask = 255.255.248.0
WINS = No

;File and print services
[NetServices]
MS_Server = params.MS_Server

[params.MS_Server]
BroadcastsToLanman2Clients = No
Optimization = Balance

Sample 3

Installs a member of the Windows Server 2003 family with Routing and Remote Access Service (RRAS).

[Unattended]
FileSystem = LeaveAlone
TargetPath = Windows

[GuiUnattended]
OemSkipWelcome = 1
TimeZone = 04

[LicenseFilePrintData]
AutoMode = PerServer
AutoUsers = 8000

[UserData]
ComputerName = computer2
FullName = "User Name"
OrgName = "Microsoft"

;High color 1024 x 768
[Display]
BitsPerPel = 16
Vrefresh = 60
XResolution = 1024
YResolution = 768

[Networking]

[NetClients]
MS_MSClient = params.MS_MSClient

[NetProtocols]
MS_NetBeui = params.MS_NetBeui
MS_NWIPX = params.MS_NWIPX
MS_TCPIP = params.MS_TCPIP

[NetServices]
;Install RAS entries
MS_RasSrv = params.MS_RasSrv

[params.MS_TCPIP]
AdapterSections = params.MS_TCPIP.A1,params.MS_TCPIP.A2
DeadGWDetectDefault = No
DontAddDefaultGatewayDefault = Yes
EnableICMPRedirect = No

[params.MS_TCPIP.A1]
DHCP = Yes
SpecificTo = A1

[params.MS_TCPIP.A2]
DHCP = Yes
SpecificTo = A2

[params.MS_RasSrv]
ParamsSection = params.MS_RAS

[params.MS_RAS]
AssignSameNetworkNumber = Yes
AutomaticNetworkNumbers = No
ClientCanRequestIPAddress = No
ClientsCanRequestIpxNodeNumber = No
DialinProtocols = All
ForceEncryptedPassword = 0
IPXClientAccess = Network
Multilink = No
NetBEUIClientAccess = Network
NetworkNumberFrom = 00000003
RouterType = 7
TcpIpClientAccess = Network
UseDHCP = Yes

[NetAdapters]
A1 = params.A1
A2 = params.A2

[params.A1]
NetCardAddress = 0x2bfc01f388d

[params.A2]
NetCardAddress = 0x2bfc01f3890


[Branding] (Unattend.txt)

banner

[Branding]

Answer File = Unattend.txt

The [Branding] section contains entries for branding Microsoft® Internet Explorer during an unattended Setup. If you do not specify this section, Setup uses the default for the Microsoft Windows® XP or Windows Server 2003 family, as appropriate.

Entry | Description
BrandIEUsingUnattended | Specifies whether to use Unattend.txt or an .ins file to brand Internet Explorer during an unattended Setup.
IEBrandingFile | Specifies the name of the .ins file (created by the IEAK) for branding Internet Explorer.

Sample

This sample demonstrates one use of the [Branding] section of Unattend.txt.

[Branding]
BrandIEUsingUnattended = No
IEBrandingFile = MyFile.ins

BrandIEUsingUnattended

Specifies whether to use Unattend.txt or an .ins file to brand Internet Explorer during an unattended Setup.

Syntax BrandIEUsingUnattended = Yes | No
Values Yes

Brands the browser settings by using the entries specified in the browser-specific sections of the answer file: [FavoritesEx], [Proxy], and [URL].

No

Uses the .ins file specified in IEBrandingFile.
Example
BrandIEUsingUnattended = No
Comments If you provide an .ins file that you created using the Internet Explorer Administration Kit (IEAK), add the following to your answer file:

IEBrandingFile = file_name

Not required if you do not configure the browser.

Return to top

IEBrandingFile

Specifies the name of the .ins file (created by the IEAK) for branding Internet Explorer.

Syntax | IEBrandingFile = file_name
Value | file_name
Example
IEBrandingFile = MyFile.ins
Comments The full path to the file is not required. You must place the specified file in the root of the \$OEM$ folder of the distribution share point.

Dependencies: Setup ignores all other sections relating to Internet Explorer branding. Requires BrandIEUsingUnattended = No.

Return to top


[Certsrv_Client] (Unattend.txt)

banner

[Certsrv_Client]

Answer File = Unattend.txt

The [Certsrv_Client] section contains entries for the Web client component of Certificate Services. You do not need to include this section in the Unattend.txt file to install the Web client component of Certificate Services on the computer. Enabling Certificate Services in the [Components] section of the answer file installs the necessary files.

The computer saves any entries that you specify and processes them only after you restart to configure the Web client Certificate Services. They do not process during unattended Setup. For more information about configuring Web client Certificate Services and about Web client Certificate Services requirements, see the Microsoft Windows 2000 Server Resource Kit.

Entry | Description
CAMachine | Specifies the full Domain Name System (DNS) name of the computer with an installed Certification Authority.
CAName | Specifies the name of the certification authority (CA).

Sample

This sample demonstrates one use of the [Certsrv_Client] section of Unattend.txt.

[Certsrv_Client]
CAMachine = CAComputer1
CAName = MyCA

CAMachine

Specifies the full Domain Name System (DNS) name of the computer with an installed Certification Authority.

Syntax | CAMachine = certificate_authority_computer_name
Value | certificate_authority_computer_name
Example
CAMachine = CAComputer1
Comments | Requires that the computer is running and connected to a network.

Return to top

CAName

Specifies the name of the certification authority (CA).

Syntax | CAName = certificate_authority_name
Value | certificate_authority_name
Example
CAName = MyCA
Comments

The value of this entry is required. You must run Certificate Services on the computer and call it through the Component Object Model (COM).

For an installation of the Web client component, CAMachine and CAName refer to the Certification Authority that the Web enrollment pages work with. For an installation of the server components, these two entries are the attributes for the CA.

Return to top


[CertSrv_Server] (Unattend.txt)

banner

[CertSrv_Server]

Answer File = Unattend.txt

The [CertSrv_Server] section contains entries for specifying the server components of Certificate Services. The entries in this section are supported only for the Microsoft® Windows® Server 2003 family.

Required attributes depend on the installation type and configuration.

The computer saves any entries that you specify and processes them only after you restart to configure Certificate Services. They do not process during Setup. For more information about configuring Certificate Services and Certificate Services requirements, see the Microsoft Windows Server 2003 Resource Kit.

Entry | Description
CAType | Specifies the type of certification authority (CA) to install.
CSPProvider | Specifies the name of the Cryptography Service Provider (CSP).
HashAlgorithm | Specifies the hash algorithm used by the CA to sign certificates.
KeyLength | Specifies the key length for the CA.
Name | Specifies the name of the CA.
ParentCAMachine | Specifies the computer name with a certification authority that works as a parent CA with the current subordinate CA installation.
ParentCAName | Specifies the parent CA name for the current subordinate CA installation.
SharedFolder | Specifies the path to the folder that contains the configuration information for the CA.
UseSharedFolder | Specifies whether to use the SharedFolder entry.
ValidityPeriod | Specifies the number of periods, measured in units specified by ValidityPeriodUnits, for which the CA is valid.
ValidityPeriodUnits | Specifies the units for the validity period of the CA.

Sample

This sample demonstrates one use of the [CertSrv_Server] section of Unattend.txt.

[CertSrv_Server]
CAType = EnterpriseRoot
CSPProvider = MyCSP
HashAlgorithm = SHA1
KeyLength = 128
Name = MyCA
ParentCAMachine = CAComputer1
ParentCAName = MyParentCA
SharedFolder = %SYSTEMDRIVE%\CAConfig
UseSharedFolder = Yes
ValidityPeriod = 3
ValidityPeriodUnits = Months

CAType

Specifies the type of certification authority (CA) to install.

Syntax | CAType = EnterpriseRoot | EnterpriseSubordinate | StandaloneRoot | StandaloneSubordinate
Values EnterpriseRoot

EnterpriseSubordinate

StandaloneRoot

StandaloneSubordinate

Default Value Determined programmatically
If Active Directory is available and writable then:
   If any CA is in Active Directory then
      Default is EnterpriseSubordinate
   Else
      Default is EnterpriseRoot
Else
   Default is StandaloneRoot
Example
CAType = EnterpriseRoot
Comments | You must enter a value for this entry.

Return to top

CSPProvider

Specifies the name of the Cryptography Service Provider (CSP).

Syntax | CSPProvider = CSP_name
Values CSP_name

The value is case-sensitive.
Default Value | Microsoft Base Cryptographic Provider v1.0
Example
CSPProvider = MyCSP

Return to top

HashAlgorithm

Specifies the hash algorithm used by the CA to sign certificates.

Syntax | HashAlgorithm = hash_algorithm_string_or_algorithm_ID
Values | hash_algorithm_string_or_algorithm_ID
Default Value | SHA1
Example
HashAlgorithm = SHA1
Comments | The specified Cryptography Service Provider (CSP) must support the algorithm. The value is not case-sensitive.

Return to top

KeyLength

Specifies the key length for the CA.

Syntax | KeyLength = key_length
Value | key_length
Example
KeyLength = 128
Comments | The default key length for the Cryptography Service Provider (CSP) is used if you do not specify a value.

Return to top

Name

Specifies the name of the CA.

Syntax Name = certification_authority_name
Value certification_authority_name

Required
Example
Name = MyCA
Comments The value is required, is case-sensitive, and can contain a maximum of 64 characters.

Note

  • No default value for Name is provided. Because this is a required field, if you install Certificate Services through a fully unattended Setup and if you do not provide the Name value in the Unattend.txt file, then Setup fails with the error code E_INVALIDARG.

Return to top

ParentCAMachine

Specifies the computer name with a certification authority that works as a parent CA with the current subordinate CA installation.

Syntax | ParentCAMachine = parent_computer_name_for_subordinate_CA
Value | parent_computer_name_for_subordinate_CA
Example
ParentCAMachine = CAComputer1
Comments | Setup ignores the value if the current CA installation type is not a subordinate CA. The value is not case-sensitive. If you do not define the attribute when setting up a subordinate CA, Setup saves the CA certificate request to a file. Use this entry in combination with the ParentCAName entry.

Return to top

ParentCAName

Specifies the parent CA name for the current subordinate CA installation.

Syntax | ParentCAName = parent_CA_name_for_subordinate_CA
Value | parent_CA_name_for_subordinate_CA
Example
ParentCAName = MyParentCA
Comments | Setup ignores the value if the CA type is not the subordinate CA. The value is not case-sensitive. If you do not define the attribute but define the ParentCAMachine entry when setting up a subordinate CA, Setup calls Certificate Services on the parent computer to get the CA name.

Return to top

SharedFolder

Specifies the path to the folder containing the configuration information for the CA.

Syntax | SharedFolder = path_to_folder
Value | path_to_folder
Example
SharedFolder = %SYSTEMDRIVE%\CAConfig
Comments The default value is the registered shared folder path, if it exists. If a registered shared folder does not exist, the value is in the format of %SYSTEMDRIVE%\CAConfig.

Enclose path_to_folder in quotation marks if it is a long file name.

Return to top

UseSharedFolder

Specifies whether to use the SharedFolder entry.

Syntax | UseSharedFolder = Yes | No
Values Yes

Use the SharedFolder entry in unattended installations.

No

Do not use the SharedFolder entry in unattended installations.
Default Value | Yes
Example
UseSharedFolder = Yes

Return to top

ValidityPeriod

Specifies the number of periods, measured in units specified by ValidityPeriodUnits, for which the CA is valid.

Syntax | ValidityPeriod = numeric_value
Value | numeric_value
Default Value | 2
Example
ValidityPeriod = 3
Comments | The value must be greater than 0 and less than or equal to 1,000.

Return to top

ValidityPeriodUnits

Specifies the units for the validity period of the CA.

Syntax | ValidityPeriodUnits = Years | Months | Weeks | Days
Values Years

Meausures the ValidityPeriod in years.

Months

Measures the ValidityPeriod in months.

Weeks

Measures the ValidityPeriod in weeks.

Days

Measures the ValidityPeriod in days.
Default Value | Years
Example
ValidityPeriodUnits = Months

Return to top


[Components] (Unattend.txt, Winbom.ini)

banner

[Components]

Answer File = Unattend.txt and Winbom.ini

WinbomType = Factory, OOBE

The [Components] section contains entries for installing the components of Windows XP or Windows Server 2003 family.

Entry | Description
AccessOpt | Specifies whether to install the Accessibility wizard.
appsrv_console | Specifies whether to install the Application Server Console.
aspnet | Specifies whether to install the ASP.NET Web development platform.
BitsServerExtensionsISAPI | Specifies whether to install Internet Server Application Programming Interface (ISAPI) for Background Intelligent Transfer Service (BITS) server extensions on client computers.
BitsServerExtensionsManager | Specifies whether to install the Microsoft Management Console (MMC) snap-in, administrative Application Programming Interfaces (APIs), and Active Directory® Service Interfaces (ADSI) extensions for Background Intelligent Transfer Service (BITS) server extensions.
Calc | Specifies whether to install the Calculator feature.
certsrv | Specifies whether to install the Certificate Services components.
certsrv_client | Specifies whether to install the Web client components of Certificate Services.
certsrv_server | Specifies whether to install the server components of the Certificate Services feature for the Windows Server 2003 family only.
charmap | Specifies whether to install the Character Map feature that inserts symbols and characters into documents.
chat | Specifies whether to install the Chat feature.
clipbook | Specifies whether to install the clipboard viewer.
cluster | Specifies whether to install the Cluster service.
complusnetwork | Specifies whether to enable network COM+ access.
deskpaper | Specifies whether to install a desktop background on the computer desktop.
dialer | Specifies whether to install the Phone Dialer feature.
dtcnetwork | Specifies whether to enable Microsoft Distributed Transaction Coordinator (DTC) network access.
fax | Specifies whether to install the Fax feature.
fp_extensions | Specifies whether to install Microsoft FrontPage® server extensions.
fp_vdir_deploy | Specifies whether to install Visual InterDev® RAD Remote Deployment Support.
freecell | Specifies whether to install the Freecell game.
hearts | Specifies whether to install the Hearts game.
hypertrm | Specifies whether to install the HyperTerminal feature.
IEAccess | Specifies whether to install visible entry points to Internet Explorer.
IEHardenAdmin | Applies the Enhanced Security Configuration to members of the Administrators and Power Users groups.
IEHardenUser | Applies the Enhanced Security Configuration to members of the Restricted Users and Guests groups.
iis_asp | Specifies whether to install Active Server Pages for Internet Information Services (IIS).
iis_common | Specifies whether to install the common set of files required by IIS.
iis_ftp | Specifies whether to install the File Transfer Protocol (FTP) service.
iis_inetmgr | Specifies whether to install the Microsoft Management Console (MMC)-based administration tools for IIS.
iis_internetdataconnector | Specifies whether to install the Internet Data Connector.
iis_nntp | Specifies whether to install the Network News Transfer Protocol (NNTP) service for the Windows Server 2003 family.
iis_serversideincludes | Specifies whether to install Server-Side Includes.
iis_smtp | Specifies whether to install the Simple Mail Transfer Protocol (SMTP) service for the Windows Server 2003 family.
iis_webdav | Specifies whether to install WebDAV Publishing.
iis_www | Specifies whether to install the World Wide Web (WWW) service.
indexsrv_system | Specifies whether to install the Indexing Service files.
inetprint | Specifies whether to install Internet Printing.
licenseserver | Specifies whether to turn Terminal Services licensing on.
media_clips | Specifies whether to install sample sound clips on the computer.
media_utopia | Specifies whether to install the Utopia Sound Scheme on the computer.
minesweeper | Specifies whether to install the Minesweeper game on the computer.
mousepoint | Specifies whether to install all the available mouse pointers distributed with Windows XP or Windows Server 2003 family.
msmq_ADIntegrated | Specifies whether to integrate Message Queuing (also known as MSMQ) with Active Directory if the computer belongs to a domain.
msmq_Core | Specifies whether to set up the Message Queuing components and provide functionality for any dependent clients.
msmq_HTTPSupport | Specifies whether to enable the sending and receiving of messages using the HTTP protocol.
msmq_LocalStorage | Specifies whether to store messages locally, so the computer can send and receive messages even when not connected to a network.
msmq_MQDSService | Specifies whether to provide access to Active Directory and site recognition for downstream clients.
msmq_RoutingSupport | Specifies whether to provide efficient routing.
msmq_TriggersService | Specifies whether to associate the arrival of incoming messages at a queue with functionality in a Component Object Model (COM) component or a stand-alone executable program.
msnexplr | Specifies whether to install MSN Explorer.
mswordpad | Specifies whether to install the WordPad feature on the computer.
netcis | Specifies whether to install Microsoft Component Object Model (COM) Internet Services.
netoc | Specifies whether to install additional optional networking components.
objectpkg | Specifies whether to install the Object Packager feature (packager.exe) on the computer.
OEAccess | Specifies whether to install visible entry points to Outlook Express.
paint | Specifies whether to install the Microsoft Paint feature on the computer.
pinball | Specifies whether to install the Pinball game on the computer.
Pop3Admin | Specifies whether to install the optional Web UI for the Remote Administration Tools on the computer.
Pop3Service | Specifies whether to install the main POP3 service on the computer.
Pop3Srv | Specifies whether to install the root POP3 component on the computer.
rec | Specifies whether to install the Sound Recorder feature on the computer.
reminst | Specifies whether to install Remote Installation Services, which enables you to install an operating system remotely onto a computer with either a new PXE-based remote boot read-only memory (ROM) or a network card supported by the remote installation boot floppy disk.
rootautoupdate | Specifies whether to turn on the Optional Components Manager (OCM) Update Root Certificates.
rstorage | Specifies whether to install the Remote Storage feature that enables the use of tape libraries as extensions of NTFS file system volumes.
sakit_web | Specifies whether to install the Remote Administration Tools (formerly known as the Server Administration Kit).
solitaire | Specifies whether to install the Solitaire game on the computer.
spider | Specifies whether to install the Spider Solitaire game on the computer.
templates | Specifies whether to install Document Templates on the computer.
TerminalServer | Specifies whether to install Terminal Server (Terminal Services for multiple users) on the computer.
TSWebClient | Specifies whether to install the ActiveX® control and sample pages for hosting Terminal Services client connections over the Web.
vol | Specifies whether to install the Volume Control feature on the computer.
WbemCrrl | Specifies whether to install the Windows Management Instrumentation (WMI) event correlation component.
WbemFwrd | Specifies whether to install the Windows Management Instrumentation (WMI) event forwarding components.
WbemMSI | Specifies whether to install the Windows Management Instrumentation (WMI) Windows installer provider.
WMAccess | Specifies whether to install visible entry points to Windows Messenger.
WMPOCM | Specifies whether to install visible entry points to Windows Media Player.
wms | Specifies whether to install the core Windows Media Server components.
wms_admin_asp | Specifies whether to install the Windows Media Services Web-based administrative components.
wms_admin_mmc | Specifies whether to install the Windows Media Services Microsoft Management Console (MMC)-based administrative components.
wms_isapi | Specifies whether to install the Windows Media Services Multicast and Advertisement Logging Agent components.
wms_server | Specifies whether to install the Windows Media Services server components.
zonegames | Specifies whether to install the Microsoft Gaming Zone Internet games on the computer.

Sample

This sample demonstrates one use of the [Components] section of Unattend.txt.

[Components]
AccessOpt = On
Appsrv_console = Off
Aspnet = Off
BitsServerExtensionsISAPI = On
BitsServerExtensionsManager = On
Calc = On
Certsrv = On
Certsrv_client = On
Certsrv_server = On
Charmap = On
Chat = Off
Clipbook = On
Cluster = On
Complusnetwork = Off
Deskpaper = On
Dialer = On
Dtcnetwork = Off
Fax = On
Fp_extensions = On
Fp_vdir_deploy = On
Freecell = On
Hearts = On
Hypertrm = On
IEAccess = On
IEHardenAdmin = On
IEHardenUser = On
Iis_asp = Off
Iis_common = On
Iis_ftp = On
Iis_inetmgr = On
Iis_internetdataconnector = Off
Iis_nntp = On
Iis_serversideincludes = Off
Iis_smtp = On
Iis_webdav = Off
Iis_www = On
Indexsrv_system = On
Inetprint = On
Licenseserver = On
Media_clips = On
Media_utopia = On
Minesweeper = On
Mousepoint = On
Msmq_ADIntegrated = On
Msmq_Core = On
Msmq_HTTPSupport = On
Msmq_LocalStorage = On
Msmq_MQDSService = On
Msmq_RoutingSupport = On
Msmq_TriggersService = On
Msnexplr = On
Mswordpad = On
Netcis = On
Netoc = On
Objectpkg = On
OEAccess = On
Paint = On
Pinball = On
Pop3Admin = On
Pop3Service = On
Pop3Srv = On
Rec = On
Reminst = On
Rootautoupdate = On
Rstorage = On
Sakit_web = Off
Solitaire = On
Spider = On
Templates = On
TerminalServer = On
TSWebClient = On
Vol = On
WbemCrrl = On
WbemFwrd = On
WbemMSI = On
WMAccess = On
WMPOCM = On
Wms = On
Wms_admin_asp = On
Wms_admin_mmc = On
Wms_isapi = On
Wms_server = On
Zonegames = On

AccessOpt

Specifies whether to install the Accessibility wizard.

Syntax | AccessOpt = On | Off
Values On

Installs the Accessibility wizard.

Off

Does not install the Accessibility wizard.
Default Value | On
Example
AccessOpt = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\accessopt

Return to top

appsrv_console

Specifies whether to install the Application Server Console.

Syntax | appsrv_console = On | Off
Values On

Installs the Application Server Console.

Off

Does not install the Application Server Console.
Default Value | Off
Example
appsrv_console = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\appsrv_console

Return to top

aspnet

Specifies whether to install the ASP.NET Web development platform.

Syntax | aspnet = On | Off
Values On

Installs the ASP.NET Web development platform.

Off

Does not install the ASP.NET Web development platform.
Default Value | Off
Example
aspnet = Off
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\aspnet

Return to top

AutoUpdate

See the AutomaticUpdates entry in the [Data] section of Unattend.txt.

Return to top

BitsServerExtensionsISAPI

Specifies whether to install Internet Server Application Programming Interface (ISAPI) for Background Intelligent Transfer Service (BITS) server extensions on client computers.

BITS provides two very useful features to the client:

  • Automatically adjusts the amount of network bandwidth used to make sure all other foreground applications use up all the bandwidth they need, then BITS uses up the rest.
  • Automatically continues a file transfer if the download (or upload) was interrupted by a computer restart or an unplugged network cable.

Syntax | BitsServerExtensionsISAPI = On | Off
Values On

Installs ISAPI for BITS server extensions on client computers.

Off

Does not install ISAPI for BITS server extensions on client computers.
Default Value | Off
Dependencies | Requires BITSServerExtensionsManager and iis_www.
Example
BitsServerExtensionsISAPI = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\bitsserverextensionsisapi

Return to top

BitsServerExtensionsManager

Specifies whether to install the Microsoft Management Console (MMC) snap-in, administrative Application Programming Interfaces (APIs), and Active Directory Service Interfaces (ADSI) extensions for Background Intelligent Transfer Service (BITS) server extensions.

Syntax | BitsServerExtensionsManager = On | Off
Values On

Installs the MMC snap-in, administrative APIs, and ADSI extensions for BITS server extensions.

Off

Does not install the MMC snap-in, administrative APIs, and ADSI extensions for BITS server extensions.
Default Value | Off
Dependencies | Requires iis_inetmgr.
Example
BitsServerExtensionsManager = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\bitsserverextensionsmanager

Return to top

Calc

Specifies whether to install the Calculator feature.

Syntax | Calc = On | Off
Values On

Installs the Calculator feature.

Off

Does not install the Calculator feature.
Default Value | On
Example
Calc = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\calc

Return to top

certsrv

Specifies whether to install the Certificate Services components.

Syntax | certsrv = On | Off
Values On

Installs the Certificate Services components.

Off

Does not install the Certificate Services components.
Default Value | Off
Example
Certsrv = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\certsrv

Return to top

certsrv_client

Specifies whether to install the Web client components of Certificate Services.

Syntax | certsrv_client = On | Off
Values On

Installs the Web client components of Certificate Services.

Off

Does not install the Web client components of Certificate Services.
Default Value | Off
Example
Certsrv_client = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\certsrv_client
Comments | These components enable you to publish Web pages on your server for submitting and requesting certificates from a Certification Authority (CA). You must specify options for the Web client services in the [Certsrv_Client] section in Unattend.txt.

Return to top

certsrv_server

Specifies whether to install the server components of the Certificate Services feature for the Windows Server 2003 family only.

Syntax | certsrv_server = On | Off
Values On

Installs the server components of the Certificate Services feature for the Windows Server 2003 family only.

Off

Does not install the server components of the Certificate Services feature for the Windows Server 2003 family only.
Default Value | Off
Example
Certsrv_server = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\certsrv_server
Comments | These components enable you to create a Certification Authority (CA) on your server for issuing digital certificates. When certsrv_server is set to On, the certsrv_client entry must also be set to On. You must specify options for the server services in the [Certsrv_Server] section in Unattend.txt.

Return to top

charmap

Specifies whether to install the Character Map feature that inserts symbols and characters into documents.

Syntax | charmap = On | Off
Values On

Installs the Character Map feature.

Off

Does not install the Character Map feature.
Default Value | On
Example
Charmap = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\charmap

Return to top

chat

Specifies whether to install the Chat feature.

Syntax | chat = On | Off
Values On

Installs the Chat feature.

Off

Does not install the Chat feature.
Default Value | Off
Example
Chat = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\chat

Return to top

clipbook

Specifies whether to install the clipboard viewer.

Syntax | clipbook = On | Off
Values On

Installs the clipboard viewer.

Off

Does not install the clipboard viewer.
Default Value | On
Example
Clipbook = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\clipbook

Return to top

cluster

Specifies whether to install the Cluster service.

Syntax | cluster = On | Off
Values On

Installs the Cluster service.

Off

Does not install the Cluster service.
Default Value | Off (for the Windows 2000 Server family)
Example
Cluster = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\cluster
Comments | This is supported only by the Windows 2000 Server family. For the Windows Server 2003 family, the Cluster service is automatically installed.

Return to top

complusnetwork

Specifies whether to enable network COM+ access.

Syntax | complusnetwork = On | Off
Values On

Enable network COM+ access.

Off

Does not enable network COM+ access.
Default Value | Off
Example
complusnetwork = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\complusnetwork

Return to top

deskpaper

Specifies whether to install a desktop background on the computer desktop.

Syntax | deskpaper = On | Off
Values On

Installs a desktop background on the computer desktop.

Off

Does not install a desktop background on the computer desktop.
Default Value | On
Example
Deskpaper = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\deskpaper
Comments | If deskpaper = Off, only the standard Windows XP or Windows Server 2003 family background bitmaps are not installed. Background files for the Active Desktop® interface are not affected and are still installed.

Return to top

dialer

Specifies whether to install the Phone Dialer feature.

Syntax | dialer = On | Off
Values On

Installs the Phone Dialer feature only if modem is detected.

Off

Does not install the Phone Dialer feature.
Default Value | On
Example
Dialer = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\dialer
Comments | If dialer = on and a modem is not present the Phone Dialer feature is not installed.

Return to top

dtcnetwork

Specifies whether to enable Microsoft Distributed Transaction Coordinator (DTC) network access.

Syntax | dtcnetwork = On | Off
Values On

Enables Microsoft Distributed Transaction Coordinator (DTC) network access.

Off

Does not enable Microsoft Distributed Transaction Coordinator (DTC) network access.
Default Value | Off
Example
dtcnetwork = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\dtcnetwork

Return to top

fax

Specifies whether to install the Fax feature.

Syntax | fax = On | Off
Values On

Installs the Fax feature.

Off

Does not install the Fax feature.
Default Value | Off
Dependencies | Requires that you also include the parameters for the [Fax] section in Unattend.txt in this installation.
Example
Fax = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\fax

Return to top

fp_extensions

Specifies whether to install Microsoft FrontPage server extensions.

Syntax | fp_extensions = On | Off
Values On

Installs Microsoft FrontPage server extensions.

Off

Does not install Microsoft FrontPage server extensions.
Default Value | Off
Dependencies | Requires iis_common, iis_inetmgr, and iis_www.
Example
Fp_extensions = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\fp_extensions

Return to top

fp_vdir_deploy

Specifies whether to install Visual InterDev RAD Remote Deployment Support.

Syntax | fp_vdir_deploy = On | Off
Values On

Installs Visual InterDev RAD Remote Deployment Support.

Off

Does not install Visual InterDev RAD Remote Deployment Support.
Default Value | Off
Dependencies | Requires fp_extensions.
Example
Fp_vdir_deploy = On

Return to top

freecell

Specifies whether to install the Freecell game.

Syntax | freecell = On | Off
Values On

Installs the Freecell game.

Off

Does not install the Freecell game.
Default Value | On (not available in the Windows Server 2003 family)
Example
Freecell = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\freecell

Return to top

hearts

Specifies whether to install the Hearts game.

Syntax | hearts = On | Off
Values On

Installs the Hearts game.

Off

Does not install the Hearts game.
Default Value | On (not available in the Windows Server 2003 family)
Example
Hearts = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\hearts

Return to top

hypertrm

Specifies whether to install the HyperTerminal feature.

Syntax hypertrm = On | Off
Values On

Installs the HyperTerminal feature.

Off

Does not install the HyperTerminal feature.
Default Value On (Windows XP)
Off (Windows Server 2003 family)
Example
Hypertrm = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\hypertrm

Return to top

IEAccess

Specifies whether to install visible entry points to Internet Explorer.

Syntax | IEAccess = On | Off
Values On

Installs visible entry points to Internet Explorer.

Off

Does not install visible entry points to Internet Explorer.
Default Value | On
Example
IEAccess = On
Comments Not supported by the Windows Server 2003 family. A shortcut link on the Start menu is an example of a visible entry point. This entry does not remove any Windows code, including any Internet Explorer code, other than these visible entry points. Various Windows components and third-party applications rely upon Internet Explorer code.

IEAccess has no effect on Internet Explorer branding or the configuration of Internet settings.

Note

  • You must set IEAccess to Off and then install a different Internet Explorer installation package on the computer, so the user will see the Internet Explorer visible entry points. Other forms of subsequent Internet Explorer configuration (such as autoconfiguration of Internet setttings) do not affect whether the Internet Explorer visible entry points are visible on the Windows desktop.

Return to top

IEHardenAdmin

Applies the Enhanced Security Configuration to members of the Administrators and Power Users groups.

Syntax | IEHardenAdmin = On | Off
Values On

Applies the Enhanced Security Configuration to members of the Administrators and Power Users groups. Changes the Internet Explorer home page to IEHardenAdmin.htm.

Off

Does not apply the Enhanced Security Configuration to members of the Administrators and Power Users groups.

Default Value | On
Example
IEHardenAdmin = On

Return to top

IEHardenUser

Applies the Enhanced Security Configuration to members of the Restricted Users and Guests groups.

Syntax | IEHardenUser = On | Off
Values On

Applies the Enhanced Security Configuration to members of the Restricted Users and Guests groups. Changes the Internet Explorer home page to IEHardenAdmin.htm.

Off

Does not apply the Enhanced Security Configuration to members of the Restricted Users and Guests groups.
Default Value | On
Example
IEHardenUser = On

Return to top

iis_asp

Specifies whether to install Active Server Pages for IIS.

Syntax | iis_asp = On | Off
Values On

Installs Active Server Pages.

Off

Does not install Active Server Pages.
Default Value | Off
Example
iis_asp = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_asp

Return to top

iis_common

Specifies whether to install the common set of files required by IIS.

Syntax iis_common = On | Off
Values On

Installs the common set of files required by IIS.

Off

Does not install the common set of files required by IIS.
Default Value On (Windows Server 2003, Web Edition, and Microsoft Small Business Server)
Off (Windows XP and the Windows Server 2003 family)
Dependencies The following components require iis_common:
  • All of the IIS components (iis_ftp, iis_inetmgr, iis_nntp, iis_smtp, and iis_www.)
  • FrontPage Extensions (fp_extensions)
  • Indexing Service (indexsrv_system)
  • MSMQ (msmq_Core)
  • Windows Media Server Web-based administration tools (wms_admin_asp)
  • Microsoft® Exchange Server
  • Microsoft® BackOffice® Server

Any component that requires the iis_common entry will install it even if iis_common = Off.
Example
iis_common = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_common
Comments

Important

  • Windows XP Professional and Windows XP 64-Bit Edition contain Internet Information Services 5.1. All members of the Windows Server 2003 family contain Internet Information Services 6.0.
  • Windows XP Home Edition does not contain any Web server software components.

Return to top

iis_ftp

Specifies whether to install the FTP service.

Syntax | iis_ftp = On | Off
Values On

Installs the FTP service.

Off

Does not install the FTP service.
Default Value | Off
Dependencies | Requires iis_common and iis_inetmgr.
Example
Iis_ftp = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_ftp
Comments | Use PathFTPRoot in the [InternetServer] section of Unattend.txt to change the default installation path for the FTP root.

Return to top

iis_inetmgr

Specifies whether to install the Microsoft Management Console (MMC)-based administration tools for IIS.

Syntax | iis_inetmgr = On | Off
Values On

Installs the MMC-based administration tools for IIS.

Off

Does not install the MMC-based administration tools for IIS.
Default Value On (Windows Server 2003, Web Edition, and Microsoft Small Business Server)
Off (Windows XP and the Windows Server 2003 family)
Dependencies | Requires iis_common.
Example
Iis_inetmgr = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_inetmgr

Return to top

iis_internetdataconnector

Specifies whether to install the Internet Data Connector.

Syntax | iis_internetdataconnector = On | Off
Values On

Installs the Internet Data Connector.

Off

Does not install the Internet Data Connector.
Default Value | Off
Example
iis_internetdataconnector = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_internetdataconnector

Return to top

iis_nntp

Specifies whether to install the Network News Transfer Protocol (NNTP) service for the Windows Server 2003 family.

Syntax | iis_nntp = On | Off
Values On

Installs the NNTP service for the Windows Server 2003 family.

Off

Does not install the NNTP service for the Windows Server 2003 family.
Default Value | Off
Dependencies | Requires iis_common, iis_inetmgr, and iis_www.
Example
Iis_nntp = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_nntp

Return to top

iis_serversideincludes

Specifies whether to install the Server-Side Includes.

Syntax | iis_serversidesincludes = On | Off
Values On

Installs the Server-Side Includes.

Off

Does not install the Server-Side Includes.
Default Value | Off
Example
iis_serversideincludes = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_serversideincludes

Return to top

iis_smtp

Specifies whether to install the Simple Mail Transfer Protocol (SMTP) service for the Windows Server 2003 family.

Syntax | iis_smtp = On | Off
Values On

Installs the SMTP service for the Windows Server 2003 family.

Off

Does not install the SMTP service for the Windows Server 2003 family.
Default Value On (Windows Server 2003, Web Edition, and Microsoft Small Business Server)
Off (Windows XP and the Windows Server 2003 family)
Dependencies | Requires iis_common, iis_inetmgr, and iis_www.
Example
Iis_smtp = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_smtp

Return to top

iis_webdav

Specifies whether to install WebDAV Publishing.

Syntax | iis_webdav = On | Off
Values On

Installs WebDAV Publishing.

Off

Does not install WebDAV Publishing.
Default Value | Off
Example
iis_webdav = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_webdav

Return to top

iis_www

Specifies whether to install the World Wide Web (WWW) service.

Syntax iis_www = On | Off
Values On

Installs the WWW service.

Off

Does not install the WWW service.
Default Value On (Windows Server 2003, Web Edition, and Microsoft Small Business Server)
Off (Windows XP and the Windows Server 2003 family)
Dependencies Requires iis_common and iis_inetmgr.

Use PathWWWRoot in the [InternetServer] section in Unattend.txt to change the default installation path for the WWW root.
Example
Iis_www = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_www

Return to top

indexsrv_system

Specifies whether to install the Indexing Service files.

Syntax | indexsrv_system = On | Off
Values On

Installs the Indexing Service files.

Off

Does not install the Indexing Service files.
Default Value On (the Windows Server 2003 family);
Off(Windows XP Professional)
Dependencies | Requires iis_common, iis_inetmgr, and iis_www.
Example
Indexsrv_system = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\indexsrv_system

Return to top

inetprint

Specifies whether to install Internet Printing.

Syntax | inetprint = On | Off
Values On

Installs Internet Printing.

Off

Does not install Internet Printing.
Default Value | Off
Dependencies | Requires iis_common, iis_inetmgr, and iis_www.
Example
Inetprint = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\inetprint

Return to top

licenseserver

Specifies whether to turn Terminal Services licensing on.

Syntax | licenseserver = On | Off
Values On

Turns Terminal Services licensing on.

Off

Does not turn Terminal Services licensing on.
Example
Licenseserver = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\LicenseServer
Comments | You can run Terminal Services licensing on a domain controller or on a member server. For more information, see "Terminal Services Licensing" in Windows Server 2003 Help.

Return to top

media_clips

Specifies whether to install sample sound clips on the computer.

Syntax media_clips = On | Off
Values On

Installs sample sound clips on the computer.

Off

Does not install sample sound clips on the computer.
Default Value On (Windows XP)
Off (Windows Server 2003 family)
Example
Media_clips = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\media_clips

Return to top

media_utopia

Specifies whether to install the Utopia Sound Scheme on the computer.

Syntax | media_utopia = On | Off
Values On

Installs the Utopia Sound Scheme on the computer.

Off

Does not install the Utopia Sound Scheme on the computer.
Default Value | Off
Example
Media_utopia = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\media_utopia

Return to top

minesweeper

Specifies whether to install the Minesweeper game on the computer.

Syntax | minesweeper = On | Off
Values On

Installs the Minesweeper game on the computer.

Off

Does not install the Minesweeper game on the computer.
Default Value | On (not available in the Windows Server 2003 family)
Example
Minesweeper = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\minesweeper

Return to top

mousepoint

Specifies whether to install all the available mouse pointers distributed with Windows XP or Windows Server 2003 family.

Syntax | mousepoint = On | Off
Values On

Installs all the available mouse pointers distributed with Windows XP or Windows Server 2003 family.

Off

Does not install all the available mouse pointers distributed with Windows XP or the Windows Server 2003 family.
Default Value | On
Example
Mousepoint = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\mousepoint

Return to top

msmq_ADIntegrated

Specifies whether to integrate Message Queuing (also known as MSMQ) with Active Directory if the computer belongs to a domain.

Syntax | msmq_ADIntegrated = On | Off
Values On

Integrates MSMQ with Active Directory if the computer belongs to a domain.

Off

Does not integrate MSMQ with Active Directory if the computer belongs to a domain.
Default Value | Off
Dependencies | Requires msmq_LocalStorage.
Example
Msmq_ADIntegrated = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_ADIntegrated
Comments | Recommended for a minimal Message Queuing installation. Only for use in unattended installations of members of the Windows Server 2003 family.

Return to top

msmq_Core

Specifies whether to set up the Message Queuing components and provide functionality for any dependent clients.

Syntax | msmq_Core = On | Off
Values On

Sets up the Message Queuing components.

Off

Does not set up the Message Queuing components.
Default Value | Off
Example
Msmq_Core = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_Core
Comments | Required for a minimal Message Queuing installation. Only for use in unattended installations of members of the Windows Server 2003 family.

Return to top

msmq_HTTPSupport

Specifies whether to enable the sending and receiving of messages using the HTTP protocol.

Syntax | msmq_HTTPSupport = On | Off
Values On

Enables the sending and receiving of messages using the HTTP protocol.

Off

Does not enable the sending and receiving of messages using the HTTP protocol.
Default Value | Off
Dependencies | Requires msmq_LocalStorage and iis_www.
Example
Msmq_HTTPSupport = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_HTTPSupport
Comments | Only for use in unattended installations of members of the Windows Server 2003 family.

Return to top

msmq_LocalStorage

Specifies whether to store messages locally, so the computer can send and receive messages even when not connected to a network.

Syntax | msmq_LocalStorage = On | Off
Values On

Stores messages locally.

Off

Does not store messages locally.
Default Value | Off
Dependencies | Requires msmq_Core.
Example
Msmq_LocalStorage = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_LocalStorage
Comments | Required for a minimal Message Queuing installation. Only for use in unattended installations of members of the Windows Server 2003 family.

Return to top

msmq_MQDSService

Specifies whether to provide access to Active Directory and site recognition for downstream clients.

Syntax | msmq_MQDSService = On | Off
Values On

Provides access to Active Directory and site recognition for downstream clients.

Off

Does not provide access to Active Directory and site recognition for downstream clients.
Default Value | Off
Dependencies | Requires msmq_ADIntegrated.
Example
Msmq_MQDSService = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_MQDSService
Comments | msmq_MQDSService is an advanced Message Queuing component that you can install only on the Windows Server 2003 family.

Return to top

msmq_RoutingSupport

Specifies whether to provide efficient routing.

Syntax | msmq_RoutingSupport = On | Off
Values On

Provides efficient routing.

Off

Does not provide efficient routing.
Default Value | Off
Dependencies | Requires msmq_ADIntegrated.
Example
Msmq_RoutingSupport = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_RoutingSupport
Comments | msmq_RoutingSupport is an advanced Message Queuing component that you can install only on the Windows Server 2003 family.

Return to top

msmq_TriggersService

Specifies whether to associate the arrival of incoming messages at a queue with functionality in a Component Object Model (COM) component or a stand-alone executable program.

Syntax | msmq_TriggersService = On | Off
Values On

Associates the arrival of incoming messages at a queue with functionality in a Component Object Model (COM) component or a stand-alone executable program.

Off

Does not associate the arrival of incoming messages at a queue with functionality in a Component Object Model (COM) component or a stand-alone executable program.
Default Value | Off
Dependencies | Requires msmq_LocalStorage.
Example
Msmq_TriggersService = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_TriggersService
Comments | Only for use in unattended installations of members of the Windows Server 2003 family.

Return to top

msnexplr

Specifies whether to install MSN Explorer.

SW
Syntax | msnexplr = On | Off
Values On

Installs MSN Explorer.

Off

Does not install MSN Explorer.
Default Value | On
Example
Msnexplr = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msnexplr
Comments Not supported by the Windows Server 2003 family. If MSN Internet Access is available in Windows Welcome, you must install MSN Explorer.

To replace the MSN shortcut with an MSN Internet Access shortcut, use the following entries in Winbom.ini:

  • IEAccess entry in the [Components] section
  • MSNExplorer entry in the [Shell] section

Do not set msnexplr = No in the [Components] section of Winbom.ini or Unattend.txt.

Return to top

mswordpad

Specifies whether to install the WordPad feature on the computer.

Syntax | mswordpad = On | Off
Values On

Installs the WordPad feature on the computer.

Off

Does not install the WordPad feature on the computer.
Default Value | On
Example
Mswordpad = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\mswordpad

Return to top

netcis

Specifies whether to install Microsoft Component Object Model (COM) Internet Services.

Syntax | netcis = On | Off
Values On

Installs Microsoft COM Internet Services.

Off

Does not install Microsoft COM Internet Services.
Default Value | Off
Dependencies | Requires iis_common = On, iis_inetmgr = On, and iis_www = On.
Example
Netcis = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\netcis

Return to top

netoc

Specifies whether to install additional optional networking components.

Syntax | netoc = On | Off
Values On

Installs additional optional networking components.

Off

Does not install additional optional networking components.
Default Value | On
Example
Netoc = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\netoc
Comments | To modify the default components installed, use the [NetOptionalComponents] section of Unattend.txt or Sysprep.inf. If you set the value of netoc to Off, the [NetOptionalComponents] section is not processed.

Return to top

objectpkg

Specifies whether to install the Object Packager feature (packager.exe) on the computer.

Syntax | objectpkg = On | Off
Values On

Installs the Object Packager feature on the computer.

Off

Does not install the Object Packager feature on the computer.
Default Value | On
Example
Objectpkg = On

Return to top

OEAccess

Specifies whether to install visible entry points to Outlook Express.

Syntax | OEAccess = On | Off
Values On

Installs visible entry points to Outlook Express.

Off

Does not install visible entry points to Outlook Express.
Default Value | On
Example
OEAccess = On
Comments | Not supported in the Windows Server 2003 family. A shortcut link on the Start menu is an example of a visible entry point. This entry does not remove any Windows code, including any Outlook Express code, other than these visible entry points.

Return to top

paint

Specifies whether to install the Microsoft Paint feature on the computer.

Syntax | paint = On | Off
Values On

Installs the Microsoft Paint feature on the computer.

Off

Does not install the Microsoft Paint feature on the computer.
Default Value | On
Example
Paint = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\paint

Return to top

pinball

Specifies whether to install the Pinball game on the computer.

Syntax | pinball = On | Off
Values On

Installs the Pinball game on the computer.

Off

Does not install the Pinball game on the computer.
Default Value | On (not available in the Windows Server 2003 family)
Example
Pinball = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\pinball

Return to top

Pop3Admin

Specifies whether to install the optional Web UI for the Remote Administration Tools on the computer.

Syntax | Pop3Admin = On | Off
Values On

Installs the optional Web UI for the Remote Administration Tools on the computer.

Off

Does not install the optional Web UI for the Remote Administration Tools on the computer.
Default Value | Off
Dependencies | Requires sakit_web.
Example
Pop3Admin = On

Return to top

Pop3Service

Specifies whether to install the main POP3 service on the computer.

Syntax | Pop3Service = On | Off
Values On

Installs the main POP3 service on the computer.

Off

Does not install the main POP3 service on the computer.
Default Value | On
Dependencies | Requires iis_smtp.
Example
Pop3Service = On

Return to top

Pop3Srv

Specifies whether to install the root POP3 component on the computer.

Syntax | Pop3Srv = On | Off
Values On

Installs the root POP3 component on the computer.

Off

Does not install the root POP3 component on the computer.
Default Value | On
Example
Pop3Srv = On

Return to top

rec

Specifies whether to install the Sound Recorder feature on the computer.

Syntax | rec = On | Off
Values On

Installs the Sound Recorder feature on the computer.

Off

Does not install the Sound Recorder feature on the computer.
Default Value | On
Example
Rec = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\rec

Return to top

reminst

Specifies whether to install Remote Installation Services, which enables you to install an operating system remotely onto a computer with either a new PXE-based remote boot read-only memory (ROM) or a network card supported by the remote installation boot floppy disk.

Syntax | reminst = On | Off
Values On

Installs Remote Installation Services.

Off

Does not install Remote Installation Services.
Default Value | Off
Example
Reminst = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\reminst

Return to top

rootautoupdate

Specifies whether to turn on the Optional Components Manager (OCM) Update Root Certificates.

Syntax | rootautoupdate = On | Off
Values On

Turns on the OCM Update Root Certificates.

Off

Does not turn on the OCM Update Root Certificates.
Default Value | On
Example
Rootautoupdate = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\rootautoupdate

Return to top

rstorage

Specifies whether to install the Remote Storage feature that enables the use of tape libraries as extensions of NTFS file system volumes.

Syntax | rstorage = On | Off
Values On

Installs the Remote Storage feature.

Off

Does not install the Remote Storage feature.
Default Value | Off
Example
Rstorage = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\rstorage

Return to top

sakit_web

Specifies whether to install the Remote Administration Tools (formerly known as the Server Administration Kit).

Syntax | Sakit_web = On | Off
Values On

Installs the Remote Administration Tools.

Off

Does not install the Remote Administration Tools.
Default Value | Off
Dependencies Sakit_web = On also installs iis_common, iis_inetmgr, and iis_www.

Use %WINDIR%\System32\ServerAppliance to install the Remote Administration Tools.
Example
Sakit_web = Off
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\sakit_web

Return to top

solitaire

Specifies whether to install the Solitaire game on the computer.

Syntax | solitaire = On | Off
Values On

Installs the Solitaire game on the computer.

Off

Does not install the Solitaire game on the computer.
Default Value | On (not available in the Windows Server 2003 family)
Example
Solitaire = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\solitaire

Return to top

spider

Specifies whether to install the Spider Solitaire game on the computer.

Syntax | spider = On | Off
Values On

Installs the Spider Solitaire game on the computer.

Off

Does not install the Spider Solitaire game on the computer.
Default Value | On (not available in the Windows Server 2003 family)
Example
Spider = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\spider

Return to top

templates

Specifies whether to install Document Templates on the computer.

Syntax | templates = On | Off
Values On

Installs Document Templates on the computer.

Off

Does not install Document Templates on the computer.
Default Value | On
Example
Templates = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\templates

Return to top

TerminalServer

Specifies whether to install Terminal Server (Terminal Services for multiple users) on the computer.

Syntax | TerminalServer = On | Off
Values On

Installs Terminal Server (Terminal Services for multiple users) on the computer.

Off

Does not install Terminal Server (Terminal Services for multiple users) on the computer.
Default Value | Off
Example
TerminalServer = On
Comments If TerminalServer = On, Setup installs Terminal Server and configures the computer to run in multi-user mode. If TerminalServer = Off, Setup does not install Terminal Server. The value of this entry does not affect your ability to establish a remote connection to the computer using Terminal Services Remote Desktop.

TerminalServer applies only to Windows Advanced Server, Limited Edition; Windows Server 2003, Datacenter Edition; and the 64-bit version of Windows Server 2003, Datacenter Edition.

To specify important security settings for a server with Terminal Server enabled, use the PermissionsSetting entry in the [TerminalServices] section.

To specify the type of licensing you are using for Terminal Server, use the LicensingMode entry in the [TerminalServices] section of Unattend.txt.

Return to top

TSWebClient

Specifies whether to install the ActiveX control and sample pages for hosting Terminal Services client connections over the Web.

Syntax | TSWebClient = On | Off
Values On

Installs the ActiveX control and sample pages for hosting Terminal Services client connections over the Web.

Off

Does not install the ActiveX control and sample pages for hosting Terminal Services client connections over the Web.
Default Value | Off
Dependencies | Requires iis_common, iis_inetmgr, and iis_www.
Example
TSWebClient = On

Return to top

vol

Specifies whether to install the Volume Control feature on the computer.

Syntax | vol = On | Off
Values On

Installs the Volume Control feature on the computer.

Off

Does not install the Volume Control feature on the computer.
Default Value | On
Example
Vol = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\vol

Return to top

WbemCrrl

Specifies whether to install the Windows Management Instrumentation (WMI) event correlation component.

Syntax | WbemCrrl = On | Off
Values On

Installs the WMI event correlation component.

Off

Does not install the WMI event correlation component.
Default Value | On
Example
WbemCrrl = On

Return to top

WbemFwrd

Specifies whether to install the Windows Management Instrumentation (WMI) event forwarding components.

Syntax | WbemFwrd = On | Off
Values On

Installs the WMI event forwarding components.

Off

Does not install the WMI event forwarding components.
Default Value | On
Example
WbemFwrd = On

Return to top

WbemMSI

Specifies whether to install the Windows Management Instrumentation (WMI) Windows installer provider.

Syntax | WbemMSI = On | Off
Values On

Installs the WMI Windows installer provider.

Off

Does not install the WMI Windows installer provider.
Default Value | On
Example
WbemMSI = On

Return to top

WMAccess

Specifies whether to install visible entry points to Windows Messenger.

Syntax | WMAccess = On | Off
Values On

Installs visible entry points to Windows Messenger.

Off

Does not install visible entry points to Windows Messenger.
Default Value | On
Example
WMAccess = On
Comments | Not supported in the Windows Server 2003 family. A shortcut link on the Start menu is an example of a visible entry point. This entry does not remove any Windows code, including any Windows Messenger code, other than these visible entry points.

Return to top

WMPOCM

Specifies whether to install visible entry points to Windows Media Player.

Syntax | WMPOCM = On | Off
Values On

Installs visible entry points to Windows Media Player.

Off

Removes visible entry points to Windows Media Player, if the visible entry points are installed.

Default Value | On
Example
WMPOCM = On
Comments | Not supported by the Windows Server 2003 family. A shortcut link on the Start menu is an example of a visible entry point. This entry does not remove any Windows code, including any Windows Media Player code

Return to top

wms

Specifies whether to install the core Windows Media Server components.

Syntax | wms = On | Off
Values On

Installs the core Windows Media Server components.

Off

Does not install the core Windows Media Server components.
Default Value | Off
Dependencies Requires wms_admin_asp, wms_admin_mmc, or wms_server.

Valid only for the Windows Server 2003 family.
Example
Wms = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms

Return to top

wms_admin_asp

Specifies whether to install the Windows Media Services Web-based administrative components.

Syntax | wms_admin_asp = On | Off
Values On

Installs Windows Media Services Web-based administrative components.

Off

Does not install Windows Media Services Web-based administrative components.
Default Value | Off
Dependencies Requires wms, iis_common, iis_inetmgr, and iis_www.

Valid only for the Windows Server 2003 family.
Example
Wms_admin_asp = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms_admin_asp

Return to top

wms_admin_mmc

Specifies whether to install the Windows Media Services Microsoft Management Console (MMC)-based administrative components.

Syntax | wms_admin_mmc = On | Off
Values On

Installs the Windows Media Services MMC-based administrative components.

Off

Does not install the Windows Media Services MMC-based administrative components.
Default Value | Off
Dependencies Requires wms.

Valid only for the Windows Server 2003 family.
Example
Wms_admin_mmc = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms_admin_mmc

Return to top

wms_isapi

Specifies whether to install the Windows Media Services Multicast and Advertisement Logging Agent components.

Syntax | wms_isapi = On | Off
Values On

Installs Windows Media Services Multicast and Advertisement Logging Agent components.

Off

Does not install Windows Media Services Multicast and Advertisement Logging Agent components.
Default Value | Off
Dependencies Requires iis_common, iis_inetmgr, and iis_www.

Valid only for the Windows Server 2003 family.
Example
Wms_isapi = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms_isapi

Return to top

wms_server

Specifies whether to install the Windows Media Services server components.

Syntax | wms_server = On | Off
Values On

Installs the Windows Media Services server components.

Off

Does not install the Windows Media Services server components.
Default Value | Off
Dependencies | Requires wms and wms_server.
Example
Wms_server = On
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms_server
Comments | Valid only for the Windows Server 2003 family.

Return to top

zonegames

Specifies whether to install the Microsoft Gaming Zone Internet games on the computer.

Syntax | zonegames = On | Off
Value On

Installs the Microsoft Gaming Zone Internet games on the computer.

Off

Does not install the Microsoft Gaming Zone Internet games on the computer.
Default Value | On (not available in the Windows Server 2003 family)
Example
Zonegames = On
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\zonegames

Return to top


[Data] (Unattend.txt)

banner

[Data]

Answer File = Unattend.txt

The [Data] section contains entries for performing an unattended Setup directly from the Microsoft Windows product CD or with Winnt.exe.

Entry | Description
AutomaticUpdates | Specifies whether to enable Automatic Updates.
AutoPartition | Installs Windows to the first available partition that has adequate space for a Windows installation and does not already contain an installed version of Windows.
DisableAdminAccountOnDomainJoin | Disables the local Administrator account immediately after the Remote Installation Server (RIS) client successfully joins the domain.
MsDosInitiated | Informs the Windows Setup Loader that an unattended Setup is running directly from the Windows product CD.
UnattendedInstall | Informs the Windows Setup Loader that an unattended Setup is running directly from the Windows product CD.
UseBIOSToBoot | Specifies whether Setup uses the basic input/output system (BIOS) to start the computer, even though Windows Setup might detect that it is best to use a device miniport driver to start the computer.

Sample

This sample demonstrates one use of the [Data] section of Unattend.txt.

[Data]
AutomaticUpdates = 1
AutoPartition = 1
MsDosInitiated = 0
UnattendedInstall = Yes
UseBIOSToBoot = 1

AutomaticUpdates

Specifies whether to enable Automatic Updates.

Syntax AutomaticUpdates = Yes | 1
Value Yes

Enables Automatic Updates. The Help Protect Your PC page does not display. Windows routinely verifies the latest important updates and installs them automatically.

1

Enables Automatic Updates. The Help Protect Your PC page does not display. Windows routinely verifies the latest important updates and installs them automatically.
Example
AutomaticUpdates = 1
Comments Use this setting to enable automatic downloads and installations from Windows Updates.

If this entry is missing or set to anything other than 1 or Yes, then the Help Protect Your PC page displays, enabling the end user to choose to schedule Automatic Updates.

If you set AutomaticUpdates in the [Data] section of the Unattend.txt file equal to 1 or Yes, the Help Protect Your PC page does not display. Windows routinely verifies the latest important updates and installs them automatically to the end user's computer. By taking this action, you are making a choice for the end user. Opt-in privacy laws in some states and local jurisdictions may require you to advise end users that you are making a choice on their behalf. For more information about consumer privacy guidelines, see the Federal Trade Commission Privacy Policy (http://www.ftc.gov/ftc/privacy.htm), the European Commission's Directive on Data Protection (http://europa.eu.int/comm/internal_market/privacy/index_en.htm), and the European Union's principles of "safe harbor" (http://www.export.gov/safeharbor/sh_overview.html).

Return to top

AutoPartition

Installs Windows to the first available partition that has adequate space for a Windows installation and does not already contain an installed version of Windows.

Syntax | AutoPartition = 1
Value | 1
Example
AutoPartition = 1
Comments | Either omit the AutoPartition entry from your answer file or set the value of AutoPartition to 1. If AutoPartition = 1, the /tempdrive command-line option of Winnt32.exe is ignored during Setup. If you do not set the value, text-mode Setup installs Windows on the partition where $WIN_NT$.~LS is located.

Return to top

DisableAdminAccountOnDomainJoin

Disables the local Administrator account immediately after the Remote Installation Server (RIS) client successfully joins the domain.

Syntax | DisableAdminAccountOnDomainJoin = 1
Value | 1
Default Value | 1, if Windows is installed using RIS.
Example
DisableAdminAccountOnDomainJoin = 1
Comments | The value must always be set to 1. If you do not want the local Administrator account to be disabled after the RIS client joins the domain, you must completely remove the DisableAdminAccountOnDomainJoin entry from the unattended installation file.

Return to top

MsDosInitiated

Informs the Windows Setup Loader that an unattended Setup is running directly from the Windows product CD.

Syntax | MsDosInitiated = 0
Value | 0
Example
MsDosInitiated = 0
Comments | The value must always be set to 0. If an unattended Setup is running directly from the product CD and you do not set the value to 0, then Setup fails at the beginning of GUI-mode Setup.

Return to top

UnattendedInstall

Informs the Windows Setup Loader that an unattended Setup is running directly from the Windows product CD.

Syntax | UnattendedInstall = Yes
Value | Yes
Example
UnattendedInstall = Yes
Comments The value must always be set to Yes if you preinstall Windows by using the CD Boot method.

If UnattendedInstall is Yes, set MsDosInitiated to 0.

Note

  • The UnattendedInstall entry is not the same as the UnattendSwitch entry in the [Unattended] section of the answer file. UnattendSwitch controls Windows Welcome; UnattendedInstall does not.

Return to top

UseBIOSToBoot

Specifies whether Setup uses the basic input/output system (BIOS) to start the computer, even though Windows Setup might detect that it is best to use a device miniport driver to start the computer.

Syntax | UseBIOSToBoot = 0 | 1
Values 0

Setup uses the default behavior to start the computer.

1

Setup uses the BIOS to start the computer.
Default Value | 0
Example
UseBIOSToBoot = 1
Comments On computers with large drives that support extended int13 BIOS calls, using the BIOS starts computers faster by eliminating possible delays caused by a miniport driver.

Important

  • Do not use this entry unless you are sure that the BIOS supports the extended int13 functions.

Note

  • The current generation of hardware uses the BIOS to start the computer, so this entry is rarely required.

Return to top


[DCInstall] (Unattend.txt)

banner

[DCInstall]

Answer File = Unattend.txt

The [DCInstall] section contains entries for installing a domain controller after the initial setup of the Microsoft® Windows® operating system finishes. The entries in this section apply only to the Windows Server 2003 family.

You can create an answer file that contains only this section, and run it after Setup completes and an end user logs on to the system. The command for this is dcpromo /answer:answer_file

Entry | Description
AdministratorPassword | Sets the local administrator password for the computer during the demotion of a domain controller.
AllowAnonymousAccess | Specifies whether any pre-Windows 2000 server authenticates end users from this domain or any trusting domain.
AutoConfigDNS | Specifies whether Dcpromo.exe configures Domain Name Service (DNS) for the new domain if it detects that the DNS dynamic update protocol is not available.
ChildName | Specifies whether to append the DNS label at the beginning of the name of an existing directory service domain when installing a child domain.
ConfirmGc | Specifies whether the replica is also a global catalog.
CreateOrJoin | Specifies whether the new tree domain is part of an existing forest of domains.
CriticalReplicationOnly | Specifies whether the promotion operation performs only critical replication, and then continues, skipping the noncritical (and potentially lengthy) portion of replication.
DatabasePath | Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer that contains the domain database.
DisableCancelForDnsInstall | Specifies whether to disable the Cancel button during a DNS installation.
DNSOnNetwork | Specifies whether to set DNS server addresses automatically.
DomainNetBiosName | Assigns a network basic input/output system (NetBIOS) name to the new domain.
IsLastDCInDomain | Specifies whether the computer on which Dcpromo.exe is running is the last domain controller in the domain.
LogPath | Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer that contains the domain log files.
NewDomain | Indicates the type of a new domain: whether a new domain is in a new forest, the root of a new tree in an existing forest, or a child of an existing domain.
NewDomainDNSName | Specifies the required name of a new tree in an existing domain or when Setup installs a new forest of domains.
ParentDomainDNSName | Specifies the DNS domain name of an existing directory service domain when installing a child domain.
Password | Specifies the password for the user name (account credentials) to use for promoting the member server to a domain controller.
RebootOnSuccess | Specifies whether to restart the computer upon successful completion.
RemoveApplicationPartitions | Specifies whether to remove application partitions during the demotion of a domain controller.
ReplicaDomainDNSName | Specifies the DNS domain name of the domain to replicate.
ReplicaOrMember | Specifies whether to convert an upgraded Windows NT 3.51 or Windows NT 4.0 backup domain controller (BDC) to a domain controller or demote it to a regular member server in the domain.
ReplicaOrNewDomain | Specifies whether to install a new domain controller as the first domain controller in a new directory service domain or to install it as a replica directory service domain controller.
ReplicationSourceDC | Indicates the full DNS name of the domain controller from which you replicate the domain information.
ReplicationSourcePath | Indicates the location of the files used to create a new domain controller.
SafeModeAdminPassword | Supplies the password for the administrator account when starting the computer in safe mode or a variant of safe mode, such as directory service restore mode.
SetForestVersion | Indicates the functional level for a new forest.
SiteName | Specifies the name of an existing site where you can place the new domain controller.
Syskey | Indicates that the end user must supply the system key.
SysVolPath | Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer.
TreeOrChild | Specifies that the new domain is the root of a new tree or a child of an existing domain.
UserDomain | Specifies the domain name for the user name (account credentials) used for promoting the member server to a domain controller.
UserName | Specifies the user name (account credentials) used for promoting the member server to a domain controller.

Sample

This sample demonstrates one use of the [DCInstall] section of Unattend.txt.

[DCInstall]
AdministratorPassword = YH3$GJ
AllowAnonymousAccess = No
AutoConfigDNS = Yes
ChildName = childdom.parentdom.fabrikam.com
ConfirmGc = Yes
CreateOrJoin = Create
CriticalReplicationOnly = Yes
DatabasePath = %SYSTEMROOT%\Data
DisableCancelForDnsInstall = Yes
DNSOnNetwork = Yes
DomainNetBiosName = MY_DOMAIN
IsLastDCInDomain = Yes
LogPath = $SYSTEMROOT%\Logs
NewDomain = Tree
NewDomainDNSName = newdom.fabrikam.com
ParentDomainDNSName = fabrikam.com
Password = YH3$GJ
RebootOnSuccess = NoAndNoPromptEither
RemoveApplicationPartitions = Yes
ReplicaDomainDNSName = fab_2.com
ReplicaOrMember = Replica
ReplicaOrNewDomain = Replica
ReplicationSourceDC = fabrikam.com
ReplicationSourcePath = %SYSTEMDRIVE%\Source
SafeModeAdminPassword = XHJ3$G
SetForestVersion = Yes
SiteName = FirstSite
Syskey = 12345
SysVolPath = %SYSTEMDRIVE%\Sysvol
TreeOrChild = Tree
UserDomain = mydomain.com
UserName = PatC

AdministratorPassword

Sets the local administrator password for the computer during the demotion of a domain controller to a member server.

Syntax AdministratorPassword = admin_password
Values admin_password

Default: <blank>
Example
AdministratorPassword = YH3$GJ
Comments This entry is valid only during a demotion. If you do not specify a value, Setup uses a blank administrator password.

Setup deletes the value from the answer file after the demotion operation finishes.

Return to top

AllowAnonymousAccess

Specifies whether any pre-Windows 2000 server authenticates end users from this domain or any trusting domain.

Syntax | AllowAnonymousAccess = Yes | No
Values Yes

Enables anonymous access to end user and group information. Used with pre-Windows 2000 servers.

No

Makes the default permissions more restrictive. Used with Windows 2000 servers.
Default Value | Yes
Example
AllowAnonymousAccess = No

Return to top

AutoConfigDNS

Specifies whether Dcpromo.exe configures DNS for the new domain if it detects that the DNS dynamic update protocol is not available.

Syntax AutoConfigDNS = Yes | No
Values Yes

Default. Configures DNS for the new domain if the DNS dynamic update protocol is not available.

No

Does not configure DNS for the domain.
Example
AutoConfigDNS = Yes

Return to top

ChildName

Specifies whether to append the DNS label at the beginning of the name of an existing directory service domain when installing a child domain.

Syntax | ChildName = child_domain_name
Values | child_domain_name
Example
ChildName = childdom.parentdom.fabrikam.com
Comments For example, if the parent name is "parentdom.fabrikam.com" and the ChildName is "childdom," then the name of the new domain is
"childdom.parentdom.fabrikam.com."

This new domain name must not already be in use and you must properly configure DNS services on the computer. This entry is required.

For more information, see TreeOrChild.

Return to top

ConfirmGc

Specifies whether the replica is also a global catalog.

Syntax | ConfirmGc = Yes | No
Values Yes

Makes the replica a global catalog if the backup was a global catalog.

No

Does not make the replica a global catalog.
Default Value | Yes
Example
ConfirmGc = Yes
Comments | Only applies if you specify ReplicationSourcePath. If you create the restored files from a backup of a global catalog, then the replica can also be a global catalog of those files.

Return to top

CreateOrJoin

Specifies whether the new tree domain is part of an existing forest of domains.

Syntax | CreateOrJoin = Create | Join
Values Create

Creates a new forest of domains.

Join

Default. Places the new domain at the root of a new domain tree in an existing forest of domains.
Example
CreateOrJoin = Create
Comments | Setup supports CreateOrJoin for backward compatibility with Windows 2000 unattended Setup. For unattended Setup of a member of the Windows Server 2003 family, use NewDomain instead.

Return to top

CriticalReplicationOnly

Specifies whether the promotion operation performs only critical replication, and then continues, skipping the noncritical (and potentially lengthy) portion of replication.

Syntax | CriticalReplicationOnly = Yes | No
Values Yes

Skips noncritical replication.

No

Does not skip any replication steps.
Default Value | <none>
Example
CriticalReplicationOnly = Yes
Comments | If Setup skips noncritical replication, replication automatically and silently resumes when you reboot the computer. The computer assumes its new role as a domain controller.

Return to top

DatabasePath

Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer that contains the domain database.

Syntax | DatabasePath = path_to_database_files
Values | path_to_database_files
Default Value | %SYSTEMROOT%\NTDS
Example
DatabasePath = %SYSTEMROOT%\Data
Comments Enclose path_to_database_files in quotation marks if it is a long file name.

If the directory exists, it must be empty. If the directory does not exist, Setup creates it.

The disk must have enough free disk space available (new domains require at least 20 MB) and must have room to grow if you plan to add numerous objects to the domain. For replica domains, you must specify the space required in the domain size.

Note

  • For optimal performance, place the domain database on a different volume than the domain log files.

Return to top

DisableCancelForDnsInstall

Specifies whether to disable the Cancel button during a DNS installation.

Syntax | DisableCancelForDnsInstall = Yes | No
Values Yes

Does not display the Cancel button. During the DNS installation, the /c switch invokes the Optional Component Manager (OCM).

No

Displays the Cancel button.
Default Value | No
Example
DisableCancelForDnsInstall = Yes
Comments

Note

  • This entry applies only if the answer file indicates that the wizard installs DNS on the computer if it has not already installed it.

Return to top

DNSOnNetwork

Specifies whether to set DNS server addresses automatically.

Syntax | DNSOnNetwork = Yes | No
Values Yes

Sets the DNS server addresses manually for the computer.

Important

  • If DNSOnNetwork = Yes, Dcpromo.exe does not test the client configuration. As a result, the user will have to manually set the server addresses later and may have to configure DNS manually for the new domain.
No

Installs the DNS service, creates a valid DNS configuration, and creates a zone for the new domain with that service.
Default Value | Yes
Example
DNSOnNetwork = Yes
Comments | Used when installing the first domain in a new forest and the Transmission Control Protocol/Internet Protocol (TCP/IP) configuration has missing or incorrect DNS server addresses. Before the computer can become a domain controller, its TCP/IP stack must have a valid DNS configuration.

Return to top

DomainNetBiosName

Assigns a network basic input/output system (NetBIOS) name to the new domain.

Syntax | DomainNetBiosName = domain_NetBIOS_name
Values | domain_NetBIOS_name
Example
DomainNetBiosName = MY_DOMAIN
Comments Required

The value is required, and the name specified must not already be in use as a domain or computer name. Setup ignores this entry when upgrading pre-Windows 2000 primary domain controllers.

Return to top

IsLastDCInDomain

Specifies whether the computer on which Dcpromo.exe runs is the last domain controller in the domain.

Syntax | IsLastDCInDomain = Yes | No
Values Yes

Indicates that this computer is the last domain controller in the domain.

No

Indicates that this computer is not the last domain controller in the domain.
Default Value | No
Example
IsLastDCInDomain = Yes
Comments | This entry is valid only when demoting an existing domain controller to a member server.

Return to top

LogPath

Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer that contains the domain log files.

Syntax | LogPath = path_to_log_files
Values | path_to_log_files
Default Value | %SYSTEMROOT%\NTDS
Example
LogPath = %SYSTEMROOT%\Logs
Comments Enclose path_to_log_files in quotation marks if it is a long file name.

If the directory exists, it must be empty. If the directory does not exist, Setup creates it.

The disk must have enough free disk space available (new domains require at least 10 MB) and must have room to expand if you plan to add numerous objects to the domain. For replica domains, you must specify the space required in the domain size.

Note

  • For optimal performance, place the log files on a different volume than the database files.

Return to top

NewDomain

Indicates the type of a new domain: whether a new domain is in a new forest, the root of a new tree in an existing forest, or a child of an existing domain.

Syntax | NewDomain = Tree | Child | Forest
Values Tree

The new domain is the root of a new tree in an existing forest.

Child

The new domain is a child of an existing domain.

Forest (or any other value)

The new domain is the first domain in a new forest of domain trees.
Default Value | Forest
Example
NewDomain = Tree

Return to top

NewDomainDNSName

Specifies the required name of a new tree in an existing domain or when Setup installs a new forest of domains.

Syntax | NewDomainDNSName = DNS_name_of_domain
Values | DNS_name_of_domain
Example
NewDomainDNSName = newdom.fabrikam.com.
Comments | For example, this DNS name could be "newdom.fabrikam.com."

Return to top

ParentDomainDNSName

Specifies the DNS domain name of an existing directory service domain when installing a child domain.

Syntax | ParentDomainDNSName = DNS_name_of_domain
Values | DNS_name_of_domain
Example
ParentDomainDNSName = fabrikam.com
Comments When specifying this entry, make sure that the current end user has administrative user rights to the specified domain, and that you properly configure the DNS services. The domain name must refer to an existing directory service domain.

For more information, see TreeOrChild.

Return to top

Password

Specifies the password for the user name (account credentials) to use for promoting the member server to a domain controller.

Syntax | Password = password
Values | password
Example
Password = YH3$GJ
Comments | The Unattend.txt file deletes the value after the promotion operation finishes.

Return to top

RebootOnSuccess

Specifies whether to restart the computer upon successful completion.

Syntax | RebootOnSuccess = Yes | No | NoAndNoPromptEither
Values Yes

Restarts upon successful completion.

No

Does not restart, but prompts the user to restart.

NoAndNoPromptEither

Does not restart and does not prompt the user to restart.
Default Value | No
Example
RebootOnSuccess = NoAndNoPromptEither
Comments | You must restart the server to start the directory services.

Return to top

RemoveApplicationPartitions

Specifies whether to remove application partitions during the demotion of a domain controller.

Syntax | RemoveApplicationPartitions = Yes | No
Values Yes

Removes application partitions on the domain controller.

No

Does not remove application partitions on the domain controller. If the domain controller hosts the last replica of any application directory partition, you must manually confirm that you must remove these partitions.
Default Value | No
Example
RemoveApplicationPartitions = Yes
Comments

Important

  • If you remove the last replica of any application directory partition, Setup destroys the partition and all data it contains.

Return to top

ReplicaDomainDNSName

Specifies the DNS domain name of the domain to replicate.

Syntax | ReplicaDomainDNSName = DNS_name_of_domain
Values | DNS_name_of_domain
Example
ReplicaDomainDNSName = fab_2.com
Comments This entry is valid only for backup domain controller (BDC) upgrades and domain controller installations. In such situations, you must specify a value or the installation fails.

Normally, the end user who is currently logged on has administrative privileges to the specified domain, and Setup properly configures DNS services. The domain name must refer to an existing directory service domain.

Return to top

ReplicaOrMember

Specifies whether to convert an upgraded Windows NT 3.51 or Windows NT 4.0 BDC to a domain controller or demote it to a regular member server in the domain.

Syntax | ReplicaOrMember = Replica | Member
Values Replica

Installs the server as a domain controller.

Member

Installs the new domain controller as a member server in a domain.
Default Value | Member
Example
ReplicaOrMember = Replica
Comments | This entry is valid only when upgrading a BDC.

Return to top

ReplicaOrNewDomain

Specifies whether to install a new domain controller as the first domain controller in a new directory service domain or to install it as a replica directory service domain controller.

Syntax | ReplicaOrNewDomain = Replica | Domain
Values Replica

Installs the new domain controller as a replica directory service domain controller.

Domain

Installs the new domain controller as the first domain controller in a new directory service domain. You must specify the TreeOrChild entry with a valid value.
Default Value | Replica
Example
ReplicaOrNewDomain = Replica

Return to top

ReplicationSourceDC

Indicates the full DNS name of the domain controller from which you replicate the domain information.

Syntax | ReplicationSourceDC = DNS_name_of_DC
Values DNS_name_of_DC

Indicates the full DNS name of the domain controller from which you replicate the domain information. Applies only in new replica or BDC upgrade cases.

<none>

Selects the closest domain controller for the domain it replicates.
Default Value | <none>
Example
ReplicationSourceDC = fabrikam.com

Return to top

ReplicationSourcePath

Indicates the location of the files used to create a new domain controller.

Syntax | ReplicationSourcePath = replication_source_path
Value | replication_source_path
Default Value | <none>
Example
ReplicationSourcePath = %SYSTEMDRIVE%\Source
Comments The value must be the fully qualified path to a folder on the local computer where you copied the files.

Used to indicate that the bulk of the directory data replication came from backup files that you restored to a volume on the server, rather from another domain controller.

However, you cannot perform complete replication entirely from copied files. You need to access another domain controller. (See ReplicationSourceDC.)

If this value is present and non-empty, then you can perform data replication using the restored files. If this value is not present or is empty, then perform replication from another domain controller on the network.

If the value refers to a valid set of restored backup files, then Setup ignores any value for the ReplicaDomainDNSName entry. The domain name to which the restored files belong takes precedence.

Return to top

SafeModeAdminPassword

Supplies the password for the administrator account when starting the computer in safe mode or a variant of safe mode, such as directory service restore mode.

Syntax | SafeModeAdminPassword = password | None
Value password

Specifies the password for the administrator account that you use when the computer is in safe mode.

None

Does not supply a password for the administrator account.
Default Value | None
Example
SafeModeAdminPassword = XHJ3$G

Return to top

SetForestVersion

Indicates the functional level for a new forest.

Syntax | SetForestVersion = Yes | No
Values Yes

Sets forest functional level to Windows Server 2003 interim.

Important

  • If you set the functional level to Windows Server 2003 interim, you cannot change the functional level to enable Windows 2000 domain controllers later.
No

Sets forest functional level to Windows 2000.
Default Value | No
Example
SetForestVersion = Yes
Comments Set the value of SetForestVersion to Yes if:
  • You want more efficient replication of large group memberships. This functional level includes improvements to the group membership replication feature in Active Directory and is useful if you have groups with many members.
  • You want to support Windows NT 4.0 and Windows Server 2003 domain controllers.
  • You will not have Windows 2000 domain controllers in your forest.

You must set the value of SetForestVersion to No if:

  • You plan on having Windows NT 4.0, Windows 2000, and Windows Server 2003 domain controllers in your forest. This functional level does not support the large group membership replication feature.

Note

  • Use this entry only when the destination computer is a domain controller upgraded from Windows NT 4.0 to a member of the Windows Server 2003 family, and is the first domain controller in a new forest. For more information about creating and typing new domains, see NewDomain.

Return to top

SiteName

Specifies the name of an existing site where you can place the new domain controller.

Syntax | SiteName = site_name
Value | site_name
Default Value | default_first_site
Example
SiteName = FirstSite
Comments | If you do not specify a site, Setup selects a suitable site using the current site and subnet configuration of the forest.

Return to top

Syskey

Indicates that the end user must supply the system key.

Syntax | Syskey = <none> | system key
Default Value | <none>
Example
Syskey = 12345
Comments Only applies if you specify ReplicationSourcePath. Setup uses this value if the restored files that are used to install a replica indicate that the end user must supply the system key.

If the restored files indicate that the end user must supply the system key on a floppy disk, then the system looks for the key on drive A.

Return to top

SysVolPath

Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer.

Syntax | SysVolPath = path_to_database_file
Value | path_to_database_file
Default Value | %SYSTEMROOT%\sysvol
Example
SysVolPath = %SYSTEMROOT%\Sysvol
Comments Enclose path_to_database_file in quotation marks if it is a long file name.

If the directory exists, it must be empty. If the directory does not exist, Setup creates it.

You must format the disk with NTFS version 5.0.

Return to top

TreeOrChild

Specifies that the new domain is the root of a new tree or a child of an existing domain.

Syntax | TreeOrChild = Tree | Child
Values Tree

Specifies that the new domain is the root of a new tree. You must specify the CreateOrJoin or NewDomain entries with a valid value.

Child

Specifies that the new domain is a child of an existing domain.
Default Value | Child
Example
TreeOrChild = Tree
Comments | Setup supports TreeOrChild for backward compatibility with Windows 2000 unattended Setup. For unattended Setup of a member of the Windows Server 2003 family, use NewDomain instead.

Return to top

UserDomain

Specifies the domain name for the user name (account credentials) used for promoting the member server to a domain controller.

Syntax | UserDomain = domain_name
Value | domain_name
Example
UserDomain = mydomain.com

Return to top

UserName

Specifies the user name (account credentials) used for promoting the member server to a domain controller.

Syntax | UserName = user_name
Value | user_name
Example
UserName = PatC

Return to top


[Display] (Unattend.txt, Sysprep.inf)

banner

[Display]

Answer File = Unattend.txt and Sysprep.inf

The [Display] section contains entries for specifying display settings for graphics devices.

If the specified settings are not valid for the graphics device, Setup finds the closest match to the selected settings to configure the device.

Important

  • If the monitor plugged into the computer is a Plug and Play device and is capable of displaying a screen resolution of 800x600x16m, then the display resolution must be at least 800x600x16m. Setup uses the 640 x 480-pixel screen size only if the monitor is unable to display an 800 x 600-pixel screen.

Sysprep.exe configures the operating system to use the video settings in the [Display] section of Sysprep.inf. If there are no display settings or if Setup does not use Sysprep.inf, Sysprep.exe uses the video settings in the registry. If you configure the display settings manually, set them in Unattend.txt, or use the defaults, then Sysprep retains those settings. If you define the screen resolution in both the [Display] section of Sysprep.inf and in the [ComputerSettings] section of Winbom.ini, the operating system uses the settings in Sysprep.inf.

Entry | Description
BitsPerPel | Specifies the valid bits per pixel for the graphics device.
Vrefresh | Specifies a valid refresh rate for the graphics device.
Xresolution | Specifies a valid x resolution for the graphics device.
Yresolution | Specifies a valid y resolution for the graphics device.

Sample

This sample demonstrates one use of the [Display] section of Unattend.txt.

[Display]
BitsPerPel = 16
Vrefresh = 75
Xresolution = 1024
Yresolution = 768

BitsPerPel

Specifies the valid bits per pixel for the graphics device.

Syntax | BitsPerPel = valid_bits_per_pixel
Value | valid_bits_per_pixel
Example | For example, a value of 8 (28) implies 256 colors, and a value of 16 implies 65,536 colors.

Return to top

Vrefresh

Specifies a valid refresh rate for the graphics device.

Syntax | Vrefresh = valid_refresh_rate
Value | valid_refresh_rate
Example
Vrefresh = 75

Return to top

Xresolution

Specifies a valid x resolution for the graphics device.

Syntax | Xresolution = valid_x_resolution
Value | valid_x_resolution
Example
Xresolution = 1024

Return to top

Yresolution

Specifies a valid y resolution for the graphics device.

Syntax | Yresolution = valid_y_resolution
Value | valid_y_resolution
Example
Yresolution = 768

Return to top


[FavoritesEx] (Unattend.txt)

banner

[FavoritesEx]

Answer File = Unattend.txt

The [FavoritesEx] section contains the default Favorites settings for the Windows browser. If not present, Setup uses the default for Microsoft® Windows®.

Sample

This sample demonstrates one use of the [FavoritesEx] section of Unattend.txt.

[FavoritesEx]
Title1 = MSN.url
URL1 = http://www.microsoft.com/
Title2 = MSNBC.url
URL2 = http://www.msnbc.co
Syntax Title1 = site_name.url
URL1 = url
Value Title# = site_name.url
URL# = site_address
Example
[FavoritesEx]
Title1 = MSN.url
URL1 = http://www.microsoft.com/
Title2 = MSNBC.url
URL2 = http://www.msnbc.com
Comments

Important

  • To make sure your [FavoritesEx] settings take effect, include the [Branding] section header and the BrandIEUsingUnattended entry in the answer file to enable the browser-related settings:
    [Branding]
BrandIEUsingUnattended = Yes

Return to top


[Fax] (Unattend.txt)

banner

[Fax]

Answer File = Unattend.txt

The [Fax] section contains entries for specifying custom installation information for the fax service in Microsoft® Windows®.

All settings in the [Fax] section require Fax = On in the [Components] section.

Entry | Description
ArchiveFolderName | Specifies the folder in which the fax service saves copies of outgoing faxes.
ArchiveIncoming | Specifies whether to save incoming faxes in a folder.
ArchiveIncomingFolderName | Specifies the folder in which the fax service saves copies of incoming faxes.
ArchiveOutgoing | Specifies whether to save outgoing faxes in a folder.
ArchiveOutgoingFolderName | Specifies the folder in which the fax service saves copies of outgoing faxes.
Csid | Specifies the Called Subscriber ID (CSID) transmitted to the sending fax machine when receiving incoming faxes.
FaxPrinterIsShared | Specifies if the fax printer is shared and if remote users can use the server as a shared fax server.
FaxPrinterName | Specifies the fax printer name for outgoing faxes.
FaxUserName | Specifies the user account name to use for authenticating against the server in Basic Simple Mail Transfer Protocol (SMTP) Authentication, or the account name used for Windows Security-based authentication.
FaxUserPassword | Specifies the password to use for authenticating against the server in Basic SMTP Authentication or Windows Security-based authentication.
ReceiveFaxes | Specifies whether the fax service answers incoming calls on this device.
Rings | Specifies the number of rings before the fax service answers the telephone.
RouteFolderName | Specifies the destination folder for incoming faxes.
RoutePrinterName | Specifies the printer name to which the fax service routes faxes automatically.
RouteToEmail | Specifies whether to route faxes to a specific e-mail account.
RouteToEmailRecipient | Specifies the e-mail name (or e-mail alias) of the recipient of incoming faxes.
RouteToFolder | Specifies whether to route incoming faxes to a folder.
RouteToPrinter | Specifies whether to route incoming faxes to a printer.
SendFaxes | Specifies whether the fax service uses a device to send faxes. This entry applies to existing and new fax devices.
SuppressConfigurationWizard | Specifies whether to display the service setting pages of the Configuration Wizard when the end user runs Fax for the first time.
SmtpNotificationsEnabled | Specifies whether to enable Simple Mail Transfer Protocol (SMTP) notifications for sent faxes.
SmtpSenderAddress | Specifies the e-mail address used in outgoing e-mail notifications.
SmtpServerAddress | Specifies the name or IP address of the e-mail server.
SmtpServerAuthenticationMechanism | Specifies the authentication schema to use.
SmtpServerPort | Specifies the IP port number for the e-mail server.
SuppressConfigurationWizard | Specifies whether to display the service setting pages of the Configuration Wizard when the end user runs Fax for the first time.
Tsid | Specifies the Transmitter Subscriber ID (TSID) sent by the fax machine to a receiving fax machine.

Sample

This sample demonstrates one use of the [Fax] section of Unattend.txt.

[Fax]
ArchiveFolderName = %SystemDrive%\MsFax\SentItems
ArchiveIncoming = True
ArchiveIncomingFolderName = %SystemDrive%\MsFax\Inbox
ArchiveOutgoing = True
ArchiveOutgoingFolderName = %SystemDrive%\MsFax\SentItems
Csid = 12345
FaxPrinterIsShared = True
FaxPrinterName = MyFaxPrinter
FaxUserName = PatC
FaxUserPassword = 32*XXj
ReceiveFaxes = True
Rings = 3
RouteFolderName = %SYSTEMDRIVE%\MsFax\NewFaxes
RoutePrinterName = MyPrinter
RouteToEmail = True
RouteToEmailRecipient = PatC@fabrikam.com
RouteToFolder = True
RouteToPrinter = True
SendFaxes = True
SuppressConfigurationWizard = True
SmtpNotificationsEnabled = True
SmtpSenderAddress = PatC@fabrikam.com
SmtpServerAddress = SMTP_1@fabrikam.com
SmtpServerPort = 25
SmtpServerAuthenticationMechanism = WindowsSecurity
SuppressConfigurationWizard = True
Tsid = Fab1234567

ArchiveFolderName

Specifies the folder in which the fax service saves copies of outgoing faxes.

Syntax | ArchiveFolderName = folder_to_save_faxes_to
Value | folder_to_save_faxes_to
Default Value | %SystemDrive%\documents and Settings\All Users\Application Data\Microsoft\Windows NT\MsFax\SentItems
Example
ArchiveFolderName = %SystemDrive%\MsFax\SentItems
Comments Setup supports ArchiveFolderName for backward compatibility with Windows 2000 unattended Setup. For Windows XP and Windows Server 2003 installations, use ArchiveOutgoingFolderName instead.

You must specify a valid folder name that is not an empty string or a string containing only spaces. Unless you explicitly set the ArchiveOutgoing entry to False, you must specify the folder.

Return to top

ArchiveIncoming

Specifies whether to save incoming faxes in a folder.

Syntax | ArchiveIncoming = True | False
Values True

Saves incoming faxes in the folder specified by the ArchiveIncomingFolderName entry.

False

Does not save incoming faxes.
Default Value | True
Example
ArchiveIncoming = True
Comments | If ArchiveIncoming = True, you must specify a folder in ArchiveIncomingFolderName.

Return to top

ArchiveIncomingFolderName

Specifies the folder in which the fax service saves copies of incoming faxes.

Syntax | ArchiveIncomingFolderName = folder_to_save_faxes_to
Value | folder_to_save_faxes_to
Default Value | %SystemDrive%\documents and Settings\All Users\Application Data\Microsoft\Windows NT\MsFax\Inbox
Example
ArchiveIncomingFolderName = %SystemDrive%\MsFax\Inbox
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Inbox\Folder
Comments | If ArchiveIncoming = True, you must specify a valid folder name that is not an empty string or a string containing only spaces.

Return to top

ArchiveOutgoing

Specifies whether to save outgoing faxes in a folder.

Syntax | ArchiveOutgoing = True | False
Values True

Saves outgoing faxes in the folder specified by the ArchiveOutgoingFolderName entry.

False

Does not save outgoing faxes.
Default Value | True
Example
ArchiveOutgoing = True
Comments | If ArchiveOutgoing = True, you must specify a folder in ArchiveOutgoingFolderName.

Return to top

ArchiveOutgoingFolderName

Specifies the folder in which the fax service saves copies of outgoing faxes.

Syntax | ArchiveOutgoingFolderName = folder_to_save_faxes_to
Values | folder_to_save_faxes_to
Default Value %SystemDrive%\documents and Settings\All Users\
Application Data\Microsoft\Windows NT\MsFax\SentItems
Example
ArchiveOutgoingFolderName = %SystemDrive%\MsFax\SentItems
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\SentItems\Folder
Comments | You must specify a valid folder name that is not an empty string or a string containing only spaces. Unless you explicitly set ArchiveOutgoing to False, you must specify the folder.

Return to top

Csid

Specifies the Called Subscriber ID (CSID) transmitted to the sending fax machine when receiving incoming faxes.

Syntax | Csid = called_subscriber_ID_string
Value | called_subscriber_ID_string
Default Value | Fax
Example
Csid = 12345
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\Csid
Comments This string is usually a combination of the fax or telephone number and the name of the business. It is often the same as the Transmitter Subscriber ID.

This entry applies to all of the existing devices and every new device.

Return to top

FaxPrinterIsShared

Specifies if the fax printer is shared and if remote users can use the server as a shared fax server.

Syntax | FaxPrinterIsShared = True | False
Values True

Creates a shared fax printer. Users can use this printer to send faxes to over the network. The server functions as a shared fax server.

False

Creates a fax printer that is not shared. The fax service can be used only as a personal fax from the server itself.
Default Value | False
Example
FaxPrinterIsShared = True
Comments | This entry applies to existing and new fax devices.

Return to top

FaxPrinterName

Specifies the fax printer name for outgoing faxes.

Syntax | FaxPrinterName = fax_printer_name_string
Value | fax_printer_name_string
Default Value | Fax
Example
FaxPrinterName = MyFaxPrinter
Comments The value of this entry cannot be the same as the value of RoutePrinterName.

This string must not be an empty string or a string containing only spaces.

Return to top

FaxUserName

Specifies the user account name to use for authenticating against the server in Basic Simple Mail Transfer Protocol (SMTP) Authentication, or the account name used for Windows Security-based authentication.

Syntax | FaxUserName = user_account_name
Value | user_account_name
Example
FaxUserName = PatC
Comments This string must not be an empty string or a string containing only spaces.

Valid only for the Windows Server 2003 family.

Return to top

FaxUserPassword

Specifies the password to use for authenticating against the server in Basic SMTP Authentication or Windows Security-based authentication.

Syntax | FaxUserPassword = user_account_password
Value | user_account_password
Example
FaxUserPassword = 32*XXj
Comments | Valid only for the Windows Server 2003 family.

Return to top

ReceiveFaxes

Specifies whether the fax service answers incoming calls on this device.

Syntax | ReceiveFaxes = True | False
Values True

Answers incoming calls on this device.

False

Does not answer incoming calls on this device.
Default Value | False
Example
ReceiveFaxes = True
Comments | This entry applies to existing and new fax devices.

Return to top

Rings

Specifies the number of rings before the fax service answers the telephone.

Syntax | Rings = number_of_rings
Value | number_of_rings
Default Value | 2
Example
Rings = 3
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\Rings
Comments | This string must be a numeric value between 0 and 99. This setting applies to existing and new fax devices.

Return to top

RouteFolderName

Specifies the destination folder for incoming faxes.

Syntax | RouteFolderName = folder_to_route_faxes to
Value | folder_to_route_faxes to
Example
ReceiveFaxes = %SYSTEMDRIVE%\MsFax\NewFaxes
Comments For Windows XP, this entry applies to all existing devices and every new device present during Setup.

For the Windows Server 2003 family, this entry applies to all existing devices and every new device.

Return to top

RoutePrinterName

Specifies the printer name to which the fax service routes faxes automatically.

Syntax | RoutePrinterName = printer_to_route_faxes_to
Value | printer_to_route_faxes_to
Example
RoutePrinterName = MyPrinter
Comments For Windows XP, this entry applies to all existing devices and every new device present during Setup.

For the Windows Server 2003 family, this entry applies to all existing devices and every new device.

Return to top

RouteToEmail

Specifies whether to route faxes to a specific e-mail account.

Syntax | RouteToEmail = True | False
Values True

Routes faxes directly to the e-mail address specified by the RouteToEmailRecipient entry.

False

Does not route faxes to an e-mail address.
Default Value | False
Example
RouteToEmail = True
Comments If you set RouteToEmail to True, you must provide Simple Mail Transfer Protocol (SMTP) settings for incoming faxes by using SmtpNotificationsEnabled, SmtpSenderAddress, SmtpServerAddress, SmtpServerPort, SmtpServerAuthenticationMechanism, and RouteToEmailRecipient.

This entry applies to all existing devices and every new device present during Setup.

Valid only for the Windows Server 2003 family.

Return to top

RouteToEmailRecipient

Specifies the e-mail name (or e-mail alias) of the recipient of incoming faxes.

Syntax | RouteToEmailRecipient = email_name_to_route_faxes_to
Value | email_name_to_route_faxes_to
Example
RouteToEmailRecipient = PatC@fabrikam.com
Comments This entry applies to all existing devices and every new device present during Setup. This string must be a valid recipient e-mail name, and must not be an empty string or a string containing only spaces.

Valid only for the Windows Server 2003 family.

Return to top

RouteToFolder

Specifies whether to route incoming faxes to a folder.

Syntax | RouteToFolder = True | False
Values True

Routes faxes to the folder specified by the RouteFolderName entry.

False

Does not route faxes to a folder.
Default Value | True
Example
RouteToFolder = True
Comments For Windows XP, this entry applies to all existing devices and every new device present during Setup.

For the Windows Server 2003 family, this entry applies to all existing devices and every new device.

Return to top

RouteToPrinter

Specifies whether to route incoming faxes to a printer.

Syntax | RouteToPrinter = True | False
Values True

Routes incoming faxes to the printer specified by the RoutePrinterName entry.

False

Does not route incoming faxes to a printer.
Default Value | False
Example
RouteToPrinter = True
Comments For Windows XP, this entry applies to all existing devices and every new device present during Setup.

For the Windows Server 2003 family, this entry applies to all existing devices and every new device.

Return to top

SendFaxes

Specifies whether the fax service uses a device to send faxes. This entry applies to existing and new fax devices.

Syntax | SendFaxes = True | False
Values True

Uses a device to send faxes.

False

Does not use a device to send faxes.
Default Value | True
Example
SendFaxes = True

Return to top

SuppressConfigurationWizard

Specifies whether to display the service setting pages of the Configuration Wizard when the end user runs Fax for the first time.

Syntax | SuppressConfigurationWizard = True | False
Values True

Skips service setting pages of the Configuration Wizard when the end user runs Fax for the first time.

False

Displays service setting pages of the Configuration Wizard when the end user runs Fax for the first time.
Default Value | True
Example
SuppressConfigurationWizard = True

Return to top

SmtpNotificationsEnabled

Specifies whether to enable Simple Mail Transfer Protocol (SMTP) notifications for sent faxes.

Syntax | SmtpNotificationsEnabled = True | False
Values True

Enables SMTP notifications and provides settings for SmtpSenderAddress, SmtpServerAddress, SmtpServerPort, SmtpServerAuthenticationMechanism and other parameters related to them.

False

Does not enable SMTP notifications.
Default Value | False
Example
SmtpNotificationsEnabled = True
Comments | Valid only for the Windows Server 2003 family.

Return to top

SmtpSenderAddress

Specifies the e-mail address used in outgoing e-mail notifications.

Syntax | SmtpSenderAddress = sender_email_address
Value | sender_email_address
Example
SmtpSenderAddress = PatC@fabrikam.com
Comments This string must not be an empty string or a string containing only spaces.

Valid only for the Windows Server 2003 family.

Return to top

SmtpServerAddress

Specifies the name or IP address of the e-mail server.

Syntax | SmtpServerAddress = email_server_address
Value | email_server_address
Example
SmtpServerAddress = SMTP_1@fabrikam.com
Comments This string must not be an empty string or a string containing only spaces.

Valid only for the Windows Server 2003 family.

Return to top

SmtpServerAuthenticationMechanism

Specifies the authentication schema to use.

Syntax | SmtpServerAuthenticationMechanism = Anonymous | Basic | WindowsSecurity
Values Anonymous

Provides a low level of security, and allows all end users to authenticate to servers.

Basic

Provides basic security. Requires FaxUserName and FaxUserPassword.

WindowsSecurity

Provides high security. Requires FaxUserName and FaxUserPassword
Default Value | Anonymous
Example
SmtpServerAuthenticationMechanism = WindowsSecurity
Comments | Valid only for the Windows Server 2003 family.

Return to top

SmtpServerPort

Specifies the IP port number for the e-mail server.

Syntax | SmtpServerPort = email_server_port
Value | email_server_port
Default Value | 25
Example
SmtpServerPort = 25
Comments This string must be a numeric value between 1 and 65,535.

Valid only for the Windows Server 2003 family.

Return to top

SuppressConfigurationWizard

Specifies whether to display the service setting pages of the Configuration Wizard when the end user runs Fax for the first time.

Syntax | SuppressConfigurationWizard = True | False
Values True

Skips service setting pages of the Configuration Wizard when the end user runs Fax for the first time.

False

Displays service setting pages of the Configuration Wizard when the end user runs Fax for the first time.
Default Value | True
Example
SuppressConfigurationWizard = True

Return to top

Tsid

Specifies the Transmitter Subscriber ID (TSID) sent by the fax machine to a receiving fax machine.

Syntax | Tsid = transmitter_subscriber_ID_string
Values | transmitter_subscriber_ID_string
Default Value | Fax
Example
Tsid = Fab1234567
Registry subkey | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax\Setup\Original Setup Data\Tsid
Comments | This string is usually a combination of the fax or telephone number and the name of the business. It is often the same as the Called Subscriber ID.

Return to top


[GuiRunOnce] (Unattend.txt, Sysprep.inf)

banner

[GuiRunOnce]

Answer File = Unattend.txt and Sysprep.inf

The [GuiRunOnce] section contains commands to execute the first time an end user logs on to the computer after GUI-mode Setup completes.

Commands called in the [GuiRunOnce] section process synchronously. Each application runs in the order listed in this section, and each command must finish before you run the next command.

Each line specifies a command that the [GuiRunOnce] registry entry executes, HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Runonce. See the following table for examples:

To install | Add this line to [GuiRunOnce]
Domain Controller | dcpromo /answer:answer_file
Cluster service | %WINDIR%\cluster\cluster.exe clustername /create /options where /options is defined in the "Managing server clusters from the command line" topic in the Windows Server Help.

Important

  • You must put each command line in quotation marks.

Commands run using the [GuiRunOnce] section in the context of the currently logged-in end user. If the end user does not have the permissions necessary to run the command completely, then the application fails. Because this application runs in the context of a logged-in end user instead of as a service, the registry entries that the application creates are for the current end user instead of the default user. (Setup propagates default user registry settings to new end users.) If you want any settings and updates to appear only for the specifically logged-in end user, then this might be appropriate. Otherwise, Cmdlines.txt is a better approach to running commands and installing applications, because it runs as a system service.


[GuiUnattended] (Unattend.txt)

Answer File = Unattend.txt

The [GuiUnattended] section for Unattend.txt contains entries for preparing the graphical user interface (GUI) for unattended Setup.

For the Sysprep.inf version, see [GuiUnattended] (Sysprep.inf).

Entry | Description
AdminPassword | Sets the Administrator account password.
Arguments | Indicates that arguments or entries accompany the custom program that runs concurrently with the Setup program.
AutoLogon | Configures the computer to log on once with the Administrator account.
AutoLogonCount | Specifies the number of times that the computer automatically logs on with the specified Administrator account and password.
DetachedProgram | Indicates the path of the custom program that runs concurrently with the Setup program.
EMSBlankPassword | Enables the use of a blank administrator password in unattended installations to EMS servers.
EMSSkipUnattendProcessing | Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to an EMS server.
EncryptedAdminPassword | Enables Setup to install encrypted passwords for the Administrator account.
OEMSkipRegional | Enables unattended Setup to skip the Regional and Language Options page in GUI-mode Setup and Mini-Setup.
OEMSkipWelcome | Enables unattended Setup to skip the Welcome page in GUI-mode Setup and Mini-Setup.
ProfilesDir | Specifies the location of Microsoft® Windows® XP or Windows Server 2003 family profiles.
ServerWelcome | Specifies whether to install the Web UI for Remote Administration at first logon on a member of the Windows Server 2003 family.
TimeZone | Specifies the time zone of the computer.

Sample

This sample demonstrates one use of the [GuiUnattended] section of Unattend.txt.

[GuiUnattended]
AdminPassword = "YhJ##3"
Arguments = /n/s
AutoLogon = Yes
AutoLogonCount = 5
DetachedProgram = "%SYSTEMDRIVE%\extras\install.exe"
EMSBlankPassword = Yes
EMSSkipUnattendProcessing = 1
EncryptedAdminPassword = Yes
OEMSkipRegional = 0
OEMSkipWelcome = 0
OEMPreinstall = Yes
ProfilesDir = "%SYSTEMROOT%\Profiles"
ServerWelcome = Yes
TimeZone = 030

AdminPassword

Sets the Administrator account password.

Syntax AdminPassword = "password" | *
Values password

The password may contain as many as 127 characters. Passwords are case-sensitive and must be enclosed in quotation marks. End users cannot change or specify their own passwords in Mini-Setup. You can enter a new password in the appropriate dialog box, but the password does not change.

*

The administrator password is blank (null).
Example
AdminPassword = "YhJ##3"
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\WinLogon\DefaultPassword
Dependencies If AdminPassword is set to blank, null, or not set, the registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\
CurrentVersion\WinLogon\AutoAdminLogon (controlled by the AutoLogon entry) is set to 0 (false), which disables the automatic Administrator account logon feature.
Comments If you specify a password in the Administrator account, you cannot use the AdminPassword entry in the Sysprep.inf file to change it; the administrator password remains the same. However, if the administrator password was initially blank (either manually or through unattended Setup), you can use AdminPassword to change it to a non-blank password.

Important

  • Security breaches can occur if you use a common, non-blank administrator password for all computers provided to end users. We recommend that you use an automation process to set the administrator password to blank before you run Sysprep. End users can then specify their own passwords after receiving the computers.
  • In an unattended installation, Windows Setup will force any password string that begins with an asterisk to null.

Return to top

Arguments

Indicates that arguments or entries accompany the custom program that runs concurrently with the Setup program.

Syntax | Arguments = string
Value | string
Example
Arguments = /n/s
Comments | This entry is required if you are using DetachedProgram.

Return to top

AutoLogon

Configures the computer to log on once with the Administrator account.

Syntax | AutoLogon = Yes | No
Values Yes

Configures the computer to log on once with the Administrator account.

No

Does not automatically log on to the computer.
Default Value | No
Example
AutoLogon = Yes
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\
CurrentVersion\WinLogon\AutoAdminLogon
Dependencies If AdminPassword is set to blank, null, or not set, the registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\
CurrentVersion\WinLogon\AutoAdminLogon (controlled by AutoLogon) is set to 0 (false) which disables the automatic Administrator account logon feature.
Comments The entry is not valid on upgrades.

When you set AutoLogon to Yes, you cannot log off. If you try to log off, you will be logged back on automatically. The only way to log off is to reboot, which decrements the value of AutoLogonCount.

If you specify a password in the AdminPassword entry, Setup uses that password when you log on automatically to the computer. After the installation finishes, Setup deletes the password from the copy of the answer file left on the computer.

Important

  • Encrypting the Administrator password in the EncryptedAdminPassword entry disables AutoLogon.
  • To skip Windows Welcome, set UnattendSwitch to Yes in the [Unattended] section of Unattend.txt.
  • If you wish to log on automatically after running Sysprep in Factory mode, set AuditAdminAutoLogon to Yes in the [ComputerSettings] section of Winbom.ini.

Return to top

AutoLogonCount

Specifies the number of times that the computer automatically logs on with the specified Administrator account and password.

Syntax | AutoLogonCount = integer
Value | integer
Example
AutoLogonCount = 5
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\WinLogon\AutoLogonCount
Comments The value decrements after each logon, and WinLogon disables the feature after the specified number of logon attempts.

Requires AutoLogon = Yes and AdminPassword = password in Unattend.txt. If AutoLogon = Yes, WinLogon checks the value of AutoLogonCount. If the number for AutoLogonCount is greater than 0, WinLogon decrements the count and then checks AdminPassword. If AdminPassword = password, WinLogon uses this password to log on automatically. If AdminPassword = *, the user must enter a password.

If AutoLogonCount = 0, then WinLogon deletes AutoAdminLogon, AutoLogonCount, and DefaultPassword from the registry. During the next reboot, the user must log on manually.

Important

  • The function of this entry has changed slightly between Windows 2000 and Windows XP. Please review this entry carefully before using it in your answer file.
  • Make sure that the password for the master installation (that you plan to duplicate onto one or more destination computers) is blank.
  • You must reboot the computer to decrement the value of AutoLogonCount.

Return to top

DetachedProgram

Indicates the path of the custom program that runs concurrently with the Setup program.

Syntax | DetachedProgram = detached_program_string
Value | detached_program_string
Example
DetachedProgram = "%SYSTEMDRIVE%\extras\install.exe"
Comments | If the program requires any arguments, you must specify them in the Arguments entry.

Return to top

EMSBlankPassword

Enables the use of a blank administrator password in unattended installations to EMS servers.

Syntax | EMSBlankPassword = Yes | No
Values Yes

Enables the use of "*" with AdminPassword when preinstalling to EMS servers.

No

Disables the use of "*" with AdminPassword when preinstalling to EMS servers.
Default Value | No
Example
EMSBlankPassword = Yes
Comments | Applies only to the Windows Server 2003 family. By default, blank administrator passwords (AdminPassword = "*") are not allowed in unattended installations of any member of the Windows Server 2003 family to EMS servers.

Return to top

EMSSkipUnattendProcessing

Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to an EMS server.

Syntax | EMSSkipUnattendProcessing = 0 | 1
Values 0

Does not prevent Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to an EMS server.

1

Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to an EMS server.
Default Value | 0
Example
EMSSkipUnattendProcessing = 0
Comments | Applies only to the Windows Server 2003 family.

Return to top

EncryptedAdminPassword

Enables Setup to install encrypted passwords for the Administrator account.

Syntax | EncryptedAdminPassword = Yes | No
Values Yes

Instructs Setup to install the encrypted Administrator account password.

No

Instructs Setup to keep the Administrator account password as clean text.
Default Value | No
Example
EncryptedAdminPassword = Yes
Comments To encrypt your Administrator passwords, use Setup Manager on the Windows OPK CD (in Tools) and in Deploy.cab.

Important

  • If you use this key to install an encrypted Administrator password during an unattended installation, Setup disables Autologon.

Return to top

OEMSkipRegional

Enables unattended Setup to skip the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

Syntax | OEMSkipRegional = 0 | 1
Values 0

Displays the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

1

Skips the Regional and Language Options page in GUI-mode Setup and Mini-Setup.
Example
OEMSkipRegional = 0
Dependency
OEMPreinstall = Yes
Comments | If, in the [Unattended] section, you set OemPreinstall to Yes and provide values for the [RegionalSettings] section, set the value of the OEMSkipRegional entry equal to 1 to ensure that Setup completes without prompting the end user for regional information.

Return to top

OEMSkipWelcome

Enables unattended Setup to skip the Welcome page in GUI-mode Setup and Mini-Setup.

Syntax OEMSkipWelcome = 0 | 1
Values 0

Displays the Welcome page in GUI-mode Setup and Mini-Setup.

1

Skips the Welcome page in GUI-mode Setup and Mini-Setup.
Example
OEMSkipWelcome = 0
Dependency
OEMPreinstall = Yes
Comments

Important

  • If OemPreinstall in the [Unattended] section of Unattend.txt is set to Yes, unattended Setup automatically stops on the Welcome page. To avoid this pause in your factory or testing environment, set OEMSkipWelcome = 1. Do not ship any computer with OEMSkipWelcome = 1. Instead, change OEMSkipWelcome in the [GuiUnattended] section of Sysprep.inf to 0 before delivering the computer to the customer.

Return to top

ProfilesDir

Specifies the location of Windows XP or Windows Server 2003 family profiles.

Syntax | ProfilesDir = path_to_profile_folder
Value | path_to_profile_folder
Default Value | "%SYSTEMDRIVE%\Documents and Settings"
Example
ProfilesDir = "%SYSTEMROOT%\Profiles"
Comments This entry is useful if you require new installations to use the same profile folder as Windows NT 4.0 or Windows 2000. This entry is valid only on clean installations of Windows XP or Windows Server 2003 family. Setup ignores this entry during upgrades.

The specified directory can contain an environment variable such as %SYSTEMDRIVE% or %SYSTEMROOT%. Enclose path_to_profile_folder in quotation marks if it is a long file name or if it contains an environment variable.

Return to top

ServerWelcome

Specifies whether to install the Web UI for Remote Administration at first logon on a member of the Windows Server 2003 family.

Syntax | ServerWelcome = Yes | No
Value | Yes | No
Default Value | Yes
Example
ServerWelcome = Yes
Comments On the Windows Server 2003, Web Edition, if this entry is set to Yes, then on first logon, Sasetup.msi will be run from the hard drive, the Web UI for Web server administration will be added to the Startup program group for the Administrator account, and the Web UI will be launched.

On Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition, Microsoft Small Business Server, and Windows Server 2003, Datacenter Edition, if this entry is set to Yes, then the Configure Your Server wizard will be run on first user logon. If this parameter is set to No, then the Configure Your Server Wizard will not be run.

This parameter will not be utilized during a Sysprep (Sysprep.inf) installation.

Return to top

TimeZone

Specifies the time zone of the computer.

Syntax TimeZone = index
Value index

Index values corresponding to each time zone - Click here to see a table listing the numeric values corresponding to the time zones.

This table lists the numeric values corresponding to the time zones.

Index | Time Zone | Display
000 | Dateline Standard Time | (GMT-12:00) International Date Line West
001 | Samoa Standard Time | (GMT-11:00) Midway Island, Samoa
002 | Hawaiian Standard Time | (GMT-10:00) Hawaii
003 | Alaskan Standard Time | (GMT-09:00) Alaska
004 | Pacific Standard Time | (GMT-08:00) Pacific Time (US and Canada); Tijuana
010 | Mountain Standard Time | (GMT-07:00) Mountain Time (US and Canada)
013 | Mexico Standard Time 2 | (GMT-07:00) Chihuahua, La Paz, Mazatlan
015 | U.S. Mountain Standard Time | (GMT-07:00) Arizona
020 | Central Standard Time | (GMT-06:00) Central Time (US and Canada)
025 | Canada Central Standard Time | (GMT-06:00) Saskatchewan
030 | Mexico Standard Time | (GMT-06:00) Guadalajara, Mexico City, Monterrey
033 | Central America Standard Time | (GMT-06:00) Central America
035 | Eastern Standard Time | (GMT-05:00) Eastern Time (US and Canada)
040 | U.S. Eastern Standard Time | (GMT-05:00) Indiana (East)
045 | S.A. Pacific Standard Time | (GMT-05:00) Bogota, Lima, Quito
050 | Atlantic Standard Time | (GMT-04:00) Atlantic Time (Canada)
055 | S.A. Western Standard Time | (GMT-04:00) Caracas, La Paz
056 | Pacific S.A. Standard Time | (GMT-04:00) Santiago
060 | Newfoundland and Labrador Standard Time | (GMT-03:30) Newfoundland and Labrador
065 | E. South America Standard Time | (GMT-03:00) Brasilia
070 | S.A. Eastern Standard Time | (GMT-03:00) Buenos Aires, Georgetown
073 | Greenland Standard Time | (GMT-03:00) Greenland
075 | Mid-Atlantic Standard Time | (GMT-02:00) Mid-Atlantic
080 | Azores Standard Time | (GMT-01:00) Azores
083 | Cape Verde Standard Time | (GMT-01:00) Cape Verde Islands
085 | GMT Standard Time | (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London
090 | Greenwich Standard Time | (GMT) Casablanca, Monrovia
095 | Central Europe Standard Time | (GMT+01:00) Belgrade, Bratislava, Budapest, Ljubljana, Prague
100 | Central European Standard Time | (GMT+01:00) Sarajevo, Skopje, Warsaw, Zagreb
105 | Romance Standard Time | (GMT+01:00) Brussels, Copenhagen, Madrid, Paris
110 | W. Europe Standard Time | (GMT+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna
113 | W. Central Africa Standard Time | (GMT+01:00) West Central Africa
115 | E. Europe Standard Time | (GMT+02:00) Bucharest
120 | Egypt Standard Time | (GMT+02:00) Cairo
125 | FLE Standard Time | (GMT+02:00) Helsinki, Kyiv, Riga, Sofia, Tallinn, Vilnius
130 | GTB Standard Time | (GMT+02:00) Athens, Istanbul, Minsk
135 | Israel Standard Time | (GMT+02:00) Jerusalem
140 | South Africa Standard Time | (GMT+02:00) Harare, Pretoria
145 | Russian Standard Time | (GMT+03:00) Moscow, St. Petersburg, Volgograd
150 | Arab Standard Time | (GMT+03:00) Kuwait, Riyadh
155 | E. Africa Standard Time | (GMT+03:00) Nairobi
158 | Arabic Standard Time | (GMT+03:00) Baghdad
160 | Iran Standard Time | (GMT+03:30) Tehran
165 | Arabian Standard Time | (GMT+04:00) Abu Dhabi, Muscat
170 | Caucasus Standard Time | (GMT+04:00) Baku, Tbilisi, Yerevan
175 | Transitional Islamic State of Afghanistan Standard Time | (GMT+04:30) Kabul
180 | Ekaterinburg Standard Time | (GMT+05:00) Ekaterinburg
185 | West Asia Standard Time | (GMT+05:00) Islamabad, Karachi, Tashkent
190 | India Standard Time | (GMT+05:30) Chennai, Kolkata, Mumbai, New Delhi
193 | Nepal Standard Time | (GMT+05:45) Kathmandu
195 | Central Asia Standard Time | (GMT+06:00) Astana, Dhaka
200 | Sri Lanka Standard Time | (GMT+06:00) Sri Jayawardenepura
201 | N. Central Asia Standard Time | (GMT+06:00) Almaty, Novosibirsk
203 | Myanmar Standard Time | (GMT+06:30) Yangon (Rangoon)
205 | S.E. Asia Standard Time | (GMT+07:00) Bangkok, Hanoi, Jakarta
207 | North Asia Standard Time | (GMT+07:00) Krasnoyarsk
210 | China Standard Time | (GMT+08:00) Beijing, Chongqing, Hong Kong SAR, Urumqi
215 | Singapore Standard Time | (GMT+08:00) Kuala Lumpur, Singapore
220 | Taipei Standard Time | (GMT+08:00) Taipei
225 | W. Australia Standard Time | (GMT+08:00) Perth
227 | North Asia East Standard Time | (GMT+08:00) Irkutsk, Ulan Bator
230 | Korea Standard Time | (GMT+09:00) Seoul
235 | Tokyo Standard Time | (GMT+09:00) Osaka, Sapporo, Tokyo
240 | Yakutsk Standard Time | (GMT+09:00) Yakutsk
245 | A.U.S. Central Standard Time | (GMT+09:30) Darwin
250 | Cen. Australia Standard Time | (GMT+09:30) Adelaide
255 | A.U.S. Eastern Standard Time | (GMT+10:00) Canberra, Melbourne, Sydney
260 | E. Australia Standard Time | (GMT+10:00) Brisbane
265 | Tasmania Standard Time | (GMT+10:00) Hobart
270 | Vladivostok Standard Time | (GMT+10:00) Vladivostok
275 | West Pacific Standard Time | (GMT+10:00) Guam, Port Moresby
280 | Central Pacific Standard Time | (GMT+11:00) Magadan, Solomon Islands, New Caledonia
285 | Fiji Islands Standard Time | (GMT+12:00) Fiji Islands, Kamchatka, Marshall Islands
290 | New Zealand Standard Time | (GMT+12:00) Auckland, Wellington
300 | Tonga Standard Time | (GMT+13:00) Nuku'alofa
Example
TimeZone = 030
Registry subkey HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Control\TimeZoneInformation\DaylightName
Comments If the entry is not present, the end user must select a time zone.

Note

  • If you do not configure a specific time zone setting, the default time zone depends on the language version of Windows that is installed. For example, in the Japanese version, the default time zone is "GMT+9 (Osaka, Sapporo, Tokyo)."

Return to top


[Homenet] (Unattend.txt)

Answer File = Unattend.txt

The [Homenet] section contains entries for installing Home Networking settings for network adapters, Internet Connection Sharing (ICS), and Windows Firewall.

Entry | Description
Bridge | Specifies the adapters to bridge together a home network.
EnableICS | Specifies whether to enable ICS.
ExternalAdapter | Specifies the adapter used for the ICS external connection, which must be one of those specified in the [NetAdapters] section of Unattend.txt.
InternalAdapter | Specifies the adapter used for the ICS internal connection, which must be one of those specified in the [NetAdapters] section of Unattend.txt.
InternetConnectionFirewall | Specifies the adapters on which the Windows Firewall must be turned on. The adapters are those identified in the [NetAdapters] section of Unattend.txt.
InternalIsBridge | Specifies whether the internal adapter is a bridge.
ShowTrayIcon | Specifies whether to enable the display of the ICS tray icon.

Sample

This sample demonstrates one use of the [Homenet] section of Unattend.txt.

[Homenet]
Bridge = MyAdapter1, MyAdapter2
EnableICS = Yes
ExternalAdapter = MyAdapter3
InternalAdapter = MyAdapter4
InternetConnectionFirewall = MyAdapter3
InternalIsBridge = No
ShowTrayIcon = Yes

Bridge

Specifies the adapters to bridge together a home network.

Syntax | Bridge = adapter1_name, adapter2_name[, adapter3_name,...]
Values | adapter1_name, adapter2_name[, adapter3_name,...]
Dependencies This section requires at least two adapters from those specified in the [NetAdapters] section of Unattend.txt.

When you bridge an adapter, you cannot specify it in InternetConnectionFirewall, InternalAdapter, or ExternalAdapter.
Example
Bridge = MyAdapter1, MyAdapter2

Return to top

EnableICS

Specifies whether to enable ICS.

Syntax | EnableICS = Yes | No
Values Yes

Enables ICS.

No

Does not enable ICS.
Default Value | No
Example
EnableICS = Yes

Return to top

ExternalAdapter

Specifies the adapter used for the ICS external connection, which must be one of those specified in the [NetAdapters] section of Unattend.txt.

Syntax | ExternalAdapter = adapter_name
Value | adapter_name
Dependencies Requires EnableICS = Yes.

Note

  • You cannot use this entry in an unattended upgrade from either Microsoft® Windows® 98 or Windows Millennium Edition to Windows XP Home Edition.
Example
ExternalAdapter = MyAdapter3

Return to top

InternalAdapter

Specifies the adapter used for the ICS internal connection, which must be one of those specified in the [NetAdapters] section of Unattend.txt.

Syntax | InternalAdapter = adapter_name
Value | adapter_name
Dependencies | Requires InternalIsBridge = No and EnableICS = Yes.
Example
InternalAdapter = MyAdapter4

Return to top

InternetConnectionFirewall

Specifies the adapters on which the Windows Firewall must be turned on. The adapters are those identified in the [NetAdapters] section of Unattend.txt.

Syntax | InternetConnectionFirewall = adapter_name[, adapter_name,...]
Values | adapter_name[, adapter_name,...]
Dependencies You cannot specify adapters with the firewall turned on in the InternalAdapter and Bridge entries.

Running Sysprep - reseal resets this entry. This entry is valid only for performing an unattended Setup that does not require Sysprep to prepare computers for end users.
Example
InternetConnectionFirewall = MyAdapter3

Return to top

InternalIsBridge

Specifies whether the internal adapter is a bridge.

Syntax | InternalIsBridge = Yes | No
Values Yes

The internal adapter is a bridge. In the Bridge entry, you must specify the adapters to bridge together a home network.

No

The internal adapter is not a bridge. The InternalAdapter entry contains the name of the adapter.
Default Value | No
Dependencies | Requires EnableICS = Yes.
Example
InternalIsBridge = No

Return to top

ShowTrayIcon

Specifies whether to enable the display of the ICS tray icon.

Syntax | ShowTrayIcon = Yes | No
Values Yes

Enables the display of the ICS tray icon.

No

Does not enable the display of the ICS tray icon.
Default Value | Yes
Dependencies | Requires EnableICS = Yes.
Example
ShowTrayIcon = Yes

Return to top


[IEHardening] (Unattend.txt and Sysprep.inf)

banner

[IEHardening]

Answer File = Unattend.txt and Sysprep.inf

When Internet Explorer Enhanced Security Configuration is enabled, it reduces the exposure of your server to potential security attacks from Web pages that do not belong to the local intranet zone or the Trusted Sites zone.

Entry | Description
LocalIntranetSites | Local intranet sites whose content you trust.
TrustedSites | Internet sites whose content you trust.

Sample

This sample demonstrates one use of the [IEHardening] section.

[IEHardening]
LocalIntranetSites = http://internal_1;http://internal_2
TrustedSites = http://microsoft.com;http://fabrikam.com

LocalIntranetSites

Local intranet sites whose content you trust.

Syntax | LocalIntranetSites = URL[;URL]...
Values URL

The URL of a trusted local Intranet site
Default Value | none
Example
LocalIntranetSites = http://internal_1;http://internal_2
Comments | This is supported only by the Windows Server 2003 family.

Return to top

TrustedSites

Internet sites whose content you trust.

Syntax | TrustedSites = URL[;URL]...
Values URL

The URL of a trusted Internet site
Default Value | none
Example
TrustedSites = http://microsoft.com;http://fabrikam.com
Comments | This is supported only by the Windows Server 2003 family.

Return to top


[IEPopupBlocker]

Answer File = Unattend.txt and Sysprep.inf

WinbomType = Factory

The [IEPopupBlocker] section contains entries for specifying the settings of the Pop-up Blocker tool.

Entry | Description
AllowedSites | Specifies the sites allowed by Pop-up Blocker.
BlockPopups | Specifies whether or not to block pop-ups.
FilterLevel | Specifies the level of Pop-up Blocker filtering.
ShowInformationBar | Specifies whether or not to show the Information Bar when pop-ups are blocked.

Sample

This sample demonstrates one use of the [IEPopupBlocker] section.

[IEPopupBlocker]
AllowedSites = www.fabrikam.com; http://www.contoso.com
BlockPopups = Yes
FilterLevel = Medium
ShowInformationBar = Yes

AllowedSites

Specifies the sites allowed by Pop-up Blocker.

Syntax | AllowedSites = URL[; URL;...]
Value URL

The URLs of the sites allowed by Pop-up Blocker
Default | None
Example
AllowedSites = www.fabrikam.com; http://www.contoso.com

Return to top

BlockPopups

Specifies whether or not to block pop-ups.

Syntax | BlockPopups = Yes | No
Value Yes

Turns on Pop-up Blocker.

No

Turns off Pop-up Blocker.
Default | Yes
Example
BlockPopups = Yes

Return to top

FilterLevel

Specifies the level of Pop-up Blocker filtering.

Syntax | FilterLevel = High | Medium | Low
Value High

Blocks all pop-ups.

Medium

Blocks most automatic pop-ups.

Low

Allows pop-ups from secure sites.
Default | Medium
Example
FilterLevel = Medium

Return to top

ShowInformationBar

Specifies whether or not to show the Information Bar when pop-ups are blocked.

Syntax | ShowInformationBar = Yes | No
Value Yes

Shows the Information Bar.

No

Does not show the Information Bar.
Default | Yes
Example
ShowInformationBar = Yes

Return to top


[InternetServer] (Unattend.txt)

banner

[InternetServer]

Answer File = Unattend.txt

The [InternetServer] section contains entries for configuring the installation folder for Internet Information Services (IIS) components.

Requires that you set the values of the iis_common, iis_inetmgr, and iis_www entries in the [Components] section equal to On.

Entry | Description
ApplicationDependency | Specifies the Web Server Extension groups that an application depends on.
DisableWebServiceOnUpgrade | Specifies whether to keep the WWW service running on a server after an operating system upgrade.
ExtensionFile | Specifies the IIS extension files.
PathFTPRoot | Specifies the installation folder for the File Transfer Protocol (FTP) service.
PathWWWRoot | Specifies the installation folder for the World Wide Web service.
SvcManualStart | Specifies whether to start the WWW or FTP services manually on an upgrade.

Sample

This sample demonstrates one use of the [InternetServer] section of Unattend.txt.

[InternetServer]
ApplicationDependency = MyApp,ASPNET20
DisableWebServiceOnUpgrade = True
ExtensionFile = 1, C:\Directory\, 0, ASP60
PathFTPRoot = C:\Inetpub\Ftproot
PathWWWRoot = C:\Inetpub\Wwwroot
SvcManualStart = ftp

ApplicationDependency

Specifies the Web Server Extension groups that an application depends on.

Syntax | ApplicationDependency = "AppName; GroupID, GroupID..."
Values AppName

The name of the application.

GroupID

A unique text ID associated with one or more ISAPIs or CGIs required to enable the group.
Default Value | None
Example
ApplicationDependency = CommerceServer;ASP60,INDEX99
ApplicationDependency = ExchangeServer;ASP60
ApplicationDependency = MyApp,ASPNET20

Return to top

DisableWebServiceOnUpgrade

Specifies whether to keep the WWW service running on a server after an operating system upgrade.

Syntax | DisableWebServiceOnUpgrade = True | False
Values True

Keeps the WWW service running after an upgrade.

False

Keeps the WWW service from running after an upgrade.
Default Value | True
Example
DisableWebServiceOnUpgrade = True | False
Comments | For security purposes, the WWW service is turned off after an upgrade.

Return to top

ExtensionFile

Specifies the IIS extension files.

Syntax | ExtensionFile = enable, file_path[ ,ui_deletable [ ,group_id [ ,description ] ] ]
Values enable= 0 | 1

Disables (0) or enables (1) the extension file.

file_path

The path to the extension file. Can contain environment variables.

ui_deletable= 0 | 1

Disables (0) or enables (1) the ability to delete the extension file from the UI.

GroupID

A unique text ID associated with one or more ISAPIs or CGIs required to enable the group. Also used with ApplicationDependency.

description

The description of the extension file.
Default Value | none
Example
ExtensionFile = 1, C:\Directory\, 0, ASP60
Comments | Enclose file_path in double quotation marks if it is a long file name.

Return to top

PathFTPRoot

Specifies the installation folder for the FTP service.

Syntax | PathFTPRoot = path_to_FTProot
Value | path_to_FTProot
Default Value | %SYSTEMDRIVE%\Inetpub\Ftproot
Example
PathFTPRoot = C:\Inetpub\Ftproot
Comments Enclose path_to_FTProot in quotation marks if it is a long file name.

This entry is useful only if you install the FTP service.

Return to top

PathWWWRoot

Specifies the installation folder for the World Wide Web service.

Syntax | PathWWWRoot = path_to_wwwroot
Values | path_to_wwwroot
Default Value | %SYSTEMDRIVE%\Inetpub\Wwwroot
Example
PathWWWRoot = C:\Inetpub\Wwwroot
Comments Enclose path_to_wwwroot in quotation marks if it is a long file name.

This entry is useful only if you install the World Wide Web service.

Return to top

SvcManualStart

Specifies whether to start the WWW or FTP services manually on an upgrade.

Syntax | SvcManualStart = [www, ftp]
Values www

The WWW service requires a manual restart after an upgrade.

ftp

The FTP service requires a manual restart after an upgrade.
Default Value | None
Example
SvcManualStart = ftp

Return to top


[LicenseFilePrintData] (Unattend.txt, Sysprep.inf)

banner

[LicenseFilePrintData]

Answer File = Unattend.txt and Sysprep.inf

The [LicenseFilePrintData] section contains entries for installing licensing information for the Microsoft® Windows® Server 2003 family.

Entry | Description
AutoMode | Determines whether to install Windows Server, Windows Advanced Server, Limited Edition, or Windows Server 2003, Datacenter Edition, in a per-seat or a per-server license mode.
AutoUsers | Indicates the number of client licenses purchased for the server.

Sample

This sample demonstrates one use of the [LicenseFilePrintData] section of Unattend.txt.

[LicenseFilePrintData]
AutoMode = PerServer
AutoUsers = 10

AutoMode

Determines whether to install Windows Server, Windows Advanced Server, Limited Edition, or Windows Server 2003, Datacenter Edition, in a per-seat or a per-server license mode.

Syntax AutoMode = PerSeat | PerServer
Values PerSeat

Indicates that the end user purchased a client access license for each computer accessing the server.

PerServer

Indicates that the end user purchased client access licenses for each server, which allows a certain number of concurrent connections to the server.
Example
AutoMode = PerServer
Comments If AutoMode = PerServer, you must also specify the AutoUsers entry.

If the AutoMode entry is empty or missing, Setup prompts the end user to select the license mode.

Return to top

AutoUsers

Indicates the number of client licenses purchased for the server.

Syntax | AutoUsers = integer
Value | integer
Example
AutoUsers = 10
Comments This entry is valid only if AutoMode = PerServer.

Important

  • You must specify a number greater than five, otherwise the unattended Setup fails and prompts the end user to pick a value through the user interface.

Return to top


[MassStorageDrivers] (Unattend.txt)

banner

[MassStorageDrivers]

Answer File = Unattend.txt

The [MassStorageDrivers] section contains an entry for loading small computer system interface (SCSI) drivers in the Setup Loader during text-mode Setup. If this section is missing or empty, Setup attempts to detect the SCSI devices on the computer and install the corresponding retail drivers.

Entry | Description
mass_storage_driver_description | Identifies the driver to install.

Sample

This sample demonstrates one use of the [MassStorageDrivers] section of Unattend.txt.

[MassStorageDrivers]
MyDriver_1 = OEM

mass_storage_driver_description

Identifies the driver to install.

Syntax mass_storage_driver_description = Retail | OEM
Values Retail

Indicates that the driver is part of the retail Microsoft® Windows® product.

OEM

Indicates that the driver is OEM-supplied. If the value is OEM, you must also list the driver in the [OEMBootFiles] section of the Unattend.txt file.
Example
MyDriver_1 = OEM
Comments mass_storage_driver_description must match one of the strings defined in the right-hand side of the [SCSI] section of TxtSetup.sif (for a retail driver) or TxtSetup.oem (for an OEM driver). You can specify multiple instances of mass_storage_driver_description.

Important

  • Add driver entries only to the [MassStorageDrivers] and [OEMBootFiles] sections for bootable mass-storage devices. Do not include secondary mass-storage devices. Instead, add the drivers for secondary mass-storage devices to the folder specified by the OemPnPDriversPath entry in your unattended Setup answer file. Including drivers for non-bootable mass-storage devices in the [MassStorageDrivers] or [OEMBootFiles] sections causes an error during Setup.

Return to top


[Networking] (Unattend.txt, Sysprep.inf)

banner

[Networking]

Answer File = Unattend.txt and Sysprep.inf

The [Networking] section contains no entries. However, to configure network protocols in unattended Setup or to use Sysprep, you must include the [Networking] section name in your answer file.

Important

  • Because of Plug-and-Play limitations when installing network adapters, you cannot use this section in Sysprep.inf to configure more than one network adapter. The additional adapters will assume the default networking settings.

To configure network settings, you must include one or more of the following sections:

  • [adapter_specific_protocol_section]
  • [Identification]
  • [MS_AppleTalk parameters]
  • [MS_ATMArps parameters]
  • [MS_ATMLANE parameters]
  • [MS_ATMUni parameters]
  • [MS_L2TP parameters]
  • [MS_MSClient parameters]
  • [MS_NetMon parameters]
  • [MS_NWClient parameters]
  • [MS_NWIPX parameters]
  • [MS_NwSapAgent parameters]
  • [MS_PPTP parameters]
  • [MS_Psched parameters]
  • [MS_RAS parameters]
  • [MS_RasSrv parameters]
  • [MS_Server parameters]
  • [MS_TCPIP parameters]
  • [MS_WLBS parameters]
  • [NetAdapters]
  • [NetBindings]
  • [NetClients]
  • [NetOptionalComponents]
  • [NetProtocols]
  • [NetServices]
  • [Networking]
  • [params.adapter instance]
  • [protocol parameters section]


[adapter_specific_protocol_section] (Unattend.txt)

banner

[adapter_specific_protocol_section]

Answer File = Unattend.txt and Sysprep.inf

The [adapter_specific_protocol_section] section contains an entry for specifying the network component.

Entry | Description
SpecificTo | Specifies the name of a network component on the computer.

Sample

This sample demonstrates one use of the [adapter_specific_protocol_section] section of Unattend.txt.

[adapter_specific_protocol_section]
SpecificTo = Adapter1

SpecificTo

Specifies the name of a network component on the computer.

Syntax | SpecificTo = network_component_name
Value | network_component_name
Example
SpecificTo = Adapter1
Comments

If the SpecificTo entry is not present, the entries in the section are global to the network protocol that you configure during Setup.

If you specify an entry that is in both the [Protocol] section and this section, Setup ignores entries specified in this section.

Return to top


[Identification] (Unattend.txt, Sysprep.inf)

banner

[Identification]

Answer File = Unattend.txt and Sysprep.inf

The [Identification] section contains entries for specifiying the network identification of a computer. If these entries are not present, Setup adds the computer to the default workgroup. If there is not enough information for this entry, Setup prompts the end user to provide this information.

Entry | Description
DomainAdmin | Specifies the name of the user account in the domain that has permission to create a computer account in that domain
DomainAdminPassword | Specifies the password of the user account as defined by the DomainAdmin entry.
JoinDomain | Specifies the name of the domain in which the computer participates.
JoinWorkgroup | Specifies the name of the workgroup in which the computer participates.
MachineObjectOU | Specifies the full Lightweight Directory Access Protocol (LDAP) path name of the organizational unit (OU) in which the computer belongs.

Sample

This sample demonstrates one use of the [Identification] section of Unattend.txt.

[Identification]
DomainAdmin = PatC
DomainAdminPassword = "abcdef123"
JoinDomain = MYDOMAIN
JoinWorkgroup = MYUSERGROUP
MachineObjectOU = "OU = myou,OU = myparentou,DC = mydom,DC = mycompany,DC = com"

DomainAdmin

Specifies the name of the user account in the domain that has permission to create a computer account in that domain.

Syntax | DomainAdmin = account_name
Value | account_name
Dependencies | This entry is required if you set a value for JoinDomain, even though the computer account might already exist on the domain.
Example
DomainAdmin = PatC
Comments | For deployment, use an account with limited privileges that can only create computer accounts and join them to the domain. Alternatively, use the Visual Basic Script described in JoinDomain.

Return to top

DomainAdminPassword

Specifies the password of the user account as defined by the DomainAdmin entry.

Syntax | DomainAdminPassword = "password_of_user_account"
Value | password_of_user_account
Dependencies | This entry is required if you set a value for JoinDomain, even though the computer account might already exist on the domain.
Example
DomainAdminPassword = "abcdef123"
Comments

Important

  • The password is deleted from the $winnt$.inf file, which is a copy of the original Unattend.txt file left on the computer after Setup completes. However, using JoinDomain, DomainAdmin, and DomainAdminPassword to join the computer to the domain is still a potential security issue because the password is in plain text. If anyone has access to the original Unattend.txt or Sysprep.inf file, they can use that password to access your network.

    Instead, the recommended best practice is to use Active Directory Services Interface (ADSI) and Windows Script Host (WSH) to create a Visual Basic Script (VBScript) that automates the creation of computer accounts. A sample script is given in the Microsoft Knowledge Base, article Q315273 (http://support.microsoft.com/default.aspx?scid=kb;en-us;q315273).

Return to top

JoinDomain

Specifies the name of the domain in which the computer participates.

Syntax | JoinDomain = domain_name
Value | domain_name
Example
JoinDomain = MYDOMAIN
Comments You can specify either this entry or the JoinWorkgroup entry, but you cannot specify both.

Important

  • Use an account with limited privileges that can only create computer accounts and join them to the domain.
  • Otherwise, instead of using JoinDomain, the recommended best practice is to use Active Directory Services Interface (ADSI) and Windows Script Host (WSH) to create a Visual Basic Script (VBScript) that automates the creation of computer accounts. A sample script is given in the Microsoft Knowledge Base, article Q315273 (http://support.microsoft.com/default.aspx?scid=kb;en-us;q315273).

Return to top

JoinWorkgroup

Specifies the name of the workgroup in which the computer participates.

Syntax | JoinWorkgroup = workgroup_name
Value | workgroup_name
Example
JoinWorkgroup = MYUSERGROUP
Comments | You can specify either this entry or the JoinDomain entry, but you cannot specify both.

Return to top

MachineObjectOU

Specifies the full Lightweight Directory Access Protocol (LDAP) path name of the organizational unit (OU) in which the computer belongs.

Syntax | MachineObjectOU = DNS_name, LDAP_path
Values | DNS_name, LDAP_path
Example
MachineObjectOU = "OU = myou,OU = myparentou,DC = mydom,DC = mycompany,DC = com"

Return to top


[MS_AppleTalk parameters] (Unattend.txt)

banner

[MS_AppleTalk parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_AppleTalk parameters] section contains entries for configuring AppleTalk.

Entry | Description
DefaultPort | Specifies the network on which you register the Services for Macintosh (SFM) service names.
DefaultZone | Specifies the default zone for the network if the network adapter is seeding the network.
DesiredZone | Specifies the zone in which the SFM service is present.
EnableRouter | Specifies whether to start routing for the AppleTalk protocol on this computer.
NetworkRangeLowerEnd | Specifies the lower network number of the network range if the network adapter is seeding the network.
NetworkRangeUpperEnd | Specifies the upper network number of the network range if the network adapter is seeding the network.
SeedingNetwork | Specifies whether the computer is a seed router for a physical AppleTalk network segment.
ZoneList | Specifies the list of zones with which to seed the network.

Sample

This sample demonstrates one use of the [MS_AppleTalk parameters] section of Unattend.txt.

[MS_AppleTalk parameters]
DefaultPort = PCI\VEN_10B7&DEV_5900\1&5070
DefaultZone = Zone2
DesiredZone = Zone1
EnableRouter = No
NetworkRangeLowerEnd = 3
NetworkRangeUpperEnd = 33
SeedingNetwork = 1
ZoneList = Zone1, Zone2

DefaultPort

Specifies the network adapter on which you register the Services for Macintosh (SFM) service names.

Syntax | DefaultPort = adapter name
Value | adapter name
Example
DefaultPort = PCI\VEN_10B7&DEV_5900\1&5070
Comments | If the AppleTalk protocol is not routing, only Macintosh workstations connected to this network adapter can access the file and print services on the computer. Normally, the default port is automatically set to the first Ethernet adapter, Token Ring adapter, or LocalTalk adapter found on the computer (in that order).

Return to top

DefaultZone

Specifies the default zone for the network if the network adapter is seeding the network.

Syntax | DefaultZone = zone name
Value | zone name
Example
DefaultZone = Zone2

Return to top

DesiredZone

Specifies the zone in which the SFM service is present.

Syntax DesiredZone = zone name
Value zone name

If this value is not set, the SFM service for the default zone on that network is used.
Example
DesiredZone = Zone1

Return to top

EnableRouter

Specifies whether to start routing for the AppleTalk protocol on this computer.

Syntax EnableRouter = Yes | No
Values Yes

Starts routing for the AppleTalk protocol.

No

Does not start routing for the AppleTalk protocol.
Example
EnableRouter = No
Comments If routing starts, Macintosh workstations connected to any networks that the computer is on can use the file and print servers for Macintosh.

Important

  • The remaining parameters in this section are network adapter-specific. Therefore, you can use them only in an [MS_AppleTalk parameters] section where you specify the SpecificTo parameter. For more information, see SpecificTo in the section on [adapter_specific_protocol_section].

Return to top

NetworkRangeLowerEnd

Specifies the lower network number of the network range if the network adapter is seeding the network.

Syntax | NetworkRangeLowerEnd = integer from 1 to 65279
Value | integer from 1 to 65279
Example
NetworkRangeLowerEnd = 3

Return to top

NetworkRangeUpperEnd

Specifies the upper network number of the network range if the network adapter is seeding the network.

Syntax | NetworkRangeUpperEnd = integer from 1 to 65279
Value | integer from 1 to 65279
Example
NetworkRangeUpperEnd = 33

Return to top

SeedingNetwork

Specifies whether the computer is a seed router for a physical AppleTalk network segment.

Syntax | SeedingNetwork = 0 | 1
Values 0

Does not seed the network and ignores seeding information.

1

Reads all seeding information and seeds the network to provide the network address to clients, servers, or other routers on the AppleTalk network.
Default Value | 0
Example
SeedingNetwork = 1
Comments

Important

  • When specifying SeedingNetwork = 0 for a computer acting as a router on an AppleTalk network, you must supply another router that seeds the network in order to start the first router.

Return to top

ZoneList

Specifies the list of zones with which to seed the network.

Syntax | ZoneList = zone name[, zone name, ...]
Values | zone name[, zone name, ...]
Example
ZoneList = Zone1, Zone2
Comments | This entry is valid only if the network adapter is seeding the network.

Return to top


[MS_ATMArps parameters] (Unattend.txt)

banner

[MS_ATMArps parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_ATMArps parameters] section does not require any parameters.


[MS_ATMLANE parameters] (Unattend.txt)

banner

[MS_ATMLANE parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_ATMLANE parameters] section does not require any parameters.


[MS_ATMUni parameters] (Unattend.txt)

banner

[MS_ATMUni parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_ATMUni parameters] section does not require any parameters.


[MS_L2TP parameters] (Unattend.txt)

banner

[MS_L2TP parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_L2TP parameters] section contains parameters for the L2TP (Layer 2 Tunneling Protocol).

Entry | Description
WanEndpoints | Specifies the maximum number of virtual private network ports available to the L2TP.

Sample

This sample demonstrates one use of the [MS_L2TP parameters] section of Unattend.txt.

[MS_L2TP parameters]
WanEndpoints = 3

WanEndpoints

Specifies the maximum number of virtual private network ports available to the L2TP.

Syntax | WanEndpoints = integer_value_from_0_to_30000
Value | integer_value_from_0_to_30000
Default Value | 5
Example
WanEndpoints = 3
Comments | Valid only for the Microsoft® Windows® Server 2003 family.

Return to top


[MS_MSClient parameters] (Unattend.txt)

banner

[MS_MSClient parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_MSClient parameters] section contains client parameters for Client for Microsoft Networks.

Entry | Description
BrowseDomains | Specifies a list of domains that the computer can browse.
NameServiceNetworkAddress | Specifies the network address of the name service provider.
NameServiceProtocol | Specifies the protocols that the name service uses.

Sample

This sample demonstrates one use of the [MS_MSClient parameters] section of Unattend.txt.

[MS_MSClient parameters]
BrowseDomains = Sales, Research
NameServiceNetworkAddress = 193.1.1.1
NameServiceProtocol = ncacn_np

BrowseDomains

Specifies a list of domains that the computer can browse.

Syntax | BrowseDomains = domain name [, domain name[, ...]]
Values | domain name [, domain name[, ...]]
Example
BrowseDomains = Sales, Research
Comments | Valid only for the Microsoft® Windows® Server 2003 family.

Return to top

NameServiceNetworkAddress

Specifies the network address of the name service provider.

Syntax | NameServiceNetworkAddress = IP address
Value | IP address
Example
NameServiceNetworkAddress = 193.1.1.1
Comments | Requires NameServiceProtocol = ncacn_ip_tcp.

Return to top

NameServiceProtocol

Specifies the protocols that the name service uses.

Syntax NameServiceProtocol = ncacn_np
ncacn_ip_tcp
Values ncacn_np
ncacn_ip_tcp
Example
NameServiceProtocol = ncacn_np

Return to top


[MS_NetMon parameters] (Unattend.txt)

banner

[MS_NetMon parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_NetMon parameters] section does not require any parameters.


[MS_NWClient parameters] (Unattend.txt)

banner

[MS_NWClient parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_NWClient parameters] section contains parameters for Client Service for NetWare.

Important

  • Microsoft® Windows® XP Professional and the Windows Server 2003 family support the NetWare client, but Windows XP Home Edition does not support it.
Entry | Description
DefaultContext | Specifies the default logon context.
DefaultTree | Specifies the name of the preferred tree.
LogonScript | Specifies whether to execute a logon script.
PreferredServer | Specifies the name of the preferred server.

Sample

This sample demonstrates one use of the [MS_NWClient parameters] section of Unattend.txt.

[MS_NWClient parameters]
DefaultContext = SALES.NWSERVER1
DefaultTree = NDSSERVER
LogonScript = No
PreferredServer = NWSERVER1

DefaultContext

Specifies the default logon context.

Syntax | DefaultContext = NetWare context name
Value | NetWare context name
Example
DefaultContext = SALES.NWSERVER1

Return to top

DefaultTree

Specifies the name of the preferred tree.

Syntax | DefaultTree = tree name
Value | tree name
Example
DefaultTree = NDSSERVER

Return to top

LogonScript

Specifies whether to execute a logon script.

Syntax LogonScript = Yes | No
Values Yes

Executes a logon script.

No

Does not execute a logon script.
Example
LogonScript = No

Return to top

PreferredServer

Specifies the name of the preferred server.

Syntax | PreferredServer = server name
Value | server name
Example
PreferredServer = NWSERVER1
Comments | This parameter and the DefaultTree and DefaultContext parameters are mutually exclusive.

Return to top


[MS_NWIPX parameters] (Unattend.txt)

banner

[MS_NWIPX parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_NWIPX parameters] section contains parameters for the Internetwork Packet Exchange (IPX) protocol. The following parameters are network adapter–independent.

Important

  • The IPX protocol is valid only on 32-bit platforms.
Entry | Description
DedicatedRouter | Specifies whether to install the computer as a dedicated router and indicates that the computer does not run other network services.
EnableWANRouter | Specifies whether to enable the Routing Information Protocol (RIP) router.
NetworkNumber | Specifies the network number.
PktType | Specifies the packet type/form to use for the IPX protocol.
VirtualNetworkNumber | Specifies the internal network number for configuring the IPX protocol.

Sample

This sample demonstrates one use of the [MS_NWIPX parameters] section of Unattend.txt.

[MS_NWIPX parameters]
DedicatedRouter = No
EnableWANRouter = No
NetworkNumber = 0x1234
PktType = FF
VirtualNetworkNumber = 0

DedicatedRouter

Specifies whether to install the computer as a dedicated router and indicates that the computer does not run other network services.

Syntax | DedicatedRouter = Yes | No
Values Yes

The computer is a dedicated router.

No

The computer may be running other network services, in addition to serving as a router.
Default Value | No
Example
DedicatedRouter = No

Return to top

EnableWANRouter

Specifies whether to enable the Routing Information Protocol (RIP) router.

Syntax | EnableWANRouter = Yes | No
Values Yes

Enables the RIP router.

No

Does not enable the RIP router.
Default Value | Yes
Example
EnableWANRouter = No

Return to top

NetworkNumber

Specifies the network number.

Syntax | NetworkNumber = hexadecimal_number
Value | hexadecimal_number
Default Value | 0
Example
NetworkNumber = 0x1234
Comments

Important

  • This parameter is network adapter–specific. Therefore, you must use it only in an IPX section containing parameters where you specify the SpecificTo entry. For more information, see SpecificTo in the [adapter_specific_protocol_section] section.

Return to top

PktType

Specifies the packet type/form to use for the IPX protocol.

Syntax | PktType = 0 | 1 | 2 | 3 | FF
Values 0

Packet type: Ethernet_II

Adapter type: Ethernet

1

Packet type: Ethernet_802.3

Adapter type: Ethernet

2

Packet type: 802.2

Adapter type: Ethernet, Token Ring, FDDI

3

Packet type: SNAP

Adapter type: Ethernet, Token Ring, FDDI

FF

Packet type: Auto-detect

Adapter type: Ethernet, Token Ring, FDDI
Default Value | FF
Example
PktType = FF
Comments

Important

  • This parameter is network adapter–specific. Therefore, you must use it only in an IPX section containing parameters where you specify the SpecificTo entry. For more information, see SpecificTo in the [adapter_specific_protocol_section] section.

Return to top

VirtualNetworkNumber

Specifies the internal network number for configuring the IPX protocol.

Syntax | VirtualNetworkNumber = hexadecimal_number
Value | hexadecimal_number
Default Value | 0
Example
VirtualNetworkNumber = 0

Return to top


[MS_NwSapAgent parameters] (Unattend.txt)

banner

[MS_NwSapAgent parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_NwSapAgent parameters] section does not require any parameters.


[MS_PPTP parameters] (Unattend.txt)

banner

[MS_PPTP parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_PPTP parameters] section contains parameters for the Point-to-Point Tunneling Protocol (PPTP).

Entry | Description
NumberLineDevices | Specifies the number of virtual private networks that PPTP supports.

Sample

This sample demonstrates one use of the [MS_PPTP parameters] section of Unattend.txt.

[MS_PPTP parameters]
NumberLineDevices = 10

NumberLineDevices

Specifies the number of virtual private networks that PPTP supports.

Syntax | NumberLineDevices = integer_value_from_0_to_16384
Value | integer_value_from_0_to_16384
Default Value | 5
Example
NumberLineDevices = 10
Comments | Valid only for the Microsoft® Windows® Server 2003 family.

Return to top


[MS_Psched parameters] (Unattend.txt)

banner

[MS_Psched parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_Psched parameters] section does not require any parameters.


[MS_RAS parameters] (Unattend.txt)

banner

[MS_RAS parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_RAS parameters] section contains parameters for Routing and Remote Access Service for remote access servers.

Requires RouterType.

Entry | Description
AssignSameNetworkNumber | Specifies whether to assign the same network number to all clients.
AutomaticNetworkNumbers | Specifies whether to allocate the network numbers parameter automatically.
ClientCanRequestIPAddress | Specifies whether a Transmission Control Protocol/Internet Protocol (TCP/IP) client can request a specific IP address.
ClientsCanRequestIpxNodeNumber | Specifies whether a client can request an Internetwork Packet Exchange (IPX) node number.
DialinProtocols | Specifies the protocols that support incoming connections.
IpAddressEnd | Specifies the ending IP address that Setup uses when assigning addresses to clients.
IpAddressStart | Specifies the beginning IP address that Setup uses when assigning addresses to clients.
IPXClientAccess | Specifies the access scope of an IPX client.
Multilink | Specifies whether to enable multilinking of modems for increased bandwidth.
NetworkNumberFrom | Specifies the start address of allowed IPX network numbers.
RouterType | Specifies how to configure the Routing and Remote Access Service.
TcpIpClientAccess | Specifies the access scope of an TCP/IP client.
UseDHCP | Specifies whether Dynamic Host Configuration Protocol (DHCP) assigns IP addresses to TCP/IP clients.

Sample

This sample demonstrates one use of the [MS_RAS parameters] section of Unattend.txt.

[MS_RAS parameters]
AssignSameNetworkNumber = No
AutomaticNetworkNumbers = No
ClientCanRequestIPAddress = Yes
ClientsCanRequestIpxNodeNumber = Yes
DialinProtocols = IPX,TCP/IP
IpAddressEnd = 193.1.1.200
IpAddressStart = 193.1.1.100
IPXClientAccess = ThisComputer
Multilink = No
NetworkNumberFrom = 0x000005ab
RouterType = 3
TcpIpClientAccess = ThisComputer
UseDHCP = Yes

AssignSameNetworkNumber

Specifies whether to assign the same network number to all clients.

Syntax | AssignSameNetworkNumber = Yes | No
Values Yes

Assigns the same network number to all clients.

No

Does not assign the same network number to all clients.
Default Value | Yes
Example
AssignSameNetworkNumber = No

Return to top

AutomaticNetworkNumbers

Specifies whether to allocate the network numbers parameter automatically.

Syntax | AutomaticNetworkNumbers = Yes | No
Values Yes

Automatically allocates network numbers.

No

Does not automatically allocate network numbers.
Default Value | Yes
Example
AutomaticNetworkNumbers = No
Comments | If AutomaticNetworkNumbers = No, then you must provide a value for the NetworkNumberFrom entry.

Return to top

ClientCanRequestIPAddress

Specifies whether a Transmission Control Protocol/Internet Protocol (TCP/IP) client can request a specific IP address.

Syntax | ClientCanRequestIPAddress = Yes | No
Values Yes

Specifies that a TCP/IP client can request a specific IP address.

No

A TCP/IP client cannot request a specific IP address.
Default Value | No
Example
ClientCanRequestIPAddress = Yes

Return to top

ClientsCanRequestIpxNodeNumber

Specifies whether a client can request an Internetwork Packet Exchange (IPX) node number.

Syntax | ClientsCanRequestIpxNodeNumber = Yes | No
Values Yes

A client can request an IPX node number.

No

A client cannot request an IPX node number.
Default Value | No
Example
ClientsCanRequestIpxNodeNumber = Yes
Comments | For 32-bit platforms only.

Return to top

DialinProtocols

Specifies the protocols that support incoming connections.

Syntax DialinProtocols = All | TCP/IP | IPX | AppleTalk
Values All

Indicates all installed protocols on the computer.

TCP/IP

Indicates the TCP/IP protocol.

IPX

Indicates the IPX protocol.

AppleTalk

Indicates the AppleTalk protocol.
Example
DialinProtocols = IPX,TCP/IP
Comments You can specify multiple protocols, but you must separate them with a comma.

Setup supports the IPX protocol only on 32-bit platforms.

Return to top

IpAddressEnd

Specifies the ending IP address that Setup uses when assigning addresses to clients.

Syntax | IpAddressEnd = IP_address
Value | IP_address
Example
IpAddressEnd = 193.1.1.200
Comments | Setup adds only one range of IP addresses during unattended Setup.

Return to top

IpAddressStart

Specifies the beginning IP address that Setup uses when assigning addresses to clients.

Syntax | IpAddressStart = IP_address
Value | IP_address
Example
IpAddressStart = 193.1.1.100
Comments | Setup adds only one range of IP addresses during unattended Setup.

Return to top

IPXClientAccess

Specifies the access scope of an IPX client.

Syntax | IPXClientAccess = Network | ThisComputer
Values Network

The IPX client can access the entire network.

ThisComputer

The IPX client can access only this computer.
Default Value | Network
Example
IPXClientAccess = ThisComputer
Comments Valid only if one of the values of the entry DialinProtocols is IPX.

Setup supports the IPX protocol only on 32-bit platforms.

Return to top

Multilink

Specifies whether to enable multilinking of modems for increased bandwidth.

Syntax | Multilink = Yes | No
Values Yes

Can link multiple modems together.

No

Cannot link multiple modems together.
Default Value | Yes
Example
Multilink = No
Comments | Valid only if you install multiple modems.

Return to top

NetworkNumberFrom

Specifies the start address of allowed IPX network numbers.

Syntax | NetworkNumberFrom = 0x00000001_to_0xFFFFFFFE
Values | 0x00000001_to_0xFFFFFFFE
Example
NetworkNumberFrom = 0x000005ab
Comments | Setup supports the IPX protocol only on 32-bit platforms.

Return to top

RouterType

Specifies how to configure the Routing and Remote Access Service.

Syntax RouterType = 1 | 2 | 3 | 6 | 7
Values 1

Enables remote access.

2

Enables local routing only (LAN-only router).

3

Enables remote access and local routing.

6

Enables local/remote routing (LAN and WAN routers).

7

Enables remote access and local/remote routing.

Required
Dependencies

Required for all [MS_RAS parameters] to take effect.
Valid only for the Microsoft® Windows® Server 2003 family.
Example
RouterType = 3

Return to top

TcpIpClientAccess

Specifies the access scope of an TCP/IP client.

Syntax | TcpIpClientAccess = Network | ThisComputer
Values Network

The TCP/IP client can access the entire network.

ThisComputer

The TCP/IP client can access only this computer.
Default Value | Network
Dependencies | Valid only if one of the values of the entry DialinProtocols is TCP/IP.
Example
TcpIpClientAccess = ThisComputer

Return to top

UseDHCP

Specifies whether Dynamic Host Configuration Protocol (DHCP) assigns IP addresses to TCP/IP clients.

Syntax | UseDHCP = Yes | No
Values Yes

Use DHCP to assign IP addresses to TCP/IP clients.

No

Do not use DHCP to assign IP addresses to TCP/IP clients.
Default Value | Yes
Dependencies

Important

  • If UseDHCP = No, then you must specify IpAddressStart and IpAddressEnd.
Example
UseDHCP = Yes

Return to top


[MS_RasSrv parameters] (Unattend.txt)

banner

[MS_RasSrv parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_RasSrv parameters] section contains parameters for the Routing and Remote Access Service for remote access servers.

Entry | Description
ParamsSection | Specifies the section containing the Routing and Remote Access Service parameters.

Sample

This sample demonstrates one use of the [MS_RasSrv parameters] section of Unattend.txt.

[MS_RasSrv parameters]
ParamsSection = params.MS_RAS

ParamsSection

Specifies the section containing the Routing and Remote Access Service parameters.

Syntax | ParamsSection = RAS_parameters_section
Value | RAS_parameters_section (Required.)
Example
ParamsSection = params.MS_RAS

Return to top


[MS_Server parameters] (Unattend.txt)

banner

[MS_Server parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_Server parameters] section contains parameters for the File and Print Service.

Entry | Description
BroadcastsToLanman2Clients | Specifies whether the Server service makes browser broadcasts to LAN Manager 2.x clients.
Optimization | Controls the optimization method used by the Microsoft® Windows® Server 2003 family.

Sample

This sample demonstrates one use of the [MS_Server parameters] section of Unattend.txt.

[MS_Server parameters]
BroadcastsToLanman2Clients = Yes
Optimization = Balance

BroadcastsToLanman2Clients

Specifies whether the Server service makes browser broadcasts to LAN Manager 2.x clients.

Syntax | BroadcastsToLanman2Clients = Yes | No
Values Yes

Server sends LAN Manager 2.x-compatible server announcements to announce its presence.

No

Server does not send LAN Manager 2.x-compatible server announcements.
Default Value | No
Example
BroadcastsToLanman2Clients = Yes
Comments | Valid only for the Windows Server 2003 family.

Return to top

Optimization

Controls the optimization method used by Windows Server 2003 family.

Syntax | Optimization = MinMemoryUsed | Balance | MaxThroughputForFileSharing | MaxThroughputForNetworkApps
Values MinMemoryUsed

Server uses the minimum amount of resources possible.

Balance

Server balances its resource usage for both local applications and file serving.

MaxThroughputForFileSharing

Server uses the resources necessary to optimize file sharing throughput.

MaxThroughputForNetworkApps

Server uses the resources necessary to optimize file sharing throughput, and handle requests for run-from-network applications.
Default Value | MaxThroughputForFileSharing
Example
Optimization = Balance
Comments | Valid only for the Windows Server 2003 family.

Return to top


[MS_TCPIP parameters] (Unattend.txt)

banner

[MS_TCPIP parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_TCPIP parameters] section contains parameters for configuring the Transmission Control Protocol/Internet Protocol (TCP/IP) protocol.

Important

    The TCP/IP protocol is a mandatory component of Windows and is always installed.
  • The parameters in this section are noted as being either global or adapter-specific. Global parameters apply to all network adapters on the computer. To use an adapter-specific parameter, add the SpecificTo=adapter line to that section of your answer file, as in the example.

Global Parameters

Entry | Description
DeadGWDetectDefault | Specifies whether the computer detects nonfunctional gateways.
DNSDomain | Specifies the primary Domain Name Service (DNS) suffix of the computer.
DNSSuffixSearchOrder | Specifies the search order for DNS servers.
DontAddDefaultGatewayDefault | Specifies whether the computer uses the default gateway.
EnableICMPRedirect | Specifies whether this computer uses ICMPRedirect.
EnableLMHosts | Specifies whether this computer uses LMHosts lookup.
EnableSecurity | Specifies whether to enable TCP/IP filtering.
ScopeID | Specifies the computer's scope identifier if a network that uses network basic input/output system (NetBIOS) over TCP/IP requires it.
SyncDomainWithMembership | Specifies whether to change the primary DNS suffix.
UseDomainNameDevolution | Specifies whether to enable domain name devolution when the DNS-caching resolver resolves an unqualified query.

Adapter-Specific Parameters

Entry | Description
DefaultGateway | Specifies the default gateway addresses.
DHCP | Specifies whether to use Dynamic Host Configuration Protocol (DHCP) on the network connection that uses this adapter.
DHCPClassId | Specifies the DHCP class ID.
DisableDynamicUpdate | Specifies whether to register the A and PTR records dynamically.
DNSDomain | Specifies the suffix of the network connection that uses this adapter.
DNSServerSearchOrder | Specifies a list of addresses to use when searching for the DNS server on the network.
EnableAdapterDomainNameRegistration | Specifies whether to register the DNS resource records.
IPAddress | Specifies the IP addresses for the network connection that uses this adapter.
IpAllowedProtocols | Specifies whether to enable network traffic of specific IP protocols.
NetBIOSOptions | Specifies the NetBIOS option for the network connection that uses this adapter.
SubnetMask | Specifies the subnet mask addresses.
TcpAllowedPorts | Specifies whether to enable network traffic through specific TCP ports.
UdpAllowedPorts | Specifies whether to enable network traffic through specific UDP ports.
WINS | Specifies whether to use Windows Internet Name Service (WINS) on the network connection that uses this adapter.
WINSServerList | Specifies the IP addresses of the WINS servers on the network.

Sample

This sample demonstrates one use of the [MS_TCPIP parameters] section of Unattend.txt.

[MS_TCPIP parameters]
DeadGWDetectDefault = No
DNSDomain = fabrikam.com
DNSSuffixSearchOrder = server1.fabrikam.com, fabrikam.com
DontAddDefaultGatewayDefault = No
EnableICMPRedirect = No
EnableLMHosts = Yes
EnableSecurity = Yes
ScopeID = REDMOND
SyncDomainWithMembership = 1
UseDomainNameDevolution = No

[params.MS_TCPIP.Adapter01]
SpecificTo = Adapter01
DisableDynamicUpdate = No
EnableAdapterDomainNameRegistration = No
DefaultGateway = 193.1.1.1
DHCP = Yes
DHCPClassId = abc
DNSDomain = fabrikam.com
DNSServerSearchOrder = server1.fabrikam.com, fabrikam.com
IPAddress = 193.1.1.33,193.1.1.34
IpAllowedProtocols = 10
NetBIOSOptions = 1
TcpAllowedProtocols = 10
UdpAllowedProtocols = 10
SubnetMask = 193.1.1.255
WINS = Yes
WINSServerList = 193.1.1.95,193.1.1.97

Global Parameters

DeadGWDetectDefault

Specifies whether the computer detects nonfunctional gateways.

Syntax | DeadGWDetectDefault = Yes | No
Values Yes

Detects nonfunctional gateways.

No

Does not detect nonfunctional gateways.

Global
Default Value | No
Example
DeadGWDetectDefault = No
Comments Use this entry only if the computer offers Routing and Remote Access Service of any type. If this is the case, you must set it to No.

For more information, see [MS_RAS parameters].

Return to top

DNSDomain

Specifies the primary DNS suffix of the computer.

Syntax | DNSDomain = primary_DNS_suffix
Value primary_DNS_suffix

Global
Example
DNSDomain = fabrikam.com
Comments | Requires SyncDomainWithMembership = 0.

Return to top

DNSSuffixSearchOrder

Specifies the search order for DNS servers.

Syntax DNSSuffixSearchOrder = suffix[, suffix[, ...]]
Values suffix[, suffix[, ...]]

Global
Example
DNSSuffixSearchOrder = server1.fabrikam.com, fabrikam.com

Return to top

DontAddDefaultGatewayDefault

Specifies whether the computer uses the default gateway.

Syntax | DontAddDefaultGatewayDefault = Yes | No
Values Yes

Uses the default gateway.

No

Does not use the default gateway.

Global
Default Value | Yes
Example
DontAddDefaultGatewayDefault = No
Comments Use this entry only if the computer offers Routing and Remote Access Service of any type, in which case you must set it to Yes.

For more information, see [MS_RAS parameters].

Return to top

EnableICMPRedirect

Specifies whether this computer uses ICMPRedirect.

Syntax | EnableICMPRedirect = Yes | No
Values Yes

Use ICMPRedirect.

No

Do not use ICMPRedirect.

Global
Default Value | No
Example
EnableICMPRedirect = No
Comments Use this entry only if the computer offers Routing and Remote Access Service of any type. If this is the case, you must set it to No.

For more information, see [MS_RAS parameters].

Return to top

EnableLMHosts

Specifies whether this computer uses LMHosts lookup.

Syntax | EnableLMHosts = Yes | No
Values Yes

Use LMHosts lookup.

No

Do not use LMHosts lookup.

Global
Default Value | Yes
Example
EnableLMHosts = Yes
Registry subkey HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\
NetBT\entries\EnableLMHosts
Example
EnableLMHosts = Yes

Return to top

EnableSecurity

Specifies whether to enable TCP/IP filtering.

Syntax | EnableSecurity = Yes | No
Values Yes

Enables TCP/IP filtering.

No

Does not enable TCP/IP filtering.

Global
Default Value | No
Example
EnableSecurity = No

Return to top

IpAllowedProtocols

Specifies whether to enable network traffic of specific IP protocols.

Syntax | IpAllowedProtocols = IP_protocol[,IP_protocol[, ...]]
Values IP_protocol[,IP_protocol[, ...]]

Global
Example
IpAllowedProtocols = 10
Dependencies | EnableSecurity = Yes

Return to top

ScopeID

Specifies the computer's scope identifier if a network that uses network basic input/output system (NetBIOS) over TCP/IP requires it.

Do not use a scope ID if you enable DNS on the network in which the computer participates.

Syntax ScopeID = scope_ID
Value scope_ID

Global
Example
ScopeID = REDMOND

Return to top

SyncDomainWithMembership

Specifies whether to change the primary DNS suffix.

Syntax | SyncDomainWithMembership = 0 | 1
Values 0

Does not change the primary DNS suffix.

1

Changes the primary DNS suffix value when the computer joins an Active Directory domain.

Global
Default Value | Not present
Example
SyncDomainWithMembership = 1
Comments If not present, or if nonzero, the primary DNS suffix value changes when the computer joins an Active Directory® (Microsoft® Windows® 2000 or Windows Server 2003 family) domain. The name is the DNS name of the Active Directory domain joined by the computer.

To specify a primary DNS suffix, set SyncDomainWithMembership to 0 and set DNSDomain to primary_DNS_suffix.

Return to top

TcpAllowedPorts

Specifies whether to enable network traffic through specific TCP ports.

Syntax | TcpAllowedPorts = TCP_port[,TCP_port[, ...]]
Values TCP_port[,TCP_port[, ...]]

Global
Example
TCPAllowedPorts = 10
Dependencies | EnableSecurity = Yes

Return to top

UdpAllowedPorts

Specifies whether to enable network traffic through specific UDP ports.

Syntax | UdpAllowedPorts = UDP_port[,UDP_port[, ...]]
Values UDP_port[,UDP_port[, ...]]

Global
Example
UdpAllowedPorts = 10
Dependencies | EnableSecurity = Yes

Return to top

UseDomainNameDevolution

Specifies whether to enable domain name devolution when the DNS-caching resolver resolves an unqualified query.

Syntax | UseDomainNameDevolution = Yes | No
Values Yes

Enables domain name devolution.

No

Does not enable domain name devolution.

Global
Default Value | Yes
Example
UseDomainNameDevolution = No
Comments

Important

  • The remaining parameters in this section are network adapter-specific. Only use these parameters in a TCP/IP section where you specify the SpecificTo parameter. For more information, see SpecificTo in the [adapter_specific_protocol_section] section.

Return to top

Adapter-Specific Parameters

DefaultGateway

Specifies the default gateway addresses.

Syntax DefaultGateway = gateway_address[, gateway_address[, ...]]
Values gateway_address[, gateway_address[, ...]]

Adapter-specific
Example
DefaultGateway = 193.1.1.1

Return to top

DHCP

Specifies whether to use Dynamic Host Configuration Protocol (DHCP) on the network connection that uses this adapter.

Syntax | DHCP = Yes | No
Values Yes

Uses DHCP on the network connection that uses this adapter.

No

Does not use DHCP on the network connection that uses this adapter. In this case, you must specify the IPAddress and SubnetMask entries. You may also need to specify a value for the DefaultGateway, if your network configuration requires it.

Adapter-specific
Default Value | Yes
Example
DHCP = Yes

Return to top

DHCPClassId

Specifies the DHCP class ID.

Syntax DHCPClassId = string
Value string

Adapter-specific
Example
DHCPClassId = abc

Return to top

DisableDynamicUpdate

Specifies whether to register the A and PTR records dynamically.

Syntax | DisableDynamicUpdate = Yes | No
Values Yes

Disables dynamic registration of the A and PTR records corresponding to the IP addresses of the connection.

No

Dynamically registers the A and PTR records corresponding to the IP addresses of the connection.

Adapter-specific
Default Value | Not present
Example
DisableDynamicUpdate = No
Comments If you set this option to Yes, then Setup does not dynamically register the A and PTR records corresponding to the IP addresses of this connection.

If this option does not exist or is set to No, then Setup registers A and PTR resource records containing the full DNS name of the computer and the IP addresses of this connection in the DNS. The full DNS name is a concatenation of the Computer Name and the Primary DNS Suffix of the computer, computer_name.primary_DNS_suffix.

Return to top

DNSDomain

Specifies the suffix of the network connection that uses this adapter.

Syntax DNSDomain = DNS_domain_name
Value DNS_domain_name

Adapter-specific
Example
DNSDomain = fabrikam.com

Return to top

DNSServerSearchOrder

Specifies a list of addresses to use when searching for the DNS server on the network.

Syntax DNSServerSearchOrder = server_address[, server_address [, ...]]
Values server_address[, server_address [, ...]]

Adapter-specific
Example
DNSServerSearchOrder = 193.1.1.3,193.1.1.44

Return to top

EnableAdapterDomainNameRegistration

Specifies whether to register the DNS resource records.

Syntax | EnableAdapterDomainNameRegistration = Yes | No
Values Yes

Registers the DNS resource records.

No

Does not register the DNS resource records.

Adapter-specific
Default Value | Not present
Example
EnableAdapterDomainNameRegistration = No
Comments If you set this option to Yes, and the DisableDynamicUpdate value for the same network connection does not exist or you set it to No, then the computer attempts to register the following dynamically:
  • The A and PTR resource records containing the computer name, primary DNS suffix, and the IP addresses of the connection.
  • The A and PTR resource records containing the IP addresses of the connection, and a name that is a concatenation of the computer name and the connection-specific DNS suffix.

Return to top

IPAddress

Specifies the IP addresses for the network connection that uses this adapter.

Syntax IPAddress = IP_address[, IP_address [, ...]]
Values IP_address[, IP_address [, ...]]

Adapter-specific
Example
IPAddress = 193.1.1.33,193.1.1.34
Comments If you specify more than one IP address, you must specify multiple subnet mask addresses in a one-to-one relationship.

If you specify IPAddress and SubnetMask, you must specify DHCP = No in the Unattend.txt file.

Return to top

NetBIOSOptions

Specifies the NetBIOS option for the network connection that uses this adapter.

Syntax | NetBIOSOptions = 0 | 1 | 2
Values 0

Uses NetBIOS setting from the DHCP Server.

1

Enables NetBIOS over TCP/IP.

2

Disables NetBIOS over TCP/IP.

Adapter-specific
Default Value | 0
Example
NetBIOSOptions = 1

Return to top

SubnetMask

Specifies the subnet mask addresses.

Syntax | SubnetMask = subnet_address[, subnet_address[, ...]]
Values subnet_address[, subnet_address[, ...]]

Adapter-specific
Example
SubnetMask = 193.1.1.255
Comments | If you specify IPAddress and SubnetMask, you must specify DHCP = No in the Unattend.txt file.

Return to top

WINS

Specifies whether to use Windows Internet Name Service (WINS) on the network connection that uses this adapter.

Syntax | WINS = Yes | No
Values Yes

Uses WINS on the network connection that uses this adapter.

No

Does not use WINS on the network connection that uses this adapter.

Adapter-specific
Default Value | No
Example
WINS = Yes

Return to top

WINSServerList

Specifies the IP addresses of the WINS servers on the network.

Syntax | WINSServerList = IP_address[, IP_address, …]
Values IP_address[, IP_address, …]

Adapter-specific
Dependencies | Requires WINS = Yes to apply the WINSServerList IP addresses.
Example
WINSServerList = 193.1.1.95,193.1.1.97

Return to top


[MS_WLBS parameters] (Unattend.txt)

banner

[MS_WLBS parameters]

Answer File = Unattend.txt and Sysprep.inf

The [MS_WLBS parameters] section contains parameters for configuring Network Load Balancing (formerly, Windows Load Balancing Service, or WLBS). Bind Network Load Balancing to multiple network adapters.

By default, the bindings of all networking components (except Network Load Balancing) are enabled. You can selectively disable these by using the Disable entry in the [NetBindings] section. In addition, the Enable entry in the [NetBindings] section allows for explicit binding enabling.

Important

  • All Network Load Balancing parameters are specific to individual adapters. Any section containing settings specific to an adapter must use the SpecificTo entry to declare the adapter that the parameter is specific to. See the sample for examples.

Valid only for Microsoft® Windows® Server 2003 operating systems.

Entry | Description
AliveMsgPeriod | Specifies in milliseconds a period between sending Network Load Balancing cluster heartbeat messages.
AliveMsgTolerance | Specifies the number of lost heartbeat messages before Setup considers the Network Load Balancing cluster host inactive and initiates convergence.
ClusterIPAddress | Specifies the Network Load Balancing cluster's primary Internet protocol (IP) address.
ClusterModeOnStart | Specifies whether a host joins the Network Load Balancing cluster upon startup or waits for an explicit command to do so.
ClusterName | Specifies a full Internet name for the Network Load Balancing cluster.
ClusterNetworkMask | Specifies the subnet mask for the Network Load Balancing cluster IP address.
DedicatedIPAddress | Specifies the host's unique IP address.
DedicatedNetworkMask | Specifies the subnet mask for the dedicated IP address.
DescriptorsPerAlloc | Specifies the number of connection descriptors created for each allocation.
HostPriority | Specifies the host's unique priority ID in the Network Load Balancing cluster.
IGMPSupport | Specifies whether to use IGMP (Internet Group Management Protocol) support to prevent switch flooding.
MaskSourceMAC | Specifies whether to use source Media Access Control (MAC) address masking, allowing Network Load Balancing cluster hosts to connect to different switch ports.
Master | Specifies whether the host is the master.
MaxDescriptorAllocs | Specifies the maximum number of connection descriptor allocations.
McastIPaddress | Specifies the multicast IP address for sending IGMP join messages when you enable IGMPSupport.
MulticastSupportEnable | Specifies whether to use a multicast MAC address for Network Load Balancing cluster operations.
NetmonAliveMsgs | Specifies whether Network Load Balancing forwards heartbeat messages up to the bound protocols, allowing the Network Monitor utility to capture heartbeats.
NumActions | Specifies the number of actions created for each allocation.
NumAliveMsgs | Specifies the number of heartbeat packet buffers created for each allocation.
NumPackets | Specifies the number of packets created for each allocation.
PersistedStates | Specifies whether a host that is shut down while in a suspended state will remain suspended when Windows is started.
Ports | Specifies rules for distributing traffic among Network Load Balancing cluster hosts according to protocol and destination ports.
RemoteControlEnabled | Specifies whether to enable remote-control operations.
RemoteControlPassword | Specifies a password for restricting access to the Network Load Balancing cluster from remote, networked computers running Windows and using the Wlbs.exe control program.
RemoteControlUDPPort | Specifies the remote control UDP (User Datagram Protocol) port.
ReverseHash | Specifies whether the adapter should reverse the source and destination IP addresses and ports before making load balancing decisions.
TeamID | Specifies a valid GUID that identifies a BDA (bidirectional affinity) team.

Sample

This sample demonstrates the [MS_WLBS parameters] section in the context of a complete [Networking] section that defines two adapters using static IP addresses and Network Load Balancing.

[Networking]

[Identification]
DomainAdmin = domain\user
DomainAdminPassword = password
JoinDomain = domain

;We'll have two network adapters - Adapter01 and Adapter02.
;Note: The adapter specified here as No.1 may not be
;LAN connection No.1 in the user interface.
[NetAdapters]
Adapter01 = params.Adapter01
Adapter02 = params.Adapter02

;Specify the network card used by network adapter No. 1.
[params.Adapter01]
ConnectionName = "Intel Adapter"
Netcardaddress = 0x0002A5D0510f

;Specify the network card used by network adapter No. 2.
[params.Adapter02]
ConnectionName = "3Com Adapter"
Netcardaddress = 0x000476D5F57D

;Install client for MS networks.
[NetClients]
MS_MSClient = params.MS_MSClient

[params.MS_MSClient]

;Only install TCP.
[NetProtocols]
MS_TCPIP = params.MS_TCPIP

[params.MS_TCPIP]
;TCP/IP properties
AdapterSections = params.MS_TCPIP.Adapter01,params.MS_TCPIP.Adapter02

;Card 1 using static IP address info
[params.MS_TCPIP.Adapter01]
DHCP = No
DNSServerSearchOrder = 157.5.2.2,157.5.23.13
IPAddress = 172.24.23.91
SpecificTo = Adapter01
SubnetMask = 255.255.255.0
WINS = Yes
WINSServerList = 157.5.2.22,157.5.7.5

;Card 2 using static info
[params.MS_TCPIP.Adapter02]
DefaultGateway = 157.5.4.1
DHCP = No
DNSServerSearchOrder = 157.5.2.2,157.5.23.13
IPAddress = 157.5.4.5
SpecificTo = Adapter02
SubnetMask = 255.255.252.0
WINS = Yes
WINSServerList = 157.5.2.22,157.5.7.5

[params.MS_WLBS]
AdapterSections = params.MS_WLBS.Adapter01,params.MS_WLBS.Adapter02

[params.MS_WLBS.Adapter01]
ClusterIpAddress = 157.5.4.15
ClusterModeOnStart = 1
ClusterName = nlbcluster.domain.com
ClusterNetworkMask = 255.255.252.0
DedicatedIPAddress = 172.24.23.91
DedicatedNetworkMask = 255.255.255.0
HostPriority = 1
IGMPSupport = 0
MulticastSupportEnable = 1
Ports = 1,65535,Both,Multiple,Single,Equal
RemoteControlEnabled = 1
SpecificTo = Adapter01

[params.MS_WLBS.Adapter02]
ClusterIpAddress = 157.5.4.15
ClusterModeOnStart = 1
ClusterName = nlbcluster.domain.com
ClusterNetworkMask = 255.255.252.0
DedicatedIPAddress = 157.5.4.5
DedicatedNetworkMask = 255.255.252.0
HostPriority = 1
IGMPSupport = 0
MulticastSupportEnable = 1
Ports = 1,65535,Both,Multiple,Single,Equal
RemoteControlEnabled = 1
SpecificTo = Adapter02

[NetBindings]
Disable = MS_WLBS,Adapter01
Enable = MS_WLBS,Adapter02

AliveMsgPeriod

Specifies in milliseconds a period between sending Network Load Balancing cluster heartbeat messages.

Syntax | AliveMsgPeriod = integer_between_100_and_10,000
Value | integer_between_100_and_10,000
Default Value | 1000
Example
AliveMsgPeriod = 5000

Return to top

AliveMsgTolerance

Specifies the number of lost heartbeat messages before Setup considers the Network Load Balancing cluster host inactive and initiates convergence.

Syntax | AliveMsgTolerance = integer_between_5_and_100
Value | integer_between_5_and_100
Default Value | 5
Example
AliveMsgTolerance = 50

Return to top

ClusterIPAddress

Specifies the Network Load Balancing cluster's primary IP address.

Syntax | ClusterIPAddress = IP_address
Value | IP_address
Default Value | 0.0.0.0
Example
ClusterIPAddress = 10.192.45.7
Comments | Required. This address is a virtual IP address and it must be set identically for all hosts in the Network Load Balancing cluster. If you use one alias for several IP addresses to the Network Load Balancing cluster, then you must specify only the primary (main) IP address.

Return to top

ClusterModeOnStart

Specifies whether a host joins the Network Load Balancing cluster upon startup or waits for an explicit command to do so.

Syntax | ClusterModeOnStart = 0 | 1
Values 0

Host does not join the Network Load Balancing cluster upon startup, but instead waits for an explicit command.

1

Host joins the Network Load Balancing cluster upon startup.
Default Value | 1
Example
ClusterModeOnStart = 0

Return to top

ClusterName

Specifies a full Internet name for the Network Load Balancing cluster.

Syntax | ClusterName = fully_qualified_domain_name_of_the_cluster
Values | fully_qualified_domain_name_of_the_cluster
Default Value | cluster.domain.com
Example
ClusterName = nlbcluster.domain.com

Return to top

ClusterNetworkMask

Specifies the subnet mask for the Network Load Balancing cluster IP address.

Syntax | ClusterNetworkMask = network_mask
Value | network_mask
Default Value | 0.0.0.0
Example
ClusterNetworkMask = 255.255.255.0
Comment | Required.

Return to top

DedicatedIPAddress

Specifies the host's unique IP address.

Syntax | DedicatedIPAddress = IP_address
Value | IP_address
Default Value | 0.0.0.0
Example
DedicatedIPAddress = 10.192.45.1
Comment | Required.

Return to top

DedicatedNetworkMask

Specifies the subnet mask for the dedicated IP address.

Syntax | DedicatedNetworkMask = network_mask
Value | network_mask
Default Value | 0.0.0.0
Example
DedicatedNetworkMask = 255.255.255.0
Comment | Required.

Return to top

DescriptorsPerAlloc

Specifies the number of connection descriptors created for each allocation.

Syntax | DescriptorsPerAlloc = integer_between_16_and_1024
Value | integer_between_16_and_1024
Default Value | 512
Example
DescriptorsPerAlloc = 1024
Comments | Change this value only when an event log message instructs you to do so.

Return to top

HostPriority

Specifies the host's unique priority ID in the Network Load Balancing cluster.

Syntax | HostPriority = integer_between_1_and_32
Value | integer_between_1_and_32
Default Value | 1
Example
HostPriority = 5
Comment | Required.

Return to top

IGMPSupport

Specifies whether to use IGMP (Internet Group Management Protocol) support to prevent switch flooding.

Syntax | IGMPSupport = 0 | 1
Values 0

Do not use IGMP for Network Load Balancing cluster operations.

1

Use IGMP for Network Load Balancing cluster operations.

Default Value | 0
Example
IGMPSupport = 0
Comments

Important

  • Requires MulticastSupportEnable = 1.

Return to top

MaskSourceMAC

Specifies whether to use source Media Access Control (MAC) address masking, enabling Network Load Balancing cluster hosts to connect to different switch ports.

Syntax | MaskSourceMAC = 0 | 1
Values 0

Does not use source MAC address masking. The Network Load Balancing cluster connects to a hub to re-enable learning in the upstream switch and conserve its bandwidth.

1

Uses source MAC address masking.
Default Value | 1
Example
MaskSourceMAC = 0

Return to top

Master

Specifies whether the host is the master.

Syntax Master = 0 | 1
Value 0

The host is not the master.

1

The host is the master.
Example
Master = 1

Return to top

MaxDescriptorAllocs

Specifies the maximum number of connection descriptor allocations.

Syntax | MaxDescriptorAllocs = integer_between_1_and_1024
Values | integer_between_1_and_1024
Default Value | 512
Example
MaxDescriptorAllocs = 1024
Comments | Change this value only when an event log message instructs you to do so.

Return to top

McastIPaddress

Specifies the multicast IP address for sending IGMP join messages when you enable IGMPSupport.

Syntax | McastIPaddress = IP_address
Value | IP_address
Example
McastIPaddress = 239.255.1.1
Comments | The Primary Cluster IP automatically generates the default address.

Return to top

MulticastSupportEnable

Specifies whether to use a multicast MAC address for Network Load Balancing cluster operations.

Syntax | MulticastSupportEnable = 0 | 1
Values 0

Does not use multicast MAC addresses for Network Load Balancing cluster operations.

1

Uses multicast MAC addresses for Network Load Balancing cluster operations.
Default Value | 0
Example
MulticastSupportEnable = 1

Return to top

NetmonAliveMsgs

Specifies whether Network Load Balancing forwards heartbeat messages up to the bound protocols, allowing the Network Monitor utility to capture heartbeats.

Syntax | NetmonAliveMsgs = 0 | 1
Values 0

Does not forward heartbeat messages to bound protocols.

1

Forwards heartbeat messages to bound protocols.
Default Value | 0
Example
NetmonAliveMsgs = 0

Return to top

NumActions

Specifies the number of actions created for each allocation.

Syntax | NumActions = integer_between_5_and_500
Value | integer_between_5_and_500
Default Value | 50
Example
NumActions = 100
Comments | Change this value only when an event log message instructs you to do so.

Return to top

NumAliveMsgs

Specifies the number of heartbeat packet buffers created for each allocation.

Syntax | NumAliveMsgs = integer_between_66_and_660
Value | integer_between_66_and_660
Default Value | 66
Example
NumAliveMsgs = 100
Comments | Change this value only when an event log message instructs you to do so.

Return to top

NumPackets

Specifies the number of packets created for each allocation.

Syntax | NumPackets = integer_between_5_and_500
Value | integer_between_5_and_500
Default Value | 100
Example
NumPackets = 100
Comments | Change this value only when an event log message instructs you to do so.

Return to top

PersistedStates

Specifies whether a host that is shut down while in a suspended state will remain suspended when Windows is started.

Syntax PersistedStates = 0 | 4
Value 0

Suspended state does not persist.

4

Suspended state persists.
Example
PersistedStates = 4

Return to top

Ports

Specifies rules for distributing traffic among Network Load Balancing cluster hosts according to protocol and destination ports.

Syntax

Mode entry for Multiple:
Ports = None | Single | ClassC,
Equal | integer_from_1_to_100

Mode entry for Single:
Ports = integer_from_1_to_32

Mode entry for Disabled:
Ports = None
Values integer_from_1_to_65535,integer_from_1_to_65535,
Both | TCP | UDP,Multiple | Single | Disabled,
mode entry,[...]
Default Value 1, 65535, Both, Multiple, Single, Equal
Example
Ports = 20,21,TCP,Multiple,Single,Equal,80,80,Both,Multiple, None,Equal,
443,443,Both,Multiple,Single,Equal,1024,65535,TCP, Multiple,Single,Equal
Ports = ALL,20,21,TCP,Multiple,Single,Equal,80,80,Both,Multiple, None,Equal,
443,443,Both,Multiple,Single,Equal,1024,65535,TCP, Multiple,Single,Equal
Ports = 172.31.80.178,20,21,TCP,Multiple,Single,Equal,80,80,Both,Multiple, None,Equal,
443,443,Both,Multiple,Single,Equal,1024,65535,TCP, Multiple,Single,Equal

Return to top

RemoteControlEnabled

Specifies whether to enable remote-control operations.

Syntax | RemoteControlEnabled = 0 | 1
Values 0

Does not enable remote-control operations.

1

Enables remote-control operations.
Default Value | 0
Example
RemoteControlEnabled = 1
Comments

Important

  • For security reasons, it is recommended that you place the Network Load Balancing UDP control port behind a firewall.

Return to top

RemoteControlPassword

Specifies a password for restricting access to the Network Load Balancing cluster from remote, networked computers running Windows and using the Wlbs.exe control program.

Syntax | RemoteControlPassword = password
Value | password
Default Value | NULL
Example
RemoteControlPassword = B1gCluster

Return to top

RemoteControlUDPPort

Specifies the remote control UDP port.

Syntax | RemoteControlUDPPort = integer_between_1_and_65535
Value | integer_between_1_and_65535
Default Value | 2505
Example
RemoteControlUDPPort = 1717

Return to top

ReverseHash

Specifies whether the adapter reverses the source and destination IP addresses and ports before making load balancing decisions.

Syntax ReverseHash = 0 | 1
Value 0

The adapter does not reverse the source and destination IP addresses and ports.

1

The adapter reverses the source and destination IP addresses and ports.
Example
ReverseHash = 1

Return to top

TeamID

Specifies a valid GUID that identifies a BDA (bidirectional affinity) team.

Syntax | TeamID = {GUID}
Value | {GUID}
Example
TeamID = {BF967924-0DE6-11D0-A285-00AA003049E2}

Return to top


[NetAdapters] (Unattend.txt)

banner

[NetAdapters]

Answer File = Unattend.txt and Sysprep.inf

The [NetAdapters] section specifies the network adapters to install. You must list each adapter present in the computer as an entry = value pair. Only one network adapter is configured during Sysprep, even if the Sysprep.inf file specifies configuration of multiple cards.

The entry name is user-defined and acts as an identifier for the adapter that you install.

Entry | Description
adapter_instance | Specifies a section that contains entries for the adapter under consideration.

Sample

This sample demonstrates one use of the [NetAdapters] section of Unattend.txt.

[NetAdapters]
Adapter1 = params.Adapter1

adapter_instance

Specifies a section that contains entries for the adapter under consideration.

Syntax | adapter_instance = adapter_entries_section
Value | adapter_entries_section
Default Value | user-defined
Example
Adapter1 = params.Adapter1
Comments | You must create a unique entry for each adapter.

Return to top


[NetBindings] (Unattend.txt)

banner

[NetBindings]

Answer File = Unattend.txt and Sysprep.inf

The [NetBindings] section contains entries for disabling, enabling, and demoting binding rules for network components such as services, protocols, and adapters.

You can list each entry more than once in this section, but you must list the network components that comprise the binding order/path in the following order:

network_service, network_protocol, network_adapter

The binding order/path must always start with a client/service (if one exists) and end with an adapter. Setup ignores incorrectly specified binding orders/paths. If you list more than one item, then separate the values with commas and enclose the entire string of values in quotation marks.

Important

  • For Windows 2000 and Windows XP, do not use commas as separators when specifying binding paths. For more information, see Microsoft Knowledge Base article 263241 (http://support.microsoft.com/default.aspx?scid=kb;en-us;263241).

Define network services in [NetServices], network protocols in [NetProtocols], and network adapters in [NetAdapters].

Entry | Description
Demote | Demotes the specified binding path/order to the bottom of the list of binding paths that start with the first specified network component.
Disable | Disables bindings between network components in the specified path.
Enable | Enables bindings between components in the specified path.

Sample

This sample demonstrates one use of the [NetBindings] section of Unattend.txt.

[NetBindings]
Demote = "MS_Server, MS_NetBT, MS_TCPIP, Adapter1"
Disable = "MS_Server, MS_NetBEUI, Adapter2"
Enable = "MS_Server, MS_NetBT, MS_TCPIP, Adapter1"

Demote

Demotes the specified binding path/order to the bottom of the list of binding paths that start with the first specified network component.

Syntax Demote = network_service, [...] network_protocol, [...] network_adapter [...]
Values network_service

network_protocol

network_adapter
Example
Demote = "MS_Server, MS_NetBT, MS_TCPIP, Adapter1"

Return to top

Disable

Disables bindings between network components in the specified path.

Syntax Disable = network_service, [...] network_protocol, [...] network_adapter [...]
Values network_service

network_protocol

network_adapter
Example
Disable = "MS_Server, MS_NetBEUI, Adapter2"
Comments The following examples are incorrect:
Disable = Adapter1              ; incorrect
Diable = Adapter2, MS_TCPIP   ; incorrect

Return to top

Enable

Enables bindings between components in the specified path.

Syntax | Enable = network_service, [...] network_protocol, [...] network_adapter [...]
Values network_service

network_protocol

network_adapter
Example
Enable = "MS_Server, MS_NetBT, MS_TCPIP, Adapter1"
Comments | If you specify a single component as the path, you enable all bindings to it.

Return to top


[NetClients] (Unattend.txt)

banner

[NetClients]

Answer File = Unattend.txt and Sysprep.inf

The [NetClients] section contains an entry for specifying the network clients to install.

Entry | Description
network_client_name | Specifies the section where you define entries for a network client.

Sample

This sample demonstrates one use of the [NetClients] section of Unattend.txt.

[NetClients]
MS_MSClient = params.MS_MSClient

network_client_name

Specifies the section where you define entries for a network client.

Syntax | network_client_name = client_entries_section
Value | client_entries_section
Example
MS_MSClient = params.MS_MSClient
Comments You must include the network client name in the following table. The table describes each client and the components that automatically install.
Client ID | Description | Component installed
MS_MSClient | Client for Microsoft Networks, which represents MS_Browser, MS_Workstation, MS_RPC | MS_NetBIOS
MS_NWClient | Client for NetWare Networks |

Important

  • Microsoft® Windows® XP Professional and the Windows Server 2003 family support the NetWare client, but Windows XP Home Edition does not support it.

Return to top


[NetOptionalComponents] (Unattend.txt)

banner

[NetOptionalComponents]

Answer File = Unattend.txt and Sysprep.inf

The [NetOptionalComponents] section contains entries for installing optional network components. To process this section during unattended Setup, the value of netoc must be set to On in the Components section of Unattend.txt.

Entry | Description
Beacon | Specifies whether to install or remove the beacon client.
DHCPServer | Specifies whether to install the Dynamic Host Configuration Protocol (DHCP) server on the computer.
DNS | Specifies whether to install Domain Name Service (DNS) on the computer.
IAS | Specifies whether to install the Internet Authentication Services (IAS) and creates a shortcut to the IAS Microsoft Management Console (MMC) snap-in under the Administrative Tools section of the Start menu.
ILS | Specifies whether to install the Internet Location Service (ILS) on the computer.
LPDSVC | Specifies whether to install Print Services for UNIX on the computer.
MacPrint | Specifies whether to install Print Server Services for Macintosh on the computer.
MacSrv | Specifies whether to install Services for Macintosh (SFM) on the computer.
NetCMAK | Specifies whether to install the Microsoft Connection Manager Administration Kit.
NetCPS | Specifies whether to install the Microsoft Connection Point Services.
NetMonTools | Specifies whether to install Network Monitor tools on the computer.
SimpTcp | Specifies whether to install Simple TCP/IP Services on the computer.
SNMP | Specifies whether to install Simple Network Management Protocol (SNMP) on the computer.
WBEMSNMP | Specifies whether to install the WMI SNMP Provider components.
WINS | Specifies whether to install Windows Internet Name Service (WINS) on the computer.

Sample

This sample demonstrates one use of the [NetOptionalComponents] section of Unattend.txt.

[NetOptionalComponents]
Beacon = 1
DHCPServer = 1
DNS = 1
IAS = 1
ILS = 1
LPDSVC = 1
MacPrint = 1
MacSrv = 1
NetCMAK = 1
NetCPS = 1
NetMonTools = 1
SimpTcp = 1
SNMP = 1
WBEMSNMP = 1
WINS = 1

Beacon

Specifies whether to install the beacon client.

Syntax | Beacon = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
Beacon = 1
Comments | Not valid for the Microsoft® Windows® Server 2003 family. The beacon client is installed by default on Windows XP Home Edition and Windows XP Professional.

Return to top

DHCPServer

Specifies whether to install the Dynamic Host Configuration Protocol (DHCP) server on the computer.

Syntax | DHCPServer = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
DHCPServer = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

DNS

Specifies whether to install DNS on the computer.

Syntax | DNS = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
DNS = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

IAS

Specifies whether to install the Internet Authentication Services (IAS) and creates a shortcut to the IAS Microsoft Management Console (MMC) snap-in under the Administrative Tools section of the Start menu.

Syntax | IAS = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
IAS = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

ILS

Specifies whether to install the Internet Location Service (ILS) on the computer.

Syntax | ILS = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Dependencies | Requires iis_common, iis_inetmgr, iis_www, and COM.
Example
ILS = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

LPDSVC

Specifies whether to install Print Services for UNIX on the computer.

Syntax LPDSVC = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
LPDSVC = 1

Return to top

MacPrint

Specifies whether to install Print Server Services for Macintosh on the computer.

Syntax | MacPrint = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
MacPrint = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

MacSrv

Specifies whether to install Services for Macintosh (SFM) on the computer.

Syntax | MacSrv = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
MacSrv = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

NetCMAK

Specifies whether to install the Microsoft Connection Manager Administration Kit.

Syntax | NetCMAK = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
NetCMAK = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

NetCPS

Specifies whether to install the Microsoft Connection Point Services.

Syntax | NetCPS = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
NetCPS = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

NetMonTools

Specifies whether to install Network Monitor tools on the computer.

Syntax | NetMonTools = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
NetMonTools = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top

SimpTcp

Specifies whether to install Simple TCP/IP Services on the computer.

Syntax SimpTcp = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
SimpTcp = 1

Return to top

SNMP

Specifies whether to install Simple Network Management Protocol (SNMP) on the computer.

Syntax SNMP = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
SNMP = 1

Return to top

WBEMSNMP

Specifies whether to install the WMI SNMP Provider components.

Syntax | WBEMSNMP = 0 | 1
Values 0

Does not install the WMI SNMP Provider components.

1

Installs the WMI SNMP Provider components.
Default Value | 0
Example
WBEMSNMP = 1
Registry Subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\WBEMSNMP

Return to top

WINS

Specifies whether to install Windows Internet Name Service (WINS) on the computer.

Syntax | WINS = 0 | 1
Values 0

Ignores the component during unattended Setup.

1

Installs the component during unattended Setup.
Example
WINS = 1
Comments | Valid only for the Windows Server 2003 family.

Return to top


[NetProtocols] (Unattend.txt)

banner

[NetProtocols]

Answer File = Unattend.txt and Sysprep.inf

The [NetProtocols] section contains an entry for installing the network protocols.

Entry | Description
protocol_name | Specifies the section where you define entries of this protocol.

Sample

This sample demonstrates one use of the [NetProtocols] section of Unattend.txt.

[NetProtocols]
MS_TCPIP = params.TCPIP

protocol_name

Specifies the section where you define entries of this protocol.

Syntax | protocol_name = protocol_entries_section
Value | protocol_entries_section
Example
MS_TCPIP = params.TCPIP
Comments You must select the protocol name from the Protocol ID column of the following table. This table describes each protocol and the components that automatically install.

Important

  • The IPX protocol is valid only on 32-bit platforms.

Protocol ID | Description | Components installed
MS_AppleTalk | AppleTalk Protocol |
MS_ATMArps | ATM ARP Server Protocol |
MS_ATMLANE | ATM LAN Emulation Client |
MS_ATMUni | ATM Call Manager Protocol |
MS_L2TP | L2TP (Layer 2 Tunneling Protocol) |
MS_NetMon | Network Monitor Agent |
MS_NWIPX | Internetwork Packet Exchange (IPX) Protocol | MS_Nwipx, MS_Nwnb
MS_PPTP | Point-to-Point Tunneling Protocol (PTPP) |
MS_TCPIP | Transmission Control Protocol/Internet Protocol (TCP/IP) | MS_NetBT

Return to top


[NetServices] (Unattend.txt)

banner

[NetServices]

Answer File = Unattend.txt and Sysprep.inf

The [NetServices] section contains entries for installing network services.

Entry | Description
network_service_name | Specifies the section where you define entries for a network service.

Sample

This sample demonstrates one use of the [NetServices] section of Unattend.txt.

[NetServices]
MS_Server = params.MS_Server

network_service_name

Specifies the section where you define entries for a network service.

Syntax | network_service_name = service_entries_section
Value | service_entries_section
Example
MS_Server = params.MS_Server
Comments You must select the network service name from the Service ID column in the following table. The table describes each client and the components that automatically install.
Service ID | Description
MS_NwSapAgent | SAP Agent
MS_PSched | QoS Packet Scheduler
MS_RasSrv | Dial-Up Server
MS_Server | File and Print Services
MS_WLBS | Network Load Balancing (formerly known as Windows Load Balancing Service)

Return to top


[params.adapter instance] (Unattend.txt)

banner

[params.adapter instance]

Answer File = Unattend.txt and Sysprep.inf

The [params.adapter instance] section contains entries for specifying an adapter’s instance on a computer.

To create an unattended answer file for identical computers with the same hardware configurations, including the same type of network adapters in the same PCI slots:

  1. Install Microsoft® Windows® on one of the computers.
  2. View each network adapter’s properties on the General tab in Device Manager and make a note of the PCI location information.
  3. This information (PCI Bus, Device, and Function numbers) is written in the Unattend.txt file specified later in this document.
  4. The file is now ready to install the operating system on the other computers.

The PCI location information comprises three entries: PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber. You must use all of these entries to ensure that Setup applies all of the networking settings based on the PCI location.

If different adapters are on the computers (that is, the Plug and Play IDs are not the same), the answer file can use the explicit Plug and Play IDs of each adapter instead of PCI location information.

Adding devices after Setup installs the operating system can cause bus numbers to change. As a result, the Unattend.txt file might not work on other computers. If different adapters are on the computers (that is, the Plug and Play IDs are not the same), the unattended file can use the explicit Plug and Play IDs of each adapter instead of the PCI location information.

Entry | Description
ConnectionName | Specifies the name for the network connection associated with the network adapter to install.
DMA | Specifies the direct memory access (DMA) channel setting of a network adapter.
DoNotDetectLegacyCards | Specifies legacy (non-Plug and Play) adapters that Setup can ignore when trying to detect the network adapters on a computer.
InfID | Identifies a network adapter with a value that is the same as the adapter’s Plug and Play ID.
IOAddr | Specifies the I/O address (hexadecimal number) of a network adapter.
IRQ | Specifies the interrupt number setting of a network adapter.
MEM | Specifies the memory base address setting of a network adapter.
NetCardAddress | Specifies the media access control address for the network adapter being configured during unattended Setup.
PCIBusNumber | Indicates the PCI bus on which the network card resides.
PCIDeviceNumber | Indicates the PCI device number for the network card and approximately relates to the particular slot number in which the network card resides on the given PCI bus.
PCIFunctionNumber | Defines which function on the card provides the networking function.

Sample

This sample demonstrates one use of the [params.adapter instance] section of Unattend.txt.

[params.adapter instance]
ConnectionName = "Corporate Network"
DMA = 1
DoNotDetectLegacyCards = *PNP030b,*PNP8132
InfID = *PNP030b
IOAddr = 330
IRQ = 5
MEM = 0xC123456
NetcardAddress = 0x123456789AB
PCIBusNumber = 0
PCIDeviceNumber = 11
PCIFunctionNumber = 0

ConnectionName

Specifies the name for the network connection associated with the network adapter to install.

Syntax | ConnectionName = network_connection_name
Value | network_connection_name
Example
ConnectionName = "Corporate Network"
Comments | If you do not specify this entry or its value is empty, use the default connection name of "Local Area Connection" for the first enumerated network adapter and "Local Area Connection x" for subsequent adapters where x starts from 2.

Return to top

DMA

Specifies the direct memory access (DMA) channel setting of a network adapter.

Syntax | DMA = DMA_channel_number
Value | DMA_channel_number
Example
DMA = 1

Return to top

DoNotDetectLegacyCards

Specifies legacy (non-Plug and Play) adapters that Setup can ignore when trying to detect the network adapters on a computer.

Syntax | DoNotDetectLegacyCards = InfID[, InfID, …]
Values | InfID[, InfID, …]
Example
DoNotDetectLegacyCards = *PNP030b,*PNP8132
Comments Setup does not detect and/or install these cards on the computer.

This entry does not prevent Setup from enumerating and installing Plug and Play adapters.

Important

  • The remaining entries in this section are optional and are meaningful only for non-Plug and Play adapters that require you to explicitly specify resources.

Return to top

InfID

Identifies a network adapter with a value that is the same as the adapter’s Plug and Play ID.

Syntax | InfID = PnP_ID_of_adapter
Value | PnP_ID_of_adapter
Example
InfID = *PNP030b
Comments If InfID = *, Setup matches the first enumerated/detected network adapter on the computer with the settings in this section. Therefore, on a computer with a single network card, you can specify adapter-specific entries without knowing the name or type of the network adapter.

For computers with more than one network adapter, you must specify the correct Plug and Play ID of each adapter. For computers with multiple adapters of the same type (that is, the Plug and Play ID for each is the same), you must specify the NetCardAddress or PCI location information. If you do not specify the NetCardAddress or PCI location, only the first adapter enumerated/detected that matches the InfID receives the answer file entries.

If you specify the NetCardAddress or PCI location, Setup does not use this entry because it is the least specific entry.

Return to top

IOAddr

Specifies the I/O address (hexadecimal number) of a network adapter.

Syntax | IOAddr = numeric_IO_address
Value | numeric_IO_address
Example
IOAddr = 330

Return to top

IRQ

Specifies the interrupt number setting of a network adapter.

Syntax | IRQ = IRQ_number
Value | IRQ_number
Example
IRQ = 5

Return to top

MEM

Specifies the memory base address setting of a network adapter.

Syntax | MEM = memory_range
Value | memory_range
Example
MEM = 0xC123456

Return to top

NetCardAddress

Specifies the media access control address for the network adapter being configured during unattended Setup.

Syntax | NetCardAddress = network_card_MAC_address
Value | network_card_MAC_address
Example
NetCardAddress = 0x123456789AB
Comments This entry is required when you install multiple network cards of the same type (with the same Plug and Play ID) on a computer and apply nondefault entries to the adapters.

This entry is not required for PCI adapters if you specify the PCI location information.

Return to top

PCIBusNumber

Indicates the PCI bus on which the network card resides.

Syntax | PCIBusNumber = PCI_bus_number_of_adapter
Value | PCI_bus_number_of_adapter
Example
PCIBusNumber = 0
PCIDeviceNumber = 11
PCIFunctionNumber = 0
Comments This entry is one of the three required entries to specify the PCI location information. You must also specify PCIDeviceNumber and PCIFunctionNumber.

You must specify these PCI location entries if:

  • You do not specify NetCardAddress.
  • You install multiple network cards of the same type (with the same Plug and Play ID) on a computer.
  • You need to apply nondefault entries to the adapter.

If you specify NetCardAddress, Setup does not use the PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber entries because NetCardAddress provides more specific information than the PCI location information.

Return to top

PCIDeviceNumber

Indicates the PCI device number for the network card and approximately relates to the particular slot number in which the network card resides on the given PCI bus.

Syntax | PCIDeviceNumber = PCI_device_number_of_adapter
Value | PCI_device_number_of_adapter
Example
PCIBusNumber = 0
PCIDeviceNumber = 11
PCIFunctionNumber = 0
Comments This entry is one of the three required entries to specify the PCI location information. You must also specify PCIBusNumber and PCIFunctionNumber.

You must specify these PCI location entries if:

  • You do not specify NetCardAddress.
  • You install multiple network cards of the same type (with the same Plug and Play ID) on a computer.
  • You need to apply nondefault entries to the adapter.

If you specify NetCardAddress, Setup does not use the PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber entries because NetCardAddress provides more specific information than the PCI location information.

Return to top

PCIFunctionNumber

Defines which function on the card provides the networking function.

Syntax | PCIFunctionNumber = PCI_function_number_of_adapter
Value | PCI_function_number_of_adapter
Example
PCIBusNumber = 0
PCIDeviceNumber = 11
PCIFunctionNumber = 0
Comments This is useful if there is a combination modem/network card. The function number begins with 0. This entry is one of the three required entries to specify the PCI location information for the network adapter configured during unattended Setup. You must also specify PCIBusNumber and PCIDeviceNumber.

You must specify these PCI location entries if:

  • You do not specify NetCardAddress.
  • You install multiple network cards of the same type (with the same Plug and Play ID) on a computer.
  • You need to apply nondefault entries to the adapter.

If you specify NetCardAddress, Setup does not use the PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber entries because NetCardAddress provides more specific information than the PCI location information.

Return to top


[protocol parameters section] (Unattend.txt)

banner

[protocol parameters section]

Answer File = Unattend.txt and Sysprep.inf

The [protocol parameters section] section contains an entry for specifying network protocol parameters that are also specified in the [NetProtocols] section.

Entry | Description
AdapterSections | Specifies a list of sections that contain device-specific network protocol parameters.

Sample

This sample demonstrates one use of the [protocol parameters section] section of Unattend.txt.

[protocol parameters section]
AdapterSections = params.TCPIP.Adapter1, params.TCPIP.Adapter2

AdapterSections

Specifies a list of sections that contain device-specific network protocol parameters.

Syntax | AdapterSections = section name[,section name, ...]
Values | section name[,section name, ...]
Example
AdapterSections = params.TCPIP.Adapter1, params.TCPIP.Adapter2
Comments You must specify a value in SpecificTo for each of the adapter sections listed here. The value of the SpecificTo entry is the name of a network adapter defined in the [NetAdapters] section.

For more information, see SpecificTo in the [adapter_specific_protocol_section] section.

Return to top


[OEMBootFiles] (Unattend.txt)

banner

[OEMBootFiles]

Answer File = Unattend.txt

The [OEMBootFiles] section contains entries for specifying OEM-supplied boot files. This entry is valid only if you set OemPreinstall to Yes and you place the files listed here in the \$OEM$\Textmode folder of the OEM’s distribution share point.

This section is required if you use the ComputerType entry in either the [Unattended] or [MassStorageDrivers] sections of Unattend.txt.

Important

  • Add driver entries only to the [MassStorageDrivers] and [OEMBootFiles] sections for bootable mass-storage devices. Do not include secondary mass-storage devices. Instead, add the drivers for secondary mass-storage devices to the folder specified by the OemPnPDriversPath entry in your unattended Setup answer file. Including drivers for non-bootable mass-storage devices in the [MassStorageDrivers] or [OEMBootFiles] sections causes an error during Setup.

HAL_file_name

Maps to a hardware abstraction layer (HAL) description in the ComputerType entry of the [Unattended] section of the Unattend.txt file.

SCSI_driver_file_name

Maps to a mass-storage device driver description defined in the [MassStorageDrivers] section of the Unattend.txt file. You can list multiple instances of SCSI_driver_file_name in the [OEMBootFiles] section.

TxtSetup.oem

This file contains descriptions of all the OEM-supplied drivers listed in this section and includes instructions on how to install them. This file must exist if the Unattend.txt file contains an [OEMBootFiles] section.

If your mass-storage device is a Plug and Play device, verify that a Hardware Identification section and a reference to the catalog file for the driver (<Driver>.cat) exist in the Txtsetup.oem file.

If the Hardware Identification section does not exist, you must add [HardwareIds.scsi.yyyyy] to the Txtsetup.oem file and verify that the following information is included:

id = xxxxx, yyyyy

where xxxxx represents the device ID, and yyyyy represents the service associated with the device.

For more information about Txtsetup.oem, see the Microsoft Driver Development Kit (DDK), which you can order from the Microsoft DDK Web site (http://www.microsoft.com/ddk/). You can also read the DDK documentation in the MSDN Library (http://msdn.microsoft.com/library/): Select Windows Development, then Driver Development Kit.


[OsChooser] (Unattend.txt)

banner

[OsChooser]

Answer File = Unattend.txt

The [OsChooser] section contains entries for selecting the operating system. Only clients installed with access to Remote Installation Services (RIS) can use this section.

Entry | Description
Description | Specifies the description of the operating system image. This text appears on the client computer within the Client Installation Wizard (CIW).
Help | Specifies the Help topic when end users select the operating system description within the CIW.
ImageType | Specifies the type of operating system image.
LaunchFile | Specifies the file to execute when the end user selects an operating system image from within the CIW.
Version | Specifies the version of the operating system or tool executed when the end user selects an image from within the CIW.

Sample

This sample demonstrates one use of the [OsChooser] section of Unattend.txt.

[OsChooser]
Description = "This is my description."
Help = MyHelpTopic
ImageType = Sysprep
LaunchFile = "%Installpath%\%MachineType%\Vendortool.bin"
Version = 123

Description

Specifies the description of the operating system image.

Syntax | Description = string
Value | string
Example
Description = "This is my description."
Comments | This text appears on the client computer within the Client Installation Wizard (CIW).

Return to top

Help

Specifies the Help topic when end users select the operating system description within the CIW.

Syntax | Help = string
Value | string
Example
Help = MyHelpTopic
Comments | The Help topic provides a more detailed, formal description of the operating system image.

Return to top

ImageType

Specifies the type of operating system image.

Syntax | ImageType = Flat | Sysprep
Values Flat

Supports a flat CD-ROM-based image.

Sysprep

Supports a Sysprep image created using the RIPrep wizard.
Example
ImageType = Sysprep
Comments | RIS supports either a flat CD-ROM-based image or a Sysprep image created using the Remote Installer Preparation (RIPrep) wizard.

Return to top

LaunchFile

Specifies the file to execute when the end user selects an operating system image from within the CIW.

Syntax | LaunchFile = path_and_file_name
Value | path_and_file_name
Example
LaunchFile = "%Installpath%\%MachineType%\Vendortool.bin"
Comments Using RIS to install an operating system on a client computer from within the CIW automatically defines this path. Use this option to execute preboot maintenance and troubleshooting tools for use with RIS. LaunchFile accepts either a literal path or a relative path to the executable file.

Literal Path:

Setup\English\Tools\VendorName\i386\Vendortool.bin

Relative Path:

%Installpath%\%MachineType%\Vendortool.bin

Return to top

Version

Specifies the version of the operating system or tool executed when the end user selects an image from within the CIW.

Syntax | Version = string
Value | string
Example
Version = 123

Return to top


[PCHealth] (Unattend.txt)

banner

[PCHealth]

Answer File = Unattend.txt

The [PCHealth] section contains entries for configuring error reporting, Remote Assistance, and Help and Support Center.

Entry | Description
ER_Display_UI | Specifies whether Setup notifies the end user that an error has occurred and shows details about the error.
ER_Enable_Applications | Specifies how Microsoft® Windows® reports errors that occur in applications.
ER_Enable_Kernel_Errors | Specifies whether Windows reports errors in the Windows kernel.
ER_Enable_Reporting | Specifies whether Windows automatically reports errors.
ER_Enable_Windows_Components | Specifies whether to report errors in Windows applications.
ER_Exclude_EXE(n) | Specifies an application for which Windows does not report any errors, if they occur.
ER_Force_Queue_Mode | Specifies whether to send all reports in queue mode.
ER_Include_EXE(n) | Specifies whether the error report includes the file name of the application causing the error.
ER_Include_MSApps | Specifies whether to track and report errors in Microsoft applications.
ER_Include_Shutdown_Errs | Specifies whether to report shutdown errors.
RA_AllowFullControl | Specifies whether a person (other than the end user of the computer) can take full control of the computer from a separate location.
RA_AllowToGetHelp | Specifies whether to enable Remote Assistance.
RA_AllowUnsolicited | Specifies whether to enable unsolicited Remote Assistance.
RA_MaxTicketExpiry | Specifies the time, in seconds, after which a Remote Assistance invitation expires.

Sample

This sample demonstrates one use of the [PCHealth] section of Unattend.txt.

[PCHealth]
ER_Display_UI = 1
ER_Enable_Applications = All
ER_Enable_Kernel_Error = 1
ER_Enable_Reporting = 1
ER_Enable_Windows_Components = 1
ER_Exclude_EXE1 = notepad.exe
ER_Force_Queue_Mode = 1
ER_Include_EXE1 = iexplore.exe
ER_Include_MSApps = 1
ER_Include_Shutdown_Errs = 1
RA_AllowFullControl = 0
RA_AllowToGetHelp = 1
RA_AllowUnsolicited = 0
RA_MaxTicketExpiry = 600

ER_Display_UI

Specifies whether Setup notifies the end user that an error has occurred and shows details about the error.

Syntax ER_Display_UI = 0 | 1
Values 0

Does not display the error notification user interface.

1

Displays the error notification user interface.
Example
ER_Display_UI = 1
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\PCHealth\
ErrorReporting\ShowUI
Comments If you enable ER_Enable_Reporting, the end user can choose to report the error. If you disable ER_Enable_Reporting and enable ER_Display_UI, the end user cannot report errors. If you disable ER_Display_UI and enable ER_Enable_Reporting, Setup automatically reports the errors, but does not notify the end user.

Note

  • For servers that do not have interactive users, consider disabling ER_Display_UI.

Return to top

ER_Enable_Applications

Specifies how Windows reports errors that occur in applications.

Syntax | ER_Enable_Applications = All | Listed | None
Values All

Reports errors for all applications except for those listed in ER_Exclude_EXE(n).

Listed

Reports errors only for those applications listed in ER_Include_EXE(n) and Microsoft applications when you enable ER_Include_MSapps.

None

Reports no application errors.
Example
ER_Enable_Applications = All
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\
PCHealth\ErrorReporting\AllOrNone
Comments | Controls whether to report errors in applications when you enable ER_Enable_Reporting.

Return to top

ER_Enable_Kernel_Errors

Specifies whether Windows reports errors in the Windows kernel.

Syntax ER_Enable_Kernel_Errors = 0 | 1
Values 0

Does not report errors in the Windows kernel.

1

Reports errors in the Windows kernel when you enable ER_Enable_Reporting.
Example
ER_Enable_Kernel_Errors = 1
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\PCHealth\
ErrorReporting\IncludeKernelFaults

Return to top

ER_Enable_Reporting

Specifies whether Windows automatically reports errors.

Syntax | ER_Enable_Reporting = 0 | 1
Values 0

Does not report errors.

1

Reports errors.
Example
ER_Enable_Reporting = 1
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\PCHealth\
ErrorReporting\DoReport
Comments | If you disable ER_Enable_Reporting and enable ER_Display_UI, the end user cannot report errors.

Return to top

ER_Enable_Windows_Components

Specifies whether to report errors in Windows applications.

Syntax | ER_Enable_Windows_Components = 0 | 1
Values 0

Reports errors in Windows components.

1

Reports errors in Windows components when you enable ER_Enable_Reporting.
Example
ER_Enable_Windows_Components = 1
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\PCHealth\
ErrorReporting\IncludeWindowsApps
Comments | When you enable ER_Enable_Reporting, Setup reports errors for the components that are part of Windows XP and Windows Server 2003 operating systems. To exclude individual Windows components, use ER_Exclude_EXE(n).

Return to top

ER_Exclude_EXE(n)

Specifies an application for which Windows does not report any errors, if they occur.

Syntax | ER_Exclude_EXE(n) = executable_filename
Value executable_filename

The filename of a Windows component or application that error reporting excludes.
Example
ER_Exclude_EXE1 = notepad.exe
ER_Exclude_EXE2 = explorer.exe
ER_Exclude_EXE3 = iexplore.exe
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\PCHealth\
ErrorReporting\ExclusionList
Comments | Only used if you enable ER_Enable_Windows_Components or if ER_Enable_Applications = All.

Return to top

ER_Force_Queue_Mode

Specifies whether to send all reports in queue mode.

Syntax ER_Force_Queue_Mode = 0 | 1
Values 0

Does not send reports in queue mode.

1

Sends reports in queue mode.
Default Value Windows Server 2003 family: 1
Windows XP Professional or Windows XP Home Edition: 0
Example
ER_Force_Queue_Mode = 1
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting\
ForceQueueMode

Return to top

ER_Include_EXE(n)

Specifies whether the error report includes the file name of the application causing the error.

Syntax | ER_Include_EXE = executable_filename
Value executable_filename

The file name of an application that includes error reporting.
Example
ER_Include_EXE1 = notepad.exe
ER_Include_EXE2 = explorer.exe
ER_Include_EXE3 = iexplore.exe
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\PCHealth\
ErrorReporting\InclusionList
Comments | Requires that ER_Enable_Applications is set to Listed. You can automatically include Microsoft applications by using ER_Include_MSApps.

Return to top

ER_Include_MSApps

Specifies whether to track and report errors in Microsoft applications.

Syntax | ER_Include_MSApps = 0 | 1
Values 0

Does not report errors in Microsoft applications.

1

Reports errors in Microsoft applications when you enable ER_Enable_Reporting.
Example
ER_Include_MSApps = 1
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\PCHealth\
ErrorReporting\IncludeMicrosoftApps
Comments | If you set ER_Enable_Reporting to 1 and ER_Enable_Applications to Listed, Setup reports errors for all Microsoft applications.

Return to top

ER_Include_Shutdown_Errs

Specifies whether to report shutdown errors.

Syntax ER_Include_Shutdown_Errs = 0 | 1
Values 0

Does not report shutdown errors.

1

Reports shutdown errors.
Default Value Windows Server 2003 family: 1
Windows XP Professional or Windows XP Home Edition:0
Example
ER_Include_Shutdown_Errs = 1
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting\
IncludeShutdownErrs

Return to top

RA_AllowFullControl

Specifies whether a person (other than the end user of the computer) can take full control of the computer from a separate location.

Syntax | RA_AllowFullControl = 0 | 1
Values 0

Enables remote helper to view the end user's desktop but cannot take control of the end user's computer.

1

Enables remote helper to ask to take control of the end user's computer and the end user can grant this request.
Default Value | 1
Example
RA_AllowFullControl = 0
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\
Windows NT\Terminal Services\fAllowFullControl
Comments | The helper must ask the end user for explicit permission to take control; the end user can accept or decline such requests. Requires RA_AllowToGetHelp = 1. If RA_AllowToGetHelp is 0, Setup ignores RA_AllowFullControl.

Return to top

RA_AllowToGetHelp

Specifies whether to enable Remote Assistance.

Syntax | RA_AllowToGetHelp = 0 | 1
Values 0

Disables Remote Assistance.

1

Enables Remote Assistance.
Default Value | 1
Example
RA_AllowToGetHelp = 1
Registry subkey HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Control\TerminalServer\fAllowToGetHelp or
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\
Windows NT\Terminal Services\fAllowToGetHelp
Comments Remote Assistance allows another person to view and share the control of the end user's desktop from a separate location, using Terminal Services, so that person can more easily assist the end user with a technical problem.

End users may request Remote Assistance by escalating a support request to OEM product support from the Help and Support Center. End users may also request Remote Assistance from a friend using MSN® Messenger or Windows Messenger or e-mail.

Return to top

RA_AllowUnsolicited

Specifies whether to enable unsolicited Remote Assistance.

Syntax | RA_AllowUnsolicited = 0 | 1
Values 0

Disables unsolicited Remote Assistance.

1

Enables unsolicited Remote Assistance.
Default Value | 0
Example
RA_AllowUnsolicited = 0
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\
Windows NT\Terminal Services\fAllowUnsolicited
Comments | With unsolicited Remote Assistance, another person within the corporate local area network (LAN) who has administrator-level access to the computer (or one who has a user account with the appropriate level of permissions) may request access to the computer for management or troubleshooting purposes. The end user can accept or decline such requests.

Return to top

RA_MaxTicketExpiry

Specifies the time, in seconds, after which a Remote Assistance invitation expires.

Syntax | RA_MaxTicketExpiry = time_in_seconds
Value time_in_seconds

The time, in seconds, after which a Remote Assistance ticket expires.
Default Value | 2,592,000 seconds (30 days)
Example
RA_MaxTicketExpiry = 600
Registry subkeys HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\
Windows NT\Terminal Services\MaxTicketExpiryUnits and
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\
Windows NT\Terminal Services\MaxTicketExpiry

Return to top


[Proxy] (Unattend.txt)

banner

[Proxy]

Answer File = Unattend.txt

The [Proxy] section contains entries for specifying proxy server settings for the Microsoft® Windows® XP or Windows Server 2003 family browser. If these settings are not present, Setup uses the default for Windows XP or the Windows Server 2003 family.

Important

  • To make sure your [Proxy] settings take effect, you need to include the [Branding] section header and the BrandIEUsingUnattended entry in the answer file to enable the following browser-related settings:
    [Branding]
BrandIEUsingUnattended = Yes
  • In the [Unattended] section, if AutoActivate = Yes and ActivateProxy = Proxy, Windows Product Activation (WPA) attempts to activate this installation of Windows XP by using the proxy settings specified in this section.

    If ActivateProxy is a value other than Proxy, WPA uses the proxy settings specified in [section_name] of the Unattend.txt file. The entries in [section_name] must match the syntax specified for the [Proxy] section.

Entry | Description
FTP_Proxy_Server | Specifies the Internet Protocol (IP) address or Uniform Resource Locator (URL) of the File Transfer Protocol (FTP) proxy server on the network.
Gopher_Proxy_Server | Specifies the IP address or URL of the Gopher proxy server on the network.
HTTP_Proxy_Server | Specifies the IP address or URL of the HTTP proxy server on the network.
Proxy_Enable | Specifies whether to use a proxy server to connect to the Internet.
Proxy_Override | Specifies a semicolon-separated list of IP addresses to bypass the proxy server.
Secure_Proxy_Server | Specifies the IP address or URL of the Secure proxy on the network.
Socks_Proxy_Server | Specifies the IP address or URL of the Socks proxy on the network.
Use_Same_Proxy | Specifies whether to use the same proxy server for all protocols.

Sample

This sample demonstrates one use of the [Proxy] section of Unattend.txt.

[Proxy]
FTP_Proxy_Server = http://proxyserver:80
Gopher_Proxy_Server = http://proxyserver:80
HTTP_Proxy_Server = http://proxyserver:80
Proxy_Enable = 1
Proxy_Override = <local>
Secure_Proxy_Server = http://proxyserver:80
Socks_Proxy_Server = http://proxyserver:80
Use_Same_Proxy = 1

FTP_Proxy_Server

Specifies the Internet Protocol (IP) address or URL of the FTP proxy server on the network.

Syntax | FTP_Proxy_Server = URL_or_IP_address
Value | URL_or_IP_address
Example
FTP_Proxy_Server = http://proxyserver:80

Return to top

Gopher_Proxy_Server

Specifies the IP address or URL of the Gopher proxy server on the network.

Syntax | Gopher_Proxy_Server = URL_or_IP_address
Value | URL_or_IP_address
Example
Gopher_Proxy_Server = http://proxyserver:80

Return to top

HTTP_Proxy_Server

Specifies the IP address or URL of the HTTP proxy server on the network.

Syntax | HTTP_Proxy_Server = URL_or_IP_address
Value | URL_or_IP_address
Dependencies | Required if you use Use_Same_Proxy.
Example
HTTP_Proxy_Server = http://proxyserver:80

Return to top

Proxy_Enable

Specifies whether to use a proxy server to connect to the Internet.

Syntax Proxy_Enable = 0 | 1
Values 0

Does not use a proxy server.

1

Uses a proxy server.
Registry subkey HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Internet Settings\ProxyEnable
Example
Proxy_Enable = 1

Return to top

Proxy_Override

Specifies a semicolon-separated list of IP addresses to bypass the proxy server.

Syntax | Proxy_Override = list_of_IP_addresses
Value | list_of_IP_addresses
Registry subkey HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Internet Settings\ProxyOverride
Example
Proxy_Override = <local>
Comments | You must enclose the list in quotation marks (for more than one address) and add the string <local> to override local addresses.

Return to top

Secure_Proxy_Server

Specifies the IP address or URL of the Secure proxy on the network.

Syntax | Secure_Proxy_Server = URL_or_IP_address
Value | URL_or_IP_address
Example
Secure_Proxy_Server = http://proxyserver:80

Return to top

Socks_Proxy_Server

Specifies the IP address or URL of the Socks proxy on the network.

Syntax | Socks_Proxy_Server = URL_or_IP_address
Value | URL_or_IP_address
Example
Socks_Proxy_Server = http://proxyserver:80

Return to top

Use_Same_Proxy

Specifies whether to use the same proxy server for all protocols.

Syntax | Use_Same_Proxy = 0 | 1
Values 0

Does not use the same proxy server for all protocols.

1

Uses the same proxy server for all protocols.
Example
Use_Same_Proxy = 1
Comments | If you specify this entry, all other transports use the HTTP proxy server.

Return to top


[RegionalSettings] (Unattend.txt, Sysprep.inf)

banner

[RegionalSettings]

Answer File = Unattend.txt and Sysprep.inf

The [RegionalSettings] section contains entries for installing regional settings during Setup.

Using [RegionalSettings] in Unattend.txt

If you include [RegionalSettings] in Unattend.txt, you must also use the /copysource:lang command-line option of Winnt32.exe so that Setup copies the appropriate language files to the hard disk. The command winnt32 /copysource:lang copies all the files in the PRODUCT:\i386\Lang folder to MASTER:\%WINDIR%\Lang.

Important

  • Any settings specified in the [RegionalSettings] section in Unattend.txt do not persist if you run Sysprep on the computer. If the first-run experience is Windows Welcome, specify the corresponding settings in the [Options] section of Oobeinfo.ini. If the first-run experience is Mini-Setup, specify the corresponding settings in the [RegionalSettings] section of Sysprep.inf.

If you set OemPreinstall to Yes in the [Unattended] section of Unattend.txt and do not provide values for the [RegionalSettings] section, set OEMSkipRegional to 1 in the [GuiUnattended] section of Unattend.txt or in the [GuiUnattended] section of Sysprep.inf to ensure Setup completes without prompting for regional option information. However, do not distribute computers that do not:

  • Have preconfigured regional, language, and keyboard settings.

    —OR—

  • Enable the Regional and Language Options page during the end user's first-run experience.

Using [RegionalSettings] in Sysprep.inf

To use [RegionalSettings] in Sysprep.inf, you must have all language files on the computer's hard disk. Specify the location of the files by using InstallFilesPath in the [Unattended] section of Sysprep.inf.

Entry | Description
InputLocale | Specifies the input locale and keyboard layout combinations to install.
InputLocale_DefaultUser | Specifies the input locale and keyboard layout combination for the default user.
Language | Specifies the language/locale to install.
LanguageGroup | Specifies the language group for this installation.
SystemLocale | Specifies the system locale to install.
UserLocale | Specifies the user locale to install.
UserLocale_DefaultUser | Specifies the user locale for the default user.

Sample

This sample demonstrates one use of the [RegionalSettings] section of Unattend.txt.

[RegionalSettings]
InputLocale = 2058:40a, 1046:416
InputLocale_DefaultUser = 2058:40a
Language = 0409
LanguageGroup = 2
SystemLocale = 2058
UserLocale = 2058
UserLocale_DefaultUser = 2058

InputLocale

Specifies the input locale and keyboard layout combinations to install.

Syntax | InputLocale = locale_ID:keyboard layout ID[, locale_ID:keyboard_layout_ID][, ...]
Values | locale_ID:keyboard layout ID[, locale_ID:keyboard_layout_ID][, ...]
Example
InputLocale = 2058:40a, 1046:416
Comments The first keyboard layout specified is the default layout for the installation. One of the language groups defined in the LanguageGroup entry or the default language group for the language version of Microsoft® Windows® must support the specified combination. If an available language group does not support the combination specified, Setup uses the default combination. Setup also ignores this entry if you specify the Language entry.

For a list of valid locale ID and keyboard layout combinations, visit the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

Return to top

InputLocale_DefaultUser

Specifies the input locale and keyboard layout combination for the default user.

Syntax | InputLocale_DefaultUser = locale_ID:keyboard_layout_ID
Values | locale_ID:keyboard_layout_ID
Example
InputLocale_DefaultUser = 2058:40a
Comments One of the language groups defined in the LanguageGroup entry or the default language group for the language version of Windows must support the specified combination. You must define the keyboard in the KeyboardLayout entry in the [Unattended] section of Unattend.txt.

Not supported by Sysprep.inf.

For a list of valid locale ID and keyboard layout combinations, visit the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

Return to top

Language

Specifies the language/locale to install.

Syntax | Language = locale_ID
Value | locale_ID
Example
Language = 0409
Comments One of the language groups specified in the LanguageGroup entry must support this language. If an available language group does not support the locale, Setup uses the default language for this version of Windows.

Important

  • If you specify this entry, Setup ignores the SystemLocale, UserLocale, and InputLocale entries.

For a list of valid locales and their language groups, visit the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

Return to top

LanguageGroup

Specifies the language group for this installation.

Syntax | LanguageGroup = language_group_ID[, language_group_ID[, ...]]
Values | language_group_ID[, language_group_ID[, ...]]
Example
LanguageGroup = 2
Comments You cannot specify a particular locale or language unless you install the appropriate language group.

In Windows XP, if you install one language group, then you install all corresponding language groups. For example, if you install one language group from the set of East Asian language groups, then you also install associated language groups. Likewise, if you install one language group from the set of complex script language groups, then you install all complex script language groups.

The supported language group IDs are listed in the following table.

ID | Language Group | Corresponding Value in Regional and Language Options Control Panel
1 | Western Europe and United States | Installed by Default
2 | Central Europe | Installed by Default
3 | Baltic | Installed by Default
4 | Greek | Installed by Default
5 | Cyrillic | Installed by Default
6 | Turkic | Installed by Default
7 | Japanese | East Asian Language
8 | Korean | East Asian Language
9 | Traditional Chinese | East Asian Language
10 | Simplified Chinese | East Asian Language
11 | Thai | Complex Script
12 | Hebrew | Complex Script
13 | Arabic | Complex Script
14 | Vietnamese | Complex Script
15 | Indic | Complex Script
16 | Georgian | Complex Script
17 | Armenian | Complex Script

For a list of specific languages that correspond to particular language groups, see the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

Return to top

SystemLocale

Specifies the system locale to install.

Syntax | SystemLocale = locale_ID
Value | locale_ID
Example
SystemLocale = 2058
Comments | The system locale enables localized applications to run and display menus and dialog boxes in their native language. One of the language groups specified in the LanguageGroup entry or the default language group for the language version of Windows must support the specified system locale. If an available language group does not support the locale specified, Setup installs the default system locale. Setup also ignores this entry if you specify the Language entry.

Return to top

UserLocale

Specifies the user locale to install.

Syntax | UserLocale = locale_ID
Value | locale_ID
Example
UserLocale = 2058
Comments | The user locale controls the settings for numbers, time, currency, and dates. One of the language groups specified in the LanguageGroup entry or the default language group for the language version of Windows must support the specified user locale. If an available language group does not support the locale specified, Setup installs the default user locale. Setup also ignores this entry if you specify the Language entry.

Return to top

UserLocale_DefaultUser

Specifies the user locale for the default user.

Syntax | UserLocale_DefaultUser = locale_ID
Value | locale_ID
Example
UserLocale_DefaultUser = 2058
Comments | The user locale controls the settings for numbers, time, currency, and dates. The specified user locale must be supported by one of the languages that is specified in the LanguageGroup setting or the default language for the Windows version that is installed.

Return to top


[RemoteInstall] (Unattend.txt)

banner

[RemoteInstall]

Answer File = Unattend.txt

The [RemoteInstall] section contains entries for specifying remote installation. Only clients installed by the Remote Installation Services (RIS) can use this section.

Entry | Description
Repartition | Specifies whether to delete all partitions on the first drive of the client computer and reformat it with the NTFS file system.
UseWholeDisk | Specifies whether to extend the volume to the end of the drive.

Sample

This sample demonstrates one use of the [RemoteInstall] section of Unattend.txt.

[RemoteInstall]
Repartition = Yes
UseWholeDisk = Yes

Repartition

Specifies whether to delete all partitions on the first drive of the client computer and reformat it with the NTFS file system.

Syntax | Repartition = Yes | No
Values Yes

Deletes all partitions on the first drive of the client computer and reformat it with the NTFS file system.

No

Uses the default entries in the answer file.
Example
Repartition = Yes
Comments | You cannot run unattended Setup on a disk that does not contain a file system. Make sure that you format your destination disk with a file system.

Return to top

UseWholeDisk

Specifies whether to extend the volume to the end of the drive.

Syntax | UseWholeDisk = Yes | No
Values Yes

Extends the volume to the end of the drive.

No

Stops Setup from extending the volume to the end of the drive.
Default Value | Yes
Example
UseWholeDisk = Yes
Comments | Valid only for RIPrep (Remote Installer Preparation) images.

Return to top


[SetupParams] (Unattend.txt)

banner

[SetupParams]

Answer File = Unattend.txt

This section is used to run an additional post-Setup command. It contains a single entry, UserExecute. The command specified with UserExecute runs immediately after Setup completes.

Entry | Description
UserExecute | Specifies the command or application to run after Setup completes.

Sample

This sample demonstrates one use of the [SetupParams] section of Unattend.txt.

[SetupParams]
UserExecute="C:\folder1\folder2\example.exe /s1 /s2"

UserExecute

Specifies the command or application to run after Setup completes.

Syntax | UserExecute = path_and_file_name
Value | path_and_file_name
Default Value | none
Example
[SetupParams]
UserExecute="C:\folder1\folder2\example.exe /s1 /s2"
Comments | Enclose path_and_file_name in quotation marks if it is a long file name. You can omit the path only if the application is in the %SYSTEMROOT% or %SYSTEMROOT%\system32 folder or search path.

Return to top


[Shell] (Unattend.txt and Winbom.ini)

banner

[Shell]

Answer File = Unattend.txt and Winbom.ini

The [Shell] section contains entries for specifying the visual style of the user interface.

Entry | Description
CustomDefaultThemeFile | Specifies the complete path to a .theme file.
DefaultStartPanelOff | Specifies whether to use the classic Microsoft® Windows® Start menu instead of the Windows XP Start menu, and displays icons for My Computer and My Documents on the Windows desktop.
DefaultThemesOff | Specifies whether to use the classic Windows visual style instead of the default Windows XP visual style.

Sample

This sample demonstrates one use of the [Shell] section of Unattend.txt.

[Shell]
CustomDefaultThemeFile = "%SYSTEMDRIVE%\Themes\MyTheme.theme"
DefaultStartPanelOff = Yes
DefaultThemesOff = Yes

CustomDefaultThemeFile

Specifies the complete path to a .theme file.

Syntax | CustomDefaultThemeFile = path_and_file_name
Value | path_and_file_name
Default Value | none
Example
CustomDefaultThemeFile = "%SYSTEMDRIVE%\Themes\MyTheme.theme"
Comments

Enclose path_and_file_name in quotation marks if it is a long file name. If path_and_file_name contains the environment variable %WINDIR%, you must follow %WINDIR% with a backward slash character.

If the value of DefaultThemesOff is Yes, Windows XP uses the classic Windows visual style.

These file names have a .theme extension. When you preinstall Windows using Winnt32.exe, you can use long file names for files included in a configuration set or distribution share. However, if you use Winnt.exe to preinstall the operating system, all files and folders in the $OEM$ directory structure must be in 8.3 format for Setup to copy the files. In addition, you must always use 8.3 file names when copying a set of files from one computer to another with MS-DOS. Use the $$Rename.txt file to restore these 8.3 names to long file names during Windows Setup.

Return to top

DefaultStartPanelOff

Specifies whether to use the classic Windows Start menu instead of the Windows XP Start menu, and displays icons for My Computer and My Documents on the Windows desktop.

Syntax | DefaultStartPanelOff = Yes | No
Values Yes

Uses the classic Windows Start menu and displays icons for My Computer and My Documents on the desktop.

No

Uses the default Windows XP start menu.
Default Value | No
Example
DefaultStartPanelOff = Yes

Return to top

DefaultThemesOff

Specifies whether to use the classic Windows visual style instead of the default Windows XP visual style.

Syntax | DefaultThemesOff = Yes | No
Values Yes

Uses the classic Windows visual style.

No

Uses the default Windows XP visual style.
Default Value | No
Example
DefaultThemesOff = Yes

Return to top


[SNMP] (Unattend.txt)

banner

[SNMP]

Answer File = Unattend.txt

The [SNMP] section contains entries for specifying the Simple Network Management Protocol (SNMP) service.

Entry | Description
Accept_CommunityName | Defines the community names from which the computer running the Simple Network Management Protocol (SNMP) service can accept traps.
Any_Host | Specifies whether the computer accepts SNMP packets from any host.
Community_Name | Indicates the community name for the computer.
Contact_Name | Specifies the contact name for this managed node, as well as information about how to contact this person.
Limit_Host | Specifies a maximum of three host names separated by commas.
Location | Specifies the physical location of the computer.
Send_Authentication | Specifies whether to send an authentication trap when an unauthorized community or host requests information.
Service | Specifies any combination of up to five SNMP services.
Traps | Specifies a maximum of three Internet Protocol (IP) or Internetwork Packet Exchange (IPX) addresses to which SNMP sends traps.

Sample

This sample demonstrates one use of the [SNMP] section of Unattend.txt.

[SNMP]
Accept_CommunityName = MyCommunity:Read_Only
Any_Host = No
Community_Name = "MyCommunity"
Contact_Name = "Pat Coleman"
Limit_Host = Host1, Host2, Host3
Location = "San Francisco"
Send_Authentication = Yes
Service = Applications, Internet, End-to-End
Traps = 193.1.56.13

Accept_CommunityName

Defines the community names from which the computer running the Simple Network Management Protocol (SNMP) service can accept traps.

Syntax | Accept_CommunityName = community_name:privilege, ...
Values | community_name:privilege, ...
Default Value | public:Read_Only
Example
Accept_CommunityName = MyCommunity:Read_Only
Comments Each community name must have a privilege associated with it. Valid privileges are None, Notify, Read_Only, Read_Write, and Read_Create.

If you do not assign a privilege to a community name, the default of Read_Only applies. Commas separate community names.

Return to top

Any_Host

Specifies whether the computer accepts SNMP packets from any host.

Syntax Any_Host = Yes | No
Values Yes

Accepts SNMP packets from any host.

No

Does not accept SNMP packets from any host.
Example
Any_Host = Yes

Return to top

Community_Name

Indicates the community name for the computer.

Syntax | Community_Name = community_name
Value | community_name
Example
Community_Name = "MyCommunity"
Comments | Enclose community_name in quotation marks.

Return to top

Contact_Name

Specifies the contact name for this managed node, as well as information about how to contact this person.

Syntax | Contact_Name = name
Values | name
Example
Contact_Name = "Pat Coleman"
Comments | Enclose name in quotation marks.

Return to top

Limit_Host

Specifies a maximum of three host names separated by commas.

Syntax | Limit_Host = host_name[, host_name][, host_name]
Values | host_name[, host_name][, host_name]
Dependencies | Requires Any_Host = No.
Example
Limit_Host = Host1, Host2, Host3

Return to top

Location

Specifies the physical location of the computer.

Syntax | Location = location
Value | location
Example
Location = "San Francisco"
Comments | Enclose location in quotation marks.

Return to top

Send_Authentication

Specifies whether to send an authentication trap when an unauthorized community or host requests information.

Syntax Send_Authentication = Yes | No
Values Yes

Sends an authentication trap when an unauthorized community or host requests information.

No

Does not send an authentication trap when an unauthorized community or host requests information.
Example
Send_Authentication = Yes

Return to top

Service

Specifies any combination of up to five SNMP services.

Syntax | Service = Physical, Applications, Datalink, Internet, End-to-End
Values | Physical, Applications, Datalink, Internet, End-to-End
Default Value | Applications, Internet, End-to-End
Example
Service = Applications, Internet, End-to-End
Comments | You must separate these values with commas.

Return to top

Traps

Specifies a maximum of three Internet Protocol (IP) or Internetwork Packet Exchange (IPX) addresses to which SNMP sends traps.

Syntax | Traps = IP_or_IPX_address[, IP_or_IPX_address]
Values | IP_or_IPX_address[, IP_or_IPX_address]
Example
Traps = 193.1.56.13
Comments For the values specified in the Traps entry to take effect, you must specify a valid value in the Community_Name entry.

Important

  • The IPX protocol is valid only on 32-bit platforms.

Return to top


[SystemFileProtection] (Unattend.txt)

banner

[SystemFileProtection]

Answer File = Unattend.txt

The [SystemFileProtection] section contains entries for specifying a new feature in Microsoft® Windows® XP called Windows File Protection (WFP). If this section is missing or empty, Setup installs WFP using default values. By preventing the replacement of essential system files, WFP avoids file version mismatches. It runs in the background on a Windows XP system, and protects all .sys, .dll, .exe, and .ocx files that ship on the Windows XP CD, as well as the TrueType fonts Micross.ttf, Tahoma.ttf, and Tahomabd.ttf.

Note

  • In earlier pre-release versions of Windows XP, WFP was known as System File Protection or System File Checker. Entry naming conventions still use this nomenclature.

WFP initiates when Setup attempts to:

  • Replace a protected system file.
  • Change a protected folder or a file in a protected folder. (WFP then determines which file changed.)

Windows File Protection (WFP) also checks version control of protected files. It looks up the file signature in a catalog file to determine if the new file is the correct Microsoft version. If the new file is not the correct Microsoft version, WFP looks for the replaced files by searching for them in the following order:

  1. The Dllcache folder.
  2. The network install path (if you install the system via network install).
  3. The Windows product CD.
Entry | Description
SFCDllCacheDir | Specifies the folder that WFP uses to cache the system files (the \Dllcache folder location).
SFCQuota | Specifies the cache size of the Dllcache file stored on the system hard disk.
SFCShowProgress | Specifies whether System File Checker displays a progress meter during file system scans.

Sample

This sample demonstrates one use of the [SystemFileProtection] section of Unattend.txt.

[SystemFileProtection]
SFCDllCacheDir = %SYSTEMROOT%\Windows\System32\Dllcache
SFCQuota = FFFFFFFF
SFCShowProgress = 1

SFCDllCacheDir

Specifies the folder that WFP uses to cache the system files (the \Dllcache folder location).

Syntax | SFCDllCacheDir = location of Dllcache folder
Values | location of Dllcache folder
Default Value | %SYSTEMROOT%\%WINDIR%\System32\Dllcache
Example
SFCDllCacheDir = %SYSTEMROOT%\Windows\System32\Dllcache
Comments This path must be a local path. This entry also allows environment variables.

Important

  • You must put quotation marks around the value you provide.

Return to top

SFCQuota

Specifies the cache size of the Dllcache file stored on the system hard disk.

Syntax | SFCQuota = size in MB (hexadecimal)
Values | size in MB (hexadecimal)
Default Value | 0xFFFFFFFF
Example
SFCQuota = FFFFFFFF
Comments | If you specify 0xFFFFFFFF, this entry caches all system files in the Dllcache folder.

Return to top

SFCShowProgress

Specifies whether System File Checker displays a progress meter during file system scans.

Syntax | SFCShowProgress = 0 | 1
Values 0

Does not display progress meter during file system scans.

1

Displays progress meter during file system scans.
Default Value | 0
Example
SFCShowProgress = 1

Return to top


[SystemRestore] (Unattend.txt)

banner

[SystemRestore]

Answer File = Unattend.txt

The [SystemRestore] section contains entries for specifying the System Restore feature.

Entry | Description
CheckpointCalendarFrequency | Specifies the calendar frequency with which Setup creates automatic system checkpoints or restore points.
CheckpointSessionFrequency | Specifies the session length frequency after which Setup creates an automatic system checkpoint or restore point.
MaximumDataStorePercentOfDisk | Specifies the maximum percentage of the hard disk to use for the System Restore datastore.
RestorePointLife | Specifies the maximum age of a restore point before Setup automatically purges it from the datastore.

Sample

This sample demonstrates one use of the [SystemRestore] section of Unattend.txt.

[SystemRestore]
CheckpointCalendarFrequency = 2
CheckpointSessionFrequency = 10
MaximumDataStorePercentOfDisk = 25
RestorePointLife = 10

CheckpointCalendarFrequency

Specifies the calendar frequency with which Setup creates automatic system checkpoints or restore points.

Syntax | CheckpointCalendarFrequency = days
Value days

An integer.
Default Value | 1
Registry entry HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\RPGlobalInterval
Example
CheckpointCalendarFrequency = 2
Comments | Setup calculates the time since the last restore point, converts this entry to its equivalent number of seconds, and then writes that value to the registry. CheckpointCalendarFrequency is checked before CheckpointSessionFrequency.

Return to top

CheckpointSessionFrequency

Specifies the session length frequency after which Setup creates an automatic system checkpoint or restore point.

Syntax | CheckpointSessionFrequency = hours
Value hours

An integer.
Default Value | 10
Registry entry HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\RPSessionInterval
Example
CheckpointSessionFrequency = 10
Comments | Setup calculates the time since the last restore point, converts this entry to its equivalent number of seconds, and then writes that value to the registry. CheckpointCalendarFrequency is checked before CheckpointSessionFrequency.

Return to top

MaximumDataStorePercentOfDisk

Specifies the maximum percentage of the hard disk to use for the System Restore datastore.

Syntax | MaximumDataStorePercentOfDisk = disk_percentage
Value disk_percentage

A two-digit integer.
Default Value | 12
Registry entry HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\DiskPercent
Example
MaximumDataStorePercentOfDisk = 25
Comments | If the size of the datastore is minimal, Setup might purge restore points before they reach the maximum age set by RestorePointLife.

Return to top

RestorePointLife

Specifies the maximum age of a restore point before Setup automatically purges it from the datastore.

Syntax | RestorePointLife = integer
Value days

An integer.
Default Value | 30
Registry entry HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\RPLifeInterval
Example
RestorePointLife = 10
Comments | Setup converts this entry to its equivalent number of seconds and writes that value to the registry.

Return to top


[TapiLocation] (Unattend.txt, Sysprep.inf)

banner

[TapiLocation]

Answer File = Unattend.txt and Sysprep.inf

The [TapiLocation] section contains entries for specifying the telephony API (TAPI). It is valid only if a modem is present on the computer.

If you use the Sysprep.inf file with Sysprep, the modem information (TAPI) and the Networking screens do not display during Mini-Setup. Setup uses the default networking components if you do not configure the networking components and if you do not specify them in Sysprep.inf.

To prevent the end user from being prompted for TAPI information during Windows Welcome, you can set TAPI location information in advance, and then set TapiConfigured to Yes.

Entry | Description
AreaCode | Specifies the area code for the computer's location.
CountryCode | Specifies the country/region code to use for telephony.
Dialing | Specifies the type of dialing to use for the telephony device in the computer.
LongDistanceAccess | Specifies the number to dial to gain access to an outside line, such as 9.

Sample

This sample demonstrates one use of the [TapiLocation] section of Unattend.txt.

[TapiLocation]
AreaCode = 555
CountryCode = 030
Dialing = Tone
LongDistanceAccess = 9

AreaCode

Specifies the area code for the computer's location.

Syntax | AreaCode = area code string
Value | area code string
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Telephony\Locations\Location1\AreaCode
Example
AreaCode = 555

Return to top

CountryCode

Specifies the country/region code to use for telephony.

Syntax | CountryCode = country/region code number
Value | country/region code number
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Telephony\Locations\Location1\Country
Example
CountryCode = 030
Comments For example, use 1 for the United States. For more information, search on the Internet for "ISO 3166" for a list of valid country or region codes, or visit the International Telecommunication Union Survey Web site at http://www.itu.int

In some software modem drivers, particularly those used in portable computers, the default modem location is set to "USA." To make sure that the correct location is chosen, use one of the following methods:

Method 1: Before running Setup Manager, add the following section to Unattend.txt and set CountryCode equal to the appropriate number.

[TapiLocation]
CountryCode = number

Method 2: After using Setup Manager to create a configuration set, add the following section to Unattend.txt in your configuration set and set CountryCode equal to the appropriate number.

[TapiLocation]
CountryCode = number

Method 3: In Audit mode, change the modem location from "USA" to the correct country or region before running Sysprep -reseal:

  1. In Device Manager, open the Properties dialog box for the modem.
  2. Click Advanced.
  3. If the Country/Region list box appears below Extra Settings, select the correct country/region code.
  4. In Control Panel, Phone and Modem Options, delete any TAPI locations that may be present in Dialing Rules.

You may also delete the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Telephony\Locations\LocationN

Return to top

Dialing

Specifies the type of dialing to use for the telephony device in the computer.

Syntax Dialing = Tone | Pulse
Values Tone

Specifies dialing with a multifrequency tone, such as a push-button phone.

Pulse

Specifies dialing with transmitting pulses of electricity, such as a rotary dial phone.
Example
Dialing = Tone

Return to top

LongDistanceAccess

Specifies the number to dial to gain access to an outside line, such as 9.

Syntax | LongDistanceAccess = number to get outside line
Value | number to get outside line
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Telephony\Locations\Location1\LongDistanceAccess
Example
LongDistanceAccess = 9

Return to top


[TerminalServices] (Unattend.txt)

banner

[TerminalServices]

Answer File = Unattend.txt

The [TerminalServices] section contains entries for configuring Terminal Services features (Terminal Server and Remote Desktop) in Windows XP and the Windows Server 2003 family.

Terminal Server applies only to Windows Server 2003, Enterprise Edition, Windows Server 2003, Datacenter Edition, and the 64-bit editions of the Windows Server 2003 family.

To install and enable Terminal Server (also called Terminal Services in Application Server mode), use the TerminalServer entry in the [Components] section. To change the permissions settings for a Terminal Server installation, use the PermissionsSetting entry in the [TerminalServices] section.

Windows XP Professional and the Windows Server 2003 family install Remote Desktop (also called Terminal Services in Remote Administration mode), but display it by default. To enable Remote Desktop during unattended Setup, set AllowConnections to 1. Windows XP Home Edition does not provide the Remote Desktop feature.

Entry | Description
AllowConnections | Specifies whether Remote Desktop (also called Terminal Services in Remote Administration mode) enables connections from other computers.
LicensingMode | Configures how Terminal Services manages its Client Access Licenses (CALs).
PermissionsSetting | Enables administrators to choose the security mode for Terminal Server users during terminal server sessions.

Sample

This sample demonstrates one use of the [TerminalServices] section of Unattend.txt.

[TerminalServices]
AllowConnections = 0
LicensingMode = PerUser
PermissionsSetting = 1

AllowConnections

Specifies whether Remote Desktop (also called Terminal Services in Remote Administration mode) enables connections from other computers.

Syntax | AllowConnections = 0 | 1
Values 0

Disables Remote Desktop on the computer.

1

Enables Remote Desktop during unattended Setup.
Default Value | 0
Example
AllowConnections = 0
Comments Any member of the Windows Server 2003 family installs Remote Desktop (also called Terminal Services in Remote Administration mode) and enables it by default. If you set TerminalServer to On in the [Components] section of the answer file, setting AllowConnections to 0 installs Terminal Server without enabling it.

Windows XP Professional and Windows XP Home Edition install the Remote Desktop feature by default but do not enable it.

Return to top

LicensingMode

Configures how Terminal Services manages its Client Access Licenses (CALs).

Syntax | LicensingMode = PerDevice | PerUser
Values PerDevice

Configures Terminal Server to require that each connected device has a valid Terminal Server Client Access License (CAL). If the client has a Terminal Server CAL, it can access more than one Terminal Server.

PerUser

Configures Terminal Server to provide one Terminal Server CAL for each active user.
Default Value | PerDevice
Example
LicensingMode = PerDevice
Comments For more information, see "Terminal Services Licensing" in the Windows Server 2003 Help.

Important

  • Setup ignores LicensingMode unless you enable Terminal Server. For more information, see TerminalServer in the [Components] section.

Return to top

PermissionsSetting

Enables administrators to choose the security mode for Terminal Server users during terminal server sessions.

Syntax | PermissionsSetting = 0 | 1
Values 0

Grants Terminal Server users the same permissions as the users of Windows 2000, Windows XP, or the Windows Server 2003 family. Note that some applications written for Windows NT 4.0 or earlier operating systems might not run correctly in this security mode.

1

Grants Terminal Server users the same permissions as the users of Terminal Server 4.0. End users can continue running previous application versions that might require additional user permissions. Note, however, that using this option bypasses some of the security enhancements in Windows XP and the Windows Server 2003 family, and grants end users access to critical registry and system file locations.
Default Value | 0
Example
PermissionsSetting = 1
Comments By default, Setup enables Terminal Server in Full Security mode, which grants Terminal Server users the same permissions as members of the User group and provides the most secure environment in which to run applications. However, some applications not certified for Windows 2000, Windows XP, or the Windows Server 2003 family require write access to certain parts of HKLM and to certain system directories. Granting these additional permissions may enable end users to delete or change vital settings under HKLM and/or system files.

Important

  • Setup ignores PermissionsSetting unless you enable Terminal Server. For more information, see TerminalServer in the [Components] section.

Return to top


[UserData] (Unattend.txt, Sysprep.inf)

banner

[UserData]

Answer File = Unattend.txt and Sysprep.inf

The [UserData] section contains entries for specifying user settings during Setup.

Entry | Description
ComputerName | Specifies the computer name.
FullName | Specifies the end user’s full name.
OrgName | Specifies an organization’s name.
ProductKey | Specifies the Product Key for each unique installation of Microsoft® Windows®.

Sample

This sample demonstrates one use of the [UserData] section of Unattend.txt.

[UserData]
ComputerName = MYCOMPUTER
FullName = "Pat Coleman"
OrgName = "Woodgrove Bank"
ProductKey = "12345-ABCDE-12345-ABCDE-12345"

ComputerName

Specifies the computer name.

Syntax | ComputerName = computer_name
Value | computer_name
Registry subkey HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
ComputerName\ComputerName
Example
ComputerName = MYCOMPUTER
Comments

If the ComputerName entry is empty or missing, the end user must enter a computer name. If the value is *, Setup generates a random computer name based on the organization name specified.

If computer_name is longer than 63 characters, the string truncates to 63 characters.

Return to top

FullName

Specifies the end user’s full name.

Syntax | FullName = string
Value | string
Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\
CurrentVersion\RegisteredOwner
Example
FullName = "Pat Coleman"
Comments | If the entry is empty or missing, the end user must enter a name, so that Setup can finish unattended.

Return to top

OrgName

Specifies an organization’s name.

Syntax | OrgName = string
Value | string
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\
CurrentVersion\RegisteredOrganization
Example
OrgName = "Woodgrove Bank"

Return to top

ProductKey

Specifies the Product Key for each unique installation of Windows.

Syntax | ProductKey = "xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"
Value | "xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"
Example
ProductKey = "12345-ABCDE-12345-ABCDE-12345"
Comments

Each x is either an alphabetic character or a number. Requires the quotation marks and the hyphens.

Important

  • You must always specify a value for the ProductKey entry.
  • The Product Key that you use to activate the installation must match the number on the Certificate of Authenticity (COA) sticker that accompanies the retail product or that is physically attached to the computer case by the original equipment manufacturer (OEM).
  • Standard licensing agreements specify that you can use a given Product Key only to activate one installation of Windows XP on one computer. Windows Product Activation (WPA) enforces this requirement.
  • If you preinstall Windows XP or Windows Server 2003 family under a volume license agreement, consult your specific license agreement to determine the number of installations allowed per Product Key.
  • When using the Unattend.txt file, this entry assigns the same Product Key to all computers on which you install Windows XP or a member of the Windows Server 2003 family.
  • When using the Unattend.txt file, enter the ProductKey in both the Unattend.txt file and the Sysprep.inf file. Sysprep deletes the ProductKey entry in the Unattend.txt file and replaces it with the entry specified in Sysprep.inf.

Return to top


[Unattended] (Unattend.txt)

Answer File = Unattend.txt

The [Unattended] section for Unattend.txt contains entries for running Setup. For the Sysprep.inf version, see [Unattended] (Sysprep.inf).

Required in Unattend.txt file. Otherwise, Setup ignores Unattend.txt.

Entry | Description
ActivateProxy | Specifies the proxy settings to use when connecting to the Internet to activate this installation of Windows XP, if you set AutoActivate to Yes.
AutoActivate | Specifies whether Setup attempts to activate this installation of Windows XP automatically through an existing Internet connection.
ComputerType | Specifies the type of custom hardware abstraction layer (HAL) that Setup Loader loads and installs by text-mode Setup.
CrashDumpSetting | Specifies the creation and type of the dump file.
DisableVirtualOemDevices | Specifies whether to load virtual original equipment manufacturer (OEM) devices during Setup.
DUDisable | Specifies whether to connect to the Windows Update site to download updates during Setup.
DUShare | Specifies the location for downloaded Dynamic Update .cab files.
DUStopOnError | Specifies whether to stop the Windows Update process when an error is detected.
DriverSigningPolicy | Specifies how to process unsigned drivers during unattended Setup.
ExtendOemPartition | Specifies whether to extend the partition on which you install Windows.
FactoryMode | Specifies whether %SYSTEMDRIVE%\Sysprep\Factory.exe runs on first boot.
FileSystem | Specifies whether to convert the primary partition to NTFS or to leave it alone.
ForceHALDetection | Specifies whether text-mode Setup examines the operating system and determines the most appropriate hardware abstraction layer (HAL) to install during an upgrade.
Hibernation | Specifies whether to enable the hibernation option in the Power Options control panel.
KeyboardLayout | Specifies the type of keyboard layout to install during text-mode Setup.
NTUpgrade | Specifies whether Setup upgrades a previous version of Windows NT 3.51, Windows NT 4.0, Windows 2000, Windows XP, or the Windows Server 2003 family.
OemFilesPath | Specifies the path to the \$OEM$ folder (containing OEM files) if it does not exist under the i386 folder of the distribution share point.
OemPnPDriversPath | Specifies the path to one or more folders that contain Plug and Play drivers not distributed in Drivers.cab on the Windows product CD.
OemPreinstall | Specifies whether Setup installs its files from distribution folders.
OemSkipEula | Specifies whether the end user must accept the End-User License Agreement (EULA) included with Windows.
OverwriteOemFilesOnUpgrade | Specifies whether to overwrite OEM-supplied files that have the same name as Windows XP or Windows Server 2003 operating system files during an unattended upgrade.
Repartition | Specifies whether to delete all partitions on the first drive of the client computer and to reformat the drive with the NTFS file system.
TargetPath | Determines the installation folder in which you install Windows.
UnattendMode | Defines the unattended mode to use during GUI-mode Setup.
UnattendSwitch | Specifies whether Setup skips Windows Welcome or Mini-Setup when preinstalling Windows XP Home Edition or Windows XP Professional using the CD boot method.
WaitForReboot | Specifies whether the computer waits 15 seconds after GUI-mode Setup finishes.
Win9xUpgrade | Specifies whether Setup upgrades previous installations of Windows 98, Windows 98 Second Edition, or Windows Millennium Edition to either Windows XP Home Edition or Windows XP Professional, as specified in the [Win9xUpg] section.

Sample

This sample demonstrates one use of the [Unattended] section of Unattend.txt.

[Unattended]
ActivateProxy = Proxy
AutoActivate = Yes
ComputerType = "OEM HAL", OEM
CrashDumpSetting = 0
DisableVirtualOemDevices = Yes
DUDisable = No
DUShare = "%SYSTEMDRIVE%\DU_Cabs"
DUStopOnError = Yes
DriverSigningPolicy = Block
ExtendOemPartition = 1000
FactoryMode = Yes
FileSystem = ConvertNTFS
ForceHALDetection = Yes
Hibernation = Yes
KeyboardLayout = Us
NTUpgrade = Yes
OemFilesPath = "%SYSTEMDRIVE%\OEM_Files"
OemPnPDriversPath = MyFolder1;MyFolder2
OemPreinstall = Yes
OemSkipEula = No
OverwriteOemFilesOnUpgrade = Yes
Repartition = Yes
TargetPath = *
UnattendMode = FullUnattended
UnattendSwitch = Yes
WaitForReboot = Yes
Win9xUpgrade = Yes

ActivateProxy

Specifies the proxy settings to use when connecting to the Internet to activate this installation of Windows XP, if you set AutoActivate to Yes.

Syntax ActivateProxy = section_name | Proxy
Values section_name
Proxy
Example
ActivateProxy = Proxy
Comments If section_name is Proxy, Windows Product Activation (WPA) uses the proxy settings specified in the [Proxy] section. If section_name is anything else, WPA uses the proxy settings specified in [section_name] in the Unattend.txt file. The entries in [section_name] must match the syntax specified in the [Proxy] section.

Note

  • If your network uses Web Proxy Auto-Discovery (WPAD), you may not need to set the proxy explicitly.

Return to top

AutoActivate

Specifies whether Setup attempts to activate this installation of Windows XP automatically through an existing Internet connection.

Syntax | AutoActivate = Yes | No
Values Yes

Attempts to activate this installation of Windows XP during unattended Setup through an existing Internet connection on the computer.

No

Requires the end user to activate Windows XP either through an Internet connection or by telephone.
Default Value | No
Example
AutoActivate = Yes
Comments You must specify a valid Product Key in the ProductKey entry of the [UserData] section. If the Internet connection is through a firewall, you may need to specify the relevant proxy settings in the ActivateProxy entry.

Important

  • Always requires a Product Key.
  • The Product Key that you use to activate this installation using Windows Product Activation (WPA) must match the number on the Certificate of Authenticity (COA). The original equipment manufacturer (OEM) packages the COA with the retail product or affixes it to the computer case.
  • Standard licensing agreements specify that you can use a given Product Key to activate only one installation of Windows XP on one computer. WPA enforces this requirement.
  • If you use Winnt.exe to install Windows, you must set UnattendSwitch to Yes.
  • Setting AutoActivate to Yes does not guarantee successful activation of this installation of Windows XP. For example, the activation attempt will fail if the computer cannot successfully connect to the Internet.

Return to top

ComputerType

Specifies the type of custom hardware abstraction layer (HAL) that Setup Loader loads and installs by text-mode Setup.

Syntax ComputerType = HAL_description [, Retail | OEM]
Values

HAL_description [, Retail | OEM]

Retail

Informs Setup that the HAL to install is part of Windows XP or Windows Server 2003 family.

OEM

Indicates that the HAL to load is OEM-supplied. If this is the case, you must also list the driver name in the [OEMBootFiles] section of the Unattend.txt file.
Examples
ComputerType = "OEM HAL", OEM
ComputerType = "Advanced Configuration and Power Interface (ACPI) PC", Retail
Comments This entry is valid only when the value of OemPreinstall is Yes. If the ComputerType entry is not present, Setup attempts to detect the type of computer and install the appropriate retail HAL.

The HAL_description string identifies the Hardware Abstraction Layer (HAL) to install. It must match one of the strings in the [Computer] section of TxtSetup.sif (for a retail HAL) or TxtSetup.oem (for an OEM HAL).

Return to top

CrashDumpSetting

Specifies the creation and type of the dump file.

Syntax | CrashDumpSetting = 0 | 1 | 2 | 3
Values 0

Does not create a dump file.

1

Complete Memory Dump: Records the entire contents of system memory to %SYSTEMROOTt%\Memory.dmp when the system stops unexpectedly. If you choose this option, you must have a paging file on the boot volume large enough to hold all of the physical random access memory (RAM) plus 1 megabyte (MB).

2

Kernel Memory Dump: Records only kernel memory to %SYSTEMROOTt%\Memory.dmp when the system stops unexpectedly. This speeds up the process of recording information in a log. Depending on the amount of RAM in your computer, you must have 50 MB to 800 MB available for the paging file on the boot volume.

3

Small Memory Dump (64K): Records the smallest set of useful information that can help identify the problem to %SYSTEMROOTt%\Mini.dmp. This option requires a paging file of at least 2 MB on the boot volume of your computer and specifies that Setup creates a new file each time the system stops unexpectedly.
Default Value Windows XP Home Edition and Windows XP Professional: 3
Windows Server 2003 family: 1
Example
CrashDumpSetting = 0
Comments | When the system fails, you can create a dump file that contains information useful for debugging. Dump file types vary by size. The system checks for available space on the boot volume and writes the largest possible dump file.

Return to top

DisableVirtualOemDevices

Specifies whether to load virtual OEM devices during Setup.

Syntax | DisableVirtualOemDevices = Yes | No
Values Yes

Disables loading virtual OEM devices during Setup.

No

Does not disable loading virtual OEM devices during Setup.
Default Value | Yes for preinstallation; No otherwise
Example
DisableVirtualOemDevices = Yes
Comments An example of a virtual OEM device is a RAM disk that has mass-storage drivers, related .inf files, and so on.

During attended Setup, you can disable loading of virtual OEM devices by pressing F4 at the prompt to press the F6 key.

Return to top

DUDisable

Specifies whether to connect to the Windows Update site to download updates during Setup.

Syntax | DUDisable = Yes | No
Values Yes

Instructs Setup not to connect to the Windows Update site.

No

Instructs Setup to connect to the Windows Update site to download any available Windows XP Setup updates. Setup also downloads any necessary drivers that are not on the Windows XP CD-ROM.
Default Value | Yes
Example
DUDisable = No
Comments Specifies whether Setup connects to the Windows Update site to download any available Windows Setup updates or necessary drivers that are not on the Windows CD-ROM.

DUDisable is equivalent to the command:

winnt32 /unattend /dudisable

Setup disables dynamic updates by default so corporate administrators can more easily standardize on a known set of Windows system components.

Return to top

DUShare

Specifies the location for downloaded Dynamic Update .cab files.

Syntax | DUShare = path_to_downloaded_cabs
Values path_to_downloaded_cabs

Specifies the location for all downloaded Dynamic Update .cab files.
Example
DUShare = "%SYSTEMDRIVE%\DU_Cabs"
Requires | You must run winnt32 /DUPrepare:path_to_downloaded_cabs before using this entry.
Comments | When a path is specified, the Dynamic Update wizard page is not shown and Setup does not try to connect to Windows Update. Instead, Setup uses the Dynamic Update .cab files from this share.

Return to top

DUStopOnError

Specifies whether to stop the Windows Update process when an error is detected.

Syntax | DUStopOnError = Yes | No
Values Yes

Stops the Windows Update process when an error is detected.

No

Does not stop the Windows Update process when an error is detected.
Example
DUStopOnError = Yes
Comments | Windows Update errors include any failure to process Windows Update files, or the inability to connect to Windows Update. By default, the Windows Update process stops when an error is detected.

Return to top

DriverSigningPolicy

Specifies how to process unsigned drivers during unattended Setup.

Syntax | DriverSigningPolicy = Block | Warn | Ignore
Values Block

Setup does not install the unsigned device driver.

Warn

Setup stops the installation and prompts the end user for input before accepting the unsigned device driver.

Ignore

Setup continues despite the unsigned driver.
Default Value | Warn
Example
DriverSigningPolicy = Block
Comments Signed drivers have gone through the Microsoft driver testing and signing process to ensure they are compatible with Windows XP and the Windows Server 2003 family.

Important

  • Microsoft strongly advises against using DriverSigningPolicy = Ignore unless you have fully tested the device driver in your environment and are sure that it works properly. Using unsigned drivers increases the risk of device driver problems that can affect the performance or stability of the computer.
  • If you are using DriverSigningPolicy = Ignore and you attempt to install a newer, unsigned copy of a driver that distributed with Windows XP or the Windows Server 2003 family, Setup installs the signed Windows XP driver instead of the unsigned drivers, in accordance with the ranking process used by the operating system.
  • A catalog certificate (.cat) file authenticates a driver signature. Microsoft can only use the given certificate to sign drivers for a finite length of time, generally six months. However, as long as you have a digitally signed driver, the subsequent expiration date of the certificate does not affect the status of the driver. A driver signature does not expire, even after the certificate used to sign the driver has expired.

For more information, see:

  • Windows Hardware and Driver Central Web site (http://www.microsoft.com/whdc/)
  • Driver Signing for Windows (http://www.microsoft.com/whdc/hwdev/driver/digitsign.mspx)

For more information about driver ranking and how Setup chooses the correct driver, see the Microsoft Device Development Kit (http://www.microsoft.com/ddk/).

Return to top

ExtendOemPartition

Specifies whether to extend the partition on which you install Windows.

Syntax ExtendOemPartition = 0 | 1 | extra_size_in_MB
Values 0

Setup does not extend the partition.

1

Setup extends the partition to fill out the hard disk.

extra_size_in_MB

Setup increases the current partition size by this amount. This is useful if you want to configure more than one partition on the hard disk.
Example
ExtendOemPartition = 1000
Comments This entry causes Setup to extend this destination partition into any available unpartitioned space that physically follows it on the disk.

ExtendOemPartition automatically leaves the last cylinder on the hard disk free to allow dynamic disk support.

Important

  • You can extend only NTFS file system partitions.
  • When you use ExtendOEMPartition in Sysprep.inf for imaged computers, the destination computer’s hard disk must be the same size or larger than the hard disk of the original master installation.
  • The partition that you want to extend must have unpartitioned space available following the partition.

If your manufacturing process requires FAT32, use the Oformat command-line tool included in the OEM Preinstallation Kit to format the hard disk so that you configure it for NTFS. Use the Convert command-line tool to convert the file system.

You can also convert the partition during text-mode Setup by setting the FileSystem entry in the [Unattended] section of Unattend.txt to ConvertNTFS. FileSystem is not a valid entry in Sysprep.inf. However, the hard drive performs better if you use Convert with Oformat and/or Cvtarea instead of the FileSystem entry. For more information, see the Legacy Methods section of NTFS Preinstallation and Windows XP.

You can also use the ExtendPartition entry in the [ComputerSettings] section of Winbom.ini to extend the partition using the Factory tool.

Return to top

FactoryMode

Specifies whether %SYSTEMDRIVE%\Sysprep\Factory.exe runs on first boot.

Syntax | FactoryMode = Yes | No
Value Yes

%SYSTEMDRIVE%\Sysprep\Factory.exe runs on first boot.

No

%SYSTEMDRIVE%\Sysprep\Factory.exe does not run on first boot. (Default)
Default Value | Yes
Example
FactoryMode = Yes
Comments | Use this entry when performing a clean install of the operating system as the first step in building a master installation, which you then plan to duplicate onto multiple destination computers. FactoryMode = Yes will start the computer into Factory mode, where system configuration can be done before imaging. You must place the OPK tools in the %SYSTEMDRIVE%\Sysprep folder.

Return to top

FileSystem

Specifies whether to convert the primary partition to NTFS or to leave it alone.

Does not change the primary partition file system.

Syntax FileSystem = ConvertNTFS LeaveAlone
Values ConvertNTFS

Converts the primary partition to NTFS.

LeaveAlone
Example
FileSystem = ConvertNTFS
Comments This entry is provided for backward compatibility with the Windows 2000 unattended Setup.

For the Windows XP and Windows Server 2003 family of operating systems, if your manufacturing processes require that you format the hard disk as FAT32, use the Oformat tool to create a FAT32 volume with clusters aligned in an optimal way for later conversion to the NTFS file system. Then use the Convert command-line tool to convert the file system to NTFS.

You can also convert the partition during text-mode Setup by setting the FileSystem entry equal to ConvertNTFS. However, the hard drive performs better if you use Convert with Oformat and/or Cvtarea instead of using the FileSystem entry. For more information, see the Legacy Methods section of NTFS Preinstallation and Windows XP.

Note

  • If you plan to use ExtendOemPartition during Setup, the file system must be NTFS.
  • FileSystem is not a valid entry in Sysprep.inf.

Return to top

ForceHALDetection

Specifies whether text-mode Setup examines the operating system and determines the most appropriate hardware abstraction layer (HAL) to install during an upgrade.

Syntax | ForceHALDetection = Yes | No
Values Yes

Installs the most appropriate HAL for the new operating system.

No

Keeps the HAL from the previous operating system.
Default Value | No
Example
ForceHALDetection = Yes
Comments

Important

  • If ForceHALDetection=Yes during an upgrade, Setup may lose some user-specified hardware settings.
  • If ForceHALDetection=No during an upgrade, Setup preserves user-specified hardware settings.

Return to top

Hibernation

Specifies whether to enable the hibernation option in the Power Options control panel.

Syntax | Hibernation = Yes | No
Values Yes

Enables hibernation.

No

Disables hibernation.
Default Value | Yes
Example
Hibernation = Yes
Comments Not supported on the 64-bit versions of the Windows Server 2003 family. This setting adds Hibernate to the Shutdown menu and creates the Hiberfil.sys file.

Notes

  • To keep the size of your image file as small as possible, you may delete the hibernation file (Hiberfil.sys) (if it exists) from your master installation.
  • The Hiberfil.sys file created during hibernation mode is as large as the available random access memory (RAM) on the computer. Before beginning hibernation mode, verify that the amount of free disk space on your computer hard drive is greater than or equal to the amount of RAM in the computer.
  • Setup does not support hibernation if any driver or video card does not support Plug and Play.
  • For Windows Server 2003, Enterprise Edition, Windows Server 2003, Datacenter Edition, you cannot use hibernation if the computer uses Terminal Server or if the Physical Address Extension (PAE) Kernel supports 3 GB or more of memory.

    For more information on the PAE Kernel, see the Microsoft Driver Development Kit (DDK), which you can order from the Microsoft DDK Web site (http://www.microsoft.com/ddk/). You can also read the DDK documentation in the MSDN Library (http://msdn.microsoft.com/library/): Select Windows Development, then Driver Development Kit.

Return to top

KeyboardLayout

Specifies the type of keyboard layout to install during text-mode Setup.

Syntax | KeyboardLayout = layout_description
Value | layout_description
Example
KeyboardLayout = Us
Comments If this entry does not exist, Setup detects and installs a keyboard layout.

This entry must match one of the right-hand strings (in quotation marks) in the [Keyboard Layout] section of TxtSetup.sif.

Return to top

NTUpgrade

Specifies whether Setup upgrades a previous version of Windows NT 3.51, Windows NT 4.0, Windows 2000, Windows XP, or the Windows Server 2003 family.

Syntax NTUpgrade = Yes | No
Values Yes

Upgrades a previous version of Windows. Only these additional Unattend.txt entries are processed: ProductKey, AutoActivate, DUDisable, DUShare, and DUStopOnError

No

Does not upgrade a previous version of Windows.

Example
NTUpgrade = Yes
Comments This entry is valid only for Winnt32.exe.

Note

    To upgrade from Windows 98 or Windows Millennium Edition, use the Win9xUpgrade entry.

Set NTUpgrade = Yes to upgrade the previous Windows installation. If OemPreinstall is Yes, do not set NTUpgrade equal to Yes.

This entry upgrades your previous version of Windows XP, Windows Server 2003 family, Windows 2000, Windows NT 4.0, or Windows NT 3.51. Setup takes all user settings from the previous installation, and does not require end-user intervention.

The following table provides a comprehensive list of valid upgrade scenarios.

Upgrade from | Upgrade to
 | Windows Server 2003, Standard Edition | Windows Server 2003, Enterprise Edition | Windows Server 2003, Datacenter Edition
Windows NT 3.51 Server | No | No | No
Windows NT 4.0 Server (with Service Pack 5) | Yes | Yes | No
Windows NT 4.0 Terminal Server | Yes* | Yes* | No
Windows NT 4.0 Enterprise Edition (with Service Pack 5) | No | Yes | No
Microsoft BackOffice® Small Business Server 4.0/4.5 | No | No | No
Windows 2000 Server | Yes | Yes | No
Microsoft Small Business Server 2000 | No | No | No
Windows 2000 Advanced Server | No | Yes | No
Windows 2000 Datacenter Server | No | No | Yes
Windows Server 2003, Standard Edition | Yes | Yes | No
Windows Server 2003, Enterprise Edition | No | Yes | No
Windows Server 2003, Datacenter Edition | No | No | Yes

* You can upgrade from Windows NT 4.0 Terminal Server Edition or Windows 2000 Application Server mode to Windows Server 2003 family, but Setup will warn you that it does not support Terminal Service Application mode.

Return to top

OemFilesPath

Specifies the path to the \$OEM$ folder (containing OEM files) if it does not exist under the i386 folder of the distribution share point.

Syntax | OemFilesPath =path_to_$OEM$_folder
Value | path_to_$OEM$_folder
Example
OemFilesPath = "%SYSTEMDRIVE%\OEM_Files"
Comments The path can be a UNC name. Enclose path_to_$OEM$_folder in quotation marks if it is a long file name.

For more information about the \$OEM$ folder, if you are a computer manufacturer, see the Microsoft Windows XP OEM Preinstallation Kit (OPK) User Guide. Otherwise, see the Microsoft Windows 2000 Server Deployment Guide.

Return to top

OemPnPDriversPath

Specifies the path to one or more folders that contain Plug and Play drivers not distributed in Drivers.cab on the Windows product CD.

Syntax | OemPnPDriversPath = folder_1_on_system_drive[;folder_2_on_system_drive]...
Values | folder_1_on_system_drive[;folder_2_on_system_drive]...
Example
OemPnPDriversPath = MyFolder1;MyFolder2
Dependency
OEMPreinstall = Yes
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\DevicePath
Comments The folders must contain all the files necessary to install the particular devices: catalog files, .inf files, and drivers.

For example, if you have a folder called \Drivers with subfolders called \Audio and \Net, specify OemPnPDriversPath = drivers\audio;drivers\net in the Unattend.txt file. Setup adds:

  • %SYSTEMDRIVE% to each of the folder names
  • the path for each subfolder to the Plug and Play device search path.

Important

  • The length of the OemPnPDriversPath entry in Unattend.txt must not exceed 4096 characters.
  • You cannot use environment variables to specify the location of a folder.
  • Always use signed drivers. Signed drivers make the operating system more stable and significantly reduce requests for product support.

When using OemPnPDriversPath in Unattend.txt, be sure that the folders are available during GUI-mode Setup or the end user first-run experience. The easiest way to do this is to place the Plug and Play drivers in the \$OEM$\$1 folder. To prevent end users from inadvertently deleting driver folders located at the root of the drive, you can place drivers under the \$OEM$\$$ folder (for example: $OEM$\$$\PnP\Audio).

If the drivers are not in the Drivers.cab file on the computer's hard disk or in the location specified by OemPnPDriversPath, Setup prompts the end user for the location of the drivers during the first boot of the machine, before Windows Welcome or Mini-Setup.

You can also use the [PnPDrivers] section in Winbom.ini to update drivers on a previously-created image of the installed operating system.

Return to top

OemPreinstall

Specifies whether Setup installs its files from distribution folders.

Syntax OemPreinstall = Yes | No
Values Yes

Setup copies the subfolders and files contained in the \platform\$oem$ folder.

No

Setup does not copy these files.
Example
OemPreinstall = Yes
Comments

Note

  • If OemPreinstall = Yes, do not set NTUpgrade to Yes.
  • If OemPreinstall = Yes, unattended Setup automatically stops at the Welcome page. To avoid this pause in your factory environment, set OEMSkipWelcome to 1. Do not distribute any computer with OEMSkipWelcome = 1. Instead, set OEMSkipWelcome to 0 in the Sysprep.inf file you use before delivering the computer to the customer.

Return to top

OemSkipEula

Specifies whether the end user must accept the End-User License Agreement (EULA) included with Windows.

Syntax OemSkipEula = Yes | No
Values Yes

Implies that the person performing the installation has read and agreed to the contents of the license agreement included with the product. It also implies that the end user on whose behalf you install Windows has agreed to the license agreement.

No

Implies that the person performing the installation and the end user have not read and agreed to the license agreement.
Example
OemSkipEula = No
Comments

Important

  • You must not use this entry to remove the Microsoft® End-User License Agreement screen because end users must see and accept it. Use Sysprep to ensure that end users see the EULA when the computer starts for the first time.

Return to top

OverwriteOemFilesOnUpgrade

Specifies whether to overwrite OEM-supplied files that have the same name as Windows XP or Windows Server 2003 family of operating system files during an unattended upgrade.

Syntax | OverwriteOemFilesOnUpgrade =
Values Yes

Overwrites the files if found.

No

Does not overwrite the files if found.
Default Value | Yes
Example
OverwriteOemFilesOnUpgrade = Yes
Comments | This entry is provided for backward compatibility with Windows 2000 unattended Setup.

Return to top

Repartition

Specifies whether to delete all partitions on the first drive of the client computer and to reformat the drive with the NTFS file system.

Syntax Repartition = Yes | No
Values Yes

Deletes all partitions on the first drive and reformats the drive with NTFS.

No

Does not delete partitions or reformat the drive.
Example
Repartition = Yes
Comments

Important

  • Repartition is valid only when performing an unattended Setup by starting the computer from the Windows product CD.

Return to top

TargetPath

Determines the installation folder in which you install Windows.

Syntax TargetPath = * | target_path
Values *

Setup generates a unique folder name for the installation.

target_path

Setup installs to the specified folder.
Example
TargetPath = *
Comments * indicates that Setup generates a unique folder name for the installation. The folder name given is usually Windows, unless that folder already exists. In that case, Setup installs into Windows.x (where x is 0, 1, ... 999) if these folders do not already exist.

The path must use 8.3 file names. be Do not include the drive letter in target_path. If you want to specify the target drive, you must use the /tempdrive command-line switch when you run Winnt32.exe.

Return to top

UnattendMode

Defines the unattended mode to use during GUI-mode Setup.

Syntax | UnattendMode = DefaultHide | FullUnattended | GuiAttended | ProvideDefault | ReadOnly
Values DefaultHide

Specifies that answers in the answer file are defaults. Unlike UnattendMode = ProvideDefault, Setup does not display the user interface to end users if you specify in the answer file all the answers relating to a particular Setup page. If you specify only subsets of the answers on a page, the page appears with the provided answers. The end user can modify any of the answers on the displayed page.

Use UnattendMode = DefaultHide in deployment scenarios where an administrator might want only end users to provide the administrator password on the computer. This behavior is the default if you do not specify unattended mode.

FullUnattended

Specifies a fully unattended GUI-mode Setup. If you do not specify a required Setup answer in the answer file, Setup generates an error.

During an attended Setup, improperly signed hardware drivers generate a warning dialog box. If UnattendMode = FullUnattended, then Setup does not install hardware drivers unless they are properly signed.

Use UnattendMode = FullUnattended in deployment scenarios where you require a complete unattended installation.

GuiAttended

Specifies an attended GUI-mode section of Setup. When specified, the end user must answer all questions in the GUI-mode portion of Setup before Setup finishes.

Use UnattendMode = GuiAttended in preinstallation scenarios when you want to automate only text-mode Setup.

ProvideDefault

Specifies default answers in the answer file. In this case, Setup displays these default answers to the end user, who can change them if they are not appropriate.

Use UnattendMode = ProvideDefault in preinstallation scenarios where the OEM or administrator wants to give the person setting up the computer the option to change the predefined default answers (especially network options).

ReadOnly

Specifies read-only answers in the answer file if the Windows Setup pages containing these answers appear to the end user. Like UnattendMode = ProvideDefault, no user interface appears if the answer file contains all the answers on a page. Unlike UnattendMode = DefaultHide, however, the end user can specify only new answers on a displayed page.

Use UnattendMode = ReadOnly in scenarios where an administrator wants to force specific answers on one page but not others.
Default Value | DefaultHide
Example
UnattendMode = FullUnattended
Comments | The default value is DefaultHide when you do not specify the entry. When you specify this entry, it fully automates text-mode Setup with or without the necessary answers.

Return to top

UnattendSwitch

Specifies whether Setup skips Windows Welcome or Mini-Setup when preinstalling Windows XP Home Edition or Windows XP Professional using the CD boot method.

Syntax | UnattendSwitch = Yes | No
Values Yes

Instructs Setup to skip Windows Welcome.

No

Instructs Setup not to skip Windows Welcome.
Default Value | No
Example
UnattendSwitch = Yes
Comments Use UnattendSwitch only when you perform an unattended Setup with Winnt.exe, Winnt.sif, and the CD boot method. This entry is not necessary if you use Winnt32.exe to run Setup.

Note

  • UnattendSwitch is not the same as the UnattendedInstall entry in the [Data] section of the answer file. UnattendSwitch controls Windows Welcome; UnattendedInstall does not.

Return to top

WaitForReboot

Specifies whether the computer waits 15 seconds after GUI-mode Setup finishes.

Syntax | WaitForReboot = Yes | No
Values Yes

Delays the reboot for 15 seconds after GUI-mode Setup finishes.

No

Restarts immediately after GUI-mode Setup finishes.
Default Value | Yes
Example
WaitForReboot = Yes

Return to top

Win9xUpgrade

Specifies whether Setup upgrades previous installations of Windows 98, Windows 98 Second Edition, or Windows Millennium Edition to either Windows XP Home Edition or Windows XP Professional, as specified in the [Win9xUpg] section.

Syntax | Win9xUpgrade = Yes | No
Values Yes

Instructs Setup to upgrade the Windows installation, if found.

No

Instructs Setup not to upgrade the Windows installation, if found.
Default Value | No
Example
Win9xUpgrade = Yes
Comments This entry is necessary only when using an answer file to upgrade an existing Windows 98 or Windows Millennium Edition computer to Windows XP Home Edition or Windows XP Professional. This entry is valid only for Winnt32.exe.

For more information, see [Uninstall].

Return to top


[Uninstall] (Unattend.txt)

banner

[Uninstall]

Answer File = Unattend.txt

The [Uninstall] section contains entries for allowing end users who upgrade to Windows XP to remove the operating system if they encounter problems.

This section header instructs Setup to create a backup file of the end user's existing operating system. You must specify this section to make the Uninstall feature available.

Important

Consider the following restrictions with the Uninstall feature:

  • Setup does not support Uninstall if the number of partitions or the file system changes.
  • Setup supports Uninstall only for upgrades of Windows 98, Windows 98 Second Edition, or Windows Millennium Edition.
  • End users who upgrade from Windows 4.0 or Windows 2000 to Windows XP Home Edition or Windows XP Professional cannot uninstall the operating system.
  • End users can uninstall the operating system if Setup does not complete successfully.
  • After Uninstall, some applications installed with or upgraded to Windows XP may not work. However, Uninstall does not affect any user data created with the new operating system.

For more information on upgrades from Windows 98, Windows 98 Second Edition, or Windows Millennium Edition, see [Win9xUpg].

Entry | Description
DisableCompression | Specifies whether to compress the files in Backup.cab.
EnableBackup | Specifies whether to create a backup file (Backup.cab) for removing Windows XP Home Edition or Windows XP Professional.
PathForBackup | Specifies the location of the backup files of the previous Windows 98, Windows 98 Second Edition, or Windows Millennium Edition.

Sample

This sample demonstrates one use of the [Uninstall] section of Unattend.txt.

[Uninstall]
DisableCompression = Yes
EnableBackup = Yes
PathForBackup = "%SYSTEMDRIVE%\Backup"

DisableCompression

Specifies whether to compress the files in Backup.cab.

Syntax | DisableCompression = Yes | No | Auto
Values Yes

Does not compress the backup files in Backup.cab, located in the folder specified by PathForBackup. This setting speeds up an upgrade to Windows XP Home Edition or Windows XP Professional.

No

Compresses the files in Backup.cab to approximately 40 percent of their original size.

Auto

Checks the available disk space. If there is sufficient disk space, do not compress the backup files in Backup.cab. If there is not enough disk space for all of these uncompressed files, then compress the files when storing them in Backup.cab.

Default Value | Auto
Example
DisableCompression = Yes
Comments | The [Uninstall.DiskSpaceEstimation] section in Win9xupg.inf controls the compression factor. If EnableBackup = No, Setup ignores this entry.

Return to top

EnableBackup

Specifies whether to create a backup file (Backup.cab) for removing Windows XP Home Edition or Windows XP Professional.

Syntax | EnableBackup = Yes | No
Values Yes

Creates Backup.cab in the folder specified by PathForBackup.

No

Does not create Backup.cab.
Default Value | Yes
Example
EnableBackup = Yes

Return to top

PathForBackup

Specifies the location of the backup files of the previous Windows 98, Windows 98 Second Edition, or Windows Millennium Edition.

Syntax | PathForBackup = path_for_backup_files
Values | path_for_backup_files
Default Value | system_drive:\Undo
Example
PathForBackup = "%SYSTEMDRIVE%\Backup"
Comments

Setup accesses these files if the end user chooses to remove Windows XP Home Edition or Windows XP Professional. In the PathForBackup entry you must specify a location on the computer's hard disk. You cannot specify a network server share or a removable mass-storage device. Enclose path_for_backup_files in quotation marks if it is a long file name.

If EnableBackup = No, Setup ignores this entry.

Return to top


[URL] (Unattend.txt)

banner

[URL]

Answer File = Unattend.txt

The [URL] section contains entries for specifying default Uniform Resource Locator (URL) settings for the browser available in Microsoft® Windows® XP or the Windows Server 2003 family of operating systems. If you do not specify these settings, Setup uses the default for Windows XP or Windows Server 2003 family.

Important

  • Requires BrandIEUsingUnattended = Yes
Entry | Description
AutoConfig | Specifies whether to configure the browser automatically from a server.
AutoConfigJSURL | Specifies the URL of a JScript® file that automatically configures the proxy-server settings for the browser.
AutoConfigURL | Specifies the URL of an .ins file that automatically configures the proxy-server settings for the browser.
Help_Page | Specifies the URL for HTML-based Help.
Home_Page | Specifies the URL for the browser’s default home page.
Quicklink | Specifies shortcuts in the link folder of the [FavoritesEx] section.

Sample

This sample demonstrates one use of the [URL] section of Unattend.txt.

[URL]
AutoConfig = 1
AutoConfigJSURL = http://configserver/autoconfig.js
AutoConfigURL = http://configserver/autoconfig.ins
Help_Page = http://configserver
Home_Page = http://www.msn.com/
Quick_Link_1_Name = "MS HomePage"
Quick_Link_1 = http://www.microsoft.com/
Quick_Link_2_Name = "MS Japan HomePage"
Quick_Link_2 = http://www.microsoft.com/Japan

AutoConfig

Specifies whether to configure the browser automatically from a server.

Syntax AutoConfig = 0 | 1
Values 0

Does not configure the browser settings with an automatic configuration file located on a server.

1

Configures the browser settings with an automatic configuration file located on a server.
Example
AutoConfig = 1

Return to top

AutoConfigJSURL

Specifies the URL of a JScript file that automatically configures the proxy-server settings for the browser.

Syntax | AutoConfigJSURL = URL
Value | URL
Example
AutoConfigJSURL = http://configserver/autoconfig.js

Return to top

AutoConfigURL

Specifies the URL of an .ins file that automatically configures the proxy-server settings for the browser.

Syntax | AutoConfigURL = URL
Value | URL
Example
AutoConfigURL = http://configserver/autoconfig.ins

Return to top

Help_Page

Specifies the URL for HTML-based Help.

Syntax | Help_Page = URL
Value | URL
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Internet Explorer\Main\Star
Example
Help_Page = http://configserver

Return to top

Home_Page

Specifies the URL for the browser’s default home page.

Syntax | Home_Page = URL
Value | URL
Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Internet Explorer\Main\Start Page
Example
Home_Page = http://www.msn.com/

Return to top

Quicklink

Specifies shortcuts in the link folder of the [FavoritesEx] section.

Syntax | Quicklink = site name, URL
Values | site name, URL
Example
Quick_Link_1_Name = "MS HomePage"
Quick_Link_1 = http://www.microsoft.com/
Quick_Link_2_Name = "MS Japan HomePage"
Quick_Link_2 = http://www.microsoft.com/Japan
Comments | This entry is a set of "Quick_Link_N_Name" and "Quick_Link_N," where N is a numerical designation for the site and URL.

Return to top


[WindowsFirewall] (Unattend.txt)

banner

[WindowsFirewall]

Answer File = Unattend.txt and Winbom.ini; WinbomType = Factory

Windows Firewall is a stateful host firewall that discards unsolicited incoming traffic, providing a level of protection for computers against malicious users or programs. To provide better protection for computers connected to any kind of network (such as the Internet, a home network, or an organization network), Windows XP SP2 enables Windows Firewall on all network connections by default.

The [WindowsFirewall] section must be included in your answer file to configure firewall sections and entries in unattended Setup or Sysprep in factory mode.

All of the sections for the Windows Firewall are user defined. For example, the user-defined profile is referenced by the Profiles entry in the [WindowsFirewall] section. Windows Firewall maintains two sets of configurations known as profiles. The Domain profile is used when a computer is a member of a domain, while the Standard profile is used when a computer is not connected to a domain. You may specify a domain type of profile, a standard type, or a profile that applies to both domain and standard. The name of the user-defined profile must match the section name of [WindowsFirewall.profile_name]. See the examples later in this topic.

To configure Windows Firewall settings, you must include the [WindowsFirewall] section along with one or more of the following user-defined sections in the Unattend.txt file:

  • [WindowsFirewall.profile_name]
  • [WindowsFirewall.program_name]
  • [WindowsFirewall.service_name]
  • [WindowsFirewall.portopening_name]
  • [WindowsFirewall.icmpsetting_name]

The [WindowsFirewall] section contains entries for specifying which user-defined profiles to use and for specifying the log file settings.

Entry | Description
Profiles | Specifies the names of the user-defined profiles to use for configuring the Windows Firewall (domain, standard, or both domain and standard.
LogFile | Specifies the location and file name of the Pfirewall.log file.
LogSize | Specifies the maximum size of the Pfirewall.log file.
LogDroppedPackets | Specifies whether to enable logging dropped packets to the Pfirewall.log file.
LogConnections | Specifies whether to enable logging connections to the Pfirewall.log file.

Sample

This sample demonstrates one use of the [WindowsFirewall] section of Unattend.txt. See the examples later in this topic for more details and descriptive user-defined names.

[WindowsFirewall]
Profiles = WindowsFirewall.profile1_name,  WindowsFirewall.profile2_name
LogFile = %WINDIR%\Pfirewall.log
LogSize = 4096
LogDroppedPackets = 1
LogConnections = 1

Profiles

Specifies the names of the user-defined profiles to use for configuring the Windows Firewall. You may specify a domain profile, standard profile, or a profile for both domain and standard. Each profile_name must be unique, and each profile_name must match the name in the [WindowsFirewall.profile_name] section. For more information about Windows Firewall profile types, see Type.

Syntax | Profiles = WindowsFirewall.profile1_name, WindowsFirewall.profile2_name
Value | WindowsFirewall.profile_name
Example
Profiles = WindowsFirewall.standard_profilename, WindowsFirewall.domain_profile_name, WindowsFirewall.Both_types_profile_name
Comments | This is a required entry. The Profiles entry lists the user-defined profiles to configure the Windows Firewall. This entry must match the [WindowsFirewall.profile_name] section name.

Return to top

LogFile

Specifies the location and file name of the Pfirewall.log file.

Syntax | LogFile = path
Value | path
Default | %WINDIR%\Pfirewall.log
Example
LogFile = %WINDIR%\Pfirewall.log
Comments | This is an optional entry. Use this entry to create a log file for troubleshooting.

Return to top

LogSize

Specifies the maximum size of the Pfirewall.log file.

Syntax | LogSize = Size in KB
Value | Size in KB
Default | 4096
Example
LogSize = 4096
Comments | This is an optional entry. Use this entry to limit the size of the log file.

Return to top

LogDroppedPackets

Specifies whether to enable logging dropped packets in the Pfirewall.log file.

Syntax | LogDroppedPackets = 0 | 1
Values 1

Enables logging dropped packets to the Pfirewall.log file.

0

Does not enable logging dropped packets to the Pfirewall.log file.
Default Value | 0
Example
LogDroppedPackets = 0
Comments | This is an optional entry. Use this entry for troubleshooting connection problems.

Return to top

LogConnections

Specifies whether to enable logging connections in the Pfirewall.log file.

Syntax | LogConnections = 0 | 1
Values 1

Enables logging connections to the Pfirewall.log file.

0

Does not enable logging connections to the Pfirewall.log file.
Default Value | 0
Example
LogConnections = 0
Comments | This is an optional entry. Use this entry for troubleshooting connectivity problems.

Return to top

Example of a User-defined Configuration of Windows Firewall

You may configure the Windows Firewall by using the [WindowsFirewall] section and its associated sections and entries to add programs and services, open ports, and enable ICMP settings. This example shows one way to add sections and entries to the Unattend.txt file.

[WindowsFirewall]
Profiles=WindowsFirewall.Standard
LogFile = "%WINDIR%\pfirewall.log"
LogSize = 4096
LogDroppedPackets = 1
LogConnections = 1

[WindowsFirewall.Standard]
Type = 3
Mode = 1
Exceptions = 1
Notifications = 1
MulticastBroadcastResponse = 1
AllowedPrograms = WindowsFirewall.RemoteAssistance
Services = WindowsFirewall.RemoteDesktop
PortOpenings = WindowsFirewall.WebService
IcmpSettings = WindowsFirewall.EchoRequest

[WindowsFirewall.RemoteAssistance]
Program = "%WINDIR%\System32\Sessmgr.exe"
Name = "Remote Assistance"
Mode = 1
Scope = 2
Addresses = "192.168.0.5,LocalSubnet"

[WindowsFirewall.RemoteDesktop]
Type = 2
Mode = 1
Scope = 2
Addresses = "192.168.0.5,LocalSubnet"

[WindowsFirewall.WebService]
Protocol= 6
Port = 80
Name = "Web Server (TCP 80)"
Mode = 1
Scope = 2
Addresses = "192.168.0.5,LocalSubnet"

[WindowsFirewall.EchoRequest]
Type = 8
Mode = 1

Important

  • You need to include quotes around strings with spaces and around strings that use environment variables.

Note

  • You do not need to add the Addresses entry in the previous example. If you add Addresses entry, ensure that there are no spaces.

Example of a User-defined Profile to Disable Windows Firewall

You may disable the Windows Firewall, if you are including a third-party firewall that is active and enabled with your offering. Add the following sections and entries to the Unattend.txt file:

[WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

Note

  • You do not need to include the Type entry in the [WindowsFirewall.TurnOffFirewall] section. The default value of All is applied if there is no Type entry.

Using the Windows Firewall Netfw.inf File to Configure Default Settings

If the end user makes changes to the Windows Firewall settings, and then decides to use the Restore Defaults button on the Advanced tab of the Windows Firewall applet in Control Panel, the default settings are read from the Netfw.inf file. Any configurations made to Windows Firewall settings in Unattend.txt or Winbom.ini are ignored. If you want the Restore Defaults button to restore factory default settings, you must use the Netfw.inf file to customize the Windows Firewall Exceptions list.

For information about how to use the Netfw.inf file to configure the Windows Firewall Exceptions list and default firewall settings, see the white paper on the OPK product CD entitled, Using the Windows Firewall .Inf File in Microsoft Windows XP Service Pack 2.

How Windows Firewall Settings are Configured

When Setup runs it first adds any Windows Firewall settings from Netfw.inf to the registry, and then appends any settings from Unattend.txt. When you run Sysprep – factory, any Windows Firewall settings from Winbom.ini are appended to existing settings in the registry.

Important

  • If you customize the Windows Firewall Exceptions list by using Unattend.txt and then use Winbom.ini to make additional customizations, it is possible to create conflicting entries for a single application. Ensure that entries made by using Winbom.ini do not conflict with entries made earlier by using Unattend.txt.


[WindowsFirewall.<profile_name>] (Unattend.txt

banner

[WindowsFirewall.profile_name]

Answer File = Unattend.txt and Winbom.ini; WinbomType = Factory

Windows Firewall maintains two sets of configurations known as profiles. The Domain profile is used when a computer is a member of a domain, while the Standard profile is used when a computer is not connected to a domain. The [WindowsFirewall.profile_name] section is a user-defined section that is referenced by the [WindowsFirewall] section to make changes to Windows Firewall's default configuration. You must include the [WindowsFirewall] and [WindowsFirewall.profile_name] sections in your answer file to configure the Windows Firewall in unattended Setup. You may specify a domain type of profile, a standard type, or a profile that applies to both domain and standard. You may also include one or more of the following user-defined sections in your answer file.

  • [WindowsFirewall]
  • [WindowsFirewall.program_name]
  • [WindowsFirewall.service_name]
  • [WindowsFirewall.portopening_name]
  • [WindowsFirewall.icmpsetting_name]
Entry | Description
Type | Specifies the type of profile to use for changing the default configuration of the Windows Firewall.
Mode | Specifies whether to enable or disable Windows Firewall.
Exceptions | Specifies whether to enable or disable the Windows Firewall Exceptions list. Windows Firewall blocks all unsolicited, incoming traffic, except traffic that matches entries in the exceptions list.
Notifications | Specifies whether to enable or disable notifications.
MulticastBroadcastResponse | Specifies whether to enable or disable multicast and broadcast packets.
AllowedPrograms | Specifies a list of programs that will not be blocked by the Windows Firewall.
Services | Specifies a list of services that will not be blocked by the Windows Firewall, such as file and print services, remote administration services, and remote desktop services.
PortOpenings | Specifies a list of open ports that will not be blocked by Windows Firewall.
IcmpSettings | Specifies a list of Internet Control Message Protocol (ICMP) message types that will not be blocked by Windows Firewall.

Sample

This sample demonstrates one use of the [WindowsFirewall.profile_name] section of Unattend.txt.

[WindowsFirewall.Standard]
Type = 1
Mode = 1
Exceptions = 1
Notifications = 1
MulticastBroadcastResponse = 1
AllowedPrograms = WindowsFirewall.RemoteAssistance
Services = WindowsFirewall.RemoteDesktop
PortOpenings = WindowsFirewall.WebServer
IcmpSettings = WindowsFirewall.EchoRequest

Type

Specifies the type of profile to use for changing the default configuration of the Windows Firewall.

Syntax | Type = 0 | 1 | 3
Values 0

Specifies a domain type of profile.

1

Specifies a standard type of profile.

3

Specifies both domain and standard profiles.
Default | 3
Example
Type = 3
Comments | This is an optional entry. If you do not specify a value for the Type entry, the default value is applied.

Return to top

Mode

Specifies whether to enable or disable Windows Firewall.

Syntax | Mode = 0 | 1
Values 1

Enables Windows Firewall.

0

Disables Windows Firewall.
Default | 1
Example
Mode = 1
Comments | This is a required entry.

Return to top

Exceptions

Specifies whether to enable or disable the Windows Firewall Exceptions list. Windows Firewall blocks all unsolicited, incoming traffic, except traffic that matches entries in the exceptions list.

Syntax | Exceptions = 0 | 1
Values 1

Enables Windows Firewall Exceptions list.

0

Disables Windows Firewall Exceptions list.
Default | 1
Example
Exceptions = 1
Comments | You can configure Windows Firewall to be enabled with no exceptions, enabled with exceptions, or disabled.

Return to top

Notifications

Specifies whether to enable or disable notifications.

Syntax | Notifications = 0 | 1
Values 1

Enables notifications.

0

Disables notifications.
Default Value | 1
Example
Notifications = 1
Comments | This is an optional entry.

Return to top

MulticastBroadcastResponse

Specifies whether to enable or disable multicast and broadcast packets.

Syntax | MulticastBroadcastResponse = 0 | 1
Values 1

Enables MulticastBroadcastResponse.

0

Disbales MulticastBroadcastResponse.
Default Value | 1
Example
MulticastBroadcastResponse = 1
Comments | This is an optional entry.

Return to top

AllowedPrograms

Specifies a list of programs that will not be blocked by the Windows Firewall.

Syntax | AllowedPrograms = WindowsFirewall.program_name
Value | WindowsFirewall.program_name
Example
AllowedPrograms = WindowsFirewall.RemoteAssistance
Comments | You may include multiple user-defined WindowsFirewall.program_name entries. Each WindowsFirewall.program_name entry references a [WindowsFirewall.program_name] section that defines the path and program name. Each WindowsFirewall.program_name entry must have a unique name, for example, WindowsFirewall.RemoteAssistance.

Return to top

Services

Specifies a list of services that will not be blocked by the Windows Firewall, such as file and print services, remote administration services, and remote desktop services.

Syntax | Services = WindowsFirewall.service_name
Value | WindowsFirewall.service_name
Example
Services = WindowsFirewall.PrintService
Comments | You may include multiple user-defined services. Each service entry references a [WindowsFirewall.service_name] section that defines the type of service, mode, and address. Each service entry must have a unique name.

Return to top

PortOpenings

Specifies a list of open ports that will not be blocked by Windows Firewall.

Syntax | PortOpenings = WindowsFirewall.portopening_name
Value | WindowsFirewall.portopening_name
Example
PortOpenings = WindowsFirewall.WebServer
Comments | You may include multiple user-defined port openings. Each entry references a [WindowsFirewall.portopening_name] section that defines the port. Each entry must have a unique name.

Return to top

IcmpSettings

Specifies a list of Internet Control Message Protocol (ICMP) message types that will not be blocked by Windows Firewall.

Syntax | IcmpSettings = WindowsFirewall.icmpsetting_name
Value | WindowsFirewall.icmpsetting_name
Example
IcmpSettings = WindowsFirewall.EchoRequest
Comments | You may include multiple user-defined ICMP settings. Each entry references a [WindowsFirewall.icmpsetting_name] section that specifies the name and type of ICMP setting. Each entry must have a unique name.

Return to top


[WindowsFirewall.<program_name>] (Unattend.txt)

banner

[WindowsFirewall.program_name]

Answer File = Unattend.txt and Winbom.ini; WinbomType = Factory

Windows Firewall is On by default. In this mode, Windows Firewall drops all unsolicited, incoming traffic, except traffic that matches enabled entries in the Windows Firewall Exceptions list. Some application programs require dynamic ports to be opened in order to function properly. You can change the default settings in Windows Firewall to allow incoming traffic for certain programs by adding each program to the Windows Firewall Exceptions list.

Only programs that require unsolicited, incoming traffic should be added to the Windows Firewall Exceptions list. There is no benefit to adding programs that use only outgoing connections to the Windows Firewall Exceptions list.

The [WindowsFirewall.<program_name>] section is a user-defined section that can be used to add programs to the Windows Firewall Exceptions list. You may add as many programs as necessary. Each program_name must be unique. You must add the [WindowsFirewall.<program_name>] to the [WindowsFirewall.<profile_name>] section. Use the [WindowsFirewall.<program_name>] section with the following sections in your answer file to change the default settings in Windows Firewall.

  • [WindowsFirewall]
  • [WindowsFirewall.profile_name]
  • [WindowsFirewall.service_name]
  • [WindowsFirewall.portopening_name]
  • [WindowsFirewall.icmpsetting_name]
Entry | Description
Program | Specifies the path of a program to be added to the Windows Firewall Exceptions list. This is a required entry.
Name | Specifies the name of a program to be added to the Windows Firewall Exceptions list. This is a required entry.
Mode | Specifies whether to enable or disable an entry in the Windows Firewall Exceptions list.
Scope | Defines the set of limits on which computers (IP addresses) are allowed to send traffic through the specified exception (program, service). The Mode must be set to 1 (on).
Addresses | Specifies the addresses for an entry in the Windows Firewall Exceptions list.

Sample

This sample demonstrates one use of the [WindowsFirewall.program_name] section of Unattend.txt.

[WindowsFirewall.RemoteAssistance]
Program = %WINDIR%\System32\Sessmgr.exe
Name = Remote Assistance
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

Program

Specifies the program's image path. This is the fully qualified path for the file to be added to Windows Firewall's default Exceptions lists. It may include environmental variables, such as %ProgramFiles%.

Syntax | Program = path
Value | path_name
Example
Program = %WINDIR%\system32\sessmgr.exe
Comments | This is a required entry.

Return to top

Name

Specifies the name that is used to represent the entry for Windows Firewall in the Windows Firewall applet in Control Panel.

Syntax | Name = program_name
Value | program_name
Example
Name = MSN Messenger v6.1
Comments | This is a required entry.

Return to top

Mode

Specifies whether an entry added to the Windows Firewall default Exceptions list is either enabled or disabled.

Syntax | Mode = 0 | 1
Values 1

Enables an entry in the Windows Firewall Exceptions list. Ports are dynamically opened in Windows Firewall for the program.

0

Disables an entry in the Windows Firewall Exceptions list. Ports are not dynamically opened in Windows Firewall for the program.
Default | 1
Example
Mode = 1
Comments | This is a required entry.

Return to top

Scope

Defines the set of limits on which computers (IP addresses) are allowed to send traffic through the specified exception (program, service). The Mode must be set to 1 (on).

Syntax | Scope = 0 | 1 | 2
Values 0

Enables unsolicited, incoming traffic with no limitations. Any computer can send traffic through this exception.

1

Enables unsolicited, incoming traffic that matches the exception from any computer on the same local subnet as the network connection on which the traffic was received through Windows Firewall, while dropping unsolicited, incoming traffic from all other computers.

2

Defines a custom scope, which is a collection of IP addresses and subnets. Unsolicited, incoming traffic that matches the exception and originates from a computer in the defined collection is enabled through Windows Firewall.

Default Value | 0
Example
Scope = 192.168.0.5,LocalSubnet
Comments | When enabling Remote Assistance, opening a port, or enabling a program, the set of IP addresses from which the unsolicited, incoming traffic is enabled can be defined using this entry.

Return to top

Addresses

Specifies the IP addresses in the Scope entry.

Syntax | Addresses = IP_addresses
Values | IP_addresses
Example
Addresses = 192.168.0.5,LocalSubnet
Comments | This entry is ignored unless the Scope entry is set to 2.

Return to top


[WindowsFirewall.<service_name>]

banner

[WindowsFirewall.service_name]

Answer File = Unattend.txt and Winbom.ini; WinbomType = Factory

When in normal operation, Windows Firewall opens static ports used by services in its current profile's exception list. Only services that actually require unsolicited, incoming traffic should be added to the Windows Firewall Exceptions list. There is no benefit to adding services that use only outgoing connections to the Windows Firewall Exceptions list. You must add the [WindowsFirewall.service_name] section in the [WindowsFirewall.profile_name] section.

The [WindowsFirewall.service_name] section can be used with the following sections in your answer file to change the default settings in Windows Firewall.

  • [WindowsFirewall]
  • [WindowsFirewall.profile_name]
  • [WindowsFirewall.program_name]
  • [WindowsFirewall.portopening_name]
  • [WindowsFirewall.icmpsetting_name]
Entry | Description
Type | Specifies the type of service to use for changing the default configuration of the Windows Firewall.
Mode | Specifies whether to enable or disable an entry in the Windows Firewall Exceptions lists.
Scope | Defines the set of limits on which computers (IP addresses) are allowed to send traffic through the specified exception. The value of the Mode entry must equal 1 (On).
Addresses | Specifies the addresses for an entry in the Windows Firewall Exceptions lists.

Sample

This sample demonstrates one use of the [WindowsFirewall.service_name] section of Unattend.txt.

[WindowsFirewall.RemoteDesktop]
Type = 2
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

Type

Specifies the type of service to use for changing the default configuration of the Windows Firewall.

Syntax | Type = 0 | 1 | 2 | 4 | 5
Values 0

Specifies file and print sharing.

1

Specifies UPnP framework.

2

Specifies remote desktop service.

4

Specifies remote administration service.

5

Specifies all services.
Default | 5
Example
Type = 5
Comments | This is a required entry.

Return to top

Mode

Specifies whether an entry added to the Windows Firewall Exceptions list is either enabled or disabled.

Syntax | Mode = 0 | 1
Value 1

Enables an entry in the Windows Firewall Exceptions list.

0

Disables an entry in the Windows Firewall Exceptions list.
Default | 1
Example
Mode = 1
Comments | This is a required entry.

Return to top

Scope

Defines the set of limits on which computers (IP addresses) are allowed to send traffic through the specified exception. The value of the Mode entry must equal 1 (On).

Syntax | Scope = 0 | 1 | 2
Values 0

Enables unsolicited, incoming traffic with no limitations. Any computer can send traffic through this exception.

1

Enables unsolicited, incoming traffic that matches the exception from any computer on the same subnet as the network connection on which the traffic was received through Windows Firewall, while dropping unsolicited, incoming traffic from all other computers.

2

Defines a custom scope, which is a collection of IP addresses and subnets, as specified in the Addresses entry. Unsolicited, incoming traffic that matches the exception and originates from a computer in the defined collection is enabled through Windows Firewall.
Default Value | 0
Example
Scope = 192.168.0.5,LocalSubnet
Comments | When enabling a service, the set of IP addresses from which the unsolicited, incoming traffic is enabled can be defined by using this entry.

Return to top

Addresses

Specifies the IP addresses in the Scope entry.

Syntax | Addresses = IP_address1, IP_address2
Values | IP_address
Example
Addresses = 192.168.0.5,LocalSubnet
Comments | This entry is ignored unless Scope is set to 2.

Return to top


[WindowsFirewall.<portopening_name>]

banner

[WindowsFirewall.portopening_name]

Answer File = Unattend.txt and Winbom.ini; WinbomType = Factory

When in normal operation, Windows Firewall statically opens ports that are included in its current profile's exceptions list. It is generally recommended that programs be added to the exceptions list, instead of statically opening ports. This enables Windows Firewall to open and close ports dynamically and to minimize the number of ports open at any one time. There are scenarios in which ports need to be opened statically. For example, a static port may need to be opened in order for a Windows service to receive unsolicited, incoming traffic. To support these scenarios, you have the ability to add static ports to the Windows Firewall Exceptions list by using the [WindowsFirewall.portopening_name] section. You must add this section to the [WindowsFirewall.profile_name] section.

The [WindowsFirewall.portopening_name] section can be used with the following sections in your answer file to change the default settings in Windows Firewall:

  • [WindowsFirewall]
  • [WindowsFirewall.profile_name]
  • [WindowsFirewall.program_name]
  • [WindowsFirewall.service_name]
  • [WindowsFirewall.icmpsetting_name]
Entry | Description
Protocol | Specifies the protocol of a port. A port is specified by the combination of a protocol and a port number. The protocol must be either TCP or UDP.
Port | Specifies the port number. A port is specified by the combination of a protocol and a port number. The port number must be between 1 and 65535 inclusive.
Name | Specifies the friendly name of a port to be added to the Windows Firewall Exceptions list. This descriptive name is used to represent the entry for Windows Firewall in Control Panel.
Mode | Specifies whether to enable or disable an entry in the Windows Firewall Exceptions lists.
Scope | Defines the set of limits on which computers (IP addresses) are allowed to send traffic through the specified exception. The value of the Mode entry must equal 1 (On).
Addresses | Specifies the addresses for an entry in the Windows Firewall Exceptions list.

Sample

This sample demonstrates one use of the [WindowsFirewall.portopening_name] section of Unattend.txt.

[WindowsFirewall.WebService]
Protocol= 18
Port = 80
Name = Web Server (TCP 80)
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

Protocol

Specifies the protocol of a port. A port is specified by the combination of a protocol and a port number. The protocol must be either TCP or UDP.

Syntax | Protocol = 6 | 17 | 18
Values 6

Specifies a TCP port.

17

Specifies a UDP port.

18

Specifies both TCP and UDP type ports.

Default | 18
Example
Protocol = 18
Comments | This is a required entry.

Return to top

Port

Specifies the port number. A port is specified by the combination of a protocol and a port number. The port number must be between 1 and 65535 inclusive.

Syntax | Port = port_number
Value | port_number
Example
Port = 80
Comments | This is a required entry.

Return to top

Name

Specifies the friendly name of the port that is used to represent this entry for Windows Firewall in Control Panel.

Syntax | Name = port_name
Value | port_name
Example
Name = Web Server (TCP 80)
Comments | This is a required entry. The friendly name should provide an indication of why the port is statically opened, such as Web Server (TCP 80) or Telnet Server (TCP 23).

Return to top

Mode

Specifies whether an entry added to the Windows Firewall Exceptions list is either enabled or disabled.

Syntax | Mode = 0 | 1
Value 1

Enables an entry in the Windows Firewall Exceptions list.

0

Disables an entry in the Windows Firewall Exceptions list.
Default | 1
Example
Mode = 1
Comments | This is a required entry.

Return to top

Scope

Defines the set of limits on which computers (IP addresses) are allowed to send traffic through the specified exception. The value of the Mode entry must equal 1 (On).

Syntax | Scope = 0 | 1 | 2
Values 0

Enables unsolicited, incoming traffic with no limitations. Any computer can send traffic through this exception.

1

Enables unsolicited, incoming traffic that matches the exception from any computer on the same subnet as the network connection on which the traffic was received through Windows Firewall, while dropping unsolicited, incoming traffic from all other computers.

2

Defines a custom scope, which is a collection of IP addresses and subnets. Unsolicited, incoming traffic that matches the exception and originates from a computer in the defined collection is enabled through Windows Firewall.

Default Value | 0
Example
Scope = 0
Comments | When opening a port, the set of IP addresses from which the unsolicited, incoming traffic is enabled can be defined by using this entry.

Return to top

Addresses

Specifies the IP addresses in the Scope entry.

Syntax | Addresses = IP_address1, IP_address2
Values | IP_address
Example
Addresses = 192.168.0.5,LocalSubnet
Comments | This entry is ignored unless Scope is set to 2.

Return to top


[WindowsFirewall.<icmpsetting_name>]

banner

[WindowsFirewall.icmpsetting_name]

Answer File = Unattend.txt and Winbom.ini; WinbomType = Factory

The default configuration for Windows Firewall blocks all Internet Control Message Protocol (ICMP) message types; however, you can modify this behavior by adding entries to the Windows Firewall Exceptions lists that enable certain ICMP message types.

The permitted values for adding ICMP Message Types to the Windows Firewall Exceptions list are described in the following table:

ICMP Message Type | Number | Description
OutboundPacketTooBig | 2 | When an Internet Protocol version 6 (IPv6) packet is too large to be forwarded, data is dropped and a computer replies to the sender with a Packet Too Big message.
OutboundDestinationUnreachable | 3 | Sent data that fails to reach this computer due to an error is discarded and reported with a Destination Unreachable message explaining the failure.
OutboundSourceQuench | 4 | When a computer's ability to process incoming data cannot keep up with the rate of a transmission, data is dropped and the sender is asked to transmit more slowly.
Redirect | 5 | Data sent from a computer is rerouted.
InboundEchoRequest | 8 | Messages sent to a computer are repeated back to the sender. This is commonly used for troubleshooting.
InboundRouterRequest | 9 | A computer responds to router discovery messages.
OutboundTimeExceeded | 11 | When a computer discards a packet because its hop count was exceeded or it ran out of time to assemble fragments of a packet, it replies to the sender with a Time Exceeded message.
OutboundParameterProblem | 12 | When a computer discards data that it has received because of a header problem, a reply is sent to the sender with a Parameter Problem error message.
InboundTimestampRequest | 13 | A confirmation message is sent, indicating the time that the data was received by a computer.
InboundMaskRequest | 17 | A computer listens for and responds to requests for a network subnet mask.

The [WindowsFirewall.icmpSetting_name] section can be used with the following sections in your answer file to change the default settings in Windows Firewall. You must include the [WindowsFirewall.icmpsetting_name] section in the [WindowsFirewall.profile_name] section.

  • [WindowsFirewall]
  • [WindowsFirewall.profile_name]
  • [WindowsFirewall.program_name]
  • [WindowsFirewall.service_name]
  • [WindowsFirewall.portopening_name]
Entry | Description
Type | Specifies the type of ICMP message to enable in the configuration of Windows Firewall.
Mode | Specifies whether to enable or disable the ICMP message type.

Sample

This sample demonstrates one use of the [WindowsFirewall.icmpsetting_name] section of Unattend.txt.

[WindowsFirewall.EchoRequest]
Type = 8
Mode = 1

Type

Specifies the type of ICMP message to enable in the configuration of Windows Firewall.

Syntax | Type = 2 | 3 | 4 | 5 | 8 | 9 | 11 | 12 | 13 | 17 | 18
Values 2

Specifies an OutboundPacketTooBig message type.

3

Specifies an OutboundDestinationUnreachable message type.

4

Specifies an OutboundSourceQuench message type.

5

Specifies an Redirect message type.

8

Specifies an InboundEchoRequest message type.

9

Specifies an InboundRouterRequest message type.

11

Specifies an OutboundTimeExceeded message type.

12

Specifies an OutboundParameterProblem message type.

13

Specifies an InboundTimestampRequest message type.

17

Specifies an InboundMaskRequest message type.

18

Specifies all message types.
Example
Type = 2
Comments | This is a required entry.

Return to top

Mode

Specifies whether an entry added to the Windows Firewall Exceptions list is either enabled or disabled.

Syntax | Mode = 0 | 1
Value 1

Enables ICMP message types as specified.

0

Disables ICMP message types.
Default | 1
Example
Mode = 1
Comments | This is a required entry.

Return to top


[Win9xUpg] (Unattend.txt)

banner

[Win9xUpg]

Answer File = Unattend.txt

The [Win9xUpg] section contains entries for specifying an unattended upgrade from Microsoft® Windows® 98, Windows 98 Second Edition, or Windows Millennium Edition to either Windows XP Home Edition or Windows XP Professional. These entries are not valid on any other upgrade path.

Requires Win9xUpgrade in the [Unattended] section of Unattend.txt.

For more information about reversing this upgrade, see the [Uninstall] section.

Note

  • If you upgrade from Windows 98 to Windows XP Home Edition and if you install Personal Web Server on Windows 98, Setup removes the Personal Web Server software component. However, Setup does not remove content files.
Entry | Description
Boot16 | Specifies whether to enable MS-DOS boot mode.
DefaultPassword | Provides a default password for all local accounts created during a migration process.
DomainJoinText | Inserts the Hypertext Markup Language (HTML) text on the Join a Domain page of GUI-mode Setup.
ForcePasswordChange | Specifies whether Setup requires a password change on all local accounts it creates during the migration process.
ForceWorkgroup | Specifies whether Setup skips domain checks and runs the computer in Workgroup mode after the upgrade.
IgnoreNetworkErrors | Specifies whether Setup retries a domain that fails.
KeepBadLinks | Specifies whether Setup keeps all links.
MigrateDefaultUser | Specifies whether Setup migrates the default user account settings of Windows 98 and Windows Millennium Edition to the default Windows XP user account.
MigrateUsersAsAdmin | Specifies whether Setup adds all accounts created during migration to the Local Administrators group, giving those end users full control over the computer.
MigrateUsersAsPowerUser | Specifies whether to add all accounts created during migration to the Power Users group.
MigrationDlls | Specifies the location of upgrade packs that Setup needs to copy and process during an upgrade to Windows XP or a member of the Windows Server 2003 family.
ReportOnly | Specifies whether Setup generates an upgrade report and then exits without changing the current Windows 98 or Windows Millennium Edition installation.
SafeMode | Specifies whether Setup maintains a list of settings during the upgrade.
SaveReportTo | Specifies the full path and file name of the upgrade report (text file) generated by Setup.
ScanDrives | Enables scanning of drives that Setup normally skips.
UseLocalAccountOnError | Specifies whether Setup creates a local account if Setup cannot automatically determine or resolve a network account.
UserDomain | Specifies the domain for one or more end users.
UserPassword | Provides Setup with the names of the passwords created for specific local accounts.

Sample

This sample demonstrates one use of the [Win9xUpg] section of Unattend.txt.

[Win9xUpg]
Boot16 = Yes
DefaultPassword = ABC123
DomainJoinText = MYDOMAIN
ForcePasswordChange = Yes
ForceWorkgroup = No
IgnoreNetworkErrors = Yes
KeepBadLinks = No
MigrateDefaultUser = Yes
MigrateUsersAsAdmin = No
MigrateUsersAsPowerUser = Yes
MigrationDlls = "%SYSTEMDRIVE%\MigFiles"
ReportOnly = No
SafeMode = Yes
SaveReportTo = "%SYSTEMDRIVE%\Upgrade Report%"
ScanDrives = C, D
UseLocalAccountOnError = Yes
UserDomain = MYDOMAIN, PatC
UserPassword = PatC, ABC12345

Boot16

Specifies whether to enable MS-DOS boot mode.

Syntax | Boot16 = Yes | No
Values Yes

Enables MS-DOS boot mode.

No

Disables MS-DOS boot mode.
Default Value | No
Example
Boot16 = Yes

Return to top

DefaultPassword

Provides a default password for all local accounts created during a migration process.

Syntax | DefaultPassword = password
Value | password
Example
DefaultPassword = ABC123
Comments Because Setup cannot migrate the Windows passwords of end users when upgrading a system, it must assign passwords for those created accounts. When Setup needs to assign one of these passwords, it checks first to see if a UserPassword entry exists for that end user. If an entry doesn't exist, Setup uses the value of this entry (if specified).

There are security concerns about using this key, because Setup stores the password as plain text in the Unattend.txt file. After the upgrade, Setup automatically deletes all passwords in the answer file.

If you need to create a local account for an end user without specifying the UserPassword and DefaultPassword entries, Setup creates a random password. After the first reboot, the end user must enter a password for all end users created during Setup.

Return to top

DomainJoinText

Inserts the Hypertext Markup Language (HTML) text on the Join a Domain page of GUI-mode Setup.

Syntax | DomainJoinText = html_text
Value | html_text
Example
DomainJoinText = MYDOMAIN
Comments | The only supported HTML tags are anchor (<A>) and bold (<B>).

Return to top

ForcePasswordChange

Specifies whether Setup requires a password change on all local accounts that it creates during the migration process.

Syntax | ForcePasswordChange = Yes | No
Values Yes

Requires a password change on all local accounts it creates during the migration process. Setup informs end users logging on with these accounts that the current password has expired. End users must select a new password before logging on.

No

Does not require a password change for local accounts.
Default Value | Yes
Example
ForcePasswordChange = Yes

Return to top

ForceWorkgroup

Specifies whether Setup skips domain checks and runs the computer in Workgroup mode after the upgrade.

Syntax | ForceWorkgroup = Yes | No
Values Yes

Skips domain checks and runs the computer in Workgroup mode after the upgrade.

No

Joins the computer to a domain after the upgrade.
Default Value | No
Example
ForceWorkgroup = No

Return to top

IgnoreNetworkErrors

Specifies whether Setup retries a domain that fails.

Syntax | IgnoreNetworkErrors = Yes | No
Values Yes

Does not try to join a domain again if the first attempt fails. In this case, Setup is completely unattended, but the domain account migration might fail.

No

Tries to join a domain again if the first attempt fails.
Default Value | No
Example
IgnoreNetworkErrors = Yes

Return to top

KeepBadLinks

Specifies whether Setup keeps all links.

Syntax | KeepBadLinks = Yes | No
Values Yes

Keeps all links.

No

Removes incompatible links.
Default Value | Yes
Example
KeepBadLinks = No

Return to top

MigrateDefaultUser

Specifies whether Setup migrates the default user account settings of Windows 98 and Windows Millennium Edition to the default Windows XP user account.

Syntax | MigrateDefaultUser = Yes | No
Values Yes

Migrates the default user account settings of Windows 98 and Windows Millennium Edition to the default Windows XP user account.

No

Does not migrate the default user account settings.
Default Value | Yes
Example
MigrateDefaultUser = Yes
Comments

Important

  • If you set this entry to No, the default user settings of Windows 98 and Windows Millennium Edition do not persist. Subsequent user accounts created on the computer inherit the defaults of the upgraded operating system (Windows XP or a member of the Windows Server 2003 family).
  • Some applications rely on settings migrated to the default user. These applications might not work unless you enable default user migration.
  • Use this entry only in special cases (for example, when it is known that no applications require default user migration).

Return to top

MigrateUsersAsAdmin

Specifies whether Setup adds all accounts created during migration to the Local Administrators group, giving those end users full control over the computer.

Syntax | MigrateUsersAsAdmin = Yes | No
Values Yes

Adds all accounts created during migration to the Local Administrators group, giving those users full control over the computer.

No

Does not add all accounts created during migration to the Local Administrators group. If you do not migrate end users as administrators, some migrated applications and settings might not work properly after the upgrade finishes.
Default Value | Yes
Example
MigrateUsersAsAdmin = No
Comments | For more information about group-level security settings, see Windows Help.

Return to top

MigrateUsersAsPowerUser

Specifies whether to add all accounts created during migration to the Power Users group.

Syntax | MigrateUsersAsPowerUser = Yes | No
Values Yes

Adds all accounts created during migration to the Power Users group. Causes Setup to add all accounts that it creates during migration to the Power Users group, giving the new end users in the Power Users group more permissions than end users in the Users group, but fewer permissions than end users in the Administrators group. Power Users can perform any operating system task except tasks reserved for the Administrators group.

No

Does not add all accounts created during migration to the Power Users group.
Default Value | Yes
Example
MigrateUsersAsPowerUser = Yes
Comments | For more information about group-level security settings, see Windows Help.

Return to top

MigrationDlls

Specifies the location of upgrade packs that Setup needs to copy and process during an upgrade to Windows XP or Windows Server 2003 family.

Syntax | MigrationDlls = migration_dll_path [, ...]
Values | migration_dll_path [, ...]
Example
MigrationDlls = "%SYSTEMDRIVE%\MigFiles"
Comments If you specify multiple paths, you must separate the paths with commas. Setup searches each of these paths (and their subfolders) for upgrade packs. You can put multiple upgrade packs in a single path, but each upgrade pack must exist in its own subfolder of that path. Do not put more than one upgrade pack in a single folder.

Note

  • An upgrade pack consists of a migration .dll file (Migrate.dll) and any additional files required to properly upgrade a software component from Windows 98 or Windows Millennium Edition to either Windows XP Home Edition or Windows XP Professional.

Return to top

ReportOnly

Specifies whether Setup generates an upgrade report and then exits without changing the current Windows 98 or Windows Millennium Edition installation.

Syntax | ReportOnly = Yes | No
Values Yes

Generates an upgrade report and then exits without changing the current Windows 98 or Windows Millennium Edition installation.

No

Upgrades the current Windows 98 or Windows Millennium Edition installation.
Default Value | No
Example
ReportOnly = Yes
Comments | The upgrade report contains a list of hardware and software incompatibilities. If you do not specify the SaveReportTo entry, Setup saves the upgrade report to the root of the system drive.

Return to top

SafeMode

Specifies whether Setup maintains a list of settings during the upgrade.

Syntax | SafeMode = Yes | No
Values Yes

Instructs Setup to maintain a list of settings during the upgrade.

No

Does not instruct Setup to maintain a list of settings during upgrade.
Default Value | No
Example
SafeMode = Yes
Comments If any setting causes Windows 98 or later to fail or stop responding, the next Setup skips that setting. Using this entry slows Setup, but it enables Setup to skip certain types of malfunctioning software installed on Windows 98 or later.

Important

  • Safe mode starts automatically if Setup detects a problem. If SafeMode = Off, you must run Setup three times. If SafeMode = Yes, you must run Setup only twice.

Return to top

SaveReportTo

Specifies the full path and file name of the upgrade report (text file) generated by Setup.

Syntax | SaveReportTo = path_of_report
Value | path_of_report
Example
SaveReportTo = "%SYSTEMDRIVE%\Upgrade Report%"
Comments If the Windows 98 or Windows Millennium Edition installation has network connectivity, the path_of_report can be a UNC path. Enclose path_of_report in quotation marks if it is a long file name.

You can use system environment variables enclosed in percent signs (%) in the path. If you specify the special environment variable %computername% in the path, the resulting file name contains the actual computer name. This is useful if Setup collects upgrade reports from several Windows 98 or Windows Millennium Edition computers to a central location.

For more information, see ReportOnly.

Return to top

ScanDrives

Enables scanning of drives that Setup normally skips.

Syntax | ScanDrives = [drive][,drive,drive]
Values | [drive][,drive,drive]
Dependencies

Requires ReportOnly. Enables Setup to check software on network drives.

For more information, see ReportOnly.
Example
ScanDrives = C, D

Return to top

UseLocalAccountOnError

Specifies whether Setup creates a local account if Setup cannot automatically determine or resolve a network account.

Syntax | UseLocalAccountOnError = Yes | No
Values Yes

Creates a local user account if Setup cannot automatically determine or resolve a network account.

No

Does not create a local user account.
Default Value | No
Example
UseLocalAccountOnError = Yes
Comments This is valid only on computers with the Microsoft Networking Client software installed.

Windows 98 and Windows Millennium Edition keep only the domain of the last logged-in user in the registry. Because neither Windows 98 or Windows Millennium Edition keeps the domains of other end users who might have logged on to the computer, Windows Setup searches all trusted domains on the network by default. Setup automatically uses a domain account when it finds an exact match.

If Setup does not find an end user on any trusted domain, or if it finds the user account on two or more domains on the network, a dialog box appears prompting the person performing the upgrade to resolve the conflict. This dialog box also appears if network errors occur.

Specifying UseLocalAccountOnError = Yes in the Unattend.txt file ensures a complete unattended Setup. This causes Setup to create a local account whenever Setup cannot automatically resolve a network account.

In addition, if Setup cannot add a computer to the computer domain during installation of the network on Windows, all user accounts change to local accounts.

For more information, see UserDomain.

Return to top

UserDomain

Specifies the domain for one or more end users.

Syntax | UserDomain = domain_name, user_name [, user_name, user_name, ...]
Values | domain_name, user_name [, user_name, user_name, ...]
Example
UserDomain = MYDOMAIN, PatC
Comments You can use multiple UserDomain lines to specify different domains for different users. When specified, this entry prevents Setup from searching all trusted domains on the network for a matching user account. (The search process can be time-consuming if a large number of trusted domains exist on the network.)

If Setup does not find the account in the specified domain, either because the account does not exist or the domain is not accessible, a dialog box appears prompting the end user to resolve the account unless the UseLocalAccountOnError entry is set to Yes.

For more information, see UseLocalAccountOnError.

Return to top

UserPassword

Provides Setup with the names of the passwords created for specific local accounts.

Syntax | UserPassword = user,password [,user,password,...]
Values | user,password [,user,password,...]
Example
UserPassword = PatC, ABC12345
Comments Because Setup cannot migrate the Windows passwords of end users when upgrading a system, it must create passwords for nondomain accounts during the migration process. Using this key, an administrator can predetermine what those passwords are for specific end users.

There are security concerns about using this key because Setup stores the password as plain text in the answer file. However, after the upgrade finishes, Setup deletes all the password entries from the copy of the answer file left on the computer. However, Setup does not delete the original copy of the answer file.

If you need to create a local account for an end user without specifying the UserPassword and DefaultPassword entries, Setup creates a random password. After the first reboot, the end user must enter the password created during Setup.

For more information, see DefaultPassword.

Return to top


Sysprep.inf

Sysprep.inf is an optional answer file that you can use to automate Mini-Setup. Normally, when Mini-Setup runs, it prompts the end user for some standard information to configure the computer. However, if Sysprep.inf is present, Mini-Setup uses information in Sysprep.inf instead of prompting the end user. By using Sysprep.inf, you can have Mini-Setup prompt the end user for certain information, or you can create a completely automated installation that does not prompt the end user for information at all.

Location of Sysprep.inf

The Sysprep.inf file must reside in the same location as Sysprep.exe and Setupcl.exe. These Sysprep files must in the %SYSTEMDRIVE%\Sysprep folder, located on the hard disk of the destination computer.

If you run Sysprep.exe from %SYSTEMDRIVE%\Sysprep, Sysprep removes the entire folder and its contents.

Syntax of Sysprep.inf

The syntax of Sysprep.inf is similar to that of the unattended Setup answer file, Unattend.txt. Sysprep.inf supports a subset of the sections and entries supported by Unattend.txt, plus a few Sysprep-specific entries. You can use Setup Manager to create the Sysprep.inf file.

The following two tables list the sections that you can include in the Sysprep.inf file. Note that many sections and entries are interdependent.

The [Unattended] and [GuiUnattended] sections support different entries in Unattend.txt and Sysprep.inf:

Section Comparisons Between Unattend.txt and Sysprep.inf
[GuiUnattended] Contains a core subset of the entries from the [GuiUnattended] section in Unattend.txt that are set during GUI-mode Setup. Both Sysprep and Unattend.txt support the following entries:
  • AdminPassword
  • AutoLogon
  • AutoLogonCount
  • OemSkipRegional
  • OemSkipWelcome
  • TimeZone

In addition, Sysprep supports the following entry that Unattend.txt does not support:

  • OEMDuplicatorString
[Unattended] Contains a core subset of entries from the [Unattended] section in Unattend.txt that Sysprep uses. Both Sysprep and Unattend.txt support the following entries:
  • ExtendOemPartition
  • OemPnPDriversPath
  • OemSkipEula

Sysprep supports the following entries that Unattend.txt does not support:

  • InstallFilesPath
  • KeepPageFile
  • ResetSourcePath
  • TapiConfigured
  • UpdateHAL
  • UpdateInstalledDrivers
  • UpdateUPHAL

Both Sysprep.inf and Unattend.txt use the following sections:

Section | Description
[Display] | Specifies display settings for the graphics device. Supports the same set of entries as Unattend.txt.
[GuiRunOnce] | Contains a list of commands to execute the first time an end user logs on to the computer after GUI-mode Setup completes. Supports the same set of entries as Unattend.txt.
[Identification] | Specifies the network identification entries of the computer. Supports the same set of entries as Unattend.txt.
[IEPopupBlocker] | Contains entries for specifying the settings of the Pop-up Blocker tool.
[LicenseFilePrintData] | Includes server licensing entries. Supports the same set of entries as Unattend.txt.
[Networking] | Configures network capability. This section is required when configuring network protocols in unattended Setup or when using Sysprep. However, no entries are required within this section. The syntax is the same as in Unattend.txt.
[RegionalSettings] | Configures locale and language settings, provided the correct language files are available on the computer's hard disk. For more information, see InstallFilesPath. Supports the same set of entries as Unattend.txt.
[TapiLocation] | Includes the Telephony API (TAPI) entries. The values set in this section are valid only if a modem is present on the computer. Supports the same set of entries as Unattend.txt.
[UserData] | Includes user-specific entries. Supports the same set of entries as Unattend.txt.

Important

  • Any settings specified in [RegionalSettings] in Unattend.txt do not persist if Sysprep runs on the computer, unless you also specify the corresponding settings in Sysprep.inf.

Only Sysprep.inf uses the following sections:

Section | Description
[Sysprep] | Automatically generates the entries in the [SysprepMassStorage] section.
[SysprepMassStorage] | Enables you to use the same image on computers with different mass-storage devices.

You can run additional programs at the end of Mini-Setup by providing a Cmdlines.txt file in your Sysprep folder. Mini-Setup can then run Cmdlines.txt just as GUI-mode Setup does.

Note

  • Commands that make changes to an end user's preferences do not replicate to end users if they run from Cmdlines.txt during Mini-Setup.

To run Cmdlines.txt during Mini-Setup

  1. In the distribution folder, create:

    %SYSTEMDRIVE%\Sysprep\i386\$OEM$

  2. Copy Cmdlines.txt to the %SYSTEMDRIVE%\Sysprep\i386\$OEM$ folder.
  3. In Sysprep.inf, add:
    [Unattended]
InstallFilesPath = C:\Sysprep\i386
  4. Run Sysprep.


Sample Sysprep.inf Files

Sample 1

Customizes the Windows installation for a standard departmental desktop.

[GuiUnattended]
AdminPassword = "Administrator password"
OemSkipWelcome = 1
TimeZone = 20

[Identification]
DomainAdmin = "CORPDOM\AcctAddID"
DomainAdminPassword = "Domain password"
JoinDomain = "CORPDOM"

[Networking]

[Unattended]
OemSkipEula = Yes

[UserData]
FullName = "Company Department Name"
OrgName = "Company Name, Inc."

Sample 2

Customizes the Windows installation for remote office servers.

[GuiRunOnce]
Command0 = "dcpromo /answer:ansfile.txt"

[GuiUnattended]
AutoLogon = Yes
AdminPassword = *
OEMSkipRegional = 1
OemSkipWelcome = 1
TimeZone = 20

[Identification]
DomainAdmin = "CORPDOM\IDAcct"
DomainAdminPassword = "Domain password"
JoinDomain = "REGDOM"

[LicenseFilePrintData]
AutoMode = PerSeat

[Networking]

[Unattended]
OemSkipEula = Yes

[UserData]
ComputerName = 005-REGSRV-1
FullName = "Company Server Name"
OrgName = "Company Name, Inc."


[GuiUnattended] (Sysprep.inf)

Answer File = Sysprep.inf

The [GuiUnattended] section for Sysprep.inf contains entries for preparing the graphical user interface (GUI) for unattended Setup.

For the Unattend.txt version, see [GuiUnattended] (Unattend.txt).

Entry | Description
AdminPassword | Sets the Administrator account password.
AutoLogon | Configures the computer to log on automatically with the Administrator account on the first reboot.
AutoLogonCount | Specifies the number of times that the computer automatically logs on using the specified Administrator account and password.
EMSSkipUnattendProcessing | Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to a remotely administered server.
EncryptedAdminPassword | Enables Setup to install encrypted passwords for the Administrator account.
OEMDuplicatorString | Specifies a description of the duplication utility used, as well as any other information that an OEM or administrator wants to store in the registry.
OEMSkipRegional | Specifies whether unattended Setup skips the Regional and Language Options page in GUI-mode Setup and Mini-Setup.
OEMSkipWelcome | Specifies whether unattended Setup skips the Welcome page in GUI-mode Setup and Mini-Setup.
TimeZone | Specifies the time zone of the computer's location.

Sample

This sample demonstrates one use of the [GuiUnattended] section of Sysprep.inf.

[GuiUnattended]
AdminPassword = "TG33hY"
AutoLogon = Yes
AutoLogonCount = 3
EMSSkipUnattendProcessing = 1
EncryptedAdminPassword = Yes
OEMDuplicatorString = "My Duplication Utility"
OEMSkipRegional = 1
OEMSkipWelcome = 1
TimeZone = 030

AdminPassword

Sets the Administrator account password.

Syntax AdminPassword = password
Values "password"

The password may contain as many as 127 characters. Passwords are case-sensitive and must be enclosed in quotes. Users cannot change or specify their own passwords in Mini-Setup. You can enter a new password in the appropriate dialog box, but the password does not change.

*

The Administrator password is blank or NULL.
Example
AdminPassword = "TG33hY"
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\WinLogon\DefaultPassword
Dependencies If AdminPassword is set to blank, null, or not set, the registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\
CurrentVersion\WinLogon\AutoAdminLogon (controlled by AutoLogon) is set to 0 (false) which disables the automatic Administrator account logon feature.
Comments

If you specify a password in the Administrator account, you cannot use the AdminPassword entry in the Sysprep.inf file to change it. The Administrator password remains the same. However, if the Administrator password was initially blank (either manually or through an unattended Setup), you can use the AdminPassword entry to change it to a non-blank password.

Important

  • Do not specify the Administrator password in the Sysprep.inf file on computers delivered to end users. Security breaches can occur if you use a common, non-blank Administrator password for all computers provided to end users. Before running Sysprep, we recommend that you use an automation process to set the Administrator password to blank. End users can then specify their own passwords when they receive the computer.

Return to top

AutoLogon

Configures the computer to log on automatically with the Administrator account on the first reboot.

Syntax AutoLogon = Yes | No
Values Yes

Configures the computer to log on automatically with the Administrator account on the first reboot.

No

Default. Does not automatically log on to the computer.
Example
AutoLogon = Yes
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows NT\CurrentVersion\WinLogon\AutoAdminLogon
Dependencies If AdminPassword is set to blank, null, or not set, the registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\
CurrentVersion\WinLogon\AutoAdminLogon (controlled by AutoLogon) is set to 0 (false) which disables the automatic Administrator account logon feature.
Comments

The entry is not valid on upgrades.

When you set the value of the AutoLogon entry to Yes, you cannot log off. If you try to log off, you will be logged back on automatically. The only way to log off is to reboot, which decrements the value of AutoLogonCount.

If you specify a password by using the AdminPassword entry, the computer uses that password when you automatically log on. After the installation finishes, Setup deletes the password from the copy of the answer file left on the computer.

Return to top

AutoLogonCount

Specifies the number of times that the computer automatically logs on using the specified Administrator account and password.

Syntax | AutoLogonCount = integer
Value | integer
Example
AutoLogonCount = 3
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\WinLogon\AutoLogonCount
Comments

The value decrements after each time someone logs on, and WinLogon disables the feature after the specified number of logon attempts.

Requires AutoLogon = Yes and AdminPassword = password in Sysprep.inf. If AutoLogon = Yes, WinLogon checks the value of AutoLogonCount. If the number for AutoLogonCount is greater than 0, WinLogon decrements the count and then checks AdminPassword. If AdminPassword = password, WinLogon uses this password to log on automatically. If AdminPassword = *, the user must enter a password.

If AutoLogonCount = 0, then WinLogon deletes AutoAdminLogon, AutoLogonCount, and DefaultPassword from the registry. During the next reboot, the user must log on manually.

Important

  • The function of this entry has changed slightly between Microsoft® Windows® 2000 and Windows XP. Please review this entry carefully before using it in your answer file.
  • Make sure that the password for the master installation (that you plan to duplicate onto one or more destination computers) is blank.
  • You must restart the computer to decrement the value of AutoLogonCount.

Return to top

EMSSkipUnattendProcessing

Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to a remotely administered server.

Syntax | EMSSkipUnattendProcessing = 0 | 1
Values 0

Does not prevent Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to a remotely administered server.

1

Prevents Windows Setup from processing Unattend.txt or Sysprep.inf during an unattended installation to a remotely administered server.
Default Value | 0
Example
EMSSkipUnattendProcessing = 0
Comments | Applies only to the Windows Server 2003 family.

Return to top

EncryptedAdminPassword

Enables Setup to install encrypted passwords for the Administrator account.

Syntax EncryptedAdminPassword = Yes | No
Values Yes

Instructs Setup to install the encrypted Administrator account password.

No

Default. Instructs Setup to keep the Administrator account password as clean text.
Example
EncryptedAdminPassword = Yes
Comments

To encrypt your Administrator passwords, use Setup Manager on the Windows OPK CD (in Tools) and in Deploy.cab.

Important

  • If you use this key to install an encrypted Administrator password during an unattended installation, Setup disables Autologon.

Return to top

OEMDuplicatorString

Specifies a description of the duplication utility used, as well as any other information that an OEM or administrator wants to store in the registry.

Syntax | OEMDuplicatorString = string
Value user-defined_string

Valid only for Sysprep.inf. The value can have a maximum of 255 characters.
Example
OEMDuplicatorString = "My Duplication Utility"
Registry subkey | HKEY_LOCAL_MACHINE\System\Setup\OemDuplicatorString

Return to top

OEMSkipRegional

Specifies whether unattended Setup skips the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

Syntax OEMSkipRegional = 0 | 1
Values 0

Displays the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

1

Skips the Regional and Language Options page in GUI-mode Setup and Mini-Setup.
Example
OEMSkipRegional = 1
Comments

When providing values for the [RegionalSettings] section, set OEMSkipRegional = 1 to ensure that Setup completes without prompting the end user for regional information.

Return to top

OEMSkipWelcome

Specifies whether unattended Setup skips the Welcome page in GUI-mode Setup and Mini-Setup.

Syntax OEMSkipWelcome = 0 | 1
Values 0

Displays the Welcome page in GUI-mode Setup and Mini-Setup.

1

Skips the Welcome page in GUI-mode Setup and Mini-Setup.
Example
OEMSkipWelcome = 1
Comments

If OemPreinstall = Yes, unattended Setup automatically stops at the Welcome page. To avoid this pause in your factory or testing environment, set OEMSkipWelcome = 1. However, do not distribute any computer with OEMSkipWelcome = 1.

If the value of the OemPreinstall entry in the [Unattended] section of Unattend.txt is set to Yes, unattended Setup automatically stops at the Welcome page. To avoid this pause in your factory or testing environment, set the value of OEMSkipWelcome in the [GuiUnattended] section of Sysprep.inf to 1. However, do not deliver any computer with OEMSkipWelcome = 1. Instead, change OEMSkipWelcome to 0 in the Sysprep.inf file that you use before delivering the computer to the customer.

Return to top

TimeZone

Specifies the time zone of the computer's location.

Syntax | TimeZone = index
Value | index
Example
TimeZone = 030
Comments

If the entry is not present, the end user must select a time zone. For a list of valid time zones, see TimeZone in Unattend.txt.

Note

  • If you do not configure a specific time zone setting, the default time zone depends on the language version of Windows that is installed. For example, in the Japanese version, the default time zone is "GMT+9 (Osaka, Sapporo, Tokyo)."

Return to top


[Sysprep] (Sysprep.inf)

banner

[Sysprep]

Answer File = Sysprep.inf

The [Sysprep] section contains an entry for automatically generating the entries in the pre-existing [SysprepMassStorage] section and then installing those mass-storage controllers.

Entry | Description
BuildMassStorageSection | Generates the entries in the [SysprepMassStorage] section from the Plug and Play hardware IDs specified in Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf, and installs each of these mass-storage controllers.

Sample

This sample demonstrates one use of the [Sysprep] section of Sysprep.inf.

[Sysprep]
BuildMassStorageSection = Yes

BuildMassStorageSection

Generates the entries in the [SysprepMassStorage] section from the Plug and Play hardware IDs specified in Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf, and installs each of these mass-storage controllers.

Syntax BuildMassStorageSection = Yes | No
Values Yes

Populates a pre-existing [SysprepMassStorage] section with the hardware IDs specified in Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf, and installs those mass-storage controllers.

No

Does not populate the [SysprepMassStorage] section.
Example
[Sysprep]
BuildMassStorageSection = Yes

[SysprepMassStorage]
Comments You can run the command Sysprep -bmsd instead of including the BuildMassStorageSection entry in your Sysprep.inf file. When you run the command Sysprep -bmsd, Sysprep populates a pre-existing [SysprepMassStorage] section, but the mass-storage controllers are not installed until the next time you run Sysprep. You can then delete items from this section before running Sysprep -reseal or Sysprep -factory on this installation. Installing a smaller number of items in the critical device database reduces the time required for this image to restart into the operating system.

For more information about automatically generating entries for mass-storage controllers, see [SysprepMassStorage]

Return to top


[SysprepMassStorage] (Sysprep.inf)

banner

[SysprepMassStorage]

Answer File = Sysprep.inf

The [SysprepMassStorage] section contains an entry for identifying the different mass-storage controllers that you want to install on each destination computer. Sysprep prepopulates the necessary driver information, based on the entries that you provide, so that the correct drivers will be loaded when the operating system starts on a computer that uses one of the predefined mass-storage controllers.

You do not need to create the entries manually in the [SysprepMassStorage] section. Instead, you can include the BuildMassStorageSection = Yes entry in the [Sysprep] section of the Sysprep.inf file. For example:

[Sysprep]
BuildMassStorageSection = Yes

Sysprep will automatically generate the entries in the [SysprepMassStorage] section for all mass-storage controllers that are specified by the Plug and Play hardware IDs in Machine.inf, Scsi.inf, Pnpscsi.inf, Mshdc.inf, and will install those mass-storage controllers. This is the default method for installing mass-storage controllers on destination computers.

To audit individual destination computers before releasing them to customers

  1. On the master computer, run the Sysprep -factory command with Sysprep.inf in the Sysprep directory.

    Sysprep processes the BuildMassStorageSection = Yes entry, adds the list of controllers to the [SysprepMassStorage] section, and then installs the controllers.

  2. Create an image of the master installation and deploy it to the destination computer.

    When the destination computer restarts, Sysprep uninstalls the unused mass-storage controllers.

  3. Run the Sysprep -reseal command to shut down the destination computer and return the operating system to a customer-ready state.

To use mass-storage controllers in an automated preinstallation without auditing the individual destination computers

  1. On the master computer, run the Sysprep -reseal command with Sysprep.inf in the Sysprep directory.

    Sysprep processes the BuildMassStorageSection = Yes entry, adds the list of controllers to the [SysprepMassStorage] section, and then installs the controllers.

  2. Create an image of the master installation and deploy that image to the destination computer.

    When the destination computer starts, Sysprep uninstalls the unused mass-storage controllers.

Notes

  • When you run the Sysprep -reseal or Sysprep -factory command, Sysprep reads the [SysprepMassStorage] section of the Sysprep.inf file and installs the mass-storage controllers by writing the information into the registry before shutdown. The next time the computer starts, all mass-storage controllers are available.
  • If you do not use the [SysprepMassStorage] section, Sysprep requires that the mass-storage controller on the master installation be identical to the controllers on the destination computers.
  • If you use images as part of your manufacturing process, you may want to reduce the number of images that you maintain by creating one master image to install Microsoft® Windows® on destination computers that may use different mass-storage controllers.

Sample

This sample demonstrates how to install a new QLogic driver by using the [SysprepMassStorage] section of Sysprep.inf.

[SysprepMassStorage]
PCI\VEN_1077&DEV_1080 = "C:\Drivers\qlogic\qlogic.inf"
Entry | Description
hardware_id | Specifies the Plug and Play ID for the device as specified in the device's .inf file. In this example, the value of hardware_id is found in qlogic.inf. The minimum required parameters are hardware_id and the .inf file name.
Syntax | hardware_id = path_to_device_inf[, disk_directory[, disk_description[, disk_tag]]]
Values path_to_device_inf

Specifies the path to the .inf file that contains the Plug and Play ID of the controller to install. Enclose path_to_device_inf in quotation marks if it is a long file name.

disk_directory

Specifies the name of the directory on the floppy disk provided by the third party that contains the copy of the mass-storage driver.

disk_description

Specifies the description of the floppy disk as specified in the Txtsetup.oem file provided by the third party.

disk_tag

Specifies the disk tag of the floppy disk as specified in the Txtsetup.oem file provided by the third party.
Example To support a new Qlogic driver, copy the Qlogic.inf file to the Sysprep folder and include the following section in the Sysprep.inf file:
[SysprepMassStorage]
PCI\VEN_1077&DEV_1080 = "C:\Drivers\qlogic\qlogic.inf",
 "C:\Drivers\qlogic\", "QLogic Software Disk", "C:\Drivers\qlogic\disk_tag"

Return to top


[Unattended] (Sysprep.inf)

Answer File = Sysprep.inf

The [Unattended] section for Sysprep.inf contains entries for running Setup. For the Unattend.txt version, see [Unattended] (Unattend.txt).

Entry | Description
ExtendOemPartition | Specifies whether to extend the partition on which you install the Microsoft® Windows® operating system.
InstallFilesPath | Specifies the location of files necessary for installation during Mini-Setup, such as the language files, so that the installation does not stop to prompt for end-user input.
KeepPageFile | Specifies whether to regenerate the page file.
OemPnPDriversPath | Specifies the path to one or more folders that contain Plug and Play drivers not distributed with Drivers.cab on the Windows product CD.
OemSkipEula | Specifies whether the end user accepts the End-User License Agreement (EULA) included with Windows.
ResetSourcePath | Specifies whether to change the registry setting of the source path for the Setup files.
TapiConfigured | Specifies whether to preconfigure telephony application programming interface (TAPI) settings on the installation.
UpdateHAL | Loads the multiprocessor hardware abstraction layer (HAL) on the destination computer, regardless of whether it is a uniprocessor or an multiprocessor computer.
UpdateInstalledDrivers | Specifies whether to call Plug and Play after Mini-Setup, to re-enumerate all the installed drivers, and to install any updated drivers in the driver path.
UpdateUPHAL | Identifies the processor type and loads the appropriate kernel.

Sample

This sample demonstrates one use of the [Unattended] section of Sysprep.inf.

[Unattended]
ExtendOemPartition = 1 2000
InstallFilesPath = C:\Sysprep\i386
KeepPageFile = 1
OEMPnPDriversPath = drivers\audio;drivers\net
OEMSkipEula = No
ResetSourcePath = E:
TapiConfigured = Yes
UpdateHAL = MPS_MP,%WINDIR%\inf\hal.inf
UpdateInstalledDrivers = Yes
UpdateUPHAL = MPS_UP,%WINDIR%\Inf\Hal.inf

ExtendOemPartition

Specifies whether to extend the partition on which you install the Windows operating system.

Syntax ExtendOEMPartition = 0 | 1 extra_size_in_MB
Values 0

Sysprep does not extend the partition.

1

Sysprep extends the partition to fill out the hard disk.

extra_size_in_MB

Sysprep increases the current partition size by this amount. This is useful if you want to configure more than one partition on the hard disk.
Example
ExtendOEMPartition = 1 2000
Comments Setup extends this destination partition into any available unpartitioned space that physically follows it on the disk.

ExtendOemPartition automatically leaves the last cylinder on the hard disk free to enable dynamic disk support to work.

Important

  • You can extend only NTFS file system partitions.
  • When you use ExtendOEMPartition in Sysprep.inf for imaged computers, the destination computer's hard disk must be the same size or larger than the hard disk of the original master installation.
  • The partition that you want to extend must have unpartitioned space available following the partition.

If your manufacturing process requires FAT32, use the Oformat command-line tool to format the hard disk so that you configure it optimally for NTFS. Use the Convert command-line tool to convert the file system.

You can also convert the partition during text-mode Setup by setting the FileSystem entry in the [Unattended] section of Unattend.txt to ConvertNTFS. Note that FileSystem is not a valid entry in Sysprep.inf. However, the hard drive will perform better if you use the Convert command-line tool instead of the FileSystem entry.

Instead of extending the partition in Sysprep, you can also use the ExtendPartition entry in the [ComputerSettings] section of Winbom.ini to extend the partition using the Factory tool.

Return to top

InstallFilesPath

Specifies the location of files necessary for installation during Mini-Setup, such as the language files, so that the installation does not stop to prompt for end-user input.

Syntax InstallFilesPath = path_to_installation_files_on_computer
Value path_to_installation_files_on_computer

Valid only for Sysprep.inf.
Example
InstallFilesPath = C:\Sysprep\i386
Comments For example, if there is a copy of the \i386 folder in the root of the end user's system drive, you need to specify InstallFilesPath in the Sysprep.inf file so that Setup can find the files, such as:
InstallFilesPath = "C:\Sysprep\i386"

InstallFilesPath does not support environment variables (for example, %SYSTEMDRIVE%). Instead, you must use a valid path with an actual drive letter. Enclose path_to_installation_files_on_computer in quotation marks if it is a long file name.

Return to top

KeepPageFile

Specifies whether to regenerate the page file.

Syntax KeepPageFile = 0 | 1
Values 0

Regenerates the page file so that it is large enough to accommodate the amount of random access memory (RAM) on the computer. (Default)

1

Does not regenerate the page file.
Example
KeepPageFile = 1
Comments

Valid only for Sysprep.inf. After Sysprep runs, Mini-Setup or Windows Welcome automatically regenerates the system's page file to accommodate differences in the amount of RAM between the master computer and the destination computer. The default setting ensures that the page file is large enough to accommodate the amount of RAM on the computer.

If the amount of RAM is the same on both the computer used to create the master installation and the destination computers, you do not need to regenerate the paging file.

If you delete the page file by using Windows PE and KeepPageFile = 0 or 1 in Sysprep.inf, the page file will be re-created based on the master computer's page file setting. For more detailed information on how to use the KeepPageFile entry with Sysprep.inf, see the KB article (Q813138), "Description of the KeepPageFile= setting for Windows XP and Windows Server 2003."

Return to top

OemPnPDriversPath

Specifies the path to one or more folders that contain Plug and Play drivers not distributed with Drivers.cab on the Windows product CD.

Syntax OemPnPDriversPath = folder_1_on_system_drive
Value folder_1_on_system_drive[;folder_2_on_system_drive]...
Example
OemPnPDriversPath = drivers\audio;drivers\net
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\DevicePath
Comments The folders must contain all the files necessary to install the particular devices: catalog files, .inf files, and drivers.

For example, if you have a folder called \Drivers with subfolders called \Audio and \Net, specify OemPnPDriversPath = drivers\audio;drivers\net in Sysprep.inf. Sysprep adds:

  • %SYSTEMDRIVE% to each of the folder names
  • The path for each subfolder to the Plug and Play device search path

If there is already a path in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\DevicePath, Sysprep does not append the path to the registry key a second time.

Important

  • The length of OemPnPDriversPath in Sysprep.inf must not exceed 4,096 characters.
  • You cannot use environment variables to specify the location of a folder.
  • Always use signed drivers. Signed drivers make the operating system more stable and significantly reduce requests for product support.

In Sysprep.inf, the value of OemPnPDriversPath can be any location on the computer's hard disk.

If the drivers are not in the Drivers.cab file on the computer's hard disk or in the location specified by OemPnPDriversPath, Setup prompts the end user for the location of the drivers the first time the computer starts, before Windows Welcome or Mini-Setup runs.

As in Windows 2000, you can use OemPnPDriversPath in Sysprep.inf to specify the location of additional drivers. However, you can also use the [PnPDrivers] section in Winbom.ini to update drivers on a previously-created image of the installed operating system.

Return to top

OemSkipEula

Specifies whether the end user accepts the End-User License Agreement (EULA) included with Windows.

Syntax OEMSkipEula = Yes | No
Values Yes

Skips the EULA and implies that the person performing the installation has read and agreed to the contents of the license agreement included with the product. It also implies that the end user on whose behalf you installed Windows has agreed to the license agreement.

No

Does not skip the EULA and prompts the end user to accept it.
Example
OEMSkipEula = No
Comments

Important

  • OEMs must not specify this entry in the Sysprep.inf file of computers sold to end users.

Return to top

ResetSourcePath

Specifies whether to change the registry setting of the source path for the Setup files.

Syntax ResetSourcePath = * | path_to_install_files
Values *

No change to the registry values. (Default)

path_to_install_files

Specifies the location of the Setup files in the registry.
Example
ResetSourcePath = E:
Registry subkey HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\Setup\SourcePath and
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\ServicePackSourcePath
Comments

Important

  • If this directory does not exist or is set to the %SYSTEMROOT% directory, Windows Welcome or Mini-Setup resets the path to the first CD-ROM drive.

Return to top

TapiConfigured

Specifies whether to preconfigure TAPI settings on the installation.

Syntax TapiConfigured = Yes | No
Values Yes

The TAPI settings are preconfigured for the end user. In this case, all TAPI locations in the registry are preserved after Sysprep. (Default)

No

The TAPI settings are not preconfigured, and the end user must enter them during Windows Welcome. Setup deletes keys in the following registry location: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Telephony\Locations\LocationN.

Blank

Configured TAPI settings are not altered. This is the same as TapiConfigured = Yes.
Example
TapiConfigured = Yes
Comments

Important

  • The end user must enter TAPI location information during Windows Welcome or on the first use of a modem. Some modem drivers provide generic TAPI information during their installation. When using TapiConfigured = Yes, configure the correct location. Otherwise, your customers might unknowingly make long distance telephone calls when they use the modem.

Return to top

UpdateHAL

Loads the multiprocessor hardware abstraction layer (HAL) on the destination computer, regardless of whether it is a uniprocessor or an multiprocessor computer.

Syntax UpdateHAL = hwid,%WINDIR%\inf\hal.inf
Value hwid,%WINDIR%\inf\hal.inf
(where hwid is either MPS_MP or ACPIAPIC_MP)
Example
UpdateHAL = MPS_MP,%WINDIR%\inf\hal.inf
Comments Valid only for Sysprep.inf. Not required in Windows XP or the Windows Server 2003 family.

Important

  • Do not use a Sysprep.inf file containing this entry on destination uniprocessor computers. A multiprocessor kernel on a uniprocessor computer noticeably reduces the computer's performance.
  • An image created on a computer with a single processor (with no multiprocessor support) cannot be used on a multiprocessor computer.

Add the modified Sysprep.inf file to the destination computer, in the %SYSTEMDRIVE%\Sysprep directory.

Return to top

UpdateInstalledDrivers

Specifies whether to call Plug and Play after Mini-Setup, to re-enumerate all the installed drivers, and to install any updated drivers in the driver path.

Syntax | UpdateInstalledDrivers = Yes | No
Values Yes

Installs updated drivers.

No

Does not install updated drivers. (Default)
Example
UpdateInstalledDrivers = Yes
Comments | Do not use UpdateInstalledDrivers with the sysprep -pnp command-line option.

Return to top

UpdateUPHAL

Identifies the processor type and loads the appropriate kernel.

Syntax | UpdateUPHAL = hwid,%WINDIR%\Inf\Hal.inf
Value hwid,%WINDIR%\Inf\Hal.inf
(where hwid is either MPS_UP or ACPIAPIC_UP)
Example
UpdateUPHAL = MPS_UP,%WINDIR%\Inf\Hal.inf
Comments | Valid only for Sysprep.inf. Required if the master installation is built on an APIC multiprocessor computer and the image of that master installation is on compatible APIC uniprocessor or multiprocessor destination computers.

Return to top


Internet Settings (.ins) File

The Internet settings (.ins) file is the mechanism used to configure computers for broadband or dial-up Internet access during Windows Welcome. At the end of the Internet service provider (ISP) sign-up offer, the ISP sign-up server creates an .ins file that contains the specified Internet settings and returns the file to the computer. Windows Welcome then processes the .ins file and applies the settings to the computer.

Use the .ins file to configure dial-up networking, Connection Manager, Microsoft® Internet Explorer, and Microsoft® Outlook Express. For broadband Internet connections, the .ins file can also contain Transmission Control Protocol/Internet Protocol (TCP/IP) and other connection-related settings.

For more information, see Internet Settings (.ins entries) for Broadband Connections.

Notes

  • Custom .ins files must have the following security descriptor:
    D:P(A;;GRGX;;;BU)(A;;GA;;;BA)(A;;GA;;;SY)(A;;GRGX;;;WD)
    This protects the file from being modified by a user with inheritable settings, allows the Users group to read and execute, allows the Administrators group all access, allows system all access, and allows Everyone read and execute access.
  • Make sure that you navigate only to trusted sites and pages.

The following sections appear in the .ins files:

Section | Description
[ActiveSetup] | Specifies the location of your custom bitmap files that appear in the Internet Explorer 6.0 Customization Wizard.
[ActiveSetupSites] | Specifies the names and locations of the custom packages that users can download.
[Animation] | Specifies the location of your custom animated bitmap files that appear in the Setup Wizard.
[Batch] | Specifies the types of installation media available for your custom package.
[Big_Logo] | Specifies the name and path of your 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser.
[Branding] | Specifies information about the custom branding and setup information included in your browser package.
[BrowserToolbars] | Customizes the appearance of the Microsoft Internet Explorer toolbar.
[CabSigning] | Specifies the information used to sign your programs.
[ConnectionSettings] | Specifies information about the dial-up networking connection settings used to install your custom Internet Explorer package. This creates common network connection settings on all users' workstations.
[CustomBranding] | Specifies the Uniform Resource Locator (URL) for your branding cabinet file.
[CustomWallpaper] | Specifies the HTML and supporting files for your custom wallpaper.
[Device] | Specifies the type of connection used for Setup.
[Entry] | Specifies whether the information in this .ins file overrides the name of the dial-up networking in your custom package.
[ExtRegInf] | Specifies the names of your information (.inf) files and the installation mode for components.
[FavoritesEx] | Specifies the path to your icon file for Favorites, the URL to each Favorite site, and whether Favorites are available offline.
[HideCustom] | Specifies whether to hide the globally unique identifier (GUID). Each custom component has a GUID that is based on system information and other parameters, such as the time of day it is created.
[ICW_IEAK] | Specifies the path to your custom bitmap files that appear in the Internet Connection Wizard (ICW).
[Internet_Mail] | Specifies your custom Outlook Express information.
[Internet_News] | Specifies your custom news information and whether Outlook Express is the default news client.
[ISP_Security] | Specifies the root certificate to add to your custom package.
[LDAP] | Specifies information for your Lightweight Directory Access Protocol (LDAP) server. Also specifies whether Outlook Express always checks names and e-mail addresses against the LDAP server.
[Mail_Signature] | Specifies an e-mail signature for news and whether to use the signature.
[Media] | Specifies the types of media that your installation package is available in, such as CD, download, and floppy disk.
[Outlook_Express] | Specifies which pieces of Outlook Express to brand or customize in your package.
[Outlook_Express_Global] | Specifies your branding for the Outlook Express service.
[Phone] | Specifies the telephone information used for your dial-up connection.
[Proxy] | Specifies whether to use a proxy server and identifies the host names for the proxy server.
[Script_File] | Specifies the text of the script file associated with dial-up networking.
[Scripting] | Specifies the names and paths of your dial-up networking script files.
[Security Imports] | Specifies whether to import security information from your computer to your custom package.
[Server] | Specifies the default connection settings used by the Internet Connection Wizard (ICW).
[Signature] | Specifies whether to use an Outlook Express signature and the text of that signature.
[SignupFiles] | Specifies the name of the files that appear during signup, such as Sign-up.htm.
[Small_Logo] | Specifies the name and path of your 22 x 22-pixel bitmap file that appears in the upper-right corner of the browser.
[TCP/IP] | Specifies the Internet Protocol (IP) number of the Domain Name System (DNS) server to use. You can also specify to use a remote gateway, an IP address, and a server address.
[URL] | Specifies whether to use an auto-configured proxy server, and identifies the URLs for the pages that appear when users connect to that server.
[User] | Specifies the logon information required by your users.


Sample .ins File (.ins)

banner

Sample .ins File

Here is a sample .ins file.

[Entry]
Entry_Name = Fabrikam

[Phone]
Area_Code = 555
Country_Code = 1
Country_ID = 1
Dial_As_Is = No
Phone_Number = 123-4567

[Server]
Negotiate_TCP/IP = Yes
PW_Encrypt = No
SW_Compress = Yes
Type = PPP

[TCP/IP]
Gateway_On_Remote = Yes
IP_Header_Compress = Yes
Specify_IP_Address = No
Specify_Server_Address = No

[User]
Name = InternetUser
Password = secret

[Favorites]
Microsoft Software and Service\Microsoft Product Support Services URL = http://www.microsoft.com/support/
Microsoft Software and Service\The Microsoft Corporation URL = http://www.microsoft.com/


Internet Settings (.ins entries) for Broadband Connections

Windows Welcome enables the configuration of a new broadband Internet account. The following settings are extensions to the existing .ini file format that enable this broadband configuration. These settings replace any similar settings described in the .ins entries for dial-up connections.

[Device]
Type = {modem, isdn, atm, pppoe}
Modem, ISDN, and ATM will bind entries to RAS
Modem and ISDN look only for [TCP/IP] header
ATM looks for [TCP/IP] and [ATM] headers
PPPOE looks for [TCP/IP] and [PPPOE] headers
Name = {friendly name of the device}
Pnpid = {Plug and Play ID of the device, or for multifunction
adapters, only the Plug and Play ID of the configured network device required}

Note

  • The OEM places the device name and Plug and Play ID of the broadband device on the computer before shipping it. This information is transmitted to the Internet service provider (ISP) during the end-user sign-up process. The ISP then adds these entries to the .ins file so that the sign-up process configures the correct device.
[TCP/IP]
Specify_IP_Address = {Yes for static, No for DHCP}
IP_Address = {static IP address if used}
Subnet_Mask = {IP address}
Specify_DNS_Address = {Yes if use, else No}
DNS List = {IP address},{IP address}, …
IP_Header_Compress = {Yes if used, else No}
Gateway_On_Remote = {Yes if used, else No}
Default_Gateway_List = {IP address},{IP address}, …
Domain_Name = {string},{string}, …
Host_Name = {string if used}
Domain_Suffix_Search_List = {IP address},{IP address}, …
Specify_WINS_Address = {Yes, No}
WINS_List = {IP address},{IP address}, …
[PPPoverATM]
Circuit_Speed = {flag}
0 = Line Rate
1 = User Specified
Or actual value of rate in kilobytes (512, 1536, 25000, 155000)
Circuit_QOS = {flag}
0 = UBR
1 = VBR
2 = CBR
3 = ABR
Circuit_Type = {0 if SVC, 1 if PVC}
Speed_Adjust = {Yes or No}
QOS_Adjust = {Yes or No}
Encapsulation = {flag}
0 – PPP over ATM (null encapsulation)
1 – PPP over ATM (LLC)
2 – Bridged Ethernet/802.3 (LLC/SNAP) Not defined for PPPOA
3 – Routed IPv4 (LLC/SNAP) Not defined for PPPOA
4 – Bridged Ethernet/802.3 (null encapsulation) Not defined for
PPPOA
5 – Routed IPv4 (null encapsulation) Not defined for PPPOA
VPI = {numeric value} Only for PVC
VCI = {numeric value}
Vendor_Config = {Yes or No}
Show_Status = {Yes or No}
Enable_Log = {Yes or No}
[Phone]
PhoneNumber = NSAP address if ATM, else telephone number

Note

  • These are extensions to the existing .ins file format that work only in Windows Welcome.


[ActiveSetup](.ins)

OPK banner

[ActiveSetup]

Answer File = Internet Settings (.ins) File

The [ActiveSetup] section contains entries for specifying the location of your custom bitmap files that appear in the Microsoft® Internet Explorer 6.0 Customization Wizard.

Entry | Description
Name | Specifies the name of the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.
Path | Specifies the path to the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.

Sample

This sample demonstrates one use of the [ActiveSetup] section of the Internet Settings (.ins) File.

[ActiveSetup]
Name = MyBitmap.bmp
Path = C:\Windows\MyBitmap.bmp

Name

Specifies the name of the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.

Syntax | Name = file_name
Value | file_name
Example
Name = MyBitmap.bmp

Return to top

Path

Specifies the path to the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.

Syntax | Path = path_and_file_name
Value | path_and_file_name
Example
Path = C:\Windows\MyBitmap.bmp

Return to top


[ActiveSetupSites](.ins)

OPK banner

[ActiveSetupSites]

Answer File = Internet Settings (.ins) File

The [ActiveSetupSites] section contains entries for specifying the names and locations of the custom packages that users can download.

Entry | Description
SiteName0 | Specifies the friendly name of the site from which users download files.
SiteRegion0 | Specifies the geographical region of the first download site's location.
SiteURL0 | Specifies the Uniform Resource Locator (URL) of the first download site.
SiteName1 | Specifies the friendly name of the second site from which users download files.
SiteRegion1 | Specifies the geographical region of the second download site's location.
SiteURL1 | Specifies the URL of the second download site.
SiteNameX | Specifies the friendly name of the third or subsequent site from which users download files.
SiteRegionX | Specifies the geographical region of the third or subsequent download site's location.
SiteURLX | Specifies the URL of the third or subsequent download site.
TestCertsOK | Specifies whether to use test certificates.

Sample

This sample demonstrates one use of the [ActiveSetupSites] section of the Internet Settings (.ins) File.

[ActiveSetupSites]
SiteName0 = My Home Page
SiteRegion0 = Sweden
SiteURL0 = http://www.fabrikam.com
SiteName1 = My Second Home Page
SiteRegion1 = Mexico
SiteURL1 = http://www.fabrikam1.com
SiteNameX = My Fifth Home Page
SiteRegionX = Portugal
SiteURLX = http://www.fabrikam5.com
TestCertsOK = 1

SiteName0

Specifies the friendly name of the site from which users download files.

Syntax | SiteName0 = string
Value | string
Example
SiteName0 = My Home Page

Return to top

SiteRegion0

Specifies the geographical region of the first download site's location.

Syntax | SiteRegion0 = string
Value | string
Example
SiteRegion0 = Sweden

Return to top

SiteURL0

Specifies the URL of the first download site.

Syntax | SiteURL0 = URL
Value | URL
Example
SiteURL0 = http://www.fabrikam.com

Return to top

SiteName1

Specifies the friendly name of the second site from which users download files.

Syntax | SiteName1 = string
Value | string
Example
SiteName1 = My Second Home Page

Return to top

SiteRegion1

Specifies the geographical region of the second download site's location.

Syntax | SiteRegion1 = string
Value | string
Example
SiteRegion1 = Mexico

Return to top

SiteURL1

Specifies the URL of the second download site.

Syntax | SiteURL1 = URL
Value | URL
Example
SiteURL1 = http://www.fabrikam1.com

Return to top

SiteNameX

Specifies the friendly name of the third or subsequent site from which users download files.

Syntax | SiteNameX = string
Value | string
Example
SiteName5 = My Fifth Home Page

Return to top

SiteRegionX

Specifies the geographical region of the third or subsequent download site's location.

Syntax | SiterRegionX = string
Value | string
Example
SiteRegion5 = Portugal

Return to top

SiteURLX

Specifies the URL of the third or subsequent download site.

Syntax | SiteURLX = URL
Value | URL
Example
SiteURL5 = http://www.fabrikam5.com

Return to top

TestCertsOK

Specifies whether to use test certificates.

Syntax TestCertsOK = 0 | 1
Values 0

Does not use test certificates.

1

Uses test certificates.
Example
TestCertsOK = 1

Return to top


[Animation](.ins)

OPK banner

[Animation]

Answer File = Internet Settings (.ins) File

The [Animation] section contains entries for specifying the location of your custom animated bitmap files that appear in the Setup Wizard.

Entry | Description
Big_Name | Specifies the name of the bitmap file that contains the frames for the 38 x 38-pixel animation.
Big_Path | Specifies the full path to the 38 x 38-pixel animated bitmap file.
DoAnimation | Specifies whether to customize the animation.
Small_Name | Specifies the name of the bitmap file that contains the frames for the 22 x 22-pixel animation.
Small_Path | Specifies the full path to the 22 x 22-pixel animated bitmap file.

Sample

This sample demonstrates one use of the [Animation] section of the Internet Settings (.ins) File.

[Animation]
Big_Name = Large.bmp
Big_Path = C:\Windows\Large.bmp
DoAnimation = 0
Small_Name = Small.bmp
Small_Path = C:\Windows\Small.bmp

Big_Name

Specifies the name of the bitmap file that contains the frames for the 38 x 38-pixel animation.

Syntax | Big_Name = file_name
Value | file_name
Example
Big_Name = Large.bmp

Return to top

Big_Path

Specifies the full path to the 38 x 38-pixel animated bitmap file.

Syntax | Big_Path = path_and_file_name
Value | path_and_file_name
Example
Big_Path = C:\Windows\Large.bmp

Return to top

DoAnimation

Specifies whether to customize the animation.

Syntax | DoAnimation = 0 | 1
Values 0

Does not customize the animation.

1

Customizes the animation.
Default Value | 0
Example
DoAnimation = 0

Return to top

Small_Name

Specifies the name of the bitmap file that contains the frames for the 22 x 22-pixel animation.

Syntax | Small_Name = file_name
Value | file_name
Example
Small_Name = Small.bmp

Return to top

Small_Path

Specifies the full path to the 22 x 22-pixel animated bitmap file.

Syntax | Small_Path = path_and_file_name
Value | path_and_file_name
Example
Small_Path = C:\Windows\Small.bmp

Return to top


[Batch](.ins)

OPK banner

[Batch]

Answer File = Internet Settings (.ins) File

The [Batch] section contains entries for specifying the types of installation media available for your custom package.

Entry | Description
Build_CD | Specifies whether to build a custom package for CD distribution.
Build_Floppy | Specifies whether to build a custom package for distribution on a single floppy disk.
Build_MultiFloppy | Specifies whether to build a custom package for distribution on multiple floppy disks.
Build_W31 | Specifies whether to build a package for distribution to Windows 3.1 users.

Sample

This sample demonstrates one use of the [Batch] section of the Internet Settings (.ins) File.

[Batch]
Build_CD = 1
Build_Floppy = 1
Build_MultiFloppy = 1
Build_W31 = 1

Build_CD

Specifies whether to build a custom package for CD distribution.

Syntax | Build_CD = 0 | 1
Values 0

Does not build a package for CD distribution.

1

Builds a package for CD distribution.
Default Value | 0
Example
Build_CD = 1

Return to top

Build_Floppy

Specifies whether to build a custom package for distribution on a single floppy disk.

Syntax Build_Floppy = 0 | 1
Values 0

Does not build a package for distribution on a single floppy disk.

1

Builds a package for distribution on a single floppy disk.
Example
Build_Floppy = 1

Return to top

Build_MultiFloppy

Specifies whether to build a custom package for distribution on multiple floppy disks.

Syntax Build_MultiFloppy = 0 | 1
Values 0

Does not build a package for distribution on multiple floppy disks.

1

Builds a package for distribution on multiple floppy disks.
Example
Build_MultiFloppy = 1

Return to top

Build_W31

Specifies whether to build a package for distribution to Windows 3.1 users.

Syntax Build_W31 = 0 | 1
Values 0

Does not build a package for distribution to Windows 3.1 users.

1

Builds a package for distribution to Windows 3.1 users.
Example
Build_W31 = 1

Return to top


[Big_Logo](.ins)

OPK banner

[Big_Logo]

Answer File = Internet Settings (.ins) File

The [Big_Logo] section contains entries for specifying the name and path of your 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser.

Entry | Description
Name | Specifies the name of the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.
Path | Specifies the path to the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.

Sample

This sample demonstrates one use of the [Big_Logo] section of the Internet Settings (.ins) File.

[Big_Logo]
Name = BigLogo.bmp
Path = C:\Windows\BigLogo.bmp

Name

Specifies the name of the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.

Syntax | Name = file_name
Value | file_name
Example
Name = BigLogo.bmp

Return to top

Path

Specifies the path to the 38 x 38-pixel bitmap file that appears in the upper-right corner of the browser window.

Syntax | Path = path_and_file_name
Value | path_and_file_name
Example
Path = C:\Windows\BigLogo.bmp

Return to top


[Branding] (.ins)

banner

[Branding]

Answer File = Internet Settings (.ins) File

The [Branding] section contains entries for specifying information about the custom branding and setup information included in your browser package.

Entry | Description
Add on URL | Specifies the add-on Uniform Resource Locator (URL) for the Product Updates command in the browser.
BrowserDefault | Specifies the default browser.
CMBitmapName | Specifies the file name of the Connection Manager custom bitmap file.
CMBitmapPath | Specifies the full path to the Connection Manager custom bitmap file.
CMProfileName | Specifies the name of the Connection Manager profile.
CMProfilePath | Specifies the full path to the Connection Manager profile.
CMUseCustom | Specifies whether to use a custom Connection Manager profile.
CompanyName | Specifies the name of the company with a valid Internet Explorer Administration Kit (IEAK) license that builds this .ins file.
EncodeFavs | Specifies whether to encode the [Favorites] section generated by the IEAK for versions of Microsoft® Internet Explorer earlier than 5.0.
FavoritesDelete | Specifies the value to remove all pre-existing Favorites and Quick Links.
FavoritesOnTop | Specifies whether to add new favorites to the top of the Favorites menu.
IE4WelcomeMsg | Specifies whether to go to a welcome page the first time the browser opens.
Language ID | Specifies the code page of the language used.
Language Locale | Specifies the locale of the Internet Explorer version that you customize.
NoDial | Specifies whether to use an IEAK-based sign-up process.
NoIELite | Specifies whether the Active Setup wizard optimizes for downloading.
SilentInstall | Specifies whether Windows Update Setup runs noninteractively.
StealthInstall | Specifies whether Windows Update Setup runs without visual feedback.
ToolbarBitmap | Specifies the full path to the bitmap file that appears on the browser toolbar.
Type | Specifies the type of customization used.
User Agent | Specifies the string appended to the default User Agent string.
Version | Specifies the browser version.
WebIntegrated | Specifies whether to include the integrated shell of Internet Explorer 4.x in this package.
Win32DownloadSite | Specifies the URL from which the Windows Update Setup file (IEsetup.exe) downloads.
Window_Title | Specifies the customized window title for Internet Explorer.
Window_Title_CN | Specifies the company name appended to the window title.
Wizard_Version | Specifies the version of the IEAK wizard that created the .ins file.

Sample

This sample demonstrates one use of the [Branding] section of the Internet Settings (.ins) File.

[Branding]
Add on URL = http://server/addons/addon.htm
BrowserDefault = 2
CMBitmapName = CMBitmap.bmp
CMBitmapPath = C:\Windows
CMProfileName = profile.ext
CMProfilePath = C:\Windows
CMUseCustom = 1
CompanyName = Fabrikam
EncodeFavs = 1
FavoritesDelete = 0x89
FavoritesOnTop = 1
IE4WelcomeMsg = 1
Language ID = 1033
Language Locale = EN
NoDial = 1
NoIELite = 1
SilentInstall = 1
StealthInstall = 1
ToolbarBitmap = C:\Windows\MyBitmap.bmp
Type = 1
User Agent = UATEST
Version = 5
WebIntegrated = 1
Win32DownloadSite = http://www.fabrikam.com
Window_Title = Internet Explorer Presented By Fabrikam
Window_Title_CN = Fabrikam
Wizard_Version = 6.00.2600.0000

Add on URL

Specifies the add-on URL for the Product Updates command in the browser.

Syntax | Add on URL = URL
Value | URL
Example
Add on URL = http://server/addons/addon.htm

Return to top

BrowserDefault

Specifies the default browser.

Syntax | BrowserDefault = 0 | 1 | 2
Values 0

Designates Internet Explorer as the default browser.

1

Preserves the existing default browser.

2

Lets the end user choose the default browser.
Default Value | 2
Example
BrowserDefault = 2

Return to top

CMBitmapName

Specifies the file name of the Connection Manager custom bitmap file.

Syntax | CMBitmapName = file_name
Value | file_name
Example
CMBitmapName = CMBitmap.bmp

Return to top

CMBitmapPath

Specifies the full path to the Connection Manager custom bitmap file.

Syntax | CMBitmapPath = path
Value | path
Example
CMBitmapPath = C:\Windows

Return to top

CMProfileName

Specifies the name of the Connection Manager profile.

Syntax | CMProfileName = Profile.ext
Value | file_name
Example
CMProfileName = profile.ext

Return to top

CMProfilePath

Specifies the full path to the Connection Manager profile.

Syntax | CMProfilePath = path
Value | path
Example
CMProfilePath = C:\Windows

Return to top

CMUseCustom

Specifies whether to use a custom Connection Manager profile.

Syntax | CMUseCustom = 0 | 1
Values 0

Does not use a custom profile.

1

Uses a custom profile.
Default Value | 0
Example
CMUseCustom = 1

Return to top

CompanyName

Specifies the name of the company with a valid Internet Explorer Administration Kit (IEAK) license that builds this .ins file.

Syntax | CompanyName = name
Value | name
Example
CompanyName = Fabrikam

Return to top

EncodeFavs

Specifies whether to encode the [Favorites] section generated by the IEAK for versions of Internet Explorer earlier than 5.0.

Syntax | EncodeFavs = 0 | 1
Values 0

Does not encode the [Favorites] section.

1

Encodes the [Favorites] section generated by the IEAK for versions of Internet Explorer earlier than 5.0.
Default Value | 0
Example
EncodeFavs = 1

Return to top

FavoritesDelete

Specifies the value to remove all pre-existing Favorites and Quick Links.

Syntax FavoritesDelete = hexadecimal
Value hexadecimal

Set this value to 0x89 to remove all pre-existing Favorites and Quick Links. This feature is available to corporate administrators.
Example
FavoritesDelete = 0x89

Return to top

FavoritesOnTop

Specifies whether to add new favorites to the top of the Favorites menu.

Syntax | FavoritesOnTop = 0 | 1
Values 0

Adds new favorites to the bottom of the Favorites menu.

1

Adds new favorites to the top of the Favorites menu.
Default Value | 0
Example
FavoritesOnTop = 1

Return to top

IE4WelcomeMsg

Specifies whether to go to a welcome page the first time the browser opens.

Syntax IE4WelcomeMsg = 0 | 1
Values 0

Does not go to a welcome page the first time the browser opens.

1

Goes to a welcome page the first time the browser opens.
Example
IE4WelcomeMsg = 1

Return to top

Language ID

Specifies the code page of the language used.

Syntax | Language ID = number
Value | number
Example
Language ID = 1033

Return to top

Language Locale

Specifies the locale of the Internet Explorer version that you customize.

Syntax Language Locale = locale
Value locale

Denoted by a two-letter string. For example, EN for English.
Example
Language Locale = EN

Return to top

NoDial

Specifies whether to use an IEAK-based sign-up process.

Syntax | NoDial = 0 | 1
Values 0

Uses an IEAK-based sign-up process.

1

Does not use any kind of an IEAK-based sign-up process.
Default Value | 1 if not serverless, kiosk, or ICW mode. Otherwise, 0.
Example
NoDial = 1

Return to top

NoIELite

Specifies whether the Active Setup wizard optimizes for downloading.

Syntax | NoIELite = 0 | 1
Values 0

The Active Setup wizard does not optimize for downloading.

1

The Active Setup wizard optimizes for downloading, using existing files if possible.
Default Value | 1
Example
NoIELite = 1

Return to top

SilentInstall

Specifies whether Windows Update Setup runs noninteractively.

Syntax | SilentInstall = 0 | 1
Values 0

Windows Update Setup does not run noninteractively.

1

Windows Update Setup runs noninteractively, but shows progress and error messages.
Default Value | 0
Example
SilentInstall = 1

Return to top

StealthInstall

Specifies whether Windows Update Setup runs without visual feedback.

Syntax | StealthInstall = 0 | 1
Values 0

Windows Update Setup does not run without visual feedback.

1

Windows Update Setup runs without any visual feedback.
Default Value | 0
Example
StealthInstall = 1

Return to top

ToolbarBitmap

Specifies the full path to the bitmap file that appears on the browser toolbar.

Syntax | ToolbarBitmap = path_and_file_name
Value | path_and_file_name
Example
ToolbarBitmap = C:\Windows\MyBitmap.bmp

Return to top

Type

Specifies the type of customization used.

Syntax | Type = 0 | 1 | 2
Values 0

Customization is tailored to an Internet content provider.

1

Customization is tailored to an Internet service provider.

2

Customization is tailored to a corporate administrator.
Default Value | 0 (for invalid input, 2)
Example
Type = 1

Return to top

User Agent

Specifies the string appended to the default User Agent string.

Syntax | User Agent = string
Value | string
Example
User Agent = UATEST

Return to top

Version

Specifies the browser version.

Syntax | Version = string
Value | string
Example
Version = 5

Return to top

WebIntegrated

Specifies whether to include the integrated shell of Internet Explorer 4.x in this package.

Syntax | WebIntegrated = 0 | 1
Values 0

Does not include the integrated shell of Internet Explorer 4.x in this package.

1

Includes the integrated shell of Internet Explorer 4.x in this package.
Default Value | 0
Example
WebIntegrated = 1

Return to top

Win32DownloadSite

Specifies the URL from which the Windows Update Setup file (IEsetup.exe) downloads.

Syntax | Win32DownloadSite = url
Value | url
Example
Win32DownloadSite = http://www.fabrikam.com

Return to top

Window_Title

Specifies the customized window title for Internet Explorer.

Syntax | Window_Title = string
Value | string
Example
Window_Title = Internet Explorer Presented By Fabrikam

Return to top

Window_Title_CN

Specifies the company name appended to the window title.

Syntax | Window_title_CN = string
Value | string
Example
Window_Title_CN = Fabrikam

Return to top

Wizard_Version

Specifies the version of the IEAK wizard that created the .ins file.

Syntax | Wizard_Version = string
Value | string
Example
Wizard_Version = 6.00.2600.0000

Return to top


[BrowserToolbars] (.ins)

banner

[BrowserToolbars]

Answer File = Internet Settings (.ins) File

The [BrowserToolbars] section contains entries for customizing the appearance of the Microsoft® Internet Explorer toolbar.

Entry | Description
Action0 | Specifies the path and file name for the executable file associated with a custom toolbar button.
Caption0 | Specifies the caption for the custom toolbar button.
DeleteButtons | Specifies whether to delete existing custom toolbar buttons during installation.
HotIcon0 | Specifies the highlighted icon (an .ico file) that appears when the end user points the mouse to the toolbar button.
Icon0 | Specifies the dimmed icon (an .ico file) that appears when the end user does not point the mouse to the toolbar button.
Show0 | Specifies whether to display the new button on the toolbar by default.
ToolTipText0 | Specifies the ToolTip text for the custom button.

Sample

This sample demonstrates one use of the [BrowserToolbars] section of the Internet Settings (.ins) File.

[BrowserToolbars]
Action0 = C:\Windows\MyToolbar.exe
Caption0 = My Custom Button
DeleteButtons = 1
HotIcon0 = C:\Windows\MyIcon_Hot.ico
Icon0 = C:\Windows\MyIcon_Normal.ico
Show0 = 1
ToolTipText0 = Opens a new browser window

Action0

Specifies the path and file name for the executable file associated with a custom toolbar button.

Syntax | Action0 = path_and_file_name
Value | path_and_file_name
Example
Action0 = C:\Windows\MyToolbar.exe

Return to top

Caption0

Specifies the caption for the custom toolbar button.

Syntax | Caption0 = caption
Value | caption
Example
Caption0 = My Custom Button

Return to top

DeleteButtons

Specifies whether to delete existing custom toolbar buttons during installation.

Syntax | DeleteButtons = 0 | 1
Values 0

Does not delete the existing custom toolbar buttons.

1

Deletes the buttons.
Default Value | 0
Example
DeleteButtons = 1

Return to top

HotIcon0

Specifies the highlighted icon (an .ico file) that appears when the end user points the mouse to the toolbar button.

Syntax | HotIcon0 = path_and_file_name
Value | path_and_file_name
Example
HotIcon0 = C:\Windows\MyIcon_Hot.ico

Return to top

Icon0

Specifies the dimmed icon (an .ico file) that appears when the end user does not point the mouse to the toolbar button.

Syntax | Icon0 = path_and_file_name
Value | path_and_file_name
Example
Icon0 = C:\Windows\MyIcon_Normal.ico

Return to top

Show0

Specifies whether to display the new button on the toolbar by default.

Syntax Show0 = 0 | 1
Values 0

Does not display the button.

1

Displays the button.
Example
Show0 = 1

Return to top

ToolTipText0

Specifies the ToolTip text for the custom button.

Syntax | ToolTiptext0 = text
Value | text
Example
ToolTipText0 = Opens a new browser window

Return to top


[CabSigning](.ins)

OPK banner

[CabSigning]

Answer File = Internet Settings (.ins) File

The [CabSigning] section contains entries for specifying the information used to sign your programs.

Entry | Description
InfoURL | Specifies the Uniform Resource Locator (URL) that appears on the certificate dialog box.
Name | Specifies the company name associated with the certificate.
PvkFile | Specifies the path to the private key file.
SpcFile | Specifies the path to the certificate file.

Sample

This sample demonstrates one use of the [CabSigning] section of the Internet Settings (.ins) File.

[CabSigning]
InfoURL = http://www.fabrikam.com
Name = CompanyName
PvkFile = C:\Windows\pvkfile.pvk
SpcFile = C:\Windows\spcfile.spc

InfoURL

Specifies the URL that appears on the certificate dialog box.

Syntax | InfoURL = URL
Value | URL
Example
InfoURL = http://www.fabrikam.com

Return to top

Name

Specifies the company name associated with the certificate.

Syntax | Name = string
Value | string
Example
Name = CompanyName

Return to top

PvkFile

Specifies the path to the private key file.

Syntax | pvkFile = path_and_file_name
Value | path_and_file_name
Example
PvkFile = C:\Windows\pvkfile.pvk

Return to top

SpcFile

Specifies the path to the certificate file.

Syntax | SpcFile = path_and_file_name
Value | path_and_file_name
Example
spcFile = C:\Windows\spcfile.spc

Return to top


[ConnectionSettings] (.ins)

banner

[ConnectionSettings]

Answer File = Internet Settings (.ins) File

The [ConnectionSettings] section contains entries for specifying information about the dial-up networking connection settings used to install your custom Microsoft® Internet Explorer package. This creates common network connection settings on all users' workstations.

Entry | Description
ConnectName0 | Specifies the primary name for the connection.
ConnectName1 | Specifies the secondary name for the connection.
DeleteConnectionSettings | Specifies whether to remove the existing connection settings during installation.
Option | Specifies whether the end user can import connection settings in the Internet Explorer Administration Kit (IEAK) wizard.

Sample

This sample demonstrates one use of the [ConnectionSettings] section of the Internet Settings (.ins) File.

[ConnectionSettings]
ConnectName0 = MyConnection
ConnectName1 = MySecondConnection
DeleteConnectionSettings = 1
Option = 1

ConnectName0

Specifies the primary name for the connection.

Syntax | ConnectName0 = string
Value | string
Example
ConnectName0 = MyConnection

Return to top

ConnectName1

Specifies the secondary name for the connection.

Syntax | ConnectName1 = string
Value | string
Example
ConnectName1 = MySecondConnection

Return to top

DeleteConnectionSettings

Specifies whether to remove the existing connection settings during installation.

Syntax | DeleteConnectionSettings = 0 | 1
Values 0

Does not remove the existing connection settings during installation.

1

Removes the settings only in corporate Administrator mode.
Default Value | 0
Example
DeleteConnectionSettings = 1

Return to top

Option

Specifies whether the end user can import connection settings in the Internet Explorer Administration Kit (IEAK) wizard.

Syntax | Option = 0 | 1
Values 0

Does not give the end user the option to import connection settings in the IEAK wizard.

1

Gives the end user the option to import connection settings in the IEAK Wizard.
Default Value | 0
Example
Option = 1

Return to top


[CustomBranding](.ins)

banner

[CustomBranding]

Answer File = Internet Settings (.ins) File

The [CustomBranding] section contains an entry for specifying the Uniform Resource Locator (URL) for your branding cabinet file.

Entry | Description
Branding | Specifies the URL for the branding .cab file.

Sample

This sample demonstrates one use of the [CustomBranding] section of the Internet Settings (.ins) File.

[CustomBranding]
Branding = http://www.yourserver.net/cabs/branding.cab

Branding

Specifies the URL for the branding .cab file.

Syntax | Branding = url
Value | url
Example
Branding = http://www.yourserver.net/cabs/branding.cab

Return to top


[CustomWallpaper] (.ins)

banner

[CustomWallpaper]

Answer File = Internet Settings (.ins) File

The [CustomWallpaper] section contains entries for specifying the Hypertext Markup Language (HTML) and supporting files for your custom wallpaper.

Entry | Description
File0 | Specifies the HTML file for the custom wallpaper, also known as background, to install.
File1 | Specifies the supporting files for the custom background.
NumFiles | Specifies the total number of files for the custom background.

Sample

This sample demonstrates one use of the [CustomWallpaper] section of the Internet Settings (.ins) File.

[CustomWallpaper]
File0 = MyWallpaper.htm
File1 = MyWallpaper2.htm
NumFiles = 2

File0

Specifies the HTML file for the custom wallpaper, also known as background, to install.

Syntax | File0 = file_name
Value | file_name
Example
File0 = MyWallpaper.htm

Return to top

File1

Specifies the supporting files for the custom background.

Syntax | File1 = file_name
Value | file_name
Example
File1 = MyWallpaper2.htm

Return to top

NumFiles

Specifies the total number of files for the custom background.

Syntax | NumFiles = number
Value | number
Example
NumFiles = 2

Return to top


[Device] (.ins)

banner

[Device]

Answer File = Internet Settings (.ins) File

The [Device] section contains an entry for specifying the type of connection used for Setup.

Entry | Description
Type | Specifies the type of connection used for Windows Update Setup.

Sample

This sample demonstrates one use of the [Device] section of the Internet Settings (.ins) File.

[Device]
Type = modem

Type

Specifies the type of connection used for Windows Update Setup.

Syntax | Type = string
Value | string
Example
Type = modem

Return to top


[Entry] (.ins)

banner

[Entry]

Answer File = Internet Settings (.ins) File

The [Entry] section contains entries for specifying whether the information in this .ins file overrides the name of the dial-up networking in your custom package.

Entry | Description
Cancel | Specifies whether to cancel the sign-up process. Used by the Internet Connection Wizard.
Entry_Name | Specifies the name of the dial-up connection.

Sample

This sample demonstrates one use of the [Entry] section of the Internet Settings (.ins) File.

[Entry]
Cancel = No
Entry_Name = MyConnection

Cancel

Specifies whether to cancel the sign-up process. Used by the Internet Connection Wizard.

Syntax | Cancel = Yes | No
Values Yes

Cancels the sign-up process.

No

Does not cancel the sign-up process.
Default Value | No
Example
Cancel = No

Return to top

Entry_Name

Specifies the name of the dial-up connection.

Syntax | Entry_Name = string
Value | string
Example
Entry_Name = MyConnection

Return to top


[ExtRegInf](.ins)

OPK banner

[ExtRegInf]

Answer File = Internet Settings (.ins) File

The [ExtRegInf] section contains entries for specifying the names of your information (.inf) files and the installation mode for components.

Entry | Description
Chat | Specifies the information (.inf) file and installation mode for components.
Conf | Specifies the information (.inf) file and installation mode for components.
ConnectionSettings | Specifies the information (.inf) file and installation mode for components.
Inetres | Specifies the information (.inf) file and installation mode for components.
Inetset | Specifies the information (.inf) file and installation mode for components.
Oe | Specifies the information (.inf) file and installation mode for components.
Shell | Specifies the information (.inf) file and installation mode for components.
Sp1shell | Specifies the information (.inf) file and installation mode for components.
Subs | Specifies the information (.inf) file and installation mode for components.

Sample

This sample demonstrates one use of the [ExtRegInf] section of the Internet Settings (.ins) File.

[ExtRegInf]
Chat = *,chat.inf,DefaultInstall
Conf = *,conf.inf,DefaultInstall
ConnectionSettings = *,connect.inf,DefaultInstall
Inetres = *,inetres.inf,DefaultInstall
Inetset = *,inetset.inf,DefaultInstall
Oe = *,oe.inf,DefaultInstall
Shell = *,shell.inf,DefaultInstall
Sp1shell = *,sp1shell.inf,DefaultInstall
Subs = *,subs.inf,DefaultInstall

Chat

Specifies the information (.inf) file and installation mode for components.

Syntax | Chat = string
Value | string
Example
Chat = *,chat.inf,DefaultInstall

Return to top

Conf

Specifies the information (.inf) file and installation mode for components.

Syntax | Conf = string
Value | string
Example
Conf = *,conf.inf,DefaultInstall

Return to top

ConnectionSettings

Specifies the information (.inf) file and installation mode for components.

Syntax | ConnectionSettings = string
Value | string
Example
ConnectionSettings = *,connect.inf,DefaultInstall

Return to top

Inetres

Specifies the information (.inf) file and installation mode for components.

Syntax | Inetres = string
Value | string
Example
Inetres = *,inetres.inf,DefaultInstall

Return to top

Inetset

Specifies the information (.inf) file and installation mode for components.

Syntax | Inetset = string
Value | string
Example
Inetset = *,inetset.inf,DefaultInstall

Return to top

Oe

Specifies the information (.inf) file and installation mode for components.

Syntax | Oe = string
Value | string
Example
Oe = *,oe.inf,DefaultInstall

Return to top

Shell

Specifies the information (.inf) file and installation mode for components.

Syntax | Shell = string
Value | string
Example
Shell = *,shell.inf,DefaultInstall

Return to top

Sp1shell

Specifies the information (.inf) file and installation mode for components.

Syntax | Sp1shell = string
Value | string
Example
Sp1shell = *,sp1shell.inf,DefaultInstall

Return to top

Subs

Specifies the information (.inf) file and installation mode for components.

Syntax | Subs = string
Value | string
Example
Subs = *,subs.inf,DefaultInstall

Return to top


[FavoritesEx] (.ins)

banner

[FavoritesEx]

Answer File = Internet Settings (.ins) File

The [FavoritesEx] section contains entries for specifying the path to your icon file for Favorites, the Uniform Resource Locator (URL) to each Favorite site, and whether Favorites are available offline.

Entry | Description
IconFile1 | Specifies the icon for the favorite.
Offline1 | Specifies whether to make the favorite available for offline browsing.
Title1 | Specifies the title of the favorite.
Url1 | Specifies the URL of the favorite.

Sample

This sample demonstrates one use of the [FavoritesEx] section of the Internet Settings (.ins) File.

[FavoritesEx]
IconFile1 = C:\Windows\MyFile.ico
Offline1 = 1
Title1 = My Custom Title
Url1 = http://www.fabrikam.com

IconFile1

Specifies the icon for the favorite.

Syntax | IconFile1 = path_and_file_name
Value | path_and_file_name
Example
IconFile1 = C:\Windows\MyFile.ico

Return to top

Offline1

Specifies whether to make the favorite available for offline browsing.

Syntax Offline1 = 0 | 1
Values 0

Does not make the favorite available for offline browsing.

1

Makes the favorite available for offline browsing.
Example
Offline1 = 1

Return to top

Title1

Specifies the title of the favorite.

Syntax | Title1 = string
Value | string
Example
Title1 = My Custom Title

Return to top

Url1

Specifies the URL of the favorite.

Syntax | Url1 = url
Value | url
Example
Url1 = http://www.fabrikam.com

Return to top


[HideCustom](.ins)

OPK banner

[HideCustom]

Answer File = Internet Settings (.ins) File

The [HideCustom] section contains an entry for specifying whether to hide the globally unique identifier (GUID). Each custom component has a GUID that is based on system information and other parameters, such as the time of day it is created.

Entry | Description
GUID | Specifies whether this is a hidden component.

Sample

This sample demonstrates one use of the [HideCustom] section of the Internet Settings (.ins) File.

[HideCustom]
GUID = 1

GUID

Specifies whether this is a hidden component.

Syntax GUID = 0 | 1
Values 0

This is not a hidden component.

1

This is a hidden component.
Example
GUID = 1

Return to top


[ICW_IEAK](.ins)

OPK banner

[ICW_IEAK]

Answer File = Internet Settings (.ins) File

The [ICW_IEAK] section contains entries for specifying the path to your custom bitmap files that appear in the Internet Connection Wizard (ICW).

Entry | Description
Header_Bitmap | Specifies the path to the custom header bitmap file that appears in the ICW.
Watermark_Bitmap | Specifies the path to the custom watermark bitmap that appears in the ICW.

Sample

This sample demonstrates one use of the [ICW_IEAK] section of the Internet Settings (.ins) File.

[ICW_IEAK]
Header_Bitmap = C:\Windows\MyBitmap.bmp
Watermark_Bitmap = C:\Windows\MyWatermark.bmp

Header_Bitmap

Specifies the path to the custom header bitmap file that appears in the Internet Connection Wizard (ICW).

Syntax | Header_Bitmap = path_and_file_name
Value | path_and_file_name
Example
Header_Bitmap = C:\Windows\MyBitmap.bmp

Return to top

Watermark_Bitmap

Specifies the path to the custom watermark bitmap that appears in the ICW.

Syntax | Watermark_Bitmap = path_and_file_name
Value | path_and_file_name
Example
Watermark_Bitmap = C:\Windows\MyWatermark.bmp

Return to top


[Internet_Mail] (.ins)

banner

[Internet_Mail]

Answer File = Internet Settings (.ins) File

The [Internet_Mail] section contains entries for specifying your custom Microsoft® Outlook® Express information.

Entry | Description
Default_Client | Specifies whether Internet Mail is the default client (for Microsoft Internet Explorer 4.x Custom).
Infopane | Specifies the Hypertext Markup Language (HTML) file for the branded infopane of customized Outlook Express.
Infopane_Bitmap | Specifies the branded .gif file for customized Outlook Express.
Junk_Mail_Filtering | Specifies whether to activate the junk-mail filtering feature by default.
Logon_Using_SPA | Specifies whether to log on by using Secure Password Authentication.
POP_Server | Specifies the host name of the POP3 Server to set by default.
SMTP_Logon_Required | Specifies whether to require logging on to the Simple Mail Transfer Protocol (SMTP) Server by default.
SMTP_Logon_Using_SPA | Specifies whether to log on to the SMTP Server using Secure Password Authentication.
SMTP_Server | Specifies the host name of the SMTP server to set by default.
Use_IMAP | Specifies whether to use the IMAP4 protocol for e-mail.
Welcome_Address | Specifies the "From Address" for the Welcome message in Outlook Express.
Welcome_Message | Specifies the location of the HTML file containing the Welcome message.
Welcome_Name | Specifies the friendly name of the "From Address" for the Welcome message.
Window_Title | Specifies the custom window title for Outlook Express.

Sample

This sample demonstrates one use of the [Internet_Mail] section of the Internet Settings (.ins) File.

[Internet_Mail]
Default_Client = No
Infopane = C:\Windows\MyInfopane.htm
Infopane_Bitmap = C:\Windows\MyInfopane.gif
Junk_Mail_Filtering = 1
Logon_Using_SPA = Yes
POP_Server = pop.fabrikam.com
SMTP_Logon_Required = 1
SMTP_Logon_Using_SPA = Yes
SMTP_Server = smtp.fabrikam.com
Use_IMAP = Yes
Welcome_Address = welcome@fabrikam.com
Welcome_Message = C:\Windows\MyWelcome.htm
Welcome_Name = "Welcome to Custom Internet Mail"
Window_Title = My Custom Window Title

Default_Client

Specifies whether Internet Mail is the default client (for Internet Explorer 4.x Custom).

Syntax | Default_Client = Yes | No
Values Yes

Internet Mail is the default client.

No

Internet Mail is not the default client.
Default Value | No
Example
Default_Client = No

Return to top

Infopane

Specifies the HTML file for the branded infopane of customized Outlook Express.

Syntax | Infopane = path_and_file_name
Value | path_and_file_name
Example
Infopane = C:\Windows\MyInfopane.htm

Return to top

Infopane_Bitmap

Specifies the branded .gif file for customized Outlook Express.

Syntax | Infopane_Bitmap = path_and_file_name
Value | path_and_file_name
Example
Infopane_Bitmap = C:\Windows\MyInfopane.gif

Return to top

Junk_Mail_Filtering

Specifies whether to activate the junk-mail filtering feature by default.

Syntax | Junk_Mail_Filtering = 0 | 1
Values 0

Does not activate the junk-mail filtering feature by default.

1

Activates the junk-mail filtering feature by default.
Default Value | 0
Example
Junk_Mail_Filtering = 1

Return to top

Logon_Using_SPA

Specifies whether to log on by using Secure Password Authentication.

Syntax | Logon_Using_SPA = Yes | No
Values Yes

Logs on using Secure Password Authentication.

No

Does not log on using Secure Password Authentication.
Default Value | No
Example
Logon_Using_SPA = Yes

Return to top

POP_Server

Specifies the host name of the POP3 Server to set by default.

Syntax | POP_Server = string
Value | string
Example
POP_Server = pop.fabrikam.com

Return to top

SMTP_Logon_Required

Specifies whether to require logging on to the Simple Mail Transfer Protocol (SMTP) Server by default.

Syntax | SMTP_Logon_Required = 0 | 1
Values 0

Does not require logging on to the SMTP Server by default.

1

Requires logging on to the SMTP Server by default.
Default Value | 0
Example
SMTP_Logon_Required = 1

Return to top

SMTP_Logon_Using_SPA

Specifies whether to log on to the SMTP Server using Secure Password Authentication.

Syntax | SMTP_Logon_Using_SPA = Yes | No
Values Yes

Logs on to the SMTP Server using Secure Password Authentication.

No

Does not log on to the SMTP Server using Secure Password Authentication.
Default Value | No
Example
SMTP_Logon_Using_SPA = Yes

Return to top

SMTP_Server

Specifies the host name of the SMTP server to set by default.

Syntax | SMTP_Server = string
Value | string
Example
SMTP_Server = smtp.fabrikam.com

Return to top

Use_IMAP

Specifies whether to use the IMAP4 protocol for e-mail.

Syntax | Use_IMAP = Yes | No
Values Yes

Uses the IMAP4 protocol for e-mail.

No

Does not use the IMAP4 protocol for e-mail.
Default Value | No
Example
Use_IMAP = Yes

Return to top

Welcome_Address

Specifies the "From Address" for the Welcome message in Outlook Express.

Syntax | Welcome_Address = string
Value | string
Example
Welcome_Address = welcome@fabrikam.com

Return to top

Welcome_Message

Specifies the location of the HTML file containing the Welcome message.

Syntax | Welcome_Message = path_and_file_name
Value | path_and_file_name
Example
Welcome_Message = C:\Windows\MyWelcome.htm

Return to top

Welcome_Name

Specifies the friendly name of the "From Address" for the Welcome message.

Syntax | Welcome_Name = string
Value | string
Example
Welcome_Name = "Welcome to Custom Internet Mail"

Return to top

Window_Title

Specifies the custom window title for Outlook Express.

Syntax | Window_Title = string
Value | string
Example
Window_Title = My Custom Window Title

Return to top


[Internet_News] (.ins)

banner

[Internet_News]

Answer File = Internet Settings (.ins) File

The [Internet_News] section contains entries for specifying your custom news information and whether Microsoft® Outlook® Express is the default news client.

Entry | Description
Default_Client | Specifies whether to use Outlook Express as the default news client.
Logon_Required | Specifies whether the Network News Transfer Protocol (NNTP) server requires that end users log on to it.
Logon_Using_SPA | Specifies whether the NNTP server uses Secure Password Authentication.
NNTP_Server | Specifies the host name of your NNTP server.

Sample

This sample demonstrates one use of the [Internet_News] section of the Internet Settings (.ins) File.

[Internet_News]
Default_Client = No
Logon_Required = 1
Logon_Using_SPA = Yes
NNTP_Server = news.fabrikam.com

Default_Client

Specifies whether to use Outlook Express as the default news client.

Syntax | Default_Client = Yes | No
Values Yes

Uses Outlook Express as the default news client.

No

Does not use Outlook Express as the default news client.
Default Value | No
Example
Default_Client = No

Return to top

Logon_Required

Specifies whether the Network News Transfer Protocol (NNTP) server requires that end users log on to it.

Syntax | Logon_Required = 0 | 1
Values 0

Does not require end users to log on to the NNTP server.

1

Requires end users to log on to the NNTP server.
Default Value | 1
Example
Logon_Required = 1

Return to top

Logon_Using_SPA

Specifies whether the NNTP server uses Secure Password Authentication.

Syntax | Logon_Using_SPA = Yes | No
Values Yes

The NNTP server uses Secure Password Authentication.

No

The NNTP server does not use Secure Password Authentication.
Default Value | No
Example
Logon_Using_SPA = Yes

Return to top

NNTP_Server

Specifies the host name of your NNTP server.

Syntax | NNTP_Server = string
Value | string
Example
NNTP_Server = news.fabrikam.com

Return to top


[ISP_Security] (.ins)

banner

[ISP_Security]

Answer File = Internet Settings (.ins) File

The [ISP_Security] section contains an entry for specifying the root certificate to add to your custom package.

Entry | Description
RootCertPath | Specifies a root certificate to add to the system.

Sample

This sample demonstrates one use of the [ISP_Security] section of the Internet Settings (.ins) File.

[ISP_Security]
RootCertPath = c:\myfolder\mycertfile.ext

RootCertPath

Specifies a root certificate to add to the system.

Syntax | RootCertPath = path_and_file_name
Value | path_and_file_name
Example
RootCertPath = c:\myfolder\mycertfile.ext

Return to top


[LDAP] (.ins)

banner

[LDAP]

Answer File = Internet Settings (.ins) File

The [LDAP] section contains entries for specifying information for your Lightweight Directory Access Protocol (LDAP) server. Also specifies whether Microsoft® Outlook® Express always checks names and e-mail addresses against the LDAP server.

Entry | Description
AuthType | Specifies how the Windows Address Book accesses directory services.
Bitmap | Specifies the path and file name of a bitmap to be used with the Address Book directory service. For more information, see the Internet Explorer Administration Kit Help.
Checknames | Specifies whether Outlook Express always checks names and e-mail addresses against the LDAP server.
FriendlyName | Specifies the friendly name for the LDAP server account.
HomePage | Specifies the location of the home page for the browser.
SearchBase | Specifies the location of the search page for the browser.
Server | Specifies the host name of the LDAP server.

Sample

This sample demonstrates one use of the [LDAP] section of the Internet Settings (.ins) File.

[LDAP]
AuthType = 2
Bitmap = C:\My Documents\Branding\LDAP.bmp
Checknames = 1
FriendlyName = My LDAP Server Account
HomePage = http://www.fabrikam.com
SearchBase = http://www.fabrikam.com
Server = LDAP-SRV-1

AuthType

Specifies how the Windows Address Book accesses directory services.

Syntax | AuthType = 0 | 2
Values 0

Authenticates through the built-in access to popular directories.

2

Authenticates through SPA.
Default Value | 0
Example
AuthType = 2
Comment | For more information, see Address Book directory service.

Return to top

Bitmap

Specifies the path and file name of a bitmap to be used with the Address Book directory service. For more information, see the Internet Explorer Administration Kit Help.

Syntax | Bitmap = path_and_file_name
Value | path_and_file_name
Example
Bitmap = C:\My Documents\Branding\LDAP.bmp

Return to top

Checknames

Specifies whether Outlook Express always checks names and e-mail addresses against the LDAP server.

Syntax | Checknames = 0 | 1
Values 0

Outlook Express does not check names and e-mail addresses against the LDAP server.

1

Outlook Express always checks names and e-mail addresses against the LDAP server.
Default Value | 0
Example
Checknames = 1

Return to top

FriendlyName

Specifies the friendly name for the LDAP server account.

Syntax | FriendlyName = string
Value | string
Example
FriendlyName = My LDAP Server Account

Return to top

HomePage

Specifies the location of the home page for the browser.

Syntax | HomePage = url
Value | url
Example
HomePage = http://www.fabrikam.com

Return to top

SearchBase

Specifies the location of the search page for the browser.

Syntax | SearchBase = url
Value | url
Example
SearchBase = http://www.fabrikam.com

Return to top

Server

Specifies the host name of the LDAP server.

Syntax | Server = string
Value | string
Example
Server = LDAP-SRV-1

Return to top


[Mail_Signature] (.ins)

banner

[Mail_Signature]

Answer File = Internet Settings (.ins) File

The [Mail_Signature] section contains entries for specifying an e-mail signature for news and whether to use the signature.

Entry | Description
Signature_Text | Specifies the boilerplate text that is automatically appended to the end of e-mail messages or newsgroup postings. To indicate a new line in the signature, use the characters "\n".
Use_Mail_For_News | Specifies whether to append the value of Signature_Text to the end of postings to newsgroups.
Use_Signature | Specifies whether to append the value of Signature_Text to the end of e-mail messages.

Sample

This sample demonstrates one use of the [Mail_Signature] section of the Internet Settings (.ins) File.

[Mail_Signature]
Signature_Text = Tell your friends about our free e-mail!
Use_Mail_For_News = 1
Use_Signature = 1

Signature_Text

Specifies the boilerplate text that is automatically appended to the end of e-mail messages or newsgroup postings. To indicate a new line in the signature, use the characters "\n".

Syntax | Signature_Text = string
Value | string
Example
Signature_Text = Tell your friends about our free e-mail!

Return to top

Use_Mail_For_News

Specifies whether to append the value of Signature_Text to the end of postings to newsgroups.

Syntax | Use_Mail_For_News = 0 | 1
Values 0

Does not append the value of Signature_Text to the end of postings to newsgroups.

1

Appends the value of Signature_Text to the end of postings to newsgroups.
Default Value | 0
Example
Use_Mail_For_News = 1

Return to top

Use_Signature

Specifies whether to append the value of Signature_Text to the end of e-mail messages.

Syntax | Use_Signature = 0 | 1
Values 0

Does not append the value of Signature_Text to the end of e-mail messages.

1

Appends the value of Signature_Text to the end of e-mail messages.
Default Value | 0
Example
Use_Signature = 1

Return to top


[Media](.ins)

OPK banner

[Media]

Answer File = Internet Settings (.ins) File

The [Media] section contains entries for specifying the types of media that your installation package is available in, such as CD, download, and floppy disk.

Entry | Description
Build_CD | Specifies whether to create a CD installation package.
Build_Download | Specifies whether to create an installation package that users can download.
Build_Floppy | Specifies whether to create a branding-only installation package that fits on a single floppy disk.
Build_LAN | Specifies whether to create an installation package for a local-area network (LAN).
Build_MultiFloppy | Specifies whether to create an installation package that fits on multiple floppy disks.

Sample

This sample demonstrates one use of the [Media] section of the Internet Settings (.ins) File.

[Media]
Build_CD = 1
Build_Download = 1
Build_Floppy = 0
Build_LAN = 0
Build_MultiFloppy = 0

Build_CD

Specifies whether to create a CD installation package.

Syntax | Build_CD = 0 | 1
Values 0

Does not create a CD installation package.

1

Creates a CD installation package.
Default Value | 0
Example
Build_CD = 1

Return to top

Build_Download

Specifies whether to create an installation package that users can download.

Syntax | Build_Download = 0 | 1
Values 0

Does not create an installation package that users can download.

1

Creates an installation package that users can download.
Default Value | 1
Example
Build_Download = 1

Return to top

Build_Floppy

Specifies whether to create a branding-only installation package that fits on a single floppy disk.

Syntax | Build_Floppy = 0 | 1
Values 0

Does not create a branding-only installation package that fits on a single floppy disk.

1

Creates a branding-only installation package that fits on a single floppy disk.
Default Value | 0
Example
Build_Floppy = 0

Return to top

Build_LAN

Specifies whether to create a LAN-based installation package.

Syntax | Build_LAN = 0 | 1
Values 0

Does not create a LAN-based installation package.

1

Creates a LAN-based installation package.
Default Value | 0
Example
Build_LAN = 0

Return to top

Build_MultiFloppy

Specifies whether to create an installation package that fits on multiple floppy disks.

Syntax Build_MultiFloppy = 0 | 1
Values 0

Does not create a branding-only installation package that fits on multiple floppy disks.

1

Creates a branding-only installation package that fits on multiple floppy disks.
Example
Build_MultiFloppy = 0

Return to top


[Outlook_Express] (.ins)

banner

[Outlook_Express]

Answer File = Internet Settings (.ins) File

The [Outlook_Express] section contains entries for specifying which pieces of Microsoft® Outlook® Express to brand or customize in your package.

Entry | Description
Contacts | Specifies whether to display contacts by default.
Folder_Bar | Specifies whether to display the folder bar by default.
Folder_List | Specifies whether to display the folder list by default.
Outlook_Bar | Specifies whether to display the Outlook bar by default.
Preview_Pane | Specifies whether to display the preview pane by default.
Show_Preview_Beside_Msgs | Specifies whether to display the message preview.
Show_Preview_Header | Specifies whether to display the preview pane header bar by default.
Show_Toolbar_Text | Specifies whether to display the toolbar text by default.
Status_Bar | Specifies whether to display the status bar by default.
Tip_Day | Specifies whether to display the tip of the day by default.
Toolbar | Specifies whether to display the toolbar by default.

Sample

This sample demonstrates one use of the [Outlook_Express] section of the Internet Settings (.ins) File.

[Outlook_Express]
Contacts = 1
Folder_Bar = 1
Folder_List = 1
Outlook_Bar = 1
Preview_Pane = 1
Show_Preview_Beside_Msgs = 1
Show_Preview_Header = 1
Show_Toolbar_Text = 1
Status_Bar = 1
Tip_Day = 1
Toolbar = 1

Contacts

Specifies whether to display contacts by default.

Syntax | Contacts = 0 | 1
Values 0

Does not display contacts by default.

1

Displays contacts by default.
Default Value | 1
Example
Contacts = 1

Return to top

Folder_Bar

Specifies whether to display the folder bar by default.

Syntax | Folder_Bar = 0 | 1
Values 0

Does not display the folder bar by default.

1

Displays the folder bar by default.
Default Value | 1
Example
Folder_Bar = 1

Return to top

Folder_List

Specifies whether to display the folder list by default.

Syntax | Folder_List = 0 | 1
Values 0

Does not display the folder list by default.

1

Displays the folder list by default.
Default Value | 1
Example
Folder_List = 1

Return to top

Outlook_Bar

Specifies whether to display the Outlook bar by default.

Syntax | Outlook_Bar = 0 | 1
Values 0

Does not display the Outlook bar by default.

1

Displays the Outlook bar by default.
Default Value | 0
Example
Outlook_Bar = 1

Return to top

Preview_Pane

Specifies whether to display the preview pane by default.

Syntax | Preview_Pane = 0 | 1
Values 0

Does not display the preview pane by default.

1

Displays the preview pane by default.
Default Value | 1
Example
Preview_Pane = 1

Return to top

Show_Preview_Beside_Msgs

Specifies whether to display the message preview.

Syntax | Show_Preview_Beside_Msgs = 0 | 1
Values 0

Does not display the message preview.

1

Displays the message preview.
Default Value | 0
Example
Show_Preview_Beside_Msgs = 1

Return to top

Show_Preview_Header

Specifies whether to display the preview pane header bar by default.

Syntax Show_Preview_Header = 0 | 1
Values 0

Does not display the preview pane header bar by default.

1

Displays the preview pane header bar by default.
Example
Show_Preview_Header = 1

Return to top

Show_Toolbar_Text

Specifies whether to display the toolbar text by default.

Syntax | Show_Toolbar_Text = 0 | 1
Values 0

Does not display the toolbar text by default.

1

Displays the toolbar text by default.
Default Value | 1
Example
Show_Toolbar_Text = 1

Return to top

Status_Bar

Specifies whether to display the status bar by default.

Syntax | Status_Bar = 0 | 1
Values 0

Does not display the status bar by default.

1

Displays the status bar by default.
Default Value | 1
Example
Status_Bar = 1

Return to top

Tip_Day

Specifies whether to display the tip of the day by default.

Syntax | Tip_Day = 0 | 1
Values 0

Does not display the tip of the day by default.

1

Displays the tip of the day by default.
Default Value | 1
Example
Tip_Day = 1

Return to top

Toolbar

Specifies whether to display the toolbar by default.

Syntax | Toolbar = 0 | 1
Values 0

Does not display the toolbar by default.

1

Displays the toolbar by default.
Default Value | 1
Example
Toolbar = 1

Return to top


[Outlook_Express_Global] (.ins)

banner

[Outlook_Express_Global]

Answer File = Internet Settings (.ins) File

The [Outlook_Express_Global] section contains entries for specifying your branding for the Microsoft® Outlook® Express service.

Entry | Description
Read_Only | Specifies whether to make server names read-only in the Outlook Express settings.
Service_Name | Specifies a company name.
Service_URL | Specifies the location of the e-mail service.

Sample

This sample demonstrates one use of the [Outlook_Express_Global] section of the Internet Settings (.ins) File.

[Outlook_Express_Global]
Read_Only = 1
Service_Name = Fabrikam
Service_URL = http://www.fabrikam.com

Read_Only

Specifies whether to make server names read-only in the Outlook Express settings.

Syntax | Read_Only = 0 | 1
Values 0

Does not make server names read-only in the Outlook Express settings.

1

Makes server names read-only.
Default Value | 0
Example
Read_Only = 1

Return to top

Service_Name

Specifies a company name.

Syntax | Service_Name = name
Value | name
Example
Service_Name = Fabrikam

Return to top

Service_URL

Specifies the location of the e-mail service.

Syntax | Service_URL = url
Value | url
Example
Service_URL = http://www.fabrikam.com

Return to top


[Phone] (.ins)

banner

[Phone]

Answer File = Internet Settings (.ins) File

The [Phone] section contains entries for specifying the telephone information used for your dial-up connection.

Entry | Description
Area_Code | Specifies the area code for the dial-up connection.
Country_Code | Specifies the country/region code for the dial-up connection.
Country_ID | Specifies the country/region ID number for the dial-up connection.
Dial_As_Is | Specifies whether to dial the telephone number as is, without appending an area code or other numbers.
Phone_Number | Specifies the telephone number to dial.

Sample

This sample demonstrates one use of the [Phone] section of the Internet Settings (.ins) File.

[Phone]
Area_Code = 555
Country_Code = 1
Country_ID = 1
Dial_As_Is = Yes
Phone_Number = 123-4567

Area_Code

Specifies the area code for the dial-up connection.

Syntax | Area_Code = number
Value | number
Example
Area_Code = 555

Return to top

Country_Code

Specifies the country/region code for the dial-up connection.

Syntax | Country_Code = number
Value | number
Example
Country_Code = 1

Return to top

Country_ID

Specifies the country/region ID number for the dial-up connection.

Syntax | Country_ID = number
Value | number
Example
Country_ID = 1

Return to top

Dial_As_Is

Specifies whether to dial the telephone number as is, without appending an area code or other numbers.

Syntax | Dial_As_Is = Yes | No
Values Yes

Dials the telephone number as is.

No

Appends an area code or other numbers.
Default Value | No
Example
Dial_As_Is = Yes

Return to top

Phone_Number

Specifies the telephone number to dial.

Syntax | Phone_Number = number
Value | number
Example
Phone_Number = 123-4567

Return to top


[Proxy] (.ins)

banner

[Proxy]

Answer File = Internet Settings (.ins) File

The [Proxy] section contains entries for specifying whether to use a proxy server and identifies the host names for the proxy server.

Entry | Description
FTP_Proxy_Server | Specifies the host name for the proxy server.
Gopher_Proxy_Server | Specifies the host name for the proxy server that uses the Internet utility Gopher.
HTTP_Proxy_Server | Specifies the host name for the proxy server that uses the Hypertext Transfer Protocol (HTTP).
Proxy_Enable | Specifies whether to use a proxy server.
Proxy_Override | Specifies the host name for the proxy server.
Secure_Proxy_Server | Specifies the host name for the secure proxy server.
Socks_Proxy_Server | Specifies the host name for the proxy server that uses SOCKS, a security package.
Use_Same_Proxy | Specifies whether to use one proxy server for all services.

Sample

This sample demonstrates one use of the [Proxy] section of the Internet Settings (.ins) File.

[Proxy]
FTP_Proxy_Server = MyFTPProxy
Gopher_Proxy_Server = MyGopherProxy
HTTP_Proxy_Server = MyHTTPProxy
Proxy_Enable = 1
Proxy_Override = <LOCAL>
Secure_Proxy_Server = MySecureProxy
Socks_Proxy_Server = MySocksProxy
Use_Same_Proxy = 1

FTP_Proxy_Server

Specifies the host name for the proxy server.

Syntax | FTP_Proxy_Server = proxy server name
Value | proxy server name
Example
FTP_Proxy_Server = MyFTPProxy

Return to top

Gopher_Proxy_Server

Specifies the host name for the proxy server that uses the Internet utility Gopher.

Syntax | Gopher_Proxy_Server = proxy server name
Value | proxy server name
Example
Gopher_Proxy_Server = MyGopherProxy

Return to top

HTTP_Proxy_Server

Specifies the host name for the proxy server that uses the Hypertext Transfer Protocol (HTTP).

Syntax | HTTP_Proxy_Server = proxy server name
Value | proxy server name
Example
HTTP_Proxy_Server = MyHTTPProxy

Return to top

Proxy_Enable

Specifies whether to use a proxy server.

Syntax | Proxy_Enable = 0 | 1
Values 0

Does not use a proxy server.

1

Uses a proxy server.
Default Value | 0
Example
Proxy_Enable = 1

Return to top

Proxy_Override

Specifies the host name for the proxy server.

Syntax | Proxy_Override = string
Value | string
Example
Proxy_Override = <LOCAL>

Return to top

Secure_Proxy_Server

Specifies the host name for the secure proxy server.

Syntax | Secure_Proxy_Server = proxy server name
Value | proxy server name
Example
Secure_Proxy_Server = MySecureProxy

Return to top

Socks_Proxy_Server

Specifies the host name for the proxy server that uses SOCKS, a security package.

Syntax | Socks_Proxy_Server = proxy server name
Value | proxy server name
Example
Socks_Proxy_Server = MySocksProxy

Return to top

Use_Same_Proxy

Specifies whether to use one proxy server for all services.

Syntax | Use_Same_Proxy = 0 | 1
Values 0

Does not use one proxy server for all services.

1

Uses one proxy server for all services.
Default Value | 0
Example
Use_Same_Proxy = 1

Return to top


[Script_File] (.ins)

banner

[Script_File]

Answer File = Internet Settings (.ins) File

The [Script_File] section contains entries for specifying the text of the script file associated with dial-up networking.

Entry | Description
1 | Specifies the first line of the script file.
2 | Specifies the second line of the script file.
3 | Specifies the third line of the script file.
n | Specifies the text of line n in the script file, where n stands for any number.

Sample

This sample demonstrates one use of the [Script_File] section of the Internet Settings (.ins) File.

[Script_File]
1 = This is the first line of the script file.
2 = This is the second line of the script file.
3 = This is the third line of the script file.
7 = This is the seventh line of the script file.

1

Specifies the first line of the script file.

Syntax | 1 = text
Value | text
Example
1 = This is the first line of the script file.

Return to top

2

Specifies the second line of the script file.

Syntax | 2 = text
Value | text
Example
2 = This is the second line of the script file.

Return to top

3

Specifies the third line of the script file.

Syntax | 3 = text
Value | text
Example
3 = This is the third line of the script file.

Return to top

n

Specifies the text of line n in the script file, where n stands for any number.

Syntax | n = text
Value | text
Example
7 = This is the seventh line of the script file.

Return to top


[Scripting] (.ins)

banner

[Scripting]

Answer File = Internet Settings (.ins) File

The [Scripting] section contains entries for specifying the names and paths of your dial-up networking script files.

Entry | Description
Name | Specifies the file name of the Network Connections script.
Name16 | Specifies the file name of the 16-bit Network Connections script.
Name32 | Specifies the file name of the 32-bit Network Connections script.
Path16 | Specifies the full path to the 16-bit script.
Path32 | Specifies the full path to the 32-bit script.

Sample

This sample demonstrates one use of the [Scripting] section of the Internet Settings (.ins) File.

[Scripting]
Name = sis.scp
Name16 = sis16.scp
Name32 = sis32.scp
Path16 = c:\myfolder\sis16.scp
Path32 = c:\myfolder\sis32.scp

Name

Specifies the file name of the Network Connections script.

Syntax | Name = file_name
Value | file_name
Example
Name = sis.scp

Return to top

Name16

Specifies the file name of the 16-bit Network Connections script.

Syntax | Name16 = file_name
Value | file_name
Example
Name16 = sis16.scp

Return to top

Name32

Specifies the file name of the 32-bit Network Connections script.

Syntax | Name32 = file_name
Value | file_name
Example
Name32 = sis32.scp

Return to top

Path16

Specifies the full path to the 16-bit script.

Syntax | Path16 = path_and_file_name
Value | path_and_file_name
Example
Path16 = c:\myfolder\sis16.scp

Return to top

Path32

Specifies the full path to the 32-bit script.

Syntax | Path32 = path_and_file_name
Value | path_and_file_name
Example
Path32 = c:\myfolder\sis32.scp

Return to top


[Security Imports] (.ins)

banner

[Security Imports]

Answer File = Internet Settings (.ins) File

The [Security Imports] section contains entries for specifying whether to import security information from your computer to your custom package.

Entry | Description
ImportAuthCode | Specifies whether to import the existing Authenticode settings.
ImportRatings | Specifies whether to import the existing Content Ratings settings.
ImportSecZones | Specifies whether to import the existing Security Zones settings.
ImportSiteCert | Specifies whether to import existing site Certification Authorities.
Win16SiteCerts | Specifies whether to use site certificates for 16-bit computers running Microsoft® Windows®.

Sample

This sample demonstrates one use of the [Security Imports] section of the Internet Settings (.ins) File.

[Security Imports]
ImportAuthCode = 1
ImportRatings = 1
ImportSecZones = 1
ImportSiteCert = 1
Win16SiteCerts = 1

ImportAuthCode

Specifies whether to import the existing Authenticode settings.

Syntax | ImportAuthCode = 0 | 1
Values 0

Does not import the existing Authenticode settings.

1

Imports the existing Authenticode settings.
Default Value | 0
Example
ImportAuthCode = 1

Return to top

ImportRatings

Specifies whether to import the existing Content Ratings settings.

Syntax | ImportRatings = 0 | 1
Values 0

Does not import the existing Content Ratings settings.

1

Imports the existing Content Ratings settings.
Default Value | 0
Example
ImportRatings = 1

Return to top

ImportSecZones

Specifies whether to import the existing Security Zones settings.

Syntax | ImportSecZones = 0 | 1
Values 0

Does not import the existing Security Zones settings.

1

Imports the existing Security Zones settings.
Default Value | 0
Example
ImportSecZones = 1

Return to top

ImportSiteCert

Specifies whether to import existing site Certification Authorities.

Syntax | ImportSiteCert = 0 | 1
Values 0

Does not import the existing Certification Authorities.

1

Imports the existing Certification Authorities.
Default Value | 0
Example
ImportSiteCert = 1

Return to top

Win16SiteCerts

Specifies whether to use site certificates for 16-bit computers running Windows.

Syntax Win16SiteCerts = 0 | 1
Values 0

Does not use site certificates.

1

Uses site certificates.
Example
Win16SiteCerts = 1

Return to top


[Server] (.ins)

banner

[Server]

Answer File = Internet Settings (.ins) File

The [Server] section contains entries for specifying the default connection settings used by the Internet Connection Wizard (ICW).

Entry | Description
Disable_LCP | Specifies whether to disable the Point-to-Point Protocol (PPP) Link Control Protocol (LCP) Extensions. LCP is used to establish and configure link and framing settings such as maximum frame size.
Negotiate_IPX_SPX | Specifies whether to use the Internet Packet Exchange (IPX) protocol.
Negotiate_NetBEUI | Specifies whether to use the NetBIOS Extended User Interface (NetBEUI) protocol.
Negotiate_TCP_IP | Specifies whether to use the Transmission Control Protocol/Internet Protocol (TCP/IP) protocol.
Network_Logon | Specifies whether to log on to a network.
PW_Encrypt | Specifies whether to use an encrypted password.
SW_Compress | Specifies whether to use software compression.
SW_Encrypt | Specifies whether to require data encryption.
Type | Specifies the server type.

Sample

This sample demonstrates one use of the [Server] section of the Internet Settings (.ins) File.

[Server]
Disable_LCP = Yes
Negotiate_IPX_SPX = Yes
Negotiate_NetBEUI = No
Negotiate_TCP_IP = Yes
Network_Logon = Yes
PW_Encrypt = Yes
SW_Compress = Yes
SW_Encrypt = Yes
Type = PPP

Disable_LCP

Specifies whether to disable the Point-to-Point Protocol (PPP) Link Control Protocol (LCP) Extensions. LCP is used to establish and configure link and framing settings such as maximum frame size.

Syntax | Disable_LCP = Yes | No
Values Yes

Disables LCP.

No

Does not disable LCP.
Default Value | No
Example
Disable_LCP = Yes

Return to top

Negotiate_IPX_SPX

Specifies whether to use the Internet Packet Exchange (IPX) protocol.

Syntax | Negotiate_IPX_SPX = Yes | No
Values Yes

Uses IPX.

No

Does not use IPX.
Default Value | No
Example
Negotiate_IPX_SPX = Yes

Return to top

Negotiate_NetBEUI

Specifies whether to use the NetBIOS Extended User Interface (NetBEUI) protocol.

Syntax | Negotiate_NetBEUI = Yes | No
Values Yes

Uses NetBEUI.

No

Does not use NetBEUI.
Default Value | No
Example
Negotiate_NetBEUI = No

Return to top

Negotiate_TCP_IP

Specifies whether to use the Transmission Control Protocol/Internet Protocol (TCP/IP) protocol.

Syntax | Negotiate_TCP_IP = Yes | No
Values Yes

Uses TCP/IP.

No

Does not use TCP/IP.
Default Value | Yes
Example
Negotiate_TCP_IP = Yes

Return to top

Network_Logon

Specifies whether to log on to a network.

Syntax | Network_Logon = Yes | No
Values Yes

Logs on to a network.

No

Does not log on to a network.
Default Value | No
Example
Network_Logon = Yes

Return to top

PW_Encrypt

Specifies whether to use an encrypted password.

Syntax | PW_Encrypt = Yes | No
Values Yes

Uses an encrypted password. Recommended.

No

Does not use an encrypted password.
Default Value | 0
Example
PW_Encrypt = Yes

Return to top

SW_Compress

Specifies whether to use software compression.

Syntax | SW_Compress = Yes | No
Values Yes

Uses software compression.

No

Does not use software compression.
Default Value | 0
Example
SW_Compress = Yes

Return to top

SW_Encrypt

Specifies whether to require data encryption.

Syntax SW_Encrypt = Yes | No
Values Yes

Requires data encryption. Recommended.

No

Does not require data encryption.
Example
SW_Encrypt = Yes

Return to top

Type

Specifies the server type.

Syntax | Type = string
Value | string
Example
Type = PPP

Return to top


[Signature] (.ins)

banner

[Signature]

Answer File = Internet Settings (.ins) File

The [Signature] section contains entries for specifying whether to use a Microsoft® Outlook® Express signature and the text of that signature.

Entry | Description
Signature_Text | Specifies the text of an e-mail signature.
Use_Signature | Specifies whether to use a signature.

Sample

This sample demonstrates one use of the [Signature] section of the Internet Settings (.ins) File.

[Signature]
Signature_Text = Tell your friends about our free e-mail!
Use_Signature = 1

Signature_Text

Specifies the text of an e-mail signature.

Syntax | Signature_Text = string
Value | string
Example
Signature_Text = Tell your friends about our free e-mail!
Comment | To indicate a new line in the signature, use the characters "\n".

Return to top

Use_Signature

Specifies whether to use a signature.

Syntax | Use_Signature = 0 | 1
Values 0

Does not use a signature.

1

Uses a signature.
Default Value | 0
Example
Use_Signature = 1

Return to top


[SignupFiles](.ins)

OPK banner

[SignupFiles]

Answer File = Internet Settings (.ins) File

The [SignupFiles] section contains entries for specifying the name of the files that appear during signup, such as sign-up.htm.

Entry | Description
File0 | Specifies the name of the first file used in your sign-up process.
File1 | Specifies the name of the second file used in your sign-up process.
File2 | Specifies the name of the third file used in your sign-up process.
File3 | Specifies the name of the fourth file used in your sign-up process.

Sample

This sample demonstrates one use of the [SignupFiles] section of the Internet Settings (.ins) File.

[SignupFiles]
File0 = cancel.ins
File1 = sign-up.htm
File2 = sign-up.isp
File3 = sign-up2.isp

File0

Specifies the name of the first file used in your sign-up process.

Syntax | File0 = file name
Value | file name
Example
File0 = cancel.ins

Return to top

File1

Specifies the name of the second file used in your sign-up process.

Syntax | File1 = file name
Value | file name
Example
File1 = sign-up.htm

Return to top

File2

Specifies the name of the third file used in your sign-up process.

Syntax | File2 = file name
Value | file name
Example
File2 = sign-up.isp

Return to top

File3

Specifies the name of the fourth file used in your sign-up process.

Syntax | File3 = file name
Value | file name
Example
File3 = sign-up2.isp

Return to top


[Small_Logo](.ins)

OPK banner

[Small_Logo]

Answer File = Internet Settings (.ins) File

The [Small_Logo] section contains entries for specifying the name and path of your 22 x 22-pixel bitmap file that appears in the upper-right corner of the browser.

Entry | Description
Name | Specifies the name of the 22 x 22-pixel bitmap file that appears in the upper-right corner of the browser.
Path | Specifies the path to the 22 x 22-pixel bitmap file that appears in the upper-right corner of the browser.

Sample

This sample demonstrates one use of the [Small_Logo] section of the Internet Settings (.ins) File.

[Small_Logo]
Name = Small.bmp
Path = C:\Windows

Name

Specifies the name of the 22 x 22-pixel bitmap file that appears in the upper-right corner of the browser.

Syntax | Name = file name
Value | file name
Example
Name = Small.bmp

Return to top

Path

Specifies the path to the 22 x 22-pixel bitmap file that appears in the upper-right corner of the browser.

Syntax | Path = path
Value | path
Example
Path = C:\Windows

Return to top


[TCP/IP] (.ins)

banner

[TCP/IP]

Answer File = Internet Settings (.ins) File

The [TCP/IP] section contains entries for specifying the Internet Protocol (IP) number of the Domain Name System (DNS) server to use. You can also specify to use a remote gateway, an IP address, and a server address.

Entry | Description
DNS_Address | Specifies the IP number of the DNS server to use.
DNS_Alt_Address | Specifies the IP number of an alternate DNS server to use.
Gateway_On_Remote | Specifies whether to use a remote gateway.
IP_Header_Compress | Specifies whether to use IP header compression.
Specify_IP_Address | Specifies whether to use an IP address.
Specify_Server_Address | Specifies whether to use a server address.

Sample

This sample demonstrates one use of the [TCP/IP] section of the Internet Settings (.ins) File.

[TCP/IP]
DNS_Address = 127.0.0.1
DNS_Alt_Address = 127.0.0.2
Gateway_On_Remote = No
IP_Header_Compress = Yes
Specify_IP_Address = No
Specify_Server_Address = Yes

DNS_Address

Specifies the IP number of the DNS server to use.

Syntax | DNS_Address = string
Value | string
Example
DNS_Address = 127.0.0.1

Return to top

DNS_Alt_Address

Specifies the IP number of an alternate DNS server to use.

Syntax | DNS_Alt_Address = string
Value | string
Example
DNS_Alt_Address = 127.0.0.2

Return to top

Gateway_On_Remote

Specifies whether to use a remote gateway.

Syntax | Gateway_On_Remote = Yes | No
Values Yes

Uses a remote gateway.

No

Does not use a remote gateway.
Default Value | Yes
Example
Gateway_On_Remote = No

Return to top

IP_Header_Compress

Specifies whether to use IP header compression.

Syntax | IP_Header_Compress = Yes | No
Values Yes

Uses IP header compression.

No

Does not use IP header compression.
Default Value | Yes
Example
IP_Header_Compress = Yes

Return to top

Specify_IP_Address

Specifies whether to use an IP address.

Syntax | Specify_IP_Address = Yes | No
Values Yes

Uses an IP address.

No

Does not use an IP address.
Default Value | No
Example
Specify_IP_Address = No

Return to top

Specify_Server_Address

Specifies whether to use a server address.

Syntax | Specify_Server_Address = Yes | No
Values Yes

Uses a server address.

No

Does not use a server address.
Default Value | No
Example
Specify_Server_Address = Yes

Return to top


[URL] (.ins)

banner

[URL]

Answer File = Internet Settings (.ins) File

The [URL] section contains entries for specifying whether to use an auto-configured proxy server, and identifies the URLs for the pages that appear when users connect to that server.

Entry | Description
AutoConfig | Specifies whether to use an autoconfigured proxy server.
AutoConfigJSURL | Specifies the URL of the automatic proxy file, which is in either JavaScript or Microsoft® JScript®.
AutoConfigTime | Specifies to configure the browser automatically after running the specified number of minutes.
AutoConfigURL | Specifies the URL of the autoproxy file.
FirstHomePage | Specifies the page to browse the first time the customized browser runs.
Help_Page | Specifies the URL of a Web page offering technical support.
Home_Page | Specifies the URL of the default home page.
NoWelcome | Specifies whether to display a welcome page the first time the end user opens the browser.
Quick_Link_1 | Specifies the first quick link URL.
Quick_Link_1_Name | Specifies the name associated with Quick_Link_1.
Quick_Link_2 | Specifies the second quick link URL.
Quick_Link_2_Name | Specifies the name associated with Quick_Link_2.
Quick_Link_X | Specifies the quick link URL, where X is any number.
Quick_Link_X_Icon | Specifies the quick link icon, where X is any number.
Quick_Link_X_Name | Specifies the name associated with Quick_Link_X, where X is any number.
Quick_Link_X_Offline | Specifies whether to make the quick link available for offline browsing, where X is any number.
Search_Page | Specifies the default Search page.
Signup | Specifies the path to the page containing a link to the .ins file for the sign-up server.
UseLocalIns | Specifies whether to use a local .ins file.

Sample

This sample demonstrates one use of the [URL] section of the Internet Settings (.ins) File.

[URL]
AutoConfig = 1
AutoConfigJSURL = http://www.fabrikam.com/autoproxy.js
AutoConfigTime = 10
AutoConfigURL = http://www.fabrikam.com/autoconfig.htm
FirstHomePage = http://www.fabrikam.com/firsthome.htm
Help_Page = http://www.fabrikam.com/techsupport.htm
Home_Page = http://www.fabrikam.com/home.htm
NoWelcome = 0
Quick_Link_1 = http://www.fabrikam.com/quicklink1.htm
Quick_Link_1_Name = My First Quick Link
Quick_Link_2 = http://www.fabrikam.com/quicklink2.htm
Quick_Link_2_Name = My Second Quick Link
Quick_Link_8 = http://www.fabrikam.com/quicklink8.htm
Quick_Link_8_Icon = C:\Windows\link8.ico
Quick_Link_8_Name = My Eighth Quick Link
Quick_Link_X_Offline = 1
Search_Page = http://www.fabrikam.com/search.htm
Signup = C:\Windows\signupfile.htm
UseLocalIns = 1

AutoConfig

Specifies whether to use an autoconfigured proxy server.

Syntax | AutoConfig = 0 | 1
Values 0

Does not use an autoconfigured proxy server.

1

Uses an autoconfigured proxy server.
Default Value | 0
Example
AutoConfig = 1

Return to top

AutoConfigJSURL

Specifies the URL of the automatic proxy file, which is in either JavaScript or Microsoft® JScript®.

Syntax | AutoConfigJSURL = url
Value | url
Example
AutoConfigJSURL = http://www.fabrikam.com/autoproxy.js

Return to top

AutoConfigTime

Specifies to configure the browser automatically after running the specified number of minutes.

Syntax | AutoConfigTime = integer
Value | integer
Example
AutoConfigTime = 10

Return to top

AutoConfigURL

Specifies the URL of the autoproxy file.

Syntax | AutoConfigURL = url
Value | url
Example
AutoConfigURL = http://www.fabrikam.com/autoconfig.htm

Return to top

FirstHomePage

Specifies the page to browse the first time the customized browser runs.

Syntax | FirstHomePage = url
Value | url
Example
FirstHomePage = http://www.fabrikam.com/firsthome.htm

Return to top

Help_Page

Specifies the URL of a Web page offering technical support.

Syntax | Help_Page = url
Value | url
Example
Help_Page = http://www.fabrikam.com/techsupport.htm

Return to top

Home_Page

Specifies the URL of the default home page.

Syntax | Home_Page = url
Value | url
Example
Home_Page = http://www.fabrikam.com/home.htm

Return to top

NoWelcome

Specifies whether to display a welcome page the first time the end user opens the browser.

Syntax | NoWelcome = 0 | 1
Values 0

Displays a welcome page.

1

Does not display a welcome page.
Default Value | 0
Example
NoWelcome = 0

Return to top

Quick_Link_1

Specifies the first quick link URL.

Syntax | Quick_Link_1 = url
Value | url
Example
Quick_Link_1 = http://www.fabrikam.com/quicklink1.htm

Return to top

Quick_Link_1_Name

Specifies the name associated with Quick_Link_1.

Syntax | Quick_Link_1_Name = string
Value | string
Example
Quick_Link_1_Name = My First Quick Link

Return to top

Quick_Link_2

Specifies the second quick link URL.

Syntax | Quick_Link_2 = url
Value | url
Example
Quick_Link_2 = http://www.fabrikam.com/quicklink2.htm

Return to top

Quick_Link_2_Name

Specifies the name associated with Quick_Link_2.

Syntax | Quick_Link_2_Name = string
Value | string
Example
Quick_Link_2_Name = My Second Quick Link

Return to top

Quick_Link_X

Specifies the quick link URL, where X is any number.

Syntax | Quick_Link_X = url
Value | url
Example
Quick_Link_8 = http://www.fabrikam.com/quicklink8.htm

Return to top

Quick_Link_X_Icon

Specifies the quick link icon, where X is any number.

Syntax | Quick_link_X_icon = path_and_file_name
Value | path_and_file_name
Example
Quick_Link_8_Icon = C:\Windows\link8.ico

Return to top

Quick_Link_X_Name

Specifies the name associated with Quick_Link_X, where X is any number.

Syntax | Quick_Link_X_Name = string
Value | string
Example
Quick_Link_8_Name = My Eighth Quick Link

Return to top

Quick_Link_X_Offline

Specifies whether to make the quick link available for offline browsing, where X is any number.

Syntax | Quick_Link_X_Offline = 0 | 1
Values 0

Does not make the quick link available for offline browsing.

1

Makes the quick link available for offline browsing.
Default Value | 0
Example
Quick_Link_X_Offline = 1

Return to top

Search_Page

Specifies the default Search page.

Syntax | Search_Page = url
Value | url
Example
Search_Page = http://www.fabrikam.com/search.htm

Return to top

Signup

Specifies the path to the page containing a link to the .ins file for the sign-up server.

Syntax | Signup = path_and_file_name
Value | path_and_file_name
Example
Signup = C:\Windows\signupfile.htm

Return to top

UseLocalIns

Specifies whether to use a local .ins file.

Syntax | UseLocalIns = 0 | 1
Values 0

Does not use a local .ins file.

1

Uses a local .ins file.
Default Value | 0
Example
UseLocalIns = 1

Return to top


[User] (.ins)

banner

[User]

Answer File = Internet Settings (.ins) File

The [User] section contains entries for specifying the logon information required by your users.

Entry | Description
Display_Password | Specifies whether to display the password.
Name | Specifies the user name.
Password | Specifies the password.
Requires_Logon | Specifies whether to require the end user to log on.

Sample

This sample demonstrates one use of the [User] section of the Internet Settings (.ins) File.

[User]
Display_Password = No
Name = Pat Coleman
Password = PC*1234
Requires_Logon = Yes

Display_Password

Specifies whether to display the password.

Syntax | Display_Password = Yes | No
Values Yes

Displays the password.

No

Does not display the password.
Default Value | No
Example
Display_Password = No

Return to top

Name

Specifies the user name.

Syntax | Name = string
Value | string
Example
Name = Pat Coleman

Return to top

Password

Specifies the password.

Syntax | Password = string
Value | string
Example
Password = PC*1234

Return to top

Requires_Logon

Specifies whether to require the end user to log on.

Syntax | Requires_Logon = Yes | No
Values Yes

Requires the end user to log on.

No

Does not require the end user to log on.
Default Value | No
Example
Requires_Logon = Yes

Return to top


Internet Service Provider (.isp) Files

An .isp file contains information that a computer requires to dial up and connect to your Internet Service Provider (ISP) sign-up server. A single .isp file can be used by all users who want to sign up for Internet access with a given Internet service provider. Use information in the following table to help you customize entries to point to your ISP sign-up server.

Note

  • Custom .isp files must have the following security descriptor:
    D:P(A;;GRGX;;;BU)(A;;GA;;;BA)(A;;GA;;;SY)(A;;GRGX;;;WD)
    This security descriptor protects the file from being modified by a user with inheritable settings, enables the Users group to read and execute, allows the Administrators group all access, allows the system all access, and allows Everyone read and execute access.
  • Make sure that you navigate only to trusted sites and pages.

The following sections appear in .isp files:

Section or Entry | Comment | Format | Required?
[Entry] | Specifies the entry description. | N/A | Yes
Entry_Name | Specifies the name of the entry for your sign-up server connection listed in Microsoft® Windows XP dial-up networking. | Text string | Yes
[Phone] | Specifies the telephone number description. | N/A | Yes
Area_Code | Specifies the area or city code of the Post Office Protocol (POP) telephone number. | Numeric string | Yes
Country_Code | Specifies the country/region code of the POP telephone number. | Numeric string | Yes
Country_ID | Specifies the country/region ID. The Country_Code and Country_ID entries work together to represent the unique country/region combination. Country_ID is necessary because the same Country_Code can represent more than one country/region. For example, the United States and Canada both use 1 as the Country_Code. |  | Yes
Dial_As_Is | Must be set to No for this release. | No | Yes
Phone_Number | Specifies the local portion of the POP telephone number. | Numeric string | Yes
[Server] | Specifies the dial-up access server description. | N/A | Yes
Disable_LCP | Indicates whether the sign-up server handles LCP extensions. The default setting is No. If the sign-up server cannot handle LCP extensions, set to Yes to disable LCP on the client computer. If the sign-up server can handle LCP extensions, set to No to enable LCP on the client computer. This value is valid for Microsoft® Windows NT clients only. | Yes | No | No
Negotiate_TCP_IP | Specifies whether to use Transmission Control Protocol/Internet Protocol (TCP/IP). Must be set to Yes for this release. | Yes | N/A
PW_Encrypt | Encrypts password by using Password Authentication Protocol (PAP) while authenticating a user logging on. | Yes | No | N/A
SW_Compress | Negotiates Point-to-Point Protocol (PPP) software compression of data. | Yes | No | N/A
Type | Specifies the server type. PPP is the only supported server type in this release. | PPP | N/A
[Support] | Specifies the customer support telephone number. | N/A | Yes
Support_Number | Specifies the customer support telephone number to appear on the New Connection Wizard sign-up server connection error page. | String | Yes
[TCP/IP] | Specifies a description of TCP/IP settings. | N/A | Yes
DNS_Address | Specifies the primary Domain Name Service (DNS) server address if static DNS addressing is used. | Standard IP address nnn.nnn.nnn.nnn | Required if static DNS address is used.
DNS_Alt_Address | Specifies an alternate (secondary) DNS server address, if applicable. | Standard IP address nnn.nnn.nnn.nnn | Required if there is a secondary DNS address.
Gateway_On_Remote | Specifies whether to use default gateway on a remote network. | Yes | No | N/A
IP_Address | Specifies a static IP address for client, if used. | Standard IP address nnn.nnn.nnn.nnn | Required if static IP address is used.
IP_Header_Compress | Specifies whether to use IP header compression. | Yes | No | N/A
Specify_IP_Address | Specifies whether a static Internet Protocol (IP) address is specified for client. | Yes | No | N/A
Specify_Server_Address | Specifies whether to use static Domain Name System (DNS) addressing. | Yes | No | N/A
[URL] | Specifies the Uniform Resource Locator (URL) description. | N/A | Yes
Reconnect | Specifies the secondary URL used in the case of a disconnection or a server error. | Valid sign-up server reconnect URL | Yes
Signup | Specifies the initial URL used during signup. | Valid sign-up server URL | Yes
[User] | Specifies the logon description. | N/A | Yes
Name | Specifies the user name used to log on to the sign-up server, for example, "guest." | Text string | Yes
Password | Specifies the password used to log on to the sign-up server. | Text string | Yes
Requires_Logon | Specifies the logon requirement setting. The default setting is No. Set this entry to Yes to ensure that the client computer has Microsoft® Windows® logon authentication turned on. (Providing a Windows password enables access to the Windows Me, Windows 95, or Windows 98 password cache, where the ISP password is stored. This option is particularly useful if you assign long random strings as passwords.) Windows Me, Windows 95, or Windows 98 clients only. | Yes | No | No


Sample .isp File

You must create an .isp file to dial up and connect to your Internet Service Provider (ISP) sign-up server. This sample demonstrates one use of an .isp file.

[Entry]
Entry_Name = Fabrikam Corporation Sign-Up

[Phone]
Area_Code = 425
Country_Code = 1
Country_ID = 1
Dial_As_Is = No
Phone_Number = 707-9790

[Server]
Negotiate_TCP_IP = Yes
PW_Encrypt = No
SW_Compress = Yes
Type = PPP

[TCP/IP]
Gateway_On_Remote = Yes
IP_Header_Compress = Yes
Specify_IP_Address = No
Specify_Server_Address = No

[User]
Name = guest
Password =

[URL]
Signup = http://1.2.3.4/scripts/signup.exe

[Support]
Support_Number = 800-123-1234


[Entry] (.isp)

banner

[Entry]

Answer File = Internet Service Provider (.isp) File

The [Entry] section contains an entry for specifying your own entries.

Entry | Description
Entry_Name | Specifies the name of the entry for your sign-up server connection listed in Windows XP dial-up networking.

Sample

This sample demonstrates one use of the [Entry] section of the Internet Service Provider (.isp) File.

[Entry]
Entry_Name = "My Favorite ISP"

Entry_Name

Specifies the name of the entry for your sign-up server connection listed in Windows XP dial-up networking.

Syntax | Entry_Name = string
Value | string
Example
Entry_Name = "My Favorite ISP"

Return to top


[Phone] (.isp)

banner

[Phone]

Answer File = Internet Service Provider (.isp) File

The [Phone] section contains entries for specifying information about your dial-up connection.

Entry | Description
Area_Code | Specifies the area code for the dial-up connection.
Country_Code | Specifies the country/region code for the dial-up connection.
Country_ID | Specifies the country/region ID number for the dial-up connection.
Dial_As_Is | Specifies whether to dial the telephone number as is, without appending an area code or other numbers.
Phone_Number | Specifies the telephone number for the dial-up connection.

Sample

This sample demonstrates one use of the [Phone] section of the Internet Service Provider (.isp) File.

[Phone]
Dial_As_Is = No
Phone_Number = 123-4567
Area_Code = 123
Country_Code = 1
Country_ID = 1

Area_Code

Specifies the area code for the dial-up connection.

Syntax | Area_Code = number
Value | number
Example
Area_Code = 555

Return to top

Country_Code

Specifies the country/region code for the dial-up connection.

Syntax | Country_Code = number
Value | number
Example
Country_Code = 1

Return to top

Country_ID

Specifies the country/region ID number for the dial-up connection.

Syntax | Country_ID = number
Value | number
Example
Country_ID = 1

Return to top

Dial_As_Is

Specifies whether to dial the telephone number as is, without appending an area code or other numbers.

Syntax Dial_As_Is = Yes | No
Value Yes

Dials the telephone number as is.

No

Dials the telephone number by appending an area code or other numbers. Must be set to No for this release.
Example
Dial_As_Is = Yes

Return to top

Phone_Number

Specifies the telephone number for the dial-up connection.

Syntax | Phone_Number = number
Value | number
Example
Phone_Number = 123-4567

Return to top


[Server] (.isp)

banner

[Server]

Answer File = Internet Service Provider (.isp) File

The [Server] section contains entries for specifying information about your server.

Entry | Description
Disable_LCP | Specifies the default connection settings used by the Internet Connection Wizard.
Negotiate_TCP_IP | Specifies whether to use the Transmission Control Protocol/Internet Protocol (TCP/IP) protocol.
PW_Encrypt | Specifies whether to use an encrypted password.
SW_Compress | Specifies whether to use software compression.
Type | Specifies the server type.

Sample

This sample demonstrates one use of the [Server] section of the Internet Service Provider (.isp) File.

[Server]
Type = PPP
SW_Compress = Yes
PW_Encrypt = No
Negotiate_TCP_IP = Yes
Disable_LCP = Yes

Disable_LCP

Specifies the default connection settings used by the Internet Connection Wizard.

Syntax Disable_LCP = Yes | No
Values Yes

Disables LCP.

No

Does not disable LCP.
Example
Disable_LCP = Yes

Return to top

Negotiate_TCP_IP

Specifies whether to use the Transmission Control Protocol/Internet Protocol (TCP/IP).

Syntax Negotiate_TCP_IP = Yes | No
Values Yes

Uses TCP/IP. Must be set to Yes for this release.

No

Does not use TCP/IP.
Example
Negotiate_TCP_IP = Yes

Return to top

PW_Encrypt

Specifies whether to use an encrypted password.

Syntax PW_Encrypt = Yes | No
Values Yes

Uses an encrypted password. Recommended.

No

Does not use an encrypted password.
Example
PW_Encrypt = Yes

Return to top

SW_Compress

Specifies whether to use software compression.

Syntax SW_Compress = Yes | No
Values Yes

Uses software compression.

No

Does not use software compression.
Example
SW_Compress = Yes

Return to top

Type

Specifies the server type.

Syntax | Type = string
Value | string
Example
Type = PPP
Comment | PPP is the only supported server type in this release.

Return to top


[Support](.isp)

OPK banner

[Support]

Answer File = Internet Service Provider (.isp) File

The [Support] section contains an entry for specifying information about your customer support.

Entry | Description
Support_Number | Specifies the customer support telephone number to appear on the New Connection Wizard sign-up server connection error page.

Sample

This sample demonstrates one use of the [Support] section of the Internet Service Provider (.isp) File.

[Support]
Support_Number = (425) 707-9790

Support_Number

Specifies the customer support telephone number to appear on the New Connection Wizard sign-up server connection error page.

Syntax | Support_Number = string
Value | string
Example
Support_Number = (425) 707-9790

Return to top


[TCP/IP] (.isp)

banner

[TCP/IP]

Answer File = Internet Service Provider (.isp) File

The [TCP/IP] section contains entries for specifying information about Transmission Control Protocol/Internet Protocol (TCP/IP).

Entry | Description
DNS_Address | Specifies the IP number of the Domain Name System (DNS) server to use.
DNS_Alt_Address | Specifies the IP number of an alternate DNS server to use.
Gateway_On_Remote | Specifies whether to use a remote gateway.
IP_Address | Specifies a static IP address for the client, if used.
IP_Header_Compress | Specifies whether to use IP header compression.
Specify_IP_Address | Specifies whether to use an Internet Protocol (IP) address.
Specify_Server_Address | Specify whether to use a server address.

Sample

This sample demonstrates one use of the [TCP/IP] section of the Internet Service Provider (.isp) File.

[TCP/IP]
Specify_IP_Address = No
IP_Address = 169.172.0.1
Specify_Server_Address = No
DNS_Address = 127.0.0.1
DNS_Alt_Address = 127.0.0.1
IP_Header_Compress = Yes
Gateway_On_Remote = Yes

DNS_Address

Specifies the IP number of the Domain Name System (DNS) server to use.

Syntax | DNS_Address = string
Value | string
Example
DNS_Address = 127.0.0.1

Return to top

DNS_Alt_Address

Specifies the IP number of an alternate DNS server to use.

Syntax | DNS_Alt_Address = string
Value | string
Example
DNS_Alt_Address = 127.0.0.1

Return to top

Gateway_On_Remote

Specifies whether to use a remote gateway.

Syntax Gateway_On_Remote = Yes | No
Values Yes

Uses a remote gateway.

No

Does not use a remote gateway.
Example
Gateway_On_Remote = Yes

Return to top

IP_Address

Specifies a static IP address for the client, if used.

Syntax | IP_Address = string
Value | string
Example
IP_Address = 169.172.0.1

Return to top

IP_Header_Compress

Specifies whether to use IP header compression.

Syntax IP_Header_Compress = Yes | No
Values Yes

Uses IP header compression.

No

Does not use IP header compression.
Example
IP_Header_Compress = Yes

Return to top

Specify_IP_Address

Specifies whether to use an Internet Protocol (IP) address.

Syntax Specify_IP_Address = Yes | No
Values Yes

Uses an IP address.

No

Does not use an IP address.
Example
Specify_IP_Address = No

Return to top

Specify_Server_Address

Specifies whether to use a server address.

Syntax Specify_Server_Address = Yes | No
Values Yes

Uses a server address.

No

Does not use a server address.
Example
Specify_Server_Address = Yes

Return to top


[URL] (.isp)

banner

[URL]

Answer File = Internet Service Provider (.isp) File

The [URL] section contains entries for specifying information about the Uniform Resource Locator (URL) of your Internet Service Provider.

Entry | Description
Reconnect | Specifies a secondary URL used in case of a disconnection or server error.
Signup | Specifies the path to the page containing a link to the .ins file for the sign-up server.

Sample

This sample demonstrates one use of the [URL] section of the Internet Service Provider (.isp) File.

[URL]
Reconnect = http://www.fabrikam.com
Signup = C:\Windows\Signup.htm

Reconnect

Specifies a secondary URL used in case of a disconnection or server error.

Syntax | Reconnect = URL
Value | Valid sign-up server reconnection URL
Example
Reconnect = http://www.fabrikam.com

Return to top

Signup

Specifies the path to the page containing a link to the .ins file for the sign-up server.

Syntax | Signup = path_and_file_name
Value | path_and_file_name
Example
Signup = C:\Windows\Signup.htm

Return to top


[User] (.isp)

banner

[User]

Answer File = Internet Service Provider (.isp) File

The [User] section contains entries for specifying information about the end user.

Entry | Description
Name | Specifies the user name.
Password | Specifies the password.
Requires_Logon | Specifies whether to require the end user to log on.

Sample

This sample demonstrates one use of the [User] section of the Internet Service Provider (.isp) File.

[User]
Name = Pat Coleman
Password = PC*1234
Requires_Logon = Yes

Name

Specifies the user name.

Syntax | Name = string
Value | string
Example
Name = Pat Coleman

Return to top

Password

Specifies the password.

Syntax | Password = string
Value | string
Example
Password = PC*1234

Return to top

Requires_Logon

Specifies whether to require the end user to log on.

Syntax Requires_Logon = Yes | No
Values Yes

Requires the end user to log on.

No

Does not require the end user to log on.
Example
Requires_Logon = Yes

Return to top


Oeminfo.ini

To fulfill the terms of the Microsoft® Windows® XP Original Equipment Manufacturer (OEM) license agreement, you are required to identify your company and provide a link to information about your product support services in System Properties.

To include your product support information in System Properties

  1. Copy the Oeminfo.ini file from the \Samples\Branding folder on the Windows OPK CD to the \$OEM$\$$\System32 subfolder of the distribution folder.
  2. Remove all fictitious sample values from this file, and replace them with your specific information.

The following sections appear in Oeminfo.ini:

Section | Optional or Required
[General] | Required
[ICW] | Optional
[OEMSpecific] | Optional
[Support Information] | Required. You must localize the required [Support Information] section in Oeminfo.ini for each language in which you release your product.

Note

  • Do not include any information in Oeminfo.ini that will not be true if the customer upgrades the computer to a later version of Windows.

Example Oeminfo.ini file

[General]
Manufacturer = Fabrikam
Model = Fabrikam DTP/433
SupportURL = http://www.fabrikam.com

[ICW]
Product = Brand X from Fabrikam, Inc.

[OEMSpecific]
SubModel = 456A0123
SerialNo = 12345678
OEM1 = Built from image 20010630
OEM2 = Factory location: Redmond, Washington

[Support Information]
Line1 = For technical support:
Line2 = In the USA:
Line3 = Call 1-425-707-9790 from 8 A.M. to 8 P.M. EST
Line4 = for software and hardware support.
Line5 =
Line6 = In the United Kingdom:
Line7 = Call 44-9790 for hardware configuration support.
Line8 = Call 55-9799 for software support.
Line9 =

It is possible to change the contents of Oeminfo.ini as displayed in Help and Support Center without reinstalling Windows.

To change information without reinstalling Windows

  • Manually edit the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\HelpSvc\OEMInfo
    Manufacturer = oem_name
    Model = model_name
    Text = text[#BR#][text[#BR#]...]

    • Each #BR# is converted to a new line. For example:

    Text = "For support, please call:#BR#USA 1-800-425-707-9790#BR# Europe 1-800-425-707-9799#BR#E-mail : Support@oem_name.com#BR#"

To change the logo bitmap without reinstalling Windows

  • Replace Oemlogo.bmp in C:\Windows\System32 with another bitmap of the same name.


[General] (Oeminfo.ini)

banner

[General]

Answer File = Oeminfo.ini

The [General] section contains entries for adding text to the General tab in System Properties that identifies your company, the model of the computer, and where customers can find product support information. This section is required in Oeminfo.ini.

Entry | Description
Manufacturer | Specifies the name of the company that manufactured the computer.
Model | Specifies the name of this particular model line.
SupportURL | Specifies the Uniform Resource Locator (URL) of your company's product support resource, which Windows Update displays as a link for your customers.

Sample

This sample demonstrates one use of the [General] section of Oeminfo.ini.

[General]
Manufacturer = Fabrikam
Model = Fabrikam DTP/433
SupportURL = http://www.fabrikam.com

Manufacturer

Specifies the name of the company that manufactured the computer.

Syntax Manufacturer = manufacturer name
Value string

Do not leave any trailing spaces at the end of this string. Required.
Example
Manufacturer = Fabrikam
Comments

Important

  • You must make sure that you specify your company name in the Manufacturer entry for Oeminfo.ini before you preinstall Microsoft® Windows®. If Windows cannot find a value for this entry, end users cannot access critical product support information.

Return to top

Model

Specifies the name of this particular model line.

Syntax | Model = model name and number
Value | string
Example
Model = Fabrikam DTP/433

Return to top

SupportURL

Specifies the URL of your company's product support resource, which Windows Update displays as a link for your customers.

Syntax | SupportURL = URL
Value | string
Example
SupportURL = http://www.fabrikam.com

Return to top


[ICW] (Oeminfo.ini)

banner

[ICW]

Answer File = Oeminfo.ini

The [ICW] section contains an entry for identifying the computer to server-side applications.

Entry | Description
Product | Identifies this specific computer model.

Sample

This sample demonstrates one use of the [ICW] section of Oeminfo.ini.

[ICW]
Product = Brand X from Fabrikam, Inc.

Product

Identifies this specific computer model.

Syntax | Product = product name
Value | string
Example
Product = Brand X from Fabrikam, Inc.

Return to top


[OEMSpecific] (Oeminfo.ini)

banner

[OEMSpecific]

Answer File = Oeminfo.ini

You can store more specific information about the computer in this section of Oeminfo.ini. This information does not appear anywhere in the Microsoft® Windows® user interface. However, a support technician can gain access to this information by instructing the end user to click Start, click Run, and then type Oeminfo.ini.

You can create any entries that you want in this section. There are no length limitations.

Using Winbom.ini to store order-specific information on the computer

If your factory uses a build-to-order process, you may be programmatically generating a Winbom.ini file during your order entry process. If so, you can use the [UpdateSystem] sections in Winbom.ini to write specific information about the order or customer in Oeminfo.ini during Factory mode of Sysprep.

Example

Include this section in Winbom.ini:

[UpdateSystem]
UpdateInis = UpdatesToOeminfoFile

[UpdatesToOeminfoFile]
<Windows directory>\System32\Oeminfo.ini, OEMSpecific, , Submodel = 456A0123
<Windows directory>\System32\Oeminfo.ini, OEMSpecific, , SerialNo = 12345678
<Windows directory>\System32\Oeminfo.ini, OEMSpecific, , OEM1 = Built from image 20010630
<Windows directory>\System32\Oeminfo.ini, OEMSpecific, , OEM2 = Factory location: Redmond, Washington

Note

  • Replace <Windows directory> with the fully-qualified path for the Windows directory. The use of %WINDIR% is not supported.

When Sysprep processes this Winbom.ini file in Factory mode, it writes the following information in Oeminfo.ini:

[OEMSpecific]
SubModel = 456A0123
SerialNo = 12345678
OEM1 = Built from image 20010630
OEM2 = Factory location: Redmond, Washington


[Support Information] (Oeminfo.ini)

banner

[Support Information]

Answer File = Oeminfo.ini

The [Support Information] section contains an entry for adding text to the General tab in System Properties that identifies contact information for your company's product support services, including:

  • The telephone numbers and hours for your technical support group.
  • A link to the technical information page of your company's Web site.
  • Information for several countries or regions with a common language and different product support groups.
Entry | Description
LineXX | Specifies the logo of the original equipment manufacturer (OEM).

Important

  • This section is required in Oeminfo.ini.
  • Do not include any information in this section that does not directly pertain to product support. Specifically, do not include any marketing or promotional information.

Sample

This sample demonstrates one use of the [Support Information] section of Oeminfo.ini.

[Support Information]
Line1 = For technical support:
Line2 = In the USA:
Line3 = Call 1-425-707-9790 from 8 A.M. to 8 P.M. EST
Line4 = for software and hardware support.
Line5 =
Line6 = In the United Kingdom:
Line7 = Call 44-9790 for hardware configuration support.
Line8 = Call 55-9799 for software support.
Line9 =

LineXX

Specifies contact information for product support.

Syntax LineXX = text
Value string

At least one entry (Line1) is required.
Example
Line1 = For technical support:
Line2 = In the USA:
Line3 = Call 1-425-707-9790 from 8 A.M. to 8 P.M. EST
Line4 = for software and hardware support.
Line5 =
Line6 = In the United Kingdom:
Line7 = Call 44-9790 for hardware configuration support.
Line8 = Call 55-9799 for software support.
Line9 =
Comments XX is a number from 1 to 99. For the first entry, XX must be 1. You can include multiple lines of text by using multiple Line XX entries. The numbers must be consecutive, with no duplicates. If a number is missing in the sequence, the remaining entries do not display to the end user. To include a blank line, use an empty Line XX entry.

The text:

  • Appears in a fixed-font, read-only text box.
  • Automatically scrolls horizontally and vertically if the lines are too long or if there are more lines than can display on a single page.

Important

  • You must localize the required [Support Information] section in Oeminfo.ini for each language in which you distribute your product. Microsoft® includes only an English (U.S.) sample in the OEM Preinstallation Kit (OPK).

Return to top


Oobeinfo.ini

Oobeinfo.ini enables you to customize the Windows Welcome experience for your customers. Create the file by using Setup Manager. You can modify this file later by using Setup Manager or any text editor.

You can also use Sysprep in Factory mode to customize the contents of this file, as controlled by the settings in the [UpdateSystem] section in Winbom.ini.

The following sections appear in Oobeinfo.ini:

Section | Description
[Branding] | Enables you to incorporate your company name into Windows Welcome.
[DesktopReminders] | Enables you to place reminders for registration and the Internet service provider (ISP) sign-up offer on the desktop.
[DUN] | Enables you to configure the settings for dial-up networking that are used when collecting user registration information.
[OEMHardwareTutorial] | Enables you to include a custom hardware tutorial in Windows Welcome.
[OEMRegistrationPage] | Enables you to configure options for user registration.
[Options] | Enables you to configure other options.
[Signup] | Enables you to configure Internet sign-up options.
[StartupOptions] | Enables you to configure the appearance and operation of Msoobe.exe.
[UserInfo] | Enables you to personalize the text on the Welcome screen, and prepopulate the user information fields on the registration page.
[Version] | Enables you to prepopulate the Product Key.

For more information about Oobeinfo.ini changes in Microsoft® Windows® XP, see Changes in Windows Welcome Files.


[Branding] (Oobeinfo.ini)

banner

[Branding]

Answer File = Oobeinfo.ini

The [Branding] section contains entries for incorporating your company name into Windows Welcome. Your company name appears on two pages in Windows Welcome:

  • On the Opening screen, where the text says:

    Thank you for purchasing a CorporateName computer with Microsoft®Windows® XP.

  • On the Registration page, with the contact information for product support.
Entry | Description
OEMLogo | Specifies the logo of the original equipment manufacturer (OEM).
OEMName | Specifies the name of the OEM.

Sample

This sample demonstrates one use of the [Branding] section of Oobeinfo.ini.

[Branding]
OEMLogo = "OEMlogo.ext"
OEMName = "Fabrikam, Inc."

OEMLogo

Specifies the logo of the original equipment manufacturer (OEM).

Syntax OEMLogo = * | OEM_logo_file_name
Values *

Empty string. (Default)

OEM_logo_file_name

File name of the OEM logo.
Example
OEMLogo = oemlogo.ext
Comments You can add a graphic of your logo to Windows Welcome in .bmp, .gif, .jpg, or .png formats. You must place the logo file in the ..\Oobe\Images folder. You can specify only the file name; you cannot specify an alternative path. If you leave OEMLogo blank or set it to anything other than a valid logo in the ..\Oobe\Images folder, no graphic or error displays.

If you use a logo larger than 255 x 40 pixels, the logo displays cropped or truncated on the right and at the bottom. If you use a logo smaller than 255 x 40 pixels, Setup uses its actual size. The unused area becomes transparent and the Windows Welcome background becomes visible.

You can use any file name for the Windows Welcome logo file. In contrast, the image file used for the System Properties dialog box must be named Oemlogo.bmp.

Return to top

OEMName

Specifies the name of the OEM.

Syntax OEMName = * | name_of_OEM
Values *

Empty string. (Default)

name_of_OEM

String containing name of OEM.
Example
OEMName = "Fabrikam, Inc."
Comments This string can also be transmitted to an Internet service provider (ISP) as part of the query string used to establish an Internet account for the end user.

You can define this entry in Setup Manager or set it manually in the Oobeinfo.ini file.

To determine the value of OEMName programmatically, use the Signup.get_OEMName method.

Return to top


[DesktopReminders] (Oobeinfo.ini)

banner

[DesktopReminders]

Answer File = Oobeinfo.ini

The [DesktopReminders] section contains entries for specifying reminders.

Entry | Description
RegRemind1 | Specifies the number of days before Windows Welcome reminds the end user to register their copy of Microsoft® Windows®.
RegRemind2 | Specifies the number of days before Windows Welcome reminds the end user a second time to register their copy of Windows.
RegRemind3 | Specifies the number of days before Windows Welcome reminds the end user a third time to register their copy of Windows.
ISPRemind1 | Specifies the number of days before Windows Welcome reminds the end user to sign up for Internet access.
ISPRemind2 | Specifies the number of days before Windows Welcome reminds the end user a second time to sign up for Internet access.
ISPRemind3 | Specifies the number of days before Windows Welcome reminds the end user a third time to sign up for Internet access.

Sample

This sample demonstrates one use of the [DesktopReminders] section of Oobeinfo.ini.

[DesktopReminders]
RegRemind1 = 30
RegRemind2 = 20
RegRemind3 = 10
ISPRemind1 = 30
ISPRemind2 = 20
ISPRemind3 = 10

RegRemind1

Specifies the number of days before Windows Welcome reminds the end user to register their copy of Windows.

Syntax | RegRemind1 = days
Value days

DWORD. Number of days before Windows Welcome reminds the end user to register their copy of Windows. Must be a positive integer less than or equal to 30. If 0, there is no reminder.
Default Value | 0
Example
RegRemind1 = 30

Return to top

RegRemind2

Specifies the number of days before Windows Welcome reminds the end user a second time to register their copy of Windows.

Syntax | RegRemind2 = days
Value days

DWORD. Number of days before Windows Welcome reminds the end user a second time to register their copy of Windows. Must be a positive integer less than or equal to 30. If 0, there is no reminder.
Default Value | 0
Example
RegRemind2 = 20

Return to top

RegRemind3

Specifies the number of days before Windows Welcome reminds the end user a third time to register their copy of Windows.

Syntax | RegRemind3 = days
Value days

DWORD. Number of days before Windows Welcome reminds the end user a third time to register their copy of Windows. Must be a positive integer less than or equal to 30. If 0, there is no reminder.
Default Value | 0
Example
RegRemind3 = 10

Return to top

ISPRemind1

Specifies the number of days before Windows Welcome reminds the end user to sign up for Internet access.

Syntax | ISPRemind1 = days
Value days

DWORD. Number of days before Windows Welcome reminds the end user to sign up for Internet access. Must be a positive integer less than or equal to 30. If 0, there is no reminder.
Default Value | 0
Example
ISPRemind1 = 30

Return to top

ISPRemind2

Specifies the number of days before Windows Welcome reminds the end user a second time to sign up for Internet access.

Syntax | ISPRemind2 = days
Value days

DWORD. Number of days before Windows Welcome reminds the end user a second time to sign up for Internet access. Must be a positive integer less than or equal to 30. If 0, there is no reminder.
Default Value | 0
Example
ISPRemind2 = 20

Return to top

ISPRemind3

Specifies the number of days before Windows Welcome reminds the end user a third time to sign up for Internet access.

Syntax | ISPRemind3 = days
Value days

DWORD. Number of days before Windows Welcome reminds the end user a third time to sign up for Internet access. Must be a positive integer less than or equal to 30. If 0, there is no reminder.
Default Value | 0
Example
ISPRemind3 = 10

Return to top


[DUN] (Oobeinfo.ini)

banner

[DUN]

Answer File = Oobeinfo.ini

The [DUN] section contains an entry for specifying the dial-up connection user name in Windows Welcome.

Entry | Description
UserName | Specifies the user name used for the dial-up connection.

Sample

This sample demonstrates one use of the [DUN] section of Oobeinfo.ini.

[DUN]
UserName = "username@fabrikam.com"

UserName

Specifies the user name used for the dial-up connection.

Syntax | UserName = username
Value | username
Example
UserName = "username@fabrikam.com"
Comments Setup requires the UserName entry if you choose to collect online user registration information through the Microsoft dial-up network. You can populate the UserName entry by using Setup Manager or by editing Oobeinfo.ini.

UserName is case-sensitive.

Return to top


[OEMHardwareTutorial] (Oobeinfo.ini)

banner

[OEMHardwareTutorial]

Answer File = Oobeinfo.ini

The [OEMHardwareTutorial] section contains an entry for specifying a custom original equipment manufacturer (OEM) hardware tutorial page.

Entry | Description
OEMHWTutorial | Specifies whether to include a custom OEM hardware tutorial page.

Sample

This sample demonstrates one use of the [OEMHardwareTutorial] section of Oobeinfo.ini.

[OEMHardwareTutorial]
OEMHWTutorial = 1

OEMHWTutorial

Specifies whether to include a custom OEM hardware tutorial page.

Syntax | OEMHWTutorial = 0 | 1
Values 0

Does not include a custom OEM hardware tutorial page in Windows Welcome. (Default)

1

Includes a custom OEM hardware tutorial page in Windows Welcome.
Example
OEMHWTutorial = 1
Comments | The custom tutorial must fulfill the guidelines specified in the OPK User's Guide.

Return to top


[OEMRegistrationPage] (Oobeinfo.ini)

banner

[OEMRegistrationPage]

Answer File = Oobeinfo.ini

The [OEMRegistrationPage] section contains entries for specifying the original equipment manufacturer (OEM) registration page.

Entry | Description
OEMAddRegPage | Specifies whether to display up to two custom OEM registration pages in Windows Welcome.
PostToOEM | Specifies whether to transmit registration information to the OEM's server.
RegPostURL | Specifies the uniform resource locator (URL) of the location where Windows Welcome posts registration information.

Sample

This sample demonstrates one use of the [OEMRegistrationPage] section of Oobeinfo.ini.

[OEMRegistrationPage]
OEMAddRegPage = 1
PostToOEM = 1
RegPostURL = "http://www.fabrikam.com/registration"

OEMAddRegPage

Specifies whether to display up to two custom OEM registration pages in Windows Welcome.

Syntax OEMAddRegPage = 0 | 1
Values 0

Does not add additional registration pages to Windows Welcome. (Default)

1

Adds up to two additional registration pages to Windows Welcome.
Example
OEMAddRegPage = 1
Comments

To determine the value of OEMAddRegPage programmatically, use the Directions.get_DoOEMAddRegistration or the Register.get_OEMAddRegPage method.

Return to top

PostToOEM

Specifies whether to transmit registration information to the OEM's server.

Syntax PostToOEM = 0 | 1
Values 0

Does not transmit registration information to the OEM's server. (Default)

1

Transmits registration information to the OEM's server.
Example
PostToOEM = 1
Comments If PostToOEM = 1, Windows Welcome includes a check box on the registration page so that the end user can choose whether to transmit their registration data to your company. In addition, PostToOEM enables a hyperlink on this page to a Web page containing your company's privacy policy.

To determine the value of PostToOEM programmatically, use the Register.get_PostToOEM method.

Return to top

RegPostURL

Specifies the URL of the location where Windows Welcome posts registration information.

Syntax | RegPostURL = URL
Value URL

URL of the location where Windows Welcome posts registration information.
Example
RegPostURL = "http://www.fabrikam.com/registration"
Comments | To determine the value of RegPostURL programmatically, use the Register.get_RegPostURL method.

Return to top


[Options] (Oobeinfo.ini)

banner

[Options]

Answer File = Oobeinfo.ini

The [Options] section contains entries for configuring which pages appear in Windows Welcome.

Entry | Description
AdminPW | Specifies whether to include the Administrator Password page in Windows Welcome.
AreaCode | Specifies the local area code.
DefaultKeyboard | Specifies the default keyboard value of the version of Microsoft® Windows® XP that you install.
DefaultLanguage | Specifies the default language value of the version of Windows XP that you install.
DefaultRegion | Specifies the default regional value of the version of Windows XP that you install.
DisableCallWaiting | Specifies whether to disable call waiting.
FontSmoothing | Specifies whether to turn on anti-aliasing of fonts during Windows Welcome.
IMETutorial | Specifies whether to include an Input Method Editor (IME) tutorial in Windows Welcome.
INTL_Settings | Specifies whether to display the Regional and Keyboard Settings screen in Windows Welcome.
IntroOnly | Specifies whether Windows Welcome proceeds to the Welcome page after the introductory video finishes.
JoinDomain | Specifies whether to include the Join a Domain page in Windows Welcome.
MouseTutorial | Specifies whether to include a mouse tutorial in Windows Welcome.
NoIspPreconfig | Specifies whether to process the Internet settings file without displaying a welcome message (Ispsgnup.htm) to users.
OemCust | Specifies whether to display Oemcust.htm to users.
OemEula | Specifies whether to display the original equipment manufacturer (OEM) End-User License Agreement (EULA) to users.
OemEulaText | Specifies the path and file name of a text file containing the OEM EULA.
OutsideLine | Specifies the number that the Tapi object dials before dialing any telephone number.
SkipAutoUpdate | Specifies whether to display the Help Protect Your PC page in Windows Welcome. This page enables end users to schedule Automatic Updates.
SupportPhoneNumber | Specifies the telephone number for your product support that end users can call if they encounter problems during Setup.
TimeZone | Specifies whether to display the time zone page in Windows Welcome.
TimeZoneValue | Specifies the time zone of the computer.
TonePulse | Specifies whether to use pulse dialing or tone dialing to dial a telephone modem.
USBKeyboard | Specifies whether to check for the presence of a universal serial bus (USB) keyboard.
USBMouse | Specifies whether to check for the presence of a USB mouse.
Use1394AsLan | Specifies whether to use a 1394 connection as a local area network (LAN) connection.

Sample

This sample demonstrates one use of the [Options] section of Oobeinfo.ini.

[Options]
AdminPW = 1
AreaCode = "(425)"
DefaultKeyboard = 40a
DefaultLanguage = 80a
DefaultRegion = 166
DisableCallWaiting = 1
FontSmoothing = 1
IMETutorial = 0
INTL_Settings = 0
IntroOnly = 0
JoinDomain = 0
MouseTutorial = 0
NoIspPreconfig = 0
OemCust = 1
OemEula = 1
OemEulaText = "C:\Windows\System32\Oobe\Oemeula.txt"
OutsideLine = "9"
SkipAutoUpdate = 0
SupportPhoneNumber = "425-707-9790"
TimeZone = 0
TimeZoneValue = 030
TonePulse = 1
USBKeyboard = 0
USBMouse = 0
Use1394AsLan = 1

AdminPW

Specifies whether to include the Administrator Password page in Windows Welcome.

Syntax | AdminPW = 0 | 1
Values 0

Does not include the Administrator Password page in Windows Welcome.

1

Includes the Administrator Password page in Windows Welcome. (Default)
Example
AdminPW = 0
Comments | This option is not available in Windows XP Home Edition.

Return to top

AreaCode

Specifies the local area code.

Syntax AreaCode = area code
Values string

The string used to dial an outside line.

areacode

The local area code.
Example
AreaCode = "425"

Return to top

DefaultKeyboard

Specifies the default keyboard value of the version of Windows XP that you install.

Syntax DefaultKeyboard = keyboard value
Value keyboard_value

The default keyboard value of the version of Windows XP that you install.

Index values corresponding to each language - Click here to see a table listing the numeric values corresponding to the keyboard languages.

This table lists the numeric values corresponding to the keyboards installed by default in Windows XP. Some of the following keyboards may be available only when you install support for East Asian languages or complex scripts.

Index | Language
41c | Albanian
0401 | Arabic
042b | Armenian
82c | Azeri (Cyrillic)
42c | Azeri (Latin)
423 | Belarusian
1080c | Belgian (Comma)
813 | Belgian (Period)
80c | Belgian French
402 | Bulgarian
10402 | Bulgarian (Latin)
1009 | Canadian French
c0c | Canadian French (Legacy)
11009 | Canadian Multilingual Standard
0804 | Chinese (Simplified)
0404 | Chinese (Traditional)
41a | Croatian
405 | Czech
10405 | Czech (QWERTY)
20405 | Czech Programmers
406 | Danish
0465 | Divehi (Maldivian)
413 | Dutch
0409 | English
425 | Estonian
438 | Faeroese
0429 | Farsi
40b | Finnish
40c | French
11809 | Gaelic
0437 | Georgian
407 | German
10407 | German (IBM)
408 | Greek
10408 | Greek (220)
30408 | Greek (220) Latin
20408 | Greek (319)
40408 | Greek (319) Latin
50408 | Greek Latin
60408 | Greek Polytonic
040d | Hebrew
0439 | Hindi
40e | Hungarian
1040e | Hungarian 101
40f | Icelandic
044d | Indic-Assamese
0445 | Indic-Bengali
0447 | Indic-Gujarati
044b | Indic-Kannada
044c | Indic-Malayalam
0448 | Indic-Oriya
0446 | Indic-Punjabi
0449 | Indic-Tamil
044a | Indic-Telugu
1809 | Irish
410 | Italian
10410 | Italian (142)
411 | Japanese
43f | Kazakh
0457 | Konkani
0412 | Korean (Hangul)
440 | Kyrgyz (Cyrillic)
80a | Latin American
426 | Latvian
10426 | Latvian (QWERTY)
10427 | Lithuanian
427 | Lithuanian IBM
42f | Macedonian (FYROM)
044e | Marathi
450 | Mongolian (Cyrillic)
0861 | Nepali
414 | Norwegian
10415 | Polish (214)
415 | Polish (Programmers)
816 | Portuguese
416 | Portuguese (Brazilian ABNT)
10416 | Portuguese (Brazilian ABNT2)
418 | Romanian
419 | Russian
10419 | Russian (Typewriter)
044f | Sanskrit
c1a | Serbian (Cyrillic)
81a | Serbian (Latin)
41b | Slovak
1041b | Slovak (QWERTY)
424 | Slovenian
40a | Spanish
1040a | Spanish Variation
41d | Swedish
100c | Swiss French
807 | Swiss German
045a | Syriac
444 | Tatar
041e | Thai
1041f | Turkish F
41f | Turkish Q
422 | Ukrainian
809 | United Kingdom
409 | United States
10409 | United States (Dvorak)
30409 | United States (Dvorak for left hand)
40409 | United States (Dvorak for right hand)
20409 | United States (International)
0420 | Urdu
843 | Uzbek (Cyrillic)
042a | Vietnamese
Example
DefaultKeyboard = 40a
Comments It is recommended that you preconfigure this entry and do not display the INTL_Settings page to the users unless you are uncertain of the country/region in which the computer will be purchased.

Any settings specified in the [RegionalSettings] section in Unattend.txt do not remain after you run Sysprep on the computer. If the first-run experience is Windows Welcome, use the DefaultKeyboard entry to configure the keyboard setting for the end user. If the first-run experience is Mini-Setup, set the appropriate values in the [RegionalSettings] section of Sysprep.inf.

Return to top

DefaultLanguage

Specifies the default language value of the version of Windows XP that you install.

Syntax DefaultLanguage = language value
Value language_value

The default language value of the version of Windows XP that you install.

Index values corresponding to each language - Click here to see a table listing the numeric values corresponding to the default languages.

This table lists the numeric values corresponding to the default languages.

Index | Language
436 | Afrikaans
41c | Albanian
82c | Azeri (Cyrillic)
42c | Azeri (Latin)
42d | Basque
423 | Belarusian
402 | Bulgarian
403 | Catalan
41a | Croatian
405 | Czech
406 | Danish
813 | Dutch (Belgium)
413 | Dutch (Netherlands)
c09 | English (Australia)
2809 | English (Belize)
1009 | English (Canada)
2409 | English (Caribbean)
1809 | English (Ireland)
2009 | English (Jamaica)
1409 | English (New Zealand)
3409 | English (Philippines)
1c09 | English (South Africa)
2c09 | English (Trinidad)
809 | English (United Kingdom)
409 | English (United States)
3009 | English (Zimbabwe)
425 | Estonian
438 | Faeroese
40b | Finnish
80c | French (Belgium)
c0c | French (Canada)
40c | French (France)
140c | French (Luxembourg)
180c | French (Monaco)
100c | French (Switzerland)
456 | Galician
c07 | German (Austria)
407 | German (Germany)
1407 | German (Liechtenstein)
1007 | German (Luxembourg)
807 | German (Switzerland)
408 | Greek
40e | Hungarian
40f | Icelandic
421 | Indonesian
410 | Italian (Italy)
810 | Italian (Switzerland)
43f | Kazakh
440 | Kyrgyz (Cyrillic)
426 | Latvian
427 | Lithuanian
42f | Macedonian (FYROM)
83e | Malay (Brunei Darussalam)
43e | Malay (Malaysia)
450 | Mongolian (Cyrillic)
414 | Norwegian (Bokmal)
814 | Norwegian (Nynorsk)
415 | Polish
416 | Portuguese (Brazil)
816 | Portuguese (Portugal)
418 | Romanian
419 | Russian
c1a | Serbian (Cyrillic)
81a | Serbian (Latin)
41b | Slovak
424 | Slovenian
2c0a | Spanish (Argentina)
400a | Spanish (Bolivia)
340a | Spanish (Chile)
240a | Spanish (Colombia)
140a | Spanish (Costa Rica)
1c0a | Spanish (Dominican Republic)
300a | Spanish (Ecuador)
440a | Spanish (El Salvador)
100a | Spanish (Guatemala)
480a | Spanish (Honduras)
80a | Spanish (Mexico)
4c0a | Spanish (Nicaragua)
180a | Spanish (Panama)
3c0a | Spanish (Paraguay)
280a | Spanish (Peru)
500a | Spanish (Puerto Rico)
40a | Spanish (Spain)
380a | Spanish (Uruguay)
200a | Spanish (Venezuela)
441 | Swahili
41d | Swedish
81d | Swedish (Finland)
444 | Tatar
41f | Turkish
422 | Ukrainian
843 | Uzbek (Cyrillic)
443 | Uzbek (Latin)

This table lists the numeric values corresponding to the East Asian languages.

Index | Language
0404 | Chinese (Taiwan)
0804 | Chinese (PRC)
0c04 | Chinese (Hong Kong SAR)
1004 | Chinese (Singapore)
1404 | Chinese (Macao SAR)
0411 | Japanese
0412 | Korean

This table lists the numeric values corresponding to the complex script languages.

Index | Language
0801 | Arabic (Iraq)
0c01 | Arabic (Egypt)
1001 | Arabic (Libya)
1401 | Arabic (Algeria)
1801 | Arabic (Morocco)
1c01 | Arabic (Tunisia)
2001 | Arabic (Oman)
2401 | Arabic (Yemen)
2801 | Arabic (Syria)
2c01 | Arabic (Jordan)
3001 | Arabic (Lebanon)
3401 | Arabic (Kuwait)
3801 | Arabic (UAE)
3c01 | Arabic (Bahrain)
4001 | Arabic (Qatar)
042b | Armenian
040d | Hebrew
0439 | Hindi
0457 | Konkani
044f | Sanskrit
0449 | Tamil
041e | Thai
0420 | Urdu
042a | Vietnamese
Example
DefaultLanguage = 80a
Comments It is recommended that you preconfigure this entry and do not display the INTL_Settings page to the users unless you are uncertain of the country/region in which the computer will be purchased.

Any settings specified in the [RegionalSettings] section in Unattend.txt do not remain after you run Sysprep on the computer. If the first-run experience is Windows Welcome, use the DefaultLanguage entry to configure the language setting for the end user. If the first-run experience is Mini-Setup, set the appropriate values in the [RegionalSettings] section of Sysprep.inf.

Return to top

DefaultRegion

Specifies the default regional value of the version of Windows XP that you install.

Syntax DefaultRegion = region value
Value region_value

The default regional value of the version of Windows XP you are installing.

Index values corresponding to each region or location - Click here to see a table listing the numeric values corresponding to the default regions or locations.

This table lists the numeric values corresponding to the default regions or locations.

Index | Region or Location
3 | Transitional Islamic State of Afghanistan
6 | Albania
4 | Algeria
10 | American Samoa
8 | Andorra
9 | Angola
300 | Anguilla
301 | Antarctica
2 | Antigua and Barbuda
11 | Argentina
7 | Armenia
302 | Aruba
303 | Ascension Island
304 | Ashmore and Cartier Islands
12 | Australia
14 | Austria
5 | Azerbaijan
22 | Bahamas, The
17 | Bahrain
305 | Baker Island
23 | Bangladesh
18 | Barbados
29 | Belarus
21 | Belgium
24 | Belize
28 | Benin
20 | Bermuda
34 | Bhutan
26 | Bolivia
25 | Bosnia and Herzegovina
19 | Botswana
306 | Bouvet Island
32 | Brazil
114 | British Indian Ocean Territory
37 | Brunei
35 | Bulgaria
245 | Burkina Faso
38 | Burundi
40 | Cambodia
49 | Cameroon
39 | Canada
57 | Cape Verde
307 | Cayman Islands
55 | Central African Republic
41 | Chad
308 | Channel Islands
46 | Chile
45 | China
309 | Christmas Island
310 | Clipperton Island
311 | Cocos (Keeling) Islands
51 | Colombia
50 | Comoros
43 | Congo
44 | Congo (DRC)
312 | Cook Islands
313 | Coral Sea Islands
54 | Costa Rica
119 | Côte d’Ivoire
108 | Croatia
56 | Cuba
59 | Cyprus
75 | Czech Republic
61 | Denmark
314 | Diego Garcia
62 | Djibouti
63 | Dominica
65 | Dominican Republic
7299303 | Democratic Republic of Timor-Leste
66 | Ecuador
67 | Egypt
72 | El Salvador
69 | Equatorial Guinea
71 | Eritrea
70 | Estonia
73 | Ethiopia
315 | Falkland Islands (Islas Malvinas)
81 | Faroe Islands
78 | Fiji Islands
77 | Finland
84 | France
317 | French Guiana
318 | French Polynesia
319 | French Southern and Antarctic Lands
87 | Gabon
86 | Gambia, The
88 | Georgia
94 | Germany
89 | Ghana
90 | Gibraltar
98 | Greece
93 | Greenland
91 | Grenada
321 | Guadeloupe
322 | Guam
323 | Guantanamo Bay
99 | Guatemala
324 | Guernsey
100 | Guinea
196 | Guinea-Bissau
101 | Guyana
103 | Haiti
325 | Heard Island and McDonald Islands
106 | Honduras
104 | Hong Kong SAR
326 | Howland Island
109 | Hungary
110 | Iceland
113 | India
111 | Indonesia
116 | Iran
121 | Iraq
68 | Ireland
117 | Israel
118 | Italy
124 | Jamaica
125 | Jan Mayen
122 | Japan
327 | Jarvis Island
328 | Jersey
127 | Johnston Atoll
126 | Jordan
137 | Kazakhstan
129 | Kenya
329 | Kingman Reef
133 | Kiribati
134 | Korea
136 | Kuwait
130 | Kyrgyzstan
138 | Laos
140 | Latvia
139 | Lebanon
146 | Lesotho
142 | Liberia
148 | Libya
145 | Liechtenstein
141 | Lithuania
147 | Luxembourg
151 | Macao SAR
19618 | Former Yugoslav Republic of Macedonia
149 | Madagascar
156 | Malawi
167 | Malaysia
165 | Maldives
157 | Mali
163 | Malta
15126 | Man, Isle of
199 | Marshall Islands
330 | Martinique
162 | Mauritania
160 | Mauritius
331 | Mayotte
166 | Mexico
80 | Micronesia
21242 | Midway Islands
152 | Moldova
158 | Monaco
154 | Mongolia
332 | Montserrat
159 | Morocco
168 | Mozambique
27 | Myanmar
254 | Namibia
180 | Nauru
178 | Nepal
333 | Netherlands Antilles
176 | Netherlands, The
334 | New Caledonia
183 | New Zealand
182 | Nicaragua
173 | Niger
175 | Nigeria
335 | Niue
336 | Norfolk Island
131 | North Korea
337 | Northern Mariana Islands
177 | Norway
164 | Oman
190 | Pakistan
195 | Palau
184 | Palestinian Authority
338 | Palmyra Atoll
192 | Panama
194 | Papua New Guinea
185 | Paraguay
187 | Peru
201 | Philippines
339 | Pitcairn Islands
191 | Poland
193 | Portugal
202 | Puerto Rico
197 | Qatar
198 | Reunion
200 | Romania
340 | Rota Island
203 | Russia
204 | Rwanda
341 | Saipan
259 | Samoa
214 | San Marino
233 | São Tomé and Príncipe
205 | Saudi Arabia
210 | Senegal
208 | Seychelles
213 | Sierra Leone
215 | Singapore
143 | Slovakia
212 | Slovenia
30 | Solomon Islands
216 | Somalia
209 | South Africa
342 | South Georgia and the South Sandwich Islands
217 | Spain
42 | Sri Lanka
343 | St. Helena
207 | St. Kitts and Nevis
218 | St. Lucia
206 | St. Pierre and Miquelon
248 | St. Vincent and the Grenadines
219 | Sudan
181 | Suriname
220 | Svalbard
260 | Swaziland
221 | Sweden
223 | Switzerland
222 | Syria
237 | Taiwan
229 | Tajikistan
239 | Tanzania
227 | Thailand
346 | Tinian Island
232 | Togo
347 | Tokelau
231 | Tonga
225 | Trinidad and Tobago
348 | Tristan da Cunha
234 | Tunisia
235 | Turkey
238 | Turkmenistan
349 | Turks and Caicos Islands
236 | Tuvalu
240 | Uganda
241 | Ukraine
224 | United Arab Emirates
242 | United Kingdom
244 | United States
246 | Uruguay
247 | Uzbekistan
174 | Vanuatu
253 | Vatican City
249 | Venezuela
251 | Vietnam
252 | Virgin Islands
351 | Virgin Islands, British
258 | Wake Island
352 | Wallis and Futuna
261 | Yemen
269 | Serbia and Montenegro
263a | Zambia
264 | Zimbabwe
Example
DefaultRegion = 166
Comments It is recommended that you preconfigure this entry and do not display the INTL_Settings page to the users unless you are uncertain of the country/region in which the computer will be purchased.

Any settings specified in the [RegionalSettings] section in Unattend.txt do not remain after you run Sysprep on the computer. If the first-run experience is Windows Welcome, use the DefaultRegion entry to configure the region setting for the end user. If the first-run experience is Mini-Setup, set the appropriate values in the [RegionalSettings] section of Sysprep.inf.

Return to top

DisableCallWaiting

Specifies whether to disable call waiting.

Syntax | DisableCallWaiting = 0 | 1
Values 0

Does not disable call waiting. (Default)

1

Disables call waiting.
Example
DisableCallWaiting = 1
Comments | DisableCallWaiting is available mainly for testing purposes.

Return to top

FontSmoothing

Specifies whether to turn on anti-aliasing of fonts during Windows Welcome.

Syntax | FontSmoothing = 0 | 1
Values 0

Turns off anti-aliasing of fonts during Windows Welcome.

1

Turns on anti-aliasing of fonts during Windows Welcome. (Default)
Example
FontSmoothing = 0
Comments | FontSmoothing affects only the appearance of screen fonts in Windows Welcome. This setting does not change the display settings of the Windows desktop.

Return to top

IMETutorial

Specifies whether to include an Input Method Editor (IME) tutorial in Windows Welcome.

Syntax IMETutorial = 0 | 1
Values 0

Does not include an Input Method Editor (IME) tutorial in Windows Welcome. (Default)

1

Includes an IME tutorial in Windows Welcome.
Example
IMETutorial = 0
Comments You may create a custom IME tutorial for the Japanese, Traditional Chinese, Simplified Chinese, and Korean versions of Windows if your license agreement permits this. Microsoft does not provide a default IME tutorial.

To determine the value of IMETutorial programmatically, use the Directions.get_DoIMETutorial method.

Return to top

INTL_Settings

Specifies whether to display the Regional and Keyboard Settings screen in Windows Welcome.

Syntax INTL_Settings = 0 | 1
Values 0

Does not display the Regional and Keyboard Settings screen in Windows Welcome. (Default)

1

Displays the Regional and Keyboard Settings screen in Windows Welcome.
Example
INTL_Settings = 0
Comments It is recommended that you preconfigure the DefaultKeyboard, DefaultLanguage, and DefaultRegion settings and do not display the Regional and Keyboard Settings page to the users unless you are uncertain of the country/region in which the computer will be purchased.

If you have preconfigured the regional and keyboard settings, then the Regional and Keyboard Settings page in Windows Welcome does not appear. If any values on this screen are invalid, then the screen appears to the end user.

To determine the value of the Regional and Keyboard Settings page programmatically, use the Directions.get_DoRegionalKeyboard method.

The behavior of the Regional and Keyboard Settings page is as follows:

  • If the page does not appear (default) and you preconfigure the values in Setup Manager, then the values apply without user input.
  • If the page appears and you preconfigure the defaults, then the preconfigured values appear to the user, who can then modify the values.
  • If the page does not appear (default) and you do not preconfigure any values, then the defaults for the particular language apply without user input. For example, an English system sold in Australia would have the United States default settings.
  • If the page appears but you do not preconfigure the defaults, then the defaults for the installed language appear to the user, who can then modify the values.

Return to top

IntroOnly

Specifies whether Windows Welcome proceeds to the Welcome page after the introductory video finishes.

IntroOnly only applies to the retail version of Windows Welcome. In OEM installations of Windows, Sysprep sets the entry of IntroOnly to 0.

Syntax | IntroOnly = 0 | 1
Values 0

Windows Welcome proceeds to the Welcome page after the introductory video finishes playing.

1

Windows Welcome ends after the introductory video finishes playing. (Default)
Example
IntroOnly = 0
Comments | IntroOnly is set to 1 if the computer is joined to a domain during Setup.

Return to top

JoinDomain

Specifies whether to include the Join a Domain page in Windows Welcome.

Syntax | JoinDomain = 0 | 1
Values [string, joindomain] 0

Does not include the Join a Domain page in Windows Welcome.

1

Includes the Join a Domain page in Windows Welcome. (Default)
Example
JoinDomain = 0
Comments | This option is not available in Windows XP Home Edition.

Return to top

MouseTutorial

Specifies whether to include a mouse tutorial in Windows Welcome.

Syntax MouseTutorial = 0 | 1
Values 0

Does not include a mouse tutorial in Windows Welcome. (Default)

1

Includes the sample HTML-based mouse tutorial in Windows Welcome.
Example
MouseTutorial = 1
Comments If you configured your computer with a pointing device other than a standard desktop mouse, set MouseTutorial to 2 and modify the old HTML mouse tutorial pages.

To determine the value of MouseTutorial programmatically, use the Directions.get_DoMouseTutorial method.

Return to top

NoIspPreconfig

Specifies whether to process the Internet settings file without displaying a welcome message (Ispsgnup.htm) to users.

Syntax NoIspPreconfig = 0 | 1
Values 0

Windows Welcome displays a welcome message. (Default)

1

Windows Welcome does not display a welcome message.
Example
NoIspPreconfig = 1

Return to top

OemCust

Specifies whether to display Oemcust.htm to users.

Syntax OemCust = 0 | 1
Values 0

Windows Welcome does not display Oemcust.htm. (Default)

1

Windows Welcome displays Oemcust.htm.
Example
OemCust = 1

Return to top

OemEula

Specifies whether to display the OEM End User License Agreement (EULA) to users.

Syntax | OemEula = 0 | 1
Values 0

Windows Welcome does not display the OEM EULA. (Default)

1

Windows Welcome displays the OEM EULA.
Example
OemEula = 1
Comments | To use this option, you must also enable the OemEulaText option.

Return to top

OemEulaText

Specifies the path and file name of a text file containing the OEM EULA.

Syntax | OemEulaText = path and file name
Values path and file name

The path and file name of a text file containing the OEM EULA (for example, C:\Windows\System32\Oobe\Oemeula.txt).
Example
OemEulaText = C:\Windows\System32\Oobe\Oemeula.txt
Comments | To use this option, you must also enable the OemEula option. The Microsoft EULA appears on top; the OEM EULA appears underneath it.

Return to top

OutsideLine

Specifies the number that the Tapi object dials before dialing any telephone number.

Syntax OutsideLine = number
Value prefix

The number that the Tapi object dials before dialing any telephone number.
Example
OutsideLine = "9"

Return to top

SkipAutoUpdate

Specifies whether to display the Help Protect Your PC page in Windows Welcome. This page enables end users to schedule Automatic Updates.

Syntax | SkipAutoUpdate = 0 | 1
Values 0

Displays the Help Protect Your PC page in Windows Welcome. (Default)

1

Hides the Help Protect Your PC page in Windows Welcome, and no settings are sent to Automatic Updates.
Example
SkipAutoUpdate = 0
Comments | If this option is missing, or if SkipAutoUpdate = 0, the Help Protect Your PC page displays in Windows Welcome. OEMs are required to display the Help Protect Your PC page. Only IT corporate administrators may use SkipAutoUpdate to hide this page.

Return to top

SupportPhoneNumber

Specifies the telephone number for your product support that end users can call if they encounter problems during Setup.

Syntax | SupportPhoneNumber = phone number
Value phone

The phone number for your product support that the end user can call if they encounter problems during Setup.
Example
SupportPhoneNumber = "425-707-9790"
Comments | To determine the value of SupportPhoneNumber programmatically, use the GetSupportPhoneNum method.

Return to top

TimeZone

Specifies whether to display the time zone page in Windows Welcome.

Syntax | TimeZone = 0 | 1
Values 0

Does not display the time zone page in Windows Welcome. (Default)

1

Displays the time zone page in Windows Welcome.
Example
TimeZone = 1
Comments | If you want to preconfigure the time zone setting, do not use TimeZone = 1. Instead, use TimeZoneValue.

Return to top

TimeZoneValue

Specifies the time zone of the computer.

Syntax TimeZoneValue = numeric value
Value index

Index values corresponding to each time zone - Click here to see a table listing the numeric values corresponding to the time zones.

This table lists the numeric values corresponding to the time zones.

Index | Time Zone | Display
000 | Dateline Standard Time | (GMT-12:00) International Date Line West
001 | Samoa Standard Time | (GMT-11:00) Midway Island, Samoa
002 | Hawaiian Standard Time | (GMT-10:00) Hawaii
003 | Alaskan Standard Time | (GMT-09:00) Alaska
004 | Pacific Standard Time | (GMT-08:00) Pacific Time (US and Canada); Tijuana
010 | Mountain Standard Time | (GMT-07:00) Mountain Time (US and Canada)
013 | Mexico Standard Time 2 | (GMT-07:00) Chihuahua, La Paz, Mazatlan
015 | U.S. Mountain Standard Time | (GMT-07:00) Arizona
020 | Central Standard Time | (GMT-06:00) Central Time (US and Canada)
025 | Canada Central Standard Time | (GMT-06:00) Saskatchewan
030 | Mexico Standard Time | (GMT-06:00) Guadalajara, Mexico City, Monterrey
033 | Central America Standard Time | (GMT-06:00) Central America
035 | Eastern Standard Time | (GMT-05:00) Eastern Time (US and Canada)
040 | U.S. Eastern Standard Time | (GMT-05:00) Indiana (East)
045 | S.A. Pacific Standard Time | (GMT-05:00) Bogota, Lima, Quito
050 | Atlantic Standard Time | (GMT-04:00) Atlantic Time (Canada)
055 | S.A. Western Standard Time | (GMT-04:00) Caracas, La Paz
056 | Pacific S.A. Standard Time | (GMT-04:00) Santiago
060 | Newfoundland and Labrador Standard Time | (GMT-03:30) Newfoundland and Labrador
065 | E. South America Standard Time | (GMT-03:00) Brasilia
070 | S.A. Eastern Standard Time | (GMT-03:00) Buenos Aires, Georgetown
073 | Greenland Standard Time | (GMT-03:00) Greenland
075 | Mid-Atlantic Standard Time | (GMT-02:00) Mid-Atlantic
080 | Azores Standard Time | (GMT-01:00) Azores
083 | Cape Verde Standard Time | (GMT-01:00) Cape Verde Islands
085 | GMT Standard Time | (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London
090 | Greenwich Standard Time | (GMT) Casablanca, Monrovia
095 | Central Europe Standard Time | (GMT+01:00) Belgrade, Bratislava, Budapest, Ljubljana, Prague
100 | Central European Standard Time | (GMT+01:00) Sarajevo, Skopje, Warsaw, Zagreb
105 | Romance Standard Time | (GMT+01:00) Brussels, Copenhagen, Madrid, Paris
110 | W. Europe Standard Time | (GMT+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna
113 | W. Central Africa Standard Time | (GMT+01:00) West Central Africa
115 | E. Europe Standard Time | (GMT+02:00) Bucharest
120 | Egypt Standard Time | (GMT+02:00) Cairo
125 | FLE Standard Time | (GMT+02:00) Helsinki, Kiev, Riga, Sofia, Tallinn, Vilnius
130 | GTB Standard Time | (GMT+02:00) Athens, Istanbul, Minsk
135 | Israel Standard Time | (GMT+02:00) Jerusalem
140 | South Africa Standard Time | (GMT+02:00) Harare, Pretoria
145 | Russian Standard Time | (GMT+03:00) Moscow, St. Petersburg, Volgograd
150 | Arab Standard Time | (GMT+03:00) Kuwait, Riyadh
155 | E. Africa Standard Time | (GMT+03:00) Nairobi
158 | Arabic Standard Time | (GMT+03:00) Baghdad
160 | Iran Standard Time | (GMT+03:30) Tehran
165 | Arabian Standard Time | (GMT+04:00) Abu Dhabi, Muscat
170 | Caucasus Standard Time | (GMT+04:00) Baku, Tbilisi, Yerevan
175 | Transitional Islamic State of Afghanistan Standard Time | (GMT+04:30) Kabul
180 | Ekaterinburg Standard Time | (GMT+05:00) Ekaterinburg
185 | West Asia Standard Time | (GMT+05:00) Islamabad, Karachi, Tashkent
190 | India Standard Time | (GMT+05:30) Chennai, Kolkata, Mumbai, New Delhi
193 | Nepal Standard Time | (GMT+05:45) Kathmandu
195 | Central Asia Standard Time | (GMT+06:00) Astana, Dhaka
200 | Sri Lanka Standard Time | (GMT+06:00) Sri Jayawardenepura
201 | N. Central Asia Standard Time | (GMT+06:00) Almaty, Novosibirsk
203 | Myanmar Standard Time | (GMT+06:30) Yangon (Rangoon)
205 | S.E. Asia Standard Time | (GMT+07:00) Bangkok, Hanoi, Jakarta
207 | North Asia Standard Time | (GMT+07:00) Krasnoyarsk
210 | China Standard Time | (GMT+08:00) Beijing, Chongqing, Hong Kong SAR, Urumqi
215 | Singapore Standard Time | (GMT+08:00) Kuala Lumpur, Singapore
220 | Taipei Standard Time | (GMT+08:00) Taipei
225 | W. Australia Standard Time | (GMT+08:00) Perth
227 | North Asia East Standard Time | (GMT+08:00) Irkutsk, Ulaanbaatar
230 | Korea Standard Time | (GMT+09:00) Seoul
235 | Tokyo Standard Time | (GMT+09:00) Osaka, Sapporo, Tokyo
240 | Yakutsk Standard Time | (GMT+09:00) Yakutsk
245 | A.U.S. Central Standard Time | (GMT+09:30) Darwin
250 | Cen. Australia Standard Time | (GMT+09:30) Adelaide
255 | A.U.S. Eastern Standard Time | (GMT+10:00) Canberra, Melbourne, Sydney
260 | E. Australia Standard Time | (GMT+10:00) Brisbane
265 | Tasmania Standard Time | (GMT+10:00) Hobart
270 | Vladivostok Standard Time | (GMT+10:00) Vladivostok
275 | West Pacific Standard Time | (GMT+10:00) Guam, Port Moresby
280 | Central Pacific Standard Time | (GMT+11:00) Magadan, Solomon Islands, New Caledonia
285 | Fiji Islands Standard Time | (GMT+12:00) Fiji Islands, Kamchatka, Marshall Islands
290 | New Zealand Standard Time | (GMT+12:00) Auckland, Wellington
300 | Tonga Standard Time | (GMT+13:00) Nuku'alofa
Example
TimeZoneValue = 013
Registry subkey HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
TimeZoneInformation\DaylightName
Comments If the entry is not present, the end user must select a time zone.

Note

  • If you do not configure a specific time zone setting, the default time zone depends on the language version of Windows that is installed. For example, in the Japanese version, the default time zone is "GMT+9 (Osaka, Sapporo, Tokyo)."

Return to top

TonePulse

Specifies whether to use pulse dialing or tone dialing to dial a telephone modem.

Syntax | TonePulse = 0 | 1
Values 0

Uses pulse dialing to dial a telephone modem. (Default)

1

Uses tone dialing to dial a telephone modem.
Example
TonePulse = 0
Comments | The default is 0 unless the Telephony API settings specify tone. If TAPI settings specify tone, then TonePulse defaults to 1.

Return to top

USBKeyboard

Specifies whether to check for the presence of a USB keyboard.

Syntax | USBKeyboard = 0 | 1
Values 0

Does not check for the presence of a USB keyboard. (Default)

1

Checks for the presence of a USB keyboard.
Example
USBKeyboard = 1
Comments | See comments following USBMouse.

Return to top

USBMouse

Specifies whether to check for the presence of a USB mouse.

Syntax USBMouse = 0 | 1
Values 0

Does not check for the presence of a USB mouse. (Default)

1

Checks for the presence of a USB mouse.
Example
USBMouse = 1
Comments If enabled, Windows Welcome performs the USB keyboard and mouse check before the Welcome screen appears. If the checks pass, then the Welcome screen appears. If one or both of the checks fail (meaning that a USB keyboard or mouse is not connected to the computer), Windows Welcome automatically displays the following error page:

ROOT:\Windows\System32\Oobe\Setup\Nousbkbd.htm (no keyboard)

ROOT:\Windows\System32\Oobe\Setup\Nousbms.htm (no mouse)

ROOT:\Windows\System32\Oobe\Setup\Nousbkm.htm (no keyboard and no mouse)

You need to modify these pages with information appropriate to each model of computer that you ship. Microsoft recommends that on these pages you display a picture or drawing showing the end user exactly where they need to plug in the keyboard and/or mouse.

Sample files for these pages are in: OPK:\Samples\Oobe\Oemhw

Note

  • Windows Welcome does not check for PS/2 or serial mice/keyboards.

Return to top

Use1394AsLan

Specifies whether to use a 1394 connection as a LAN connection.

Syntax Use1394AsLan = 0 | 1
Values 0

Does not use 1394 connection as a LAN connection.

1

Uses 1394 connection as a LAN connection. (Default)
Example
Use1394AsLan = 1

Return to top


[Signup] (Oobeinfo.ini)

banner

[Signup]

Answer File = Oobeinfo.ini

The [Signup] section contains entries for specifying Internet signup.

Entry | Description
ISPSignup | Specifies the Internet Service Provider (ISP).
OEMOfferCode | Specifies the original equipment manufacturer (OEM) offer code.

Sample

This sample demonstrates one use of the [Signup] section of Oobeinfo.ini.

[Signup]
ISPSignup = "MSN"
OEMOfferCode = 0

ISPSignup

Specifies the Internet Service Provider (ISP).

Syntax | ISPSignup = isp_provider
Value isp_provider

MSN

Microsoft® MSN® Internet Access is the only specific ISP offer available to the end user. The end user still has the option of migrating an existing Internet account (through any ISP supporting this feature in the Microsoft Internet Referral Service) or using Internet Connection Sharing if present.

OFFLINE

Displays a precached (local) list of ISP offers.

PRECONFIG

Preconfigures Internet service at the factory to use a specific new Internet account, created for this end user.

None

Does not include an ISP sign-up offer in Windows Welcome.
Example
ISPSignup = "MSN"
Comments | To determine the value of ISPSignup programmatically, use the Directions.get_ISPSignup method.

Return to top

OEMOfferCode

Specifies the OEM offer code.

Syntax | OEMOfferCode = 0
Value | 0 (Default)
Example
OEMOfferCode = 0
Comments The value is always 0 because you must display one of the four Internet Signup options that are specified with the ISPSignup entry.

To determine the value of OEMOfferCode programmatically, use the Directions.get_OEMOfferCode method.

Return to top


[StartupOptions] (Oobeinfo.ini)

banner

[StartupOptions]

Answer File = Oobeinfo.ini

The [StartupOptions] section contains entries for specifying startup options.

Sample

This sample demonstrates one use of the [StartupOptions] section of Oobeinfo.ini.

Entry | Description
DesktopStartURL | Specifies the universal resource locator (URL) of the initial page displayed for Internet service provider (ISP) sign-up that occurs after the user has completed Windows Welcome.
DesktopWindowHeight | Specifies in pixels the height of the Windows Welcome window in desktop mode.
DesktopWindowWidth | Specifies in pixels the width of the Windows Welcome window in desktop mode.
OEMAuditBoot | Specifies whether to restart the computer in Windows Welcome or in Factory mode.
Offline | Specifies whether to run Windows Welcome in offline mode.
Registration | Specifies whether to display the registration pages.
ScreenResolutionCheck | Specifies whether Windows Welcome detects screen resolution.
[StartupOptions]
DesktopStartURL = "http://www.fabrikam.com/signup"
DesktopWindowHeight = 530
DesktopWindowWidth = 640
OEMAuditBoot = 1
Offline = 1
Registration = 1
ScreenResolutionCheck = 0

DesktopStartURL

Specifies the URL of the initial page displayed for ISP sign-up that occurs after the user has completed Windows Welcome.

Syntax DesktopStartURL = URL
Value URL

URL of the initial page displayed for ISP sign-up that occurs after the user has completed Windows Welcome.
Example
DesktopStartURL = "http://www.fabrikam.com/signup"

Return to top

DesktopWindowHeight

Specifies in pixels the height of the Windows Welcome window in desktop mode.

Syntax | DesktopWindowHeight = height
Value height

Size, in pixels, of the height of the Windows Welcome window in desktop mode.
Default Value | 530
Example
DesktopWindowHeight = 530

Return to top

DesktopWindowWidth

Specifies in pixels the width of the Windows Welcome window in desktop mode.

Syntax | DesktopWindowWidth = width
Value width

Size, in pixels, of the width of the Windows Welcome window in desktop mode.
Default Value | 640
Example
DesktopWindowWidth = 640

Return to top

OEMAuditBoot

Specifies whether to restart the computer in Windows Welcome or in Factory mode.

Syntax | OEMAuditBoot = 0 | 1
Values 0

Specifies that the computer restarts in Windows Welcome after sealing with Sysprep. (Default)

1

Specifies that the computer restarts in Factory mode.
Example
OEMAuditBoot = 1
Comments | If you do not include OEMAuditBoot in Oobeinfo.ini, it is the same as specifiying OEMAuditBoot = 0.

Return to top

Offline

Specifies whether to run Windows Welcome in offline mode.

Syntax Offline = 0 | 1
Values 0

Does not run Windows Welcome in offline mode. (Default)

1

Runs Windows Welcome in offline mode.
Example
Offline = 1
Comments In offline mode, Windows Welcome skips registration and ISP signup.

This setting is the same as the /offline command-line parameter.

To determine the value of Offline programmatically, use the Directions.get_Offline method.

Return to top

Registration

Specifies whether to display the registration pages.

Syntax | Registration = 0 | 1
Values 0

Displays the registration pages. (Default)

1

Does not display the registration pages.
Example
Registration = 1
Comments | The value of Registration determines whether Windows Welcome displays the registration pages and whether the registration checkpoint appears in the status pane of Windows Welcome. See [Signup] for more information.

Return to top

ScreenResolutionCheck

Specifies whether Windows Welcome detects screen resolution.

Syntax ScreenResolutionCheck = 0 | 1
Values 0

Windows Welcome does not detect screen resolution. If the screen resolution is less than 800 x 600 pixels, then Windows Welcome displays with scroll bars.

1

Windows Welcome detects screen resolution. If the computer hardware supports a minimum 800 x 600 pixel screen resolution and the default screen resolution is set to a smaller number (for example, 640 x 480 pixels), then Windows Welcome reconfigures the computer to use an 800 x 600-pixel screen resolution. If the hardware does not support a screen resolution of at least 800 x 600 pixels, then the first-run experience is Mini-Setup. (Default)
Example
ScreenResolutionCheck = 0

Return to top


[UserInfo] (Oobeinfo.ini)

banner

[UserInfo]

Answer File = Oobeinfo.ini

The [UserInfo] section contains entries for prepopulating end-user information and personalizing the end user experience during Windows Welcome.

Entry | Description
FirstName | Specifies the end user's first name.
MiddleInitial | Specifies the end user's middle initial.
LastName | Specifies the end user's last name.
FuriganaName | Specifies the end user's name, written in furigana.
CompanyName | Specifies the end user's company name.
Address1 | Specifies the end user's primary mailing address.
Address2 | Specifies the end user's secondary mailing address.
City | Specifies the end user's city.
State | Specifies the end user's state or region.
Zip | Specifies the end user's zip or postal code.
Country | Specifies the end user's country/region.
PrimaryEmail | Specifies the end user's e-mail address or temporary Windows ID.
SecondaryEmail | Specifies the end user's secondary e-mail address.
AreaCode | Specifies the end user's area or city code.
PhoneNumber | Specifies the end user's telephone number.
Identity000 | Specifies the end user's primary identity.
Identity001 | Specifies the end user's secondary identity.
Identity002 | Specifies the end user's third identity.
Identity003 | Specifies the end user's fourth identity.
Identity004 | Specifies the end user's fifth identity.
Identity005 | Specifies the end user's sixth identity.

Sample

This sample demonstrates one use of the [UserInfo] section of Oobeinfo.ini.

[UserInfo]
FirstName = "Pat"
MiddleInitial = "L."
LastName = "Coleman"
FuriganaName = "furigana name"
CompanyName = "Woodgrove Bank"
Address1 = "1234 Main Street"
Address2 = "P.O. Box 12345"
City = "Woodgrove"
State = "WA"
Zip = "12345"
Country = "USA"
PrimaryEmail = "Pat@fabrikam.com"
SecondaryEmail = "Patc@fabrikam.com"
AreaCode = "123"
PhoneNumber = "456-7890"
Identity000 = "Pat"
Identity001 = "Zainal"
Identity002 = "Josh"
Identity003 = "Adam"
Identity004 = "Paula"
Identity005 = "Shay"

FirstName

Specifies the end user's first name.

Syntax | FirstName = first name
Value firstname

The end user's first name.
Example
FirstName = "Pat"
Comments | To determine the value of FirstName programmatically, use the UserInfo.get_FirstName method.

Return to top

MiddleInitial

Specifies the end user's middle initial.

Syntax | MiddleInitial = letter
Value middleinitial

The end user's middle initial.
Example
MiddleInitial = "L."
Comments | To determine the value of MiddleInitial programmatically, use the UserInfo.get_MiddleInitial method.

Return to top

LastName

Specifies the end user's last name.

Syntax | LastName = last name
Value lastname

The end user's last name.
Example
LastName = "Coleman"
Comments | To determine the value of LastName programmatically, use the UserInfo.get_LastName method.

Return to top

FuriganaName

Specifies the end user's name, written in furigana.

Syntax FuriganaName = furigana name
Value furigana

The end user's name, written in furigana.
Example
FuriganaName = furigana name
Comments The Japanese writing system comprises two different types of characters, kana and kanji. Each kana character has a specific pronunciation.

Individual kanji characters often have more than one pronunciation, and each pronunciation has a different meaning. Kanji characters are often augmented with tiny kana characters written above or next to the kanji characters, where the kana characters indicate the correct pronunciation of the word. Kana used in this way is called furigana.

To determine the value of FuriganaName programmatically, use the UserInfo.get_FuriganaName method.

Return to top

CompanyName

Specifies the end user's company name.

Syntax | CompanyName = company name
Value companyname

The end user's company name.
Example
CompanyName = "Woodgrove Bank"
Comments | To determine the value of CompanyName programmatically, use the UserInfo.get_CompanyName method.

Return to top

Address1

Specifies the end user's primary mailing address.

Syntax | Address1 = address
Value address1

The end user's primary mailing address.
Example
Address1 = "1234 Main Street"
Comments | To determine the value of Address1 programmatically, use the UserInfo.get_Address1 method.

Return to top

Address2

Specifies the end user's secondary mailing address.

Syntax | Address2 = address
Value address2

The end user's secondary mailing address.
Example
Address2 = "P.O. Box 12345"
Comments | To determine the value of Address2 programmatically, use the UserInfo.get_Address2 method.

Return to top

City

Specifies the end user's city.

Syntax | City = city
Value city

The end user's city.
Example
City = "Woodgrove"
Comments | To determine the value of City programmatically, use the UserInfo.get_City method.

Return to top

State

Specifies the end user's state or region.

Syntax | State = state or region
Value state

The end user's state or region.
Example
State = "WA"
Comments | To determine the value of State programmatically, use the UserInfo.get_State method.

Return to top

Zip

Specifies the end user's zip or postal code.

Syntax | Zip = zip or postal code
Value zip

The end user's zip or postal code.
Example
Zip = "12345"
Comments | To determine the value of Zip programmatically, use the UserInfo.get_Zip method.

Return to top

Country

Specifies the end user's country/region. Used only for registration or activation. Use the Default Region entry in the [Options] section to change the default setting on the computer.

Syntax | Country = country
Value country

The end user's country/region.
Example
Country = "USA"
Comments | To determine the value of Country programmatically, use the UserInfo.get_Country method.

Return to top

PrimaryEmail

Specifies the end user's e-mail address or temporary Microsoft® Windows® ID.

Syntax | PrimaryEmail = e-mail address
Value primaryemail

The end user's e-mail address or temporary Windows ID.
Example
PrimaryEmail = "Pat@fabrikam.com"
Comments | To determine the value of PrimaryEmail programmatically, use the UserInfo.get_PrimaryEmail method.

Return to top

SecondaryEmail

Specifies the end user's secondary e-mail address.

Syntax | SecondaryEmail = e-mail address
Value secondaryemail

The end user's secondary e-mail address.
Example
SecondaryEmail = "PatC@fabrikam.com"
Comments | To determine the value of SecondaryEmail programmatically, use the UserInfo.get_SecondaryEmail method.

Return to top

AreaCode

Specifies the end user's area or city code.

Syntax | AreaCode = area code
Value areacode

The end user's area or city code.
Example
AreaCode = "123"
Comments | To determine the value of AreaCode programmatically, use the UserInfo.get_AreaCode method.

Return to top

PhoneNumber

Specifies the end user's telephone number.

Syntax | PhoneNumber = phone number
Value phonenumber

The end user's telephone number.
Example
PhoneNumber = "456-7890"
Comments | To determine the value of PhoneNumber programmatically, use the UserInfo.get_PhoneNumber method.

Return to top

Identity000

Specifies the end user's primary identity.

Syntax Identity000 = user name
Value identity000

The end user's primary identity.
Example
Identity000 = "Pat"
Comments You can prepopulate up to six end-user identities.

To determine the value of Identity programmatically, use the UserInfo.get_Identity method.

Return to top

Identity001

Specifies the end user's secondary identity.

Syntax Identity001 = user name
Value identity001

The end user's secondary identity.
Example
Identity001 = "Zainal"
Comments You can prepopulate up to six end-user identities.

To determine the value of Identity programmatically, use the UserInfo.get_Identity method.

Return to top

Identity002

Specifies the end user's third identity.

Syntax Identity002 = user name
Value identity002

The end user's third identity.
Example
Identity002 = "Josh"
Comments You can prepopulate up to six end-user identities.

To determine the value of Identity programmatically, use the UserInfo.get_Identity method.

Return to top

Identity003

Specifies the end user's fourth identity.

Syntax Identity003 = user name
Value identity003

The end user's fourth identity.
Example
Identity003 = "Adam"
Comments You can prepopulate up to six end-user identities.

To determine the value of Identity programmatically, use the UserInfo.get_Identity method.

Return to top

Identity004

Specifies the end user's fifth identity.

Syntax Identity004 = user name
Value identity004

The end user's fifth identity.
Example
Identity004 = "Paula"
Comments You can prepopulate up to six end-user identities.

To determine the value of Identity programmatically, use the UserInfo.get_Identity method.

Return to top

Identity005

Specifies the end user's sixth identity.

Syntax Identity005 = user name
Value identity005

The end user's sixth identity.
Example
Identity005 = "Shay"
Comments You can prepopulate up to six end-user identities.

To determine the value of Identity programmatically, use the UserInfo.get_Identity method.

Return to top


[Version] (Oobeinfo.ini)

banner

[Version]

Answer File = Oobeinfo.ini

The [Version] section contains an entry for specifying the version of the installed operating system.

Entry | Description
ProductKey | Specifies the Product Key for this particular installation of Microsoft® Windows®. Each x is either an alphabetic character or a number. You must include the quotation marks and the hyphens.

Sample

This sample demonstrates one use of the [Version] section of Oobeinfo.ini.

[Version]
ProductKey = "12345-ABCDE-67890-FGHIJ-12345"

ProductKey

Specifies the Product Key for this particular installation of Windows. Each x is either an alphabetic character or a number. You must include the quotation marks and the hyphens.

Syntax | ProductKey = "xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"
Value | "xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"
Example
ProductKey = "12345-ABCDE-67890-FGHIJ-12345"
Comments

Important

  • You must always specify a value for the ProductKey entry.
  • The Product Key that you use to activate the installation must match the number on the Certificate of Authenticity (COA) sticker that accompanies the retail product or that is physically attached to the computer case by the original equipment manufacturer (OEM).
  • Standard licensing agreements specify that you can use a Product Key to activate only one installation of Windows XP on one computer. Windows Product Activation (WPA) enforces this requirement.
  • If you preinstall Windows XP under a volume license agreement, consult your specific license agreement to determine the number of installations per Product Key.
  • When using the Unattend.txt file, this entry assigns the same Product Key to all computers on which you install Windows XP or a member of the Windows Server 2003 family.
  • When using the Unattend.txt file, enter the ProductKey in both the Unattend.txt file and the Sysprep.inf file. Sysprep deletes the ProductKey entry in the Unattend.txt file and replaces it with the entry specified in Sysprep.inf.

Return to top


Windows Welcome APIs

The Windows Welcome APIs are a collection of objects that provide methods for retrieving and storing data, and for interacting with Msoobe.exe (Windows Welcome).

  • API object
  • Directions object
  • External APIs
  • Language object
  • Register object
  • Signup object
  • Status object
  • Tapi object
  • UserInfo object


API object

The Application Programming Interface (API) object contains methods that delete or set registry values, store environment variables, and interact with CSIDLs. ("CSIDL" refers to the special folders in Microsoft® Windows® .) The API object also contains methods that store file contents or retrieve values from .ini files.

  • API.DeleteRegKey method
  • API.DeleteRegValue method
  • API.get_CSIDLDirectory method
  • API.get_INIKey method
  • API.get_RegValue method
  • API.get_SystemDirectory method
  • API.LoadFile method
  • API.RegFlushKey method
  • API.SaveFile method
  • API.SaveFileByCSIDL method
  • API.set_RegValue method

Use the window.external.API method to access the API object.


API.DeleteRegKey method

Deletes a section in the registry.

Syntax

window.external.API.DeleteRegKey (lHKey, sSectionName);
Parameters lHKey

Long. One of the predefined HKEY values:

0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA

sSectionName

String. The section in the registry to delete.
Return Values | None
Applies To | window.external.API
Example
HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.DeleteRegKey(HKEY_LOCAL_MACHINE,"SOFTWARE\\MySection");


API.DeleteRegValue method

Deletes a specific value in the registry.

Syntax

window.external.API.DeleteRegValue(lHKey, sSectionName, sKeyName);
Parameters lHKey

Long. One of the predefined HKEY values:

0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA

sSectionName

String. The section in the registry that contains the registry key.

sKeyName

String. The name of the registry key to delete.
Return Values | None
Applies To | window.external.API
Example
HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.DeleteRegValue(HKEY_LOCAL_MACHINE, "SOFTWARE\\MySection", "MyKey");


API.get_CSIDLDirectory method

Retrieves the path to the specified CSIDL directory.

Syntax

sPath = window.external.API.get_CSIDLDirectory();
Parameters | None
Return Values | String. The path to the specified CSIDL directory.
Applies To | window.external.API
Example
sPath = window.external.API.get_CSIDLDirectory();
Comments | For details on CSIDL, consult the Microsoft® Platform Software Development Kit (SDK).


API.get_INIKey method

Retrieves a value from an .ini file.

Syntax

sValue = window.external.API.get_INIKey(sINIFileName, sSectionName, sKeyName);
Parameters sINIFileName

String. The .ini file that contains the value.

sSectionName

String. The section in the .ini file that contains the value.

sKeyName

String. The entry in the .ini file that contains the value.
Return Values | String. The value of the sKeyName entry in the .ini file.
Applies To | window.external.API
Example
sValue = window.external.API.get_INIKey(MyFile.ini, SectionName, KeyName);


API.get_RegValue method

Retrieves a value from a location in the registry.

Syntax

sValue = window.external.API.get_RegValue(lHKey, sSectionName, KeyName);
Parameters lHKey

Long. One of the predefined HKEY values:

0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA

sSectionName

String. The section in the registry that contains the registry key.

sKeyName

String. The name of the registry key for which you want the value.
Return Values | String. The value from the registry.
Applies To | window.external.API
Example
HKEY_LOCAL_MACHINE = 0x80000002;
sValue = window.external.API.get_RegValue(HKEY_LOCAL_MACHINE, "SOFTWARE\\MySection", "MyKey");
Comments | Use only registry values stored as strings or DWORDs.


API.get_SystemDirectory method

Retrieves the path to the system directory, %WINDIR%\System32.

Syntax

sPath = window.external.API.get_SystemDirectory();
Parameters | None
Return Values | String. The path to the system directory, %WINDIR%\System32.
Applies To | window.external.API
Example
sPath=window.external.API.get_SystemDirectory();


API.LoadFile method

Retrieves the contents of a file.

Syntax

sContents = window.external.API.LoadFile(sPathToFile);
Parameters sPathToFile

String. Path to the file to read its contents.
Return Values | String. The contents of a file.
Applies To | window.external.API
Example
window.external.API.LoadFile(%WINDIR%\FileName.bmp);


API.RegFlushKey method

Ensures that changes made to the registry (under that section) copy to a disk. Guarantees that the registry's disk image has the most recent changes.

Syntax

window.external.API.RegFlushKey(lHKey);
Parameters lHKey

Long. One of the predefined HKEY values:

0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA
Return Values | None
Applies To | window.external.API
Example
HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.RegFlushKey(HKEY_LOCAL_MACHINE);


API.SaveFile method

Retrieves a file from a Uniform Resource Locator (URL) and saves it in the specified location.

Syntax

window.external.API.SaveFile(sURL, sPath [,sNewFileName]);
Parameters sURL

String. Required. The URL from which to retrieve the file.

sPath

String. Required. The path on the end-user computer where to save the file.

sNewFileName

String. Optional. The name under which to save this file. If you do not specify sNewFileName, the file name is the one returned by the URL.
Return Values | None
Applies To | window.external.API
Example
window.external.API.SaveFile(http://www.fabrikam.com, %WINDIR%, NewName.bmp);
Comments SaveFile uses the Win32 URLDownloadToFile application programming interface (API) in an asynchronous fashion.

Note

  • Make sure that you do not overwrite an existing file. Avoid saving sensitive user information.


API.SaveFileByCSIDL method

Retrieves a file from a Uniform Resource Locator (URL) and saves it in the specified CSIDL location.

Syntax

window.external.API.SaveFileByCSIDL(sURL, iPath [,sNewFileName]);
Parameters sURL

String. Required. The URL from which to retrieve the file.

iPath

Integer. Required. The CSIDL location on the end user's computer where to save the file.

sNewFileName

String. Optional. The name under which to save this file. If you do not specify sNewFileName, the file name is the one returned by the URL.
Return Values | None
Applies To | window.external.API
Example
window.external.API.SaveFileByCSIDL(http://www.fabrikam.com, %WINDIR%, NewName.bmp);
Comments SaveFileByCSIDL uses the Win32 URLDownloadToFile application programming interface (API) in an asynchronous fashion.

Note

  • Make sure that you do not overwrite an existing file. Avoid saving sensitive user information.

For details on CSIDL, consult the Microsoft® Platform Software Development Kit (SDK).


API.set_RegValue method

Sets a value in a location in the registry.

Syntax

window.external.API.set_RegValue(lHKey, sSectionName, sKeyName, sValue);
Parameters lHKey

Long. One of the predefined HKEY values:

0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA
sSectionName

String. The section in the registry that contains the registry key.

sKeyName

String. The name of the registry key that contains the value.

sValue

String. The value to save in the registry. (This value can also be a DWORD.)
Return Values | None
Applies To | window.external.API
Example
HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.set_RegValue(HKEY_LOCAL_MACHINE, "SOFTWARE\\MySection", "MyKey", "Hello World");
Comments Use only registry values stored as strings or DWORDs.

Note

  • Non-administrators have access to HKEY_LOCAL_MACHINE, so do not save user information in this registry section. The full-screen mode of Windows Welcome runs in system context, so it is also inappropriate to write to HKEY_CURRENT_USER.


Directions object

The Directions object stores values pertaining to tutorials, hardware checks, regional settings, registration, and Internet Service Provider (ISP) signup in Windows Welcome.

  • Directions.get_AppMode method
  • Directions.get_DoIMETutorial method
  • Directions.get_DoMouseTutorial method
  • Directions.get_DoOEMAddRegistration method
  • Directions.get_DoOEMHardwareCheck method
  • Directions.get_DoRegionalKeyboard method
  • Directions.get_ISPSignup method
  • Directions.get_OEMOfferCode method
  • Directions.get_Offline method

Use the window.external.Directions method to access the Directions object.


Directions.get_AppMode method

Determines the mode of Windows Welcome.

Syntax

iMode = window.external.Directions.get_AppMode();
Parameters | None
Return Values Integer.

0 - Full-screen mode
2 - Desktop registration mode
4 - Desktop sign-up mode
Applies To | window.external.Directions
Example
iMode = window.external.Directions.get_AppMode();


Directions.get_DoIMETutorial method

Returns the value of the IMETutorial entry in the [Options] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoIMETutorial();
Parameters | None
Return Values | Boolean. The value of the IMETutorial entry in the [Options] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
bIMETutorial = window.external.Directions.get_DoIMETutorial();


Directions.get_DoMouseTutorial method

Returns the value of the MouseTutorial entry in the [Options] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoMouseTutorial();
Parameters | None
Return Values | Boolean. The value of the MouseTutorial entry in the [Options] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
bMouseTutorial = window.external.Directions.get_DoMouseTutorial();


Directions.get_DoOEMAddRegistration method

Returns the value of the OEMAddRegPage entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoOEMAddRegistration();
Parameters | None
Return Values | String. The value of the OEMAddRegPage entry in the [OEMRegistrationPage] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
var strOEMAddRegPage = window.external.Directions.get_DoOEMAddRegistration();


Directions.get_DoOEMHardwareCheck method

Returns the value of the OEMHWTutorial entry in the [OEMHardwareTutorial] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoOEMHardwareCheck();
Parameters | None
Return Values | Boolean. The value of the OEMHWTutorial entry in the [OEMHardwareTutorial] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
bOEMHWCheck = window.external.Directions.get_DoOEMHardwareCheck();


Directions.get_DoRegionalKeyboard method

Returns the value of the INTL_Settings entry in the [Options] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoRegionalKeyboard();
Parameters | None
Return Values | String. The value of the INTL_Settings entry in the [Options] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
var strIntlSettings = window.external.Directions.get_DoRegionalKeyboard();


Directions.get_ISPSignup method

Returns the value of the ISPSignup entry in the [Signup] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_ISPSignup();
Parameters | None
Return Values | String. The value of the ISPSignup entry in the [Signup] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
var strISPSignup = window.external.Directions.get_ISPSignup();


Directions.get_OEMOfferCode method

Returns the value of the OEMOfferCode entry in the [Signup] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_OEMOfferCode();
Parameters | None
Return Values | String. The value of the OEMOfferCode entry in the [Signup] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
var strOfferCode = window.external.Directions.get_OEMOfferCode();


Directions.get_Offline method

Returns the value of the Offline entry in the [StartupOptions] section of Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_Offline();
Parameters | None
Return Values | Boolean. The value of the Offline entry in the [StartupOptions] section of Oobeinfo.ini.
Applies To | window.external.Directions
Example
bOffline = window.external.Directions.get_Offline();


External APIs

The methods listed, though not a part of the built-in Windows Welcome application programming interfaces (APIs), are useful for interacting with Windows Welcome.

The following methods provide access to the object model of Msoobe.exe (Windows Welcome):

  • API method
  • DeleteRemind method
  • Directions method
  • Language method
  • Register method
  • Signup method
  • Status method
  • StopRemind method
  • Tapi method
  • UserInfo method

The remaining external APIs are a collection of useful functions.

  • CheckDialReady method
  • CheckOnlineStatus method
  • CheckPhoneBook method
  • CheckStayConnected method
  • Connect method
  • Dial method
  • DialEx method
  • ExecScriptFn method
  • Finish method
  • get_ConnectionType method
  • get_DialNumber method
  • get_RetailOobe method
  • get_StatusIndex method
  • GetFile method
  • GetLocalUserCount method
  • GetReconnectURL method
  • GetSupportPhoneNum method
  • Hangup method
  • IsICSAvailable method
  • IsProfessionalSKU method
  • PowerDown method
  • PreConfigINS method
  • ProcessINS method
  • ReConnect method
  • ReDial method
  • ReDialEx method
  • RunManualICW method
  • set_DialNumber method


API method

Retrieves a reference to the API object.

Syntax

window.external.API;
Parameters | None
Return Values | Object. A reference to the API object.
Applies To | window.external
Example
var Obj = window.external.API;
var sContents =  Obj.LoadFile("mytext.txt");
alert(sContents);


External.CheckDialReady method

Checks the end user's computer for an installed remote access server (RAS), Transmission Control Protocol/Internet Protocol (TCP/IP), and modem.

Syntax

iDialStatus = window.external.CheckDialReady();
Parameters | None
Return Values Integer
Value | Description
0 | The computer is ready to dial. RAS, TCP/IP, and modem are all installed.
1 | The Welcome process is the dynamic-link library (DLL) required to make the detection.
2 | Error. Unknown cause.
3 | A modem is not installed on the computer.
4 | TCP/IP, RAS, or both are not installed on the computer.
Applies To | window.external
Example
iDialStatus = window.external.CheckDialReady();


External.CheckOnlineStatus method

Determines whether Windows Welcome is connected to the Internet.

Return Values

Syntax

window.external.CheckOnlineStatus;
Parameters | None
Return Values Boolean
Value | Description
0 | Not connected to the Internet.
1 | Connected to the Internet.
Applies To | window.external
Example
bOnlineStatus = window.external.CheckOnlineStatus();
Comments | See the CheckStayConnected method for complete usage.


External.CheckPhoneBook method

Checks an .isp file to ensure that the end user's country or region matches the one in the telephone book.

Syntax

bValid = window.external.CheckPhoneBook(sIspFile);
Parameters sISPFile

String. The location and file name of the .isp file.
Return Values | Boolean. Returns the value TRUE if the end user's country or region matches the one in the telephone book.
Applies To | window.external
Example
bPhoneBookMatch = window.external.CheckPhoneBook();
Comments The .isp file must contain a telephone book entry:
[ISP INFO]
PhoneBookFile = myphonebook.obe


External.CheckStayConnected method

Specifies whether to reach a new server page through an existing Internet connection.

Syntax

window.external.CheckStayConnected(sISPFile);
Parameters sISPFile

String. The location and file name of the .isp file.
Return Values Boolean
Value | Description
0 | Redials before navigating to a new page.
1 | Navigates to a new page using the existing connection.
Applies To window.external
Example
bStayConnected = window.external.CheckStayConnected();


External.Connect method

Connects through an existing connection without dialing by using the Signup Uniform Resource Locator (URL) specified in the .isp file.

Syntax

window.external.Connect(sISPFile);
Parameters sISPFile

String. The location and file name of the .isp file.
Return Values | Boolean. Returns the value TRUE if the connection request is successful.
Applies To | window.external
Example
bConnect = window.external.Connect("c:\windows\MyFile.isp");
Comments After a successful connection, Windows Welcome navigates to the URL specified in the .isp file. For example:
[URL]
Signup = http://www.fabrikam.com/


External.DeleteRemind method

Causes Windows Welcome to delete any remaining registration or Internet Service Provider (ISP) sign-up reminders.

Syntax

window.external.DeleteRemind(lType);
Parameters lType

Long

Value | Description
0 | Registration reminder
1 | ISP sign-up reminder
Return Values | Boolean. Returns the value TRUE if Windows Welcome deletes the reminders successfully.
Applies To | window.external
Example
bDeleted = window.external.DeleteRemind();
Comments | Use DeleteRemind only in desktop registration or sign-up mode.


External.Dial method

Dials an .isp file.

Syntax

window.external.Dial(sISPFile);
Parameters sISPFile

String. The location and file name of the .isp file.
Return Values | Boolean. Returns the value TRUE if Windows Welcome successfully connects to the phone number specified in the .isp file.
Applies To | window.external
Example
bDial = window.external.Dial("c:\windows\MyFile.isp");
Comments After a successful connection, Windows Welcome navigates to the Uniform Resource Locator (URL) specified in the .isp file, as in the following example:
[URL]
Signup = http://www.microsoft.com/

See the DialEx and ReDial methods.


External.DialEx method

Specifies the connection type for connecting to the Internet service provider (ISP).

Syntax

window.external.DialEx(ulConnectionType, sISPFile);
Parameters ulConnectionType

Integer. Index identifying the type of connection.
Value | Description
1 | CONNECTED_REFERRAL
2 | CONNECTED_ISP_SIGNUP
3 | CONNECTED_ISP_MIGRATE
4 | CONNECTED_REGISTRATION

sISPFile

String. The location and file name of the .isp file.
Return Values | Boolean. Returns the value TRUE if Windows Welcome successfully completes the connection.
Applies To | window.external
Example
var CONNECTED_REFERRAL =1
window.external.DialEx(CONNECTED_REFERRAL, "phone.isp");
Comments | See the Dial method.


External.Directions method

Retrieves a reference to the Directions object.

Syntax

window.external.Directions;
Parameters | None
Return Values | Object. A reference to the Directions object.
Applies To | window.external
Example
var Obj = window.external.Directions;
var iSignup =  Obj.get_ISPSignup;


External.ExecScriptFn method

Executes a script function in MSobshel.htm.

Syntax

window.external.ExecScriptFn(sFunction);
Parameters sFunction

String. The name of the function to execute.
Return Values | Variant. The return value of the executed function.
Applies To | window.external
Example
var vRet = window.external.ExecScriptFn("GoNext();");
Comments | The Windows Welcome navigation architecture, written in JScript, resides in the %WINDIR%\System32\Oobe\Msobshel.htm file.


External.Finish method

Causes Windows Welcome to save its collected data in the correct permanent storage locations, and to time-stamp User.exe.

Syntax

window.external.Finish();
Parameters | None
Return Values Integer
Value | Description
0 | Finished successfully.
1 | Finished successfully, but requires a reboot.
2 | The end user has not accepted the Windows End-User License Agreement (EULA).
4 | The end user has not entered a valid Windows Product Key.
8 | An error occurred while attempting to save the end user's information in the registry and/or time stamp User.exe.
Applies To | window.external
Example
iConnectionType = window.external.Finish();
Comments | Call the Finish method only when the end user has completed the final checkpoint in Windows Welcome.


External.get_ConnectionType method

Determines if the computer is an Internet Connection Sharing (ICS) client.

Syntax

iConnectionType = window.external.get_ConnectionType();
Parameters | None
Return Values | Integer. Returns 1 if the computer is an ICS client, and 0 if it is not.
Applies To | window.external
Example
iConnectionType = window.external.get_ConnectionType();


External.get_DialNumber method

Returns the dialed telephone number.

Syntax

sNumber = window.external.get_DialNumber();
Parameters | None
Return Values | String. The dialed telephone number.
Applies To | window.external
Example
var strNumber = window.external.get_DialNumber();


External.get_RetailOobe method

Detects whether Microsoft® Windows® uses the retail version of Windows Welcome.

Syntax

window.external.get_RetailOobe();
Parameters | None
Return Values | Boolean. Returns the value TRUE if Windows uses the retail version of Windows Welcome. Returns the value FALSE if Windows uses the OEM version of Windows Welcome.
Applies To | window.external
Example
bType = window.external.get_RetailOobe();


External.get_StatusIndex method

Advances the status pane to the next available item.

Syntax

iCurrentItem = window.external.get_StatusIndex();
Parameters | None
Return Values | Integer. The index of the selected checkpoint in the status pane.
Applies To | window.external
Example
iCurrentItem = window.external.get_StatusIndex();


External.GetFile method

Retrieves a file from a Uniform Resource Locator (URL) and saves the file to the specified location.

Syntax

bSuccessful = window.external.GetFile(sUrl, sFileName);
Parameters sUrl

String. The URL from which to retrieve the file.

sFileName

String. The name under which to save the retrieved file.
Return Values | Boolean. Returns the value TRUE if it successfully retrieved and saved the file to disk.
Applies To | window.external
Example
bFileSaved = window.external.GetFile("http://www.fabrikam.com", "MyFile.bmp");


External.GetLocalUserCount method

Retrieves the number of available user accounts.

Syntax

window.external.GetLocalUserCount();
Parameters | None
Return Values | Integer. The number of available user accounts, not including accounts preconfigured by Microsoft® Windows® XP. Examples of preconfigured accounts are administrator, guest, and the help assistant.
Applies To | window.external
Example
iUsers = window.external.GetLocalUserCount();


External.GetReconnectURL method

Returns the reconnect Uniform Resource Locator (URL) that Windows Welcome tried to dial (specified in the last .isp file).

Syntax

sURL = window.external.GetReconnectURL();
Parameters | None
Return Values | String. The URL to use when reconnecting to the server.
Applies To | window.external
Example
var strURL = window.external.GetReconnectURL();
Comments The URL comes from the query string specified in the Reconnect entry in the [URL] section of an .isp file. For example:
[URL]
Reconnect = http://www.microsoft.com/default.asp?


External.GetSupportPhoneNum method

Returns the value of the SupportPhoneNumber entry from the [Options] section of Oobeinfo.ini.

Syntax

window.external.GetSupportPhoneNum;
Parameters | None
Return Values | String. The telephone number.
Applies To | window.external
Example
var strPhoneNumber = window.external.GetSupportPhoneNum();


External.Hangup method

Terminates the active dial-up connection if present.

Syntax

window.external.Hangup();
Parameters | None
Return Values | None
Applies To | window.external
Example
window.external.Hangup();


External.IsICSAvailable method

Determines if there is a shared Internet connection on the home network.

Syntax

window.external.IsICSAvailable;
Parameters | None
Return Values Boolean
Value | Description
0 | No shared Internet connection exists on the home network.
1 | Shared connection exists on the home network.
Applies To | window.external
Example
bICSExists = window.external.IsICSAvailable();


External.IsProfessionalSKU method

Determines whether the current operating system is the Home Edition or the Professional version of Microsoft® Windows® XP.

Syntax

window.external.IsProfessionalSKU();
Parameters | None
Return Values Boolean
Value | Description
0 | This operating system is the Home Edition.
1 | This operating system is the Professional version.
Applies To | window.external
Example
bSKUType = window.external.IsProfessionalSKU();


External.Language method

Retrieves a reference to the Language object.

Syntax

window.external.Language;
Parameters | None
Return Values | Object. A reference to the Language object.
Applies To | window.external
Example
var Obj = window.external.Language;
Obj.set_RegionIndex = 1;


External.PowerDown method

Shuts down or restarts the end user's computer.

Syntax

window.external.PowerDown(bReboot);
Parameters bReboot

Boolean. If the return value is TRUE, restart the computer. If the return value is FALSE, shut down the computer.
Return Values | None
Applies To | window.external
Example
window.external.PowerDown(0);


External.PreConfigINS method

Processes the Ispcnfg.ins file on the end user's computer if present.

Syntax

bSuccessful = window.external.PreConfigINS();
Parameters | None
Return Values | Boolean. Returns the value TRUE if it finds and successfully processes the Ispcnfg.ins file.
Applies To | window.external
Example
bSuccessful = window.external.PreConfigINS();
Comments | Ispcnfg.ins must be in the %WINDIR%\System32\Oobe directory.


External.ProcessINS method

Processes the specified .ins file.

Syntax

bSuccessful = window.external.ProcessINS(sINSPath);
Parameters sINSPath

String. Path to the .ins file to process. If the path is a Uniform Resurce Locator (URL), Windows Welcome retrieves the file from the URL and attempts to process it.
Return Values | Boolean. Returns the value TRUE if it finds and successfully processes the .ins file.
Applies To | window.external
Example
bSuccessful = window.external.ProcessINS();


External.ReConnect method

Reconnects through an existing connection without dialing by using the Reconnect Uniform Resource Locator (URL) specified in the .isp file.

Syntax

window.external.ReConnect(sISPFile);
Parameters sISPFile

String. The location and file name of the .isp file.
Return Values | Boolean. Returns the value TRUE if the connection request processes.
Applies To | window.external
Example
bConnected = window.external.ReConnect("c:\windows\MyFile.isp");
Comments After a successful connection, Windows Welcome navigates to the URL specified in the .isp file, for example:
[URL]
Reconnect = http://www.microsoft.com/


External.ReDial method

Redials the telephone number specified in an .isp file.

Syntax

window.external.ReDial(sISPFile);
Parameters sISPFile

String. The location and file name of the .isp file.
Return Values | Boolean. Returns the value TRUE if Windows Welcome successfully connects to the telephone number specified in the .isp file.
Applies To | window.external
Example
bConnected = window.external.ReDial("c:\windows\MyFile.isp");
Comments This application programming interface (API) differs from Dial because its Uniform Resource Locator (URL) comes from the Reconnect entry in the [URL] section of an .isp file, for example:
[URL]
Reconnect = http://www.microsoft.com/


External.ReDialEx method

Specifies the connection type for reattempting to connect to the Internet service provider (ISP).

Syntax

window.external.ReDialEx(ulConnectionType, sISPFile);
Parameters ulConnectionType

Integer. Index identifying the type of connection.
Value | Description
1 | CONNECTED_REFERRAL
2 | CONNECTED_ISP_SIGNUP
3 | CONNECTED_ISP_MIGRATE
4 | CONNECTED_REGISTRATION

sISPFile

String. The location and file name of the .isp file.
Return Values | Boolean. Returns the value TRUE if Windows Welcome successfully completes the connection.
Applies To | window.external
Example
var CONNECTED_REFERRAL = 1
window.external.ReDialEx(CONNECTED_REFERRAL, "phone.isp");
Comments | See the ReDial method.


External.Register method

Retrieves a reference to the Register object.

Syntax

window.external.Register;
Parameters | None
Return Values | Object. A reference to the Register object.
Applies To | window.external
Example
var Obj = window.external.Register;
var bDataPosted = Obj.get_PostToOEM;


External.RunManualICW method

Starts the Internet Connection Wizard (ICW) and closes Windows Welcome.

Syntax

window.external.RunManualICW();
Parameters | None
Return Values | None
Applies To | window.external
Example
window.external.RunManualICW;
Comments | Use RunManualICW only in reminder pages for product registration or the Internet Service Provider (ISP) sign-up offer.


External.set_DialNumber method

Sets the telephone number to redial after a dialing error.

Syntax

window.external.set_DialNumber(sNumber);
Parameters sNumber

String. The telephone number to redial after a dialing error.
Return Values | None
Applies To | window.external
Example
window.external.set_DialNumber(1234567);
Comments | Call this method only after a dialing error and before another attempt to dial the Internet service provider (ISP).


External.Signup method

Retrieves a reference to the Signup object.

Syntax

window.external.Signup;
Parameters | None
Return Values | Object. A reference to the Signup object.
Applies To | window.external
Example
var Obj = window.external.Signup;
var sLocale =  Obj.get_Locale;


External.Status method

Retrieves a reference to the Status object.

Syntax

window.external.Status;
Parameters | None
Return Values | Object. A reference to the Status object.
Applies To | window.external
Example
var Obj = window.external.Status;
var bPIDComplete =  Obj.get_PIDCompleted;


External.StopRemind method

Prevents Windows Welcome from creating Internet service provider (ISP) sign-up or registration reminders.

Syntax

window.external.StopRemind(lType);
Parameters lType

Long

Value | Description
0 | Registration reminder
1 | ISP sign-up reminder
Return Values | None
Applies To | window.external
Example
window.external.StopRemind(1);
Comments | Use StopRemind only in full-screen mode.


External.Tapi method

Retrieves a reference to the Tapi object.

Syntax

window.external.Tapi;
Parameters | None
Return Values | Object. A reference to the Tapi object.
Applies To | window.external
Example
var Obj = window.external.Tapi;
Obj.set_AreaCode = "555";


External.UserInfo method

Retrieves a reference to the UserInfo object.

Syntax

window.external.UserInfo;
Parameters | None
Return Values | Object. A reference to the UserInfo object.
Applies To | window.external
Example
var Obj = window.external.UserInfo;
Obj.set_FirstName = "John";


Language object

The Language object stores language, regional, and keyboard settings.

  • Language.get_KeyboardLayoutIndex method
  • Language.get_KeyboardLayoutName method
  • Language.get_NumOfKeyboardLayouts method
  • Language.get_NumOfRegions method
  • Language.get_RebootState method
  • Language.get_RegionIndex method
  • Language.get_RegionName method
  • Language.SaveSettings method

Use the window.external.Language method to access the Language object.


Language.get_KeyboardLayoutIndex method

Returns the index of keyboard layouts for the computer.

Syntax

iKeyboardLayoutIndex = window.external.Language.get_KeyboardLayoutIndex();
Parameters | None
Return Values | Integer. The keyboard layout index of the computer.
Applies To | window.external.Language
Example
iKeyIndex = window.external.Language.get_KeyboardLayoutIndex();


Language.get_KeyboardLayoutName method

Returns the friendly name of the keyboard layout.

Syntax

sKeyboardLayout = window.external.Language.get_KeyboardLayoutName(iKeyboardLayoutIndex);
Parameters iKeyboardLayoutIndex

Integer. The corresponding index of the keyboard layout.
Return Values | String. The friendly name of the keyboard layout.
Applies To | window.external.Language
Example
var strKeyName = window.external.Language.get_KeyboardLayoutName();


Language.get_NumOfKeyboardLayouts method

Returns the total number of available keyboard layouts.

Syntax

iNumberOfKeyboardLayouts = window.external.Language.get_NumOfKeyboardLayouts();
Parameters | None
Return Values | Integer. The total number of available keyboard layouts.
Applies To | window.external.Language
Example
iKLayouts = window.external.Language.get_NumOfKeyboardLayouts();


Language.get_NumOfRegions method

Returns the total number of regional options available to the end user.

Syntax

iNumberOfRegions = window.external.Language.get_NumOfRegions();
Parameters | None
Return Values | Integer. The total number of regional options available to the end user.
Applies To | window.external.Language
Example
iRegions = window.external.Language.get_NumOfRegions();


Language.get_RebootState method

Specifies whether to restart after language changes.

Syntax

iRebootState = window.external.Language.get_RebootState();
Parameters | None
Return Values Integer. The type of reboot needed if applicable.
Value | Description
0 | No reboot needed.
1 | Reboot needed now (after the region and keyboard layout are set).
2 | Reboot needed after the end user completes Windows Welcome.

Use the value of get_RebootState to determine if you need to call windows.external.PowerDown.
Applies To | window.external.Language
Example
iRState = window.external.Language.get_RebootState();


Language.get_RegionIndex method

Returns the index of the computer's regional setting.

Syntax

iRegionIndex = window.external.Language.get_RegionIndex();
Parameters | None
Return Values | Integer. The index of the computer's regional setting.
Applies To | window.external.Language
Example
iRIndex = window.external.Language.get_RegionIndex();


Language.get_RegionName method

Returns the friendly name of the regional index.

Syntax

sRegionName = window.external.Language.get_RegionName(iRegionIndex);
Parameters iRegionIndex

Integer. Index of the region.
Return Values | String. The friendly name of the regional index.
Applies To | window.external.Language
Example
var strRegion = window.external.Language.get_RegionName();


Language.SaveSettings method

Saves the current regional and keyboard layout indexes.

Syntax

window.external.Language.SaveSettings();
Parameters | None
Return Values | None
Applies To | window.external.Language
Example
window.external.Language.SaveSettings();
Comments | After calling SaveSettings, call window.external.get_RebootState to determine if the computer must restart.


Register object

Stores values pertaining to a method of collecting registration data during Windows Welcome.

  • Register.get_OEMAddRegPage method
  • Register.get_PostToOEM method
  • Register.get_RegPostURL method

Use the window.external.Register method to access the Register object.


Register.get_PostToOEM method

banner

Register.get_OEMAddRegPage method

Returns the value of the OEMAddRegPage entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Syntax

iValue = window.external.Register.get_OEMAddRegPage();
Parameters | None
Return Values | Integer. The value of the OEMAddRegPage entry in the [OEMRegistrationPage] section of Oobeinfo.ini.
Applies To | window.external.Register
Example
iOEMAddRegPage = window.external.Register.get_OEMAddRegPage();


Register.get_PostToOEM method

Returns the value of the PostToOEM entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Syntax

iValue = window.external.Register.get_PostToOEM();
Parameters | None
Return Values | Integer. The value of the PostToOEM entry in the [OEMRegistrationPage] section of Oobeinfo.ini.
Applies To | window.external.Register
Example
iPostToOEM = window.external.Register.get_PostToOEM();


Register.get_RegPostURL method

Returns the value of the RegPostURL entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Syntax

sUrl = window.external.Register.get_RegPostURL();
Parameters | None
Return Values | String. The value of the RegPostURL entry in the [OEMRegistrationPage] section of Oobeinfo.ini.
Applies To | window.external.Register
Example
var strRegPostURL = window.external.Register.get_RegPostURL();


Signup object

Identifies the manufacturer of the computer when the end user establishes Internet access using one of the preconfigured Internet Service Provider (ISP) sign-up offers.

  • Signup.get_OEMName method

Use the window.external.Signup method to access the Signup object.


Signup.get_OEMName method

Returns the value of the OEMName entry in the [Branding] section of Oobeinfo.ini.

Syntax

sIDLocale = window.external.Signup.get_OEMName();
Parameters | None
Return Values | String. The value of the OEMName entry in the [Branding] section of Oobeinfo.ini.
Applies To | window.external.Signup
Example
var strOEM = window.external.Signup.get_OEMName();


Status object

Stores values pertaining to the state of completion of Windows Welcome steps.

  • Status.get_ISPSignupCompleted method
  • Status.get_LanguageCompleted method
  • Status.get_MouseTutorCompleted method
  • Status.get_OEMInfoCompleted method
  • Status.get_PIDCompleted method
  • Status.get_Status method
  • Status.get_TAPICompleted method
  • Status.get_TimeZoneCompleted method
  • Status.get_UserInfoPosted method
  • Status.get_UserInfoStamped method
  • Status.set_Status method

Use the window.external.Status method to access the Status object.


Status.get_ISPSignupCompleted method

Determines whether the end user has completed the Internet service provider (ISP) sign-up checkpoint in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_ISPSignupCompleted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if the end user has completed the ISP sign-up checkpoint in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_ISPSignupCompleted();


Status.get_LanguageCompleted method

Determines whether the end user has completed the Language checkpoint in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_LanguageCompleted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if the end user has completed the Language checkpoint in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_LanguageCompleted();


Status.get_MouseTutorCompleted method

Determines whether the end user has completed the mouse tutorial in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_MouseTutorCompleted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if the end user has completed the mouse tutorial in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_MouseTutorCompleted();


Status.get_OEMInfoCompleted method

Determines whether the end user has completed the Original Equipment Manufacturer (OEM) registration checkpoint in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_OEMInfoCompleted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if the end user has completed the OEM registration checkpoint in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_OEMInfoCompleted();


Status.get_PIDCompleted method

Determines whether the end user has completed the product key checkpoint in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_PIDCompleted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if the end user has completed the product key checkpoint in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_PIDCompleted();


Status.get_Status method

Determines whether the end user has completed a custom event in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_Status(sCustomEvent);
Parameters sCustomEvent

String. The name of the custom event to check.
Return Values | Boolean. Returns the value TRUE if the end user has completed a custom event in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_Status("MyUSBIntroduction");


Status.get_TAPICompleted method

Determines whether the end user has completed the Telephony API (TAPI) checkpoint in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_TAPICompleted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if the end user has completed the TAPI checkpoint in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_TAPICompleted();
Comments | See the TapiConfigured method.


Status.get_TimeZoneCompleted method

Determines whether the end user has completed the setting of the system clock and time zone checkpoint in Windows Welcome.

Syntax

bCompleted = window.external.Status.get_TimeZoneCompleted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if the end user has completed the setting of the system clock and time zone checkpoint in Windows Welcome.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_TimeZoneCompleted();


Status.get_UserInfoPosted method

Determines whether Windows Welcome has posted the end user registration information.

Syntax

bCompleted = window.external.Status.get_UserInfoPosted();
Parameters | None
Return Values | Boolean. Returns the value TRUE if Windows Welcome has posted the end user's registration information.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_UserInfoPosted();


Status.get_UserInfoStamped method

Determines whether Windows Welcome has stamped the end user registration information into User.exe.

Syntax

bCompleted = window.external.Status.get_UserInfoStamped();
Parameters | None
Return Values | Boolean. Returns the value TRUE if Windows Welcome has stamped the end user's registration information into User.exe.
Applies To | window.external.Status
Example
bCompleted = window.external.Status.get_UserInfoStamped();


Status.set_Status method

Determines whether the end user has completed a custom event in Windows Welcome, and sets that custom event.

Syntax

window.external.Status.set_Status(sCustomEvent, bCompleted);
Parameters sCustomEvent

String. The name of the custom event to set.

bCompleted

Boolean. Returns the value TRUE if the end user has completed a custom event in Windows Welcome.
Return Values | None
Applies To | window.external.Status
Example
window.external.Status.set_Status("MyUSBIntroduction", true);


Tapi object

The Tapi object stores telephony settings and states.

  • Tapi.get_AllCountryName method
  • Tapi.get_AreaCode method
  • Tapi.get_CountryID method
  • Tapi.get_CountryIndex method
  • Tapi.get_CountryNameForIndex method
  • Tapi.get_DialOut method
  • Tapi.get_NumOfCountry method
  • Tapi.get_PhoneSystem method
  • Tapi.IsAreaCodeRequired method
  • Tapi.IsTAPIConfigured method
  • Tapi.set_AreaCode method
  • Tapi.set_CountryIndex method
  • Tapi.set_DialOut method
  • Tapi.set_PhoneSystem method

Use the window.external.Tapi method to access the Tapi object.


Tapi.get_AllCountryName method

Returns a string buffer containing all the Telephony API (TAPI) country/region names formatted for insertion into a Hypertext Markup Language (HTML) <SELECT> element.

Syntax

sBuffer = window.external.Tapi.get_AllCountryName();
Parameters | None
Return Values String. A string buffer containing all the TAPI country/region names formatted as:
<OPTION>[name of country/region]</OPTION><OPTION>...
Applies To | window.external.Tapi
Example
var strCountry = window.external.Tapi.get_AllCountryName();


Tapi.get_AreaCode method

Returns the area code that the Tapi object uses when dialing.

Syntax

sAreaCode = window.external.Tapi.get_AreaCode();
Parameters | None
Return Values | String. The area code.
Applies To | window.external.Tapi
Example
var strAreaCode = window.external.Tapi.get_AreaCode();


Tapi.get_CountryID method

Returns the Telephony API (TAPI) ID of a specific country or region used by the Tapi object.

Syntax

iCountryID = window.external.Tapi.get_CountryID();
Parameters | None
Return Values | Integer. The TAPI ID number of the country or region used by the Tapi object.
Applies To | window.external.Tapi
Example
iCountryID = window.external.Tapi.get_CountryID();


Tapi.get_CountryIndex method

Returns the index of the country or region used by the Tapi object.

Syntax

iCountryIndex = window.external.Tapi.get_CountryIndex();
Parameters | None
Return Values | Integer. The index number of the country or region used by the Tapi object.
Applies To | window.external.Tapi
Example
iCountryIndex = window.external.Tapi.get_CountryIndex();


Tapi.get_CountryNameForIndex method

Returns the friendly name of a Telephony API (TAPI) country/region index.

Syntax

sCountryName = window.external.Tapi.get_CountryNameForIndex(iCountryIndex);
Parameters iCountryIndex

Integer. The index number of the TAPI country or region.
Return Values | String. The friendly name of a TAPI country/region index value.
Applies To | window.external.Tapi
Example
var strCountryName = window.external.Tapi.get_CountryNameForIndex(030);


Tapi.get_DialOut method

Returns the number, if any, that the Tapi object dials to reach an outside line.

Syntax

sNumberToDial = window.external.Tapi.get_DialOut();
Parameters | None
Return Values | String. The number that the Tapi object dials to reach an outside line.
Applies To | window.external.Tapi
Example
var strNumberToDial = window.external.Tapi.get_DialOut();


Tapi.get_NumOfCountry method

Returns the total number of countries or regions available to the Tapi object.

Syntax

iNumberOfCountries = window.external.Tapi.get_NumOfCountry();
Parameters | None
Return Values | Integer. The total number of countries or regions available to the Tapi object.
Applies To | window.external.Tapi
Example
iNumberOfCountries = window.external.Tapi.get_NumOfCountry();


Tapi.get_PhoneSystem method

Returns the type of telephone system that the Tapi object uses when dialing a telephone modem.

Syntax

iPhoneSystemType = window.external.Tapi.get_PhoneSystem();
Parameters | None
Return Values Integer. The number value for the type of telephone system that the Tapi object uses when dialing a telephone modem.
Value | Description
0 | Pulse dialing
1 | Touch-tone dialing
Applies To | window.external.Tapi
Example
iPhoneSystemType = window.external.Tapi.get_PhoneSystem();


Tapi.IsAreaCodeRequired method

Specifies whether to require an area code for a particular country or region, identified by Tapi.get_CountryIndex.

Syntax

bIsRequired = window.external.Tapi.IsAreaCodeRequired(iCountryIndex);
Parameters iCountryIndex

Integer. The Telephony API (TAPI) country/region index to check.

Return Values | Boolean. Returns the value TRUE if an area code is required for a particular country or region.
Applies To | window.external.Tapi
Example
bIsRequired = window.external.Tapi.IsAreaCodeRequired(030);


Tapi.IsTAPIConfigured method

Specifies whether the Tapi object is configured correctly.

Syntax

bTapiConfigured = window.external.Tapi.IsTAPIConfigured();
Parameters | None
Return Values | Boolean. Returns the value TRUE if you configured the Tapi object correctly. Returns the value FALSE if you must configure the Tapi object before dialing the modem.
Applies To | window.external.Tapi
Example
bTapiConfigured = window.external.Tapi.IsTAPIConfigured();
Comments | See also TapiConfigured.


Tapi.set_AreaCode method

Sets the area code that the Tapi object uses when dialing.

Syntax

window.external.Tapi.set_AreaCode(sAreaCode);
Parameters sAreaCode

String. The area code that the Tapi object uses when dialing.
Return Values | None
Applies To | window.external.Tapi
Example
window.external.Tapi.set_AreaCode("123");


Tapi.set_CountryIndex method

Sets the index of the country or region that the Tapi object uses.

Syntax

window.external.Tapi.set_CountryIndex(iCountryIndex);
Parameters iCountryIndex

Integer. The index of the country or region that the Tapi object uses.
Return Values | None
Applies To | window.external.Tapi
Example
window.external.Tapi.set_CountryIndex(030);


Tapi.set_DialOut method

Sets the number that the Tapi object dials to reach an outside line.

Syntax

window.external.Tapi.set_DialOut(sNumber);
Parameters sNumber

String. The number that the Tapi object dials to reach an outside line.
Return Values | None
Applies To | window.external.Tapi
Example
window.external.Tapi.set_DialOut("9");


Tapi.set_PhoneSystem method

Determines the type of telephone system that the Tapi object uses when dialing a telephone modem.

Syntax

window.external.Tapi.set_PhoneSystem(iPhoneSystemType);
Parameters iPhoneSystemType

Integer. The type of telephone system that the Tapi object uses when dialing a telephone modem.
Value | Description
0 | Pulse dialing
1 | Touch-tone dialing
Return Values | None
Applies To | window.external.Tapi
Example
window.external.Tapi.set_PhoneSystem(1);


UserInfo object

The UserInfo object stores specific information about the end user that is transmitted during the registration process. In addition, the UserInfo object stores information that can be used to configure the user accounts.

  • UserInfo.get_Address1 method
  • UserInfo.get_Address2 method
  • UserInfo.get_AreaCode method
  • UserInfo.get_City method
  • UserInfo.get_CompanyName method
  • UserInfo.get_Country method
  • UserInfo.get_FirstName method
  • UserInfo.get_FuriganaName method
  • UserInfo.get_IdentitiesMax method
  • UserInfo.get_Identity method
  • UserInfo.get_LastName method
  • UserInfo.get_MiddleInitial method
  • UserInfo.get_PhoneNumber method
  • UserInfo.get_PrimaryEmail method
  • UserInfo.get_SecondaryEmail method
  • UserInfo.get_State method
  • UserInfo.get_Zip method
  • UserInfo.set_Address1 method
  • UserInfo.set_Address2 method
  • UserInfo.set_AreaCode method
  • UserInfo.set_City method
  • UserInfo.set_CompanyName method
  • UserInfo.set_Country method
  • UserInfo.set_FirstName method
  • UserInfo.set_FuriganaName method
  • UserInfo.set_Identity method
  • UserInfo.set_LastName method
  • UserInfo.set_MiddleInitial method
  • UserInfo.set_PhoneNumber method
  • UserInfo.set_PrimaryEmail method
  • UserInfo.set_SecondaryEmail method
  • UserInfo.set_State method
  • UserInfo.set_Zip method

Use the window.external.UserInfo method to access the UserInfo object.


UserInfo.get_Address1 method

Returns the first line of the end user's address that is stored in the UserInfo object.

Syntax

sAddress1 = window.external.UserInfo.get_Address1();
Parameters | None
Return Values | String. The value of the first line of the end user's address that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strAddress1 = window.external.UserInfo.get_Address1();


UserInfo.get_Address2 method

Returns the second line of the end user's address that is stored in the UserInfo object.

Syntax

sAddress2 = window.external.UserInfo.get_Address2();
Parameters | None
Return Values | String. The value of the second line of the end user's address that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strAddress2 = window.external.UserInfo.get_Address2();


UserInfo.get_AreaCode method

Returns the end user's telephone area code that is stored in the UserInfo object.

Syntax

sAreaCode = window.external.UserInfo.get_AreaCode();
Parameters | None
Return Values | String. The value of the telephone area code that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strAreaCode = window.external.UserInfo.get_AreaCode();


UserInfo.get_City method

Returns the name of the end user's city that is stored in the UserInfo object.

Syntax

sCity = window.external.UserInfo.get_City();
Parameters | None
Return Values | String. The name of the end user's city that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strCity = window.external.UserInfo.get_City();


UserInfo.get_CompanyName method

Returns the end user's company name that is stored in the UserInfo object.

Syntax

sCompanyName = window.external.UserInfo.get_CompanyName();
Parameters | None
Return Values | String. The end user's company name that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strCompanyName = window.external.UserInfo.get_CompanyName();


UserInfo.get_Country method

Returns the end user's country or region that is stored in the UserInfo object.

Syntax

sCountry = window.external.UserInfo.get_Country();
Parameters | None
Return Values | String. The end user's country or region that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strCountry = window.external.UserInfo.get_Country();


UserInfo.get_FirstName method

Returns the end user's first name that is stored in the UserInfo object.

Syntax

sFirstName = window.external.UserInfo.get_FirstName();
Parameters | None
Return Values | String. The value of the end user's first name stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strFirstName = window.external.UserInfo.get_FirstName();


UserInfo.get_FuriganaName method

Returns the furigana version of the end user's name that is stored in the UserInfo object.

The Japanese writing system comprises two different types of characters, kana and kanji. Each kana character has a specific pronunciation.

Individual kanji characters often have more than one pronunciation, and each pronunciation has a different meaning. Kanji characters are often augmented with tiny kana characters written above or next to the kanji characters to indicate the correct pronunciation of the word. Kana used in this way is called furigana.

Syntax

sFuriganaName = window.external.UserInfo.get_FuriganaName();
Parameters | None
Return Values | String. The value of the furigana version of the end user's name that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strFuriganaName = window.external.UserInfo.get_FuriganaName();
Comments | See also UserInfo.get_FirstName, UserInfo.get_LastName, and UserInfo.set_FuriganaName.


UserInfo.get_IdentitiesMax method

Returns the maximum number of user accounts that the end user can create in Windows Welcome.

Syntax

window.external.UserInfo.get_IdentitiesMax();
Parameters | None
Return Values | Integer. The maximum number of user accounts that the end user can create in Windows Welcome.
Applies To | window.external.UserInfo
Example
iMaxID = window.external.UserInfo.get_IdentitiesMax();


UserInfo.get_Identity method

Returns the name of a specific user account.

Syntax

window.external.UserInfo.get_Identity(index);
Parameters index

Integer. The index of the specified user account. The value is greater than or equal to 0; less than the value of UserInfo.get_IdentitiesMax.
Return Values | String. The name of a user account corresponding to the specified index.
Applies To | window.external.UserInfo
Example
var strIdentity = window.external.UserInfo.get_Identity();


UserInfo.get_LastName method

Returns the end user's last name that is stored in the UserInfo object.

Syntax

sLastName = window.external.UserInfo.get_LastName();
Parameters | None
Return Values | String. The value of the end user's last name that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strLastName = window.external.UserInfo.get_LastName();


UserInfo.get_MiddleInitial method

Returns the end user's middle initial that is stored in the UserInfo object.

Syntax

sMiddleInitial = window.external.UserInfo.get_MiddleInitial();
Parameters | None
Return Values | String. The value of the end user's middle initial that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strMiddleInitial = window.external.UserInfo.get_MiddleInitial();


UserInfo.get_PhoneNumber method

Returns the end user's telephone number that is stored in the UserInfo object.

Syntax

sPhoneNumber = window.external.UserInfo.get_PhoneNumber();
Parameters | None
Return Values | String. The value of the end user's telephone number that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strPhoneNumber = window.external.UserInfo.get_PhoneNumber();


UserInfo.get_PrimaryEmail method

Returns the end user's primary e-mail address that is stored in the UserInfo object.

Syntax

sPrimaryEmail = window.external.UserInfo.get_PrimaryEmail();
Parameters | None
Return Values | String. The end user's primary e-mail address that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strPrimaryEmail = window.external.UserInfo.get_PrimaryEmail();


UserInfo.get_SecondaryEmail method

Returns the end user's secondary e-mail address that is stored in the UserInfo object.

Syntax

sSecondaryEmail = window.external.UserInfo.get_SecondaryEmail();
Parameters | None
Return Values | String. The end user's secondary e-mail address that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strSecondaryEmail = window.external.UserInfo.get_SecondaryEmail();


UserInfo.get_State method

Returns the end user's state of residence that is stored in the UserInfo object.

Syntax

sState = window.external.UserInfo.get_State();
Parameters | None
Return Values | String. The value of the end user's state of residence that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strState = window.external.UserInfo.get_State();


UserInfo.get_Zip method

Returns the end user's ZIP code or postal code that is stored in the UserInfo object.

Syntax

sZip = window.external.UserInfo.get_Zip();
Parameters | None
Return Values | String. The value of the end user's ZIP code or postal code that is stored in the UserInfo object.
Applies To | window.external.UserInfo
Example
var strZip = window.external.UserInfo.get_Zip();


UserInfo.set_Address1 method

Sets the first line of the end user's address in the UserInfo object.

Syntax

window.external.UserInfo.set_Address1(sAddress1);
Parameters sAddress1

String. The value of the first line of the end user's address to save in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_Address1("1234 Main Street");


UserInfo.set_Address2 method

Sets the second line of the end user's address in the UserInfo object.

Syntax

window.external.UserInfo.set_Address2(sAddress2);
Parameters sAddress2

String. The value of the second line of the end user's address to save in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_Address2("Suite 5678");


UserInfo.set_AreaCode method

Sets the end user's telephone area code that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_AreaCode(sAreaCode);
Parameters sAreaCode

String. The value of the end user's telephone area code that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_AreaCode("123");


UserInfo.set_City method

Sets the name of the end user's city that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_City(sCity);
Parameters sCity

String. The value of the end user's city that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_City("Buffalo");


UserInfo.set_CompanyName method

Sets the end user's company name that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_CompanyName(sCompanyName);
Parameters sCompanyName

String. The value of the end user's company name that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_CompanyName("Fabrikam, Inc.");


UserInfo.set_Country method

Sets the name of the end user's country or region that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_Country(sCountry);
Parameters sCountry

String. The value of the end user's country or region that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_Country("United States of America");


UserInfo.set_FirstName method

Sets the end user's first name that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_FirstName(sFirstName);
Parameters sFirstName

String. The value of the end user's first name that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_FirstName("Pat");


UserInfo.set_FuriganaName method

Sets the furigana version of the end user's name that is stored in the UserInfo object.

The Japanese writing system comprises three different types of characters: hiragana, katakana, and kanji. Each hiragana or katakana character has a specific pronunciation.

However, individual kanji characters often have more than one pronunciation, and each pronunciation has a different meaning. Kanji characters are often augmented with tiny hiragana (or sometimes katakana) characters written above or next to them to indicate the correct pronunciation of the word. Hiragana and katakana used in this way is called furigana.

Syntax

window.external.UserInfo.set_FuriganaName(sFuriganaName);
Parameters sFuriganaName

String. The furigana version of the end user's name that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_FuriganaName("furigana name");
Comments | See also the UserInfo.set_FirstName, UserInfo.set_LastName, and UserInfo.get_FuriganaName methods.


UserInfo.set_Identity method

Sets the name of a specific user account that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_Identity(index, idName);
Parameters index

Integer. The index number of the specified user account.

idName

String. The name of the specified user account.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_Identity(1,"PatC");


UserInfo.set_LastName method

Sets the end user's last name that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_LastName(sLastName);
Parameters sLastName

String. The value of the end user's last name that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_LastName("Coleman");


UserInfo.set_MiddleInitial method

Sets the end user's middle initial that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_MiddleInitial(sMiddleInitial);
Parameters sMiddleInitial

String. The value of the end user's middle initial that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_MiddleInitial("M");


UserInfo.set_PhoneNumber method

Sets the end user's telephone number that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_PhoneNumber(sPhoneNumber);
Parameters sPhoneNumber

String. The value of the end user's telephone number that is stored in the UserInfo object.

Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_PhoneNumber("555-0100");


UserInfo.set_PrimaryEmail method

Sets the end user's primary e-mail address that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_PrimaryEmail(sPrimaryEmail);
Parameters sPrimaryEmail

String. The value of the end user's primary e-mail address that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_PrimaryEmail("pat@fabrikam.com");


UserInfo.set_SecondaryEmail method

Sets the end user's secondary e-mail address that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_SecondaryEmail(sSecondaryEmail);
Parameters sSecondaryEmail

String. The value of the end user's secondary e-mail address that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_SecondaryEmail("manager@fabrikam.com");


UserInfo.set_State method

Sets the name of the end user's state of residence that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_State(sState);
Parameters sState

String. The value of the end user's state of residence that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_State("NY");


UserInfo.set_Zip method

Sets the end user's ZIP code that is stored in the UserInfo object.

Syntax

window.external.UserInfo.set_Zip(sZip);
Parameters sZip

String. The value of the end user's ZIP code that is stored in the UserInfo object.
Return Values | None
Applies To | window.external.UserInfo
Example
window.external.UserInfo.set_Zip("12345");


Glossary

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X YZ

Symbols

$$Rename.txt

A file that lists all files contained in a particular folder that need to be renamed from an 8.3 format name to a long file name during Setup. All file names must be in 8.3 format if you run Setup using Winnt.exe, or if you copy a set of files from one computer to another using MS-DOS.

%windir%

The default directory where Windows is installed, most commonly C:\winnt.

.adm

The file name extension for Administrative Templates files.

.cab file

Cabinet file. A single cabinet file that stores multiple compressed files. These files are commonly used in software installation and to reduce the file size and the associated download time for Web content.

.dll file

See definition for: dynamic-link library (DLL)

.inf file

Information file. A file created for a particular adapter that provides the operating system with information required to set up a device, such as a list of valid logical configurations for the device, the names of driver files associated with the device, and so on. An .inf file is provided typically on a disk by the device manufacturer or may be included in the operating system.

.ini file

Initialization file. Commonly used under Windows 3.x and earlier, .ini files have been used by both the operating system and individual applications to store persistent settings related to an application, driver, or piece of hardware. In Windows 32-bit operating systems, .ini files are supported for backward compatibility, but the registry is the preferred location for storing such settings.

.ins file

Internet settings file. A file that provides Windows Update Setup with Internet settings that configure the browser and associated components. You can create multiple versions of your browser package by changing the .ins file used by each package. Use the Profile Manager to create, save, and load .ins files.

100baseT

The Ethernet standard for local area networks using twisted-pair cable carrying data at 100 megabits per second (Mbps).

8.3

The standard format for file names in MS-DOS and Windows 3.1. A file name with eight or fewer characters, followed by a period (dot), followed by a three-character file name extension.

A

account manager

A Microsoft employee who is the primary contact for the business relationship between the OEM and Microsoft.

ACPI

See definition for: Advanced Configuration and Power Interface (ACPI)

activation

See definition for: Windows Product Activation (WPA)

Active Directory

The Windows-based directory service. Active Directory stores information about objects on a network and makes this information available to users and network administrators. Active Directory gives network users access to permitted resources anywhere on the network using a single logon process. It provides network administrators with an intuitive, hierarchical view of the network and a single point of administration for all network objects.

See also: domain; forest; object

Active Directory Users and Computers

An administrative tool used by an administrator to perform day-to-day Active Directory administration tasks. The tasks that can be performed with this tool include creating, deleting, modifying, moving, and setting permissions on objects stored in the directory. Examples of objects in Active Directory are organizational units, users, contacts, groups, computers, printers, and shared file objects.

See also: Active Directory; object; permission

active partition

A partition from which an x86-based computer starts up. The active partition must be a primary partition on a basic disk. If you use Windows exclusively, the active partition can be the same as the system volume.

See also: basic disk; primary partition; system partition; x86

active volume

The volume from which the computer starts up. The active volume must be a simple volume on a dynamic disk. You cannot mark an existing dynamic volume as the active volume, but you can upgrade a basic disk containing the active partition to a dynamic disk. After the disk is upgraded to dynamic, the partition becomes a simple volume that is active.

See also: active partition; basic disk; dynamic disk; dynamic volume; simple volume

adapter

See definition for: device

add-on devices

Devices that are traditionally added to the base computer system to increase functionality, such as audio, networking, graphics, or SCSI controller. Add-on devices fall into two categories: devices built onto the system board, and devices on expansion cards, added to the system through a system board connector, such as PCI.

administrator

In Windows XP Professional and Windows XP Home Edition, a person responsible for making system changes on the local computer. For example, an administrator, on the local computer, can install software, maintain local user and group accounts, assign passwords and permissions, and manage local files.

In Windows XP Professional, administrators are members of the local administrators group and have full control over the local computer.

See also: domain controller; group account; password; permission; user account

Advanced Configuration and Power Interface (ACPI)

An open industry specification that defines power management on a wide range of mobile, desktop, and server computers and peripherals. ACPI is the foundation for the OnNow industry initiative that allows system manufacturers to deliver computers that start at the touch of a keyboard. ACPI design is essential to take full advantage of power management and Plug and Play.

See also: Plug and Play

agent character

An interactive animated character who guides users through Windows Welcome. The character interacts with the user in ways similar to the natural aspects of human social communication. Characters can respond by using synthesized speech, recorded audio, or text in a cartoon word balloon.

See also: Windows Welcome

allocation unit

The smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on allocation units. The smaller the allocation unit size, the more efficiently a disk stores information. If you do not specify an allocation unit size when formatting the disk, Windows picks default sizes based on the size of the volume. These default sizes are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. Also called a cluster.

See also: file system

AMD64 (Advanced Micro Devices 64)

The AMD 64-bit instruction set architecture. The AMD64 platform enables 64-bit memory addressing, and it is compatible with the x86 instruction set architecture.

American Standard Code for Information Interchange (ASCII)

A standard single-byte character encoding scheme used for text-based data. ASCII uses designated 7-bit or 8-bit number combinations to represent either 128 or 256 possible characters. Standard ASCII uses 7 bits to represent all uppercase and lowercase letters, the numbers 0 through 9, punctuation marks, and special control characters used in U.S. English. Most current x86-based systems support the use of extended (or "high") ASCII. Extended ASCII allows the eighth bit of each character to identify an additional 128 special symbol characters, foreign-language letters, and graphic symbols.

See also: Unicode

answer file

A text file that scripts the answers for a series of graphical user interface (GUI) dialog boxes. The answer file for Setup is commonly called Unattend.txt, but for a network preinstallation, you can name the file anything you like. For a CD-based Setup, the answer file must be named Winnt.sif. The answer files for Sysprep are Sysprep.inf and Winbom.ini. You can create or modify these answer files in a text editor or through Setup Manager.

See also: Unattend.txt

anti-aliasing

A software technique for smoothing the jagged appearance of curved or diagonal lines caused by poor resolution on a display screen. Methods of anti-aliasing include surrounding pixels with intermediate shades and manipulating the size and horizontal alignment of the pixels.

API

See definition for: application programming interface (API)

APIC

Advanced Programmable Interrupt Controller. A distributed set of devices that form an interrupt controller.

AppleTalk

See definition for: AppleTalk Protocol

AppleTalk Protocol

The set of network protocols on which AppleTalk network architecture is based. The AppleTalk Protocol is installed with Services for Macintosh to help users access resources on a network.

See also: protocol; resource

application programming interface (API)

A set of routines that an application uses to request and carry out lower-level services performed by a computer's operating system. These routines usually carry out maintenance tasks such as managing files and displaying information.

aspect ratio

The relationship of width and height for an image. When an image is displayed on different screens, the aspect ratio must be kept the same to avoid either vertical or horizontal distortion.

assigned configuration

The resources contained in the device node that are allocated for the device. For Plug and Play cards, the assigned resources for a device can change dynamically or from one system start-up to the next.

asynchronous

Not dependent on timing. Each application or command runs in the specified order, but the specified item does not wait for any previously started processes to finish before an application or command runs.

ATM adaptation layer (AAL)

The layer of the asynchronous transfer mode (ATM) protocol stack that parses data into the payload portion of the ATM cell for transport across an ATM network.

attach

Run the Setup program for an application that is already staged on the destination computer.

See also: destination computer; detach; stage

attribute

For files, information that indicates whether a file is read-only, hidden, ready for archiving (backing up), compressed, or encrypted, and whether the file contents should be indexed for fast file searching.

In Active Directory, a property of an object. For each object class, the schema defines which attributes an instance of the class must have and which additional attributes it might have.

See also: Active Directory; object

audit mode

Verifying, before it is delivered to the end user, that the fully-manufactured computer functions as expected. After auditing, always reseal the operating system to reset the first-run experience for the user.

authentication

The process for verifying that an entity or object is who or what it claims to be. Examples include confirming the source and integrity of information, such as verifying a digital signature or verifying the identity of a user or computer.

See also: smart card

authorized distributor

An independent company licensed by Microsoft Licensing, Inc., to manage the production and distribution of multipacks of Windows XP OEM products to system builders. If you purchase Microsoft software from someone other than a Microsoft authorized distributor, you run the risk of purchasing counterfeit software, which usually has many of the following problems: missing drivers, missing documentation, viruses, bugs, and other defects. Installing legitimate Microsoft products prevents customer problems and reduces requests for customer support.

authorized replicator

An independent company licensed by Microsoft Licensing, Inc., to manage the production and distribution of Microsoft OEM products for royalty OEMs. Microsoft Licensing, Inc., supplies the authorized replicator with the master components, manufacturing and assembly specifications, and other pertinent instructions. The authorized replicator manufactures and assembles genuine Microsoft products to exact specifications. The benefits of using an authorized replicator include protection against piracy, consistent high-quality software, and competitive prices.

autologon

Automatically logging on to the computer using the Administrator account when the computer restarts.

Automatic Private IP Addressing (APIPA)

A TCP/IP feature in Windows XP and products in the Windows Server 2003 family that automatically configures a unique IP address from the range 169.254.0.1 through 169.254.255.254 and a subnet mask of 255.255.0.0 when the TCP/IP protocol is configured for dynamic addressing and a DHCP server is not available. The APIPA range of IP addresses is reserved by the Internet Assigned Numbers Authority (IANA), and IP addresses within this range are not used on the Internet.

See also: DHCP server; Dynamic Host Configuration Protocol (DHCP); IP address; Transmission Control Protocol/Internet Protocol (TCP/IP)

B

bandwidth

The data transfer capacity of a transmission medium.

In digital communications, the transfer capacity expressed in bits per second (bps) or megabits per second (Mbps). For example, Ethernet accommodates a bandwidth of 10,000,000 bps or 10 Mbps.

In analog communications, the difference between the highest and lowest frequencies in a specific range. For example, an analog telephone line accommodates a bandwidth of 3,000 hertz (Hz), the difference between the lowest (300 Hz) and highest (3,300 Hz) frequencies that it can carry.

See also: bits per second (bps)

base character

A character that has meaning independent of other characters, or any graphical character that is not a diacritical mark.

basic disk

A physical disk that can be accessed by MS-DOS and all Windows-based operating systems. Basic disks can contain up to four primary partitions, or three primary partitions and an extended partition with multiple logical drives. If you want to create partitions that span multiple disks, you must first convert the basic disk to a dynamic disk by using Disk Management or the Diskpart.exe command-line tool.

See also: dynamic disk; extended partition; logical drive; primary partition

basic input/output system (BIOS)

On x86-based computers, the set of essential software routines that test hardware at startup, start the operating system, and support the transfer of data among hardware devices. The BIOS is stored in read-only memory (ROM) so that it can be executed when you turn on the computer. Although critical to performance, the BIOS is usually invisible to computer users.

See also: Extensible Firmware Interface (EFI); read-only memory (ROM); x86

basic volume

A primary partition or logical drive that resides on a basic disk.

See also: basic disk; logical drive; primary partition

bidi

Bi-Directional text. A mixture of characters that are read from left to right and characters that are read from right to left. For example, most Arabic, Hebrew, Farsi, and Urdu characters are read from right to left, but numbers and quoted Western terms within these languages' text are read from left to right.

BIOS

See definition for: basic input/output system (BIOS)

BIOS enumerator

Responsible in a non-ACPI Plug and Play system for identifying all hardware devices on the motherboard of the computer. The BIOS supports an API that enables all Plug and Play computers to be queried in a common manner.

bit (binary digit)

The smallest unit of information handled by a computer. One bit expresses a 1 or a 0 in a binary numeral, or a true or false logical condition. A group of 8 bits makes up a byte, which can represent many types of information, such as a letter of the alphabet, a decimal digit, or other character. Also known as a binary digit.

bit specifications

Numbers of colors or levels of gray that can be displayed at one time. Controlled by the amount of memory in the computer's graphics controller card. An 8-bit controller can display 256 colors or levels of gray; a 16-bit controller, 64,000 colors; and a 24-bit controller, 16.8 million colors.

bitmap

A file format for images used to customize the graphics in an Internet Explorer Administration Kit (IEAK) package.

bits per second (bps)

The number of bits transmitted every second, used as a measure of the speed at which a device, such as a modem, can transfer data.

See also: modem (modulator/demodulator)

boot partition

The partition that contains the Windows operating system and its support files. The boot partition can be, but does not have to be, the same as the system partition.

See also: partition; Primary disk; system partition

bootstrap loader

A program that is run automatically when a computer is turned on or booted. After first performing a few basic hardware tests, the bootstrap loader loads and passes control to a larger loader program, which typically then loads the operating system. The bootstrap loader typically resides in the computer's read-only memory (ROM).

See also: read-only memory (ROM)

branding

To incorporate a company name, logo, support information, and Help files into the Microsoft Windows installation.

Break-the-Seal Microsoft Distribution and Preinstallation Agreement (BTS)

The license agreement between a system builder and Microsoft Licensing, Inc., affixed to the side of every OEM Distribution Pack. By opening the package, you agree to all the terms of the Break-The-Seal agreement. If you do not agree to all the terms of the agreement, contact the Microsoft OEM authorized distributor it was purchased from and make arrangements to return the software.

broadband

Of or relating to communications systems in which the medium of transmission (such as a wire or fiber-optic cable) carries multiple messages at a time, each message modulated on its own carrier frequency by a modem.

browser

Software that interprets the markup of files in HTML, formats them into Web pages, and displays them to the end user. Some browsers also permit end users to send and receive e-mail, read newsgroups, and play sound or video files embedded in Web documents.

See also: World Wide Web

build-to-order

To manufacture a computer according to a customer's specification.

build-to-plan

To manufacture computers according to a general specification.

built-in groups

The default security groups installed with the operating system. Built-in groups have been granted useful collections of rights and built-in abilities.

In most cases, built-in groups provide all the capabilities needed by a particular user. For example, members of the built-in Backup Operators group can back up and restore files and folders. To provide a needed set of capabilities to a user account, assign it to the appropriate built-in group.

bus

A communication line used for data transfer among the components of a computer system. A bus essentially allows different parts of the system to share data. For example, a bus connects the disk-drive controller, memory, and input/output ports to the microprocessor.

See also: expansion slot; universal serial bus (USB)

C

cable modem

A modem that sends and receives data through a coaxial cable television network instead of telephone lines.

cache

A special memory subsystem in which frequently used data values are duplicated for quick access.

See also: cache file

cache file

A file used by DNS servers and clients to store responses to DNS queries. For Windows DNS servers, the cache file is named Cache.dns by default.

See also: cache

caching

The process of temporarily storing recently accessed information in a special memory subsystem for quicker access.

See also: cache

CAL

See definition for: client access license (CAL)

CD boot

Starting a computer from the retail product CD-ROM and then installing Windows on the hard disk using the Setup program on the CD. This method is much slower than installing Windows from a network and is not recommended. For an unattended Setup using the CD boot method, the Unattend.txt file must be named Winnt.sif. The user can select in the winnt.sif if they want to select the partition manually or have it automatically selected.

CD-ROM

Compact disc read-only memory. A form of storage characterized by high capacity (roughly 650 MB) and the use of laser optics instead of magnetic means for reading data.

certificate

A digital document that is commonly used for authentication and to secure information on open networks. A certificate securely binds a public key to the entity that holds the corresponding private key. Certificates are digitally signed by the issuing certification authority (CA), and they can be issued for a user, a computer, or a service.

See also: certification authority (CA); private key; public key

certificate of authenticity (COA)

A label with sophisticated anti-counterfeiting features that helps the end user identify that the computer uses a validly licensed copy of Microsoft Windows. The product name and a unique product key appear in the center of the label. The OEM must physically attach the COA label to the computer chassis, and it should never be removed from the computer.

certificate revocation list (CRL)

A document maintained and published by a certification authority that lists certificates that have been revoked.

See also: certificate; certification authority (CA)

certificate template

A Windows construct that specifies the format and content of certificates based on their intended usage. When requesting a certificate from a Windows enterprise certification authority (CA), certificate requestors can select from a variety of certificate types that are based on certificate templates.

See also: certificate; certification authority (CA)

certificate trust list (CTL)

A signed list of root certification authority certificates that an administrator considers reputable for designated purposes, such as client authentication or secure e-mail.

See also: certificate; certification authority (CA); root certificate

certification authority (CA)

An entity responsible for establishing and vouching for the authenticity of public keys belonging to subjects (usually users or computers) or other certification authorities. Activities of a certification authority can include binding public keys to distinguished names through signed certificates, managing certificate serial numbers, and certificate revocation.

See also: certificate; public key; root certification authority

character

The simplest element used to represent written languages. The appearance of a character is not constant; a character's appearance depends on the font used, as well as the context of surrounding text.

checkpoint

An identifier for a specific page or a conceptually related set of pages that tracks the user's navigation through Windows Welcome.

child object

An object that resides in another object. A child object implies relation. For example, a file is a child object that resides in a folder, which is the parent object.

See also: object; parent object

clean system

An installation of Windows that has not been modified and has not had any additional software installed on it.

ClearType

A font display technology that dramatically improves font display resolution so that letters on the computer screen appear smooth, not jagged. ClearType dramatically improves the readability of text on color LCD monitors with a digital interface, such as those found in laptops and high-quality flat-panel desktop displays.

client

Any computer or program connecting to, or requesting the services of, another computer or program. Client can also refer to the software that enables the computer or program to establish the connection.

For a local area network (LAN) or the Internet, a computer that uses shared network resources provided by another computer (called a server).

See also: server

client access license (CAL)

A license that specifies the number of client computers that can connect to and use software located on a server.

cluster

In data storage, the smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on clusters, which consist of one or more contiguous sectors. The smaller the cluster size, the more efficiently a disk stores information. If no cluster size is specified during formatting, Windows picks defaults based on the size of the volume. These defaults are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. Also called an allocation unit.

In computer networking, a group of independent computers that work together to provide a common set of services and present a single-system image to clients. The use of a cluster enhances the availability of the services and the scalability and manageability of the operating system that provides the services.

See also: client; file system

Cmdlines.txt

A text file that GUI-mode Setup executes when installing optional components, such as applications.

COA

See definition for: certificate of authenticity (COA)

code page

A means of providing support for character sets and keyboard layouts for different countries or regions. A code page is a table that relates the binary character codes used by a program to keys on the keyboard or to characters on the display.

codec

Hardware that can convert audio or video signals between analog and digital forms (coder/decoder); hardware or software that can compress and uncompress audio or video data (compression/decompression); or the combination of coder/decoder and compression/decompression. Generally, a codec compresses uncompressed digital data so that the data uses less memory.

collateral

The end-user manual and any other items that the OEM packages with a new computer.

compatible ID

An ID used by the Plug and Play Manager. If Plug and Play does not locate a match for the device hardware ID, Plug and Play installs the driver .inf file associated with the compatible ID.

composite character

A text element consisting of a base character and a diacritic or accent mark. Although most common in the Latin script, other scripts (including Greek, Devanagari, and Tamil) also have composite characters.

config set

See definition for: configuration set

Configuration Manager

The Windows Plug and Play system component that drives the process of locating devices, setting up their nodes in the hardware tree, and running the resources allocation process. Each of the three phases of configuration management--boot time, real mode, and protected mode--have their own configuration managers.

configuration set

A file and folder structure that contain the necessary configuration settings that control the preinstallation process and define the manufacturers' custom information.

configure-to-order

To manufacture a computer according to a customer's specification by customizing a pre-existing image of a master installation.

Connection Manager

A client dialer used to obtain Internet access.

console tree

The left pane in Microsoft Management Console (MMC) that displays the items contained in the console. The items in the console tree and their hierarchical organization determine the capabilities of a console.

See also: Microsoft Management Console (MMC)

cookie

A block of data that a Web server stores on a client system. When a user returns to the same Web site, the browser sends a copy of the cookie back to the server. Cookies identify users, instruct the server to send a customized version of the requested Web page, and submit account information for the user.

counterfeit software

Software that a system builder does not obtain from an authorized distributor, or that a royalty OEM does not obtain from an authorized replicator. Counterfeit software usually has many of the following problems: missing drivers, missing documentation, viruses, bugs, and other defects. Installing legitimate Microsoft products helps ensure the quality of your products, prevents customer problems, and reduces requests for customer support.

customer

The purchaser of a new computer.

D

debug

To detect, locate, and correct logical or syntactical errors in a program.

desktop

The on-screen work area on which windows, icons, menus, and dialog boxes appear.

desktop ISP sign-up offer

A set of HTML pages that offer the end user the opportunity to sign up for Internet access. To view the offer, the end user clicks a link from the OEM link on the Start menu.

desktop registration

The opportunity given to the end user to register with Microsoft and the OEM, if the user failed to register during Windows Welcome.

destination computer

The computer on which you preinstall Windows that will be distributed to customers. You can either run Setup on the destination computer or copy a master installation onto a destination computer.

detach

Remove uninstalled application files from a destination computer.

See also: attach; destination computer; stage

device

Any piece of equipment that can be attached to a network or computer, for example, a computer, printer, joystick, adapter, or modem card, or any other peripheral equipment. Devices normally require a device driver to function with Windows.

For Windows licensing, electronic equipment such as computers, workstations, terminals, and handheld computers that can access or use the services of Windows operating systems, including file sharing, print sharing, remote access, and authentication.

See also: device driver

device driver

A program that enables a specific device, such as a modem, network adapter, or printer, to communicate with the operating system. Although a device might be installed on your system, Windows cannot use the device until you have installed and configured the appropriate driver. Device drivers load automatically (for all enabled devices) when a computer is started, and thereafter they run invisibly.

See also: device; signed driver

device ID

A unique ASCII string for the device created by enumerators to identify a hardware device and used to cross-reference data about the device stored in the registry. Distinguishes each logical device and bus from all others on the system.

Device Manager

An administrative tool that you can use to manage the devices on your computer. Using Device Manager, you can view and change device properties, update device drivers, configure device settings, and uninstall devices.

See also: device

DHCP

See definition for: Dynamic Host Configuration Protocol (DHCP)

DHCP server

A computer running the Microsoft DHCP service that offers dynamic configuration of IP addresses and related information to DHCP-enabled clients.

See also: Dynamic Host Configuration Protocol (DHCP); IP address

diacritic

Any mark placed over, under, or through a character, usually to indicate a change in phonetic value from the unmarked state. A character that is attached to it is a base character. Most diacritics are non-spacing characters that do not increase the width of the base character.

dial-up connection

The connection to your network if you use a device that uses the telephone network. This includes modems with a standard telephone line, ISDN cards with high-speed ISDN lines, or X.25 networks.

If you are a typical user, you might have one or two dial-up connections, for example, to the Internet and to your corporate network. In a more complex server situation, multiple network modem connections might be used to implement advanced routing.

See also: modem (modulator/demodulator)

dial-up networking (DUN)

Connecting to a remote network or the Internet through a dial-up connection, such as a modem.

digital signature

A means for originators of a message, file, or other digitally encoded information to bind their identity to the information. The process of digitally signing information entails transforming the information, as well as some secret information held by the sender, into a tag called a signature. Digital signatures are used in public key environments, and they provide nonrepudiation and integrity services.

See also: service; time stamp

direct OEM

See definition for: royalty OEM

disk

A storage device that is attached to a computer.

See also: basic disk; dynamic disk

disk duplication

Using third-party hardware or software to copy a full master Windows XP installation onto the hard disks of multiple destination computers. The master computer and destination computers must have compatible hardware abstraction layers (HALs). The destination computer can be delivered directly to customers, or it might require additional processing on the factory production line.

See also: hardware abstraction layer (HAL)

diskpart.exe

A command-line utility for formatting and managing disk partitions and volumes.

distribution share

A network folder that contains the source files for Windows products that you preinstall. It may also contain the OPK tools and your configuration sets. This folder can be manually created or created by Setup Manager.

dock

To connect a laptop or notebook computer to a docking station.

See also: docking station

docking station

A unit for housing a portable computer that contains a power connection, expansion slots, and connections to peripherals, such as a monitor, printer, full-sized keyboard, and mouse. The docking station turns the portable computer into a desktop computer.

See also: dock

domain

In Active Directory, a collection of computer, user, and group objects defined by the administrator. These objects share a common directory database, security policies, and security relationships with other domains.

In DNS, any tree or subtree within the DNS namespace. Although the names for DNS domains often correspond to Active Directory domains, DNS domains should not be confused with Active Directory domains.

See also: Active Directory; object

domain controller

In an Active Directory forest, a server that contains a writable copy of the Active Directory database, participates in Active Directory replication, and controls access to network resources. Administrators can manage user accounts, network access, shared resources, site topology, and other directory objects from any domain controller in the forest.

See also: Active Directory; authentication; forest

domain name

The name given by an administrator to a collection of networked computers that share a common directory. Part of the DNS naming structure, domain names consist of a sequence of name labels separated by periods.

See also: domain; label

domain naming master

A domain controller that holds the domain naming operations master role in Active Directory. The domain naming master controls the addition or removal of domains in the forest. At any time, the domain naming master role can be assigned to only one domain controller in the forest.

See also: Active Directory; domain controller

domain tree

In DNS, the inverted hierarchical tree structure that is used to index domain names. Domain trees are similar in purpose and concept to the directory trees used by computer filing systems for disk storage. For example, when numerous files are stored on disk, directories can be used to organize the files into logical collections. When a domain tree has one or more branches, each branch can organize domain names used in the namespace into logical collections.

In Active Directory, a hierarchical structure of one or more domains, connected by transitive, bidirectional trusts, that forms a contiguous namespace. Multiple domain trees can belong to the same forest.

See also: Active Directory; domain; domain name; forest

double-byte characters

A set of characters in which each character is represented by two bytes. Some languages, such as Japanese, Chinese, and Korean, require double-byte character sets.

driver

Kernel-mode code used either to control or emulate a hardware device.

Driver.cab

A file containing all of the device drivers that ship with Windows XP.

DUN

See definition for: dial-up networking (DUN)

DVD

Digital video disk. A form of storage characterized by high capacity (roughly 650 MB) and the use of laser optics rather than magnetic means for reading data. Optical disk storage commonly used for audio, video, and computer data. DVDs range in capacity from 4.7 GB to 17 GB, and can store significantly more than a CD-ROM.

DWORD

A data type that is composed of hexadecimal data with a maximum allotted space of 4 bytes.

dynamic disk

A physical disk that provides features that basic disks do not, such as support for volumes that span multiple disks. Dynamic disks use a hidden database to track information about dynamic volumes on the disk and other dynamic disks in the computer. You convert basic disks to dynamic by using the Disk Management snap-in or the DiskPart command-line tool. When you convert a basic disk to dynamic, all existing basic volumes become dynamic volumes.

See also: active volume; basic disk; basic volume; dynamic volume; partition

Dynamic Host Configuration Protocol (DHCP)

A TCP/IP service protocol that offers dynamic leased configuration of host IP addresses and distributes other configuration parameters to eligible network clients. DHCP provides safe, reliable, and simple TCP/IP network configuration, prevents address conflicts, and helps conserve the use of client IP addresses on the network.

DHCP uses a client/server model where the DHCP server maintains centralized management of IP addresses that are used on the network. DHCP-supporting clients can then request and obtain lease of an IP address from a DHCP server as part of their network boot process.

See also: DHCP server; IP address; lease; service; Transmission Control Protocol/Internet Protocol (TCP/IP)

dynamic volume

A volume that resides on a dynamic disk. Windows supports five types of dynamic volumes: simple, spanned, striped, mirrored, and RAID-5. A dynamic volume is formatted by using a file system, such as file allocation table (FAT) or NTFS, and has a drive letter assigned to it.

See also: basic disk; basic volume; dynamic disk; mirrored volume; RAID-5 volume; simple volume; spanned volume; striped volume

dynamic-link library (DLL)

An operating system feature that allows executable routines (generally serving a specific function or set of functions) to be stored separately as files with .dll extensions. These routines are loaded only when needed by the program that calls them.

E

EFI

See definition for: Extensible Firmware Interface (EFI)

EFI system partition

On Itanium-based computers, a portion on a GUID partition table (GPT) disk that is formatted with the file allocation table (FAT) file system and contains the files necessary to start the computer. Every Itanium-based computer must have at least one GPT disk with an EFI system partition. The EFI system partition serves the same purpose as the system volume found on x86-based computers.

See also: Extensible Firmware Interface (EFI); file allocation table (FAT); GUID partition table (GPT); Itanium; Microsoft Reserved (MSR) partition; x86

embedded controller

The general class of microcontrollers used to support OEM-specific implementation, mainly in mobile environments. The embedded controller performs complex low-level functions through a simple interface to the host microprocessor(s).

embedded controller interface

ACPI defines a standard hardware and software communications interface between an operating system driver and an embedded controller, such as Smart Battery and AML code. This allows any operating system to provide a standard driver that can directly communicate with an embedded controller in the system, thus allowing other drivers to communicate with and use the resources of the system embedded controllers.

See also: Advanced Configuration and Power Interface (ACPI); driver

encryption

The process of disguising a message or data in such a way as to hide its substance.

See also: public key encryption

end user

The person who ultimately receives the computer manufactured by the OEM.

End-User License Agreement (EULA)

A legal agreement between a software or hardware manufacturer and the end user, with regard to the terms of use and transfer of the software.

EULA

See definition for: End-User License Agreement (EULA)

event

Any significant occurrence in the system or an application that requires users to be notified or an entry to be added to a log.

Event Viewer

A component you can use to view and manage event logs, gather information about hardware and software problems, and monitor security events. Event Viewer maintains logs about program, security, and system events.

See also: event

expansion slot

A socket in a computer, designed to hold expansion boards and connect them to the system bus.

See also: bus

extended partition

A type of partition that you can create only on basic master boot record (MBR) disks. Extended partitions are useful if you want to create more than four volumes on a basic MBR disk. Unlike primary partitions, you do not format an extended partition with a file system and then assign a drive letter to it. Instead, you create one or more logical drives within the extended partition. After you create a logical drive, you format it and assign it a drive letter. An MBR disk can have up to four primary partitions or three primary partitions, one extended partition, and multiple logical drives.

See also: basic disk; logical drive; master boot record (MBR); partition; primary partition; unallocated space

Extensible Firmware Interface (EFI)

In computers with the Intel Itanium processor, the interface between a computer's firmware, hardware, and the operating system. EFI defines a new partition style called GUID partition table (GPT). EFI serves the same purpose for Itanium-based computers as the basic input/output system (BIOS) found in x86-based computers. However, it has expanded capabilities that provide a consistent way to start any compatible operating system and an easy way to add EFI drivers for new bootable devices without the need to update the computer's firmware.

See also: basic input/output system (BIOS); GUID partition table (GPT); Itanium; x86

F

factory mode

A mode of running Sysprep that postpones the first-run experience and allows OEMs to install additional drivers and applications, incorporate build-to-order customer information, and test the Windows installation. To run Sysprep in factory mode, use the command line Sysprep -factory.

FAT

See definition for: file allocation table (FAT)

FAT32

A derivative of the file allocation table (FAT) file system. FAT32 supports smaller cluster sizes and larger volumes than FAT, which results in more efficient space allocation on FAT32 volumes.

See also: file allocation table (FAT)

fault tolerance

The ability of computer hardware or software to ensure data integrity when hardware failures occur. Fault-tolerant features appear in many server operating systems and include mirrored volumes, RAID-5 volumes, and server clusters.

See also: cluster; mirrored volume; RAID-5 volume

file allocation table (FAT)

A file system used by MS-DOS and other Windows operating systems to organize and manage files. The file allocation table is a data structure that Windows creates when you format a volume by using FAT or FAT32 file systems. Windows stores information about each file in the file allocation table so that it can retrieve the file later.

See also: FAT32; file system; NTFS file system

file copy

The first of the three stages of Setup, where the Windows program files and any additional files specified are copied to the computers hard disk.

file system

In an operating system, the overall structure in which files are named, stored, and organized. NTFS, FAT, and FAT32 are types of file systems.

See also: FAT; FAT32; NTFS file system

File Transfer Protocol (FTP)

A member of the TCP/IP suite of protocols, used to copy files between two computers on the Internet. Both computers must support their respective FTP roles: one must be an FTP client and the other an FTP server.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

firmware

Software routines and low-level input/output instructions stored in read-only memory (ROM). Unlike random-access memory (RAM), read-only memory stays intact even in the absence of electrical power.

See also: random access memory (RAM); read-only memory (ROM)

first-run experience

The software that the end user sees the first time they start a new computer. The first-run experience is known as Windows Welcome in Windows XP and Mini-Setup in the Windows Server 2003 family.

See also: Windows Welcome

flash the BIOS

The process of updating the computer’s BIOS software with a new version.

See also: basic input/output system (BIOS)

font

A graphic design applied to a collection of numbers, symbols, and characters. A font describes a certain typeface, along with other qualities such as size, spacing, and pitch.

See also: OpenType fonts

foreground program

The program that runs in the active window (the uppermost window with the highlighted title bar). The foreground program responds to commands issued by the user.

forest

One or more Active Directory domains that share the same class and attribute definitions (schema), site and replication information (configuration), and forest-wide search capabilities (global catalog). Domains in the same forest are linked with two-way, transitive trust relationships.

See also: Active Directory; domain

free space

Available space that you use to create logical drives within an extended partition.

See also: extended partition; logical drive; unallocated space

furigana name

Tiny Japanese kana characters written above or next to kanji characters. The kana characters indicate the correct pronunciation of the word written in kanji.

G

glyph

A graphical representation of either a character, a part of a character, or a sequence of characters.

GPT

See definition for: GUID partition table (GPT)

graceful recovery

Termination of a process that allows the operating system or parent process to regain normal control. Does not crash the machine or result in a general protection default (GPF) or blue screen. The user is not required to close the application, and can continue to use the other functionality.

graphical user interface (GUI)

A display format, like that of Windows, that represents a program's functions with graphic images such as buttons and icons. GUIs enable a user to perform operations and make choices by pointing and clicking with a mouse.

group account

A collection of user accounts. By making a user account a member of a group, you give the related user all the rights and permissions granted to the group.

See also: user account

Group Policy

The infrastructure within Active Directory directory service that enables directory-based change and configuration management of user and computer settings, including security and user data. You use Group Policy to define configurations for groups of users and computers. With Group Policy, you can specify policy settings for registry-based policies, security, software installation, scripts, folder redirection, remote installation services, and Internet Explorer maintenance. The Group Policy settings that you create are contained in a Group Policy object (GPO). By associating a GPO with selected Active Directory system containers—sites, domains, and organizational units—you can apply the GPO's policy settings to the users and computers in those Active Directory containers. To create an individual GPO, use the Group Policy Object Editor. To manage Group Policy objects across an enterprise, you can use the Group Policy Management console.

See also: Active Directory

GUI-mode Setup

The third of the three stages of Setup, during which the computers hardware and network settings are configured, you are prompted to provide an Administrator password, and you can personalize the installation.

GUID partition table (GPT)

A disk-partitioning scheme that is used by the Extensible Firmware Interface (EFI) in Itanium-based computers. GPT offers more advantages than master boot record (MBR) partitioning because it allows up to 128 partitions per disk, provides support for volumes up to 18 exabytes in size, allows primary and backup partition tables for redundancy, and supports unique disk and partition IDs (GUIDs).

See also: Extensible Firmware Interface (EFI); Itanium; master boot record (MBR)

H

HAL

See definition for: hardware abstraction layer (HAL)

hardware abstraction layer (HAL)

A thin layer of software provided by the hardware manufacturer that hides, or abstracts, hardware differences from higher layers of the operating system. By means of the filter provided by the HAL, different types of hardware look alike to the rest of the operating system. This enables the operating system to be portable from one hardware platform to another. The HAL also provides routines that enable a single device driver to support the same device on all platforms.

hardware branch

The hardware archive root key in the registry that is a superset of the memory-resident hardware tree. Although the hardware tree contains information only about those devices currently detected and running in the system, the registry contains a complete list of all hardware ever installed on the particular computer. The hardware root key is \\HKEY-LOCAL-MACHINE\Hardware.

Hardware Compatibility List (HCL)

A hardware list that Microsoft compiled for specific products, including Windows 2000 and earlier versions of Windows. The list for a specific product, such as Windows 2000, includes the hardware devices and computer systems that are compatible with that version of the product. For products in the Windows Server 2003 family, you can find the equivalent information on the Windows Catalog Web site.

See also: device

hardware ID

A vendor-defined string used by the Plug and Play Manager to find the correct .inf file to install a particular device.

See also: .inf file; Plug and Play

hardware tree

A record in RAM of the current system configuration based on the information for all devices in the hardware branch of the registry. The hardware tree is created each time the system is started or whenever a dynamic change occurs to the system configuration.

See also: hardware branch

hardware type

A classification for similar devices. For example, Imaging Device is a hardware type for digital cameras and scanners.

See also: device

hash

A fixed-size result that is obtained by applying a one-way mathematical function (sometimes called a hash algorithm) to an arbitrary amount of data. If there is a change in the input data, the hash changes. The hash can be used in many operations, including authentication and digital signing. Also called a message digest.

See also: authentication; hash algorithm

hash algorithm

An algorithm that produces a hash value of some piece of data, such as a message or session key. With a good hash algorithm, changes in the input data can change every bit in the resulting hash value; for this reason, hashes are useful in detecting any modification in a data object, such as a message. Furthermore, a good hash algorithm makes it computationally infeasible to construct two independent inputs that have the same hash. Typical hash algorithms include MD2, MD4, MD5, and SHA-1. Also called a hash function.

HCL

See definition for: Hardware Compatibility List (HCL)

HCT

Hardware Compatibility Tests. A suite of tests from WHQL to verify hardware and device driver operations under a specific operating environment. These tests exercise the combination of a device, a software driver, and an operating system under controlled conditions to verify that all components operate properly.

See also: Windows Hardware Quality Labs (WHQL)

headless server

See definition for: remotely administered server

Help and Support Center

A unified place where a user can access all Help and Support content and services from both Microsoft and the OEM.

hidden partition

A partition that is not visibly exposed to the user. To create a hidden partition, set the partition type to one not recognized by Windows.

hive

A file in which the system stores a portion of the registry (named for their resemblance to the cellular structure of a beehive). A hive is backed by a single file and a .log file, which are in either the systemroot\System32\Config folder or the systemroot\Profiles\username folder.

By default, most hive files (Default, SAM, Security, and System) are stored in the systemroot\System32\Config folder. The systemroot\Profiles folder contains the user profile for each user of the computer. Because a hive is a file, it can be moved from one system to another. However, you must use the Registry Editor, Regedit.exe, to edit the file.

See also: key; registry; systemroot

hotfix

An update to address an issue identified after a software product has been distributed. Hotfix distribution is limited by its licensing terms.

hub

A common connection point for devices in a network. Typically used to connect segments of a local area network (LAN), a hub contains multiple ports. When data arrives at one port, it is copied to the other ports so that all segments of the LAN can see the data.

See also: local area network (LAN); port

Hypertext Markup Language (HTML)

A simple markup language used to create hypertext documents that are portable from one platform to another. HTML files are simple ASCII text files with codes embedded (indicated by markup tags) to denote formatting and hypertext links.

See also: American Standard Code for Information Interchange (ASCII)

I

I/O

See definition for: input/output (I/O) port

I/O request packet (IRP)

Data structures that drivers use to communicate with each other.

IA-PC

Intel Architecture Personal Computer. A general descriptive term for computers built with processors conforming to the architecture defined by the Intel processor family based on the 486 instruction set and having an industry-standard computer architecture.

icon character

The animated icon from the Help and Support Center that guides users through their first-run experience or Windows Welcome.

See also: Windows Welcome

IDE

See definition for: integrated device electronics (IDE)

IEEE

Institute of Electrical and Electronics Engineers, founded in 1963. IEEE is an organization composed of engineers, scientists, and students, best known for developing standards for the computer and electronics industry.

IEEE 1394

A standard for high-speed serial devices such as digital video and digital audio editing equipment.

See also: device

IHV

See definition for: independent hardware vendor (IHV)

IIS

See definition for: Internet Information Services (IIS)

image

A collection of files and folders (sometimes compressed into one file) that duplicates the original file and folder structure of an operating system. It often contains other files added by the OEM or corporation.

image resolution

The fineness or coarseness of an image as it is digitized, measured in dots per inch (DPI), typically ranging from 200 to 400 DPI.

in-box driver

A driver contained in the Driver.cab file, located in the i386 folder on the Windows product CD. The Plug and Play hardware IDs for in-box drivers are specified in Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf.

independent hardware vendor (IHV)

A company that manufactures hardware devices and the associated device drivers.

independent software vendor (ISV)

A third-party software developer; an individual or an organization that independently creates computer software.

Input language

A Regional and Language Options setting that specifies the combination of the language entered and the keyboard layout, Input Method Editor (IME), speech-to-text converter, or other device used to enter it. Formerly known as input locale.

See also: Input Method Editor (IME)

input locale

See definition for: Input language

Input Method Editor (IME)

A program used to enter the thousands of different characters in written Asian languages with a standard 101-key keyboard. An IME consists of both an engine that converts keystrokes into phonetic and ideographic characters and a dictionary of commonly used ideographic words. As the user enters keystrokes, the IME engine attempts to identify which character or characters that the keystrokes should be converted into.

input/output (I/O) port

A channel through which data is transferred between a device and the microprocessor. The port appears to the microprocessor as one or more memory addresses that it can use to send or receive data.

See also: device; memory address; port

install

When referring to software, to add program files and folders to your hard disk and related data to your registry so that the software runs properly. Installing contrasts with upgrading, where existing program files, folders, and registry entries are updated to a more recent version.

When referring to hardware, to physically connect the device to your computer, to load device drivers onto your computer, and to configure device properties and settings.

See also: device driver; registry

integrated device electronics (IDE)

A type of disk-drive interface in which the controller electronics reside on the drive itself, eliminating the need for a separate adapter card. IDE offers advantages such as look-ahead caching to increase overall performance.

internet

internet. Two or more network segments connected by routers. Another term for internetwork.

Internet. A worldwide network of computers. If you have access to the Internet, you can retrieve information from millions of sources, including schools, governments, businesses, and individuals.

See also: World Wide Web

Internet address

An address for a resource on the Internet that is used by Web browsers to locate Internet resources. An Internet address typically starts with a protocol name, followed by the name of the organization that maintains the site; the suffix identifies the kind of organization it is. For example, the address http://www.yale.edu provides the following information:

  • http: This Web server uses the Hypertext Transfer Protocol.
  • www: This site is on the World Wide Web.
  • edu: This is an educational institution.
Internet address is also called Uniform Resource Locator (URL).

See also: protocol; Web server

Internet Information Services (IIS)

Software services that support Web site creation, configuration, and management, along with other Internet functions. Internet Information Services include Network News Transfer Protocol (NNTP), File Transfer Protocol (FTP), and Simple Mail Transfer Protocol (SMTP).

See also: File Transfer Protocol (FTP); Network News Transfer Protocol (NNTP); Simple Mail Transfer Protocol (SMTP)

Internet Protocol (IP)

A routable protocol in the TCP/IP protocol suite that is responsible for IP addressing, routing, and the fragmentation and reassembly of IP packets.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

Internet service provider (ISP)

A company that provides individuals or companies access to the Internet and the World Wide Web. An ISP provides a telephone number, a user name, a password, and other connection information so users can connect their computers to the ISP's computers. An ISP typically charges a monthly or hourly connection fee.

See also: Web server

Internetwork Packet Exchange (IPX)

A network protocol native to NetWare that controls addressing and routing of packets within and between local area networks (LANs). IPX does not guarantee that a message will be complete (no lost packets).

See also: Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX); local area network (LAN)

Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX)

Transport protocols used in Novell NetWare networks, which together correspond to the combination of TCP and IP in the TCP/IP protocol suite. Windows implements IPX through NWLink.

See also: Internetwork Packet Exchange (IPX); NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink); Transmission Control Protocol/Internet Protocol (TCP/IP)

interrupt request (IRQ)

A signal sent by a device to get the attention of the processor when the device is ready to accept or send information. Each device sends its interrupt requests over a specific hardware line. Each device must be assigned a unique IRQ number.

interrupt request (IRQ) lines

Hardware lines over which devices can send signals to get the attention of the processor when the device is ready to accept or send information. Each device must have a unique IRQ line.

See also: device; interrupt request (IRQ)

IP address

For Internet Protocol version 4 (IPv4), a 32-bit address used to identify a node on an IPv4 internetwork. Each node on the IP internetwork must be assigned a unique IPv4 address, which is made up of the network ID, plus a unique host ID. This address is typically represented with the decimal value of each octet separated by a period (for example, 192.168.7.27). You can configure the IP address statically or dynamically by using Dynamic Host Configuration Protocol (DHCP).

For Internet Protocol version 6 (IPv6), an identifier that is assigned at the IPv6 layer to an interface or set of interfaces and that can be used as the source or destination of IPv6 packets.

See also: Dynamic Host Configuration Protocol (DHCP); Internet Protocol (IP); node

IRP

See definition for: I/O request packet (IRP)

IRQ

See definition for: interrupt request (IRQ)

isochronous

Time dependent. Refers to processes where data must be delivered within certain time constraints. Multimedia streams require an isochronous transport mechanism to ensure that data is delivered as fast as it is displayed, and to ensure that the audio is synchronized with the video.

isolation

The Plug and Play process by which cards on an ISA bus are distinguished from each other after system startup.

ISP

See definition for: Internet service provider (ISP)

ISP sign-up server

An HTTP server that automates the task of adding new customers to an ISP's customer database. The Internet sign-up server collects information from each customer, adds the information to the ISP's customer database, and then passes a configuration packet back to the customer's desktop computer. The configuration packet contains information that is used to configure the customer's Internet browser for subsequent connection to the ISP's services.

ISP signup offer

A set of HTML pages in Windows Welcome that enables end users to sign up for Internet access from a particular Internet service provider.

ISV

See definition for: independent software vendor (ISV)

Itanium

An Intel microprocessor that uses explicitly parallel instruction set computing and 64-bit memory addressing.

Itanium-based refers to systems or platforms that are based on the Itanium processor. Itanium 2-based refers to systems or platforms that are based on the Itanium 2 processor. Itanium architecture-based refers to systems or platforms that are based on the Itanium and Itanium 2 processors.

J

There are no glossary terms that begin with this letter.

K

kernel

The core of layered architecture that manages the most basic operations of the operating system and the computer's processor. The kernel schedules different blocks of executing code, called threads, for the processor to keep it as busy as possible and coordinates multiple processors to optimize performance. The kernel also synchronizes activities among Executive-level subcomponents, such as I/O Manager and Process Manager, and handles hardware exceptions and other hardware-dependent functions. The kernel works closely with the hardware abstraction layer.

kernel mode

A highly privileged mode of operation where program code has direct access to all memory, including the address spaces of all user-mode processes and applications, and to hardware. Also known as supervisor mode, protected mode, or Ring 0.

kernel-mode driver

Driver for a logical, virtual, or physical device.

key

In Registry Editor, a folder that appears in the left pane of the Registry Editor window. A key can contain subkeys and entries. For example, Environment is a key of HKEY_CURRENT_USER.

In IP security (IPSec), a value used in combination with an algorithm to encrypt or decrypt data. Key settings for IPSec are configurable to provide greater security.

See also: registry; subkey

L

label

In DNS, each part of a DNS domain name that represents a node in the domain namespace tree. For example, the three labels example, microsoft, and com make up the DNS domain name example.microsoft.com. Each label used in a DNS name cannot exceed 63 octets, 255 bytes including the terminating dot, for the fully qualified domain name (FQDN).

See also: domain name; node

LAN

See definition for: local area network (LAN)

Language for non-Unicode programs

A Regional and Language Options setting that specifies the default code pages and associated bitmap font files for a specific computer that affects all of that computer's users. The default code pages and fonts enable a non-Unicode application written for one operating system language version to run correctly on another operating system language version. Formerly known as system locale.

language group

A term used to describe the supported script families in Microsoft Windows.

Language ID

A 16-bit value which consists of a primary and a secondary language ID. Bits 0-9 make up the primary language ID and bits 10-15 comprise the sub-language ID.

Layer Two Tunneling Protocol (L2TP)

An industry-standard Internet tunneling protocol that provides encapsulation for sending Point-to-Point Protocol (PPP) frames across packet-oriented media. For IP networks, L2TP traffic is sent as User Datagram Protocol (UDP) messages. In Microsoft operating systems, L2TP is used in conjunction with Internet Protocol security (IPSec) as a virtual private network (VPN) technology to provide remote access or router-to-router VPN connections. L2TP is described in RFC 2661.

See also: Point-to-Point Protocol (PPP)

layered driver

One of a collection of drivers that responds to the same IRPs. Layered driver describes the highest-level and lowest-level drivers in a chain of layered drivers that process the same IRPs, along with all intermediate drivers in the chain.

LBA

Logical block addressing. A method used with SCSI and IDE disk drives to translate the cylinder, head, and sector specifications of the drive into addresses that can be used by an enhanced BIOS. LBA is used with drives that are larger than 528MB.

lease

The length of time for which a DHCP client can use a dynamically assigned IP address configuration. Before the lease time expires, the client must either renew or obtain a new lease with DHCP.

See also: Dynamic Host Configuration Protocol (DHCP); IP address

legacy

Any feature in the computer system based on older technology for which compatibility continues to be maintained in other system components.

license

The right of a person or company to use software in a particular way, as described in the terms of the license agreement. Copyright law also limits how a person may use the software. A person needs a license agreement for each software program they use.

Lightweight Directory Access Protocol (LDAP)

The primary access protocol for Active Directory. LDAP is an industry-standard protocol, established by the Internet Engineering Task Force (IETF), that allows users to query and update information in a directory service. Active Directory supports both LDAP version 2 and LDAP version 3.

See also: Active Directory; protocol

local area network (LAN)

A communications network connecting a group of computers, printers, and other devices located within a relatively limited area (for example, a building). A LAN enables any connected device to interact with any other on the network.

See also: NetBIOS Extended User Interface (NetBEUI); network basic input/output system (NetBIOS); workgroup

local bus

Usually refers to a system bus directly connected to the microprocessor on a system board. Local bus is used colloquially to refer to system board buses located closer to the microprocessor than ordinary expansion buses (thus requiring less buffering), which make them capable of greater throughput.

Locale

A group of user preference information, such as date and time formatting, represented as a list of values related to the user's language and sublanguage.

Locale ID

A 32-bit value which consists of the language ID in the low word (bits 0-15) and the sorting ID (bits 16-19) and a reserved value (bits 20-31) in the high word.

See also: Language ID

logical drive

A volume that you create within an extended partition on a basic master boot record (MBR) disk. Logical drives are similar to primary partitions, except that you are limited to four primary partitions per disk, whereas you can create an unlimited number of logical drives per disk. A logical drive can be formatted and assigned a drive letter.

See also: basic disk; basic volume; extended partition; master boot record (MBR); primary partition

long file name

A folder or file name longer than the 8.3 file name standard (up to eight characters followed by a period and an extension of up to three characters). Most versions of Windows, including Windows XP, Windows 2000, Window NT, Windows 95, and Windows 98 support long file names up to 255 characters.

LPT device

See definition for: parallel device

M

mass-storage controller

A device on which mass-storage devices rely for access to a computer subsystem. For example, a SCSI card or IDE functionality on the motherboard is a mass-storage controller; the physical hard drive is a mass-storage device.

mass-storage device

A generic term for disk, optical disk, or other device that provides persistent storage for computer data.

master boot record (MBR)

The first sector on a hard disk, which begins the process of starting the computer. The MBR contains the partition table for the disk and a small amount of executable code called the master boot code.

See also: partition boot sector; Recovery Console

master computer

A fully-assembled computer containing a master installation.

See also: master installation

master file table (MFT)

An NTFS system file on NTFS-formatted volumes that contains information about each file and folder on the volume. The MFT is the first file on an NTFS volume.

See also: file allocation table (FAT); NTFS file system

master installation

A customized installation of Windows that an OEM plans to duplicate onto one or more destination computers.

memory address

A portion of computer memory that can be allocated to a device or used by a program or the operating system. Devices are usually allocated a range of memory addresses.

See also: device

Message Queuing

A message queuing and routing system for Windows that enables distributed applications running at different times to communicate across heterogeneous networks and with computers that may be offline. Message Queuing provides guaranteed message delivery, efficient routing, security, and priority-based messaging. Formerly known as MSMQ.

See also: MSMQ

MFU list

Most Frequently Used list. A list of applications that the end user has recently used.

Microsoft Management Console (MMC)

A framework for hosting administrative tools called snap-ins. A console might contain tools, folders or other containers, World Wide Web pages, and other administrative items. These items are displayed in the left pane of the console, called a console tree. A console has one or more windows that can provide views of the console tree. The main MMC window provides commands and tools for authoring consoles. The authoring features of MMC and the console tree itself might be hidden when a console is in User Mode.

See also: console tree; snap-in

Microsoft OEM System Builder Agreement

The license agreement between a system builder and Microsoft Licensing, Inc., affixed to the side of every OEM Distribution Pack. By opening the package, you agree to all the terms of the Microsoft OEM System Builder Agreement. If you do not agree to all the terms of the agreement, contact the Microsoft OEM authorized distributor from which it was purchased and make arrangements to return the software.

Microsoft Reserved (MSR) partition

A required partition on every GUID partition table (GPT) disk. System components can allocate portions of the MSR partition into new partitions for their own use. For example, when you convert a basic GPT disk to dynamic, the system allocates a portion of the MSR partition to be used as the Logical Disk Manager (LDM) metadata partition. The MSR partition varies in size based on the size of the GPT disk. For disks smaller than 16 GB, the MSR partition is 32 MB. For disks larger than 16 GB, the MSR partition is 128 MB. The MSR partition is not visible in Disk Management, and you cannot store data on the MSR partition or delete it.

See also: GUID partition table (GPT); partition

MIDI

Musical Instrument Digital Interface. An industry-standard connection for computer control of musical instruments and devices. A hardware and data standard for communication between hardware. Most references involve only the data standard, which is a byte stream used for controlling musical instruments and storing the output of such instruments.

Mini-Setup

A subset of GUI-mode Setup, Mini-Setup is the first-run experience on the Windows Server 2003 family. Mini-Setup prompts for user-specific information, detects new hardware, and regenerates system IDs.

MIPS

Millions of instructions per second. A common measure of processor speed.

mirrored volume

A fault-tolerant volume that duplicates data on two physical disks. A mirrored volume provides data redundancy by using two identical volumes, which are called mirrors, to duplicate the information contained on the volume. A mirror is always located on a different disk. If one of the physical disks fails, the data on the failed disk becomes unavailable, but the system continues to operate in the mirror on the remaining disk. You can create mirrored volumes only on dynamic disks on computers running the Windows 2000 Server or Windows Server 2003 families of operating systems. You cannot extend mirrored volumes.

See also: dynamic disk; dynamic volume; fault tolerance; RAID-5 volume

modem (modulator/demodulator)

A device that enables computer information to be transmitted and received over a telephone line. The transmitting modem translates digital computer data into analog signals that can be carried over a telephone line. The receiving modem translates the analog signals back to digital form.

See also: port; Telephony API (TAPI)

monochrome

A monitor that displays images in only one color, or displays only variable levels of a single color, such as a gray-scale monitor.

monolithic driver

A driver that contains many different classes of functionality.

motherboard

The main circuit board of a microcomputer. The motherboard contains the connectors for attaching additional boards.

mount point

See definition for: volume mount point

MP3

Acronym for MPEG Audio Layer-3. A digital audio coding scheme used to distribute recorded music over the Internet. MP3 shrinks the size of an audio file by a factor of 10 to 12 without degrading the quality (CD-recording level) of the sound.

MPEG Audio Layer-3

See definition for: MP3

MSDN

Microsoft Developer Network.

MSMQ

The message queuing and routing system for Windows NT 4.0, Windows 95, and Windows 98. For Windows 2000, Windows XP, and the Windows Server 2003 family, this feature is called Message Queuing.

See also: Message Queuing

MultiByte Character Set (MBCS)

A mixed-width character set, in which some characters consist of more than 1 byte. A double byte character set (DBCS), which is a specific type of multibyte character set, includes some characters that consist of 1 byte and some characters that consist of 2 bytes.

Multilingual User Interface Pack (MUI Pack)

A separate, stand-alone release of Windows that includes user interface resources for each supported language. MUI enables users to set the user-interface language according to their preferences, provided the required language files are present on the computer. It is designed to enable large corporations to deploy a single version of Windows worldwide, while enabling their local users or groups to select the user-interface language. The following items are not localized in MUI versions: all 16-bit code, bitmaps, registry keys and values, folders and file names, and .inf files.

multimedia

Refers to the delivery of information that combines different content formats, such as video, audio, still images, graphics, animation, and text.

multiprocessor

Two or more connected and roughly equal processors that can each carry out one or more processes (programs or sets of instructions) in tandem.

N

name resolution

The process of having software translate between names that are easy for users to work with and numerical IP addresses, which are difficult for users but necessary for TCP/IP communications. Name resolution can be provided by software components such as DNS or WINS.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP); Windows Internet Name Service (WINS)

native mode

In Windows 2000 domains, the domain mode in which all domain controllers in a domain are running Windows 2000 and a domain administrator has switched the domain operation mode from mixed mode to native mode. Native mode supports universal groups and nesting of groups. In native mode, domain controllers running Windows NT 4.0 or earlier are not supported.

In Windows Server 2003 domains, native mode is referred to as Windows 2000 native, and it is one of three domain functional levels available.

See also: Active Directory

NCW

See definition for: New Connection Wizard (NCW)

NetBEUI

See definition for: NetBIOS Extended User Interface (NetBEUI)

NetBIOS Extended User Interface (NetBEUI)

A network protocol native to Microsoft Networking. It is usually used in small, department-size local area networks (LANs) of 1 to 200 clients. NetBEUI can use Token Ring source routing as its only method of routing. NetBEUI is the Microsoft implementation of the NetBIOS standard.

See also: local area network (LAN); network basic input/output system (NetBIOS); protocol

network adapter

A device that connects your computer to a network. Sometimes called an adapter card or network interface card.

See also: device

network basic input/output system (NetBIOS)

An application programming interface (API) that can be used by programs on a local area network (LAN). NetBIOS provides programs with a uniform set of commands for requesting the lower-level services required to manage names, conduct sessions, and send datagrams between nodes on a network.

See also: application programming interface (API); basic input/output system (BIOS); local area network (LAN); node; service

network card

See definition for: network interface card (NIC)

network card driver

A device driver that works directly with the network card, acting as an intermediary between the card and the protocol driver.

network interface card (NIC)

An expansion card or other device used to provide network access to a computer or other device, such as a printer. Network interface cards mediate between the computer and physical media, such as cabling, over which transmissions travel. Also called network adapter or network card.

Network News Transfer Protocol (NNTP)

A member of the TCP/IP suite of protocols used to distribute network news messages to NNTP servers and clients (newsreaders) on the Internet. NNTP is designed so that news articles are stored on a server in a central database, thus enabling a user to select specific items to read.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

New Connection Wizard (NCW)

A tool that helps users sign up for Internet service and automatically handles the software configuration steps necessary for gaining access to the Internet.

NIC

See definition for: network interface card (NIC)

node

For tree structures, a location on the tree that can have links to one or more items below it.

For local area networks (LANs), a device that is connected to the network and is capable of communicating with other network devices.

For server clusters, a computer system that is an active or inactive member of a cluster.

See also: local area network (LAN); server cluster

non-spacing character

A character, such as diacritic, that has no meaning by itself, but overlaps a base character to modify it, sometimes referred to as a "combining character".

NTFS file system

An advanced file system that provides performance, security, reliability, and advanced features that are not found in any version of file allocation table (FAT). For example, NTFS guarantees volume consistency by using standard transaction logging and recovery techniques. If a system fails, NTFS uses its log file and checkpoint information to restore the consistency of the file system. NTFS also provides advanced features, such as file and folder permissions, encryption, disk quotas, and compression.

See also: FAT32; file allocation table (FAT); file system

NWLink

See definition for: NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

The Microsoft implementation of the Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX) protocol used on NetWare networks. NWLink allows connectivity between Windows-based computers and NetWare networks running IPX/SPX. NWLink also provides network basic input/output system (NetBIOS) functionality and the Routing Information Protocol (RIP).

See also: Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX); network basic input/output system (NetBIOS)

O

object

An entity, such as a file, folder, shared folder, printer, or Active Directory object, described by a distinct, named set of attributes. For example, the attributes of a File object include its name, location, and size; the attributes of an Active Directory User object might include the user's first name, last name, and e-mail address.

For OLE and ActiveX, an object can also be any piece of information that can be linked to, or embedded into, another object.

See also: Active Directory; attribute; child object; parent object

OEM

See definition for: original equipment manufacturer (OEM)

OEM branding

To incorporate a company name, logo, support information, and Help files into the Microsoft Windows installation.

OEM ISP sign-up offer

A set of HTML pages created by either the OEM or a third-party company that lets end users sign up for Internet access from a particular Internet service provider (ISP). You can incorporate these pages into Windows Welcome, or include a shortcut to the first page of the OEM link on the Start menu.

See also: OEM link; Windows Welcome

OEM License Agreement

A legal agreement between Microsoft Licensing, Inc., and OEMs, regarding the terms of preinstalling, customizing, and distributing Microsoft Windows XP. For system builders, the corresponding agreement is affixed to the side of every OEM Distribution Pack. By opening the package, you agree to all the terms of the Microsoft OEM System Builder Agreement. For royalty OEMs, the license agreement is a signed contract. The specific requirements and customization options that apply to either or both license agreements are documented in the OPK User's Guide.

See also: royalty OEM; system builder

OEM link

A link on the Start menu where OEMs can place any desired links or shortcuts.

OEM Preinstallation Kit (OPK)

A set of tools, documentation, and samples that enable OEMs to preinstall Windows efficiently on new computers according to the terms of the OEM Licensing Agreement.

Oem.chm

The HTML Help file that you customize to provide OEM-specific support information in Windows Help.

Oeminfo.ini

A file used to provide required OEM information, such as company name, computer model, company telephone number, and customer support information.

OnNow

See definition for: Advanced Configuration and Power Interface (ACPI)

OOBE

See definition for: Windows Welcome

OpenType fonts

Outline fonts that are rendered from line and curve commands, and can be scaled and rotated. OpenType fonts are clear and readable in all sizes and on all output devices supported by Windows. OpenType is an extension of TrueType font technology.

See also: font

OPK

See definition for: OEM Preinstallation Kit (OPK)

original equipment manufacturer (OEM)

A company that typically purchases computer components from other manufacturers, uses the components to build a personal computer, preinstalls Windows onto that computer, and then sells the computer to the public.

Out-Of-Box Experience (OOBE)

See definition for: Windows Welcome

P

paging file

A hidden file or files on the hard disk that Windows uses to hold parts of programs and data files that do not fit in memory. The paging file and physical memory, or random access memory (RAM), comprise virtual memory. Windows moves data from the paging file to memory as needed and moves data from memory to the paging file to make room for new data. Also known as a swap file.

parallel device

A device that uses a parallel connection.

parent object

An object in which another object resides. For example, a folder is a parent object in which a file, or child object, resides. An object can be both a parent and a child object. For example, a subfolder that contains files is both the child of the parent folder and the parent folder of the files.

See also: child object; object

partition

A portion of a physical disk that functions as though it were a physically separate disk. After you create a partition, you must format it and assign it a drive letter before you can store data on it.

On basic disks, partitions are known as basic volumes, which include primary partitions and logical drives. On dynamic disks, partitions are known as dynamic volumes, which include simple, striped, spanned, mirrored, and RAID-5 volumes.

See also: basic disk; basic volume; dynamic volume; extended partition; primary partition; system partition

partition boot sector

A portion of a hard disk partition that contains information about the disk's file system and a short machine language program that loads the Windows operating system.

See also: partition

passport

A single sign-in service that lets you use a single name and password on multiple participating Web sites.

password

A security measure used to restrict logon names to user accounts and access to computer systems and resources. A password is a string of characters that must be provided before a logon name or an access is authorized. A password can be made up of letters, numbers, and symbols, and it is case sensitive.

See also: user account

PC Card

A removable device, approximately the size of a credit card, that can be plugged into a Personal Computer Memory Card International Association (PCMCIA) slot in a portable computer. PCMCIA devices can include modems, network cards, and hard disk drives.

See also: modem (modulator/demodulator)

PC Health

A suite of technologies and features focused on providing end users with improved technical support by enabling web-based support solutions. PC Health also provides better operating system reliability, and an enhanced end-user experience, by providing easier access to help content and support services.

PCMCIA device

A removable device, approximately the size of a credit card, that can be plugged into a PCMCIA slot in a portable computer. PCMCIA devices can include modems, network adapters, and hard disk drives.

Some PCMCIA cards can be connected to and disconnected from your computer without restarting it. Before you remove the PCMCIA card, however, you should use the Add Hardware Wizard to notify Windows that you are doing so. Windows will then notify you when you can remove the device.

permission

A rule associated with an object to regulate which users can gain access to the object and in what manner. Permissions are assigned or denied by the object's owner.

See also: object

PIC

Programmable Interrupt Controller. This type of hardware cannot be used in computers with multiple processes, and the processing speed is slower than similar APIC hardware.

piracy

Unauthorized copying, distribution, and use of computer software, or software theft.

pixels

An abbreviation for picture elements. The minimum raster display element, represented as a point, with a specified color or intensity level. One way to measure picture resolution is by the number of pixels used to create images.

Plug and Play

A set of specifications developed by Intel Corporation that enables a computer to detect and configure a device automatically and install the appropriate device drivers.

See also: universal serial bus (USB)

Plug and Play BIOS

A BIOS with responsibility for configuring Plug and Play cards and system-board devices during system power up. Provides runtime configuration services for system board devices after startup.

See also: Advanced Configuration and Power Interface (ACPI); BIOS; system board

Point-to-Point Protocol (PPP)

An industry standard suite of protocols for the use of point-to-point links to transport multiprotocol datagrams. PPP is documented in RFC 1661.

See also: remote access; Transmission Control Protocol/Internet Protocol (TCP/IP)

Point-to-Point Tunneling Protocol (PPTP)

Networking technology that supports multiprotocol virtual private networks (VPNs), enabling remote users to access corporate networks securely across the Internet or other networks by dialing into an Internet service provider (ISP) or by connecting directly to the Internet. PPTP tunnels, or encapsulates, Internet Protocol (IP), Internetwork Packet Exchange (IPX), or NetBIOS Extended User Interface (NetBEUI) traffic inside IP packets. This means that users can remotely run applications that depend on particular network protocols.

See also: Internet Protocol (IP); Internetwork Packet Exchange (IPX); NetBIOS Extended User Interface (NetBEUI)

populate

To import prepared data using a software procedure rather than the end user entering the information.

port

A connection point on your computer where you can connect devices that pass data into and out of a computer. For example, a printer is typically connected to a parallel port (also called an LPT port), and a modem is typically connected to a serial port (also called a COM port).

See also: universal serial bus (USB)

POST

See definition for: power-on self test (POST)

power management

Mechanisms in software and hardware to minimize system power consumption, manage system thermal limits, and maximize system battery life. Power management involves trade-offs among system speed, noise, battery life, processing speed, and power consumption.

power-on self test (POST)

A set of routines stored in read-only memory (ROM) that tests various system components such as RAM, the disk drives, and the keyboard, to see if they are properly connected and operating. If problems are found, these routines alert the user with a series of beeps or a message, often accompanied by a diagnostic numeric value. If the POST is successful, it passes control to the bootstrap loader.

See also: bootstrap loader

Preboot Execution Environment

DHCP-based remote boot technology used to boot or install an operating system on a client computer from a remote server. A RIS Server is an example of a PXE Server.

precached ISP signup offer

See definition for: OEM ISP sign-up offer

precomposed character

A single character that represents a sequence of characters, usually a combination of a base character and one or more diacritics.

preconfigured ISP signup

Configuring the operating system during the manufacturing process to use a specific account for access to the Internet.

predefined key

A key that represents one of the main divisions of the registry. Each predefined key is displayed in a separate Registry Editor window, with the key's name appearing in the window's title bar. For example, HKEY_CLASSES_ROOT is a predefined key.

See also: hive; key; registry

preinstall

To install and configure Windows XP on new computers that are then distributed to end users.

preinstallation

The act of installing and configuring Windows XP on new computers that are then distributed to end users.

Primary disk

The hard disk drive that contains the system and boot partitions used to start Windows.

See also: boot partition; system partition

primary partition

A type of partition that you can create on basic disks. A primary partition is a portion of a physical disk that functions as though it were a physically separate disk. On basic master boot record (MBR) disks, you can create up to four primary partitions on a basic disk, or three primary partitions and an extended partition with multiple logical drives. On basic GUID partition table (GPT) disks, you can create up to 128 primary partitions. Also known as a volume.

See also: basic disk; extended partition; GUID partition table (GPT); logical drive; master boot record (MBR); partition

private key

The secret half of a cryptographic key pair that is used with a public key algorithm. Private keys are typically used to decrypt a symmetric session key, digitally sign data, or decrypt data that has been encrypted with the corresponding public key.

See also: public key; public key encryption

product activation

See definition for: Windows Product Activation (WPA)

Product Key

A 25-character, alpha-numeric string. Customers must enter this string to activate their installation of Windows. The product key is located on the certificate of authenticity, which is attached to the computer chassis.

property set

A method defined to set and get properties on a driver. Each property set has a unique identifier, which represents types of related information and is used to access the property set.

Protective MBR

The first sector of a GUID partition table (GPT) disk that is structured like the first sector of a master boot record (MBR) disk to prevent x86-based disk utilities from destroying GPT partitions. The Protective MBR contains one partition that reserves the entire space used on the disk by GPT partitions.

See also: Extensible Firmware Interface (EFI); GUID partition table (GPT); master boot record (MBR); x86

protocol

A set of rules and conventions for sending information over a network. These rules govern the content, format, timing, sequencing, and error control of messages exchanged among network devices.

See also: Internet Protocol (IP); Transmission Control Protocol/Internet Protocol (TCP/IP)

proxy

A firewall and content cache server that provides Internet security and improves network performance.

public key

The nonsecret half of a cryptographic key pair that is used with a public key algorithm. Public keys are typically used when encrypting a session key, verifying a digital signature, or encrypting data that can be decrypted with the corresponding private key.

See also: key; private key; public key encryption

public key encryption

A method of encryption that uses two encryption keys that are mathematically related. One key is called the private key and is kept confidential. The other is called the public key and is freely given out to all potential correspondents. In a typical scenario, a sender uses the receiver's public key to encrypt a message. Only the receiver has the related private key to decrypt the message. The complexity of the relationship between the public key and the private key means that, provided the keys are long enough, it is computationally infeasible to determine one from the other. Also called asymmetric encryption.

See also: encryption; private key; public key

public key infrastructure (PKI)

The laws, policies, standards, and software that regulate or manipulate certificates and public and private keys. In practice, it is a system of digital certificates, certification authorities, and other registration authorities that verify and authenticate the validity of each party involved in an electronic transaction. Standards for PKI are still evolving, even though they are being widely implemented as a necessary element of electronic commerce.

See also: certificate; certification authority (CA); public key

PXE

See definition for: Preboot Execution Environment

PXE protocol

An extension to the DHCP protocol that enables information to be sent to network-bootable systems and enables these systems to find RIS servers.

Q

QFE

Quick-Fix Engineering. This is usually referred to as a hotfix.

See also: hotfix

Qmark character

The animated Microsoft agent character in Windows Welcome.

quiet mode

Running a command-line application so that it does not display confirmation messages or any other user interface items that normally appear on screen. The switch for quiet mode is typically /q.

R

RAID-5 volume

A fault-tolerant volume with data and parity striped intermittently across three or more physical disks. Parity is a calculated value that is used to reconstruct data after a failure. If a portion of a physical disk fails, Windows recreates the data that was on the failed portion from the remaining data and parity. You can create RAID-5 volumes only on dynamic disks on computers running the Windows 2000 Server or Windows Server 2003 families of operating systems. You cannot mirror or extend RAID-5 volumes. In Windows NT 4.0, a RAID-5 volume was known as a striped set with parity.

See also: dynamic disk; dynamic volume; fault tolerance

RAM

See definition for: random access memory (RAM)

random access memory (RAM)

Memory that can be read from or written to by a computer or other devices. Information stored in RAM is lost when the computer is turned off.

ranking

Windows XP ranks drivers to determine which is the best for a device. The lower the rank, the better the match of the driver to the device.

read-only memory (ROM)

A semiconductor circuit that contains information that cannot be modified.

rebinding state

A state used by DHCP clients to extend and renew their address lease when the current lease is close to expiring. In this state, the client broadcasts to the network to locate any DHCP server that can either renew or replace its currently leased configuration. The rebinding state begins when 87.5 percent of the client's lease time has elapsed.

See also: Dynamic Host Configuration Protocol (DHCP); lease

reboot

To restart a computer by reloading the operating system. This can be done by performing either a cold boot, such as turning the computer off and then back on, or a warm boot, such as turning the computer off by typically pressing CTRL + ALT + DEL, clicking Shut Down, and then clicking Restart.

Recovery Console

A command-line interface that provides a limited set of administrative commands that are useful for repairing a computer.

See also: NTFS file system

recovery media

Media provided by the OEM to the customer that enables the customer to repair or reinstall their installation of Windows.

reduced instruction set computing

A type of microprocessor design that focuses on rapid and efficient processing of a relatively small set of instructions. RISC architecture limits the number of instructions that are built into the microprocessor, but optimizes each so it can be carried out very rapidly{bmct emdash.bmp}usually within a single clock cycle.

Redundant Array of Independent Disks (RAID)

A method used to standardize and categorize fault-tolerant disk systems. RAID levels provide various mixes of performance, reliability, and cost. Some servers provide three of the RAID levels: Level 0 (striping), Level 1 (mirroring), and Level 5 (RAID-5).

See also: fault tolerance; RAID-5 volume

reference computer

See definition for: technician computer

registration

Providing the user's name, address, and other demographic information to Microsoft or to both Microsoft and the OEM. Registration information is commonly used for marketing purposes. Registration is different from activation; a user may activate their installation of Windows without providing any identification or demographic information.

See also: Windows Product Activation (WPA)

registry

A database repository for information about a computer's configuration. The registry contains information that Windows continually references during operation, such as:

  • Profiles for each user
  • The programs installed on the computer and the types of documents that each can create
  • Property settings for folders and program icons
  • What hardware exists on the system
  • Which ports are being used

The registry is organized hierarchically as a tree, and it is made up of keys and their subkeys, hives, and entries.

See also: hive; key; subkey

registry key

An identifier for a record or group of records in the registry.

remote access

Part of the integrated Routing and Remote Access service that provides remote networking for telecommuters, mobile workers, and system administrators who monitor and manage servers at multiple branch offices. Users can use Network Connections to dial in to remotely access their networks for services such as file and printer sharing, electronic mail, scheduling, and SQL database access.

See also: remote access server; service

remote access server

A Windows-based computer running the Routing and Remote Access service and configured to provide remote access.

See also: remote access

Remote Installation Server (RIS)

An optional component that remotely installs Windows XP Professional. RIS installs the operating system on remote boot-enabled client computers by connecting the computer to the network, starting the client computer, logging on with a valid user account, and copying an operating system image to the client computer.

remotely administered server

A server that you can administer by using a different computer. You typically access this type of server by using a network connection. A remotely administered server can have a local keyboard, mouse, or video card and monitor. If it does not have these peripherals attached, it is also known as a headless server. Such servers are often housed in a physically secure location.

See also: server

replica

In Active Directory replication, one instance of a logical Active Directory partition that is synchronized by means of replication between domain controllers that hold copies of the same directory partition. Replica can also refer to an instance of an object or attribute in a distributed directory.

In the File Replication service (FRS), a computer that has been included in the configuration of a specific replica set.

reseal

To prepare the operating system for delivery to the customer by clearing the event log, resetting the time clock for Windows Product Activation, and configuring the first-run experience to run the next time Windows starts. Run Sysprep -reseal as the final step in your manufacturing process.

resource

Generally, any part of a computer system or network, such as a disk drive, printer, or memory, that can be allotted to a running program or a process.

For Device Manager, any of four system components that control how the devices on a computer work. These four system resources are interrupt request (IRQ) lines, direct memory access (DMA) channels, input/output (I/O) ports, and memory addresses.

For server clusters, a physical or logical entity that is capable of being managed by a cluster, brought online and taken offline, and moved between nodes. A resource can be owned only by a single node at any point in time.

See also: input/output (I/O) port; interrupt request (IRQ) lines; memory address; node; server cluster

RIS

See definition for: Remote Installation Server (RIS)

RISC

See definition for: reduced instruction set computing

root

The highest or uppermost level in a hierarchically organized set of information. The root is the point from which further subsets are branched in a logical sequence that moves from a broad or general focus to narrower perspectives.

See also: root certificate; root certification authority

root certificate

A self-signed certification authority certificate. It is called a root certificate because it is the certificate for the root authority. The root authority must sign its own certificate because by definition there is no higher certifying authority in the certification hierarchy.

See also: certificate; certification authority (CA); root certification authority

root certification authority

The most trusted certification authority (CA), which is at the top of a certification hierarchy. The root CA has a self-signed certificate. Also called the root authority.

See also: certification authority (CA); root

routing

The process of forwarding a packet through an internetwork from a source host to a destination host.

royalty OEM

A computer original equipment manufacturer who has signed a license agreement directly with Microsoft Licensing, Inc. Royalty OEMs receive a "golden master" copy of Windows from Microsoft. The royalty OEM may customize Windows as described in the OPK, their license agreement, or a signed addendum.

RunOnce application

An application that is configured to run the next time the computer is restarted. The application does not run after any subsequent reboots of the system.

S

SBSI

See definition for: Step-by-Step Interactive (SBSI)

script

A type of program consisting of a set of instructions to an application or tool program. A script usually expresses instructions by using the application's or tool's rules and syntax, combined with simple control structures such as loops and if/then expressions. "Batch program" is often used interchangeably with "script" in the Windows environment.

SCSI

See definition for: small computer system interface (SCSI)

seal

See definition for: reseal

security ID (SID)

A data structure of variable length that identifies user, group, and computer accounts. Every account on a network is issued a unique SID when the account is first created. Internal processes in Windows refer to an account's SID rather than the account's user or group name.

See also: group account; user account; user name

serial (COM) device

A string of up to 256 characters with five mandatory fields and ten optional fields, as defined in Section 3 of the Plug and Play External COM Device Specification, v. 1.0.

server

In general, a computer that provides shared resources to network users.

See also: client

server cluster

A group of computers, known as nodes, working together as a single system to ensure that mission-critical applications and resources remain available to clients. A server cluster presents the appearance of a single server to a client.

See also: cluster; node

service

A program, routine, or process that performs a specific system function to support other programs, particularly at a low (close to the hardware) level. When services are provided over a network, they can be published in Active Directory, facilitating service-centric administration and usage. Some examples of services are the Security Accounts Manager service, File Replication service, and Routing and Remote Access service.

service mark

A mark used in the sale or advertising of services to identify and distinguish them from services provided by another company.

Service Pack

A software upgrade to an existing software distribution that contains updated files consisting of patches and hot fixes.

Setup Manager

A utility for creating and modifying answer files and configuration sets.

See also: answer file; configuration set

Setupapi.log

A log file provides valuable information for troubleshooting and debugging Setup, device installation, and related issues. The information stored in the log file includes errors, warnings, and related information from Windows Setup, including time information.

Setupcl.exe

An executable program invoked by Sysprep.exe that recognizes security IDs (SIDs). It must reside in the same folder as Sysprep.exe.

See also: security ID (SID); Sysprep.exe

signature

See definition for: digital signature

signed driver

A driver that meets the criteria of the Windows Logo Program. For performance and stability, Microsoft strongly recommends that you use only signed drivers for new or updated drivers.

See also: Windows Logo Program

Simple Mail Transfer Protocol (SMTP)

A member of the TCP/IP suite of protocols that governs the exchange of electronic mail between message transfer agents.

See also: protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

Simple TCP/IP Services

Four TCP/IP services: Character Generator, Daytime Discard, Echo, and Quote of the Day.

See also: service; Transmission Control Protocol/Internet Protocol (TCP/IP)

simple volume

A dynamic volume made up of disk space from a single dynamic disk. A simple volume can consist of a single region on a disk or multiple regions of the same disk that are linked together. If the simple volume is not a system volume or boot volume, you can extend it within the same disk or onto additional disks. If you extend a simple volume across multiple disks, it becomes a spanned volume. You can create simple volumes only on dynamic disks. Simple volumes are not fault tolerant, but you can mirror them to create mirrored volumes on computers running the Windows 2000 Server or Windows Server 2003 families of operating systems.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; spanned volume

single sign-on

A process that enables a user with a domain account to log on to a network once, using a password or smart card, and to gain access to any computer in the domain.

See also: domain; smart card

single-byte character set

A character encoding in which each character is represented by 1 byte. Single byte character sets are mathematically limited to 256 characters.

skin

A customized user interface that overlays an existing user interface.

SKU

Shelf keeping unit. A particular product; in this case, a particular edition of Windows XP.

small computer system interface (SCSI)

A standard high-speed parallel interface defined by the American National Standards Institute (ANSI). A SCSI interface is used for connecting microcomputers to peripheral devices, such as hard disks and printers, and to other computers and local area networks (LANs).

See also: device; local area network (LAN)

smart card

A credit card–sized device that is used with an access code to enable certificate-based authentication and single sign-on to the enterprise. Smart cards securely store certificates, public and private keys, passwords, and other types of personal information. A smart card reader attached to the computer reads the smart card.

See also: authentication; single sign-on; smart card reader

smart card reader

A device that is installed in computers to enable the use of smart cards for enhanced security features.

See also: smart card

snap-in

A type of tool that you can add to a console supported by Microsoft Management Console (MMC). A stand-alone snap-in can be added by itself; an extension snap-in can be added only to extend the function of another snap-in.

See also: Microsoft Management Console (MMC)

spacing character

A character with a non-zero width.

spanned volume

A dynamic volume consisting of disk space on more than one physical disk. You can increase the size of a spanned volume by extending it onto additional dynamic disks. You can create spanned volumes only on dynamic disks. Spanned volumes are not fault tolerant and cannot be mirrored.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; simple volume

stage

Copy the directories and files to be installed to a destination computer, but do not configure any registry settings.

See also: attach; destination computer; detach

standalone server

A computer that runs Windows 2000 Server but does not participate in a domain. A standalone server has only its own database of end users, and it processes logon requests by itself. It does not share account information with any other computer and cannot provide access to domain accounts.

See also: domain

Standards and formats

A Regional and Language Options setting that determines the formats used to display dates, times, currency, numbers, and the sorting order of text. Formerly known as user locale.

Step-by-Step Interactive (SBSI)

Interactive training published by Microsoft Press that is integrated into Windows XP Help and Support Center.

striped volume

A dynamic volume that stores data in stripes on two or more physical disks. Data in a striped volume is allocated alternately and evenly (in stripes) across the disks. Striped volumes offer the best performance of all the volumes that are available in Windows, but they do not provide fault tolerance. If a disk in a striped volume fails, the data in the entire volume is lost. You can create striped volumes only on dynamic disks. Striped volumes cannot be mirrored or extended.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume

subkey

An element of the registry that contains entries or other subkeys. A tier of the registry that is immediately below a key or a subtree (if the subtree has no keys).

See also: key; registry; subtree

subtree

Any node within a tree, along with any selection of connected descendant nodes.

The highest level of the registry (for example, HKEY_LOCAL_MACHINE).

See also: key; node; registry; subkey

SVGA

Super VGA. A video standard established by BESA to provide high-resolution color display on IBM-compatible computers.The most commonly implemented SVGA standard is 1024 x 768 pixels color resolution.

synchronous

Each application or command runs in the order listed, and each item must finish before the next command is run.

Syspart

A process that executes through an optional parameter of Winnt32.exe. Used for clean installations to computers that have dissimilar hardware. This automated installation method reduces deployment time by eliminating the file-copy phase of Setup.

Sysprep

A tool that prepares the hard disk on a source computer for duplication to destination computers and then runs a non-Microsoft disk-imaging process. This automated installation method is used when the hard disk on the master computer is identical to those of the target computers.

See also: destination computer; first-run experience; security ID (SID)

Sysprep.exe

The System Preparation utility that uses the Sysprep.inf answer file to prepare a system disk image for duplication.

Sysprep.inf

An optional answer file used by Sysprep that automates Mini-Setup and further customizes the installed operating system.

See also: answer file

system board

Also called a motherboard or planar. The primary circuit board in a computer that contains most of the basic components of the system.

system builder

Anyone who purchases an OEM Distribution Pack of Windows (available from distributors) and preinstalls Windows onto new computers. System builders are subject to the terms of the Microsoft OEM System Builder Agreement attached to the outside of the OEM Distribution Pack.

system context

The state of Windows after it first starts when some system services are loaded but no user is logged in and per-user settings are not available.

system devices

Devices on a system board, such as interrupt controllers, keyboard controller, real-time clock, DMA page registers, DMA controllers, memory controllers, FDC, IDE ports, serial and parallel ports, PCI bridges, and so on. In today's PCs, these devices are typically integrated in the supporting chip set.

system drive

The drive letter of the mass-storage device (usually a hard disk) where Windows is installed.

system engineer

A Microsoft employee who assists one or more specific royalty OEMs as they prepare to manufacture computers that will use the version of Microsoft Windows that is currently under development.

System File Protection

See definition for: Windows File Protection (WFP)

system locale

See definition for: Language for non-Unicode programs

system partition

The partition that contains the hardware-specific files needed to load Windows (for example, Ntldr, Osloader, Boot.ini, Ntdetect.com). The system partition can be, but does not have to be, the same as the boot partition.

See also: boot partition; partition

System Restore

A tool that tracks changes to your computer and creates a restore point when it detects the beginning of a change. You can use the System Restore Wizard to select a restore point to restore your computer to an earlier state when your computer was functioning the way you like.

system-locked preinstallation (SLP)

Technology related to Windows Product Activation (WPA) that helps restrict legitimately licensed operating system software to use with the computer system upon which it was originally distributed by a royalty OEM, all in accordance with the license rights granted in the applicable End-User License Agreement. Details regarding system-locked preinstallation are available to royalty OEMs in a separate white paper.

systemroot

The path and folder name where the Windows system files are located. Typically, this is C:\Windows, although you can designate a different drive or folder when you install Windows. You can use the value %systemroot% to replace the actual location of the folder that contains the Windows system files. To identify your systemroot folder, click Start, click Run, type %systemroot%, and then click OK.

T

TAM

See definition for: technical account manager (TAM)

TAPI

See definition for: Telephony API (TAPI)

target computer

See definition for: destination computer

taxonomy

In the Windows XP Help and Support Center, the classification system that organizes Help topics into specific categories.

TCP/IP

See definition for: Transmission Control Protocol/Internet Protocol (TCP/IP)

technical account manager (TAM)

A Microsoft employee who provides technical assistance to one or more specific royalty OEMs as they manufacture computers installed with a released version of Microsoft Windows.

technician computer

The computer that you install Setup Manager on. Normally, the configuration sets and the distribution share are also located on this computer.

See also: configuration set; distribution share; Setup Manager

telephony

Telephone technology; voice, fax, or modem transmissions based on either the conversion of sound into electrical signals or wireless communication by means of radio waves.

Telephony API (TAPI)

An application programming interface (API) used by communications programs to work with telephony and network services. Communications programs like HyperTerminal and Phone Dialer use TAPI to dial, answer, and route telephone calls on conventional telephony devices, including PBXs, modems, and fax machines. TAPI 3.0 also provides Internet Protocol (IP) telephony support, which Phone Dialer and other programs use to transmit, route, and control real-time audio and video signals over IP-based networks such as the Internet.

See also: application programming interface (API); Internet Protocol (IP); modem (modulator/demodulator); service

text-mode Setup

The second of the three stages of Setup, where the basic hardware of the computer (CPU, motherboard, hard disk controllers, file systems, and memory) is determined, the base operating system necessary to continue is installed, and specified folders are created.

third-party drivers

Device drivers that are not included in Driver.cab.

See also: Driver.cab

time stamp

A certification specifying that a particular message existed at a specific time and date. In a digital context, trusted third parties generate a trusted time stamp for a particular message by having a time stamping service append a time value to a message and then digitally signing the result.

See also: digital signature; service

topology

The physical layout of computers, cables, switches, routers, and other components of a network. Topology also refers to the underlying network architecture, such as Ethernet or Token Ring.

In Active Directory replication, the set of connections that domain controllers use to replicate information among themselves.

See also: domain controller

trail byte

The byte value that is the second half of a double-byte character.

Transmission Control Protocol/Internet Protocol (TCP/IP)

A set of networking protocols widely used on the Internet that provides communications across interconnected networks of computers with diverse hardware architectures and various operating systems. TCP/IP includes standards for how computers communicate and conventions for connecting networks and routing traffic.

See also: Internet Protocol (IP); protocol

Txtsetup.oem

A text file identifying supported hardware components, the files to copy from the distribution disk for the hardware component, and listing the registry keys and values to create for the hardware component. This is used only during text-mode Setup.

U

UCS Transformation Format 8 (UTF-8)

A character set for protocols evolving beyond the use of ASCII. The UTF-8 protocol provides for support of extended ASCII characters and translation of UCS-2, an international 16-bit Unicode character set. UTF-8 enables a far greater range of names than can be achieved using ASCII or extended ASCII encoding for character data.

See also: American Standard Code for Information Interchange (ASCII); Unicode

unallocated space

Available disk space that is not allocated to any volume. The type of volume that you can create on unallocated space depends on the disk type. On basic disks, you can use unallocated space to create primary or extended partitions. On dynamic disks, you can use unallocated space to create dynamic volumes.

See also: basic disk; dynamic disk; extended partition; logical drive; object; partition; primary partition

unattach

See definition for: detach

Unattend.txt

The generic name for the Windows Setup answer file. In the CD boot preinstallation method, Unattend.txt must be named Winnt.sif.

See also: answer file; CD boot; Windows Setup; Winnt.exe

unattended Setup

An automated, hands-free method of installing Windows. During installation, unattended Setup uses an answer file to supply data to Setup instead of requiring that an administrator or end user interactively provide the answers.

UNC

See definition for: Universal Naming Convention (UNC)

uni-processor

A computer with a single processor.

See also: multiprocessor

Unicode

A character encoding standard developed by the Unicode Consortium that represents almost all of the written languages of the world. The Unicode character repertoire has multiple representation forms, including UTF-8, UTF-8, and UTF-32. Most Windows interfaces use the UTF-16 form.

See also: American Standard Code for Information Interchange (ASCII); UCS Transformation Format 8 (UTF-8)

Universal Naming Convention (UNC)

A convention for naming files and other resources beginning with two backslashes (\), indicating that the resource exists on a network computer. UNC names conform to the \\servername\sharename syntax, where servername is the server's name and sharename is the name of the shared resource. The UNC name of a directory or file can also include the directory path after the share name, by using the following syntax: \\servername\sharename\directory\filename.

universal serial bus (USB)

An external bus that supports Plug and Play installation. Using USB, you can connect and disconnect devices without shutting down or restarting your computer. You can use a single USB port to connect up to 127 peripheral devices, including speakers, telephones, CD-ROM drives, joysticks, tape drives, keyboards, scanners, and cameras. A USB port is usually located on the back of your computer near the serial port or parallel port.

See also: bus; Plug and Play; port

USB

See definition for: universal serial bus (USB)

user account

In Active Directory, an object that consists of all the information that defines a domain user, which includes user name, password, and groups in which the user account has membership. User accounts can be stored in either Active Directory or on your local computer.

For computers running Windows XP Professional and member servers running Windows Server 2003, use Local Users and Groups to manage local user accounts. For domain controllers running Windows Server 2003, use Active Directory Users and Computers to manage domain user accounts.

See also: Active Directory; object; password; user name

user interface language

The language in which the operating system displays its menus, help files, and dialog boxes.

user locale

See definition for: Standards and formats

user mode

The processing mode in which applications run.

user name

A unique name identifying a user account to Windows. An account's user name must be unique among the other group names and user names within its own domain or workgroup.

See also: domain; user account; workgroup

user password

The password stored in each user's account. Each user generally has a unique user password and must type that password when logging on or accessing a server.

See also: password; user account

user principal name (UPN)

A user account name (sometimes referred to as the user logon name) and a domain name identifying the domain in which the user account is located. This is the standard usage for logging on to a Windows domain. The format is as follows: someone@example.com (as for an e-mail address).

See also: domain; domain name

user rights

Tasks that a user is permitted to perform on a computer system or domain. There are two types of user rights: privileges and logon rights. An example of a privilege is the right to shut down the system. An example of a logon right is the right to log on to a computer locally. Both types are assigned by administrators to individual users or groups as part of the security settings for the computer.

See also: domain

UTF-8

See definition for: UCS Transformation Format 8 (UTF-8)

V

value added reseller (VAR)

A company that resells hardware and software packages to developers and/or end users.

VAR

See definition for: value added reseller (VAR)

VGA

Video graphics array. A video adapter that supports 640 x 480 pixels color resolution. VGA is the video display standard for boot devices under Windows operating systems and provides medium-resolution text and graphics.

volume mount point

A point of access to a volume that users and applications can use to unify disparate file systems into one logical system.

volume set

A volume that consists of disk space on one or more physical disks. A volume set is created by using basic disks and is supported only in Windows NT 4.0 or earlier. Volume sets were replaced by spanned volumes, which use dynamic disks.

See also: basic disk; dynamic disk; partition; spanned volume

W

WDL

See definition for: Windows Driver Library (WDL)

Web server

A computer that is maintained by a system administrator or Internet service provider (ISP) and that responds to requests from a user's browser.

See also: Internet service provider (ISP)

WHQL

See definition for: Windows Hardware Quality Labs (WHQL)

wide area network (WAN)

A communications network connecting geographically separated computers, printers, and other devices. A WAN enables any connected device to interact with any other on the network.

See also: device; local area network (LAN)

Winbom.ini

An .ini file that provides a bill-of-materials to incorporate into the Windows installation. Winbom.ini can control different points of the installation and configuration process: for example, it can control Sysprep during Factory mode, Windows preinstallation when starting from the Windows Preinstallation Environment (WinPE), or Windows XP configuration during Windows Welcome.

Windows Driver Library (WDL)

A distribution point on www.microsoft.com for third-party drivers that fulfill the Windows Logo requirements.

Windows File Protection (WFP)

A feature that runs in the background and protects your system files from being overwritten. When a file in a protected folder is modified, WFP determines whether the new file is the correct Microsoft version or whether the file is digitally signed. If not, the modified file is replaced with a valid version.

Windows Hardware Quality Labs (WHQL)

Provides compatibility testing services to test hardware and drivers for Windows operating systems.

Windows Installer

An operating system service that enables the operating system to manage the installation process. Windows Installer technologies are divided into two parts that work in combination: a clientside installer service (Msiexec.exe) and a package (.msi) file. Windows Installer uses the information contained within a package file to install the application.

Windows Internet Name Service (WINS)

A software service that dynamically maps IP addresses to computer names (network basic input/output system (NetBIOS) names). This enables users to access resources by name instead of requiring them to use IP addresses that are difficult to recognize and remember.

See also: IP address; network basic input/output system (NetBIOS); resource; service

Windows Logo Program

A certification program to help customers identify systems, hardware, and software that meet a baseline definition of platform features and quality goals and ensure a good user experience of Windows.

See also: signed driver

Windows Management Instrumentation (WMI)

A management infrastructure in Windows that supports monitoring and controlling system resources through a common set of interfaces and provides a logically organized, consistent model of Windows operation, configuration, and status.

See also: resource

Windows PE

See definition for: Windows Preinstallation Environment (Windows PE)

Windows Preinstallation Environment (Windows PE)

A minimal Win32 operating system with limited services, built on the Windows XP Professional kernel. Windows PE is used only in the preinstallation and deployment of Windows.

Windows Product Activation (WPA)

A technology that reduces software piracy by requiring that each installation of a Windows product be activated with Microsoft, either through the Internet or by telephone. A unique product key is required for each installation of Windows, but Microsoft does not request or collect any information other than the Product Key during the installation. The end user may reinstall Windows using the same Product Key on the same computer as many times as necessary, but it cannot be used to install Windows on another computer. The end user can make incremental hardware upgrades to the computer. However, if the hardware is significantly altered, the end user will be required to reactivate the installation of Windows.

Windows Setup

The program that installs the Windows operating system.

Windows Welcome

The end user's first experience of Microsoft Windows in Windows XP Home Edition and Windows XP Professional. Through a series of full-screen, HTML-based pages, Windows Welcome quickly and easily takes end users through the final steps of setting up their personal computer. End users are then prompted for any additional information that is needed to personalize their settings, which can include regional settings, network configuration (where applicable), and Internet connection settings. Windows Welcome is formerly known as Out-Of-Box Experience (OOBE).

Winnt.exe

A command-line utility used to start an unattended Windows XP Setup from computers running MS-DOS, Windows 3.1, or Windows for Workgroups.

Winnt.sif

The answer file that contains information used by Setup when you install Windows using the CD boot method.

See also: answer file; CD boot

Winnt32.exe

A command-line utility used to start an unattended Windows XP Setup from computers running Windows 95, Windows 98, Windows NT, Windows 2000, or Windows XP.

WINS

See definition for: Windows Internet Name Service (WINS)

Winsock

Windows Sockets. An application programming interface (API) standard for software that provides a TCP/IP interface under Windows.

See also: application programming interface (API); Transmission Control Protocol/Internet Protocol (TCP/IP)

WMI

See definition for: Windows Management Instrumentation (WMI)

workgroup

A simple grouping of computers, intended only to help users find such things as printers and shared folders within that group. Workgroups in Windows do not offer the centralized user accounts and authentication offered by domains.

See also: authentication; domain; user account

World Wide Web

A system for exploring the Internet by using hyperlinks. When you use a Web browser, the Web appears as a collection of text, pictures, sounds, and digital movies.

See also: internet

X

x64

Refers to the 64-bit computing architectures supported by Windows, for example, Itanium and AMD 64-bit computing architectures.

x86

Refers to microprocessors that have or emulate the 32-bit Intel processor architecture.

Y

There are no glossary terms that begin with this letter.

Z

There are no glossary terms that begin with this letter.


Legal Notices

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2004 Microsoft Corporation. All rights reserved.

Active Desktop, ActiveX, Authenticode, BackOffice, ClearType, DirectX, FrontPage, Hotmail, JScript, Microsoft, Microsoft Press, MS-DOS, MSDN, MSN, Visual Basic, Win32, Win64, Windows, Windows logo, Windows Media, Windows NT, and Windows Start logo are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries/regions.

This product contains graphics filter software; this software is based in part on the work of the Independent JPEG Group.

TrueType is a registered trademark of Apple, Inc.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


Printing the Documentation

Using the Print command of the HTML Help viewer, you can print a single topic or all subtopics of a heading.

To print topics from this documentation

  1. Select a topic or heading (book) in the Contents tab.
  2. Click the Print button in the toolbar and follow the messages.

    —OR—

    3. Right-click the selected book, click Print, and follow the messages.


Microsoft Windows Preinstallation Reference

banner1 banner2

Windows XP

This reference helps you to preinstall, customize, and deploy:

Windows XP Home Edition with Service Pack 2 (SP2)
Windows XP Professional with Service Pack 2 (SP2)

Windows Server 2003 Family

You may also use this reference to preinstall, customize, and deploy these versions of Windows:

Windows Server 2003, Standard Edition, with Service Pack 1 (SP1)
Windows Server 2003, Enterprise Edition, with Service Pack 1 (SP1)
Windows Server 2003, Datacenter Edition, with Service Pack 1 (SP1)
Windows Server 2003, Web Edition, with Service Pack 1 (SP1)
Windows XP 64-Bit Edition Version 2003 for 64-bit extended systems
Windows XP 64-Bit Edition Version 2003 for Itanium-based systems

Versions of Windows with Limited Language Availability

These versions of Windows are available only in English and Japanese:

Windows Server 2003, Standard Edition for 64-bit extended systems
Windows Server 2003, Enterprise Edition for 64-bit extended systems
Windows Server 2003, Datacenter Edition for 64-bit extended systems
Windows XP 64-Bit Edition Version 2003

© 1985-2004 Microsoft Corporation. All rights reserved. Terms of Use.