Narzędzia do wdrażania systemu Microsoft Windows w firmach — Podręcznik użytkownika

transparent1 transparent2

System Windows XP

Narzędzia do wdrażania systemu w firmach ułatwiają preinstalowanie, dostosowywanie i wdrażanie systemów:

punktor | Windows XP Home Edition z dodatkiem Service Pack 2 (SP2)
punktor | Windows XP Professional Edition z dodatkiem Service Pack 2 (SP2)

Rodzina systemów Windows Server 2003

Narzędzia do wdrażania systemu w firmach ułatwiają preinstalowanie, dostosowywanie i wdrażanie następujących wersji systemów Windows:

punktor | Windows Server 2003, Standard Edition z dodatkiem Service Pack 1 (SP1)
punktor | Windows Server 2003, Enterprise Edition z dodatkiem Service Pack 1 (SP1)
punktor | Windows Server 2003, Datacenter Edition z dodatkiem Service Pack 1 (SP1)
punktor | Windows Server 2003, Web Edition z dodatkiem Service Pack 1 (SP1)
punktor | Windows XP 64-Bit Edition, wersja 2003 dla 64-bitowych systemów rozszerzonych
punktor | Windows XP 64-Bit Edition, wersja 2003 dla 64-bitowych systemów opartych na procesorze Itanium

Systemy Windows występujące w ograniczonej liczbie wersji językowych

Następujące wersje systemu Windows są dostępne jedynie w języku angielskim i japońskim:

punktor | Windows Server 2003, Standard Edition dla 64-bitowych systemów rozszerzonych
punktor | Windows Server 2003, Enterprise Edition dla 64-bitowych systemów rozszerzonych
punktor | Windows Server 2003, Datacenter Edition dla 64-bitowych systemów rozszerzonych
punktor | Windows XP 64-Bit Edition, wersja 2003

© Copyright 1985-2004 Microsoft Corporation. Wszelkie prawa zastrzeżone.


Drukowanie dokumentacji

Przy użyciu polecenia Drukuj przeglądarki Pomocy w języku HTML można wydrukować pojedynczy temat lub wszystkie podtematy nagłówka.

Aby wydrukować tematy tej dokumentacji

  1. Wybierz temat lub nagłówek (książkę) na karcie Spis treści.
  2. Kliknij przycisk Drukuj na pasku narzędzi i postępuj zgodnie z komunikatem.

    —LUB—

    3. Kliknij prawym przyciskiem myszy wybraną książkę, kliknij przycisk Drukuj, a następnie postępuj zgodnie z komunikatem.


Używanie narzędzi do wdrażania systemu w firmach

W pliku Deploy.cab zlokalizowanym w folderze Support\Tools na dysku CD z produktem Windows znajduje się kilka narzędzi, które mogą być używane przez administratorów i specjalistów IT do wdrażania systemu Windows na wielu komputerach w organizacji.

Narzędzia do wdrażania

W pliku Deploy.cab znajdują się następujące narzędzia:

  • Menedżer instalacji: Kreator, który automatyzuje tworzenie i modyfikowanie udziałów dystrybucyjnych służących do preinstalowania systemów operacyjnych firmy Microsoft i różnych aplikacji.
  • Narzędzie przygotowania systemu (Sysprep): Przygotowuje dysk twardy komputera do duplikacji dysku, inspekcji i dostarczenia klientowi. Narzędzie Sysprep trzeba uruchomić w celu ponownego opieczętowania komputerów przed ich dystrybucją. Obejmuje ono następujące składniki: Sysprep.exe, Setupcl.exe, Factory.exe, Sysprep.inf i Winbom.ini. Pliki aplikacji (Sysprep.exe, Setupcl.exe i Factory.exe) są wymagane i nawzajem od siebie zależne.
  • Cvtarea: Jest to wszechstronne narzędzie do tworzenia plików i analizowania ich rozmieszczenia w systemach plików FAT32 i FAT. Za pomocą tego narzędzia można tworzyć pliki i umieszczać je w sposób ciągły w określonych lokalizacjach na dysku.
  • Oformat: To narzędzie tworzy wolumin FAT32 z klastrami, które są wyrównane w optymalny sposób, na użytek późniejszego konwertowania woluminu na format systemu plików NTFS.

Obsługa narzędzi do wdrażania systemu w firmach w różnych wersjach systemu operacyjnego

Komputer produkcyjny to komputer, na którym instaluje się narzędzia do wdrażania, wyodrębniając je z pliku Deploy.cab. Komputer docelowy to komputer dostarczany użytkownikowi końcowemu.

Na komputerze produkcyjnym musi być zainstalowany jeden z następujących systemów operacyjnych:

  • System Windows XP
  • System z rodziny Windows Server 2003
  • System Windows 2000

Na komputerze produkcyjnym można zainstalować tylko jedną wersję narzędzi do wdrażania. Każda wersja narzędzi do wdrażania działa w wersji systemu Windows, z którą została dostarczona, oraz we wcześniejszych wersjach systemu.

Narzędzi do wdrażania nie należy instalować w systemie Windows XP 64-Bit Edition, w 64-bitowej wersji systemu Windows Server 2003, Enterprise Edition i w 64-bitowej wersji systemu Windows Server 2003, Datacenter Edition.

Ważne

  • Zawsze należy używać wersji narzędzi Sysprep odpowiedniej do wdrażanej wersji systemu operacyjnego Windows. W przypadku wdrażania dodatku Service Pack należy używać odpowiedniej do niego wersji narzędzia Sysprep.
Wersje narzędzi na komputerze produkcyjnym | Wdrażany system operacyjny
 | Windows XP | Windows XP z dodatkiem SP1 | Windows Server 2003 | Windows XP z dodatkiem SP2 | Windows Server 2003 z dodatkiem SP1
Windows XP | X |  |  |  |
Windows XP z dodatkiem SP1 | X | X |  |  |
Windows Server 2003 | X | X | X |  |
Windows XP z dodatkiem SP2 | X | X | X | X |
Windows Server 2003 z dodatkiem SP1 | X | X | X | X | X

Podczas uaktualniania narzędzi do wdrażania systemu w firmie do systemu Windows XP z dodatkiem SP2 lub Windows Server 2003 z dodatkiem SP1 nie są wprowadzane żadne zmiany w plikach produktu Windows zlokalizowanych w udziałach dystrybucyjnych. Aby załadować pliki produktu Windows dla nowszych wersji systemu, takich jak Windows XP z dodatkiem SP2 lub rodzina Windows Server 2003, trzeba użyć strony Produkt w Menedżerze instalacji.

Uaktualnienie narzędzi do wdrażania systemu w firmie do wersji systemu Windows XP z dodatkiem SP2 lub Windows Server 2003 z dodatkiem SP1 powoduje zaktualizowanie plików szablonów używanych przez Menedżera instalacji podczas tworzenia nowego pliku odpowiedzi. Wszystkie nowe pliki odpowiedzi utworzone za pomocą Menedżera instalacji systemu Windows XP z dodatkiem SP2 lub Windows Server 2003 z dodatkiem SP1 będą korzystały z nowych wartości domyślnych.

Dokumentacja zawarta w pliku Deploy.cab

W pliku Deploy.cab znajdują się dwie książki online.

  • Narzędzia do wdrażania systemu Windows w firmach — Podręcznik użytkownika zawiera przegląd procesu preinstalacji oraz instrukcje dotyczące używania narzędzi do wdrażania w firmach.
  • Preinstallation Reference zawiera składnię różnych plików odpowiedzi, które automatyzują proces preinstalacji systemu Windows.

Aby uzyskać instrukcje dotyczące drukowania części lub całości dokumentacji narzędzi do wdrażania w firmie, zobacz Drukowanie dokumentacji.


Typy instalacji

Menedżer instalacji ułatwia administratorom tworzenie plików odpowiedzi używanych przez Instalatora systemu Windows do wykonywania instalacji nienadzorowanych lub uaktualnień systemu Windows. Pliki odpowiedzi udzielają odpowiedzi na pytania, które Instalator zadaje użytkownikowi. Na przykład Instalator pyta zwykle użytkownika o nazwę komputera. Jeśli jednak nazwa komputera zostanie podana w pliku odpowiedzi, Instalator nie będzie o nią monitował użytkownika końcowego.

Podczas tworzenia pliku odpowiedzi za pomocą Menedżera instalacji pojawiają się monity o podanie informacji wymaganych na stronach, które są wyświetlane podczas wykonywania instalacji nadzorowanej. Pliki odpowiedzi nie eliminują automatycznie konieczności interwencji użytkownika podczas pracy Instalatora. Aby interakcje użytkownika ograniczyć do minimum lub całkowicie wyeliminować, trzeba skonfigurować wpisy w pliku odpowiedzi.

Instalacja nienadzorowana systemu Windows

Instalator systemu Windows może działać w jednym z pięciu trybów nienadzorowanych, różniących się liczbą interakcji z użytkownikiem. W instalacji zupełnie nienadzorowanej Instalator nie monituje użytkownika o żadne dane, a wszystkie potrzebne informacje muszą być podane w pliku odpowiedzi. W takim wypadku Menedżer instalacji wymaga określenia danych dla wszystkich potrzebnych ustawień. W przypadku stosowania innych trybów nienadzorowanych Menedżer instalacji nie wymaga określania wszystkich danych. Aby nie określać danego ustawienia w pliku odpowiedzi, należy pozostawić odpowiadające mu pole puste lub, w niektórych przypadkach, wybrać opcję Nieokreślone.

Uwaga

  • Podczas uaktualniania istniejącej instalacji systemu Windows XP Instalator stosuje parametry istniejącej instalacji i ignoruje parametry określone w pliku odpowiedzi.

Instalacja za pomocą narzędzia Sysprep

Podczas tworzenia pliku odpowiedzi dla instalacji przy użyciu narzędzia Sysprep generowany jest plik inf. Aby ten plik odpowiedzi mógł być użyty, trzeba go umieścić na dysku systemowym, w folderze „Sysprep” (na przykład C:\Sysprep).

Pliki Sysprep.exe, Setupcl.exe i Factory.exe również muszą się znajdować w folderze %SYSTEMDRIVE%\Sysprep. Uruchomienie programu Sysprep.exe lub pliku bat wygenerowanego przez Menedżera instalacji przygotowuje dysk twardy do duplikacji. W celu uproszczenia pracy można posłużyć się Menedżerem instalacji do utworzenia folderu %SYSTEMDRIVE%\Sysprep, który będzie zawierać wszystkie potrzebne pliki. Jest to dopuszczalne tylko w przypadku uruchamiania Menedżera instalacji na komputerze, który ma być duplikowany.

Uwaga

  • Folder %SYSTEMDRIVE%\Sysprep jest usuwany automatycznie po włączeniu dysku twardego i zakończeniu pracy Instalatora.

Aby uzyskać szczegółowe informacje na temat korzystania z narzędzia Sysprep, zobacz Przygotowanie instalacji do rozmieszczenia.

Usługi instalacji zdalnej

Podczas tworzenia pliku odpowiedzi do zastosowania wraz z usługą instalacji zdalnej (RIS) Menedżer instalacji tworzy plik .sif, a nie zwykły plik .txt.

W tym przypadku nie jest tworzony przykładowy skrypt wsadowy. Aby włączyć nowy plik .sif, należy użyć narzędzi administracyjnych dostarczanych razem z usługą RIS.


Ustawianie hasła administratora

W sekcji [GuiUnattended] pliku Unattend.txt można ustawić hasło administratora, stosując wpis AdminPassword:

AdminPassword
Wartość: "hasło" | *

Hasło może zawierać nawet 127 znaków. W hasłach jest rozróżniana wielkość liter, a hasło musi być umieszczone w cudzysłowie. Do szyfrowania hasła należy stosować Menedżera instalacji. Jeśli wartością jest *, Instalator ustawia hasło administratora jako puste (czyli null). Zaleca się, aby w przypadku komputerów dostarczanych użytkownikom końcowym hasło administratora było puste.

Ważne

  • Używanie, w przypadku wszystkich komputerów dostarczanych użytkownikom końcowym, takiego samego, lecz innego niż puste, hasła administratora, stwarza zagrożenie bezpieczeństwa. Przed uruchomieniem narzędzia Sysprep można zastosować proces automatyzacji, aby ustawić puste hasło administratora. Użytkownicy końcowi mogą wówczas określić swoje własne hasła administratora.
  • W przypadku instalacji nienadzorowanej Instalator systemu Windows zamienia na pusty każdy ciąg hasła, który zaczyna się od gwiazdki.

Kiedy jest ustawiane hasło administratora, należy pamiętać, że:

  • Jeśli hasło jest określane przy użyciu wpisu AdminPassword, jest ono używane podczas automatycznego logowania się. Po zakończeniu instalacji hasło jest usuwane z kopii pliku odpowiedzi pozostałej w komputerze.
  • Jeśli AdminPassword = * (jest puste) i AutoLogon = Yes, komputer loguje się tylko raz, bez względu na wartość podaną dla wpisu AutoLogonCount. Jeśli jednak AdminPassword = hasło, komputer loguje się wielokrotnie i hasło, które nie jest puste, jest zapisywane w rejestrze.
  • Komputer loguje się automatycznie tyle razy, ile określono we wpisie AutoLogonCount, tylko wtedy, gdy AdminPassword = hasło.
  • Jeśli do szyfrowania hasła jest używany Menedżer instalacji, wpis AutoLogon nie działa.
  • Wszystkie hasła należy umieścić w cudzysłowach, aby zapewnić, że nie będą przetwarzane żadne znaki specjalne. Na przykład w czasie instalacji w trybie tekstowym znak # jest przetwarzany jako znacznik komentarza.


Używanie obrazów do preinstalacji

Najszybszym sposobem masowego preinstalowania systemu Windows XP jest używanie obrazów, nazywane również klonowaniem dysków. W tym celu można użyć oprogramowania lub sprzętu do duplikacji dysków dostarczonego przez inne firmy. Oprogramowanie do tworzenia obrazów przeprowadza duplikację sektorów, co jest procesem szybszym niż standardowe metody kopiowania plików. Oprogramowanie do tworzenia obrazów dysków nie wchodzi w skład narzędzi do wdrażania systemu Windows XP.

Preinstalacje oparte na obrazach są najlepsze w przypadku konstruowania komputerów o podobnym sprzęcie. W szczególności warstwa abstrakcji sprzętowej (HAL) instalacji wzorcowej musi być identyczna z warstwą HAL na komputerze docelowym.

Aby użyć obrazów do preinstalacji

  1. Użyj narzędzi do wdrażania systemu w celu utworzenia instalacji wzorcowej systemu Windows.
  2. Uruchom tę instalację i uruchom narzędzie Sysprep z odpowiednimi opcjami wiersza polecenia.
  3. Użyj oprogramowania do tworzenia obrazów dysków w celu utworzenia obrazu instalacji wzorcowej.
  4. Przetransferuj ten obraz na komputery docelowe albo ręcznie, za pośrednictwem sieci, używając niestandardowego dysku CD ze środowiskiem preinstalacji systemu Windows (Windows PE), albo transferując obraz na dysk twardy i instalując ten dysk w komputerze docelowym.


Optymalizowanie obrazów systemu operacyjnego

Niniejsze sugestie mogą ułatwić zmniejszenie rozmiaru obrazu systemu operacyjnego i skróceniu czasu, jaki zajmuje przenoszenie obrazu instalacji wzorcowej na komputery docelowe.

  • Zawsze, gdy to możliwe, należy stosować dostarczone z systemem sterowniki wewnętrzne, aby zmniejszyć liczbę plików sterowników kopiowanych na każdy komputer docelowy.
  • W przypadku dołączania dodatkowych sterowników należy stosować standardowy zestaw sterowników, używany w wielu liniach produktów. Ten wspólny zestaw należy zainstalować na wszystkich komputerach w ramach instalacji wzorcowej, co skróci czas potrzebny do zlokalizowania i zainstalowania określonych sterowników niestandardowych przed przekazaniem komputera docelowego klientowi.
  • Należy ograniczyć liczbę urządzeń z listy w sekcji [SysprepMassStorage] pliku Sysprep.inf.

    Jeśli w pliku Sysprep.inf zostanie umieszczona pusta sekcja [SysprepMassStorage], a w sekcji [Sysprep] zostanie ustawiony parametr BuildMassStorageSection = Yes, to narzędzie Sysprep automatycznie wygeneruje wpisy w sekcji [SysprepMassStorage] na podstawie identyfikatorów sprzętu Plug and Play określonych w plikach Machine.inf, Scsi.inf, Pnpscsi.inf i Mshdc.inf.

  • Należy ograniczyć liczbę instalowanych aplikacji dodatkowych.
  • Jeśli określona aplikacja ma się znajdować na większości komputerów, należy rozważyć umieszczenie w instalacji wzorcowej przemieszczanej wersji tej aplikacji. Przemieszczanie aplikacji znaczy udostępnienie wszystkich jej plików lokalnie. W takim przypadku do zainstalowania aplikacji wymagane jest jedynie wprowadzenie odpowiednich zmian w rejestrze, z pominięciem czasochłonnego kopiowania plików. Jeśli dana aplikacja ma zostać pominięta na którymś komputerze docelowym, jej pliki można odłączyć (czyli usunąć).

    Metoda rozruchu z dysku CD nie obsługuje aplikacji przemieszczanych.

    Aby uzyskać więcej informacji, zobacz Preinstalowanie aplikacji.

  • Na początku procesu preinstalacji należy utworzyć pojedynczą partycję NTFS, korzystając z narzędzi wiersza polecenia Diskpart i Format. Użycie narzędzia Diskpart eliminuje konieczność ponownego uruchomienia komputera między poleceniami fdisk i format, co jest wymagane w systemie MS-DOS.
  • Korzystając z małego obrazu instalacji, należy zainstalować system Windows na małej partycji, a następnie, w przypadku instalowania systemu na partycji z systemem plików NTFS, należy użyć klucza ExtendOemPartition.
  • Przed utworzeniem obrazu instalacji wzorcowej należy usunąć z niej pliki Hiberfil.sys i Pagefile.sys. Do usunięcia pliku Hiberfil.sys należy użyć polecenia del /a:sh hiberfil.sys. W razie potrzeby system Windows automatycznie utworzy te pliki ponownie.

    Uwaga

    • Plik Pagefile.sys ma taki rozmiar, jak pojemność dostępnej w komputerze pamięci RAM. Co najmniej tyle samo wolnego miejsca powinno być na partycji %SYSTEMDRIVE% na komputerze docelowym, aby plik został poprawnie wygenerowany podczas miniinstalacji.
  • Przed utworzeniem obrazu instalacji wzorcowej należy usunąć zawartość folderu %WINDIR%\System32\Dllcache. Folder Dllcache musi pozostać pusty, aby ochrona plików systemu Windows (WFP) działała poprawnie.

    W przypadku usunięcia zawartości folderu %WINDIR%\System32\Dllcache należy ustawić wpis SourcePath w sekcji [ComputerSettings] pliku Winbom.ini zgodny z lokalizacją folderu i386 na komputerze docelowym. Folder i386 musi znajdować się w folderze %WINDIR%.

  • Do usunięcia plików z obrazu niezbędne są narzędzia, które umożliwiają edytowanie obrazu lub dostęp do dysku w celu usunięcia plików. Nie można usunąć plików z instalacji systemu Windows w czasie, gdy ta instalacja systemu Windows jest uruchomiona.


Dołączanie dodatkowych plików do udziału dystrybucyjnego

Udział dystrybucyjny (nazywany również folderem dystrybucyjnym) umożliwia dostarczenie własnych plików, które Instalator systemu Windows automatycznie kopiuje na komputery docelowe. Przez proces tworzenia udziału dystrybucyjnego może poprowadzić Menedżer instalacji.

Takie pliki mogą na przykład obejmować pliki Pomocy, które powinny być zainstalowane na każdym komputerze w organizacji, lub sterowniki urządzeń, które nie są dostarczane z systemem Windows XP. Mogą to być również własne aplikacje, które powinny być rozmieszczone na komputerach docelowych.

W przypadku tworzenia udziału dystrybucyjnego za pomocą Menedżera instalacji potrzebna jest wystarczająca ilość miejsca na dysku do przechowania dysku CD z produktem Windows oraz plików, które mają być rozmieszczone.


Konfigurowanie dysku twardego

Podczas preinstalacji można zautomatyzować konfigurowanie dysków twardych.

Format dysków zalecany w przypadku 32-bitowych wersji systemu Windows XP i produktów z rodziny Windows Server 2003 to system plików NTFS. System NTFS ma wszystkie podstawowe funkcje systemu FAT, a w porównaniu z systemami FAT i FAT32 charakteryzują go istotne zalety.

Rozszerzanie partycji NTFS

Każdy z poniższych plików odpowiedzi umożliwia automatyczne rozszerzanie partycji NTFS na komputerach docelowych podczas procesu preinstalacji:

Plik odpowiedzi | Sekcja | Wpis | Moment rozszerzenia partycji
Unattend.txt | [Unattended] | ExtendOEMPartition | Instalacja nienadzorowana
Winbom.ini | [ComputerSettings] | ExtendPartition | Następny rozruch komputera po trybie fabrycznym narzędzia Sysprep
Sysprep.inf | [Unattended] | ExtendOEMPartition | Miniinstalacja

Partycje mogą być rozszerzone do określonego rozmiaru lub do wypełnienia dostępnego miejsca na dysku.

Konwertowanie partycji FAT/FAT32 na NTFS

Jeśli dany proces wdrażania wymaga systemu plików FAT32, należy użyć narzędzia wiersza polecenia Oformat i za jego pomocą sformatować dysk twardy, tak aby był skonfigurowany optymalnie dla systemu NTFS. Następnie należy przekonwertować system plików na system NTFS za pomocą narzędzia wiersza polecenia Convert. Po dokonaniu konwersji nie można powrócić do systemu plików FAT32. Aby uzyskać więcej informacji, zobacz Konwertowanie partycji FAT32/FAT na NTFS.

Po sformatowaniu dysku twardego można użyć narzędzia DiskPart i za jego pomocą sporządzić dodatkowe skrypty do konfigurowania dysków twardych, na przykład do podziału na partycje czy przypisania liter dyskom.

Scenariusze konwersji systemu plików FAT32

Jeśli dysk twardy nie jest konfigurowany podczas instalacji nienadzorowanej do używania systemu plików NTFS, to preferowaną metodą konwersji jest uruchomienie narzędzia Convert przed ostatnim uruchomieniem narzędzia Sysprep. W tym celu należy dodać polecenie Convert /fs:ntfs do sekcji [OEMRunOnce] pliku Winbom.ini, tak jak pokazano na poniższym przykładzie:

[OEMRunOnce]
Command0 = "Convert /fs:ntfs"

Dzięki temu konwersja zostanie przeprowadzona w trybie fabrycznym, a nie podczas działania programu początkowego uruchomionego przez użytkownika końcowego.

Inna metoda konwersji systemu plików FAT32 to dodanie polecenia Convert /fs:ntfs do sekcji [GUIRunOnce] pliku Sysprep.inf, tak jak pokazano na poniższym przykładzie:

[GuiRunOnce]
Command0 = "Convert /fs:ntfs"

W przypadku zastosowania polecenia Sysprep -reseal konwersja nastąpi po włączeniu komputera przez użytkownika końcowego w trakcie działania programu początkowego.


Porównanie systemów plików NTFS i FAT32/FAT

Format dysków zalecany dla 32-bitowych wersji systemu Windows XP i produktów z rodziny Windows Server 2003 to system plików NTFS. System NTFS zapewnia wszystkie podstawowe funkcje systemu FAT, a w porównaniu z systemami plików FAT i FAT32 charakteryzują go dodatkowe zalety:

  • Łatwiejsze odzyskiwanie w przypadku zresetowania bądź awarii systemu
  • Obsługa dużych dysków twardych
  • Ściślejsza kontrola dostępu do plików prywatnych
  • Udoskonalone narzędzia dyskowe, służące do takich funkcji, jak szyfrowanie, kompresowanie na poziomie pliku i folderu oraz defragmentowanie dysku

Ważne

  • W przypadku komputerów użytkowników końcowych firma Microsoft nie testuje ani nie obsługuje systemu plików FAT32 na woluminach większych niż 32 GB. Firma Microsoft obsługuje producentów OEM, którzy w czasie procesów produkcyjnych korzystają z woluminów FAT32 o pojemności większej niż 32 GB, pod warunkiem, że te systemy są konwertowane na system NTFS, zanim komputer opuści fabrykę. Aby uzyskać więcej informacji, zobacz Konwertowanie partycji FAT32/FAT na NTFS.

Wydajność

Wydajność podsystemu dysków ma duże znaczenie dla ogólnej wydajności systemu. W systemie Windows XP i w systemach z rodziny Windows Server 2003 systemy plików NTFS i FAT mają bardzo podobne charakterystyki wydajności, z tym wyjątkiem, że system NTFS ma większą wydajność przy większych pojemnościach woluminów.

Wiele osób sądzi, że system NTFS jest wolniejszy niż FAT. Wynika to jednak przeważnie z niewłaściwej konfiguracji systemu plików NTFS poddawanego testom. Poprawnie skonfigurowany system plików NTFS ma wydajność podobną do systemu plików FAT. Wyniki standardowych testów wydajności systemu plików NTFS są lepsze w systemie Windows XP i w systemach z rodziny Windows Server 2003 niż w starszych wersjach systemu Windows.

Specyfikacje systemu plików

Opis | NTFS | FAT32 | FAT
Maksymalny rozmiar pliku | 244 - 64K bajtów | 232 - 1 bajtów | 232 - 1 bajtów
Minimalny rozmiar partycji | 10 MB (zalecanym minimum jest 500 MB); nie może być używany na dyskietkach | 512 MB | Rozmiar dyskietki
Maksymalny rozmiar partycji | 2 TB (terabajty) | 2 TB (terabajty) W systemie Windows XP można sformatować partycję FAT32 o rozmiarze maksymalnym 32 GB W systemie Windows XP można odczytywać partycje FAT32 o dowolnym rozmiarze | 4 GB
Minimalny rozmiar woluminu | 1 MB | 65 535 klastrów | 4 085 klastrów
Maksymalny rozmiar woluminu | 232 klastrów | Windows 2000: Można formatować woluminy o rozmiarze maksymalnym 32 GB; można instalować i konwertować większe woluminy Windows Millennium Edition: Maksymalnie 228 - 12 klastrów Windows 98 i Windows 95: 4 177 918 klastrów | 2 GB Jeśli w czasie instalacji systemu Windows XP zostanie wybrana opcja sformatowania dysku przy użyciu systemu FAT, a partycja jest większa niż 2 GB, Instalator automatycznie sformatuje dysk przy użyciu systemu FAT32.
Liczba plików na wolumin | 232 - 1 | 228 | 2316
Rozmiar katalogu | Bez ograniczeń | 216 - 2 elementów katalogu fizycznego | 216 - 2 elementów katalogu fizycznego; specjalne ograniczenia dotyczą katalogu głównego
Zabezpieczenia | Zabezpieczenia na poziomie użytkownika Zabezpieczenia na poziomie pliku Zabezpieczenia na poziomie folderu Zabezpieczenia na poziomie udziału | Zabezpieczenia na poziomie udziału | Zabezpieczenia na poziomie udziału

Rozmiar klastra

Rozmiar klastra zależy od systemu operacyjnego, a nie od systemu plików.

System operacyjny | Rozmiar klastra
Windows XP, rodzina Windows Server 2003, Windows 2000 i Windows NT | Potęgi liczby 2, od 512 bajtów do 65 536 bajtów włącznie
Windows Millennium Edition, Windows 98 i Windows 95 | Potęgi liczby 2, od 512 bajtów do 32 768 bajtów włącznie

Zgodność systemu plików z różnymi systemami operacyjnymi firmy Microsoft

Systemy Windows XP, Windows 2000 i Windows NT 4.0 są jedynymi systemami operacyjnymi, które mogą odczytywać i pobierać dane z woluminów lokalnych sformatowanych przy użyciu systemu plików NTFS. Jeśli komputer jest skonfigurowany do podwójnego rozruchu w systemie Windows XP i w innym systemie operacyjnym, należy sprawdzić, czy wybrany system plików może być używany w obu systemach operacyjnych.

System operacyjny | NTFS | FAT32 | FAT
Windows XP | X | X | X
Rodzina systemów Windows Server 2003 | X | X | X
Windows 2000 | X | X | X
Windows Millennium Edition |  | X | X
Windows NT 4.0 z dodatkiem Service Pack 4 (lub nowszym) | X |  | X
Windows NT 3.5 Windows NT 4.0 z dodatkiem Service Pack 1, Service Pack 2 lub Service Pack 3 |  |  | X
Windows 98 Windows 98 SE |  | X | X
OS/2 |  | X | X
Windows 95 |  | X | X
Windows 3.1 |  |  | X
MS-DOS |  |  | X


Konwertowanie partycji FAT/FAT32 na NTFS

Zalecanym systemem plików dla systemu Windows XP i rodziny systemów Windows Server 2003 jest system plików NTFS. Niekiedy procesy produkcyjne mogą być jednak oparte na systemie Windows 9.x lub MS-DOS, co wymaga formatowania dysków twardych przy użyciu systemu plików FAT32 lub FAT.

Producent może zachować taki proces, a mimo to zapewniać klientom wszystkie zalety systemu NTFS, konwertując woluminy FAT32 lub FAT na NTFS. W systemie Windows XP oraz w systemach z rodziny Windows Server 2003 wydajność przekonwertowanego woluminu NTFS jest identyczna, jak woluminu sformatowanego od początku przy użyciu systemu NTFS.

Uwaga

  • Podczas instalacji na partycji NTFS dla systemu plików jest tworzona lista ACL (Access Control List) przy użyciu wstępnie zdefiniowanego zestawu domyślnych szablonów zabezpieczeń. Można także użyć sekcji [.security] w plikach instalacyjnych (.inf) składników, które używają interfejsu API Instalatora do określania unikatowego zabezpieczenia pliku. Uprawnienia z domyślnego szablonu zabezpieczeń i uprawnienia określone w plikach .inf są umieszczane w jednym szablonie setup security.inf.

    Jeśli początkowo system Windows będzie zainstalowany na partycji FAT lub FAT32, a następnie zostanie użyte narzędzie Convert.exe do przekonwertowania partycji na system NTFS, domyślne ustawienia zabezpieczeń nie zostaną zastosowane. System Windows nie dopasowuje ustawień zabezpieczeń już zainstalowanych plików do zabezpieczeń NTFS po przeprowadzeniu konwersji z systemu FAT lub FAT32. Aby zagwarantować wygenerowanie poprawnej listy ACL, należy uruchomić instalację bezpośrednio z dysku CD lub wykonać instalację nienadzorowaną z odpowiednim przełącznikiem NTFS. Aby uzyskać więcej informacji, zobacz artykuł KB: 237399 „The Default NTFS Permissions Are Not Applied to a Converted Boot” (http://kb/article.asp?id=Q237399).

Aby uzyskać informacje dotyczące różnic między systemami plików NTFS, FAT32 i FAT, zobacz Porównanie systemów plików NTFS i FAT32/FAT.

Metoda 1: Konwertowanie na system NTFS podczas instalacji nienadzorowanej

W sekcji [Unattended] pliku Unattend.txt ustaw we wpisie FileSystem wartość ConvertNTFS. Ta wartość powoduje, że Instalator automatycznie konwertuje dysk twardy bezpośrednio przed uruchomieniem instalacji w trybie graficznym.

[Unattended]
FileSystem = ConvertNTFS

Uwaga

  • Wpis FileSystem nie jest prawidłowym wpisem w pliku Sysprep.inf.

Metoda 2: Konwertowanie na system NTFS po wykonaniu instalacji

Uruchom komputer po zainstalowaniu systemu Windows. W wierszu polecenia wpisz polecenie:

Convert Dysk /FS:NTFS

Uruchom komputer ponownie, aby zakończyć konwertowanie na system NTFS. Aby uzyskać więcej informacji, zobacz:

  • NTFS Preinstallation and Windows XP (http://www.microsoft.com/whdc/)
  • „Converting Volumes to NTFS” w witrynie Microsoft TechNet


Rozszerzanie partycji NTFS

Podczas instalowania systemu Windows może wystąpić konieczność rozszerzenia partycji komputera docelowego. Kiedy jest zastosowany w pliku odpowiedzi, wpis ExtendOemPartition w sekcji [Unattended] pliku Unattend.txt powoduje, że Instalator rozszerza partycję docelową o sąsiadujące miejsce na dysku, jeszcze nie podzielone na partycje.

Określenie dla wpisu ExtendOemPartition wartości innej niż 1 będzie oznaczało określony rozmiar rozszerzenia dysku, oprócz przestrzeni używanej aktualnie. Metoda ta jest przydatna w przypadku konfigurowania więcej niż jednej partycji na dysku twardym.

Ważne

  • Wpis ExtendOemPartition można stosować w plikach odpowiedzi Unattend.txt oraz Sysprep.inf. W przypadku użycia go dla obrazowanych komputerów w pliku Sysprep.inf, dysk twardy zainstalowany w komputerze docelowym musi mieć taki sam lub większy rozmiar niż dysk twardy zainstalowany w komputerze wzorcowym.
  • Można rozszerzać tylko partycje systemu plików NTFS. Jeśli partycja docelowa, która ma być rozszerzona, jest typu FAT lub FAT32, należy ustawić wpis FileSystem w sekcji [Unattended] pliku Unattend.txt na wartość ConvertNTFS, aby wykonać konwersję partycji podczas instalacji w trybie tekstowym.
  • Instalator nie może rozszerzać partycji FAT32 i FAT, a program Sysprep nie może konwertować woluminu z formatu FAT32 lub FAT na format NTFS.

Rozszerzanie partycji NTFS w produkcji planowanej

Na przykład chcąc rozszerzyć partycję komputera, na którym narzędzie Sysprep uruchamia się automatycznie, można:

  1. Zachować możliwie mały rozmiar obrazu wzorcowego, tworząc na komputerze wzorcowym partycję, która jest dostatecznie duża, aby pomieścić instalację Windows i inne programy narzędziowe zawarte w obrazie wzorcowym.
  2. Dodać poniższy wpis do sekcji [Unattended] w pliku Sysprep.inf:
    ExtendOemPartition = 1
  3. W pliku Unattend.txt, który jest używany do wygenerowania obrazu wzorcowego, dodać poniższy wpis:
    [GuiRunOnce]
...<polecenia używane do konfigurowania lub instalowania aplikacji>
Commandn-1 = "Convert c:\ /fs:ntfs"
Commandn = "%SYSTEMDRIVE%\sysprep\sysprep -quiet"

    Po zakończeniu instalacji nienadzorowanej w komputerze wzorcowym, narzędzie Sysprep uruchamia polecenia określone w sekcji [GuiRunOnce], aby zainstalować aplikacje lub skonfigurować system. Po uruchomieniu polecenia Convert w rejestrze jest ustawiany wpis, który nakazuje systemowi operacyjnemu skonwertowanie dysku C podczas ponownego uruchomienia komputera. Po skonwertowaniu dysku przez Instalatora program Sysprep uruchamia i wyłącza komputer.

  4. Wygenerować obraz.

Kiedy obraz wzorcowy jest umieszczany w komputerze docelowym, dysk C jest konwertowany w chwili uruchomienia komputera. Następnie komputer uruchamia się ponownie, po czym uruchamiany jest aplet System Windows - Zapraszamy! lub miniinstalacja. Podczas pierwszego uruchomienia komputera system Windows błyskawicznie rozszerza dysk C na resztę nie podzielonego na partycje obszaru na dysku twardym. Następnie komputer uruchamia się ponownie jeszcze raz, po czym użytkownik końcowy może się zalogować i rozpocząć korzystanie z systemu Windows.


Konfigurowanie systemów operacyjnych z rodziny Windows Server 2003

Interfejs użytkownika systemów z rodziny Windows Server 2003 różni się od interfejsu użytkownika systemu Windows XP w następujący sposób:

  • Różnice w menu Start na serwerach z systemem Windows Server 2003
  • Instalator ustawia rozdzielczość ekranu równą 1024 x 768, jeśli jest ona obsługiwana zarówno przez kartę graficzną, jak i monitor. W przeciwnym wypadku wybierana jest rozdzielczość 800 x 600. W rzadkich przypadkach Instalator jest zmuszony użyć rozdzielczości 640 x 480.
  • Tło ekranu logowania ma kolory kodowe odpowiadające różnym wersjom systemu Windows. We wszystkich wersjach systemu Windows Server 2003 jest stosowany ten sam kolor.
  • Funkcja oczyszczania pulpitu jest domyślnie wyłączona.

Programem początkowym dla rodziny Windows Server 2003 jest miniinstalacja. Aby uzyskać więcej informacji, zobacz Pierwsze uruchomienie systemu przez użytkownika końcowego i Wstępne konfigurowanie i automatyzowanie miniinstalacji.

W wypadku produktów z rodziny Windows Server 2003 nie jest wymagane zainstalowanie programu Step by Step Interactive (SBSI).

Aby uzyskać informacje dotyczące konfigurowania serwera, zapoznaj się z następującymi tematami:

  • Instalowanie internetowych usług informacyjnych (IIS) firmy Microsoft
  • Instalowanie narzędzi administracji zdalnej
  • Instalowanie usługi klastrowania
  • Instalowanie kontrolera domeny

Do pliku Unattend.txt można dołączać dodatkowe składniki serwera i dostosowywać je. Aby uzyskać więcej informacji, zobacz:

  • [Components]
  • [InternetServer]
  • [NetOptionalComponents]
  • [NetServices]
  • [SNMP]
  • [TerminalServices]


Różnice w menu Start na serwerach z systemem Windows Server 2003

Interfejs użytkownika systemów z rodziny Windows Server 2003 różni się od interfejsu użytkownika systemów Windows XP Home Edition i Windows XP Professional w następujący sposób:

  • Menu Start jest szersze.
  • Jeśli bieżący użytkownik należy do grupy Administratorzy serwera, to w menu Start pojawia się łącze Narzędzia administracyjne. To łącze nie pojawia się w przypadku użytkowników innych niż administratorzy.
  • Łącze Wykaz systemu Windows, widoczne po kliknięciu polecenia Wszystkie programy, wskazuje stronę wykazu, która lepiej odpowiada potrzebom użytkowników serwera.
  • Łącza do programu Microsoft Management Console (MMC) i Menedżera zadań zawiera początkowe menu Narzędzia administracyjne.
  • W obszarze przypinania menu Start znajdują się łącza: Zarządzanie komputerem (Compmgmt.msc), Wiersz polecenia (Cmd.exe) i Eksplorator Windows (Explorer.exe).
  • Lista najczęściej używanych programów (MFU) zawiera dwa wstępnie wypełnione łącza: Notatnik i Konfigurowanie serwera.
  • Panel sterowania i Narzędzia administracyjne są wyświetlane w menu Start jako menu „wysuwane”.
  • Element Mój komputer jest wyświetlany w menu Start jako łącze.
  • Element Połączenia sieciowe pojawia się w menu Start, jeśli zostanie znalezione istniejące połączenie.
  • W menu Start znajdują się polecenia Pomoc i obsługa techniczna, Wyszukaj i Uruchom.
  • Polecenia Moje dokumenty i Moje bieżące dokumenty są wyłączone.
  • Polecenie Moje miejsca sieciowe jest wyłączone.

Aby poznać więcej różnic między interfejsem użytkownika systemów Windows XP i Windows Server 2003, zobacz Konfigurowanie systemów operacyjnych z rodziny Windows Server 2003.


Instalowanie internetowych usług informacyjnych (IIS) firmy Microsoft

System Windows XP Professional zawiera internetowe usługi informacyjne (IIS) 5.1 firmy Microsoft. System Windows XP Professional 64-Bit Edition 2003 i wszystkie systemy należące do rodziny Windows Server 2003 zawierają usługi IIS 6.0.

System Windows XP Home Edition nie zawiera żadnych składników oprogramowania serwera sieci Web.

Aby preinstalować internetowe usługi informacyjne (IIS), należy określić następujące elementy:

  • Wartości dla różnych składników usług IIS w sekcji [Components] pliku Unattend.txt i trzeba ustawić wartość wpisu iis_www na On.
  • Wpisy konfiguracyjne lokalizacji instalacji w sekcji [InternetServer] pliku Unattend.txt.

Jeśli sekcja [InternetServer] jest pusta, usługi IIS są instalowane w lokalizacji domyślnej.

Uwaga

  • Niektóre opcjonalne składniki systemów z rodziny Windows Server 2003 wymagają zainstalowania dodatkowych składników usług IIS. Jeśli te składniki opcjonalne są konfigurowane w czasie instalacji nienadzorowanej systemu Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition lub Windows 2000 Datacenter Server, to można ustawić preferencje dla odpowiednich składników usług IIS. Aby uzyskać listę współzależności usług IIS i listę składników, które należy zainstalować, zobacz [Components], [InternetServer] i [NetOptionalComponents].


Instalowanie narzędzi administracji zdalnej

Domyślna instalacja nadzorowana składników narzędzi administracji zdalnej (znanych wcześniej pod nazwą Server Administration Kit, SAK) następuje przy pierwszym logowaniu po zakończeniu instalacji. Instalację można wykonać automatycznie przy użyciu pliku Unattend.txt lub za pomocą jednej z następujących metod:

  • Wpis w sekcji [GuiUnattended], tylko w wypadku systemu Windows Server 2003, Web Edition
  • Menedżer składników opcjonalnych
  • Wiersz polecenia w sekcji [GUIRunOnce]

Aby uzyskać więcej informacji, zobacz Podręcznik administratora internetowych usług informacyjnych (IIS) 6.0 w systemie Windows.

Instalacja nienadzorowana w trybie graficznym w wypadku systemu Windows Server 2003, Web Edition

Domyślnym zachowaniem instalacji nadzorowanej przy pierwszym logowaniu do systemu Windows Server 2003, Web Edition jest uruchomienie pliku Sasetup.msi i zainstalowanie interfejsu sieci Web umożliwiającego administrację zdalną. Informacje o działaniu przy pierwszym logowaniu Instalator odczytuje z wpisu ServerWelcome w sekcji [GuiUnattended] pliku Unattend.txt. Na przykład:

[GuiUnattended]
ServerWelcome = Yes

Ustawieniem domyślnym jest Yes.

Ważne

  • Wpis ServerWelcome nie jest przetwarzany w przypadku korzystania z narzędzia Sysprep.

W systemie Windows Server 2003, Web Edition, jeśli ten parametr ma wartość Yes, przy pierwszym logowaniu użytkownika plik Sasetup.msi będzie uruchomiony z dysku twardego. Interfejs sieci Web umożliwiający administrowanie serwerem sieci Web będzie dodany do grupy programów Autostart dla konta administratora i zostanie uruchomiony.

Instalacja nienadzorowana przy użyciu Menedżera składników opcjonalnych (OCM)

Domyślnym zachowaniem instalacji nadzorowanej przy pierwszym logowaniu do systemu Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition, Microsoft Small Business Server lub Windows Server 2003, Datacenter Edition jest pominięcie instalacji narzędzi administracji zdalnej.

Aby przy pierwszym logowaniu po zakończeniu instalacji wykonać instalację nienadzorowaną składników interfejsu sieci Web umożliwiających administrowanie serwerem sieci Web, można uruchomić Menedżera składników opcjonalnych (OCM).Jeśli Menedżer OCM zostanie wywołany z argumentem w postaci pliku Unattend.txt, to Menedżer OCM przekaże go do pliku iisoc.dll. Plik iisoc.dll wyszuka w pliku Unattend.txt parametry definiujące ścieżkę do pliku Sasetup.msi i sprawdzi, czy jest zainstalowany interfejs sieci Web.

Na przykład wiersz polecenia instalacji może mieć postać:

sysocmgr /i:sysoc.inf /u:unattend.txt

Jeśli nie jest określony żaden nośnik, biblioteka iisoc.dll korzysta ze stacji CD-ROM. Jeśli biblioteka SaInstall.dll nie może odnaleźć pliku Sasetup.msi w określonej lokalizacji, do biblioteki iisoc.dll zostaje zwrócony błąd, który jest przez nią rejestrowany.

Parametry instalacji nienadzorowanej sterujące działaniem menedżera OCM usług IIS

Następujące parametry instalacji nienadzorowanej zapewniają funkcje narzędzi administracji zdalnej w rodzinie Windows Server 2003:

[Components]
Sakit_web = On | Off

Ustawieniem domyślnym jest Off. Nadanie temu parametrowi wartości On powoduje zainstalowanie narzędzi administracji zdalnej oraz zainstalowanie następujących składników: iis_common, iis_inetmgr i iis_www.

Uwaga

  • Parametr ten zastępuje parametr iis_htmla składnika HTMLA usług IIS w systemie Windows 2000. Parametr iis_htmla nie jest już prawidłowy w rodzinie Windows Server 2003.

Jeśli ten parametr ma wartość Off (jest to wartość domyślna), a interfejs sieci Web umożliwiający administrowanie serwerem sieci Web jest już zainstalowany, to nastąpi odinstalowanie tego składnika.

Instalacja narzędzi administracji zdalnej przy użyciu skryptów umieszczonych w pliku Sasetup.msi

Po zakończeniu pracy Instalatora interfejs sieci Web umożliwiający administrację zdalną można zainstalować w trybie instalacji nienadzorowanej przy użyciu pliku Sasetup.msi z odpowiednimi opcjami wiersza polecenia. Aby uzyskać szczegółowe informacje, zajrzyj do dokumentacji programu Sasetup.

Program Sasetup można uruchomić automatycznie po zakończeniu pracy Instalatora. W tym celu plik Sasetup.msi należy umieścić w sekcji [GUIRunOnce] pliku Unattend.txt. Dodatkowo można umieścić tam parametr AutoLogon i nadać mu wartość Yes, co spowoduje automatyczne zalogowanie i zainstalowanie narzędzi administracji zdalnej po zakończeniu pracy Instalatora.


Instalowanie usługi klastrowania

Aby uzyskać pewność, że usługa klastrowania zostanie zainstalowana, należy utworzyć dla niej wpis [GuiRunOnce].

Aby utworzyć klaster:

  1. W sekcji [GuiRunOnce] pliku Unattend.txt dodaj wpis
    Command0 = "%WINDIR%\cluster /cluster:SV-CLUSTER /CREATE /NODE:SV-NODE1 /USER:your_domain\user /PASS:****** /IPADDR:157.5.5.50"

Aby dodać węzły do istniejącego klastra:

  1. W sekcji [GuiRunOnce] pliku Unattend.txt dodaj wpis
    Command0 = "%WINDIR%\ cluster /cluster:SV-CLUSTER /ADDNODES:SV-NODE2 /PASSWORD:*********"

Wpisy z sekcji [GuiRunOnce] są uruchamiane po zakończeniu pracy Instalatora przy pierwszym logowaniu się użytkownika. Wszystkie wpisy określone w sekcji [GuiRunOnce] są zapisywane na komputerze i przetwarzane tylko po ponownym rozruchu, a nie w czasie instalacji nienadzorowanej.

Ważne

  • Aby uzyskać informacje na temat konfigurowania usługi klastrowania i związanych z nią sekcji pliku odpowiedzi, zobacz Windows Cluster Technologies: Server Clusters: Remote Setup, Unattended Installations and Image-based Installations.


Instalowanie kontrolera domeny

Program Dcpromo.exe to składnik Kreatora instalacji usługi Active Directory używany do tworzenia i obniżania kontrolerów domeny na komputerach z systemem Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition lub Windows 2000 Datacenter Server.

Uwaga

  • Program Dcpromo.exe można uruchomić tylko po zakończeniu instalacji w trybie graficznym i zalogowaniu użytkownika.

Aby uruchomić program Dcpromo.exe

  • Otwórz okno polecenia i wpisz polecenie:

    dcpromo /answer:plik_odpowiedzi

    —LUB—

  • Utwórz plik Sysprep.inf z następującymi wpisami:
    [GuiRunOnce]
"dcpromo /answer:plik_odpowiedzi"

    W obu przypadkach parametr plik_odpowiedzi określa nazwę pliku odpowiedzi zawierającego wartości kontrolera domeny.

W sekcji [DCInstall] pliku odpowiedzi Unattend.txt używanego podczas instalacji nienadzorowanej lub w oddzielnym pliku odpowiedzi zawierającym tylko sekcję [DCInstall] należy określić wartości używane przez program Dcpromo.exe.

Uwagi

  • Jeśli plik odpowiedzi nie zostanie utworzony, Kreator instalacji usługi Active Directory monituje o podanie informacji potrzebnych do podwyższenia komputera do kontrolera domeny.
  • Jeśli w tworzonym pliku odpowiedzi nie zostaną określone wartości opcji, to będą użyte wartości domyślne.

Dostosowywanie sekcji [DCInstall]

[DCInstall] to opcjonalna sekcja pliku odpowiedzi, zawierająca wpisy dotyczące instalowania kontrolera domeny po zakończeniu instalacji systemu Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition lub Windows 2000 Datacenter Server. Można utworzyć plik odpowiedzi zawierający tylko tę sekcję. Jest on uruchamiany po zakończeniu instalacji i zalogowaniu się użytkownika do komputera.

Wpisy używane w sekcji [DCInstall] są obsługiwane tylko w systemach Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition i Windows 2000 Datacenter Server. W poniższej tabeli pokazano zastosowanie poszczególnych wpisów.

Wpis | Dotyczy:
RebootOnSuccess | Wszystkie operacje (instalowanie i usuwanie)
DatabasePath LogPath SYSVOLPath UserName Password UserDomain | Wszystkie instalacje
ReplicaOrNewDomain = Replica ReplicaDomainDNSName | Uaktualnianie zapasowych kontrolerów domeny i instalowanie nowych replik
ReplicaOrNewDomain = Domain TreeOrChild = Child ParentDomainDNSName ChildName DomainNetbiosName AutoConfigDNS | Instalowanie domen podrzędnych
ReplicaOrNewDomain = Domain TreeOrChild = Tree CreateOrJoin = Join NewDomainDNSName DomainNetbiosName AutoConfigDNS | Instalowanie nowego drzewa w istniejącym lesie
AdministratorPassword IsLastDCInDomain | Obniżanie kontrolera domeny
ReplicaOrNewDomain = Domain TreeOrChild = Tree CreateOrJoin = Create NewDomainDNSName DNSOnNetwork DomainNetbiosName AutoInstallAndConfigDNS SiteName | Instalowanie nowego drzewa w nowym lesie

Uwagi

  • Hasła mogą zawierać maksymalnie 127 znaków.
  • Do pliku odpowiedzi można dodawać dodatkowe składniki serwera i dostosowywać je. Aby zapoznać się z listą tych składników, zobacz plik Unattend.txt.


Korzystanie z Menedżera instalacji

Menedżer instalacji służy do tworzenia lub modyfikowania plików sterujących instalacją nienadzorowaną.

Menedżer instalacji może:

  • Tworzyć pliki odpowiedzi, służące do automatyzowania instalacji systemu Windows XP na wielu komputerach.
  • Tworzyć punkt udostępniania dystrybucji dla instalacji sieciowych. Oprócz plików instalacyjnych systemu Windows XP, ten sieciowy udział instalacyjny może zawierać dodatkowe aplikacje, sterowniki, polecenia do uruchomienia na końcu pracy Instalatora lub inne składniki niestandardowe, określone przez administratora systemu.

Menedżer instalacji nie modyfikuje plików systemowych na komputerze produkcyjnym, na którym narzędzie jest uruchamiane i w rzeczywistości nie uruchamia Instalatora systemu Windows.

Nie ma potrzeby określania wszystkich opcji dostosowujących za pośrednictwem Menedżera instalacji. Zamiast tego, w Menedżerze instalacji można utworzyć plik Unattend.txt, a następnie edytować go ręcznie. Jeśli plik Unattend.txt zostanie później otwarty w Menedżerze instalacji, narzędzie to wyświetli zmienione ustawienia.

Uruchamianie Menedżera instalacji

Do uruchomienia Menedżera instalacji niezbędny jest system Windows 2000 lub Windows XP (wersja 32-bitowa).

Aby zainstalować i uruchomić Menedżera instalacji

  1. Z pliku Deploy.cab, który znajduje się w folderze \Support\Tools na dysku CD z produktem Windows, skopiuj plik Setupmgr.exe na dysk twardy.
  2. W wierszu polecenia zmień katalog bieżący na katalog, do którego został skopiowany plik. Wpisz polecenie:

    setupmgr

    i naciśnij klawisz ENTER.

Ważne

  • Ponieważ nazwa użytkownika i hasło wybrane w celu nawiązania połączenia z udziałem dystrybucyjnym mają postać zwykłego tekstu, zaleca się udzielenie temu kontu tylko minimalnych uprawnień niezbędnych do nawiązania połączenia.

Więcej informacji

Aby uzyskać więcej informacji na temat określonych zadań, które można wykonać za pomocą Menedżera instalacji, zobacz:

  • Typy instalacji
  • Dołączanie dodatkowych plików do udziału dystrybucyjnego
  • Korzystanie ze skryptów wsadowych

Aby zapoznać się ze szczegółową listą ustawień zapisywanych przez Menedżera instalacji, zobacz Ustawienia Menedżera instalacji. Aby uzyskać szczegółowe informacje na temat rozmieszczania systemu Windows, odwiedź strony poświęcone rozmieszczaniu w witrynie Microsoft Windows Server w sieci Web (http://www.microsoft.com/windows2000/techinfo/planning/).


Dostosowywanie Zapory systemu Windows

Zaporę systemu Windows można konfigurować za pomocą plików odpowiedzi Unattend.txt i Winbom.ini.

Dostosowywanie zapory systemu Windows za pomocą plików odpowiedzi

Zapora systemu Windows jest domyślnie ustawiona na On. Użyj plików Unattend.txt lub Winbom.ini, aby zmienić listę wyjątków Zapory systemu Windows.

Aby skonfigurować Zaporę systemu Windows za pomocą pliku odpowiedzi Unattend.txt

  1. Użyj Menedżera instalacji do utworzenia nowego lub zmodyfikowania istniejącego pliku Unattend.txt.
  2. Dodaj sekcje i wpisy Zapory systemu Windows zdefiniowane przez użytkownika, aby dodać programy, usługi, porty statyczne oraz komunikaty protokołu ICMP do listy wyjątków Zapory systemu Windows. Aby uzyskać szczegółowe informacje, zobacz tematy [WindowsFirewall] w dokumencie Windows Preinstallation Reference. W następującym przykładzie pokazano sposób dodawania sekcji i wpisów do pliku Unattend.txt:
    [WindowsFirewall]
Profiles=WindowsFirewall.Standard
LogFile = %WINDIR%\pfirewall.log
LogSize = 4096
LogDroppedPackets = 1
LogConnections = 1

[WindowsFirewall.Standard]
Type = 3
Mode = 1
Exceptions = 1
Notifications = 1
MulticastBroadcastResponse = 1
AllowedPrograms = WindowsFirewall.RemoteAssistance
Services = WindowsFirewall.RemoteDesktop
PortOpenings = WindowsFirewall.WebService
IcmpSettings = WindowsFirewall.EchoRequest

[WindowsFirewall.RemoteAssistance]
Program = %WINDIR%\System32\Sessmgr.exe
Name = Remote Assistance
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

[WindowsFirewall.RemoteDesktop]
Type = 2
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

[WindowsFirewall.WebService]
Protocol= 6
Port = 80
Name = Web Server (TCP 80)
Mode = 1
Scope = 2
Addresses = 192.168.0.5,LocalSubnet

[WindowsFirewall.EchoRequest]
Type = 8
Mode = 1

    Uwaga

    • Do sekcji wymienionych w poprzednim przykładzie nie trzeba dodawać wpisu Addresses. Po dodaniu wpisu Addresses należy się upewnić, czy nie ma spacji.
  3. Uruchom instalację nienadzorowaną.
  4. Utwórz obraz systemu operacyjnego z ustawieniami Zapory systemu Windows zdefiniowanymi przez użytkownika.
  5. Skopiuj obraz na komputer docelowy.
  6. Uruchom polecenie Sysprep - reseal na komputerze docelowym.

Aby wyłączyć Zaporę systemu Windows za pomocą pliku odpowiedzi Unattend.txt

  1. Użyj Menedżera instalacji do utworzenia nowego lub zmodyfikowania istniejącego pliku Unattend.txt.
  2. Dodaj następujące sekcje i wpisy do pliku odpowiedzi Unattend.txt:
    [WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

    Uwaga

    • Dodanie wpisu Type do sekcji [WindowsFirewall.TurnOffFirewall] nie jest konieczne. Wartość domyślna All jest stosowana w przypadku, gdy nie ma wpisu Type.
  3. Uruchom instalację nienadzorowaną.
  4. Utwórz obraz systemu operacyjnego z ustawieniami Zapory systemu Windows zdefiniowanymi przez użytkownika.
  5. Skopiuj obraz na komputer docelowy.
  6. Uruchom polecenie Sysprep - reseal na komputerze docelowym.

Aby skonfigurować Zaporę systemu Windows za pomocą pliku odpowiedzi Winbom.ini

  1. Utwórz plik odpowiedzi Winbom.ini albo zmodyfikuj istniejący plik Winbom.ini.
  2. Dodaj sekcje i wpisy Zapory systemu Windows zdefiniowane przez użytkownika, aby dodać programy, usługi, porty statyczne oraz komunikaty protokołu ICMP do listy wyjątków Zapory systemu Windows. Aby uzyskać szczegółowe informacje, zobacz tematy [WindowsFirewall] w dokumencie Windows Preinstallation Reference. Sekcje i wpisy zdefiniowane przez użytkownika są takie same w przypadku plików Unattend.txt i Winbom.ini. Zobacz poprzedni przykład dotyczący pliku odpowiedzi Unattend.txt.
  3. Uruchom narzędzie Sysprep -factory.

Aby wyłączyć Zaporę systemu Windows za pomocą pliku odpowiedzi Winbom.ini

  1. Utwórz plik odpowiedzi Winbom.ini albo zmodyfikuj istniejący plik Winbom.ini.
  2. Dodaj następujące sekcje i wpisy do pliku odpowiedzi Winbom.ini:
    [WindowsFirewall]
Profiles = WindowsFirewall.TurnOffFirewall

[WindowsFirewall.TurnOffFirewall]
Mode = 0

    Uwaga

    • Dodanie wpisu Type do sekcji [WindowsFirewall.TurnOffFirewall] nie jest konieczne. Wartość domyślna All jest stosowana w przypadku, gdy nie ma wpisu Type.
  3. Uruchom narzędzie Sysprep -factory.

Używanie pliku Netfw.inf Zapory systemu Windows do konfigurowania ustawień domyślnych

Jeżeli użytkownik końcowy wprowadza zmiany w ustawieniach Zapory systemu Windows, a następnie decyduje się na użycie przycisku Przywróć domyślne na karcie Zaawansowane w aplecie Zapora systemu Windows w Panelu sterowania, ustawienia domyślne są odczytywane z pliku Netfw.inf. Konfiguracje Zapory systemu Windows wprowadzone przy użyciu plików Unattend.txt lub Winbom.ini są ignorowane. Jeżeli kliknięcie przycisku Przywróć domyślne ma przywracać domyślne ustawienia fabryczne, należy użyć pliku Netfw.inf, aby dostosować listę wyjątków Zapory systemu Windows.

Aby uzyskać informacje, jak przy użyciu pliku Netfw.inf konfigurować listę wyjątków Zapory systemu Windows i domyślne ustawienia zapory, należy zapoznać się z dokumentacją Using the Windows Firewall .Inf File in Microsoft Windows XP Service Pack 2 na dysku CD zestawu OPK.


Ustawienia Menedżera instalacji

Menedżer instalacji zawiera szereg stron, których listę przedstawiono w poniższej tabeli. Aby uzyskać informacje, gdzie są zapisywane ustawienia z poszczególnych stron Menedżera instalacji, kliknij odpowiednią stronę w tej tabeli.

Ważne

  • Nazwa użytkownika i hasło wybierane w celu nawiązania połączenia z udziałem dystrybucyjnym mają postać zwykłego tekstu, co może stanowić zagrożenie dla bezpieczeństwa. Zaleca się, aby temu użytkownikowi udzielić tylko minimalnych praw niezbędnych do ustanowienia połączenia.
Tytuł strony | Opis
Nowy lub istniejący plik odpowiedzi | Umożliwia utworzenie nowego lub edytowanie istniejącego pliku odpowiedzi.
Typ instalacji | Zawiera trzy opcje instalacji: nienadzorowana, z użyciem narzędzia Sysprep lub z użyciem usług instalacji zdalnej (RIS).
Produkt | Monituje o wybranie produktu Windows, który ma zostać zainstalowany.
Interakcja użytkownika | Monituje o wybranie żądanego poziomu interakcji użytkownika.
Udział dystrybucyjny | Umożliwia utworzenie nowego lub zmodyfikowanie istniejącego udziału dystrybucyjnego albo zainstalowanie systemu Windows z dysku CD.
Lokalizacja plików instalacyjnych | Monituje o lokalizację plików instalacyjnych, które mają zostać skopiowane.
Lokalizacja udziału dystrybucyjnego | Monituje o lokalizację udziału dystrybucyjnego, który ma zostać utworzony lub zmodyfikowany.
Nazwa i organizacja | Umożliwia podanie domyślnej nazwy użytkownika i organizacji.
Ustawienia ekranu | Umożliwia zmianę ustawień kolorów, obszaru ekranu i częstotliwości odświeżania.
Strefa czasowa | Monituje o wybór domyślnej strefy czasowej.
Klucz produktu | Monituje o podanie klucza produktu. Identyfikuje on daną kopię systemu Windows.
Nazwy komputerów | Monituje o podanie nazw komputerów docelowych.
Hasło administratora | Umożliwia określenie hasła konta Administrator na wszystkich komputerach docelowych.
Komputery sieciowe | Umożliwia wybranie typowych lub niestandardowych ustawień sieciowych.
Grupa robocza lub domena | Monituje o określenie, jaką rolę komputery docelowe będą pełnić w sieci.
Składniki systemu Windows | Umożliwia zainstalowanie najczęściej używanych składników systemu Windows.
Telefonia | Umożliwia podanie informacji o telefonii użytkownikom końcowym.
Ustawienia regionalne | Umożliwia dostosowanie systemu Windows do różnych regionów i języków.
Języki | Monituje o wybór grup języków, które mają być używane.
Ustawienia przeglądarki i powłoki | Umożliwia dostosowanie ustawień przeglądarki i powłoki systemu Windows.
Folder instalacji | Umożliwia określenie nazwy folderu systemu Windows.
Instalowanie drukarek | Umożliwia zainstalowanie drukarek sieciowych na komputerach docelowych.
Uruchamianie jednokrotne | Umożliwia automatyczne uruchomienie polecenia przy pierwszym logowaniu użytkownika.
Dodatkowe polecenia | Umożliwia dodanie poleceń, które będą wykonywane na zakończenie instalacji nienadzorowanej.

Strona Nowy lub istniejący plik odpowiedzi

Żadne ustawienia z tej strony nie są zapisywane.

Strona Typ instalacji

Żadne ustawienia z tej strony nie są zapisywane.

Strona Produkt

Żadne ustawienia z tej strony nie są zapisywane.

Strona Interakcja użytkownika

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[Unattended]

UnattendMode

Ta strona nie jest używana w przypadku instalacji wykonywanych przy użyciu usług instalacji zdalnej (RIS) ani narzędzia Sysprep.

Strona Udział dystrybucyjny

Żadne ustawienia z tej strony nie są zapisywane.

Strona Lokalizacja plików instalacyjnych

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

Strona Lokalizacja udziału dystrybucyjnego

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[Setupmgr]

DistShare

DistFolder

Ta sekcja jest używana przez Menedżera instalacji tylko w przypadku edytowania istniejącego udziału dystrybucyjnego. Nie jest ona używana podczas instalacji nienadzorowanej.

Strona Nazwa i organizacja

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[UserData]

FullName

OrgName

Strona Ustawienia ekranu

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[Display]

BitsPerPel

XResolution

YResolution

VRefresh

Strona Strefa czasowa

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[GuiUnattended]

TimeZone

Strona Klucz produktu

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[UserData]

ProductKey

Strona Nazwy komputerów

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[UserData]

ComputerName

Strona Hasło administratora

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[GuiUnattended]

AdminPassword

EncryptedAdminPassword

Strona Komputery sieciowe

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[Networking]

W przypadku użycia ustawień niestandardowych dodatkowe wpisy pojawiają się pod następującymi nagłówkami:

Unattend.txt

[NetAdapters]

[NetClients]

[NetProtocols]

Strona Grupa robocza lub domena

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[Identification]

Strona Składniki systemu Windows

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[Components]

Strona Telefonia

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[TapiLocation]

Strona Ustawienia regionalne

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[RegionalSettings]

Strona Języki

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[RegionalSettings]

Language

Strona Ustawienia przeglądarki i powłoki

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[FavoritesEx]

Strona Folder instalacji

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[Unattended]

TargetPath

Strona Instalowanie drukarek

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[GuiRunOnce]

Strona Uruchamianie jednokrotne

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Unattend.txt

[GuiRunOnce]

Strona Dodatkowe polecenia

Menedżer instalacji zapisuje określone na tej stronie ustawienia w następującej lokalizacji:

Cmdlines.txt
[Commands]

Ustawienia określone na tej stronie są zapisywane tylko w przypadku wybrania opcji utworzenia nowego lub modyfikacji istniejącego udziału dystrybucyjnego. W przypadku wybrania opcji instalacji z dysku CD wszelkie ustawienia wprowadzone na tej stronie są ignorowane.


Uruchamianie Instalatora za pomocą programu Winnt32.exe

Używając programu Winnt32.exe w wierszu polecenia, można uruchomić Instalatora systemu Windows na komputerze, na którym działa jeden z następujących systemów operacyjnych:

  • Windows XP
  • Windows 2000
  • Windows NT
  • Windows Millennium Edition
  • Windows 98
  • Windows 95

Aby uzyskać pełną listę opcji wiersza polecenia programu Winnt32.exe, zobacz Opcje wiersza polecenia programu Winnt32.exe.

Aby uruchomić Instalatora za pomocą programu Winnt32.exe

  1. Na komputerze produkcyjnym przygotuj plik Unattend.txt za pomocą Menedżera instalacji.
  2. Uruchom komputer docelowy przy użyciu jednego z wyżej wymienionych systemów operacyjnych.
  3. Kliknij przycisk Start, kliknij polecenie Uruchom, a następnie wpisz polecenie:

    ścieżka_do_pliku_winnt32\winnt32 /unattend:nazwa_pliku

    ścieżka_do_pliku_winnt32
    Określa ścieżkę do lokalizacji pliku Winnt32.exe. Na przykład \\serwer\udział\I386.
    nazwa_pliku
    Określa nazwę pliku odpowiedzi zawierającego zautomatyzowane odpowiedzi na pytania pojawiające się podczas instalacji. Wartością parametru nazwa_pliku jest zwykle plik Unattend.txt.

Po zakończeniu pracy Instalatora można preinstalować aplikacje, wykonać inspekcję systemu i uruchomić program Sysprep w celu doprowadzenia systemu do stanu gotowości do przekazania klientowi. Aby uzyskać więcej informacji, zobacz Preinstalowanie aplikacji, Inspekcja instalacji za pomocą narzędzia Sysprep i Przygotowanie instalacji do rozmieszczenia.

Uwagi

  • Aby zapewnić czystą instalację, nie należy instalować systemu Windows XP ani systemu z rodziny Windows Server 2003 jako uaktualnienia.
  • Inna sieciowa metoda preinstalowania systemu Windows XP to użycie serwera instalacji zdalnej. Omówiono ją w zestawie Microsoft Windows Server 2003 Resource Kit.


Uruchamianie Instalatora za pomocą programu Winnt.exe

Uruchamiając program Winnt.exe z wiersza polecenia, można uruchomić Instalatora systemu Windows na komputerze, na którym zainstalowany jest jeden z następujących starszych systemów operacyjnych:

  • MS-DOS
  • Windows 3.1
  • Windows for Workgroups

Powyższe systemy operacyjne nie obsługują długich nazw plików, dlatego wszystkie pliki i foldery w udziale dystrybucyjnym muszą mieć format 8.3, aby Instalator systemu Windows (Winnt.exe) mógł skopiować pliki. Aby podczas instalacji systemu Windows przywrócić długie nazwy plików o nazwach w formacie 8.3, w udziale dystrybucyjnym należy umieścić plik $$Rename.txt. Plik $$Rename.txt musi być umieszczony w folderze $OEM$\$1.

Aby uzyskać więcej informacji, zobacz Konwertowanie krótkich nazw plików na długie nazwy plików.

Aby uzyskać pełną listę opcji wiersza polecenia programu Winnt32.exe, zobacz Opcje wiersza polecenia programu Winnt.exe.

Za pomocą programu Winnt.exe można także zainstalować system Windows przez sieć. Należy uruchomić każdy komputer docelowy za pomocą jednego z wyżej wymienionych systemów operacyjnych, umieszczonego na nośniku wymiennym. Można na przykład użyć dysku rozruchowego systemu MS-DOS z obsługą sieci.

Aby uruchomić Instalatora za pomocą programu Winnt.exe

  1. Upewnij się, że niezbędne sterowniki stacji CD-ROM są dostępne na dysku lub w stacji i że są ładowane prawidłowo.
  2. Na komputerze produkcyjnym użyj Menedżera instalacji do utworzenia pliku Unattend.txt.
  3. Uruchom komputer docelowy przy użyciu jednego z wyżej wymienionych systemów operacyjnych.
  4. Kliknij przycisk Start, kliknij polecenie Uruchom, a następnie wpisz:

    winnt /s:źródło_instalacji /u:nazwa_pliku

    źródło_instalacji
    Określa lokalizację plików systemu Windows.
    nazwa_pliku
    Określa nazwę pliku odpowiedzi, zazwyczaj Unattend.txt.

Po zakończeniu pracy Instalatora można przystąpić do preinstalowania aplikacji, dokonać inspekcji systemu i uruchomić narzędzie Sysprep w celu przekonwertowania stanu systemu na tryb gotowości do odbioru przez klienta.

Aby uzyskać więcej informacji, zobacz Preinstalowanie aplikacji, Inspekcja instalacji za pomocą narzędzia Sysprep i Przygotowanie instalacji do rozmieszczenia.

Uwaga

  • Jeśli instalacja nienadzorowana zostanie uruchomiona na komputerze z kilkoma dyskami twardymi lub partycjami, należy określić lokalizację docelową. Do określenia lokalizacji można użyć opcji wiersza polecenia Winnt /t lub Winnt32 /tempdrive.


Konwertowanie krótkich nazw plików na długie nazwy plików

W przypadku użycia programu Winnt.exe do preinstalacji systemu operacyjnego wszystkie pliki i foldery w udziale dystrybucyjnym muszą mieć format 8.3, aby Instalator systemu Windows mógł skopiować pliki. Ponadto należy zawsze używać nazw plików w formacie 8.3 w przypadku kopiowania zestawu plików z jednego komputera na inny w systemie MS-DOS.

Aby podczas instalacji systemu Windows przywrócić te nazwy z formatu 8.3 do długich nazw plików, należy użyć pliku $$Rename.txt. Plik $$Rename.txt musi znajdować się w folderze $OEM$\$1.

Składnia pliku $$Rename.txt

Składnia pliku $$Rename.txt:

["Nazwa_sekcji_1]"
"Krótka_nazwa_1 = "Długa_nazwa_1[$$]"
Krótka_nazwa_2 = "Długa_nazwa_2[$$]"
.
.
"Krótka_nazwa_x = "Długa_nazwa_x[$$]"

[Nazwa_sekcji_2]
.
.

Parametry

Nazwa_sekcji_1, Nazwa_sekcji_2 i tak dalej
Ścieżki do folderów zawierających pliki. Sekcja może nie mieć nazwy lub jej nazwą może być kreska ułamkowa odwrócona (\). Kreska ułamkowa odwrócona wskazuje, że sekcja zawiera nazwy plików lub podfolderów, które znajdują się w katalogu głównym dysku.
Krótka_nazwa_1, Krótka_nazwa_2 i tak dalej
Nazwy plików lub podfolderów w tym folderze, które muszą być zmienione. Tych nazw nie należy ujmować w cudzysłów.
Długa_nazwa_1, Długa_nazwa_2 i tak dalej
Nowe nazwy plików lub podfolderów. Jeśli nazwa zawiera spacje lub przecinki, należy ująć ją w cudzysłów. Na przykład:
[\]
Nazwa_pliku.xxx = "Długa nazwa pliku.xxx"

Jeśli nazwa Długa_nazwa_x jest nazwą katalogu profili, do której na końcu są dołączone znaki "$$", Instalator scala ten katalog z bieżącym katalogiem profili.

Na przykład, jeśli plik $$Rename.txt zawiera następujące wpisy:

[\]
D = "Documents and Settings$$"

to pliki z listy w tej sekcji zostaną umieszczone w katalogu profili "Documents and Settings$$".


Korzystanie ze skryptów wsadowych

Menedżer instalacji tworzy przykładowy skrypt wsadowy, aby zilustrować sposób użycia utworzonego pliku odpowiedzi. W niektórych przypadkach, aby zapewnić prawidłowe działanie przykładowego skryptu wsadowego, trzeba go zmodyfikować.

Plik odpowiedzi należy zawsze przekazać do Instalatora systemu Windows, stosując opcję /unattend: albo z poleceniem Winnt32 (w przypadku systemów Win32), albo z poleceniem Winnt (w przypadku systemu MS-DOS). Aby uzyskać więcej informacji, zobacz Opcje wiersza polecenia programu Winnt32.exe lub Opcje wiersza polecenia programu Winnt.exe. Przykład zawiera przykładowy skrypt wsadowy.

W przypadku rozmieszczania systemu za pomocą udziału dystrybucyjnego należy zmienić przykładowy skrypt wsadowy, tak aby odwoływał się do tego udziału.

Jeśli plik odpowiedzi został skopiowany do innej lokalizacji, to należy zmodyfikować skrypt wsadowy tak, aby odwoływał się do nowej lokalizacji.

Korzystanie z plików udf

Jeśli określono wiele nazw komputerów, Menedżer instalacji tworzy skrypt wsadowy, który oczekuje przekazania nazwy komputera w wierszu polecenia. W takim przypadku obecny musi być również plik udf.

Korzystając z pliku udf do zarządzania przypisywaniem nazw wielu komputerom, należy użyć programu Winnt32.exe lub Winnt.exe z opcją /udf. Przykład zawiera przykładowy skrypt wsadowy utworzony przez Menedżera instalacji.


Przygotowanie instalacji do rozmieszczenia

Program Sysprep to narzędzie przeznaczone dla administratorów systemów w firmach, producentów OEM oraz innych osób, które rozmieszczają system Windows XP na wielu komputerach. Po ukończeniu na jednym komputerze początkowych kroków instalacji można uruchomić narzędzie Sysprep w celu przygotowania tego komputera do duplikacji. Przy pierwszym uruchomieniu ponownym każdego komputera docelowego narzędzie Sysprep przypisuje mu unikatowy identyfikator zabezpieczeń (SID). Narzędzie Sysprep konfiguruje system operacyjny do użycia apletu System Windows - Zapraszamy! lub miniinstalacja przy pierwszym uruchomieniu ponownym komputera przez użytkownika końcowego. Ta skrócona forma instalacji w trybie graficznym zajmuje od pięciu do sześciu minut zamiast 45 do 60 minut, a użytkownik końcowy jest monitowany tylko o wymagane, informacje specyficzne dla użytkownika, na przykład o zaakceptowanie Umowy Licencyjnej Użytkownika Oprogramowania (EULA) oraz wprowadzenie klucza produktu, nazwy użytkownika i nazwy firmy.

Narzędzie Sysprep jest przydatne nawet wtedy, gdy nie jest stosowane duplikowanie dysku. Można uruchomić je z opcją -nosidgen, aby skonfigurować aplet System Windows - Zapraszamy! lub miniinstalacja na jednym komputerze. W takim przypadku narzędzie Sysprep umożliwia przeprowadzenie dodatkowej inspekcji; automatyzuje proces miniinstalacji — dzięki czemu użytkownicy mogą nadal wprowadzać specyficzne dla nich informacje, na przykład opcje ustawień regionalnych i informacje TAPI, a także pomija tworzenie unikatowych identyfikatorów SID, ponieważ będą one unikatowe podczas uruchamiania Instalatora na komputerze.

Aby uzyskać więcej informacji o narzędziu Sysprep, zobacz:

  • Korzystanie z narzędzia Sysprep
  • Korzystanie z narzędzia Sysprep w trybie fabrycznym
  • Składniki narzędzia Sysprep
  • Narzędzie Sysprep a aktywacja produktu Windows
  • Przygotowywanie obrazów używanych do duplikowania dysków
  • Inspekcja instalacji za pomocą narzędzia Sysprep
  • Opcje wiersza polecenia narzędzia Sysprep


Korzystanie z narzędzia Sysprep

Podczas wdrażania systemu Windows XP należy całkowicie zainstalować system operacyjny oraz wstępnie skonfigurować powłokę i aplikacje w wymaganym zakresie. Następnie można użyć narzędzia Sysprep w celu umożliwienia dostosowania komputera do wymagań określonego użytkownika, jeśli komputer ma być dostarczony użytkownikowi lub skonfigurowany dla niego. W takim wypadku podczas pierwszego uruchomienia komputera przez użytkownika końcowego aplet System Windows — Zapraszamy! lub miniinstalacja wyświetla monit o wprowadzenie minimalnej ilości informacji. Folder Sysprep jest automatycznie usuwany z dysku twardego, gdy program początkowy zakończy działanie.

Narzędzie Sysprep może być użyte w trzech różnych kontekstach:

  • Duplikacja dysków. Użycie narzędzia Sysprep do przygotowania obrazów w celu duplikacji dysków umożliwia skopiowanie w pełni zainstalowanych systemów na komputery z podobnym sprzętem. Narzędzie Sysprep modyfikuje identyfikator zabezpieczeń (SID) komputera lokalnego, dzięki czemu jest on unikatowy dla każdego komputera.
  • Inspekcja. W przypadku użycia narzędzia Sysprep po wykonaniu inspekcji komputera (przy użyciu opcji wiersza polecenia -nosidgen) przygotowuje ono system Windows do uruchomienia przez użytkownika końcowego.
  • Narzędzie Sysprep tworzy skróconą instalację w trybie graficznym, która zajmuje od pięciu do sześciu minut zamiast, jak zazwyczaj, od 45 do 60 minut. W trakcie tej instalacji użytkownik końcowy jest monitowany jedynie o potrzebne informacje specyficzne dla użytkownika, na przykład o zaakceptowanie Umowy Licencyjnej Użytkownika Oprogramowania (EULA) oraz wprowadzenie klucza produktu, nazwy użytkownika i nazwy firmy. Aby użyć narzędzia Sysprep w tym trybie, należy preinstalować system Windows XP na komputerze lokalnym, a następnie uruchomić narzędzie Sysprep z opcją -nosidgen.

Aby uzyskać więcej informacji, zobacz:

  • Korzystanie z narzędzia Sysprep w trybie fabrycznym
  • Opcje wiersza polecenia narzędzia Sysprep
  • Składniki narzędzia Sysprep

Aby za pomocą narzędzia Sysprep ręcznie przywrócić stan gotowości komputera do użycia przez użytkownika końcowego

  1. Kliknij przycisk Start, kliknij polecenie Uruchom, a następnie wpisz polecenie:

    cmd

  2. W wierszu polecenia przejdź do katalogu głównego na dysku systemowym (%SYSTEMDRIVE%), a następnie wpisz polecenie:

    md sysprep

  3. Z pliku \Support\Tools\Deploy.cab znajdującego się na dysku CD z produktem Windows XP skopiuj pliki Sysprep.exe i Setupcl.exe do utworzonego folderu Sysprep.
  4. Wyjmij dysk CD z produktem Windows.
  5. W wierszu polecenia przejdź do folderu Sysprep, a następnie wpisz polecenie:

    sysprep -nosidgen

    z wszelkimi opcjami dodatkowymi. Aby uzyskać listę opcji wiersza polecenia, zobacz Opcje wiersza polecenia narzędzia Sysprep.

  6. Jeśli komputer jest zgodny z systemem ACPI, po zakończeniu instalacji zostaje automatycznie zamknięty. Jeśli komputer jest niezgodny z systemem ACPI, na zakończenie tego procesu zostaje wyświetlony monit o zamknięcie komputera.

Aby zautomatyzować proces przywracania stanu gotowości komputera do przekazania użytkownikowi końcowemu

  1. W folderze \$OEM$\$1 udziału dystrybucyjnego utwórz podfolder o nazwie \Sysprep.
  2. Dodaj pliki Sysprep.exe i Setupcl.exe do folderu \$OEM$\$1\Sysprep z pliku \Support\Tools\Deploy.cab znajdującego się na dysku CD z produktem Windows. Jeśli to konieczne, możesz również utworzyć i umieścić w tym folderze plik odpowiedzi, Sysprep.inf.
  3. W pliku odpowiedzi dodaj następujący wiersz na końcu sekcji [GuiRunOnce]:
    %SYSTEMDRIVE%\sysprep\sysprep.exe -quiet dodatkowe wymagane opcje

    Aby uzyskać listę opcji wiersza polecenia, zobacz Opcje wiersza polecenia narzędzia Sysprep.

  4. Jeśli komputer jest zgodny z systemem ACPI, po zakończeniu instalacji zostaje automatycznie zamknięty. Jeśli komputer jest niezgodny z systemem ACPI, na zakończenie tego procesu zostaje wyświetlony monit o zamknięcie komputera.

Uwagi

W systemie Windows XP:

  • Plik Sysprep.inf musi znajdować się w tej samej lokalizacji, co pliki Sysprep.exe i Setupcl.exe. Te pliki narzędzia Sysprep muszą znajdować się w folderze %SYSTEMDRIVE%\Sysprep na dysku twardym komputera docelowego.
  • Po uruchomieniu programu Sysprep.exe plik Sysprep.inf jest kopiowany do pliku %WINDIR%\System32\$winnt$.inf.
  • W pliku Sysprep.inf można określić statyczne adresy IP. Po uruchomieniu komputera docelowego informacje o karcie sieciowej są usuwane, ale technologia Plug and Play instaluje ponownie kartę sieciową. Miniinstalacja odczytuje informacje o statycznym adresie IP z pliku Sysprep.inf i ustawia statyczny adres IP na komputerze docelowym.
  • Narzędzie Sysprep można uruchomić tylko w przypadku, gdy komputer jest członkiem grupy roboczej, a nie domeny. Jeśli komputer jest dołączony do domeny, narzędzie Sysprep usuwa go z domeny.
  • Na zakończenie miniinstalacji można uruchomić dodatkowe programy lub polecenia. W tym celu należy umieścić w folderze \Sysprep plik Cmdlines.txt.

    Aby uzyskać więcej informacji o pliku Cmdlines.txt, zobacz Preinstalowanie aplikacji przy zastosowaniu starszych metod.

  • Narzędzia Sysprep nie można uruchomić na komputerze, który skonfigurowano jako serwer usługi klastrowania, serwer usług certyfikatów lub kontroler domeny. Narzędzie Sysprep można uruchomić na serwerze autonomicznym.
  • Jeśli narzędzie Sysprep zostanie uruchomione na partycji z systemem plików NTFS, która zawiera zaszyfrowane pliki lub foldery, danych z tych folderów nie będzie można odczytać ani odzyskać.
  • Tej wersji narzędzia Sysprep można używać tylko w przypadku instalacji systemu Windows XP. Nie można jej stosować podczas instalacji systemu Windows 2000.
  • Narzędzie Sysprep powinno być używane jedynie w przypadku nowych instalacji systemu Windows podczas przygotowywania do wdrożenia. Nie należy go stosować w instalacjach, które są w trakcie wdrażania lub uaktualniania.


Korzystanie z narzędzia Sysprep w trybie fabrycznym

Tryb fabryczny narzędzia Sysprep to metoda wstępnego konfigurowania opcji instalacji, która pozwala zmniejszyć liczbę utrzymywanych obrazów instalacji.

Trybu fabrycznego można używać do instalowania dodatkowych sterowników i aplikacji po rozruchu ponownym, który następuje po zakończeniu działania narzędzia Sysprep. Normalnie uruchomienie narzędzia Sysprep stanowi ostatni krok procesu preinstalacji, przygotowujący komputer do przekazania klientowi. Po ponownym uruchomieniu komputera jest wyświetlany aplet System Windows - Zapraszamy! lub miniinstalacja. Gdy narzędzie Sysprep zostanie uruchomione z opcją -factory, następuje ponowne uruchomienie komputera w trybie z obsługą sieci, bez uruchamiania apletu System Windows - Zapraszamy! ani miniinstalacji. W tym trybie program Factory.exe przetwarza plik odpowiedzi, Winbom.ini, i wykonuje następujące czynności:

  • Kopiuje sterowniki ze źródła sieciowego na komputer
  • Uruchamia wyliczanie urządzeń Plug and Play
  • Umieszcza, instaluje i odinstalowuje aplikacje na komputerze, korzystając z plików źródłowych znajdujących się na komputerze lub w źródle sieciowym
  • Dodaje dane o kliencie

W tym trybie można wykonać inspekcję komputera. Po zakończeniu należy uruchomić narzędzie Sysprep z opcją -reseal, aby przygotować komputer do przekazania klientowi.

Można na przykład utworzyć instalację wzorcową zawierającą minimalny zestaw sterowników, uruchomić polecenie sysprep -factory, utworzyć obraz instalacji i skopiować go na wiele komputerów docelowych. Jeśli któryś komputer docelowy wymaga dodatkowych sterowników, należy uruchomić na nim polecenie sysprep -factory i wówczas załadować potrzebne sterowniki.

W trybie fabrycznym można wstępnie wypełnić plik odpowiedzi, Winbom.ini, informacjami o użytkowniku, takimi jak nazwa, strefa czasowa i tak dalej. W trybie fabrycznym można także zaktualizować inne pliki .ini lub pliki odpowiedzi, takie jak Sysprep.inf czy Oobeinfo.ini lub pliki .isp i pliki .ins.

Uwaga

  • Po zapieczętowaniu komputera przy użyciu narzędzia Sysprep można uruchomić go ponownie bez uruchamiania apletu System Windows - Zapraszamy!, dodając wpis OEMAuditBoot = 1 w sekcji [StartupOptions] pliku Oobeinfo.ini.

Aby uzyskać więcej informacji na temat innych opcji narzędzia Sysprep, zobacz Opcje wiersza polecenia narzędzia Sysprep.

Lokalizowanie pliku Winbom.ini

Narzędzie Sysprep wyszukuje plik Winbom.ini w poniższych lokalizacjach w podanej kolejności:

  1. Ścieżka i nazwa pliku określone w kluczu rejestru HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory\Winbom
  2. Katalog główny każdej stacji nośników wymiennych, która nie jest stacją dysków CD-ROM, na przykład stacji dyskietek
  3. Katalog główny każdej stacji dysków CD-ROM
  4. Lokalizacja pliku Factory.exe, zwykle folder %SYSTEMDRIVE%\Sysprep.
  5. Katalog główny %SYSTEMDRIVE%

Po zlokalizowaniu pliku Winbom.ini narzędzie Sysprep odczytuje wartość wpisu WinbomType w sekcji [Factory]

Jeśli wartość WinbomType jest nieodpowiednia w danym kontekście, znaleziony plik Winbom.ini jest ignorowany i narzędzie Sysprep kontynuuje wyszukiwanie pliku Winbom.ini. Jeśli wartość wpisu WinbomType jest odpowiednia w danym kontekście, narzędzie Sysprep odczytuje wartość wpisu NewWinbom w sekcji [Factory]. Jeśli wartość NewWinbom jest określona, a plik Winbom.ini znajduje się w danej lokalizacji, narzędzie Sysprep sprawdza obecność wpisu NewWinbom w pliku Winbom.ini.

Ten cykl jest powtarzany, dopóki narzędzie Sysprep nie znajdzie pliku Winbom.ini prawidłowego typu, nie zawierającego wpisu NewWinbom, albo co najwyżej dziesięć razy, w zależności od tego, co nastąpi wcześniej. Następnie narzędzie Sysprep kontynuuje działanie w trybie fabrycznym, wykorzystując ustawienia z ostatniego rozpoznanego pliku Winbom.ini.

W przypadku uruchamiania narzędzia Sysprep w trybie fabrycznym wpis NewWinbom jest przetwarzany tylko raz przy każdym rozruchu.


Składniki narzędzia Sysprep

Pliki stanowiące składniki narzędzia Sysprep to:

  • Sysprep.exe
  • Setupcl.exe
  • Factory.exe
  • Sysprep.inf
  • Winbom.ini

Pliki aplikacji (Sysprep.exe, Setupcl.exe i Factory.exe) są wymagane i nawzajem od siebie zależne.

Sysprep.inf

Plik Sysprep.inf jest opcjonalnym plikiem odpowiedzi, którego można użyć do pełnego lub częściowego zautomatyzowania miniinstalacji. Podczas miniinstalacji użytkownik jest monitowany o kilka standardowych informacji niezbędnych do skonfigurowania komputera, takich jak ustawienia strefy czasowej i klawiatury. Jeśli jednak plik Sysprep.inf jest dostępny i zawiera wartości wymaganych elementów, miniinstalacja zamiast monitować użytkownika wykorzystuje informacje z tego pliku.

Składnia pliku Sysprep.inf jest podobna do składni pliku odpowiedzi instalacji nienadzorowanej, Unattend.txt. Plik Sysprep.inf obsługuje podzestaw sekcji i wpisów obsługiwanych przez plik Unattend.txt oraz kilka wpisów specyficznych dla narzędzia Sysprep.

Winbom.ini

Plik Winbom.ini określa „wykaz materiałów” narzędzia Factory, które mają być użyte podczas aktualizowania instalacji wzorcowej. Aby użyć narzędzia Factory, należy uruchomić polecenie sysprep -factory.

Aby uzyskać więcej informacji, zobacz Korzystanie z narzędzia Sysprep w trybie fabrycznym i Opcje wiersza polecenia narzędzia Sysprep.

Lokalizacja plików narzędzia Sysprep

Pliki narzędzia Sysprep muszą znajdować się w folderze %SYSTEMDRIVE%\Sysprep.

Po zakończeniu działania narzędzia Sysprep.exe folder %SYSTEMDRIVE%\Sysprep jest usuwany wraz z jego zawartością. Aby po uruchomieniu narzędzia Sysprep folder ten pozostał na dysku twardym, w sekcji [Unattended] pliku Unattend.txt należy ustawić wartość FactoryMode równą Yes.

Aby zagwarantować działanie opcji określonych w pliku Sysprep.inf, plik ten trzeba umieścić w tej samej lokalizacji, co program Sysprep.exe. Plik Winbom.ini może znajdować się w innej lokalizacji.

Uwaga

  • Jeśli nie zostanie użyta opcja wiersza polecenia -nosidgen, narzędzie Sysprep wywoła program Setupcl.exe; narzędzia tego nie można użyć bezpośrednio. Plik Setupcl.exe musi znajdować się w tym samym folderze, co plik Sysprep.exe.

Jeśli przed uruchomieniem narzędzia Sysprep edytowano uprawnienia zabezpieczeń w plikach lub w rejestrze, to należy się upewnić, że konto „System” ma uprawnienia do odczytu/zapisu we wszystkich kontekstach zabezpieczeń. W przeciwnym wypadku przy następnym uruchomieniu komputera system operacyjny może się nie uruchomić.


Narzędzie Sysprep a aktywacja produktu Windows

Aktywacja produktu firmy Microsoft to antypiracka technologia umożliwiająca sprawdzenie, czy użytkownik ma legalną licencję na korzystanie z produktu.

Uaktualnienia systemu Windows XP nabyte na mocy jednej z grupowych umów licencyjnych firmy Microsoft, takiej jak Microsoft Open License, Enterprise Agreement lub Select License, nie wymagają aktywacji. W przypadku instalacji systemu Windows XP przeprowadzanych przy użyciu nośnika licencji grupowej i kluczy produktów licencji grupowej (VLK) nie jest wymagana aktywacja, nie jest sprawdzany sprzęt i nie istnieją ograniczenia dotyczące instalacji ani tworzenia obrazów dysków.

Klucz produktu licencji grupowej jest kluczem produktu wystawionym określonemu klientowi na podstawie określonej umowy licencyjnej. Każdy klucz VLK jest skojarzony z określonym klientem i typem licencjonowanego produktu. W przypadku umów Select License Agreement, Enterprise Agreement, School Agreement i Campus Agreement jeden klucz VLK jest wystawiany na jedną rejestrację i jedną rodzinę produktów. W przypadku umowy Microsoft Open License klucz VLK jest dostarczany wraz z potwierdzeniem zamówienia Open License. Te klucze VLK są używane w odpowiedzi na monit produktu podczas instalacji lub w przypadku tworzenia niestandardowego obrazu. Klucz VLK musi być używany z nośnikiem licencji grupowej. Klucze VLK nie mogą być używane z opakowanym produktem handlowym ani z nośnikiem CD producenta OEM.

Wpis ProductKey w pliku Sysprep.inf pozwala na zautomatyzowanie wprowadzania klucza produktu w obrazach instalacji sieciowej i niestandardowej instalacji z dysku CD. W takim wypadku użytkownicy końcowi nigdy nie są monitowani o wprowadzenie klucza produktu podczas instalacji.

Aktywacja w przypadku nośnika OEM lub nośnika handlowego

Większość użytkowników bez problemów poradzi sobie z aktywacją po otrzymaniu komputerów. Można jednak aktywować oprogramowanie w imieniu klientów, dzięki czemu łatwiej im będzie rozpocząć korzystanie z nowych komputerów, a usługi producenta znacznie zyskają na wartości. Po zakończeniu aktywacji większość użytkowników nigdy nie będzie musiała ponownie uaktywniać swoich instalacji.

Nie można utworzyć obrazu uaktywnionej instalacji systemu Windows i skopiować go na inny komputer. W takim wypadku system Windows nie rozpozna aktywacji i wymusi na użytkowniku końcowym ponowne ręczne uruchomienie aktywacji instalacji.

Aby uaktywnić system Windows dla klienta, podaj unikatowy klucz produktu (wpis ProductKey) z etykiety Certyfikatu Autentyczności przymocowanej do komputera i uaktywnij komputer w imieniu użytkownika. Następnie uruchom polecenie sysprep -reseal, aby zamknąć komputer.

Aby aktywacja instalacji się powiodła, narzędzie Sysprep trzeba uruchomić z opcją wiersza polecenia -activated. Na przykład:

sysprep -activated -reseal

Jeśli nie uruchomisz narzędzia Sysprep z opcją -activated, narzędzie Sysprep usuwa bieżące ustawienia aktywacji i resetuje zegar aktywacji produktu Windows.

Zegar aktywacji produktu Windows rozpoczyna odliczanie po pierwszym uruchomieniu systemu Windows XP. Używając narzędzia Sysprep, zegar aktywacji produktu Windows można zresetować maksymalnie trzy razy. Po trzecim uruchomieniu narzędzia Sysprep nie można już zresetować zegara.

Ograniczanie liczby ponownych opieczętowań w narzędziu Sysprep

  • Można utworzyć instalację wzorcową, uruchomić dla niej polecenie sysprep -reseal, utworzyć obraz tej instalacji, a następnie bezpiecznie go przechowywać przez ponad 30 dni. Odliczanie 30 dni do momentu konieczności aktywacji produktu Windows nie rozpoczyna się, dopóki system operacyjny nie zostanie ponownie uruchomiony.
  • Jeśli nie chcesz resetować zegara lub chcesz zachować ustawienia, gdy uruchamiasz narzędzie Sysprep dla instalacji, która jest już uaktywniona, użyj opcji wiersza polecenia -activated. Wpisz na przykład:
    sysprep -activated -reseal
  • Używając polecenia sysprep -activated, można uniknąć zresetowania wstępnego okresu aktywacji. Wymaga to wstępnego, fabrycznego uaktywnienia systemu.
  • Zresetowania okresu wstępnego można uniknąć, używając w instalacjach fabrycznych opcji preinstalacji z zablokowanym systemem (SLP).
  • Ustawiając przed ponownym opieczętowaniem parametr OEMAuditBoot = 1 w sekcji [Startup] pliku Oobeinfo.ini, można określić, że komputer zostanie ponownie uruchomiony w trybie fabrycznym. Jest to równoważne użyciu polecenia sysprep -factory.
  • Jeśli jest niezbędne zmodyfikowanie konfiguracji komputera przed dostarczeniem go użytkownikowi końcowemu, można nacisnąć klawisze CTRL+SHIFT+F3 na ekranie powitalnym systemu Windows, aby ponownie wejść w tryb inspekcji.

Aby uzyskać więcej informacji, zobacz:

  • Aktywacja produktu Windows
  • Opcje wiersza polecenia narzędzia Sysprep


Przygotowywanie obrazów używanych do duplikowania dysków

Aby można było korzystać z narzędzia Sysprep w ramach procesu duplikacji dysków, muszą być spełnione następujące wymagania:

  • Instalacja wzorcowa i komputery docelowe muszą mieć zgodne warstwy abstrakcji sprzętowej (HAL). Na przykład warstwy HAL APIC i HAL MP (dla systemów wieloprocesorowych) są zgodne, podczas gdy warstwa HAL PIC (programowalny kontroler przerwań) nie jest zgodna ani z warstwą HAL APIC, ani HAL MP.
  • Kontrolery magazynu masowego (IDE lub SCSI) zainstalowane w komputerze wzorcowym i w komputerach docelowych muszą być takie same.

    Aby jeden obraz wzorcowy mógł być użyty do zainstalowania systemu Windows na komputerach docelowych wyposażonych w różne kontrolery magazynowania masowego, obraz ten powinien zawierać dane wszystkich urządzeń magazynowania masowego wymienionych w plikach Machine.inf, Scsi.inf, Pnpscsi.inf i Mshdc.inf. W tym celu w pliku Sysprep.inf należy umieścić następujące wpisy:

    [Sysprep]
BuildMassStorageSection = Yes
[SysprepMassStorage]

    Aby uzyskać więcej informacji, zobacz Zmniejszanie liczby obrazów wzorcowych dla komputerów wyposażonych w różne kontrolery magazynowania masowego.

  • Zainstalowane w komputerach docelowych urządzenia Plug and Play, na przykład modemy, karty dźwiękowe, karty sieciowe, karty wideo itd., nie muszą być takie same. Sterowniki urządzeń, których nie ma w pliku Drivers.cab, powinny zostać dodane do instalacji wzorcowej przed uruchomieniem narzędzia Sysprep. Można też zapewnić dostępność niezainstalowanych sterowników na komputerze docelowym przy jego pierwszym uruchomieniu, aby technologia Plug and Play mogła wykryć urządzenia i zainstalować te sterowniki.
  • Wymagane jest oprogramowanie lub urządzenia sprzętowe innych firm do duplikowania dysków. Produkty te tworzą binarny obraz dysku twardego komputera i duplikują ten obraz na inny dysk twardy albo przechowują go w pliku na oddzielnym dysku.
  • Dysk twardy komputera docelowego musi mieć pojemność co najmniej taką samą, jak dysk twardy instalacji wzorcowej. Jeśli dysk twardy zainstalowany w komputerze docelowym ma większą pojemność, różnica pojemności nie jest uwzględniana w partycji podstawowej. Można jednak użyć wpisu ExtendOemPartition w pliku Sysprep.inf w celu rozszerzenia partycji podstawowej, jeśli została ona sformatowana do korzystania z systemu plików NTFS.

    Uwaga

    • Jeśli komputer wzorcowy i komputery docelowe mają różne wersje systemu BIOS , to należy najpierw przetestować cały proces, aby upewnić się, że będzie przebiegać prawidłowo.

Aby przygotować instalację wzorcową do klonowania

  1. Zainstaluj system Windows XP na komputerze wzorcowym. Instalację wzorcową trzeba umieścić na dysku C: lub w udziale dystrybucyjnym. Firma Microsoft zaleca instalowanie systemu Windows XP z udziału dystrybucyjnego przy użyciu pliku odpowiedzi, aby zapewnić spójność konfigurowania instalacji wzorcowej, co ułatwia i przyspiesza tworzenie i testowanie kolejnych instalacji. Aby uzyskać informacje dotyczące automatyzowania instalacji systemu Windows za pomocą plików odpowiedzi, zobacz Unattend.txt.
  2. Zaloguj się na komputerze jako administrator.
  3. (Opcjonalnie) Zainstaluj i dostosuj aplikacje, na przykład pakiet Microsoft Office, elementy ulubione programu Internet Explorer itd.
  4. (Opcjonalnie) Zainstaluj wszelkie sterowniki, których nie ma w pliku Drivers.cab i które nie są instalowane przez plik odpowiedzi.
  5. (Opcjonalnie) Uruchom testy inspekcji.
  6. (Opcjonalnie) Utwórz plik Sysprep.inf, ręcznie lub przy użyciu Menedżera instalacji. Plik ten służy do dostosowywania poszczególnych komputerów do wymagań użytkowników i do określenia informacji, o które użytkownik jest monitowany podczas miniinstalacji.
  7. Uruchom program Sysprep.exe. Upewnij się, że pliki Sysprep.exe i Setupcl.exe są w tym samym folderze %SYSTEMDRIVE%\Sysprep na lokalnym dysku twardym. Jeśli jest używany plik Sysprep.inf, musi on znajdować się w tym samym folderze.

    Ważne

    • Jeśli plik Setupcl.exe nie znajduje się w tym samym katalogu, co plik Sysprep.exe, to narzędzie Sysprep nie działa.
  8. Komputer zamyka się automatycznie, jeśli jest zgodny ze standardem ACPI. W przeciwnym wypadku zostaje wyświetlone okno dialogowe informujące o tym, że komputer można bezpiecznie wyłączyć.
  9. Wyjmij dysk systemowy i wykonaj kroki duplikacji systemu na innych komputerach. Duplikowanie dysków twardych wymaga specjalnego sprzętu lub oprogramowania.

Gdy użytkownik włącza komputer zawierający zduplikowany dysk twardy:

  1. Wykrywane są urządzenia Plug and Play. Zajmuje to około trzech minut.
  2. Miniinstalacja monituje użytkowników o:
    • Zaakceptowanie Umowy Licencyjnej Użytkownika Oprogramowania (EULA).
    • Podanie nazwy użytkownika i organizacji.
    • Przyłączenie się do domeny lub grupy roboczej.
    • Określenie opcji ustawień regionalnych.
    • Określenie informacji o interfejsie TAPI.
    • Określenie protokołów sieciowych i usług do zainstalowania.

    Uwaga

    • Jeśli podczas uruchamiania programu Sysprep.exe użyto pliku Sysprep.inf, to wyświetlane są tylko te okna dialogowe, które zostały pominięte w pliku .inf. Jeśli pominięto ustawienia ekranu, używane są ustawienia domyślne.
  3. Lokalny folder Sysprep, zawierający pliki Sysprep.exe i Sysprep.inf, jest usuwany z dysku %SYSTEMDRIVE%.
  4. Następuje ponowne uruchomienie komputera i wyświetlenie monitu logowania.

Aby uzyskać więcej informacji, zobacz Korzystanie z narzędzia Sysprep w trybie fabrycznym.


Inspekcja instalacji za pomocą narzędzia Sysprep

Proces inspekcji służy do sprawdzenia działania komputera przed przekazaniem go użytkownikowi. Podczas inspekcji można sprawdzić, czy system operacyjny ładuje się, a aplikacje są uruchamiane poprawnie, uruchomić program do defragmentacji dysków, uruchomić narzędzie Chkdsk w celu sprawdzenia, czy na dysku twardym nie ma uszkodzonych plików, sprawdzić, czy umowy licencyjne nie są naruszane, a także czy wszystkie zainstalowane urządzenia są prawidłowo rozpoznawane w Menedżerze urządzeń.

Do zbadania każdego komputera, na którym wdrożono system Windows, można użyć własnych narzędzi inspekcji. Można przetestować komputer, a następnie za pomocą narzędzia Sysprep przywrócić stan gotowości do przekazania użytkownikowi końcowemu. Następnie, gdy użytkownik otrzyma komputer i włączy go po raz pierwszy, uruchomiony zostanie albo aplet System Windows - Zapraszamy!, albo miniinstalacja.

Aby wykonać inspekcję komputera docelowego

  1. Zainstaluj system Windows, wykonując kroki opisane w temacie Korzystanie z narzędzia Sysprep. Po zakończeniu instalacji i ponownym uruchomieniu komputera docelowego będzie na nim działać w pełni zainstalowana wersja systemu Windows.
  2. Utwórz folder \Sysprep, a następnie skopiuj do niego pliki Sysprep.exe i Setupcl.exe. Aby uzyskać więcej informacji, zobacz Korzystanie z narzędzia Sysprep.
  3. Wykonaj inspekcję systemu, korzystając z narzędzia inspekcji innej firmy.

    Ważne

    • Podczas inspekcji nie należy zastępować żadnego pliku systemowego ani w żaden inny sposób zakłócać pracy wstępnie skonfigurowanego komputera, ponieważ narzędzie Sysprep nie jest w stanie wykryć ani przywrócić plików systemowych, które zostaną zmienione przez narzędzia inspekcji.
    • Podczas inspekcji można wykonać rozruch ponowny komputera tyle razy, ile jest to konieczne.
  4. Po zakończeniu inspekcji usuń wszelkie pliki i foldery umieszczone podczas procesu inspekcji na dysku twardym. W wierszu polecenia przejdź do katalogu zawierającego program Sysprep.exe, a następnie wpisz następujące polecenie, dodając w razie potrzeby odpowiednie opcje wiersza polecenia:

    sysprep -nosidgen

    Aby uzyskać więcej informacji, zobacz Opcje wiersza polecenia narzędzia Sysprep.

  5. Natychmiast po zakończeniu pracy narzędzia Sysprep zamknij system Windows. Komputer jest teraz gotowy do przekazania użytkownikowi końcowemu.


Narzędzie Sysprep i hiperwątkowość

Hiperwątkowość umożliwia aplikacjom wielowątkowym równoległe wykonywanie wątków w obrębie każdego procesora. Na komputerze z włączoną hiperwątkowością system Windows XP i systemy z rodziny Windows Server 2003 działają tak, jak w systemie wieloprocesorowym, nawet jeśli jest zainstalowany tylko jeden fizyczny procesor. Aby uzyskać więcej informacji, zobacz Windows Support for Hyper-Threading Technology (http://www.microsoft.com/whdc/hwdev/platform/proc/HT-Windows.mspx).

Jeśli obraz utworzony za pomocą narzędzia Sysprep zostanie wdrożony w systemie z włączoną hiperwątkowością, to w przypadku niezgodnej warstwy abstrakcji sprzętowej (HAL) poprawne uruchamianie komputera może być niemożliwe. Jeśli uruchamianie komputera przebiega poprawnie, wykorzystanie technologii hiperwątkowości może być niemożliwe.

Aby sprawdzić, jaka warstwa HAL jest używana na komputerze:

  1. Na pasku zadań kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. Wpisz DEVMGMT.MSC, a następnie kliknij przycisk OK.

    Zostanie otwarty Menedżer urządzeń.

  3. W Menedżerze urządzeń kliknij znak plus (+) obok ikony Komputer, aby rozwinąć gałąź Komputer i wyświetlić typ warstwy HAL.

Aby zapewnić zgodność obrazów utworzonych przez narzędzie Sysprep z systemami z włączoną hiperwątkowością, obraz wzorcowy trzeba utworzyć na jednym z następujących typów komputerów:

  • Komputer z włączoną hiperwątkowością, zgodny w interfejsem ACPI
  • Komputer oparty na kontrolerze APIC z uruchomionym interfejsem ACPI, który w Menedżerze urządzeń pojawia się jako „Jednoprocesorowy komputer PC z interfejsem ACPI”
  • Komputer wieloprocesorowy, zgodny z interfejsem ACPI

Jeśli obraz Sysprep nie zostanie utworzony na jednym z tych typów komputerów, system Windows nie jest w stanie zaktualizować systemu do używania wielu procesorów. Obraz Sysprep utworzony na komputerze wieloprocesorowym zgodnym z interfejsem ACPI działa w konfiguracji wieloprocesorowej, nawet jeśli obsługa hiperwątkowości jest wyłączona w systemie BIOS.

System Windows automatycznie korzysta z możliwości hiperwątkowości procesora, jeśli są spełnione następujące warunki:

  • Sprzęt komputera obsługuje hiperwątkowość i ta funkcja jest włączona w systemie BIOS komputera.
  • Funkcja hiperwątkowości jest wbudowana w procesor komputera.
  • Instalacja systemu Windows używa warstwy HAL Jednoprocesorowy komputer PC z interfejsem ACPI.
  • System Windows wykryje jeden lub większą liczbę procesorów albo włączone wątki.

Jeśli te warunki są spełnione, system Windows automatycznie aktualizuje warstwę HAL do warstwy „Wieloprocesorowy komputer PC z interfejsem ACPI” i instaluje dodatkowy procesor, który jest wymieniony w sekcji Procesory w Menedżerze urządzeń.

W działającym systemie typem warstwy HAL musi być „Wieloprocesorowy komputer PC z interfejsem ACPI”, gdyż w przeciwnym wypadku możliwości hiperwątkowości procesora nie będą wykorzystywane. Jeśli typem warstwy HAL jest „Jednoprocesorowy komputer PC z interfejsem ACPI”, oznacza to, że przynajmniej jeden z wymienionych warunków nie jest spełniony.


Dostosowywanie i testowanie komputera docelowego

Aby po przeprowadzeniu preinstalacji systemu operacyjnego przygotować komputer docelowy do przekazania użytkownikowi, należy wykonać na nim kilka dodatkowych czynności. Niektóre z nich można wykonać podczas produkcji, inne mogą poczekać do pierwszego uruchomienia komputera przez użytkownika końcowego.

Przykładem czynności tego drugiego rodzaju jest użycie w sekcji [GuiRunOnce] poleceń, które muszą być wykonane w celu dokończenia instalacji na komputerze docelowym, ale ich wykonanie można odłożyć do momentu uruchomienia komputera przez użytkownika końcowego.

Zegar aktywacji produktu Windows rozpoczyna odliczanie przy pierwszym uruchomieniu systemu Windows XP. Zegar aktywacji produktu Windows można resetować przy użyciu narzędzia Sysprep najwyżej trzy razy. Po trzecim uruchomieniu narzędzia Sysprep nie można już zresetować zegara.

  • Preinstalowanie aplikacji
  • Preinstalowanie aplikacji przy zastosowaniu starszych metod
  • Wstępne wypełnianie klucza produktu i wstępna aktywacja systemu Windows
  • Pierwsze uruchomienie systemu przez użytkownika końcowego
  • Wstępne konfigurowanie i automatyzowanie miniinstalacji
  • Usuwanie dostępu do składników systemu Windows
  • Inspekcja komputerów docelowych
  • Preinstalowanie poprawek
  • Preinstalowanie pakietu wielojęzycznego interfejsu użytkownika (MUI)
  • Preinstalowanie pakietów językowych interfejsu


Preinstalowanie aplikacji

Firma Microsoft zaleca, aby wybierając oprogramowanie do preinstalowania decydować się na oprogramowanie spełniające wymagania programu Certified for Windows (http://msdn.microsoft.com/certification/). Aby uzyskać więcej informacji o korzyściach wynikających z uzyskania tego certyfikatu, zobacz Programy logo Microsoft Windows.

Preferowany moment preinstalowania aplikacji na komputerach z systemem Windows to czas pracy narzędzia Sysprep w trybie fabrycznym — należy odpowiednio wypełnić sekcję [OEMRunOnce] w pliku Winbom.ini. Ta technika jest szybsza i zapewnia większą elastyczność.

Jedna z metod przygotowywania takich komputerów polega na rozpoczęciu od podstawowego obrazu systemu operacyjnego, oznakowanego tylko przez logo firmy i skonfigurowanego do uruchomienia narzędzia Sysprep w trybie fabrycznym podczas następnego rozruchu. W przypadku każdego zamówienia wystarczy umieścić na komputerze docelowym podstawowy obraz, zainstalować poszczególne aplikacje zgodnie z zamówieniem klienta, a następnie zapieczętować komputer w celu przygotowania go do dystrybucji. Aplikacje te można zainstalować ręcznie lub używając sekcji [OEMRunOnce] pliku Winbom.ini.

Jeśli jednak instalowane aplikacje są pakietami instalacyjnymi Instalatora Microsoft® Windows®, metoda bardziej efektywna, a zapewniająca te same możliwości dostosowania, polega na umieszczeniu wszystkich aplikacji w instalacji wzorcowej. Podczas umieszczania aplikacji wszystkie pliki są umieszczane na komputerze, ale nie są dokonywane żadne zmiany w rejestrze. Po umieszczeniu na komputerze docelowym obrazu instalacji wzorcowej poszczególne aplikacje można albo dołączyć (dokończyć instalację), albo odłączyć (usunąć wszystkie pliki), aby skonfigurować komputer zgodnie z zamówieniem klienta. Instalacja aplikacji dołączonej przebiega szybciej, ponieważ Instalator nie musi kopiować plików na komputer. Ponadto o wiele szybciej można usunąć pliki z komputera niż zainstalować aplikację przez sieć, zwłaszcza gdy aplikacja ta jest instalowana na większości komputerów, na których jest wdrażany system.

W przypadku dodawania aplikacji do profilu Właściciel (w systemie Windows XP Home Edition) lub Administrator (w innych wersjach systemu Windows) aplet System Windows - Zapraszamy! lub miniinstalacja kopiuje te aplikacje do domyślnego profilu użytkownika, dzięki czemu są one dostępne, gdy użytkownik końcowy zaloguje się. Jeśli aplikacje mają być zainstalowane dla poszczególnych kont użytkowników, trzeba je zainstalować po zakończeniu pracy apletu System Windows - Zapraszamy! lub miniinstalacji. Ewentualnie można je zainstalować przy użyciu innego konta użytkownika niż Właściciel lub Administrator.

Przykład: preinstalowanie powszechnie sprzedawanych aplikacji

Firma Fabrikam Inc. jest producentem OEM wytwarzającym komputery na zamówienie. Jako opcje standardowe firma Fabrikam oferuje trzy aplikacje ogólnego zastosowania. Na podstawie analizy wielkości sprzedaży w przeszłości firma Fabrikam wie, że 80 procent jej klientów zamawia pierwszą, 70 procent — drugą, a 50 procent — trzecią z tych aplikacji.

Na komputerach sprzedawanych w ofercie standardowej firma Fabrikam kompiluje zestaw konfiguracyjny podstawowego obrazu systemu danego typu komputera. W oknie dialogowym Dodawanie aplikacji Menedżera instalacji wszystkie trzy aplikacje są identyfikowane jako aplikacje korzystające ze skryptów Instalatora Microsoft Windows (.msi).

Menedżer instalacji generuje plik Winbom.ini, na podstawie którego pliki trzech różnych aplikacji są kopiowane na komputer wzorcowy, ale same aplikacje nie są instalowane całkowicie. Podczas zamykania systemu komputer jest konfigurowany do ponownego uruchomienia programu Sysprep w trybie fabrycznym.

[OEMRunOnce]
"Połączenie z udziałem sieciowym", "net use R: \\serwer\udział"
"Umieszczenie pierwszej aplikacji", "Application1.Stage", MSI
"Umieszczenie drugiej aplikacji", "Application1.Stage", MSI
"Umieszczenie trzeciej aplikacji", "Application3.Stage", MSI

[Application1.Stage]
InstallType = Stage
StagePath = "C:\App1_Temp"
SetupFile = "Application_One.msi"
SourcePath = "R:\ApplicationOne"

[Application1.Stage]
InstallType = Stage
StagePath = "C:\App2_Temp"
SetupFile = "Application_Two.msi"
SourcePath = "R:\ApplicationTwo"

[Application3.Stage]
InstallType = Stage
StagePath = "C:\App3_Temp"
SetupFile = "Application_Three.msi"
SourcePath = "R:\ApplicationThree"

[Factory]
ResealMode = Factory
Reseal = Yes

Firma Fabrikam tworzy obraz instalacji wzorcowej. Ponadto pracownicy firmy utworzyli niestandardowe narzędzie do generowania plików Winbom.ini odpowiadających zamówieniom klientów i umieszczania tych plików na dyskietkach.

W fabryce monter otrzymuje zlecenie wraz z odpowiednią dyskietką, kopiuje obraz instalacji wzorcowej na komputer docelowy i umieszcza dyskietkę w stacji dysków. Komputer po ponownym rozruchu w fabryce jest uruchamiany w trybie fabrycznym narzędzia Sysprep, co powoduje przetworzenie pliku Winbom.ini odpowiadającego zamówieniu klienta.

W przypadku tego zamówienia odpowiedni plik Winbom.ini powoduje zainstalowanie pierwszej aplikacji oraz usunięcie plików drugiej i trzeciej aplikacji. System jest następnie zamykany, a komputer jest gotowy do przekazania klientowi.

[OEMRunOnce]
"Dołączenie pierwszej aplikacji", "Application1.Attach", MSI
"Odłączenie drugiej aplikacji", "Application2.Detach", MSI
"Odłączenie trzeciej aplikacji", "Application3.Detach", MSI

[Application1.Attach]
InstallType = Attach
StagePath = "C:\App1_Temp"
SetupFile = "Application_One.msi"

[Application2.Detach]
InstallType = Detach
StagePath = "C:\App2_Temp"

[Application3.Detach]
InstallType = Detach
StagePath = "C:\App3_Temp"

[Factory]
ResealMode = OOBE
Reseal = Shutdown

Używanie sekcji [GuiRunOnce] lub pliku Cmdlines.txt do preinstalowania aplikacji

W celu zachowania zgodności ze starszymi wersjami nadal można korzystać z tych samych metod, których używano do preinstalowania aplikacji w systemie Windows 2000. Jednak korzystanie z tych metod powoduje wydłużenie czasu niezbędnego do pierwszego uruchomienia komputera przez użytkownika końcowego i dlatego nie jest zalecane. Aby uzyskać więcej informacji, zobacz Preinstalowanie aplikacji przy zastosowaniu starszych metod.

Umieszczanie skrótów aplikacji w menu Start

Aby umieścić skrót do aplikacji na liście najczęściej używanych programów (MFU) w menu Start, należy upewnić się, że w sekcji [StartMenuMFUlist] pliku Winbom.ini figuruje ścieżka do pliku skrótu (.lnk).

Przepakowywanie aplikacji na potrzeby preinstalacji

Jeśli aplikacja nie ma pakietu instalacyjnego Instalatora Microsoft Windows (.msi), można użyć narzędzia innej firmy w celu przepakowania aplikacji do formatu msi. Format msi jest preferowany, ponieważ umożliwia:

  • Instalowanie aplikacji podczas instalacji nienadzorowanej systemu Windows.
  • Zmniejszenie problemów z zarządzaniem wersjami plików dll.

Aby uzyskać więcej informacji o Instalatorze Microsoft Windows, odwiedź stronę sieci Web http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/WINDOWSXP/home/using/productdoc/en/sag_WinInstall_Overview.asp

Można także użyć wbudowanej procedury instalacyjnej aplikacji, jeśli ma ona opcję wiersza polecenia /q (cicha) lub /s (dyskretna).

Opcje wiersza polecenia instalacji różnią się w zależności od aplikacji. Przydatną opcją używaną przez niektóre aplikacje jest na przykład parametr /l, który powoduje utworzenie pliku dziennika do monitorowania procesu instalacji. Ważne jest, aby przed przystąpieniem do preinstalowania aplikacji zapoznać się z informacjami, instrukcjami i narzędziami, które są udostępniane przez producenta aplikacji.

Uwaga

  • Jeśli aplikacja wymaga stosowania instalatora typu InstallShield, należy dodać w wierszu polecenia przełącznik -SMS (bez cudzysłowu). Przełącznik -SMS trzeba wpisać wielkimi literami. Ta opcja wiersza polecenia gwarantuje, że proces utworzony przez Instalatora zostanie zakończony przed przetworzeniem następnego wpisu z sekcji [OEMRunOnce].

Ważne

  • Bez względu na metodę preinstalowania aplikacji konieczne jest spełnienie wymagań licencyjnych wszelkich aplikacji umieszczanych na komputerze.
  • Jeśli program instalacyjny aplikacji zamieni bieżący plik systemowy systemu Windows na starszy plik systemowy z pakietu instalacyjnego aplikacji, uaktywniona zostaje opcja ochrony plików systemu Windows, a stary plik systemowy zostaje zamieniony na bieżący plik systemowy, który zainstalowano z systemem Windows.


Preinstalowanie aplikacji przy zastosowaniu starszych metod

Preferowany moment preinstalowania aplikacji w systemach Windows XP to czas pracy narzędzia Sysprep w trybie fabrycznym — należy odpowiednio wypełnić sekcję [OEMRunOnce] w pliku Winbom.ini. Ta technika jest szybsza i zapewnia większą elastyczność. Aby uzyskać więcej informacji, zobacz Preinstalowanie aplikacji.

W celu zachowania zgodności ze starszymi wersjami nadal można korzystać z tych samych metod, których używano do preinstalowania aplikacji w systemie Windows 2000. Jednak korzystanie z tych metod powoduje wydłużenie czasu niezbędnego do pierwszego uruchomienia komputera przez użytkownika końcowego i dlatego nie jest zalecane.

Preinstalowanie aplikacji przy użyciu pliku Cmdlines.txt

Plik Cmdlines.txt jest używany, jeśli:

  • Instalacja jest wykonywana z udziału dystrybucyjnego \$OEM$.
  • Aplikacje są instalowane podczas instalacji w trybie graficznym.
  • Instalowana aplikacja została zaprojektowana do instalacji przez jednego użytkownika, a zachodzi konieczność replikacji informacji o użytkowniku dla wszystkich użytkowników danego komputera.

Polecenia zawarte w pliku Cmdlines.txt są synchroniczne, co oznacza, że żadne polecenie nie jest wykonywane, dopóki nie zostanie zakończone poprzednie polecenie (jeśli takie istnieje).

Plik Cmdlines.txt zawiera polecenia, które są wykonywane podczas instalacji w trybie graficznym, gdy są instalowane składniki opcjonalne, na przykład aplikacje. Określonych w tym pliku poleceń można użyć na przykład do uruchomienia pliku .inf za pomocą polecenia Rundll32.exe lub do wykonania innej akcji. Jeśli planowane jest użycie pliku Cmdlines.txt do zainstalowania aplikacji, należy umieścić aplikację, która ma być zainstalowana, w podfolderze \$OEM$ udziału dystrybucyjnego.

Uwaga

  • Aby uzyskać dodatkowe informacje dotyczące stosowania programu Rundll32.exe z plikami .inf, zobacz zestaw Microsoft Platform Software Development Kit pod adresem http://msdn.microsoft.com/library/.

Składnia pliku Cmdlines.txt:

[Commands]
"polecenie_1"
"polecenie_2"
     .
     .
"polecenie_x"
"polecenie_1", "polecenie_2" i tak dalej
Określa polecenia, które mają być po kolei uruchomione, gdy plik Cmdlines.txt zostanie wywołany podczas instalacji w trybie graficznym. Wszystkie polecenia należy ująć w cudzysłowy.

Uwagi dotyczące ograniczeń i korzystania z pliku Cmdlines.txt

Pliku Cmdlines.txt dotyczą następujące ograniczenia:

  • W czasie wykonywania pliku Cmdlines.txt nie jest zalogowany żaden użytkownik i nie ma żadnego połączenia z siecią. Wszystkie informacje dotyczące użytkownika są zapisywane w domyślnym rejestrze użytkownika i wszyscy użytkownicy utworzeni później dziedziczą te ustawienia rejestru.
  • Wszystkie pliki niezbędne do uruchomienia aplikacji lub narzędzia muszą być umieszczone w udziale dystrybucyjnym.
  • Jeśli aplikacja jest instalowana przy użyciu pliku Cmdlines.txt, to instalację należy wykonać w trybie nienadzorowanym, aby użytkownik nie musiał odpowiadać na komunikaty dotyczące aplikacji.
  • Aplikacji Instalatora Microsoft® Windows® (z rozszerzeniem msi) nie można zainstalować przy użyciu pliku Cmdlines.txt. Zamiast tego pliku należy użyć sekcji [GuiRunOnce].

Preinstalowanie aplikacji przy użyciu sekcji [GuiRunOnce]

Sekcja [GuiRunOnce] jest używana, jeśli:

  • Oprogramowanie jest instalowane z dowolnego źródła, takiego jak sieć, dysk twardy lub stacja CD-ROM.
  • Aplikacja nie może być zainstalowana podczas instalacji w trybie graficznym.
  • Wykonawca preinstalacji chce zalogować się jako użytkownik, ale bez automatycznego replikowania ustawień rejestru dla tworzonych w przyszłości użytkowników.
  • Instalowana aplikacja wymaga zalogowania użytkownika na komputerze.

Uwaga

  • Sekcja [GuiRunOnce] wymaga, aby funkcja logowania była włączona (należy użyć wpisu AutoLogon w sekcji [GuiUnattended]). Aby uzyskać więcej informacji, zobacz Automatyzowanie procesu logowania.

Polecenia zawarte w sekcji [GUIRunOnce] są synchroniczne, co oznacza, że żadne polecenie nie jest wykonywane, dopóki nie zostanie zakończone poprzednie polecenie (jeśli takie istnieje).

Sekcja [GuiRunOnce] pliku Unattend.txt zawiera listę poleceń, które są uruchamiane przy pierwszym logowaniu po uruchomieniu instalacji w trybie graficznym. Każdy wiersz ujęty w cudzysłowy określa polecenie, które jest przechowywane w kluczu GuiRunOnce rejestru systemu Windows. Na przykład wprowadzenie poniższego wiersza w sekcji [GuiRunOnce] spowoduje uruchomienie narzędzia Sysprep jako części instalacji nienadzorowanej.

[GuiRunOnce]
"%SYSTEMDRIVE%\Sysprep\Sysprep -quiet"

Jeśli aplikacja wymaga zainstalowania powłoki Eksploratora Windows, można użyć sekcji [GuiRunOnce] do utworzenia zautomatyzowanej instalacji fabrycznej, która przeprowadza instalację, automatycznie loguje się na komputerze, instaluje aplikację, a następnie zamyka system. Za pomocą sekcji [GuiRunOnce] można również określić kolejność instalowania aplikacji.

Ważne

  • Sekcji [GuiRunOnce] nie można użyć w celu umożliwienia wykonywania powłok, innych programów itp. podczas rozruchu wykonywanego przez użytkownika końcowego.

Automatyzowanie procesu logowania

Proces logowania można zautomatyzować, dodając wpis AutoLogon = Yes do sekcji [GuiUnattended] pliku Unattend.txt (pliku odpowiedzi). Wówczas po zakończeniu pracy Instalatora i ponownym rozruchu komputera system Windows przeprowadzi automatyczne logowanie przy użyciu konta i hasła administratora. Hasło konta administratora może być puste albo można je określić w pliku odpowiedzi. Domyślnym ustawieniem opcji AutoLogon jest No.

Uwagi

  • Jeśli hasło konta Administrator jest puste, komputer zaloguje się jeden raz. Jeśli hasło jest przypisane, komputer loguje się w pętli, a system Windows zapisuje hasło w rejestrze.
  • Jeśli Menedżer instalacji zostanie użyty do zaszyfrowania hasła, opcja AutoLogon nie działa. W celu obejścia tego problemu można podczas instalacji w trybie graficznym utworzyć inne konto o uprawnieniach administratora i zalogować się automatycznie na to konto. Po zakończeniu pracy konto zostanie usunięte. Pozwala to na automatyczne zalogowanie się, zainstalowanie aplikacji i zamknięcie systemu bez naruszania integralności hasła administratora.

Aby uzyskać więcej informacji, zobacz Ustawianie hasła administratora.

Kontrolowanie procesu instalowania aplikacji

Aby kontrolować sposób instalowania wielu aplikacji, można utworzyć plik wsadowy, zawierający poszczególne polecenia instalacyjne, a także polecenie Start z opcją wiersza polecenia /wait. Ta metoda daje pewność, że aplikacje są instalowane w określonej kolejności i że każda z nich zostaje w pełni zainstalowana, zanim następna aplikacja uruchomi swoją procedurę instalacji. Następnie jest uruchamiany plik wsadowy z sekcji [GuiRunOnce] pliku odpowiedzi.

Poniższa procedura wyjaśnia, jak:

  • Utworzyć plik wsadowy.
  • Zainstalować aplikację.
  • Usunąć wszystkie odwołania do pliku wsadowego po zakończeniu instalacji.

Aby zainstalować aplikacje przy użyciu pliku wsadowego

  1. Utwórz plik wsadowy zawierający wiersze o następującej składni:

    Start /wait ścieżka\Instalator [-x ...]
    ...
    Exit

    ścieżka
    Określa ścieżkę do pliku wykonywalnego, który uruchamia proces instalacji.
    Instalator
    Określa nazwę pliku wykonywalnego, który uruchamia proces instalacji.
    x
    Określa opcje instalacji nienadzorowanej odpowiednie do aplikacji, która ma być zainstalowana.
  2. Skopiuj plik wsadowy do udziału dystrybucyjnego lub innego folderu, do którego jest możliwy dostęp podczas instalacji.

    Uwaga

    • Można także skopiować plik wsadowy nazwa_pliku.bat do folderu Sysprep udziału dystrybucyjnego. Plik wsadowy jest wówczas dla komputera docelowego plikiem lokalnym. Po uruchomieniu programu Sysprep użytkownik zamyka program początkowy, komputer jest uruchamiany ponownie, a folder Sysprep jest usuwany wraz z całą zawartością. Nie ma konieczności usuwania pliku wsadowego przy użyciu innej procedury. Aby uzyskać więcej informacji, zobacz Korzystanie z narzędzia Sysprep.
  3. Używając nazwy nazwa_pliku.bat jako nazwy pliku wsadowego, w sekcji [GuiRunOnce] pliku odpowiedzi dołącz wpis uruchamiający ten plik wsadowy. Na przykład:
    [GuiRunOnce]
Polecenie0() = "%SYSTEMDRIVE%\sysprep\nazwa_pliku.bat"
Polecenie1() = "ścieżka-1\Polecenie-1.exe"
Polecenien() = "ścieżka-n\Polecenie-n.exe"
Polecenien+1() = "%SYSTEMDRIVE%\sysprep\sysprep.exe -quiet"
    ścieżka\Polecenie-1.exe i ścieżka-n\Polecenie-n.exe
    Określa w pełni kwalifikowane ścieżki do dodatkowych aplikacji, instalacji programów narzędziowych i narzędzi konfiguracyjnych lub innego pliku wsadowego. Ścieżki te muszą być dostępne podczas instalacji.

W tym przykładzie przyjmuje się, że plik wsadowy został skopiowany do folderu Sysprep na lokalnym dysku twardym, choć można umieścić go w dowolnej lokalizacji, do której Instalator będzie mieć dostęp podczas instalacji.


Wstępne wypełnianie klucza produktu i wstępna aktywacja systemu Windows

Ze względu na wymagania mechanizmu aktywacji produktu Windows w systemie Windows XP nie można wstępnie wypełniać rodzajowego klucza produktu dla wszystkich produkowanych komputerów. Można jednak wykonać jedną z poniższych operacji:

  • Propagować jeden klucz produktu w wielu instalacjach bez aktywowania żadnej z tych instalacji. Przed przekazaniem komputera docelowego użytkownikowi końcowemu należy usunąć ten klucz produktu za pomocą programu Sysprep.
  • Wstępnie skonfigurować unikatowy klucz produktu na komputerze docelowym i uaktywnić instalację systemu Windows w fabryce. Klucz produktu użyty do aktywacji instalacji systemu Windows musi być zgodny z kluczem produktu umieszczonym na nalepce Certyfikatu Autentyczności dołączonej do danego komputera.

Aby uzyskać więcej informacji, zobacz Narzędzie Sysprep a aktywacja produktu Windows.

Stosowanie jednego klucza produktu dla wszystkich produkowanych komputerów

W procesie preinstalacji obraz systemu operacyjnego zawierającego dany klucz produktu można zduplikować na wielu komputerach docelowych. Muszą być jednak spełnione następujące warunki:

  • Nie należy próbować uaktywnić wielu instalacji systemu Windows przy użyciu tego klucza produktu.
  • Przed przekazaniem komputerów użytkownikom końcowym na każdym komputerze docelowym należy uruchomić program Sysprep w celu usunięcia klucza produktu.

System operacyjny musi być skonfigurowany w taki sposób, aby podczas pierwszego uruchomienia systemu operacyjnego przez użytkownika końcowego aplet System Windows - Zapraszamy! lub miniinstalacja monitowały użytkownika o wprowadzenie unikatowego klucza produktu, zgodnego z kluczem na nalepce COA dołączonej do komputera.

Aby uzyskać więcej informacji, zobacz Narzędzie Sysprep a aktywacja produktu Windows.

Wstępna aktywacja systemu Windows w imieniu użytkownika

Użytkownikom można przekazywać komputery z instalacją systemu Windows, w której wstępnie skonfigurowano unikatowy klucz produktu, znajdujący się na nalepce COA umieszczonej na obudowie komputera. Można również dokonać aktywacji każdej instalacji systemu Windows w fabryce za pośrednictwem Internetu.

Wstępne konfigurowanie klucza produktu

Aby nie wprowadzać klucza produktu ręcznie, można skonfigurować go wstępnie w jednej z następujących lokalizacji:

  • Wpis ProductKey w sekcji [UserData] pliku Unattend.txt.
  • Wpis ProductKey w sekcji [UserData] pliku Sysprep.inf.
  • Wpis ProductKey w sekcji [Version] pliku Oobeinfo.ini.

Plik Unattend.txt można edytować ręcznie za pomocą edytora tekstów lub w Menedżerze instalacji na stronie Klucz produktu. Wpis ProductKey w pliku Oobeinfo.ini można edytować tylko ręcznie za pomocą edytora tekstu.

Aktywacja systemu Windows w fabryce za pomocą Internetu

W środowisku produkcyjnym instalację systemu Windows można aktywować za pomocą Internetu.

Ważne

  • Zawsze wymagany jest klucz produktu.
  • Klucz produktu służący do aktywowania instalacji za pomocą mechanizmu aktywacji produktu Windows musi być zgodny z Certyfikatem Autentyczności (COA) towarzyszącym produktowi detalicznemu lub fizycznie umieszczonym na obudowie komputera przez producenta sprzętu OEM.
  • Standardowe umowy licencyjne określają, że jeden klucz produktu może być użyty do aktywacji tylko jednej instalacji systemu Windows XP na jednym komputerze. Wymóg ten jest wymuszany przez mechanizm aktywacji produktu Windows.

Aby automatycznie aktywować instalację systemu Windows podczas działania Instalatora:

  1. W pliku Unattend.txt jako wartość wpisu ProductKey w sekcji [UserData] wprowadź wartość zgodną z kluczem produktu znajdującym się na nalepce COA dołączonej do danego komputera.
  2. Ustaw wartość wpisu AutoActivate równą Yes.
  3. Zainstaluj system Windows w trybie instalacji nienadzorowanej, zgodnie z opisem w sekcji Uruchamianie Instalatora za pomocą programu Winnt32.exe.

Komputer docelowy musi mieć fizyczny dostęp do Internetu. Jeśli połączenie internetowe odbywa się za pośrednictwem zapory, może być konieczne ręczne skonfigurowanie właściwych ustawień serwera proxy:

  • Określ ustawienia serwera proxy w sekcji [Proxy] pliku Unattend.txt.
  • W sekcji [Unattended], ustaw wartość wpisu ActivateProxy równą Proxy.
  • Podczas uruchamiania na tym komputerze docelowym narzędzia Sysprep konieczne jest użycie opcji wiersza polecenia -activated.

Ważne

  • Ustawienie wartości AutoActivate = Yes nie gwarantuje pomyślnej aktywacji tej instalacji systemu Windows XP. Próba aktywacji zakończy się niepowodzeniem na przykład wtedy, gdy komputer nie nawiąże pomyślnie połączenia z Internetem.

Aby zachować możliwość pomyślnej aktywacji instalacji, narzędzie Sysprep trzeba uruchomić z opcją wiersza polecenia -activated. Na przykład:

sysprep -activated -reseal

Ważne

  • Jeśli narzędzie Sysprep nie zostanie uruchomione z opcją -activated, to usunie ono bieżące ustawienia aktywacji i zresetuje zegar aktywacji produktu Windows.

Aby uzyskać więcej informacji, zobacz Narzędzie Sysprep a aktywacja produktu Windows oraz Opcje wiersza polecenia narzędzia Sysprep.


Pierwsze uruchomienie systemu przez użytkownika końcowego

Aplet System Windows — Zapraszamy! jest domyślnym programem początkowym w systemie Windows XP Home Edition i Windows XP Professional; miniinstalacja jest domyślnym programem początkowym w przypadku rodziny systemów Windows Server 2003 z dodatkiem Service Pack 1 (SP1) i systemu Windows XP 64-Bit Edition, wersja 2003. Każdy program początkowy umożliwia użytkownikowi końcowemu przeczytanie Umowy Licencyjnej Użytkownika Oprogramowania (EULA), wprowadzenie klucza produktu instalacji systemu Windows XP i jego uaktywnienie oraz skonfigurowanie wszelkich ustawień użytkownika, których nie ma jeszcze na komputerze docelowym.

System Windows XP Professional można tak skonfigurować, aby zamiast domyślnego apletu System Windows — Zapraszamy! była uruchamiana miniinstalacja. W tym celu należy użyć polecenia sysprep -mini, zgodnie z opisem w temacie Opcje wiersza polecenia narzędzia Sysprep. W systemie Windows XP Home Edition nie można zmienić ustawienia programu początkowego. W tym produkcie przy pierwszym uruchomieniu zawsze jest wyświetlany aplet System Windows — Zapraszamy!

System Windows — Zapraszamy!

Dokładna kolejność stron, które użytkownik końcowy widzi w oknie apletu System Windows — Zapraszamy! jest określona w pliku Oobeinfo.ini.

Miniinstalacja

Domyślnie użytkownik końcowy widzi wszystkie strony miniinstalacji, chyba że zostaną wstępnie skonfigurowane ustawienia użytkownika.

Aby ułatwić testowanie w środowisku produkcyjnym, miniinstalację można zautomatyzować za pomocą pliku Sysprep.inf. Nie można jednak użyć tego pliku do zautomatyzowania pracy apletu System Windows — Zapraszamy!. Aby uzyskać więcej informacji, zobacz Wstępne konfigurowanie i automatyzowanie miniinstalacji.

System Windows XP Professional można tak skonfigurować, aby zamiast apletu domyślnego System Windows — Zapraszamy! była uruchamiana miniinstalacja. W tym celu należy użyć polecenia sysprep -mini, zgodnie z opisem w temacie Opcje wiersza polecenia narzędzia Sysprep. Miniinstalację można skonfigurować do stosowania na dostarczanych klientom komputerach z systemem Windows XP Professional.

Uwaga

  • System Windows XP Home Edition zawsze działa w trybie grupy roboczej, dlatego miniinstalacja tego systemu nie wyświetla strony Grupa robocza lub domena komputera.

Rozdzielczość ekranu i system Windows XP

Jeśli sprzęt komputera obsługuje minimalną rozdzielczość ekranu 800 x 600 pikseli, a domyślnie jest ustawiona rozdzielczość 640 x 480 pikseli, aplet System Windows — Zapraszamy! ponownie skonfiguruje komputer, zmieniając rozdzielczość ekranu na 800 x 600 pikseli.

Jeśli sprzęt komputera nie obsługuje minimalnej rozdzielczości ekranu 800 x 600 pikseli, to systemy Windows XP Home Edition i Windows XP Professional domyślnie korzystają z miniinstalacji, a nie z apletu System Windows — Zapraszamy!. Jeśli sprzęt nie obsługuje minimalnej wymaganej rozdzielczości, to w sekcji [StartupOptions] pliku Oobeinfo.ini, we wpisie ScreenResolutionCheck trzeba skonfigurować dla systemu Windows XP stosowanie pasków przewijania w aplecie System Windows — Zapraszamy!.


Wstępne konfigurowanie i automatyzowanie miniinstalacji

Miniinstalacja jest programem początkowym dla rodziny systemów Windows Server 2003 z dodatkiem Service Pack 1 (SP1) i systemu Windows XP 64-Bit Edition. System Windows XP Professional można tak skonfigurować, aby miniinstalacja była uruchamiana zamiast apletu domyślnego System Windows - Zapraszamy!, zgodnie z opisem w temacie Opcje wiersza polecenia narzędzia Sysprep.

Aby uzyskać więcej informacji o miniinstalacji i aplecie System Windows - Zapraszamy!, zobacz Pierwsze uruchomienie systemu przez użytkownika końcowego.

Plik odpowiedzi Sysprep.inf umożliwia wstępne wypełnienie informacji konfiguracyjnych o danym użytkowniku i zautomatyzowanie miniinstalacji. Używając pliku Sysprep.inf, miniinstalację można tak skonfigurować, aby użytkownik był monitowany o podanie podzestawu informacji konfiguracyjnych, lub też utworzyć w pełni zautomatyzowaną instalację, w której użytkownik nie będzie pytany o żadne informacje konfiguracyjne.

Pliku Sysprep.inf nie można użyć do zautomatyzowania apletu System Windows - Zapraszamy!.

Uwaga

  • Aby zwiększyć wydajność produkcji, zamiast automatyzowania miniinstalacji można za pomocą narzędzia Sysprep uruchomić komputer w trybie fabrycznym. W takim wypadku program początkowy jest pomijany. W trybie fabrycznym można zainstalować dodatkowe aplikacje, zaktualizować sterowniki lub wykonać inspekcję komputera preinstalowanego. Aby uzyskać więcej informacji, zobacz Korzystanie z narzędzia Sysprep w trybie fabrycznym.

Składnia pliku syntax of Sysprep.inf jest podobna do struktury pliku odpowiedzi instalacji nienadzorowanej, Unattend.txt. Plik Sysprep.inf obsługuje podzbiór sekcji i wpisów obsługiwanych przez plik Unattend.txt, a także kilka wpisów specyficznych dla programu Sysprep. Do utworzenia pliku Sysprep.inf można użyć Menedżera instalacji.

Zawartość miniinstalacji

Jeśli plik Sysprep.inf nie jest używany, miniinstalacja wyświetla następujące ekrany:

  • Instalacja systemu Windows - Zapraszamy!
  • Umowa licencyjna
  • Klucz produktu
  • Opcje regionalne i językowe
  • Spersonalizuj swoje oprogramowanie
  • Nazwa komputera i hasło administratora
  • Ustawienia daty i godziny
  • Ustawienia sieciowe
  • Grupa robocza lub domena komputera
  • Instalacja systemu Windows — Zakończenie

Ważne

  • Aby instalacja systemu Windows została uznana za zakończoną, użytkownik końcowy musi zaakceptować Umowę Licencyjną Użytkownika Oprogramowania (EULA).

Aby pominąć te strony i spowodować, że narzędzie Sysprep całkowicie zautomatyzuje instalację, w pliku Sysprep.inf można określić, jako minimum, następujące wpisy:

Aby pominąć tę stronę | Dodaj do pliku Sysprep.inf ten wpis
Opcje regionalne i językowe | [GuiUnattended] Dla wpisu OemSkipRegional ustaw wartość 1.
Spersonalizuj swoje oprogramowanie | [UserData] FullName OrgName
Nazwa komputera i hasło administratora | [UserData] ComputerName [GuiUnattended] AdminPassword
Ustawienia daty i godziny | [GuiUnattended] TimeZone
Ustawienia sieciowe | [Networking] [Identification] JoinWorkgroup (przyłączanie do grupy roboczej) JoinDomain, DomainAdmin, DomainAdminPassword (przyłączanie do domeny)
Ustawienia sieciowe (dotyczy tylko systemów z rodziny Windows Server 2003) | [LicenseFilePrintData] Dla wpisu AutoMode ustaw wartość PerServer. Dla wpisu AutoUsers ustaw wartość nie większą niż liczba użytkowników dozwolona na mocy umowy licencyjnej.

Uruchamianie dodatkowych poleceń podczas miniinstalacji

Pod koniec miniinstalacji można uruchomić dodatkowe programy lub polecenia. W tym celu w folderze narzędzia Sysprep należy umieścić plik Cmdlines.txt. Jeśli polecenia powodujące zmiany w preferencjach użytkownika są uruchamiane z pliku Cmdlines.txt w ramach apletu System Windows - Zapraszamy! lub miniinstalacji, to nie są one replikowane dla użytkowników.

Aby podczas miniinstalacji uruchomić plik Cmdlines.txt

  1. W folderze dystrybucyjnym utwórz folder:

    %SYSTEMDRIVE%\Sysprep\i386\$OEM$

  2. Dodaj plik Cmdlines.txt do folderu %SYSTEMDRIVE%\Sysprep\i386\$OEM$.
  3. W pliku Sysprep.inf dodaj wpisy:
    [Unattended]
InstallFilesPath = C:\Sysprep\i386
  4. Uruchom narzędzie Sysprep.

Ważne

  • Wpis InstallFilesPath nie obsługuje zmiennych środowiskowych (na przykład zmiennej %SYSTEMDRIVE%). Zamiast zmiennej należy użyć prawidłowej ścieżki z rzeczywistą literą dysku.

Aby uzyskać więcej informacji o pliku Cmdlines.txt, zobacz Preinstalowanie aplikacji przy zastosowaniu starszych metod.


Usuwanie dostępu do składników systemu Windows

W systemie Windows XP można usunąć widoczne punkty wejścia do programów Internet Explorer, Outlook Express, Windows Media Player i Windows Messenger. Te widoczne punkty wejścia można usunąć albo w ramach instalacji nienadzorowanej, albo po zakończeniu instalacji, za pomocą narzędzia Sysprep lub Factory.

Uwaga

  • Opcje usunięcia widocznych punktów wejścia każdego z powyższych elementów są dostępne także w narzędziu Dodaj lub usuń programy, zarówno w przypadku opcji Dodaj/usuń składniki systemu Windows, jak i Określ dostęp do programów i ich ustawienia domyślne.

Aby usunąć widoczne punkty wejścia podczas instalacji nienadzorowanej:

  1. Użyj Menedżera instalacji do utworzenia nowego lub zmodyfikowania istniejącego pliku Unattend.txt.
  2. Aby usunąć widoczne punkty wejścia programu Internet Explorer, w sekcji [Components] pliku Unattend.txt ustaw wartość wpisu IEAccess równą Off.
  3. Aby usunąć widoczne punkty wejścia programu Outlook Express, w sekcji [Components] pliku Unattend.txt ustaw wartość wpisu OEAccess równą Off.
  4. Aby usunąć widoczne punkty wejścia programu Windows Media Player, w sekcji [Components] pliku Unattend.txt ustaw wartość wpisu WMPOCM równą Off.
  5. Aby usunąć widoczne punkty wejścia programu Windows Messenger, w sekcji [Components] pliku Unattend.txt ustaw wartość wpisu WMAccess równą Off.
  6. Uruchom instalację nienadzorowaną zgodnie z instrukcjami zawartymi w temacie Opcje wiersza polecenia programu Winnt32.exe.

Przykład

[Components]
IEAccess = Off
OEAccess = Off
WMAccess = Off
WMPOCM = Off

Aby usunąć widoczne punkty wejścia programów Internet Explorer, Outlook Express, Windows Media Player lub Windows Messenger po zainstalowaniu systemu Windows, wykonaj jedną z następujących procedur:

Aby usunąć widoczne punkty wejścia za pomocą narzędzia Sysprep:

  1. Utwórz plik Unattend.txt, zawierający w sekcji [Components] jeden lub więcej następujących wpisów:
    [Components]
IEAccess = Off
OEAccess = Off
WMAccess = Off
WMPOCM = Off

    Można użyć tego samego pliku Unattend.txt, który opisano powyżej w procedurze usuwania widocznych punktów wejścia podczas instalacji nienadzorowanej, albo oddzielnego pliku, zawierającego tylko sekcję [Components].

  2. Dodaj następujący wiersz polecenia do sekcji [GuiRunOnce] pliku Sysprep.inf:
    [GuiRunOnce]
sysocmgr /u:unattend.txt /q /r /c /x
  3. Uruchom narzędzie Sysprep zgodnie z instrukcjami zawartymi w temacie Korzystanie z narzędzia Sysprep.

Aby usunąć widoczne punkty wejścia przy użyciu pliku Winbom.ini i narzędzia Factory:

  1. Utwórz plik Winbom.ini zawierający w sekcji [Components] jeden lub więcej następujących wpisów:
    [Components]
IEAccess = Off
OEAccess = Off
WMAccess = Off
WMPOCM = Off
  2. Dodaj następujący wiersz polecenia do sekcji [GuiRunOnce] pliku Sysprep.inf:
    [GuiRunOnce]
sysocmgr /u:winbom.ini /q /r /c /x
  3. Uruchom narzędzie Sysprep -factory, wykonując instrukcje zawarte w temacie Korzystanie z narzędzia Sysprep w trybie fabrycznym.

Zmienianie programów domyślnych

W systemie Windows XP producent OEM może zainstalować aplikacje innych firm, a także, korzystając z ustawień rejestru systemu Windows lub innych udokumentowanych mechanizmów, skonfigurować je do uruchamiania zamiast programów Internet Explorer, Outlook Express, Windows Media Player i Windows Messenger. Programy instalacyjne tych aplikacji mogą je rejestrować, zmieniając takie elementy, jak domyślne skojarzenia plików dla określonych rozszerzeń, programy obsługi protokołu URL, technologii MIME i autoodtwarzania, tak aby te aplikacje były wywoływane zamiast programów Internet Explorer, Outlook Express, Windows Media Player i Windows Messenger (w tych samych warunkach). Aby uzyskać więcej informacji, zobacz Registering Programs with Client Types (http://msdn.microsoft.com/library/en-us/shellcc/platform/shell/programmersguide/shell_adv/RegisteringApps.asp).

W celu takiego skonfigurowania systemu Windows, aby użytkownik końcowy mógł później przywrócić oryginalną konfigurację producenta OEM tych składników, do sekcji Shell pliku Winbom.ini należy dodać następujące wpisy.

[Shell]
DefaultClientIM =
DefaultClientJavaVM =
DefaultClientMail =
DefaultClientMedia =
DefaultClientStartMenuInternet =

Ustawieniem domyślnym każdego z tych wpisów jest brak wartości. Te ustawienia domyślne można zmienić, wpisując po prawej stronie znaku równości nazwę kanoniczną programu zastępczego, zgodnie z opisem na stronie Registering Applications with Client Types (http://msdn.microsoft.com/library/en-us/shellcc/platform/shell/programmersguide/shell_adv/RegisteringApps.asp).

Każdy program określony w dowolnym z tych wpisów musi być w stanie zmienić domyślne skojarzenia plików zgodnie z opisem na stronie Registering Applications with Client Types.

Jeśli któregoś wpisu brakuje, to program domyślnie skojarzony z tym wpisem nie zmieni się, gdy użytkownik wybierze opcję przywrócenia oryginalnej konfiguracji producenta OEM. Jeśli na przykład nie ma wpisu DefaultClientJavaVM, to gdy użytkownik wybierze opcję przywrócenia domyślnego ustawienia producenta OEM, domyślna wirtualna maszyna Java pozostanie niezmieniona.


Modyfikowanie ustawień zasad grupy

Wstępnie instalując aplikacje z systemem Windows XP, które modyfikują obiekty Zasady grupy użytkowników lokalnych, oraz tworząc nowe grupy użytkowników lokalnych z określonymi uprawnieniami, należy:

  1. Odczekać około pięciu minut po zmodyfikowaniu lub dodaniu lokalnych obiektów Zasady grupy, aby mieć pewność, że zmiany weszły w życie.

    —LUB—

    Uruchomić ponownie komputer.

  2. Uruchomić narzędzie Sysprep.

Wykonaj te czynności po zmodyfikowaniu zasad grupy dla jakichkolwiek grup lokalnych lub utworzeniu nowych grup i zasad na komputerze przed uruchomieniem narzędzia Sysprep. Wykonaj te czynności na przykład wtedy, gdy:

  • Jest wstępnie instalowana wersja systemu Windows Server 2003 z określonymi uprawnieniami grupy.
  • Są wstępnie instalowane komputery stacji roboczych w firmie z niestandardowymi uprawnieniami grupy dla użytkowników.


Inspekcja komputerów docelowych

Inspekcja jest to ręczne testowanie nowych komputerów. Podczas inspekcji można sprawdzić, czy system operacyjny ładuje się, a aplikacje są uruchamiane poprawnie, uruchomić program do defragmentacji dysków, uruchomić narzędzie Chkdsk w celu sprawdzenia, czy na dysku twardym nie ma uszkodzonych plików, sprawdzić, czy wszystkie zainstalowane urządzenia są rozpoznawane właściwie w Menedżerze urządzeń oraz uruchomić inne narzędzia do testowania lub inspekcji. Można sprawdzić, czy program początkowy działa zgodnie z oczekiwaniami, czy jest wyświetlany prawidłowy ekran powitalny, czy działają dodatki Pomocy producenta OEM i czy w oknie dialogowym Właściwości systemu są wyświetlane informacje o opcjach producenta dotyczących pomocy technicznej. Wszelkie testy komputera oraz instalowanie aplikacji można wykonać bez niszczenia stron wyświetlanych podczas pierwszego uruchomienia komputera przez użytkownika końcowego.

Producent OEM jest zobowiązany do poprawienia wszystkich poważnych błędów wykrytych podczas instalacji początkowej. Jeśli zostaną wykryte poważne błędy, Instalator w trybie graficznym monituje o przejrzenie dziennika błędów instalacji. Jeśli błędy te nie zostaną poprawione, użytkownik końcowy jest również monitowany, w trakcie działania apletu System Windows - Zapraszamy! lub miniinstalacji, o przejrzenie dziennika błędów instalacji, zawierającego zarówno błędy instalacji oryginalnej, jak i błędy wykryte podczas pierwszego uruchomienia komputera.

Przed przekazaniem komputera użytkownikowi końcowemu producent OEM ma również obowiązek oczyścić dysk twardy. Po zakończeniu należy się upewnić, że z komputera usunięto wszelkie pliki i foldery utworzone przez narzędzia inspekcji.

Po zakończeniu inspekcji lub testowania należy uruchomić narzędzie Sysprep, co stanowi ostatni krok procesu wdrażania systemu. Narzędzie Sysprep usuwa zmiany spowodowane w systemie przez narzędzia inspekcji i przywraca stan komputera, w którym jest on gotowy do przekazania klientowi, bez konieczności ponownego instalowania systemu Windows ani żadnych zainstalowanych wcześniej aplikacji. Gdy użytkownik końcowy odbiera komputer i uruchamia go po raz pierwszy, uruchamiany jest aplet System Windows - Zapraszamy! lub miniinstalacja.

Podczas inspekcji można wykonać rozruch ponowny komputera tyle razy, ile jest to konieczne.

Ważne

  • Zegar aktywacji produktu Windows można zresetować przy użyciu narzędzia Sysprep najwyżej trzy razy. Po trzecim uruchomieniu narzędzia Sysprep nie można już zresetować zegara. Aby uzyskać więcej informacji, zobacz Narzędzie Sysprep a aktywacja produktu Windows.

Aby uzyskać więcej informacji i pełne instrukcje dotyczące korzystania z narzędzia Sysprep, zobacz Przygotowanie instalacji do rozmieszczenia.

Aby wykonać inspekcję komputera docelowego:

  1. Uruchom polecenie sysprep -audit
  2. Wykonaj preinstalację systemu Windows, wykonując kroki opisane w sekcjach „Przygotowywanie instalacji” i „Tworzenie instalacji”. Gdy Instalator zakończy pracę i nastąpi ponowny rozruch komputera docelowego, zostanie uruchomiona w pełni zainstalowana wersja systemu Windows.
  3. Utwórz folder \Sysprep w folderze %SYSTEMDRIVE% komputera docelowego. Skopiuj do tego katalogu pliki Sysprep.exe, Setupcl.exe i Factory.exe. W tej samej lokalizacji należy umieść niestandardowe pliki Sysprep.inf i Winbom.ini.
  4. Wykonaj inspekcję systemu za pomocą dowolnych narzędzi inspekcji.
  5. Po ukończeniu inspekcji usuń wszelkie pliki i foldery, które w trakcie procesu inspekcji zostały umieszczone na dysku twardym.

    W wierszu polecenia przejdź do folderu zawierającego narzędzie Sysprep.exe, a następnie wpisz polecenie:

    sysprep -reseal

    Opcja -reseal powoduje wyczyszczenie dzienników Podglądu zdarzeń i przygotowuje komputer do przekazania klientowi.

    Można również użyć innych opcji wiersza polecenia, opisanych w temacie Opcje wiersza polecenia narzędzia Sysprep.

  6. Natychmiast po zakończeniu pracy narzędzia Sysprep zamknij system Windows. Komputer jest teraz gotowy do przekazania użytkownikowi końcowemu.

Aby wykonać inspekcję komputera docelowego po uruchomieniu narzędzia Sysprep -reseal:

Nawet po wykonaniu polecenia sysprep -reseal, przygotowującego komputer docelowy dla użytkownika końcowego, nadal można przejść do pulpitu systemu Windows i wykonać inspekcję systemu.

Jeśli przy pierwszym uruchomieniu komputera jest uruchamiany aplet System Windows - Zapraszamy!:

  • Na pierwszym ekranie apletu System Windows - Zapraszamy! naciśnij klawisze CTRL-SHIFT-F3 i zaakceptuj Umowę Licencyjną Użytkownika Oprogramowania (EULA). Komputer zostanie wówczas uruchomiony w trybie fabrycznym.

    —LUB—

  • Edytuj plik Oobeinfo.ini w tej instalacji, dodając wpis OEMAuditBoot = 1 do sekcji [StartupOptions]. Komputer zostanie wówczas uruchomiony w trybie fabrycznym.

Jeśli przy pierwszym uruchomieniu komputera jest wykonywana miniinstalacja:

  • Dodaj do pliku Sysprep.inf, znajdującego się w katalogu C:\Sysprep lub na dyskietce, wszystkie wpisy niezbędne do całkowitego zautomatyzowania miniinstalacji. Miniinstalacja zostanie wykonana automatycznie, a następnie zostanie wykonany ponowny rozruch systemu. Po zakończeniu inspekcji komputera konieczne jest ponowne skopiowanie folderu Sysprep na dysk twardy i ponowne wykonanie polecenia sysprep -reseal.

Ważne

  • Po ponownym uruchomieniu komputera aplet System Windows - Zapraszamy! lub miniinstalacja usuwa folder %SYSTEMDRIVE%\Sysprep wraz z jego zawartością.
  • Na komputerze preinstalowanym nie należy zastępować żadnych plików systemowych ani w żaden inny sposób zakłócać jego pracy; narzędzie Sysprep nie jest w stanie wykryć ani przywrócić plików systemowych, które zostaną zmienione przez narzędzia inspekcji.

Uwaga

  • Narzędzie Sysprep resetuje limit czasu menu rozruchowego do wartości domyślnej dwóch sekund przy instalowaniu jednego systemu operacyjnego i do wartości domyślnej 0 sekund przy instalowaniu wielu systemów operacyjnych, tak aby domyślnie został uruchomiony obraz tej instalacji, w której uruchomiono narzędzie Sysprep. Po uruchomieniu apletu System Windows - Zapraszamy! lub miniinstalacji ustawiany jest limit czasu menu rozruchowego równy 30 sekund.

Gdy zostanie przywrócony odpowiedni stan komputera (tj. stan gotowości do przekazania klientowi), komputer można dostarczyć użytkownikowi wraz z wszelkimi wymaganymi materiałami systemu Windows, zgodnie z warunkami umowy licencyjnej zawartej z firmą Microsoft. Najczęściej są to następujące elementy:

  • Dysk CD z produktem Windows
  • Certyfikat Autentyczności (COA)

Polecenie sysprep -audit powoduje ponowne uruchomienie komputera w trybie fabrycznym bez generowania nowych identyfikatorów zabezpieczeń (SID) i bez przetwarzania żadnych elementów z sekcji [OEMRunOnce] pliku Winbom.ini.

Tej opcji wiersza polecenia należy używać tylko wtedy, gdy komputer pracuje już w trybie fabrycznym.

Aby uzyskać więcej informacji, zobacz Opcje wiersza polecenia narzędzia Sysprep.

Ważne

  • Jeśli istnieje konto użytkownika o nazwie „Właściciel”, aplet System Windows - Zapraszamy! usuwa je.
  • Jeśli podczas testowania systemu Windows XP zostaną utworzone dodatkowe konta użytkowników za pomocą apletu Konta użytkowników z Panelu sterowania, to narzędzie Sysprep ani aplet System Windows - Zapraszamy! nie usuną tych kont po ponownym zapieczętowaniu komputera.
  • Po uruchomieniu apletu System Windows - Zapraszamy! konto Właściciel (w systemie Windows XP Home Edition) lub Administrator (w systemie Windows XP Professional) jest kopiowane do domyślnego profilu użytkownika, zastępując go. Z tego powodu wszelkie pliki dodane do domyślnego profilu użytkownika przed uruchomieniem polecenia Sysprep -reseal przestaną istnieć po zakończeniu pracy apletu System Windows - Zapraszamy!
  • Przed ponownym zapieczętowaniem komputera należy usunąć z systemu Windows XP wszelkie dodatkowe konta użytkowników utworzone do celów testowych za pomocą apletu Konta użytkowników z Panelu sterowania.
  • Aby dodać lub usunąć konta użytkowników, kliknij przycisk Start, kliknij prawym przyciskiem myszy polecenie Mój komputer, kliknij polecenie Właściwości, kliknij kartę Zaawansowane, a następnie w obszarze Profile użytkownika kliknij przycisk Ustawienia.


Programy logo Microsoft Windows

Firma Microsoft Corporation opracowala programy logo Designed for Microsoft Windows (http://www.microsoft.com/winlogo/default.mspx) i Certified for Windows (http://msdn.microsoft.com/certification/), aby ulatwic uzytkownikom koncowym identyfikacje produktów sprzetowych i programowych, które zaprojektowano specjalnie dla systemów operacyjnych Windows. Celem tych programów jest zapewnienie uzytkownikom koncowym mozliwosci optymalnego wykorzystania produktów programowych i sprzetowych, które nosza logo Designed for Microsoft Windows.

Uzytkownicy moga bezpiecznie laczyc ze soba produkty programowe i sprzetowe, które nosza te logo. Moga oni wtedy miec pewnosc, ze produkty te wykorzystuja nowe technologie dostepne w systemie Microsoft Windows XP i w rodzinie systemów Windows Server 2003.

Aby uzywac logo Designed for Microsoft Windows oraz Certified for Microsoft Windows, potrzebna jest osobna licencja. Dostawcy, którzy maja licencje na uzywanie tych logo, moga ich uzywac w witrynach sieci Web, na opakowaniach produktów, materialach reklamowych i innych materialach marketingowych w polaczeniu z produktami, które przeszly testy dla danego logo i sa z tym logo licencjonowane. Logo Designed for Microsoft Windows mozna uzywac tylko zgodnie z wyraznie okreslonymi warunkami licencji logo.

Testowanie sprzetu

Organizacja zajmujaca sie testowaniem sprzetu dla programu logo jest laboratorium Windows Hardware Quality Labs (WHQL), które oferuje uslugi testowania zgodnosci sprzetu i sterowników z systemami Windows 2000, Windows XP i Windows Server 2003. Przed przyznaniem prawa do uzywania logo testowany jest zarówno sprzet, jak i oprogramowanie.

Producenci sprzetu, których produkty przejda program testów laboratorium WHQL, otrzymuja szczególowy raport z testów. Przetestowany sprzet zostaje umieszczony na liscie zgodnosci sprzetu (HCL) systemu Windows, a sterowniki sa bezplatnie rozpowszechniane w bibliotece sterowników systemu Windows (WDL).

Aby uzyskac najbardziej aktualna liste obslugiwanego sprzetu, zobacz Wykaz systemu Windows (http://www.microsoft.com/whdc/hcl/default.mspx) (poprzednio znany jako lista zgodnosci sprzetu systemu Windows).

Zacheca sie producentów OEM, aby poddawali swoje systemy sprzetowe testom dla logo i uzywali w swoich systemach skladników noszacych logo Designed for Microsoft Windows. Aby uzyskac wiecej informacji, napisz na adres:

WHQL
Microsoft Corporation
One Microsoft Way
Redmond, WA 98053-6399 USA
Faks: (425) 703-3872

Aby uzyskac wiecej informacji, zobacz witryne Windows Hardware and Driver Central w sieci Web (http://www.microsoft.com/whdc/).

Certyfikacja oprogramowania

Certyfikacja oprogramowania wymaga, aby jego sprzedawcy przestrzegali zasad wymienionych w specyfikacjach aplikacji dla systemu Windows (http://msdn.microsoft.com/certification/appspec.asp). Te aplikacje:

  • Zapewniaja sprawna, samoczynnie naprawiajaca sie instalacje, która pomaga zminimalizowac konflikty miedzy skladnikami wspóluzytkowanymi.
  • Ulatwiaja wdrazanie oprogramowania i zarzadzanie nim w organizacjach.
  • Poprawnie zachowuja preferencje uzytkownika i ustawienia komputera, zapewniajac komfort „uzytkownikom mobilnym”, obsluge wielu uzytkowników komputera oraz regeneracje ustawien aplikacji w przypadku wymiany komputera.
  • Dzialaja w scisle kontrolowanym srodowisku sieciowym, umozliwiajac administratorom sieci zabezpieczanie komputerów firmowych i zarzadzanie nimi.
  • Zapewniaja jednolity interfejs uzytkownika i sa zgodne ze standardami ulatwien dostepu, zmniejszajac koszty obslugi technicznej i szkolen.
  • Pozwalaja na latwe migrowanie aplikacji do nowego srodowiska w przypadku uaktualnienia z systemu operacyjnego Windows 95 lub nowszego.
  • Obsluguja funkcje zarzadzania energia OnNow, podnoszac komfort korzystania z komputerów przenosnych.

Aplikacje, które sa zgodne ze specyfikacja serwera:

  • Zapewniaja obsluge globalnie dostepnej infrastruktury, co ulatwia dostep uzytkownikom i zarzadzanie administratorom.
  • Ulatwiaja bezpieczny dostep do zasobów i zabezpieczenie komunikacji miedzy klientem a serwerem.
  • Skracaja czas przestojów spowodowanych awariami systemu albo planowanymi konserwacjami lub uaktualnieniami serwera, dzieki wykorzystaniu uslug klastrowania (w przypadku aplikacji spelniajacych wymagania systemu Windows Server 2003, Enterprise Edition).

Aby uzyskac najbardziej aktualna liste przetestowanego oprogramowania, zobacz Certified for Windows Program (http://msdn.microsoft.com/certification/).


Preinstalowanie poprawek

W tym temacie opisano procedury instalowania poprawek na komputerze produkcyjnym przed preinstalacja systemu operacyjnego na komputerach docelowych:

  • Dostosowywanie poprawek do udzialu dystrybucyjnego
  • Preinstalowanie poprawek przy uzyciu Menedzera instalacji i zestawów konfiguracyjnych (tylko dla producentów OEM)
  • Preinstalowanie poprawek przy uzyciu udzialu dystrybucyjnego i serwera (dla administratorów korporacyjnych systemów informatycznych)

Te procedury maja zastosowanie w systemie Windows XP i w systemach z rodziny Windows Server 2003.

Dostosowywanie poprawek do udzialu dystrybucyjnego

W tej procedurze wyjasniono, jak zintegrowac poprawki z procesem preinstalacji systemu Windows lub dostosowac je do niego. Preinstalacje systemu Windows XP lub systemów z rodziny Windows Server 2003 mozna zintegrowac z odpowiednimi poprawkami z udostepnionego folderu dystrybucyjnego w sieci. Proces dostosowywania instaluje poprawke podczas instalacji systemu Windows.

Ta metoda dziala jedynie w przypadku poprawek dostarczanych przez zespól Windows Sustained Engineering (poprawki podstawowego systemu operacyjnego Windows lub zestawu OPK). Nalezy zastapic wpis „pro.sp2” ponizej nazwa wersji systemu Windows, która ma byc zaktualizowana. Na przyklad aby dostosowac system Windows XP Home Edition z dodatkiem SP2, nalezy zamienic wpis „pro.sp2” na „per.sp2”. Poprawna nazwe wersji systemu Windows mozna okreslic, otwierajac folder c:\OPKTools\Lang\<LANG>\sku.

Ta procedura moze byc stosowana w przypadku narzedzi OPK (tylko producenci OEM) oraz udzialów dystrybucyjnych (administratorzy korporacyjnych systemów informatycznych). Sciezki do folderów sa jednak inne. Na przyklad:

c:\OPKTools\Lang\Eng\Sku\Pro.sp2\x86\i386 (OEM)
c:\XPPRO2\i386 (klienci inni niz producenci OEM)

Aby dostosowac poprawki do udzialu dystrybucyjnego:

  1. Utwórz folder c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack. Na przyklad w wierszu polecenia wpisz:
    MD c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack
  2. Zmien nazwe pakietu poprawek na odpowiednia nazwe pliku w formacie 8.3 (Instalator nie obsluguje dlugich nazw plików). Na przyklad wpisz:
    REN Q308387_WXP_SP2_X86_ENG.EXE Q308387.EXE
  3. Skopiuj program wykonywalny poprawki (w tym przykladzie Q308387.EXE) do folderu c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack.

    Uwaga

    • W przypadku wdrazania wielu poprawek nalezy skopiowac pliki wszystkich pakietów poprawek do tego samego folderu i zmienic ich nazwy.
  4. Rozpakuj zawartosc poprawki do unikatowej tymczasowej lokalizacji. Na przyklad aby rozpakowac pliki do folderu o nazwie c:\hold, w wierszu polecenia wpisz:
    c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack\Q308387.exe /X

    Gdy pojawi sie odpowiedni monit, wpisz c:\hold.

  5. Skopiuj plik katalogu i odpowiednie pliki poprawek z folderu c:\hold. Na przyklad w wierszu polecenia wpisz:
    Copy c:\hold\sp3\update\KB823980.cat c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack

    Uwagi

    • W przypadku jednoczesnego wdrazania wielu poprawek nalezy skopiowac wszystkie pliki katalogu z kazdej wdrazanej poprawki. Kazda poprawka ma unikatowy plik katalogu o nazwie typu KBnnnnnn.cat, który nalezy skopiowac.
    • Nalezy zastosowac zawartosc folderu SP3 w przypadku dostarczania wersji SP2. Poprawka ma zawsze numer n+1 w stosunku do numeru wersji dostarczanego systemu operacyjnego.
  6. Usun oryginalne pliki. Na przyklad w wierszu polecenia wpisz:
    del c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\rpcss.dl_
del c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\rpcrt4.dl_
del c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\ole32.dl_

    Wazne

    • Jesli oryginalne pliki nie zostana usuniete, nie zostana zastapione przez zaktualizowane pliki.
  7. Skopiuj pliki wykonywalne poprawki do folderu c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386 z katalogu c:\hold\sp3:
    copy c:\hold\sp3\rpcss.dll c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386
copy c:\hold\sp3\rpcrt4.dll c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386
copy c:\hold\sp3\ole32.dll c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386

    Nie trzeba kopiowac plików Update.exe, Update.inf, SPmsg.dll, SPcustom.dll, SPuninst.exe, Update.ver i plików symboli (.pdb).

  8. Usun plik c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\svcpack.in_.
  9. Utwórz nowy plik Svcpack.inf w folderze c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386. Dodaj nastepujace sekcje i wpisy o wartosciach zgodnych z poprawka, która zostanie zastosowana.

    System Windows XP:

    [Version]
Signature = "$Windows NT$"
MajorVersion = 5
MinorVersion = 1
BuildNumber = 2600

[SetupData]
CatalogSubDir = "\i386\svcpack"

[ProductCatalogsToInstall]
KBArticleNumber.cat

[SetupHotfixesToRun]
KBArticleNumber.exe /options

    System Windows Server 2003:

    [Version] Signature="$Windows NT$"
MajorVersion = 5
MinorVersion = 2
BuildNumber = 3790

[SetupData]
CatalogSubDir = "\i386\svcpack"

[ProductCatalogsToInstall]
KBArticleNumber.cat

[SetupHotfixesToRun]
KBArticleNumber.exe /options

    System Windows 2000:

    [Version]
Signature = "$Windows NT$"
MajorVersion = 5
MinorVersion = 0
BuildNumber = 2195

[SetupData]
CatalogSubDir = "\i386\svcpack"

[ProductCatalogsToInstall]
KBArticleNumber.cat

[SetupHotfixesToRun]
KBArticleNumber.exe /options

    Uwaga

    • Jesli za pomoca tej procedury ma byc wdrazanych wiele poprawek, dla kazdej z nich nalezy dodaj wpis w sekcjach [ProductCatalogsToInstall] oraz [SetupHotfixesToRun]. Na przyklad:
      [ProductCatalogsToInstall]
KB123456.cat
KB123478.cat
KB123490.cat

[SetupHotfixesToRun]
Q308387.exe -q -n -z
Q123478.exe -q -n -z
Q123490.exe -q -n -z
  10. Dodaj nastepujaca sekcje oraz wpis do pliku c:\OPKTools\lang\eng\sku\pro.sp2\x86\i386\Dosnet.inf:
    [OptionalSrcDirs]
svcpack

    Uzyj folderu i386 dla preinstalacji tej wersji systemu Windows.

Preinstalowanie poprawek przy uzyciu Menedzera instalacji i zestawów konfiguracyjnych

Ta procedura jest przeznaczona tylko dla producentów OEM. W prosty sposób moga oni dodac poprawki w postaci aplikacji preinstalowanych za pomoca Menedzera instalacji. Poprawki zostana dolaczone do zestawu konfiguracyjnego w trakcie preinstalowania systemu operacyjnego Windows.

Aby preinstalowac poprawki przy uzyciu Menedzera instalacji i zestawów konfiguracyjnych:

  1. Na komputerze produkcyjnym utwórz folder zawierajacy wszystkie pakiety poprawek, które chcesz zainstalowac.
  2. Skopiuj pakiety poprawek do tego folderu.
  3. Zmien nazwe pakietu poprawek na odpowiednia nazwe pliku w formacie 8.3 (Instalator nie obsluguje dlugich nazw plików). Na przyklad:
    REN Q308387_WXP_SP2_X86_ENG.EXE Q308387.EXE
  4. Otwórz Menedzera instalacji i utwórz zestaw konfiguracyjny lub poddaj edycji istniejacy zestaw.
  5. W oknie dialogowym Aplikacje preinstalowane kliknij przycisk Dodaj dla kazdego instalowanego pakietu poprawek. Pojawi sie okno dialogowe Dodawanie aplikacji.
  6. Wprowadz wartosc Nazwa wyswietlana.

    Ta nazwa pojawia sie po rozpoczeciu instalowania aplikacji.

  7. Kliknij przycisk Przegladaj, a nastepnie przejdz do folderu utworzonego w kroku pierwszym.
  8. Zaznacz pakiet poprawek do zainstalowania, klikajac dwukrotnie nazwe pliku.

    W polu Polecenie instalacji jest pokazana sciezka sieciowa na komputerze produkcyjnym prowadzaca do lokalizacji pakietu poprawek, a takze nazwa pakietu poprawek.

  9. Kliknij w polu Argumenty wiersza polecenia, a nastepnie wpisz opcje -q-n-z. Upewnij sie, ze wszystkie opcje sa rozdzielone znakiem spacji, a nastepnie kliknij przycisk OK.

    Wpisy zostana utworzone automatycznie w sekcji [OEMRunOnce] pliku Winbom.ini.

  10. Powtórz kroki od 5 do 9 dla wszystkich pozostalych pakietów poprawek, które chcesz zainstalowac.
  11. Po zakonczeniu dodawania poprawek kliknij przycisk Dalej, a nastepnie wykonaj kroki niezbedne do ukonczenia pracy Menedzera instalacji.

Preinstalowanie poprawek przy uzyciu udzialu dystrybucyjnego i serwera

Ta procedura jest przeznaczona dla administratorów systemów informatycznych. Poprawki zostana zainstalowane automatycznie przy uzyciu zmodyfikowanego pliku Unattend.txt z udzialu dystrybucyjnego.

Aby preinstalowac poprawki przy uzyciu udzialu dystrybucyjnego i serwera:

  1. Przejdz do udzialu dystrybucyjnego i otwórz folder i386.
  2. Jesli folder $OEM$ nie istnieje, utwórz go.
  3. Otwórz folder $OEM$.
  4. Utwórz folder o nazwie $1.

    Zawartosc folderu $1 zostanie skopiowana do katalogu glównego dysku systemowego na komputerze docelowym.

  5. Otwórz folder $1.
  6. Utwórz folder o nazwie %HOTFIXES%.
  7. Otwórz folder %HOTFIXES% i skopiuj do niego wszystkie poprawki, które chcesz zainstalowac.
  8. Zmien nazwy poszczególnych pakietów poprawek na odpowiednie nazwy plików w formacie 8.3 (Instalator nie obsluguje dlugich nazw plików). Na przyklad:
    REN Q308387_WXP_SP2_X86_ENG.EXE Q308387.EXE
  9. Przy uzyciu edytora tekstów utwórz plik wsadowy o nazwie Install.bat w folderze %HOTFIXES%. Na przyklad:
    @echo off
    %SYSTEMDRIVE%\Hotfixes\Q308387.exe -q -n -z
    %SYSTEMDRIVE%\Hotfixes\Q123457.exe -q -n -z

    W pliku wsadowym musza byc wymienione wszystkie poprawki do zastosowania.

  10. Przy uzyciu edytora tekstów utwórz plik Unattend.txt lub wyedytuj istniejacy plik i dodaj do niego nastepujace sekcje i wpisy:
    [Unattended]
OEMPreinstall = Yes

[GuiRunOnce]
"%SYSTEMDRIVE%\Hotfixes\install.bat"
  11. W przypadku preinstalowania systemu Windows XP lub systemu z rodziny Windows Server 2003 z udzialu dystrybucyjnego przy uzyciu zmodyfikowanego pliku Unattend.txt poprawki sa instalowane automatycznie. Folder poprawek mozna usunac przed wyslaniem komputera do uzytkownika koncowego.


Preinstalowanie pakietu wielojęzycznego interfejsu użytkownika (MUI)

Pakiet wielojęzycznego interfejsu użytkownika (MUI) jest zestawem plików źródłowych zależnych od języka, który można dodać do angielskiej wersji systemu Windows. Pakiet MUI umożliwia zmianę języka interfejsu użytkownika systemu operacyjnego zgodnie z preferencjami indywidualnych użytkowników na jeden z 33 obsługiwanych języków. Pozwala to wielkim korporacjom na korzystanie z tego samego obrazu na całym świecie z użyciem pojedynczej instalacji. Lokalni użytkownicy mogą później wybrać język interfejsu użytkownika lub może on być ustawiany przez zasady grupy dla poszczególnych jednostek organizacyjnych.

Ponadto pakiet MUI pozwala użytkownikom posługującym się różnymi językami na współużytkowanie tej samej stacji roboczej, a użytkownikom mobilnym na przenoszenie zlokalizowanych interfejsów użytkownika z jednej stacji roboczej na inną. Na przykład jeden użytkownik może wybrać opcję wyświetlania menu systemowych, okien dialogowych i innych tekstów w języku japońskim, natomiast inny użytkownik logujący się w tym samym systemie może preferować odpowiedni tekst w języku francuskim.

Istnieją dwa sposoby preinstalowania pakietu Windows XP/2000 MUI w trybie nienadzorowanym:

  • Jako część podstawowej instalacji angielskiej wersji systemu Windows.
  • Po zakończeniu podstawowej instalacji angielskiej wersji systemu Windows.

Preinstalowanie jako część podstawowej instalacji angielskiej wersji systemu Windows

Pakiet MUI jest dostarczany na kilku dyskach CD, więc w instalacji nienadzorowanej musi być wykorzystany udział dystrybucyjny. Wszystkie pliki pakietu MUI trzeba najpierw skopiować do udziału dystrybucyjnego. Sekcja [GUIRunOnce] w pliku Unattend.txt musi określać wykonanie programu Muisetup.exe, który instaluje języki interfejsu użytkownika. Ponadto program Winnt32.exe trzeba uruchomić z określonymi opcjami, aby zapewnić poprawną instalację plików.

Instalacja pakietu MUI obejmuje konfigurację grup języków, ustawień regionalnych (dla użytkownika, systemu i wprowadzania tekstu) oraz języków interfejsu użytkownika. Aby określone ustawienia regionalne i języki interfejsu użytkownika zostały poprawnie zainstalowane, trzeba zainstalować odpowiednie grupy języków. Instalowane ustawienia regionalne muszą być wzajemnie zgodne i muszą odpowiadać domyślnemu językowi interfejsu użytkownika. Prawidłowe zestawienia grup języków/ustawień regionalnych/języków interfejsu użytkownika są wymienione w sekcji [RegionalSettings].

Uwaga

  • Jeśli nie zostaną zainstalowane grupy języków niezbędne dla określonych ustawień regionalnych/języków oraz języków interfejsu użytkownika, Instalator może wyświetlać okna dialogowe monitujące o ścieżki do wymaganych plików. Chociaż instalacja się powiedzie, może wymagać udziału użytkownika.

Tworzenie udziału dystrybucyjnego

Instalacja nienadzorowana pakietu MUI wymaga skopiowania wszystkich językowych plików źródłowych z dysków CD z pakietem MUI do udziału dystrybucyjnego. Te pliki powinny być umieszczone w tymczasowym podkatalogu katalogu głównego. W poniższym przykładzie pliki znajdują się w katalogu tymczasowym o nazwie MUITEMP.

\źródło instalacji
     \MUITEMP
        ...wszystkie pliki pakietu wielojęzycznego

Podczas fazy kopiowania instalacji katalog MUITEMP jest kopiowany do katalogu %WINDIR% na dysku dystrybucyjnym. W końcowej fazie instalacji ten tymczasowy katalog jest usuwany.

Tworzenie pliku odpowiedzi

W pliku Unattend.txt znajdują się dwie ważne sekcje dla pakietu MUI: [RegionalSettings] i [GUIRunOnce].

Sekcja [RegionalSettings] określa wartości grupy języków i ustawień regionalnych (ustawień regionalnych użytkownika, ustawień regionalnych systemu i ustawień regionalnych dla wprowadzania tekstu), które mają być zainstalowane w systemie. Wartości są określone za pomocą odpowiednich identyfikatorów.

W przypadku systemów przeznaczonych dla jednego użytkownika zalecane jest użycie takich samych ustawień regionalnych, jak dla domyślnego języka interfejsu użytkownika (określonego w czasie działania programu Muisetup.exe). Jeśli na przykład jako domyślny język interfejsu użytkownika ustawiono język niemiecki, należy określić jedno z niemieckich ustawień regionalnych.

W przypadku współużytkowanych stacji roboczych i w środowisku serwera terminali zalecane jest ustawienie domyślnego języka interfejsu użytkownika i ustawień regionalnych systemu na język angielski (język administracyjny wersji wielojęzycznej). Ustawienia regionalne użytkownika mogą być ustawione zgodnie z indywidualnymi preferencjami/wymaganiami lub, jeśli są określane za pomocą wpisu Language, mogą być takie same, jak ustawienia regionalne systemu.

Musi być zainstalowana grupa języków wymagana przez określone ustawienia regionalne. Jeśli na przykład ustawienia regionalne są ustawione na język arabski i ten sam język ma być językiem domyślnym dla menu i okien dialogowych, w sekcji [RegionalSettings] musi być określona grupa języków arabskich:

[RegionalSettings]
LanguageGroup = 13
Language = 0401

—LUB—

[RegionalSettings]
LanguageGroup = 13
SystemLocale = 0401
UserLocale = 0401
InputLocale = 0409:00000409,0401:00000401

Sekcja [GUIRunOnce] zawiera listę poleceń, które mają być wykonane, gdy użytkownik po raz pierwszy zaloguje się na komputerze po zakończeniu instalacji w trybie graficznym. Każdy wiersz umieszczony w cudzysłowie określa polecenie, które ma być wykonane przez wpis rejestru GUIRunOnce.

Z tej sekcji należy skorzystać, aby wykonać program Muisetup z odpowiednimi parametrami i wartościami. Należy zauważyć, że ścieżka do pliku Muisetup.exe zawiera katalog tymczasowy utworzony w źródle instalacji. Drugi wiersz przykładowego wpisu usuwa ten katalog tymczasowy z dysku po zakończeniu instalacji:

[GuiRunOnce]
"%WINDIR%\MUITEMP\MUISETUP.exe [-i LangID LangID...] [-d LangID] -r -s"
"%WINDIR%\SYSTEM32\CMD.EXE /c RMDIR %WINDIR%\MUITEMP /s /q"

\MUITEMP jest tymczasowym folderem instalacyjnym utworzonym w czasie instalacji.

Opcje wiersza polecenia programu Muisetup

Opcja | Opis
-i | Określa język (języki) interfejsu użytkownika, który ma być zainstalowany. Języki powinny być wprowadzone jako czterocyfrowe, szesnastkowe wartości LangID.
-d | Określa domyślny język interfejsu użytkownika (stosowany do wszystkich nowych kont użytkowników i używany w takich miejscach, jak ekran logowania do systemu Windows).
-r | Określa, że nie jest wyświetlany komunikat ponownego rozruchu.
-s | Określa, że nie jest wyświetlany komunikat o pomyślnym zakończeniu instalacji.
-l | (Litera L, tylko w systemie Windows XP). Dopasowuje język programów innych niż Unicode do domyślnego języka użytkownika; to ustawienie jest ignorowane, jeśli nie jest używana opcja /d.
-f | (Tylko w systemie Windows XP). Dopasowuje domyślną czcionkę interfejsu użytkownika powłoki do domyślnego języka użytkownika; to ustawienie jest ignorowane, jeśli nie są używane opcje /d i /l. Stosuje się tylko do japońskiego interfejsu użytkownika.

Uruchamianie programu Winnt32.exe

Ostatnim krokiem nienadzorowanej instalacji pakietu MUI jest uruchomienie programu Winnt32.exe z poprawnymi opcjami.

Określ plik Unattend.txt z opcją /unattend. Użyj opcji /copydir, aby zapewnić, że tymczasowy katalog instalacyjny (MUITEMP) zostanie skopiowany na dysk docelowy. Jeśli ustawienia regionalne i języki interfejsu użytkownika, które będą instalowane, wymagają instalacji grup języków, użyj opcji /copysource, aby skopiować niezbędne pliki grup języków. Jeśli trzeba skopiować tylko jedną grupę języków, określ opcję lang\[nazwa katalogu języka].

Na przykład:
winnt32.exe /unattend: ścieżka do pliku odpowiedzi
    /copysource:lang /copydir:MUITEMP /s:ścieżka do źródła instalacji

Preinstalowanie pakietu MUI po zakończeniu podstawowej instalacji angielskiej wersji systemu Windows

Tworzenie udziału instalacyjnego

Nienadzorowana instalacja pakietu MUI systemu Windows XP wymaga skopiowania wszystkich plików z dysków CD z pakietem MUI do udziału dystrybucyjnego. Te pliki powinny być umieszczone w tymczasowym podkatalogu katalogu $OEM$. W poniższym przykładzie jest używany katalog \\muicore serwera. Na zawartość dysków CD z pakietem MUI są przeznaczone następujące katalogi:

\\muicore
     \unattend
        \$OEM$
          \muiinst

W katalogu \\unattend\$OEM$ utwórz plik Cmdlines.txt z następującym tekstem:

[Commands]
"muiinst\muisetup.exe [/i LangID1 LangID2 ...] [/d LangID] /r /s"

W pliku Cmdlines.txt trzeba używać cudzysłowów. Aby zapewnić instalację cichą, zastosuj odpowiednie identyfikatory języków (LANGID) oraz opcje wiersza polecenia programu MUISetup. Aby uzyskać pełny opis wszystkich opcji wiersza polecenia programu Muisetup.exe, zobacz poprzednią sekcję lub plik Muisetup.hlp.

Tworzenie pliku odpowiedzi

W pliku Unattend.txt znajdują się dwie ważne sekcje dla pakietu MUI: [RegionalSettings] i [GUIRunOnce].

Nagłówek sekcji [Unattended] wskazuje, że odbywa się instalacja nienadzorowana i jest wymagany w pliku Unattend.txt. W przeciwnym wypadku plik odpowiedzi jest ignorowany.

[Unattended]
    OemPreinstall = Yes
    OemFilesPath = \\muicore\unattend
    OemSkipEula = YES

Sekcja [RegionalSettings] określa wartości grupy języków i ustawień regionalnych (ustawień regionalnych użytkownika, ustawień regionalnych systemu i ustawień regionalnych dla wprowadzania tekstu), które mają być zainstalowane w systemie. Wartości są określone za pomocą odpowiednich identyfikatorów, wymienionych w sekcji [RegionalSettings].

Musi być zainstalowana grupa języków wymagana przez określone ustawienia regionalne. Jeśli na przykład ustawienia regionalne są ustawione na język arabski i ten sam język ma być językiem domyślnym dla menu i okien dialogowych, w sekcji [RegionalSettings] musi być określona grupa języków arabskich:

[RegionalSettings]
LanguageGroup = "5","8","13"
Language = "0401"

Uruchamianie programu Winnt32.exe

Ostatnim krokiem nienadzorowanej instalacji pakietu MUI jest uruchomienie programu Winnt32.exe z poprawnymi opcjami, jak w poniższym przykładzie:

winnt32.exe /unattend:ścieżka do pliku odpowiedzi /copysource:lang /s:ścieżka do źródła instalacji

Jeśli jest wymagana instalacja języka wschodnioazjatyckiego i obsługa odpowiednich ustawień regionalnych, należy określić opcję /copysource:lang lub /rx:lang, aby skopiować niezbędne pliki języka. W przeciwnym wypadku, jeśli sekcja [RegionalSettings] pliku odpowiedzi zawiera wartości dla języka wschodnioazjatyckiego, Instalator ignoruje sekcję [RegionalSettings].


Preinstalowanie pakietów językowych interfejsu

Pakiety językowe interfejsu (LIP) dla systemu Windows XP zapewniają zlokalizowany interfejs użytkownika w przypadku rynków rozwijających się lub obszarów, na których są używane mało popularne języki. Utworzone na podstawie technologii Multilingual User Interface (MUI) pakiety LIP zapewniają użytkownikowi zlokalizowany w około 80 procentach interfejs. Tak efekt jest osiągany w wyniku przetłumaczenia ograniczonego zestawu elementów interfejsu. Pakiet LIP jest instalowany w licencjonowanej kopii systemu Windows o ustalonym języku podstawowym. Aby uzyskać więcej informacji, zobacz Microsoft® Windows® XP LIP Frequently Asked Questions (http://www.microsoft.com/globaldev/).

Pakiet językowy interfejsu (LIP) dla systemu Windows XP instaluje obsługę tylko jednego języka. Nie można zainstalować obsługi więcej niż jednego języka naraz. Aby zainstalować inny pakiet LIP, należy najpierw odinstalować istniejący pakiet.

W pakietach LIP są aktualnie dostępne następujące języki:

  • Bułgarski
  • Kataloński (oparty na hiszpańskiej wersji systemu Windows XP)
  • Chorwacki
  • Estoński
  • Hindi
  • Łotewski
  • Litewski
  • Rumuński
  • Serbski (Cyrylica)
  • Serbski (łaciński)
  • Słowacki
  • Słoweński
  • Tajski
  • Ukraiński (oparty na rosyjskiej wersji systemu Windows XP)

Podstawowym językiem w przypadku powyższych pakietów LIP jest angielski, o ile nie podano inaczej.

Pakiety LIP można instalować jedynie na 32-bitowych wersjach systemu Windows XP. Nie można ich instalować na komputerach, na których jest lub był wcześniej zainstalowany Multilingual User Interface (MUI) Pack dla systemu Windows XP.

Metody preinstalacji

Wszystkie pakiety LIP, z wyjątkiem pakietów przeznaczonych dla języków słowackiego i słoweńskiego, można preinstalować, stosując tę samą metodę. Aby uzyskać więcej informacji dotyczących preinstalowania pakietów LIP dla języków słowackiego i słoweńskiego, zobacz Preinstalowanie pakietów LIP dla języków słowackiego i słoweńskiego.

Aby preinstalować pakiety LIP

  1. Skopiuj całą zawartość dysku CD z pakietem LIP do podkatalogu na komputerze produkcyjnym. Możesz na przykład utworzyć folder Updates w katalogu OPKTools. W katalogu Updates utwórz folder o nazwie LIP.
  2. Użyj Menedżera instalacji do utworzenia zestawu konfiguracyjnego dla systemu Windows XP Home Edition lub Windows XP Professional lub zmodyfikowania istniejącego zestawu.
  3. Dodaj następujące informacje wiersza polecenia na ekranie Preinstalacja aplikacji Menedżera instalacji:
    Plik wykonywalny:  msiexec /i
\\nazwa_serwera\\OpkTools\Updates\LIP\MUISETUP.EXE
Parametry: /q
Plik wykonywalny:  %WINDIR%\mui\fallback\LCID\profupd.exe
Parametry:  /l  wartość_LCID

W przypadku instalowania systemu Windows XP Home Edition lub Windows XP Professional na komputerze docelowym przy użyciu tego zestawu konfiguracyjnego pakiet LIP zostanie zainstalowany automatycznie w trybie inspekcji i będzie włączony przy następnym rozruchu komputera (w trybie inspekcji, trybie ponownego pieczętowania lub trybie fabrycznym).

Aby instalacja się powiodła, trzeba użyć poprawnego identyfikatora ustawień regionalnych dla instalowanego języka. Oto dostępne identyfikatory LCID:

LCID | Język
0402 | Bułgarski
0403 | kataloński
041a | Chorwacki
0425 | Estoński
0439 | Hindi
0426 | Łotewski
0427 | Litewski
0418 | Rumuński
0c1a | Serbski (Cyrylica)
081a | Serbski (łaciński)
041e | Tajski
0422 | Ukraiński

W przypadku zastosowania tej metody w pliku Winbom.ini zostaje utworzona następująca sekcja:

[OemRunOnce]
"NazwaPakietu1","msiexec /i \\server\\OpkTools\Updates\LIP\MUISETUP.EXE\LIPSetup.msi /q"
"NazwaPakietu2","c:\windows\mui\fallback\LCID_value\profupd.exe /l wartość_LCID"

Preinstalowanie pakietów LIP dla języków słowackiego i słoweńskiego

Aby preinstalować pakiet LIP dla języka słowackiego lub słoweńskiego:

  1. Skopiuj całą zawartość dysku CD z pakietem LIP do podkatalogu na komputerze produkcyjnym. Możesz na przykład utworzyć folder Updates w katalogu OPKTools. W katalogu Updates utwórz folder o nazwie LIP.
  2. Użyj Menedżera instalacji do utworzenia zestawu konfiguracyjnego dla systemu Windows XP Home Edition lub Windows XP Professional lub zmodyfikowania istniejącego zestawu.
  3. Dodaj następujące informacje wiersza polecenia na ekranie Preinstalacja aplikacji Menedżera instalacji:
    Plik wykonywalny:  msiexec /i
\\nazwa_serwera\\OpkTools\Updates\LIP\MUISETUP.EXE
Parametry: /l  wartość_LCID /s /r

W przypadku instalowania systemu Windows XP Home Edition lub Windows XP Professional na komputerze docelowym przy użyciu tego zestawu konfiguracyjnego pakiet LIP zostanie zainstalowany automatycznie w trybie inspekcji i będzie włączony przy następnym rozruchu komputera (w trybie inspekcji, trybie ponownego pieczętowania lub trybie fabrycznym).

Aby instalacja się powiodła, trzeba użyć poprawnego identyfikatora ustawień regionalnych dla instalowanego języka. Oto dostępne identyfikatory LCID:

LCID | Język
0424 | Słoweński
041b | Słowacki

W przypadku zastosowania tej metody w pliku Winbom.ini zostaje utworzona następująca sekcja:

[OemRunOnce]
"NazwaPakietu1","msiexec /i \\nazwa_serwera\\OpkTools\Updates\LIP\MUISETUP.EXE /l wartość_LCID /s /r "


Preinstalowanie urządzeń sprzętowych

Można preinstalować następujące urządzenia sprzętowe:

  • Urządzenia magazynu masowego
  • Urządzenia typu Plug and Play

Inne najważniejsze tematy omówione w tej sekcji:

  • Używanie sterowników podpisanych
  • Jak system Windows wybiera określony sterownik urządzenia
  • Wykrywanie poprawnego trybu wideo dla ekranów komputerów przenośnych
  • Pokazywanie urządzeń ukrytych
  • Zmniejszanie liczby obrazów wzorcowych dla komputerów wyposażonych w różne kontrolery magazynu masowego
  • Zmniejszanie liczby obrazów wzorcowych dla komputerów wieloprocesorowych

Aby uzyskać najnowsze informacje dotyczące programowania urządzeń sprzętowych do pracy z komputerami, na których działa system Microsoft® Windows®, zobacz witrynę Windows Hardware and Driver Central w sieci Web (http://www.microsoft.com/whdc/).


Używanie sterowników podpisanych

Firma Microsoft promuje podpisywanie sterowników określonych klas urządzeń jako mechanizm podnoszenia jakości sterowników, zwiększania komfortu pracy użytkowników końcowych oraz ograniczania kosztów obsługi technicznej ponoszonych przez dostawców i całkowitych kosztów eksploatacyjnych ponoszonych przez klientów.

Sterowniki podpisane to sterowniki z odpowiednim podpisem cyfrowym. Podpisy cyfrowe sterowników dla systemu Windows umożliwiają systemowi operacyjnemu sprawdzenie integralności każdego pliku znajdującego się w pakiecie plików sterownika. Pakiet sterownika kopiuje dostarczony przez firmę Microsoft, podpisany cyfrowo plik wykazu (.cat), który zawiera rekord każdego pliku zawartego w pakiecie sterownika. Podpisywanie sterowników (zwane czasami podpisywaniem kodu) obejmuje następujące składniki:

  • Plik wykazu (.cat), który jest częścią pakietu sterownika i zawiera podpis cyfrowy wystawiony przez laboratorium Windows Hardware Quality Labs (WHQL)
  • Plik .inf, który odwołuje się do pliku wykazu
  • Sterownik, który pomyślnie przeszedł testy programu Windows Logo Program
  • Ustawienia zasad systemu operacyjnego określające, czy można instalować sterowniki niepodpisane

Aby uzyskać podpisany cyfrowo plik wykazu, wszystkie sterowniki muszą spełnić określone przez firmę Microsoft kryteria testowe dla danego urządzenia. Testy są przeprowadzane w laboratorium WHQL. Aby uzyskać więcej informacji sterownikach podpisanych, zobacz witrynę Windows Hardware and Driver Central w sieci Web (http://www.microsoft.com/whdc/).

W przypadku planowanego użycia sterowników zaktualizowanych należy najpierw sprawdzić, czy mają one ważny podpis. Jeśli nie, zainstalowanie określonego sterownika zależy od:

  • Przyjętej zasady podpisywania sterowników, wskazanej w pliku odpowiedzi.
  • Dostępności zgodnego sterownika podpisanego, dostarczonego wraz z systemem operacyjnym.

Testowanie sterowników niepodpisanych

W przypadku otrzymania od dostawcy do celów testowych sterownika, który nie jest jeszcze podpisany, ale zastępuje sterownik systemu Windows XP, Instalator systemu Windows wybiera sterownik dołączony do systemu Windows XP, ignorując sterownik niepodpisany. Aby uzyskać więcej informacji dotyczących Instalatora systemu Windows i sterowników, zobacz Jak system Windows wybiera określony sterownik urządzenia.

Ważne

  • Wszystkie sterowniki zainstalowane na komputerze dostarczonym klientowi muszą być podpisane. Sterowniki przesłane do testowania w ramach programu Microsoft Windows Logo Program muszą być zgodne z zasadami podpisywania sterowników określonymi w dokumencie technicznym Podpisywanie sterowników dla systemów operacyjnych Windows (http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/code_signing.asp), dostępnym w witrynie Windows Hardware and Driver Central w sieci Web (http://www.microsoft.com/whdc/).

Aby sterowniki niepodpisane były instalowane w czasie działania narzędzia Sysprep, w pliku Sysprep.inf należy dodać następujące wiersze:

[Unattended]
UpdateInstalledDrivers = Yes

Wpis DriverSigningPolicy w sekcji [Unattended] określa sposób przetwarzania sterowników niepodpisanych podczas instalacji nienadzorowanej. Tylko w celach testowania można ustawić opcję DriverSigningPolicy = Ignore. W produkowanych komputerach konieczne jest użycie ustawienia domyślnego (DriverSigningPolicy = Warn) lub wyższej zasady (DriverSigningPolicy = Block) w celu zapewnienia, że użytkownicy końcowi pobierający nowe lub zaktualizowane sterowniki niepodpisane będą najpierw ostrzegani o możliwości wystąpienia problemów.

Po zakończeniu pracy narzędzia Sysprep wpis DriverSigningPolicy jest automatycznie ustawiany na wartość Warn, chyba że plik Sysprep.inf zawiera ustawienie DriverSigningPolicy = Block.

Uwaga

  • Podpis sterownika jest uwierzytelniany przez plik .cat. Firma Microsoft używa certyfikatów do podpisywania sterowników tylko na określony czas, zazwyczaj sześć miesięcy. Tak długo jednak, jak sterownik jest podpisany cyfrowo przy użyciu ważnego certyfikatu, data wygaśnięcia certyfikatu nie ma wpływu na stan sterownika. Podpis sterownika nie wygasa, nawet po wygaśnięciu certyfikatu użytego do podpisania sterownika.

Preinstalowanie sterowników podpisanych

Po podpisaniu sterownika nie można modyfikować jego plików (w tym plików .inf). Wprowadzenie zmian w jakimkolwiek pliku sterownika powoduje unieważnienie podpisu cyfrowego tego sterownika.

Podczas preinstalowania sterowników podpisanych muszą być spełnione następujące warunki:

  • Wszystkie wymagane pliki muszą być umieszczone w tym samym katalogu preinstalacyjnym, zgodnie z opisem w sekcji Preinstalowanie urządzeń typu Plug and Play.
  • Sterownik musi zostać zainstalowany przy użyciu pliku .inf.
  • Sterownik musi przejść pomyślnie testy programu Windows Logo Program i mieć podpis cyfrowy wystawiony przez laboratorium WHQL.
  • Plik .inf nie może zawierać błędów dotyczących podpisu.
  • Sterownik nie może zawierać plików ani programów pochodzących od firmy Microsoft.

Weryfikowanie podpisów plików

Aby sprawdzić, czy pliki mają podpisy, należy użyć narzędzia do weryfikowania podpisów, Sigverif.exe, dołączonego do systemu Windows. Standardowo narzędzie to skanuje domyślny zestaw plików systemowych z listy w pliku Corelist.inf, wszystkie sterowniki znajdujące się w Menedżerze urządzeń i wszystkie zainstalowane sterowniki drukarek. Tego narzędzia można również używać do skanowania oddzielnie podpisanych plików. Każdy wytworzony obraz preinstalowany fabrycznie należy przetestować przy użyciu narzędzia Sigverif w celu zidentyfikowania wszelkich niepodpisanych plików .sys lub .drv.

Aby uruchomić narzędzie Sigverif, kliknij przycisk Start, kliknij polecenie Uruchom, a następnie wpisz polecenie sigverif.

Aby sprawdzić właściwości sterownika po instalacji, przejdź do karty Właściwości sterownika w Menedżerze urządzeń na komputerze testowym.

Sprawdzanie poprawności i debugowanie podpisów sterowników urządzeń

Plik Setupapi.log, znajdujący się w katalogu %SYSTEMROOT%, może służyć do wykrywania błędów instalacji sterowników i weryfikacji podpisów. Aby przeprowadzić czystą rejestrację kodu, którego system Windows używa do zainstalowania sterownika i zweryfikowania podpisu, przed zainstalowaniem sterownika należy usunąć dziennik.

Należy włączyć pełne rejestrowanie w pliku Setupapi, dodając wartość LogLevel do następującego klucza rejestru:

HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup

DWORD LogLevel
Dane = FFFF

Następnie należy ponownie uruchomić system, zainstalować sterownik, który ma być testowany, i otworzyć plik Setupapi.log. Zawiera on szczegółowy opis stanu każdego ze składników sterownika, w tym informacje, czy dany składnik jest prawidłowo podpisany.

Aby uzyskać więcej informacji, zobacz dokument techniczny Podpisywanie sterowników dla systemów operacyjnych Windows (http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/code_signing.asp) dostępny w witrynie Windows Hardware and Driver Central w sieci Web (http://www.microsoft.com/whdc/).


Preinstalowanie sterowników magazynu masowego

Oprogramowanie Plug and Play instaluje większość sterowników sprzętu, które można załadować później w procesie instalacji. Aby jednak udostępnić pełną obsługę technologii Plug and Play podczas instalacji w trybie graficznym, należy poprawnie zainstalować sterowniki magazynu masowego, takie jak sterowniki kontrolerów dysków twardych. Z tego względu ich instalacja jest obsługiwana inaczej niż w przypadku innych sterowników sprzętu.

Jeśli w pliku Unattend.txt jest sekcja [MassStorageDrivers], to podczas instalacji w trybie tekstowym nie będą instalowane żadne wewnętrzne sterowniki magazynu masowego, chyba że zostaną one określone w tej właśnie sekcji. Jeśli nie ma tej sekcji lub nie zawiera ona żadnych wpisów, Instalator próbuje wykryć urządzenia na komputerze i zainstalować odpowiednie sterowniki wewnętrzne.

Aby preinstalować sterowniki magazynu masowego podczas instalacji w trybie tekstowym, zanim będzie dostępna obsługa technologii Plug and Play, należy udostępnić plik Txtsetup.oem, opisujący, w jaki sposób ma przebiegać instalacja konkretnych sterowników.

Aby uzyskać więcej informacji o pliku Txtsetup.oem, zobacz zestaw Microsoft Windows Driver Development Kit (DDK), który można zamówić w witrynie zestawu DDK firmy Microsoft w sieci Web (http://www.microsoft.com/ddk/). Z dokumentacją zestawu DDK można również zapoznać się w bibliotece MSDN Library (http://msdn.microsoft.com/library/): Należy kliknąć łącze Windows Development, a następnie Driver Development Kit.

Aby preinstalować urządzenie magazynu masowego

  1. W podfolderze \$OEM$ zestawu konfiguracyjnego utwórz podfolder \Textmode.
  2. Skopiuj pliki z dysku dostarczonego przez dostawcę urządzenia do podfolderu \Textmode. Są to zazwyczaj następujące pliki:
    • Sterownik.sys
    • Sterownik.dll
    • Sterownik.inf
    • Sterownik.cat
    • Txtsetup.oem

    gdzie Sterownik to nazwa sterownika.

    Uwagi

    • Pliki sterownika należy również skopiować do lokalizacji określonej we wpisie OemPnPDriversPath w plikach odpowiedzi. Na przykład:
      OemPnPDriversPath = drivers\storage
    • Niektóre sterowniki, takie jak sterowniki miniportu SCSI, mogą nie zawierać pliku dll.
    • Jeśli plik wykazu (Sterownik.cat) jest na liście w pliku Txtsetup.oem, to musi zostać dołączony do sterowników urządzeń magazynu masowego.

      Aby uzyskać więcej informacji o plikach wykazu, zobacz Używanie sterowników podpisanych. Zobacz też zestaw Microsoft Windows Driver Development Kit (DDK), z którym można zapoznać się w bibliotece MSDN Library (http://msdn.microsoft.com/library/): Należy kliknąć łącze Windows Development, a następnie Driver Development Kit.

  3. W pliku Unattend.txt utwórz sekcję [MassStorageDrivers], a następnie wpisz w niej żądane wpisy sterowników. Wpis w sekcji [MassStorageDrivers] może wyglądać na przykład tak:
    "Adaptec 2940..." = "OEM"

    Informacje do zawarcia w tej sekcji można uzyskać z sekcji [SCSI] pliku Txtsetup.oem dostarczonego przez producenta sprzętu.

    Uwaga

    • Konieczne jest użycie sterowników podpisanych. Sterowniki niepodpisane nie są instalowane podczas instalacji nienadzorowanej.
  4. W pliku Unattend.txt utwórz sekcję [OEMBootFiles] i wpisz w niej listę plików znajdujących się w folderze \$OEM$\Textmode. Na przykład:
    [OEMBootFiles]
Sterownik.sys
Sterownik.dll
Sterownik.inf
Sterownik.cat
Txtsetup.oem

    gdzie Sterownik to nazwa sterownika.

    Ważne

    • Do sekcji [MassStorageDrivers] i [OEMBootFiles] należy dodawać tylko wpisy sterowników rozruchowych urządzeń magazynu masowego. Nie należy umieszczać tam wpisów pomocniczych urządzeń magazynu masowego. Zamiast tego sterowniki pomocniczych urządzeń magazynu masowego należy dodać do folderu określonego we wpisie OemPnPDriversPath pliku odpowiedzi instalacji nienadzorowanej. Umieszczenie sterowników urządzeń magazynu masowego innych niż rozruchowe w sekcji [MassStorageDrivers] lub [OEMBootFiles] spowoduje wystąpienie błędu podczas instalacji.
  5. Jeśli urządzenie magazynu masowego jest urządzeniem typu Plug and Play, sprawdź, czy w pliku Txtsetup.oem jest sekcja identyfikacji sprzętu (Hardware Identification) i nazwa pliku wykazu sterownika (Sterownik.cat). Aby uzyskać więcej informacji, zobacz zestaw Microsoft Windows Driver Development Kit w bibliotece MSDN Library (http://msdn.microsoft.com/library/): Należy kliknąć łącze Windows Development, a następnie Driver Development Kit.

Jeśli nie ma sekcji Hardware Identification, to do pliku Txtsetup.oem należy dodać sekcję [HardwareIds.scsi.yyyyy], zawierającą następujące informacje:

id = "xxxxx" , "yyyyy"

gdzie xxxxx to identyfikator urządzenia, a yyyyy reprezentuje usługę skojarzoną z tym urządzeniem.

Aby na przykład preinstalować sterownik Symc810, którego identyfikator sprzętu to PCI\VEN_1000&DEV_0001, należy sprawdzić, czy plik Txtsetup.oem zawiera następującą dodatkową sekcję:

[HardwareIds.scsi.symc810]
id = "PCI\VEN_1000&DEV_0001","symc810"

Z pliku Txtsetup.oem trzeba usunąć odwołania do dysków i ścieżek. Na przykład zamiast tego tekstu należy użyć zamieszczonych poniższych przykładów dla systemów plików NTFS i FAT32:

[disks]
d1 = "Windows XP Driver Set v1.00", \w2kdsk1, \win2000\smy810\

W przypadku instalacji w systemie plików NTFS użyj następującego tekstu:

[disks]
d1 = "Windows XP Driver Set v1.00", \w2kdsk1, \

Zwróć uwagę na kreskę ułamkową odwróconą na końcu tego wiersza.

W przypadku instalacji w systemie plików FAT32 użyj następującego tekstu:

[disks]
d1 = "Windows XP Driver Set v1.00", w2kdsk1, .

Zwróć uwagę na brak kreski ułamkowej odwróconej i obecność kropki na końcu tego wiersza.

Wybieranie i ładowanie odpowiedniego sterownika magazynu masowego

W przypadku dołączania nowych lub zaktualizowanych sterowników urządzeń magazynu masowego sterowniki te należy dodać do obu tych folderów:

  • \$OEM$\Textmode
  • Lokalizacja określona we wpisie OemPnPDriversPath pliku Unattend.txt.

    Na przykład: \$OEM$\$1\Pnpdrvrs\storage

Ładowanie sterowników magazynu masowego podczas instalacji w trybie tekstowym

Jeśli sterownik urządzenia magazynu masowego jest zawarty w systemie Windows XP, to jest on wybierany przed wszelkimi sterownikami umieszczonymi w pliku \$OEM$\Textmode.

Jednakże sterownik umieszczony w pliku \$OEM$\Textmode jest podczas instalacji w trybie tekstowym wybierany jako pierwszy, jeśli:

  • Sterownik dostarczony wraz z systemem Windows XP nie działa.
  • Sterownik nie jest dostarczany z systemem Windows XP.

Ładowanie sterowników magazynu masowego podczas instalacji w trybie graficznym

W systemie Windows XP zaktualizowany lub nowy sterownik jest ładowany podczas instalacji w trybie graficznym pod warunkiem spełnienia następujących kryteriów.

Jeśli ładowany sterownik urządzenia magazynu masowego jest aktualizacją sterownika dostarczanego wraz z systemem Windows XP:

  • Prawidłowy sterownik magazynu masowego znajduje się w lokalizacji określonej we wpisie OemPnPDriversPath.
  • Sterownik jest podpisany i stanowi wersję nowszą niż wersja dostarczana z systemem Windows XP.

Jeśli ładowany jest nowy sterownik urządzenia magazynu masowego, niedostarczony wraz z systemem Windows XP:

  • Sterownik jest nowy (nie był dołączony do systemu Windows XP) i podpisany, a jego instalacja w trybie tekstowym przebiega prawidłowo.

Aby uzyskać informacje na temat sposobu wybierania w systemie Windows sterownika podczas wykrywania urządzeń typu Plug and Play, zobacz Jak system Windows wybiera określony sterownik urządzenia.

Aby uzyskać więcej informacji na temat zarządzania obrazami systemów operacyjnych zawierającymi różne sterowniki magazynu masowego, zobacz Zmniejszanie liczby obrazów wzorcowych dla komputerów z różnymi kontrolerami magazynu masowego.

Uwaga

  • W przypadku uruchamiania polecenia Sysprep -reseal lub Sysprep -factory narzędzie Sysprep odczytuje sekcję [SysprepMassStorage] pliku Sysprep.inf i przed zamknięciem systemu zapisuje w rejestrze informacje dotyczące magazynu masowego. Przy następnym uruchamianiu komputera wszystkie kontrolery magazynu masowego są dostępne.


Preinstalowanie urządzeń typu Plug and Play

Aby zwiększyć komfort korzystania z komputera i skrócić czas uruchamiania przy pierwszym rozruchu, w instalacji wzorcowej można uwzględnić dodatkowe sterowniki urządzeń typu Plug and Play. Aby na tym etapie procesu produkcyjnego uniknąć dokonywania zmian w instalacji wzorcowej, za pomocą narzędzia Sysprep można zainstalować dodatkowe sterowniki urządzeń typu Plug and Play przed przekazaniem komputera klientowi.

Preinstalowanie urządzeń typu Plug and Play podczas instalacji nienadzorowanej

Podczas instalacji nienadzorowanej można łatwo preinstalować urządzenia typu Plug and Play, które nie są urządzeniami magazynowania masowego i nie są umieszczane na dysku CD z produktem Windows.

Aby preinstalować urządzenia typu Plug and Play:

  1. W podfolderze \$OEM$ zestawu konfiguracyjnego utwórz podfolder dla wszelkich specjalnych sterowników Plug and Play oraz skojarzonych z nimi plików .cat i .inf. Na przykład:
    $OEM$\$1\PnPDrvrs
  2. W pliku Unattend.txt, w sekcji [Unattended] dodaj wpis OEMPnPDriversPath. Na przykład:
    OEMPnPDriversPath = "PnPDrvrs"

Jeśli w folderze, który zawiera sterowniki, są podfoldery, konieczne jest określenie ścieżki do każdego podfolderu. Ścieżki należy oddzielić średnikami. Jeśli na przykład folder \PnPDrvrs zawiera podfoldery \Net i \Audio, w pliku Unattend.txt należy umieścić następujący wiersz:

OEMPnPDriversPath = "PnPDrvrs\Net;PnPDrvrs\Audio"

Uwagi

  • Instalator tworzy określony folder w katalogu głównym dysku systemowego i folder ten pozostaje w tej lokalizacji po zakończeniu pracy Instalatora.
  • Ewentualnie, aby uniemożliwić użytkownikom końcowym przypadkowe usunięcie folderów sterowników z katalogu głównego dysku, sterowniki można umieścić w folderze \$OEM$\$$ (na przykład: $OEM$\$$\PnP\Audio).

Aby uzyskać więcej informacji, zobacz Jak system Windows wybiera określony sterownik urządzenia.

Preinstalowanie urządzeń typu Plug and Play za pomocą narzędzia Sysprep

Aby dodać ścieżki alternatywne, wykraczające poza zakres ścieżek określonych w obrazie instalacji wzorcowej, w pliku Sysprep.inf można umieścić wpis OemPnPDriversPath określający jedną lub więcej alternatywnych ścieżek do sterowników. Każda ścieżka musi wskazywać folder zawierający wszystkie pliki niezbędne do zainstalowania określonych urządzeń: pliki wykazu, pliki .inf oraz sterowniki.

Podczas pierwszego uruchomienia komputera zduplikowanego za pomocą narzędzia Sysprep zostaje wykryty cały sprzęt. W przypadku wykrycia urządzenia sprzętowego, którego sterowników nie ma w domyślnym pliku Driver.cab, komputer sprawdza lokalizację określoną we wpisie OemPnPDriversPath. Jeśli sterowników nie ma również w tej lokalizacji, wyświetlany jest monit o podanie lokalizacji sterowników.

Urządzenia typu Plug and Play można również preinstalować, korzystając z polecenia Sysprep -factory i pliku Winbom.ini. Aby uzyskać więcej informacji, zobacz Korzystanie z narzędzia Sysprep i [PnPDrivers] w pliku Winbom.ini.


Jak system Windows wybiera określony sterownik urządzenia

Aby określić, który sterownik jest najlepszy dla danego urządzenia, system Windows XP nadaje sterownikom rangę i wybiera sterownik o najniższej randze. Im niższa jest ranga sterownika, tym lepiej pasuje on do urządzenia. Jeśli wiele sterowników ma tę samą rangę, wybierany jest sterownik o najnowszej dacie.

Aby określić rangę, system Windows XP sprawdza, czy sterownik opatrzony jest podpisem i porównuje identyfikatory sprzętu i identyfikatory zgodne urządzenia z identyfikatorami z listy w sekcji [Models] pliku .inf. Do urządzenia najlepiej pasuje sterownik podpisany, którego identyfikator sprzętu jest zgodny z pierwszym identyfikatorem sprzętu określonym w urządzeniu. Sterowniki podpisane są zawsze klasyfikowane jako dopasowane lepiej niż sterowniki niepodpisane.

Ogólnie rzecz biorąc nie trzeba znać dokładnego numeru określającego rangę danego urządzenia, ponieważ algorytm określania rangi może ulec zmianie w przyszłych wersjach. Należy jednak pamiętać, że im niższa jest ranga, tym lepiej sterownik pasuje do urządzenia. Najlepiej pasującym sterownikiem jest sterownik o randze 0.

W systemach Windows 2000 i Windows XP schematy klasyfikacji sterowników różnią się. Schemat klasyfikacji sterowników określa, który z wielu dostępnych sterowników urządzenia ma być załadowany. Sterowniki są klasyfikowane na podstawie tego, czy są podpisane i na ile pasują do identyfikatora sprzętu urządzenia. Poniższa lista stanowi podsumowanie schematów klasyfikacji sterowników dla systemów Windows 2000 i Windows XP w kolejności od klasyfikacji najwyższej do najniższej:

Schemat klasyfikacji sterowników w systemie Windows 2000:

  1. Sterownik podpisany z idealną zgodnością sterownika z czteroczęściowym identyfikatorem HW ID
  2. Sterownik niepodpisany z idealną zgodnością sterownika z czteroczęściowym identyfikatorem HW ID
  3. Sterownik podpisany ze zgodnością sterownika z dwuczęściowym identyfikatorem HW ID
  4. Sterownik niepodpisany ze zgodnością sterownika z dwuczęściowym identyfikatorem HW ID

Schemat klasyfikacji sterowników w systemie Windows XP:

  1. Sterownik podpisany z idealną zgodnością sterownika z czteroczęściowym identyfikatorem HW ID
  2. Sterownik podpisany ze zgodnością sterownika z dwuczęściowym identyfikatorem HW ID
  3. Sterownik niepodpisany z idealną zgodnością sterownika z czteroczęściowym identyfikatorem HW ID (sekcja INF uzupełniona o informacje systemu NT)
  4. Sterownik niepodpisany ze zgodnością sterownika z dwuczęściowym identyfikatorem HW id (sekcja INF uzupełniona o informacje systemu NT)
  5. Sterownik niepodpisany z idealną zgodnością sterownika z czteroczęściowym identyfikatorem HW ID (sekcja INF bez informacji systemu NT)
  6. Sterownik niepodpisany ze zgodnością sterownika z dwuczęściowym identyfikatorem HW ID (sekcja INF bez informacji systemu NT)

Jeśli sterowniki urządzenia mają tę samą rangę, system Windows XP porównuje daty sterowników, znajdujące się we wpisie DriverVer pliku .inf.

Aby uzyskać więcej informacji o tym, jak system Windows XP klasyfikuje sterowniki, zobacz witrynę Windows Hardware and Driver Central w sieci Web (http://www.microsoft.com/whdc/) lub zestaw Microsoft Driver Development Kit (DDK). Zestaw DDK można zamówić w witrynie zestawu DDK firmy Microsoft w sieci Web (http://www.microsoft.com/ddk/). Z dokumentacją zestawu DDK można również zapoznać się w bibliotece MSDN Library (http://msdn.microsoft.com/library/): Należy kliknąć łącze Windows Development, a następnie Driver Development Kit.

Korzystanie z pliku Setupapi.log do rozwiązywania problemów z wybieraniem sterowników

Jeśli w przypadku instalowania zaktualizowanego sterownika urządzenia dla systemu Windows XP okaże się, że po ukończeniu instalacji systemu Windows nowy sterownik nie jest używany, należy:

  • Sprawdź, czy sterownik ma ważny podpis. Aby uzyskać więcej informacji na temat podpisów sterowników, zobacz Podpisy sterowników.
  • Sprawdzić rangę nowego sterownika.
  • Sprawdzić w pliku Setupapi.log informacje o sposobach przetwarzania sterownika w systemie Windows. Aby wyświetlić zawartość pliku Setupapi.log, przejdź do lokalizacji %WINDIR%\Setupapi.log.

Aby uzyskać więcej informacji o pliku Setupapi.log, zobacz zestaw Microsoft Windows Driver Development Kit lub witrynę Windows Hardware Driver Central w sieci Web pod adresem http://www.microsoft.com/whdc/hwdev/driver/setup/SetupAPI.mspx.

Zwiększanie szczegółowości pliku Setupapi.log

Jeśli do diagnozowania problemów z wybieraniem sterowników potrzeba więcej informacji niż jest aktualnie dostępne przy domyślnym ustawieniu pliku Setupapi.log, to można zwiększyć szczegółowość rejestrowania (czyli zwiększyć ilość dostarczanych informacji), korzystając z następujących procedur:

Aby zwiększyć szczegółowość pliku Setupapi.log, edytując rejestr:

W celu ustawienia pełnego poziomu rejestrowania należy dodać odpowiednią wartość do następującego klucza rejestru:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup

Nazwa wartości: LogLevel
Typ danych: REG_DWORD
Wartość: 0xFFFF

Powyższą wartość należy dodać przed rozpoczęciem instalacji w trybie graficznym (zaraz po zakończeniu instalacji w trybie tekstowym). Możesz również wymusić dodanie tej wartości przez Instalatora, wykonując poniższe kroki.

Ta metoda wymaga zmodyfikowania plików instalacyjnych systemu Windows XP. Jeśli na serwerze sieciowym nie ma jeszcze udziału dystrybucyjnego, należy skopiować folder \I386 z dysku CD z systemem Windows XP na lokalny dysk twardy. Przed kontynuacją należy utworzyć kopię zapasową pliku Hivesft.inf.

Aby zwiększyć szczegółowość pliku Setupapi.log, edytując plik Hivesft.inf:

  1. W udziale dystrybucyjnym lub na lokalnym dysku twardym zawierającym pliki systemu Windows XP zlokalizuj plik Hivesft.inf w folderze \I386.
  2. Używając dowolnego edytora tekstów (takiego jak Notatnik), zlokalizuj w pliku Hivesft.inf następujący wiersz:
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","DriverCachePath",0x00020002,"%SYSTEMROOT%\Driver Cache"
  3. Pod tym wierszem dodaj następujący wiersz:
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","LogLevel",0x00010003,0x0000FFFF

    Powyższe dwa wiersze mogą być zawijane w celu zwiększenia czytelności, ale każdy z nich stanowi oddzielny pojedynczy wiersz.

  4. Po zakończeniu plik musi wyglądać tak, jak w poniższym przykładzie. Sprawdź to przed zapisaniem pliku na dysku:
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","DriverCachePath",0x00020002,"%SYSTEMROOT%\Driver Cache"
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup","LogLevel",0x00010003,0x0000FFFF
    HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\BaseWinOptions",,0x00000012

    Zapisz plik i zamknij edytor tekstów.

Każda instalacja zainicjowana z tego udziału będzie miała włączone pełne rejestrowanie w pliku Setupapi.log. W trybie graficznym Instalatora można sprawdzić, czy ta opcja jest włączona, naciskając klawisze SHIFT+F10 w celu uruchomienia wiersza polecenia, a następnie, używając programu Regedit.exe sprawdzić, czy ta wartość rejestru została utworzona.

Uwagi

  • Aby wyświetlić plik Setupapi.log i sprawdzić, w jaki sposób system Windows wykrył i zainstalował sterowniki urządzeń, przejdź do pliku %WINDIR%\Setupapi.log.
  • Aby uzyskać więcej informacji dotyczących preinstalowania urządzeń typu Plug and Play, zobacz Preinstalowanie urządzeń typu Plug and Play.


Wykrywanie poprawnego trybu wideo dla ekranów komputerów przenośnych

Aby upewnić się, że Instalator poprawnie wykrywa tryb wideo, sprawdź, czy:

  • System BIOS obsługuje zestaw rozszerzeń wideo ACPI.
  • Ścieżka \$1\Pnpdrvrs obejmuje sterowniki obsługujące karty wideo i wyświetlacze.

Ważne

  • Dodaj ścieżkę Pnpdrvrs do wpisu OemPnPDriversPath w pliku Unattend.txt.

Aby Instalator automatycznie wykrywał rozdzielczość wyświetlacza komputera przenośnego (przy założeniu, że poprzednie elementy są poprawnie obsługiwane), określ optymalne ustawienia w sekcji [Display] pliku Unattend.txt.

Aby umożliwić użytkownikom końcowym poprawę czytelności za pomocą funkcji ClearType, w sekcji [ComputerSettings] pliku Winbom.ini ustaw wartość wpisu FontSmoothing na On.

Aby uzyskać najnowsze informacje na temat urządzeń sprzętowych działających w systemie Windows XP, zobacz witrynę Windows Hardware and Driver Central w sieci Web (http://www.microsoft.com/whdc/)


Pokazywanie urządzeń ukrytych

Podczas preinstalacji można utworzyć instalację wzorcową uwzględniającą wszystkie urządzenia typu Plug and Play, które można dostarczyć użytkownikowi końcowemu. W systemie Windows XP Menedżer urządzeń pokazuje tylko urządzenia obecne w dostarczanym komputerze, a nie wszystkie urządzenia zawarte w pliku instalacji wzorcowej.

Poniższa procedura umożliwia pracownikowi obsługi technicznej lub inżynierowi określenie, aby Menedżer urządzeń pokazywał urządzenia, które mogły być obecne w komputerze wzorcowym.

Aby pokazać urządzenia ukryte:

  1. Kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania.
  2. Kliknij dwukrotnie ikonę System.
  3. Kliknij kartę Zaawansowane, a następnie kliknij przycisk Zmienne środowiskowe.
  4. W obszarze Zmienne systemowe kliknij przycisk Nowa.
  5. W polu Nazwa zmiennej wpisz
    DEVMGR_SHOW_NONPRESENT_DEVICES
  6. W polu Wartość zmiennej wpisz wartość True.

    Uwaga

    • W polu tym można wprowadzić dowolną wartość niezerową.
  7. Kliknij dwukrotnie przycisk OK.
  8. W oknie Właściwości systemu kliknij kartę Sprzęt, a następnie kliknij przycisk Menedżer urządzeń.
  9. W menu Widok kliknij polecenie Pokaż ukryte urządzenia.

Uwaga

  • Aby ukryte urządzenia były wyświetlane, należy przy każdym otwarciu Menedżera urządzeń ponownie zaznaczyć polecenie Pokaż ukryte urządzenia.

Aby uzyskać więcej informacji, zobacz Jak system Windows wybiera określony sterownik urządzenia.

Usuwanie urządzeń urojonych

Aby usunąć odwołania do urządzeń, które były zainstalowane w komputerze wzorcowym, uruchom polecenie Sysprep -clean. To wymaga prawidłowej sekcji [Cleanup] w pliku Sysprep.inf. Uruchomienie tego polecenia powoduje wyczyszczenie nieużywanych sterowników magazynu masowego dodanych przez sekcję [SysprepMassStorage] pliku Sysprep.inf, a także usunięcie odwołań do urządzeń urojonych utworzonych przez oprogramowanie Plug and Play. W przeciwnym przypadku te wpisy mogą być przyczyną problemów podczas próby zainstalowania nowych urządzeń. Polecenie Sysprep -clean usuwa wszystkie urządzenia urojone z wyjątkiem następujących:

  1. HTREE\ROOT\0 (katalog główny drzewa Plug and Play)
  2. Urządzenia SWENUM (urządzenia wyliczane przez oprogramowanie, którym nie odpowiada żaden sprzęt).

    Ponieważ nie są one instalowane na podstawie obecności sprzętu, najlepiej ich nie usuwać.

  3. Węzły devnode starszych urządzeń (utworzone z powodu obecności starszych usług).

Uwaga

  • Jeśli sekcja [SysprepMassStorage] jest już w danym pliku Sysprep.inf, a zostało uruchomione polecenie Sysprep -factory, to polecenie Sysprep -reseal spowoduje automatyczne wyczyszczenie Menedżera urządzeń. (To znaczy narzędzie Sysprep usunie odwołania do tych urządzeń, które nie są już dostępne.) Eliminuje to konieczność dodatkowego kroku uruchomienia polecenia Sysprep -clean w pliku Cmdlines.txt.


Zmniejszanie liczby obrazów wzorcowych dla komputerów z różnymi kontrolerami magazynu masowego

transparent

Zmniejszanie liczby obrazów wzorcowych dla komputerów wyposażonych w różne kontrolery magazynowania masowego

Mechanizm Sysprep wymaga, aby kontroler magazynowania masowego znajdujący się w komputerze zawierającym instalację wzorcową był taki sam, jak kontrolery znajdujące się w komputerach docelowych.

W przypadku używania obrazów jako części procesu produkcyjnego można ograniczyć liczbę istniejących obrazów, tworząc jeden obraz wzorcowy umożliwiający instalowanie systemu Windows na komputerach docelowych, które mogą być wyposażone w różne kontrolery magazynowania masowego, jak to opisano w scenariuszu poniżej:

Kontroler użyty do utworzenia instalacji wzorcowej | Kontroler na komputerze docelowym | Przykładowy scenariusz
IDE | IDE | Obraz wzorcowy utworzono na komputerze z kontrolerem PCI IDE; komputery docelowe są wyposażone w kontroler IDE firmy Intel.
IDE | SCSI | Obraz wzorcowy utworzono na komputerze z kontrolerem PCI IDE; niektóre komputery docelowe są uruchamiane przy użyciu kontrolera SCSI, na przykład Adaptec 7800.
SCSI | SCSI | Obraz wzorcowy utworzono na komputerze z kontrolerem Adaptec 7800; komputery docelowe są wyposażone w kontroler Qlogic.
SCSI | IDE | Obraz wzorcowy utworzono na komputerze z kontrolerem Adaptec 7800; niektóre komputery docelowe są uruchamiane przy użyciu kontrolera IDE.

Przed uruchomieniem narzędzia Sysprep na instalacji wzorcowej i utworzeniem jej obrazu należy w sekcji [SysprepMassStorage] pliku Sysprep.inf zidentyfikować różne kontrolery magazynowania masowego, które można zainstalować na poszczególnych komputerach docelowych. Można to zrobić automatycznie, wykonując procedurę z poniższej sekcji „Automatyczne identyfikowanie zestawu sterowników magazynu masowego”. Narzędzie Sysprep wypełnia wstępnie niezbędne informacje o sterownikach, dzięki czemu podczas uruchamiania systemu operacyjnego na komputerze wyposażonym w jeden z predefiniowanych kontrolerów magazynowania masowego system Windows może załadować prawidłowe sterowniki.

Aby uzyskać więcej informacji, zobacz Przygotowanie instalacji do rozmieszczenia i [SysprepMassStorage].

Automatyczne identyfikowanie zestawu sterowników magazynowania masowego

Wpisów w sekcji [SysprepMassStorage] nie trzeba tworzyć ręcznie. Zamiast tego w pliku Sysprep.inf należy umieścić sekcję [Sysprep], a narzędzie Sysprep automatycznie wygeneruje wpisy w sekcji [SysprepMassStorage] na podstawie identyfikatorów sprzętu typu Plug and Play znajdujących się w plikach: Machine.inf, Scsi.inf, Pnpsci.inf i Mshdc.inf.

Uwaga

  • Ta procedura dotyczy tylko sterowników dostarczanych z systemem Windows XP. Ponadto sekcja [SysprepMassStorage] musi być pusta; w przeciwnym wypadku procedura nie działa.

W sekcji [Sysprep] pliku Sysprep.inf dla wpisu BuildMassStorageSection należy ustawić wartość Yes. Na przykład:

[Sysprep]
BuildMassStorageSection = Yes

Użycie tej metody może spowodować zainstalowanie większej liczby sterowników magazynowania masowego, niż jest to wymagane, co może spowodować wydłużenie rozruchu komputera. Metoda ta natomiast znacznie rzadziej powoduje wystąpienie błędów.

Ręczne identyfikowanie zestawu sterowników magazynu masowego

Jeśli znany jest dokładny zestaw wymaganych identyfikatorów urządzeń typu Plug and Play, można skrócić rozruch systemu operacyjnego dzięki ręcznemu utworzeniu sekcji [SysprepMassStorage] w pliku Sysprep.inf.

Aby zidentyfikować kontrolery magazynowania masowego, które mogą się znajdować w komputerach docelowych:

  1. Wygeneruj listę identyfikatorów sprzętu dla każdego z kontrolerów magazynowania masowego, które mogą znajdować się w komputerach docelowych.
  2. Porównaj listę utworzoną w kroku 1 z identyfikatorami sprzętu z listy w pliku .inf, aby określić, które odwołania będą potrzebne.
  3. W przypadku kontrolerów magazynowania masowego znajdujących się na dysku CD z produktem Windows utwórz plik Sysprep.inf zawierający następującą sekcję:
    [SysprepMassStorage]
identyfikator_sprzętu = ścieżka_do_pliku_inf_urządzenia

    gdzie:

    identyfikator_sprzętu
    Identyfikator urządzenia typu Plug and Play, określony w pliku .inf tego urządzenia.
    ścieżka_do_pliku_inf_urządzenia
    Ścieżka do pliku .inf zawierającego identyfikator Plug and Play kontrolera do zainstalowania.

    Tak może wyglądać na przykład sekcja zapewniająca obsługę różnych kontrolerów IDE (PCI i Intel) dostarczanych wraz z systemem Windows XP:

    [SysprepMassStorage]
PCI\VEN_8086&DEV_1222 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_1230 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_7010 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_7111 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_2411 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_2421 = "%WINDIR%\inf\mshdc.inf"
PCI\VEN_8086&DEV_7199 = "%WINDIR%\inf\mshdc.inf"

    Aby uzyskać najlepsze wyniki, należy umieścić tę listę tylko w podzestawie identyfikatorów Plug and Play wymaganych w danym środowisku. Rozpoznawanie zbędnych identyfikatorów sprzętu z tej listy wydłuża niepotrzebnie czas uruchamiania komputera.

  4. W przypadku sterowników magazynowania masowego, które nie są dostarczane na dysku CD z produktem Windows:
    • Skopiuj pliki sterowników kontrolerów magazynowania masowego znajdujące się na komputerach docelowych do folderu na swoim komputerze – na przykład do folderu %SYSTEMDRIVE%\pnpdrvrs\storage, znajdującego się na dysku twardym komputera wzorcowego.
  5. Do sekcji [SysprepMassStorage] dodaj wpisy w następującym formacie:
    identyfikator_sprzętu = "ścieżka_do_pliku_inf_urządzenia", "katalog_na_dysku", "opis_dysku", "znacznik_dysku"

    gdzie:

    identyfikator_sprzętu
    Identyfikator urządzenia typu Plug and Play, określony w pliku .inf tego urządzenia.
    ścieżka_do_pliku_inf_urządzenia
    Ścieżka do pliku .inf zawierającego identyfikator Plug and Play kontrolera do zainstalowania.
    katalog_na_dysku
    Nazwa folderu na dyskietce dostarczanej przez inną firmę, w którym znajduje się kopia sterownika magazynu masowego.
    opis_dysku
    Opis dyskietki, określony w pliku Txtsetup.oem dostarczonym przez inną firmę.
    znacznik_dysku
    Znacznik dysku dyskietki, określony w pliku Txtsetup.oem dostarczonym przez inną firmę.

    Wartości katalog_na_dysku, opis_dysku i znacznik_dysku są wymagane. Dzięki nim w procesie naprawy mogą być rozróżniane sterowniki znajdujące się na dysku CD z produktem Windows oraz sterowniki, których na nim nie ma. Jeśli sterownik dostarczony przez inną firmę zastąpi sterownik dostarczony na dysku CD z produktem Windows, to należy wykonać instrukcje zawarte w kroku 2.

    Pliki sterowników należy umieścić w lokalizacji określonej w sekcji [SysprepMassStorage] pliku Sysprep.inf. Jeśli na przykład pliki nowego sterownika Qlogic zostaną skopiowane do folderu C:\Drivers\Storage, to w celu obsługi sterownika należy dodać następujący wpis:

    [SysprepMassStorage]
PCI\VEN_1077&DEV_1080 = "C:\Drivers\Storage\qlogic\qlogic.inf", "C:\Drivers\Storage\qlogic", "Qlogic Software Disk", "C:\Drivers\Storage\qlogic\qlogic"

    Uwaga

    • Wszystkie wartości tego polecenia należy umieścić w jednym wierszu tekstu.
  6. Utwórz plik Cmdlines.txt, zawierający w górnej części następujące wiersze:
    [Commands]
"C:\Sysprep\Sysprep -clean"

    Polecenie to powoduje wyłączenie wszystkich kontrolerów magazynowania masowego, które nie są instalowane, ponieważ nie ma ich w komputerze docelowym.

    Ważne

    • Jeśli ten wiersz nie zostanie dodany do pliku Cmdlines.txt, to proces uruchamiania komputerów docelowych może przebiegać wolniej, ponieważ przy każdym ponownym uruchomieniu komputera system operacyjny będzie próbował załadować wszystkie sterowniki kontrolerów.

    Plik Cmdlines.txt należy umieścić w folderze $OEM$, w lokalizacji określonej w pliku Sysprep.inf we wpisie InstallFilesPath. Jeśli na przykład:

    InstallFilesPath = "C:\Sysprep\i386"

    to plik Cmdlines.txt należy skopiować do folderu
    C:\Sysprep\i386\$OEM$.

    Aby uzyskać więcej informacji o pliku Cmdlines.txt, zobacz Preinstalowanie aplikacji przy użyciu starszych metod.

  7. Uruchom narzędzie Sysprep.

    Uwaga

    • Podczas preinstalowania kontrolerów magazynowania masowego za pomocą tej procedury nie należy korzystać z zaktualizowanego pliku Sysprep.inf znajdującego się na dyskietce. Metoda ta nie będzie działać i może spowodować niepowodzenie instalacji.

Ważne

  • W przypadku scenariuszy polegających na użyciu kontrolerów IDE–SCSI oraz SCSI–SCSI warunkiem poprawnego działania narzędzia Sysprep jest zapewnienie możliwości dostępu do dysków twardych znajdujących się na komputerach docelowych za pośrednictwem rozszerzonych funkcji INT13 systemu BIOS. Musi być możliwe uruchamianie komputerów za pomocą takiego pliku boot.ini, w którym jest stosowana składnia multi( ), a nie składnia scsi( ) ani signature( ).

    Aby zagwarantować stosowanie składni multi( ), do pliku odpowiedzi (Unattend.txt) należy dodać wpis UseBiosToBoot.

  • Ta funkcja jest dostępna tylko dla kontrolerów magazynowania masowego typu Plug and Play (PnP) lub kontrolerów korzystających z miniportów PnP.
  • Warstwy abstrakcji sprzętu (HAL) komputera wzorcowego i komputerów docelowych muszą być zgodne.

Aby uzyskać więcej informacji na temat preinstalowania tych urządzeń, zobacz Preinstalowanie sterowników magazynu masowego.


Zmniejszanie liczby obrazów wzorcowych dla komputerów wieloprocesorowych

W przypadku korzystania z obrazów w procesie produkcyjnym ten sam obraz systemu Windows można preinstalować na komputerach wieloprocesorowych (MP) i jednoprocesorowych (UP), jeśli zarówno komputer wzorcowy, jak i komputer docelowy są wyposażone w zaawansowany programowalny kontroler przerwań (APIC) lub w kontroler APIC oraz system zarządzania oszczędzaniem energii (ACPI).

Aby uzyskać więcej informacji, zobacz:

  • Specyfikacja systemu zarządzania oszczędzaniem energii (ACPI) (http://www.acpi.info/index.html)
  • Kluczowe zalety systemu I/O APIC (http://www.microsoft.com/whdc/hwdev/platform/proc/IO-APIC.mspx)

W poniższej tabeli zestawiono typy komputerów docelowych, na których można instalować dany obraz wzorcowy, w zależności od typu warstwy abstrakcji sprzętowej (HAL) komputera użytego do utworzenia instalacji wzorcowej.

Warstwa HAL instalacji wzorcowej | Warstwa HAL komputera docelowego
 | ACPI APIC UP | ACPI APIC MP | Inna niż ACPI APIC UP | Inna niż ACPI APIC MP
ACPI APIC UP | X | X |  |
ACPI APIC MP | X | X |  |
Inna niż ACPI APIC UP |  |  | X | X
Inna niż ACPI APIC MP |  |  | X | X

Ważne

  • Typ warstwy HAL zmienia się tylko w przypadku uruchomienia narzędzia Sysprep w trybie miniinstalacji. Warstwa HAL nie zmienia się w przypadku uruchomienia narzędzia Sysprep w trybie fabrycznym lub trybie ponownego pieczętowania.
  • W żadnym wypadku nie należy próbować zmieniać warstwy ACPI HAL na standardową warstwę HAL ani standardowej warstwy HAL na warstwę ACPI HAL. Może to spowodować nieprawidłowe uruchomienie komputera lub nawet całkowicie uniemożliwić jego uruchomienie. Struktury drzew urządzeń tych dwóch typów warstw HAL są diametralnie różne, więc po ponownym uruchomieniu komputera system nie widzi zmian sprzętu, w tym lokalizacji urządzenia rozruchowego. Firma Microsoft nie zaleca stosowania tej procedury ani nie świadczy związanej z nią pomocy technicznej, ponieważ konsekwencją takiego działania jest utrata danych.

    Aby uzyskać więcej informacji na temat opcji warstwy HAL, zobacz artykuł 309283 z bazy wiedzy Microsoft Knowledge Base.

Uwagi

  • System Windows XP Home Edition nie obsługuje komputerów wieloprocesorowych.
  • Instalację wzorcową można zainstalować tylko z jednego komputera ACPI PIC na innym komputerze ACPI PIC.
  • Instalację wzorcową można zainstalować tylko z jednego komputera jednoprocesorowego innego niż ACPI PIC na innym komputerze jednoprocesorowym niebędącym komputerem ACPI PIC.
  • Obraz utworzony na komputerze jednoprocesorowym (bez obsługi wielu procesorów) nie może być wykorzystany na komputerze wieloprocesorowym.
  • W systemach APIC jest dostępnych więcej przerwań niż w jednoprocesorowych systemach wyposażonych w kontroler przerwań procesora (PIC). W efekcie komputer z warstwą HAL typu APIC:
    • Szybciej działa.
    • Może obsługiwać więcej urządzeń sprzętowych.

Istnieją dwie metody tworzenia obrazów, z których można korzystać zarówno w systemach wielo-, jak i jednoprocesorowych. Należy wybrać tę metodę, która jest najlepiej dostosowana do określonych potrzeb oraz do istniejącego środowiska produkcyjnego.

Stosowanie wieloprocesorowej instalacji wzorcowej na jednoprocesorowym komputerze docelowym

W pierwszej metodzie instalacja wzorcowa jest tworzona na komputerze wieloprocesorowym. Z tego obrazu można korzystać na innych komputerach wieloprocesorowych lub na komputerach jednoprocesorowych.

Ważne

  • Typ warstwy HAL komputera, na którym utworzono instalację wzorcową, określa typ komputera docelowego, na którym można korzystać z obrazu:
    • Instalacji wzorcowej utworzonej na wieloprocesorowym komputerze ACPI APIC można używać na innych wielo- lub jednoprocesorowych komputerach ACPI APIC.
    • Instalacji wzorcowej utworzonej na wieloprocesorowym komputerze innym niż ACPI APIC można używać na innych wielo- lub jednoprocesorowych komputerach niebędących komputerami ACPI APIC.

Aby utworzyć odwzorowanie MP na UP

  1. W pliku Sysprep.inf dodaj następujące wpisy:
    [Unattended]
UpdateUPHAL = "hwid,%WINDIR%\Inf\Hal.inf"

    gdzie hwid oznacza MPS_UP lub ACPIAPIC_UP.

    Aby uzyskać więcej informacji, zobacz wpis UpdateUPHAL.

  2. Zainstaluj konfigurację systemu Windows przeznaczoną dla komputera wieloprocesorowego.
  3. Uruchom narzędzie Sysprep w trybie miniinstalacji za pomocą pliku Sysprep.inf.

    Na przykład z folderu narzędzia Sysprep uruchom polecenie:

    C:\sysprep\sysprep -mini -quiet -shutdown
  4. Utwórz obraz instalacji.
  5. Umieść obraz na porównywalnych wieloprocesorowych komputerach docelowych.

Stosowanie jednoprocesorowej instalacji wzorcowej na wieloprocesorowym komputerze docelowym

W przypadku drugiej techniki tworzona jest instalacja wzorcowa na komputerze jednoprocesorowym z warstwą HAL typu APIC. Obraz ten można następnie wykorzystać do preinstalowania systemu Windows na komputerach docelowych wyposażonych w zgodny sprzęt, niezależnie od tego, czy jest na nich używana jedno-, czy wieloprocesorowa warstwa HAL typu APIC.

Ważne

  • Wszystkie wersje systemu Windows XP i systemów z rodziny Windows Server 2003 korzystające z warstwy HAL typu APIC (zarówno ACPI, jak i innej niż ACPI) automatycznie instalują odpowiednią wieloprocesorową warstwę HAL po wykryciu drugiego procesora. Oznacza to, że wpis UpdateHAL jest potrzebny tylko w przypadku wersji systemu Windows starszych niż Windows XP.

Ważne

Typ warstwy HAL komputera, na którym utworzono instalację wzorcową, określa typ komputera docelowego, na którym można korzystać z obrazu:

  • Instalacji wzorcowej utworzonej na jednoprocesorowym komputerze ACPI APIC można używać na innych jedno- lub wieloprocesorowych komputerach ACPI APIC.
  • Instalacji wzorcowej utworzonej na jednoprocesorowym komputerze innym niż ACPI APIC można używać na innych wielo- lub jednoprocesorowych komputerach docelowych innych niż ACPI APIC.

Aby utworzyć odwzorowanie UP na MP

  1. Zainstaluj system Windows na komputerze jednoprocesorowym.
  2. Utwórz obraz instalacji.
  3. W pliku Sysprep.inf dodaj następujące wpisy:
    [Unattended]
UpdateHAL = "hwid,%WINDIR%\Inf\Hal.inf"

    gdzie hwid oznacza MPS_MP lub ACPIAPIC_MP.

    Aby uzyskać więcej informacji, zobacz wpis UpdateHAL.

  4. Uruchom narzędzie Sysprep w trybie miniinstalacji za pomocą pliku Sysprep.inf.

    Ważne

    Na przykład z folderu narzędzia Sysprep uruchom polecenie:

    C:\sysprep\sysprep -mini -quiet -shutdown
  5. Utwórz obraz instalacji.
  6. Umieść obraz na porównywalnych wieloprocesorowych komputerach docelowych.

Ważne

  • Pliku Sysprep.inf zawierającego wpis UpdateHAL nie należy używać na jednoprocesorowych komputerach docelowych, ponieważ wpis UpdateHAL powoduje załadowanie na komputery docelowe warstwy HAL dla komputerów wieloprocesorowych, niezależnie od tego, czy są to komputery jedno-, czy wieloprocesorowe. Stosowanie wieloprocesorowego jądra systemu na komputerze jednoprocesorowym znacznie obniża wydajność komputera.

Podczas tworzenia nowych komputerów z obrazu można korzystać z dowolnych narzędzi używanych zwykle do operowania plikami przechowywanymi na dysku twardym.


Narzędzia i opcje wiersza polecenia

W wierszu polecenia można uruchomić następujące narzędzia z pliku Deploy.cab:

  • Opcje wiersza polecenia narzędzia Sysprep
  • Opcje wiersza polecenia narzędzia Cvtarea
  • Opcje wiersza polecenia narzędzia Oformat

Następujące narzędzia są zawarte w systemie operacyjnym Windows XP i są przydatne przy rozmieszczaniu systemu Windows XP:

  • Opcje wiersza polecenia narzędzia Convert
  • Polecenia narzędzia Diskpart
  • Skrypty narzędzia Diskpart
  • Opcje wiersza polecenia programu Winnt32.exe
  • Opcje wiersza polecenia programu Winnt.exe


Opcje wiersza polecenia narzedzia Sysprep

Narzedzie Windows System Preparation (Sysprep) przygotowuje dysk twardy komputera PC przed przekazaniem go uzytkownikowi koncowemu.

Skladnia polecenia Sysprep jest nastepujaca:

sysprep [-bmsd] | { {[-factory] | [-reseal]} {[-clean] | [-activated] [-audit] [-forceshutdown] [-mini] [-noreboot] [-nosidgen] [-pnp] [-quiet] [-reboot]} }

Opcja | Akcja
-activated Wylaczenie resetowania dodatkowego okresu aktywacji produktu Windows. Opcji tej nalezy uzywac tylko w przypadku, gdy aktywacje instalacji systemu Windows przeprowadzono fabrycznie.

Wazne

  • Klucz produktu uzyty do aktywacji instalacji systemu Windows musi byc zgodny z kluczem produktu umieszczonym na nalepce Certyfikatu Autentycznosci dolaczonej do danego komputera.
-audit Uruchamia ponownie komputer w trybie fabrycznym bez generowania nowych identyfikatorów zabezpieczen (SID) ani przetwarzania jakichkolwiek elementów z sekcji [OEMRunOnce] pliku Winbom.ini.

Tej opcji wiersza polecenia nalezy uzywac tylko wtedy, gdy komputer dziala w trybie fabrycznym.
-bmsd Jesli w pliku Sysprep.inf znajduje sie naglówek sekcji [SysprepMassStorage] i zostanie uruchomione polecenie Sysprep -bmsd, narzedzie Sysprep dodaje do sekcji [SysprepMassStorage] wpisy Plug_and_Play_ID = sciezka_do_pliku_inf_urzadzenia odpowiadajace identyfikatorom Plug and Play urzadzen magazynowania masowego, które okreslono w plikach Machine.inf, Scsi.inf, Pnpscsi.inf i Mshdc.inf. Narzedzie Sysprep tworzy jedynie liste urzadzen magazynowania masowego; nie instaluje tych urzadzen w bazie danych urzadzen krytycznych, ani nie wykonuje zadnych innych operacji.

Po uzyciu polecenia sysprep -bmsd do wygenerowania wpisów sekcji [SysprepMassStorage], mozna usunac elementy z tej sekcji przed uruchomieniem polecenia Sysprep -reseal lub Sysprep -factory w tej instalacji. Zainstalowanie mniejszej liczby elementów w bazie danych urzadzen krytycznych skraca czas potrzebny na przejscie od tego obrazu do uruchomienia systemu operacyjnego.

Opcji wiersza polecenia -bmsd nie nalezy uzywac z zadna inna opcja wiersza polecenia.
-clean | Usuwa nieuzywane sterowniki magazynowania masowego dodane przez sekcje [SysprepMassStorage] pliku Sysprep.inf, a takze urzadzenia urojone utworzone przez technologie Plug and Play.
-factory Ponowne uruchomienie systemu w trybie z obsluga sieci i bez wyswietlania apletu System Windows - Zapraszamy! ani miniinstalacji. Ta opcja jest przydatna podczas aktualizacji sterowników, uruchamiania wyliczania urzadzen Plug and Play, instalowania aplikacji, testowania, konfigurowania komputera przy uzyciu danych klienta lub wprowadzania innych zmian konfiguracji w srodowisku fabrycznym. W przypadku firm uzywajacych oprogramowania do tworzenia obrazów dysków (klonowania dysków) tryb fabryczny pozwala zmniejszyc liczbe potrzebnych obrazów.

Po zakonczeniu zadan w trybie fabrycznym mozna uruchomic opcje sysprep -reseal, aby przygotowac komputer do przekazania klientowi.
-forceshutdown Zamkniecie systemu po zakonczeniu pracy narzedzia Sysprep.

Uwaga

  • Tej opcji nalezy uzywac na komputerach wyposazonych w system BIOS z interfejsem ACPI, które nie sa zamykane poprawnie przy ustawieniach domyslnych narzedzia Sysprep.
-mini | Konfigurowanie systemu Windows XP Professional do uzycia miniinstalacji zamiast apletu System Windows — Zapraszamy! Ta opcja nie dziala w systemie Windows XP Home Edition, w którym programem poczatkowym jest zawsze aplet System Windows — Zapraszamy!
-noreboot | Modyfikowanie kluczy rejestru (SID, OemDuplicatorString i tak dalej) bez ponownego rozruchu systemu ani przygotowywania do duplikacji. Ta opcja sluzy glównie do testowania, zwlaszcza do sprawdzania, czy rejestr zostal zmodyfikowany poprawnie. Ta opcja nie jest zalecana, poniewaz wprowadzenie zmian w komputerze po uruchomieniu narzedzia Sysprep moze uniewaznic przygotowania poczynione przez to narzedzie. Nie nalezy uzywac tej opcji w srodowisku produkcyjnym.
-nosidgen | Uruchomienie narzedzia Sysprep bez generowania nowych identyfikatorów SID. Uzycie tej opcji jest konieczne, jesli komputer nie bedzie duplikowany lub jesli jest kontrolerem domeny.
-pnp Uruchomienie pelnego wyliczania i instalowania urzadzen Plug and Play podczas miniinstalacji. Ta opcja wiersza polecenia nie dziala, jesli pierwszym pojawiajacym sie ekranem jest aplet System Windows - Zapraszamy!

Opcji -pnp nalezy uzywac tylko do wykrycia i zainstalowania starszych urzadzen, nieobslugujacych standardu Plug and Play. Opcji -pnp nie nalezy uzywac na komputerach korzystajacych tylko z urzadzen Plug and Play. W przeciwnym razie spowoduje to wydluzenie czasu potrzebnego na pierwsze uruchomienie systemu bez zadnych dodatkowych korzysci dla uzytkownika.
-quiet | Uruchomienie narzedzia Sysprep bez wyswietlania na ekranie komunikatów potwierdzajacych. Ta opcja jest przydatna w przypadku automatyzowania pracy narzedzia Sysprep. Jesli na przyklad planowane jest uruchomienie narzedzia Sysprep zaraz po zakonczeniu instalacji nienadzorowanej, nalezy dodac wiersz sysprep -quiet do sekcji [GuiRunOnce] pliku Unattend.txt.
-reboot | Wymuszenie automatycznego ponownego uruchomienia komputera, a nastepnie uruchomienia apletu System Windows - Zapraszamy!, miniinstalacji lub trybu fabrycznego, zgodnie z wybrana opcja. Ta opcja jest przydatna, gdy trzeba dokonac inspekcji systemu i sprawdzic, czy pierwsze uruchomienie systemu przebiega poprawnie.
-reseal | Wyczyszczenie dzienników Podgladu zdarzen i przygotowanie komputera do przekazania klientowi. Komputer zostanie skonfigurowany tak, aby przy nastepnym rozruchu systemu uruchomiony zostal aplet System Windows - Zapraszamy! lub miniinstalacja. W przypadku uruchomienia polecenia sysprep -factory nalezy w ramach ostatniego kroku preinstalacji zapieczetowac instalacje, uruchamiajac polecenie sysprep -reseal albo klikajac przycisk Zapieczetuj ponownie w oknie dialogowym Sysprep.


Opcje wiersza polecenia Cvtarea

Cvtarea to wszechstronne narzędzie do tworzenia plików i analizowania ich rozmieszczenia w systemach plików FAT32 lub FAT. Za pomocą narzędzia Cvtarea można w sposób ciągły tworzyć i umieszczać ciągłe pliki w określonych lokalizacjach na dysku.

Jeśli procesy produkcyjne wymagają formatowania dysków twardych w systemie plików FAT lub FAT32 przed ich przekonwertowaniem na system plików NTFS, to można za pomocą narzędzia Cvtarea utworzyć zastrzeżony ciągły plik zastępczy, który będzie używany dla plików metadanych NTFS po zakończeniu konwersji. Skutkować to będzie mniej sfragmentowanym i bardziej wydajnym systemem plików.

Aby uzyskać więcej informacji, zobacz:

  • Konwertowanie partycji systemu FAT/FAT32 na partycje systemu NTFS
  • NTFS Preinstallation and Windows XP (http://www.microsoft.com/whdc/)
  • „Converting Volumes to NTFS” w witrynie Microsoft TechNet

Wykrywanie ilości wolnego miejsca na woluminie FAT

Składnia polecenia Cvtarea umożliwiająca wyświetlenie klastrów wolnego miejsca na woluminie FAT jest następująca:

cvtarea nazwa_dysku /freespace

Opcja | Akcja
nazwa_dysku | Litera dysku, po której następuje dwukropek. Na przykład, C:
/freespace | Wyświetla dostępne obszary wolnego miejsca.

Tworzenie pliku

Składnia polecenia Cvtarea umożliwiająca utworzenie pliku jest następująca:

cvtarea nazwa_pliku rozmiar [jednostki] [/contig] [/firstcluster klaster [jednostki_klastrów] [/strictlocation]]

Opcja | Akcja
nazwa_pliku | Nazwa tworzonego pliku. Plik musi znajdować się w katalogu głównym dysku, który ma być konwertowany.
rozmiar | 32-bitowa liczba całkowita, określająca rozmiar tworzonego obszaru.
jednostki Jednostka miary parametru rozmiar; prawidłowe opcje to KB, MB, GB, %disk i %free.
%disk
Wskazuje, że rozmiar pliku stanowi procent całkowitego rozmiaru dysku.
%free
Wskazuje, że rozmiar pliku stanowi procent bieżącego wolnego miejsca na dysku.
/contig | Określa, że utworzony plik musi zajmować ciągły obszar na dysku.
/firstcluster:klaster [jednsotki_klastra] | Określa pierwszy klaster, w który ma być umieszczony plik. Opcjonalnie można wskazać rozmiar jednostek klastra (na przykład 4 lub 8 KB).
/strictlocation | Plik nie zostanie utworzony, jeśli określony klaster jest już używany.

Wyświetlanie liczby klastrów używanych przez plik

Składnia polecenia Cvtarea umożliwiająca wyświetlenie klastrów używanych przez plik jest następująca:

cvtarea nazwa_pliku /info

Opcja | Akcja
nazwa_pliku | Nazwa istniejącego pliku.
/info | Wyświetla liczbę klastrów przydzielonych dla danego pliku.


Opcje wiersza polecenia narzędzia Oformat

Narzędzie Oformat tworzy wolumin FAT32 z klastrami, które są wyrównane w optymalny sposób na użytek późniejszego konwertowania woluminu na format systemu plików NTFS.

Ważne

  • Narzędzie to jest oparte na narzędziu Format systemu Windows Millennium Edition. W związku z tym można jedynie:
    • Narzędzie Oformat można uruchomić w tych wersjach systemu MS–DOS, które są dostarczane z systemami Windows Millennium Edition i Windows XP.
    • Uruchomić komputer przy użyciu systemu MS–DOS i zainstalować system Windows XP za pomocą programu Winnt.exe.

Ponadto w narzędziu Oformat zawarto ważne modyfikacje do użytku producentów komputerów:

  • Narzędzie Oformat nie wymusza weryfikacji sektorów przy pierwszym formatowaniu dysku. Wskutek tego możliwe jest wykonanie szybkiego formatowania natychmiast po utworzeniu nowej partycji, co w środowisku produkcyjnym jest znacznie szybsze niż użycie konwencjonalnego narzędzia Format.
  • Narzędzie Oformat nie monituje o potwierdzenie przed sformatowaniem dysku.
  • W przypadku użycia opcji wiersza polecenia /a narzędzie Oformat wyrównuje klastry danych systemu plików FAT przy określonym sektorze, co skraca czas konwersji dysku na system plików NTFS.

Składnia narzędzia Oformat do preinstalacji systemu Windows:

oformat litera_dysku [/a:liczba] [/autotest|/v:etykieta_dysku] [/q]

Opcja | Akcja
litera_dysku | Określa dysk do sformatowania.
/a:liczba | Wyrównuje sektory systemowe partycji FAT w sposób ułatwiający konwersję na system plików NTFS. Wartość parametru liczba może wynosić 2, 4, 8, 16, 32, 64 lub 128.
/autotest | Działanie dyskretne. Parametru tego nie należy używać razem z opcją /v.
/q | Wykonuje szybkie formatowanie.
/v:etykieta_dysku | Określa etykietę woluminu. Parametru tego nie należy używać razem z opcją /autotest.

Ważne

  • W razie niezastosowania opcji /q wykonanie polecenia Oformat zajmuje tyle samo czasu, co wykonanie polecenia Format.
  • Opcja wiersza polecenia /a:8 powoduje sformatowanie woluminu w taki sposób, że klastry danych FAT są wyrównane do całkowitej wielokrotności 4 kilobajtów. Ta konfiguracja jest zalecana, ponieważ zapewnia największą wydajność konwertowania na system plików NTFS.

Przykład

To polecenie formatuje wolumin na dysku E, zastępując sektor rozruchowy, tablicę FAT i folder główny czystymi strukturami na dysku twardym nowo podzielonym na partycje. Ponadto dysk jest optymalnie konfigurowany do konwersji na system plików NTFS.

oformat e: /q /autotest /a:8

Aby uzyskać więcej informacji, zobacz Opcje wiersza polecenia narzędzia Convert.

Dodatkowe opcje wiersza polecenia narzędzia Oformat

Narzędzie Oformat obsługuje dodatkowe opcje wiersza polecenia. Pełna składnia polecenia Oformat jest następująca:

oformat litera_dysku [/a:liczba] [/autotest|/v:etykieta_dysku] [/b | /s] [/c] [/f:rozmiar] [/q] [/t:liczba_ścieżek /n:liczba_sektorów] [/u] [/1] [/4] [/8]

Opcja | Akcja
/b | Przydziela na formatowanym dysku miejsce dla plików systemowych.
/c | Testuje klastry, które są aktualnie oznaczone jako klastry uszkodzone.
/f:rozmiar | Określa rozmiar dyskietki do sformatowania. Wartość parametru rozmiar może być równa 160, 180, 320, 360, 720, 1.2, 1.44 lub 2.88.
/n:liczba_sektorów | Określa liczbę sektorów na ścieżce.
/s | Kopiuje na sformatowany dysk pliki systemowe.
/t:liczba_ścieżek | Określa liczbę ścieżek na jednej stronie dysku.
/u | Nie zapisuje informacji o odzyskiwaniu, które mogłyby posłużyć do cofnięcia formatowania dysku.
/l | Formatuje jedną stronę dyskietki.
/4 | Formatuje dyskietkę 5,25 cala o pojemności 360 KB w stacji wysokiej gęstości.
/8 | Formatuje osiem sektorów na ścieżkę.

Różnice między narzędziami Oformat i Format

W odróżnieniu od narzędzia Format, narzędzie Oformat zawiera opcję nieweryfikowania integralności dysku lub zastępowania dotychczasowych danych w obszarze danych. W celu zachowania geometrii dysku, wartości bloku parametrów systemu BIOS (BPB, BIOS Parameter Block) oryginalnego sektora rozruchowego są wstawiane do nowego sektora rozruchowego. W przypadku partycji niesformatowanej, zamiast wartości z istniejącego sektora rozruchowego narzędzie Oformat używa wartości BPB obliczonych przez kod inicjujący systemu MS-DOS. Ta modyfikacja umożliwia funkcji szybkiego formatowania kontynuowanie działania, gdy sektor rozruchowy jest nieprawidłowy, co następuje bezpośrednio po podzieleniu dysku na partycje. Narzędzie Oformat pobiera parametry dysku bezpośrednio z systemu MS-DOS BIOS, który oblicza je na podstawie informacji o partycji, dzięki czemu sektor rozruchowy zapisywany ostatecznie na dysku przez narzędzie Oformat jest poprawny. Modyfikacje te umożliwiają sformatowanie dysku twardego o dowolnym rozmiarze w około pięć sekund, bez względu na to, czy dysk był już wcześniej sformatowany.

Narzędzie Oformat nie dokonuje weryfikacji dysku, co może przeszkodzić w wykryciu ewentualnych fizycznych błędów sektorów. Ryzyko takie należy ocenić na podstawie gwarancji bezbłędności uzyskanej od producenta dysku.


Opcje wiersza polecenia narzędzia Convert

Convert to narzędzie wiersza polecenia w systemie Windows XP i rodzinie systemów operacyjnych Windows Server 2003. Służy ono do konwertowania woluminów FAT i FAT32 na system plików NTFS. Woluminu NTFS nie można przekonwertować z powrotem na system plików FAT ani FAT32.

Składnia narzędzia Convert:

convert [wolumin] /fs:ntfs [/v] [/cvtarea:nazwa_pliku] [/nosecurity] [/x]

Opcja | Akcja
wolumin: Określa literę dysku (po której następuje dwukropek), punkt instalacji lub nazwę woluminu, który ma być przekonwertowany na system plików NTFS.
/fs:ntfs | Opcja wymagana. Konwertuje wolumin na system plików NTFS, pozostawiając istniejące pliki i foldery nienaruszone.
/v | Określa tryb pełny. Podczas konwersji będą wyświetlane wszystkie komunikaty.
/cvtarea:nazwa_pliku Określa, że główna tabela plików (MFT) oraz inne pliki metadanych NTFS będą zapisywane w istniejącym, ciągłym pliku zastępczym. Ten plik musi znajdować się w katalogu głównym konwertowanego systemu plików. Aby uzyskać najlepsze wyniki, rozmiar tego pliku musi być iloczynem wartości 1 KB oraz liczby plików i katalogów w systemie plików. Narzędzie Convert akceptuje jednak dowolny rozmiar pliku nie większy niż 4 GB, co stanowi ograniczenie identyczne jak w systemie FAT. Użycie parametru /cvtarea może spowodować zmniejszenie fragmentacji systemu plików po konwersji.

Aby uzyskać więcej informacji dotyczących używania parametru /cvtarea, zobacz:

  • Opcje wiersza polecenia narzędzia Cvtarea
  • NTFS Preinstallation and Windows XP (http://www.microsoft.com/whdc/)
  • „Converting Volumes to NTFS” w witrynie Microsoft TechNet

Ważne

  • Plik zastępczy musi zostać utworzony przy użyciu polecenia fsutil file createnew przed uruchomieniem narzędzia Convert. Narzędzie Convert nie tworzy tego pliku. Narzędzie Convert zastępuje ten plik metadanymi NTFS. Po zakończeniu konwersji całe nieużywane miejsce w tym pliku jest zwalniane. Aby uzyskać więcej informacji na temat polecenia fsutil file, zobacz Pomoc systemu Windows.
/nosecurity | Określa, że ustawienia zabezpieczeń konwertowanych plików i katalogów są dostępne dla wszystkich użytkowników.
/x | Powoduje odinstalowanie woluminu przed konwersją, jeśli to konieczne. Wszelkie otwarte dojścia do woluminu przestają być prawidłowe.

Uwagi

  • Aby narzędzie Convert działało tak samo, jak polecenie convert w systemie Windows 2000, należy użyć polecenia convert /nosecurity.
  • Aby przywrócić domyślne działanie z systemu Windows 2000 i automatycznie uruchomić narzędzie chkdsk po przekonwertowaniu woluminu systemowego, należy użyć tylko polecenia convert.

Komentarze

  • Jeśli narzędzie Convert nie może zablokować dysku, to proponuje jego konwersję przy następnym uruchomieniu komputera. Jeśli nie można natychmiast uruchomić ponownie komputera w celu ukończenia procesu konwersji, to należy zaplanować czas ponownego uruchomienia, biorąc pod uwagę, że będzie ono trwało dłużej z powodu procesu konwersji.
  • W przypadku woluminów, na których system plików został przekonwertowany z systemu FAT lub FAT32 na system NTFS, tabela MFT znajduje się w innym miejscu niż w przypadku woluminu od razu sformatowanego przy użyciu systemu plików NTFS. W celu zapewnienia optymalnej wydajności warto rozważyć ponowne utworzenie tych woluminów NTFS.
  • Woluminom przekonwertowanym z systemu FAT na system NTFS brakuje niektórych zalet związanych z wydajnością w porównaniu z woluminami od razu sformatowanymi w systemie NTFS. Na przekonwertowanych woluminach tabela MFT może zostać pofragmentowana. Ponadto w przypadku przekonwertowanych woluminów rozruchowych uprawnienia NTFS nie są stosowane po konwersji woluminu.
  • Wolumin przekonwertowany może być pofragmentowany i mieć mniejszą wydajność niż wolumin sformatowany przy użyciu systemu plików NTFS. Nadal jednak lepiej jest używać systemu plików NTFS, bez względu na to, czy wolumin został sformatowany przy użyciu systemu plików NTFS, czy przekonwertowany.

Przykład

Aby skonwertować wolumin na dysku E na system NTFS i wyświetlić wszystkie komunikaty, należy wpisać:

convert e: /fs:ntfs /v


Polecenia narzedzia DiskPart

Narzedzie DiskPart to interpreter polecen trybu tekstowego w systemie Windows XP i rodzinie Windows Server 2003. To narzedzie umozliwia zarzadzanie obiektami (dyskami, partycjami lub woluminami) za pomoca skryptów lub polecen wpisywanych bezposrednio w wierszu polecenia. Przed uzyciem polecen narzedzia DiskPart dla dysku, partycji lub woluminu trzeba wyswietlic liste obiektów, a nastepnie wybrac zadany obiekt, aby ustawic na nim fokus. Po ustawieniu fokusu na obiekcie wszystkie wpisywane polecenia narzedzia DiskPart dotycza tego obiektu.

W celu wyswietlenia listy dostepnych obiektów i okreslenia numeru lub litery dysku obiektu mozna uzyc polecen list disk, list volume i list partition. Polecenia list disk i list volume wyswietlaja wszystkie dyski i woluminy na komputerze. Natomiast polecenie list partition wyswietla jedynie partycje na dysku, który ma fokus. W przypadku korzystania z polecen list obok obiektu z fokusem pojawia sie gwiazdka (*). Obiekt mozna wybrac, korzystajac z numeru lub litery dysku, na przyklad dysk 0, partycja 1, wolumin 3 lub wolumin C.

Fokus pozostaje na wybranym obiekcie, dopóki nie zostanie wybrany inny obiekt. Jesli na przyklad fokus jest ustawiony na dysku 0, to w przypadku wybrania woluminu 8 na dysku 2 fokus zostanie przeniesiony z dysku 0 na wolumin 8 dysku 2. Niektóre polecenia powoduja automatyczne przeniesienie fokusu. Na przyklad po utworzeniu nowej partycji automatycznie otrzymuje ona fokus.

Fokus mozna ustawic tylko na partycji wybranego dysku. Jesli dana partycja ma fokus, odpowiedni wolumin (jesli taki istnieje) takze ma fokus. Jesli dany wolumin ma fokus, odpowiednia partycja takze ma fokus, jesli ten wolumin jest mapowany na jedna okreslona partycje. W przeciwnym wypadku dysk i partycja nie maja fokusu.

Wazne

  • W przypadku uzywania polecen narzedzia DiskPart w skryptach zaleca sie, aby wszystkie operacje narzedzia DiskPart wykonac razem jako czesc jednego skryptu narzedzia DiskPart. Mozna wykonac po kolei kilka skryptów narzedzia DiskPart, ale miedzy wykonaniem kazdego skryptu musi uplynac przynajmniej 15 sekund, zanim po zakonczeniu wykonywania jednego skryptu bedzie mozna uruchomic polecenie DiskPart w nastepnym skrypcie. W przeciwnym wypadku wykonanie nastepnego skryptu moze sie nie powiesc. Miedzy kolejnymi skryptami narzedzia DiskPart mozna dodac pauze, dodajac polecenie /t 15 do pliku wsadowego ze skryptami narzedzia DiskPart.

Aby uzyskac wiecej informacji o narzedziu DiskPart, zobacz Disk Management w witrynie zestawów Microsoft Windows Resource Kit w sieci Web.(http://www.microsoft.com/)

Polecenia narzedzia DiskPart

W ponizszej tabeli opisano skladnie i parametry polecen narzedzia DiskPart.

Polecenie | Skladnia | Opis
active active Na dyskach podstawowych oznacza partycje z fokusem jako aktywna. Informuje to podstawowy system wejscia/wyjscia (BIOS) lub rozszerzalny interfejs oprogramowania ukladowego (EFI), ze dana partycja lub wolumin to prawidlowa partycja systemowa lub prawidlowy wolumin systemowy.

Tylko partycje moga byc oznaczane jako aktywne.

Wazne

  • Narzedzie DiskPart sprawdza, czy tylko jedna partycja ma mozliwosc przechowywania plików startowych systemu operacyjnego. Narzedzie DiskPart nie sprawdza zawartosci tej partycji. W przypadku omylkowego oznaczenia jako „aktywnej” partycji, która nie zawiera plików startowych systemu operacyjnego, uruchomienie komputera moze byc niemozliwe.
add disk add disk=n [noerr] Dubluje wolumin prosty z fokusem na okreslonym dysku.
n
Okresla dysk, który ma zawierac zdublowany wolumin. Mozna dublowac tylko woluminy proste. Na okreslonym dysku musi byc przynajmniej tyle nieprzydzielonego miejsca, ile wynosi rozmiar dublowanego woluminu prostego.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
assign assign [{letter=d|mount=sciezka}] [noerr] Przypisuje woluminowi z fokusem litere dysku lub punkt instalacji. Jesli litera dysku lub punktu instalacji nie jest okreslony, przypisywana jest nastepna dostepna litera dysku. Jesli przypisana litera dysku lub punkt instalacji jest juz uzywany, wystepuje blad.

Za pomoca polecenia assign mozna zmienic litere dysku skojarzona z dyskiem wymiennym.

Nie mozna przypisywac liter dysków woluminom systemowym, woluminom rozruchowym ani woluminom zawierajacym plik stronicowania. Ponadto litery dysku nie mozna przypisac partycji OEM ani jakiejkolwiek partycji GPT innej niz podstawowa partycja danych.

letter=d
Litera dysku, która ma byc przypisana woluminowi.
mount=sciezka
Sciezka punktu instalacji, który ma byc przypisany woluminowi.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
automount automount [enable] [disable] [scrub] [noerr] Jesli parametr ma wartosc enable (wartosc domyslna), system Windows automatycznie instaluje system plików dla nowego woluminu podstawowego dodawanego do systemu, a nastepnie przypisuje mu litere dysku. W konfiguracjach sieci obszarów systemowych wylaczenie automatycznego instalowania uniemozliwia systemowi Windows automatyczne zainstalowanie nowych woluminów podstawowych dodanych do systemu lub przypisanie im litery dysku.
enable
Umozliwia systemowi Windows automatyczne instalowanie nowych woluminów podstawowych dodawanych do systemu i przypisywanie im litery dysku.
disable
Uniemozliwia systemowi Windows automatyczne instalowanie nowych woluminów podstawowych dodawanych do systemu.
scrub
Usuwa katalogi punktu instalacji woluminu oraz ustawienia rejestru dla woluminów, których nie ma juz w systemie. To uniemozliwia automatyczna instalacje (w poprzednich punktach instalacji) woluminów, które byly wczesniej w systemie, gdy zostana z powrotem dodane do systemu.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
break disk break disk=n [nokeep] [noerr] Ma zastosowanie tylko w przypadku dysków dynamicznych. Dzieli wolumin dublowany z fokusem na dwa woluminy proste. Jeden wolumin prosty zachowuje litere dysku i wszystkie punkty instalacji woluminu dublowanego, natomiast drugi wolumin prosty otrzymuje fokus, co pozwala przypisac temu woluminowi litere dysku.

Domyslnie zachowywana jest zawartosc obu polówek woluminu dublowanego; kazda polowa staje sie woluminem prostym. W przypadku uzycia parametru nokeep tylko polowa woluminu dublowanego jest zachowywana jako wolumin prosty, natomiast druga polowa jest usuwana i konwertowana na wolne miejsce. Zaden z woluminów nie otrzymuje fokusu.

n
Okresla dysk zawierajacy wolumin dublowany.
nokeep
Okresla, ze ma byc zachowany tylko jeden z woluminów dublowanych; drugi wolumin prosty jest usuwany i konwertowany na wolne miejsce. Zaden z woluminów nie otrzymuje fokusu.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
clean clean [all] Usuwa cale formatowanie partycji lub woluminu z dysku z fokusem. Na dyskach z glównym rekordem rozruchowym (MBR) zastepowane sa tylko informacje dotyczace partycji MBR i sektorów ukrytych. W przypadku dysków z tabela partycji GUID (GPT) informacje o partycjach GPT, z ochronnym rekordem MBR wlacznie, sa zastepowane; nie ma informacji o sektorach ukrytych.
all
Okresla, ze maja byc wyzerowane wszystkie sektory na dysku, co powoduje calkowite usuniecie wszystkich danych znajdujacych sie na dysku.
convert basic convert basic [noerr] Konwertuje pusty dysk dynamiczny na dysk podstawowy.

Wazne

  • Aby dysk mozna bylo przekonwertowac na dysk podstawowy, musi on byc pusty. Nalezy wykonac kopie zapasowa danych, a nastepnie, przed rozpoczeciem konwertowania dysku, usunac wszystkie partycje lub woluminy.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
convert dynamic convert dynamic [noerr] Konwertuje dysk podstawowy na dysk dynamiczny. Wszelkie partycje istniejace na dysku staja sie woluminami prostymi.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
convert gpt convert gpt [noerr] Na komputerach z procesorem Itanium konwertuje pusty dysk podstawowy z glównym rekordem rozruchowym (MBR) na dysk podstawowy z tabela partycji GUID (GPT).

Wazne

  • Aby dysk mozna bylo przekonwertowac na dysk GPT, musi on byc pusty. Nalezy wykonac kopie zapasowa danych, a nastepnie, przed rozpoczeciem konwertowania dysku, usunac wszystkie partycje lub woluminy.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
convert mbr convert mbr [noerr] Na komputerach z procesorem Itanium konwertuje pusty dysk podstawowy z tabela partycji GUID (GPT) na dysk podstawowy z glównym rekordem rozruchowym (MBR).

Wazne

  • Aby dysk mozna bylo przekonwertowac na dysk MBR, musi on byc pusty. Nalezy wykonac kopie zapasowa danych, a nastepnie, przed rozpoczeciem konwertowania dysku, usunac wszystkie partycje lub woluminy.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
create partition efi create partition efi [size=n] [offset=n] [noerr] Na komputerach z procesorem Itanium tworzy partycje systemowa EFI na dysku z tabela partycji GUID (GPT). Po utworzeniu nowej partycji otrzymuje ona fokus.
size=n
Okresla rozmiar partycji w megabajtach (MB). Jesli rozmiar nie zostanie okreslony, partycja jest tworzona do wyczerpania wolnego miejsca w biezacym regionie.
offset=n
Okresla przesuniecie w bajtach, od którego ma sie rozpoczac tworzenie partycji. Jesli przesuniecie nie zostanie okreslone, partycja jest umieszczana w pierwszym ciaglym obszarze dysku o odpowiedniej wielkosci.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
create partition extended create partition extended [size=n] [offset=n] [noerr] Tworzy partycje rozszerzona na biezacym dysku. Po utworzeniu nowej partycji automatycznie otrzymuje ona fokus. Na jednym dysku mozna utworzyc tylko jedna partycje rozszerzona. To polecenie nie dziala w przypadku próby utworzenia partycji rozszerzonej w innej partycji rozszerzonej. Przed utworzeniem dysków logicznych trzeba utworzyc partycje rozszerzona.
size=n
Okresla rozmiar partycji rozszerzonej w megabajtach (MB). Jesli rozmiar nie zostanie okreslony, partycja jest tworzona do wyczerpania wolnego miejsca w danym regionie. Rozmiar jest zaokraglany do najblizszej calkowitej wielokrotnosci rozmiaru cylindra. Jesli na przyklad zostanie okreslona wartosc 500 MB, rozmiar partycji zostanie zaokraglony w góre do 504 MB.
offset=n
Dotyczy tylko dysków z glównym sektorem rozruchowym (MBR). Okresla przesuniecie w bajtach, od którego ma sie rozpoczac tworzenie partycji rozszerzonej. Jesli przesuniecie nie zostanie okreslone, partycja rozpoczyna sie od poczatku pierwszego wolnego obszaru na dysku. Przesuniecie jest zaokraglane do najblizszej calkowitej wielokrotnosci rozmiaru cylindra. Jesli na przyklad zostanie okreslona wartosc przesuniecia 27 MB, a rozmiar cylindra wynosi 8 MB, to przesuniecie zostanie zaokraglone do 24 MB.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
create partition logical create partition logical [size=n] [offset=n] [noerr] Tworzy dysk logiczny na partycji rozszerzonej. Po utworzeniu partycji fokus jest automatycznie przenoszony na nowy dysk logiczny.
size=n
Rozmiar dysku logicznego w megabajtach (MB). Jesli rozmiar nie zostanie okreslony, partycja jest tworzona do wyczerpania wolnego miejsca w biezacym regionie.
offset=n
Dotyczy tylko dysków z glównym sektorem rozruchowym (MBR). Okresla przesuniecie w bajtach, od którego ma sie rozpoczac tworzenie dysku logicznego. Przesuniecie jest zaokraglane w góre do najblizszej calkowitej wielokrotnosci rozmiaru cylindra. Jesli przesuniecie nie zostanie okreslone, partycja jest umieszczana w pierwszym ciaglym obszarze dysku o odpowiedniej wielkosci. Partycja jest co najmniej tak duza (w bajtach), jak liczba okreslona przez parametr size=n. W przypadku okreslenia rozmiaru dysku logicznego musi on byc mniejszy niz rozmiar partycji rozszerzonej.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
create partition msr create partition msr [size=n] [offset=n] [noerr] Na komputerach z procesorem Itanium tworzy partycje MSR (Microsoft Reserved) na dysku z tabela partycji GUID (GPT).

Przestroga

  • Uzywajac polecenia create partition msr, nalezy zachowac ostroznosc. Dyski GPT wymagaja okreslonego ukladu partycji, tak wiec utworzenie partycji Microsoft Reserved moze spowodowac, ze dysku nie bedzie mozna odczytac. Na dyskach GPT, które sa uzywane do uruchamiania systemu Windows XP 64-Bit Edition lub 64-bitowych wersji systemów operacyjnych z rodziny Windows Server 2003, partycja systemowa EFI jest pierwsza partycja na dysku, a po niej nastepuje partycja Microsoft Reserved. Dyski GPT uzywane wylacznie do przechowywania danych nie maja partycji systemowej EFI; w ich przypadku pierwsza partycja jest partycja Microsoft Reserved.

    W systemie Windows XP i systemach operacyjnych z rodziny Windows Server 2003 partycja Microsoft Reserved nie jest instalowana. Tych partycji nie mozna uzywac do przechowywania danych ani nie mozna ich usuwac.

size=n
Okresla rozmiar partycji w megabajtach (MB). Partycja jest co najmniej tak duza (w bajtach), jak liczba okreslona przez parametr size=n. Jesli rozmiar nie zostanie okreslony, partycja jest tworzona do wyczerpania wolnego miejsca w biezacym regionie.
offset=n
Okresla przesuniecie w bajtach, od którego ma sie rozpoczac tworzenie partycji. Partycja rozpoczyna sie od przesuniecia okreslonego przez parametr offset=n. Przesuniecie jest zaokraglane w góre do najblizszej calkowitej wielokrotnosci rozmiaru sektora. Jesli przesuniecie nie zostanie okreslone, partycja jest umieszczana w pierwszym ciaglym obszarze dysku o odpowiedniej wielkosci.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
create partition primary create partition primary [size=n] [offset=n] [ID={bajt|identyfikator_GUID}] [noerr] Tworzy partycje podstawowa na biezacym dysku podstawowym. Po utworzeniu nowej partycji automatycznie otrzymuje ona fokus. Partycja nie otrzymuje nowej litery dysku; aby przypisac jej litere dysku, nalezy uzyc polecenia assign.
size=n
Okresla rozmiar partycji w megabajtach (MB). Jesli rozmiar nie zostanie okreslony, partycja jest tworzona do wyczerpania wolnego miejsca w biezacym regionie. Rozmiar jest zaokraglany do najblizszej calkowitej wielokrotnosci rozmiaru cylindra. Jesli na przyklad zostanie okreslona wartosc 500 MB, rozmiar partycji zostanie zaokraglony w góre do 504 MB.
offset=n
Okresla przesuniecie w bajtach, od którego ma sie rozpoczac tworzenie partycji. Jesli przesuniecie nie zostanie okreslone, partycja rozpoczyna sie od poczatku pierwszego wolnego obszaru na dysku. W przypadku dysków z glównym rekordem rozruchowym (MBR) przesuniecie jest zaokraglane do najblizszej calkowitej wielokrotnosci rozmiaru cylindra. Jesli na przyklad zostanie okreslona wartosc przesuniecia 27 MB, a rozmiar cylindra wynosi 8 MB, to przesuniecie zostanie zaokraglone do 24 MB.
ID={bajt|GUID}
Jedynie do wykorzystania przez producenta OEM.

Przestroga

  • Utworzenie partycji z tym parametrem moze spowodowac awarie komputera lub uniemozliwic jego uruchomienie. Poza producentami OEM i specjalistami IT z dobra znajomoscia dysków GPT nikt nie powinien tworzyc partycji na dyskach GPT przy uzyciu parametru ID=bajt | GUID. W przypadku dysków GPT nalezy natomiast uzywac polecenia create partition efi do tworzenia partycji systemowych EFI, polecenia create partition msr do tworzenia partycji Microsoft Reserved oraz polecenia create partition primary (bez parametru ID=bajt | GUID) do tworzenia partycji podstawowych.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.

Komentarze

Aby podzielic na partycje dysk GPT i utworzyc partycje OEM

  1. Wygeneruj identyfikator GUID producenta OEM.
  2. Utwórz partycje EFI za pomoca nastepujacego polecenia:
    Create partition efi size=n
  3. Utwórz partycje podstawowa za pomoca nastepujacego polecenia:
    Create partition primary size=n ID={bajt|GUID}
  4. Utwórz partycje MSR za pomoca nastepujacego polecenia:
    Create partition MSR size=n

Wazne

  • Partycje OEM trzeba utworzyc miedzy partycjami EFI i MSR.
  • Nigdy nie nalezy tworzyc partycji metadanych LDM ani danych LDM jawnie jako partycji. Zamiast tego nalezy przekonwertowac dysk na dysk dynamiczny.

W przypadku dysków z glównym sektorem rozruchowym (MBR) mozna okreslic bajt typu partycji w formacie szesnastkowym. Jesli bajt typu partycji nie zostanie okreslony, to polecenie create partition primary tworzy partycje typu 0x6. Za pomoca parametru ID=bajt | GUID mozna okreslic dowolny bajt typu partycji. Narzedzie DiskPart nie sprawdza poprawnosci bajtu typu partycji ani w zaden inny sposób nie sprawdza parametru identyfikatora.

W przypadku dysków GPT mozna okreslic identyfikator GUID typu tworzonej partycji:

  • Partycja systemowa EFI: c12a7328-f81f-11d2-ba4b-00a0c93ec93b
  • Partycja MSR: e3c9e316-0b5c-4db8-817d-f92df00215ae
  • Podstawowa partycja danych: ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
  • Partycja metadanych LDM na dysku dynamicznym: 5808c8aa-7e8f-42e0-85d2-e1e90434cfb3
  • Partycja danych LDM na dysku dynamicznym: af9b60a0-1431-4f62-bc68-3311714a69ad

Jesli nie zostanie okreslony identyfikator GUID typu partycji, polecenie create partition primary tworzy podstawowa partycje danych. Za pomoca parametru ID=bajt | GUID mozna okreslic dowolny typ partycji. Narzedzie DiskPart nie sprawdza poprawnosci identyfikatora GUID partycji ani w zaden inny sposób nie sprawdza parametru identyfikatora.
create volume raid create volume raid [size=n] [disk=n,n,n[,n,…]] [noerr] Tworzy wolumin RAID-5 na co najmniej trzech okreslonych dyskach dynamicznych. Po utworzeniu nowego woluminu automatycznie otrzymuje on fokus.
size=n
Okresla w megabajtach (MB) ilosc miejsca, jaka zajmuje wolumin na kazdym dysku. Jesli rozmiar nie zostanie okreslony, tworzony jest wolumin RAID-5 o najwiekszym mozliwym rozmiarze. Rozmiar woluminu RAID-5 jest okreslony przez dysk z najmniejsza dostepna, ciagla iloscia wolnego miejsca; taka sama ilosc miejsca jest przydzielana na kazdym dysku. Rzeczywista ilosc miejsca na woluminie RAID-5, która moze zostac wykorzystana, jest mniejsza niz suma miejsca na dyskach, poniewaz czesc tego miejsca jest przeznaczana na kontrole parzystosci.
disk=n,n,n[,n,…]
Okresla dyski dynamiczne, na których ma byc utworzony wolumin. Do utworzenia woluminu RAID-5 sa potrzebne przynajmniej trzy dyski dynamiczne. Na kazdym dysku jest przydzielana ilosc miejsca okreslona przez parametr size=n.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
create volume simple create volume simple [size=n] [disk=n] [noerr] Tworzy wolumin prosty. Po utworzeniu nowego woluminu automatycznie otrzymuje on fokus.
size=n
Okresla rozmiar woluminu w megabajtach (MB). Jesli rozmiar nie zostanie okreslony, nowy wolumin zajmuje pozostale wolne miejsce na dysku.
disk=n
Okresla dysk dynamiczny, na którym ma byc utworzony wolumin. Jesli dysk nie zostanie okreslony, zostaje uzyty dysk biezacy.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
create volume stripe create volume stripe [size=n] [disk=n,n[,n,…]] [noerr] Tworzy wolumin rozlozony przy uzyciu co najmniej dwóch okreslonych dysków dynamicznych. Po utworzeniu nowego woluminu automatycznie otrzymuje on fokus.
size=n
Okresla w megabajtach (MB) ilosc miejsca, jaka zajmuje wolumin na kazdym dysku. Jesli rozmiar nie zostanie okreslony, nowy wolumin zajmuje pozostale wolne miejsce na najmniejszym dysku i taka sama ilosc miejsca na kazdym nastepnym dysku.
disk=n,n[,n,…]
Okresla dyski dynamiczne, na których ma byc utworzony wolumin. Do utworzenia woluminu rozlozonego sa potrzebne przynajmniej dwa dyski dynamiczne. Na kazdym dysku jest przydzielana ilosc miejsca okreslona przez parametr size=n.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
delete disk delete disk [noerr] [override] Usuwa brakujacy dysk dynamiczny z listy dysków.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
override
Umozliwia narzedziu DiskPart usuniecie z dysku wszystkich woluminów prostych. Jesli dysk zawiera polowe woluminu dublowanego, jest ona usuwana. Polecenie delete disk override nie dziala, jesli dysk jest elementem woluminu RAID-5.
delete partition delete partition [noerr] [override] Usuwa partycje z fokusem z dysku podstawowego. Nie mozna usunac partycji systemowej, partycji rozruchowej ani zadnej partycji zawierajacej aktywny plik stronicowania lub zrzut awaryjny (zrzut pamieci).

Przestroga

  • Usuniecie partycji z dysku dynamicznego moze spowodowac usuniecie wszystkich woluminów dynamicznych z tego dysku, co oznaczaloby zniszczenie wszystkich danych i pozostawienie dysku w stanie uszkodzenia. Aby usunac wolumin dynamiczny, nalezy zawsze uzywac polecenia delete volume.

Partycje z dysków dynamicznych mozna usuwac, ale nie wolno ich tworzyc. Mozna na przyklad usunac nierozpoznana partycje tabeli partycji GUID (GPT) z dysku dynamicznego GPT. Jednak usuniecie takiej partycji nie spowoduje, ze powstale w ten sposób wolne miejsce stanie sie dostepne. To polecenie ma na celu umozliwienie odzyskania miejsca na uszkodzonych dyskach dynamicznych offline w sytuacjach awaryjnych, gdy nie mozna uzyc polecenia clean.

noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
override
Umozliwia narzedziu DiskPart usuniecie dowolnej partycji, niezaleznie od typu. Normalnie narzedzie DiskPart zezwala tylko na usuwanie znanych partycji danych.
delete volume delete volume [noerr] Usuwa wybrany wolumin. Nie mozna usunac woluminu systemowego, woluminu rozruchowego ani woluminu zawierajacego aktywny plik stronicowania lub zrzut awaryjny (zrzut pamieci).
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
detail disk | detail disk | Wyswietla wlasciwosci wybranego dysku oraz znajdujace sie na nim woluminy.
detail partition | detail partition | Wyswietla wlasciwosci wybranej partycji.
detail volume | detail volume | Wyswietla dyski, na których znajduje sie biezacy wolumin.
exit | exit | Zamyka interpreter polecen DiskPart.
extend extend [size=n] [disk=n] [noerr] Rozszerza wolumin z fokusem na nastepny ciagly, nieprzydzielony obszar. W przypadku woluminów podstawowych nieprzydzielony obszar musi znajdowac sie na tym samym dysku, za partycja z fokusem (jego przesuniecie wyrazone liczba sektorów musi byc wieksze niz przesuniecie tej partycji). Dynamiczny wolumin prosty lub laczony mozna rozszerzyc na pusty obszar na dowolnym dysku dynamicznym. Za pomoca tego polecenia mozna rozszerzyc istniejacy wolumin na nowo utworzone miejsce.

Jesli partycja zostanie wczesniej sformatowana przy uzyciu systemu plików NTFS, system plików zostaje automatycznie tak rozszerzony, aby obejmowal wieksza partycje. Zadne dane nie sa tracone. Jesli partycja zostanie wczesniej sformatowana przy uzyciu systemu plików innego niz NTFS, to polecenie nie dziala i partycja nie ulega zadnej zmianie.

Nie mozna rozszerzyc biezacej partycji systemowej ani rozruchowej.

size=n
Okresla w megabajtach (MB) ilosc miejsca, jaka ma byc dodana do biezacej partycji. Jesli rozmiar nie zostanie okreslony, dysk zostaje rozszerzony na caly nastepny ciagly, nieprzydzielony obszar.
disk=n
Okresla dysk dynamiczny, na którym ma byc rozszerzony wolumin. Na dysku jest przydzielana ilosc miejsca okreslona przez parametr size=n. Jesli dysk nie zostanie okreslony, wolumin jest rozszerzany na dysku biezacym.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
gpt attributes gpt attributes= n Na podstawowych dyskach GPT przypisuje atrybut(y) GPT partycji, która ma fokus. Atrybuty partycji GPT zawieraja dodatkowe informacje o partycji. Niektóre atrybuty sa charakterystyczne dla identyfikatora GUID typu partycji.

Wazne

  • Zmiana atrybutów GPT moze uniemozliwic instalowanie podstawowych woluminów danych lub przypisanie im liter dysku. Atrybuty GPT powinni zmieniac jedynie producenci OEM lub specjalisci z branzy informatycznej majacy doswiadczenie z dyskami GPT.
n
Liczba szesnastkowa odnoszaca sie do atrybutu, który ma byc zastosowany do partycji, która ma fokus. Pole atrybutu GPT to pole 64-bitowe zawierajace dwa pola podrzedne. Wyzsze pole jest interpretowane jedynie w kontekscie identyfikatora partycji, natomiast nizsze pole jest wspólne dla wszystkich identyfikatorów partycji.

Wszystkie partycje maja nastepujacy atrybut:

0x000000000000001 oznacza, ze partycja jest wymagana. Dla wszystkich narzedzi dyskowych oznacza to, ze partycji nie nalezy usuwac. Partycja systemowa EFI zawiera jedynie te binaria, które sa niezbedne do uruchomienia systemu operacyjnego. Dzieki temu binaria charakterystyczne dla producenta OEM lub systemu operacyjnego w prosty sposób mozna umiescic na innych partycjach.

Dla podstawowych partycji danych jest zdefiniowany nastepujacy atrybut:

0x8000000000000000 uniemozliwia automatyczne przypisanie partycji litery dysku. Domyslnie kazda partycja ma przypisywana nowa litere dysku. Ustawienie tego atrybutu gwarantuje, ze po przeniesieniu dysku do nowego komputera nowa litera dysku nie zostanie automatycznie przypisana. Zamiast tego uzytkownik bedzie mógl recznie przypisac litery dysku.

Uwaga

  • Inne atrybuty mozna dodac w dowolnym momencie.
help | help | Wyswietla liste dostepnych polecen.
import import [noerr] Importuje obca grupe dysków do grupy dysków komputera lokalnego. Polecenie import importuje kazdy dysk wchodzacy w sklad grupy, do której nalezy dysk z fokusem.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
inactive inactive Na dyskach podstawowych z glównym rekordem rozruchowym (MBR) oznacza partycje systemowa lub partycje rozruchowa z fokusem jako nieaktywna. Do ponownego uruchomienia komputera zostanie uzyta nastepna opcja okreslona w systemie BIOS, na przyklad stacja CD-ROM lub srodowisko rozruchowe Pre-Boot eXecution Environment (PXE) (takie jak uslugi instalacji zdalnej (RIS)).

Przestroga

  • Bez partycji aktywnej uruchomienie komputera moze byc niemozliwe. Bez odpowiedniego doswiadczenia i wiedzy na temat rodziny systemów Windows Server 2003 nie nalezy oznaczac partycji systemowej ani rozruchowej jako nieaktywnej.

    Jesli po oznaczeniu partycji systemowej lub rozruchowej jako nieaktywnej nie mozna uruchomic komputera, nalezy wlozyc do stacji CD-ROM instalacyjny dysk CD i podjac próbe naprawienia partycji za pomoca polecen Fixmbr i Fixboot w konsoli odzyskiwania.
list disk | list disk | Wyswietla liste dysków i dotyczace ich informacje, takie jak rozmiar, ilosc dostepnego wolnego miejsca, typ dysku (podstawowy czy dynamiczny) i styl partycji (glówny rekord rozruchowy (MBR) lub tabela partycji GUID (GPT)). Dysk oznaczony gwiazdka (*) ma fokus.
list partition | list partition | Wyswietla liste partycji z tabeli partycji biezacego dysku. W przypadku dysków dynamicznych partycje moga nie odpowiadac woluminom dynamicznym znajdujacym sie na dysku. Ta rozbieznosc wynika z tego, ze dyski dynamiczne zawieraja w tabeli partycji wpisy dla woluminu systemowego lub woluminu rozruchowego (jesli jest obecny na dysku). Dyski dynamiczne zawieraja równiez partycje, która zajmuje pozostala czesc dysku. Jest ona zarezerwowana do wykorzystania przez woluminy dynamiczne.
list volume | list volume | Wyswietla liste woluminów podstawowych i dynamicznych na wszystkich dyskach.
online online [noerr] Przelacza dysk lub wolumin z fokusem z trybu offline do trybu online. Ponownie synchronizuje majacy fokus wolumin dublowany lub wolumin RAID-5.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
rem rem Umozliwia dodanie komentarzy do skryptu. Na przyklad:
rem Te polecenia konfiguruja 3 dyski.
create partition primary size=2048
assign d:
create partition extend
create partition logical size=2048
assign e:
create partition logical
assign f:
remove remove [{letter=d|mount=sciezka|[all]}] [dismount][noerr] Usuwa litere dysku lub punkt instalacji z woluminu z fokusem. W przypadku uzycia parametru all zostaja usuniete wszystkie biezace litery dysków i punkty instalacji. Jesli nie zostanie okreslona litera dysku ani punkt instalacji, narzedzie DiskPart usuwa pierwsza napotkana litere dysku lub punkt instalacji.

Do zmiany litery dysku skojarzonej z dyskiem wymiennym mozna uzyc polecenia remove. Nie mozna usuwac liter dysków woluminów systemowych, woluminów rozruchowych ani woluminów stronicowania. Ponadto nie mozna usunac litery dysku partycji OEM, dowolnej partycji GPT z nierozpoznanym identyfikatorem GUID ani zadnej specjalnej, niebedacej partycja danych partycji GPT, takiej jak partycja systemowa EFI.

letter=d
Litera dysku, który ma byc usuniety.
mount=sciezka
Sciezka punktu instalacji, który ma byc usuniety.
all
Usuwa wszystkie litery dysków i punkty instalacji.
dismount
Odinstalowuje wolumin podstawowy, gdy wszystkie litery dysku oraz punkty instalacji zostana usuniete z woluminu i przelacza wolumin podstawowy do trybu offline, przez co woluminu nie bedzie mozna zainstalowac. Jesli inne procesy uzywaja woluminu, narzedzie DiskPart zamyka wszelkie otwarte dojscia przed odinstalowaniem woluminu. Mozna umozliwic instalowanie woluminu, przypisujac mu litere dysku lub tworzac dla niego punkt instalacji. Próba odinstalowania nie powiedzie sie, jesli zostanie wykonana na woluminie majacym przypisane litery dysku lub punkty instalacji. W wypadku uzywania skryptów zaleca sie stosowania polecenia remove all dismount.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
repair disk repair disk=n [noerr] Naprawia majacy fokus wolumin RAID-5, zastepujac uszkodzony element woluminu RAID-5 okreslonym dyskiem dynamicznym. Ilosc wolnego miejsca na dysku dynamicznym musi byc przynajmniej równa calkowitemu rozmiarowi uszkodzonego elementu woluminu RAID-5.
n
Okresla dysk dynamiczny, który ma zastapic uszkodzony element woluminu RAID-5. Ilosc wolnego miejsca na tym dysku musi byc przynajmniej równa calkowitemu rozmiarowi uszkodzonego elementu woluminu RAID-5.
noerr
Dotyczy tylko skryptów. Powoduje, ze po napotkaniu bledu narzedzie DiskPart kontynuuje przetwarzanie polecen, tak jakby blad nie wystapil. W przypadku braku parametru noerr blad powoduje zakonczenie pracy narzedzia DiskPart i zwrócenie kodu bledu.
rescan | rescan | Lokalizuje nowe dyski, które mogly zostac dodane do komputera.
retain retain Przygotowuje istniejacy dynamiczny wolumin prosty do uzycia jako wolumin rozruchowy lub systemowy.

Na komputerze z procesorem x86 tworzy wpis partycji w glównym rekordzie rozruchowym (MBR) na dynamicznym woluminie prostym z fokusem. Aby utworzyc partycje MBR, poczatek dynamicznego woluminu prostego musi pokrywac sie z poczatkiem cylindra, a rozmiar tego woluminu musi byc calkowita wielokrotnoscia rozmiaru cylindra.

Na komputerze z procesorem Itanium tworzy wpis partycji w tabeli partycji GUID (GPT) na dynamicznym woluminie prostym z fokusem.

Uwaga

  • Polecenie retain jest przeznaczone do uzycia tylko podczas instalacji nienadzorowanej lub przez producentów OEM.
select disk select disk=[n] Wybiera okreslony dysk i przenosi na niego fokus.
n
Okresla numer dysku, na który ma byc przeniesiony fokus. Jesli numer dysku nie zostanie okreslony, polecenie select wyswietla dysk, który aktualnie ma fokus. Za pomoca polecenia list disk mozna wyswietlic numery wszystkich dysków w komputerze.
select partition select partition=[{n|d}] Wybiera okreslona partycje i przenosi na nia fokus. Jesli partycja nie zostanie okreslona, polecenie select wyswietla partycje, która aktualnie ma fokus. Za pomoca polecenia list partition mozna wyswietlic numery wszystkich partycji na biezacym dysku.
n
Okresla numer partycji, na która ma byc przeniesiony fokus.
d
Okresla litere dysku lub sciezke punktu instalacji partycji, na która ma byc przeniesiony fokus.
select volume select volume=[{n|d}] Wybiera okreslony wolumin i przenosi na niego fokus. Jesli wolumin nie zostanie okreslony, polecenie select wyswietla wolumin, który aktualnie ma fokus. Wolumin mozna okreslic przy uzyciu numeru, litery dysku lub sciezki punktu instalacji. Wybranie woluminu na dysku podstawowym powoduje przeniesienie fokusu na odpowiednia partycje. Za pomoca polecenia list volume mozna wyswietlic numery wszystkich woluminów na komputerze.
n
Okresla numer woluminu, na który ma byc przeniesiony fokus.
d
Okresla litere dysku lub sciezke punktu instalacji woluminu, na który ma byc przeniesiony fokus.

Aby uzyskac wiecej informacji, zobacz Skrypty narzedzia DiskPart.


Skrypty narzędzia DiskPart

Za pomocą narzędzia wiersza polecenia DiskPart można utworzyć skrypty automatyzujące zadania związane z dyskami, na przykład tworzenie woluminów lub konwertowanie dysków na dyski dynamiczne. Realizacja tych zadań za pomocą skryptów jest szczególnie pomocna w przypadkach, gdy system Windows jest rozmieszczany w trybie instalacji nienadzorowanej lub za pomocą narzędzia Sysprep, które nie obsługują tworzenia innych woluminów niż wolumin rozruchowy.

Aby uzyskać więcej informacji na temat skryptów narzędzia DiskPart, zobacz temat „Zarządzanie dyskami” w zestawie Microsoft Windows XP Professional Resource Kit.

Aby uruchomić skrypt narzędzia DiskPart, w wierszu polecenia wpisz:

DiskPart /S nazwa_skryptu.txt

gdzie nazwa_skryptu.txt to nazwa pliku tekstowego zawierającego skrypt.

Aby przekierować dane wyjściowe skryptu narzędzia DiskPart do pliku, wpisz:

DiskPart /S nazwa_skryptu.txt > plik_dziennika.txt

gdzie plik_dziennika.txt to nazwa pliku tekstowego, do którego program DiskPart zapisuje dane wyjściowe.

Po uruchomieniu narzędzia DiskPart w wierszu polecenia wyświetlana jest wersja narzędzia DiskPart i nazwa komputera. Domyślnie, gdy narzędzie DiskPart napotka błąd podczas próby wykonania zadania ze skryptu, wówczas zatrzymuje przetwarzanie skryptu i wyświetla kod błędu (jeśli nie określono parametru noerr). Program DiskPart zawsze jednak zwraca błędy w razie napotkania błędów składni, bez względu na to, czy użyty został parametr noerr. Parametr noerr umożliwia wykonywanie przydatnych zadań, takich jak usuwanie wszystkich partycji na wszystkich dyskach za pomocą jednego skryptu, niezależnie od całkowitej liczby dysków.

Poniższa tabela zawiera listę kodów błędów narzędzia DiskPart:

Błąd | Opis
0 | Błędy nie wystąpiły. Cały skrypt wykonano bez błędów.
1 | Wystąpił krytyczny wyjątek. Może to oznaczać poważny problem.
2 | Parametry określone dla polecenia DiskPart są niepoprawne.
3 | Narzędzie DiskPart nie mogło otworzyć określonego skryptu lub pliku wyjściowego.
4 | Z jednej z usług używanych przez narzędzie DiskPart został zwrócony błąd.
5 | Wystąpił błąd składni polecenia. Wykonanie skryptu nie powiodło się, ponieważ wybrano nieprawidłowy obiekt lub danego obiektu nie można używać z tym poleceniem.


Opcje wiersza polecenia programu Winnt32.exe

Używając programu Winnt32.exe w wierszu polecenia, można uruchomić Instalatora systemu Windows na komputerze, na którym działa jeden z następujących systemów operacyjnych:

  • Windows Server 2003
  • Windows XP
  • Windows 2000
  • Windows NT z dodatkiem Service Pack 5 lub nowszym
  • Windows Millennium Edition
  • Windows 98
  • Windows 95

Uwagi

  • W przypadku wdrażania systemu Windows XP na komputerach klienckich należy użyć wersji programu Winnt32.exe zawartej w systemie Windows XP. Innym sposobem wdrożenia systemu Windows XP jest użycie pliku Winnt32.msi, który korzysta z Instalatora Microsoft® Windows® należącego do zestawu technologii IntelliMirror. Aby uzyskać więcej informacji o wdrażaniu klientów, zobacz zestaw Windows Server 2003 Deployment Kit.
  • Na komputerze z procesorem Itanium można uruchomić polecenie winnt32, korzystając z rozszerzalnego interfejsu oprogramowania układowego (EFI) lub z systemu Windows XP (ale nie ze starszego systemu operacyjnego). Ponadto na komputerze z procesorem Itanium są niedostępne opcje /cmdcons i /syspart oraz opcje związane z uaktualnieniami.

Składnia polecenia Winnt32 jest następująca:

winnt32 [/checkupgradeonly] [/cmd:wiersz_polecenia] [/cmdcons] [/copydir:{i386|ia64}\nazwa_folderu] [/copysource:nazwa_folderu] [/debug[poziom]:[nazwa_pliku]] [/dudisable] [/duprepare:nazwa_ścieżki] [/dushare:nazwa_ścieżki] [/emsport:{com1|com2|usebiossettings|off}] [/emsbaudrate:szybkość_transmisji] [/m:nazwa_folderu] [/makelocalsource] [/noreboot] [/s:ścieżka_źródłowa] [/syspart:litera_dysku:] [/tempdrive:litera_dysku:] [/udf:id [,plik_UDB]] [/unattend[numer]:[plik_odpowiedzi]]

gdzie:

Opcja | Akcja
/checkupgradeonly Sprawdza możliwość uaktualnienia komputera do danej wersji systemu Windows.

W przypadku użycia tej opcji z parametrem /unattend nie jest konieczna interwencja użytkownika. W przeciwnym wypadku wyniki są wyświetlane i można je zapisać, określając nazwę pliku. Domyślna nazwa pliku to Upgrade.txt w folderze %SYSTEMROOT%.
/cmd:wiersz_polecenia | Instruuje Instalatora, aby wykonał określone polecenie przed końcową fazą instalacji. Następuje to po ponownym uruchomieniu komputera i zebraniu przez Instalatora niezbędnych informacji konfiguracyjnych, ale przed zakończeniem instalacji.
/cmdcons | Instaluje konsolę odzyskiwania jako opcję startową na działającym komputerze z procesorem x86. Konsola odzyskiwania jest interfejsem wiersza polecenia, z którego można wykonywać takie zadania, jak uruchamianie i zatrzymywanie usług oraz uzyskiwanie dostępu do dysku lokalnego (w tym dysków sformatowanych w systemie plików NTFS). Opcji /cmdcons można użyć dopiero po zakończeniu pracy Instalatora.
/copydir:{i386|ia64}\nazwa_folderu Tworzy jeden lub więcej folderów wewnątrz folderu, w którym są instalowane pliki systemu Windows.

Nazwa_folderu dotyczy folderu utworzonego w celu przechowywania modyfikacji tylko dla danej lokacji. Na przykład w przypadku komputerów z procesorem x86 można utworzyć folder o nazwie Sterowniki_prywatne w źródłowym folderze instalacji i386 i umieścić w tym folderze pliki sterowników. Następnie można wpisać polecenie /copydir:i386\Sterowniki_prywatne, aby Instalator skopiował ten folder na nowo zainstalowany komputer, tworząc nowy folder w lokalizacji %SYSTEMROOT%\Sterowniki_prywatne. Za pomocą polecenia /copydir można utworzyć dowolną liczbę dodatkowych folderów.
/copysource:nazwa_folderu Tworzy jeden lub więcej folderów tymczasowych w folderze, w którym są instalowane pliki systemu Windows.

Nazwa_folderu dotyczy folderu utworzonego w celu przechowywania modyfikacji tylko dla danej lokacji. Można na przykład utworzyć folder o nazwie Sterowniki_prywatne w źródłowym folderze instalacji i umieścić w nim pliki sterowników. Następnie można wpisać polecenie /copysource:Sterowniki_prywatne, aby Instalator skopiował ten folder na nowo zainstalowany komputer i użył zawartych w nim plików podczas instalacji, tworząc folder tymczasowy w lokalizacji %SYSTEMROOT%\Sterowniki_prywatne. W przeciwieństwie do folderów utworzonych za pomocą polecenia /copydir, foldery utworzone przy użyciu polecenia /copysource są usuwane po zakończeniu instalacji.
/debug[poziom]:[nazwa_pliku] | Tworzy dziennik debugowania na określonym poziomie, na przykład /debug4:Debug.log. Domyślny plik dziennika to C:\%SYSTEMROOT%\Winnt32.log, a domyślnym poziomem debugowania jest poziom 2. Poziomy rejestrowania są następujące: 0 reprezentuje poważne błędy, 1 reprezentuje błędy, 2 reprezentuje ostrzeżenia, 3 reprezentuje informacje, a 4 reprezentuje szczegółowe informacje służące do debugowania. Każdy poziom zawiera niższe poziomy.
/dudisable | Uniemożliwia uruchomienie rozszerzenia Windows Update. Bez rozszerzenia Windows Update instalacja jest uruchamiana tylko przy użyciu oryginalnych plików Instalatora. Ta opcja wyłącza rozszerzenia Windows Update, nawet jeśli we wpisie DUDisable w sekcji [Unattended] pliku Unattend.txt ustawiono wartość No.
/duprepare:nazwa_ścieżki | Przygotowuje udział dystrybucyjny do użycia z plikami rozszerzenia Windows Update pobranymi z witryny Windows Update w sieci Web. Tego udziału dystrybucyjnego można używać do instalowania systemu Windows na wielu klientach.
/dushare:nazwa_ścieżki | Określa udział dystrybucyjny, do którego wcześniej pobrano pliki rozszerzenia Windows Update (zaktualizowane pliki na użytek Instalatora) z witryny Windows Update w sieci Web i na którym wcześniej uruchomiono polecenie /duprepare:nazwa_ścieżki. W przypadku uruchomienia na kliencie określa, że instalacja klienta ma użyć zaktualizowanych plików z udziału dystrybucyjnego określonego przez parametr nazwa_ścieżki.
/emsbaudrate:szybkość_transmisji W przypadku komputerów z procesorem x86 określa szybkość transmisji dla usług EMS. (Ta opcja nie dotyczy komputerów z procesorem Itanium). Opcji /emsbaudrate trzeba użyć z parametrem /emsport:com1 lub /emsport:com2. W przeciwnym wypadku zostanie ona zignorowana.

Parametr szybkość_transmisji może być równy 9600, 19200, 57600 lub 115200. Wartością domyślną jest 9600.
/emsport:{com1|com2|usebiossettings|off} Włącza lub wyłącza usługi zarządzania awaryjnego (EMS) podczas instalacji oraz po zainstalowaniu systemu należącego do rodziny Windows Server 2003. Za pomocą usług EMS można zdalnie zarządzać serwerem w sytuacjach awaryjnych, które normalnie wymagałyby użycia lokalnej klawiatury, myszy i monitora, na przykład wtedy, gdy sieć jest niedostępna lub serwer nie działa poprawnie. Usługi EMS mają specjalne wymagania sprzętowe i są dostępne tylko dla produktów z rodziny Windows Server 2003.

Opcja usebiossettings jest opcją domyślną i używa ustawienia określonego w tabeli Serial Port Console Redirection (SPCR) systemu BIOS lub — na komputerach z procesorem Itanium — ścieżki urządzenia konsoli EFI. W przypadku określenia opcji usebiossettings, jeśli nie ma żadnej tabeli SPCR ani odpowiedniej ścieżki urządzenia konsoli EFI, usługi EMS nie są włączane.

Opcje com1 i com2 dotyczą tylko komputerów z procesorem x86 (komputerów z procesorem innym niż Itanium).

Jeśli usługi EMS zostaną wyłączone wskutek określenia opcji /emsport:off, to można włączyć je później, modyfikując ustawienia rozruchu. Aby uzyskać informacje dotyczące modyfikowania ustawień rozruchu, zobacz zestaw Windows XP Professional Resource Kit.
/m:nazwa_folderu | Określa, że Instalator ma skopiować inne pliki z innej lokalizacji. Instruuje Instalatora, aby najpierw poszukiwał plików w innej lokalizacji i po ich znalezieniu korzystał z nich zamiast z plików znajdujących się w domyślnej lokalizacji.
/makelocalsource | Instruuje Instalatora, aby skopiował wszystkie źródłowe pliki instalacyjne na lokalny dysk twardy. Opcji /makelocalsource należy używać w przypadku instalacji z dysku CD w celu udostępnienia plików instalacyjnych, jeśli dysk CD nie będzie dostępny w dalszych fazach instalacji.
/noreboot | Instruuje Instalatora, aby nie uruchamiał ponownie komputera po zakończeniu fazy kopiowania plików, dzięki czemu będzie możliwe wykonanie dodatkowego polecenia.
/s:ścieżka_źródłowa Określa lokalizację plików systemu Windows. Aby równocześnie skopiować pliki z wielu serwerów, opcję /s:ścieżka_źródłowa należy wpisać wiele razy (co najwyżej osiem razy). Na przykład:
winnt32 /s:serwer1 /s:serwer2

Jeśli ta opcja zostanie wpisana wiele razy, pierwszy z określonych serwerów musi być dostępny, inaczej instalacja nie powiedzie się.
/syspart:litera_dysku: Na komputerze z procesorem x86 określa, że można skopiować pliki startowe Instalatora na dysk twardy, oznaczyć dysk jako aktywny, a następnie zainstalować ten dysk w innym komputerze. Po uruchomieniu komputera kolejna faza instalacji rozpocznie się automatycznie. Z parametrem /syspart należy zawsze używać parametru /tempdrive.

Polecenie Winnt32 można uruchomić z opcją /syspart na komputerze wyposażonym w procesor x86, na którym działa system Windows NT 4.0, Windows 2000 lub Windows XP. Nie może to być komputer z systemem Windows 95, Windows 98 ani Windows Millennium Edition.
/tempdrive:litera_dysku: Poleca Instalatorowi umieścić pliki tymczasowe na określonej partycji. W przypadku nowej instalacji na określonej partycji zostanie zainstalowany system Windows. W przypadku uaktualniania opcja /tempdrive dotyczy jedynie lokalizacji plików tymczasowych; system operacyjny zostanie uaktualniony na partycji, z której uruchomiono polecenie winnt32.
/udf:identyfikator[,plik_UDB] Wskazuje identyfikator używany przez Instalatora do określenia, w jaki sposób plik bazy danych Uniqueness Database (UDB) modyfikuje plik odpowiedzi (zobacz opis opcji /unattend).

Baza danych UDB zastępuje wartości w pliku odpowiedzi, a identyfikator określa, które wartości z pliku UDB są używane. Na przykład opcja /udf:użytkownik_RAS,Nasza_firma.udb zastępuje ustawienia określone dla identyfikatora użytkownik_RAS w pliku Nasza_firma.udb. Jeśli parametr plik_UDB nie zostanie określony, Instalator wyświetla monit o włożenie dysku zawierającego plik $Unique$.udb.

W przypadku uruchamiania komputera za pomocą dysku CD produktu Windows i instalacji nienadzorowanej nie można użyć opcji wiersza polecenia /udf programu Winnt32.exe.
/unattend | Na komputerze z procesorem x86 uaktualnia poprzednią wersję systemu Windows 98, Windows Millennium Edition, Windows NT 4.0 lub Windows 2000 w trybie instalacji nienadzorowanej. Instalator pobiera z witryny Windows Update pliki rozszerzenia Windows Update i uwzględnia je w instalacji. Wszelkie ustawienia użytkownika są kopiowane z poprzedniej instalacji, dzięki czemu interwencja użytkownika w czasie pracy Instalatora nie jest konieczna.
/unattend[liczba]:[plik_odpowiedzi] Wykonuje nową instalację systemu Windows w trybie instalacji nienadzorowanej. Instalator pobiera z witryny Windows Update w sieci Web pliki rozszerzenia Windows Update i uwzględnia je w instalacji. Określony plik_odpowiedzi zapewnia Instalatorowi informacje o ustawieniach niestandardowych.
liczba
Określa liczbę sekund, które muszą upłynąć między zakończeniem kopiowania plików przez Instalatora i ponownym uruchomieniem Instalatora. Parametru liczba można użyć na dowolnym komputerze z systemem Windows 98, Windows Millennium Edition, Windows NT, Windows 2000 lub Windows XP.
plik_odpowiedzi
Określa nazwę pliku odpowiedzi.

Użycie opcji wiersza polecenia /unattend do zautomatyzowania instalacji stanowi potwierdzenie przeczytania i zaakceptowania Umowy Licencyjnej Użytkownika Oprogramowania (EULA) dla systemu Windows. Przed użyciem tej opcji wiersza polecenia do zainstalowania systemu Windows w imieniu organizacji innej niż własna trzeba potwierdzić, że użytkownik końcowy (niezależnie od tego, czy jest to osoba, czy inny podmiot) otrzymał, przeczytał i zaakceptował warunki Umowy Licencyjnej Użytkownika Oprogramowania firmy Microsoft dla systemu Windows.

Aby uzyskać więcej informacji o programie Winnt32.exe, zobacz Uruchamianie Instalatora za pomocą programu Winnt32.exe.


Opcje wiersza polecenia programu Winnt.exe

Używając programu Winnt.exe w wierszu polecenia, można uruchomić Instalatora systemu Windows na komputerze, na którym działa jeden z następujących systemów operacyjnych:

  • MS-DOS
  • Windows 3.1
  • Windows for Workgroups

Składnia polecenia Winnt jest następująca:

winnt [/s:[ścieżka_źródłowa]] [/t:[dysk_tymczasowy]] [/u:[plik_odpowiedzi]] [/udf:identyfikator [,plik_UDB]] [/r:folder] [/rx:folder] [/e:polecenie] [/a]

Opcja | Akcja
/s:ścieżka_źródłowa | Określa lokalizację źródłową plików systemu Windows. Lokalizacja ta musi być pełną ścieżką w postaci x:\[ścieżka] lub \\serwer\udział[\ścieżka]. Domyślnie jest to folder bieżący.
/t:dysk_tymczasowy | Poleca Instalatorowi umieszczenie plików tymczasowych na określonym dysku i zainstalowanie systemu Windows na tym dysku. Jeżeli nie zostanie określona żadna lokalizacja, Instalator próbuje zlokalizować dysk automatycznie.
/u:plik_odpowiedzi | Wykonuje instalację nienadzorowaną przy użyciu pliku odpowiedzi. Plik odpowiedzi zawiera odpowiedzi na niektóre lub wszystkie komunikaty, na które zwykle podczas instalacji odpowiada użytkownik końcowy. W przypadku użycia opcji /u konieczne jest również użycie opcji /s.
/udf:identyfikator [,plik_UDB] | Wskazuje identyfikator używany przez Instalatora do określenia, w jaki sposób plik bazy danych Uniqueness Database (UDB) modyfikuje plik odpowiedzi (zobacz opcję /u). Baza danych UDB zastępuje wartości w pliku odpowiedzi, a identyfikator określa, które wartości z pliku UDB mają zostać użyte. Jeżeli parametr plik_UDB nie zostanie określony, Instalator monituje o włożenie dysku zawierającego plik $Unique$.udb. Na przykład opcja /udf:użytkownik_RAS, Nasza_firma.udb zastępuje ustawienia określone dla identyfikatora użytkownik_RAS w pliku Nasza_firma.udb.
/r:folder | Określa opcjonalny folder do zainstalowania. Folder ten pozostaje po zakończeniu instalacji.
/rx:folder | Określa opcjonalny folder do skopiowania. Folder ten jest usuwany po zakończeniu instalacji.
/e:polecenie | Określa polecenie, które ma być uruchomione po zakończeniu instalacji w trybie graficznym.
/a | Włącza opcje ułatwień dostępu.

Aby uzyskać więcej informacji na temat polecenia Winnt.exe, zobacz Uruchamianie Instalatora za pomocą programu Winnt.exe i Konwertowanie krótkich nazw plików na długie nazwy plików.


Słownik

Symbole A B C Ć D E F G H I J K L Ł M N O Ó P Q R S Ś T U V W X Y Z Ź Ż

Symbole

$$Rename.txt

Plik zawierający listę wszystkich plików zawartych w określonym folderze, których nazwy muszą zostać zmienione podczas instalacji z nazw w formacie 8.3 na długie nazwy plików. Wszystkie nazwy plików muszą mieć format 8.3, jeśli Instalator jest uruchamiany przy użyciu programu Winnt.exe lub jeśli zestaw plików jest kopiowany na komputer z systemem MS-DOS.

%windir%

Domyślny katalog, w którym jest instalowany system Windows, najczęściej C:\winnt.

.adm

Rozszerzenie nazwy pliku dla plików szablonów administracyjnych.

100BaseT

Standard Ethernet dla sieci lokalnych używających skrętki, czyli kabla przenoszącego dane z szybkością 100 megabitów na sekundę (Mb/s).

8.3

Standardowy format nazw plików w systemach MS-DOS i Windows 3.1.x. Nazwa pliku składająca się maksymalnie z ośmiu znaków, po których następuje kropka i maksymalnie trzyznakowe rozszerzenie.

A

ACPI

Zobacz definicję: system zarządzania oszczędzaniem energii (ACPI)

Active Directory

Usługa katalogowa, która przechowuje informacje dotyczące obiektów w sieci i udostępnia je użytkownikom i administratorom sieci. Usługa Active Directory daje użytkownikom sieci dostęp do dozwolonych zasobów w dowolnym miejscu w sieci przy użyciu pojedynczego procesu logowania. Oferuje ona administratorom sieci intuicyjny widok hierarchiczny sieci i pojedynczy punkt administracji dla wszystkich obiektów sieciowych.

Zobacz też: domena ; las

adapter sieciowy

Urządzenie, które łączy komputer z siecią. Niekiedy nazywany kartą sieciową lub kartą interfejsu sieciowego.

administrator

W przypadku systemów Windows XP Professional i Windows XP Home Edition jest to osoba odpowiedzialna za wprowadzanie zmian systemowych na komputerze lokalnym. Administrator komputera lokalnego może na przykład instalować oprogramowanie, zarządzać lokalnymi kontami użytkowników i grup, przypisywać hasła i uprawnienia oraz zarządzać plikami lokalnymi.

W wypadku systemu Windows XP Professional administratorzy są członkami lokalnej grupy administratorów i mają pełną kontrolę nad komputerem lokalnym.

Zobacz też: hasło ; konto grupy ; konto użytkownika ; kontroler domeny ; uprawnienie

adres internetowy

Adres zasobu w Internecie używany przez przeglądarki sieci Web do lokalizowania zasobów internetowych. Adres internetowy zazwyczaj rozpoczyna się od nazwy protokołu, po której następuje nazwa organizacji prowadzącej witrynę. Sufiks identyfikuje rodzaj organizacji. Na przykład adres http://www.yale.edu/ zawiera następujące informacje:

  • http: Ten serwer sieci Web korzysta z protokołu HTTP (Hypertext Transfer Protocol).
  • www: Ta witryna znajduje się w sieci WWW (World Wide Web).
  • edu: To jest instytucja edukacyjna.
Adres internetowy jest także zwany adresem URL. Skrót URL oznacza ujednolicony lokalizator zasobów (Uniform Resource Locator).

Zobacz też: protokół ; serwer sieci Web

adres IP

32-bitowy adres używany do identyfikacji węzła w sieci globalnej IP. Każdemu węzłowi w sieci globalnej IP musi być przypisany unikatowy adres IP, który składa się z identyfikatora sieci oraz unikatowego identyfikatora hosta. Adres jest zazwyczaj reprezentowany przez oddzielone kropkami wartości dziesiętne odpowiadające kolejnym oktetom (na przykład 192.168.7.27). Adres IP można konfigurować statycznie lub dynamicznie przy użyciu protokołu DHCP.

Zobacz też: adres IP ; protokół dynamicznej konfiguracji hosta (DHCP) ; węzeł

adres pamięci

Część pamięci komputera, która może być przydzielona urządzeniu albo używana przez program lub system operacyjny. Urządzeniom są zazwyczaj przydzielane zakresy adresów pamięci.

Zobacz też: urządzenie

aktualizacja BIOS

Proces aktualizacji systemu BIOS komputera do nowej wersji.

Zobacz też: podstawowy system wejścia/wyjścia (BIOS)

aktywacja

Zobacz definicję: aktywacja produktu Windows (WPA)

aktywacja produktu

Zobacz definicję: aktywacja produktu Windows (WPA)

aktywacja produktu Windows (WPA)

Technologia, która ogranicza piractwo komputerowe, wymagając, aby każda instalacja produktu Windows została uaktywniona przy współudziale firmy Microsoft, za pośrednictwem Internetu lub telefonicznie. Dla każdej instalacji systemu Windows jest wymagany unikatowy klucz produktu, ale firma Microsoft nie wymaga ani nie zbiera podczas instalacji żadnych informacji poza tym kluczem produktu. Użytkownik końcowy może ponownie zainstalować system Windows, używając tego samego klucza produktu, na tym samym komputerze tyle razy, ile to będzie konieczne, ale nie może użyć tego klucza do zainstalowania systemu Windows na innym komputerze. Użytkownik końcowy może stopniowo uaktualniać sprzęt komputera. Jeśli jednak sprzęt ulega znacznej zmianie, użytkownik końcowy musi ponownie uaktywnić instalację systemu Windows.

algorytm mieszania

Algorytm używany do uzyskiwania wartości hasza dla danych, takich jak wiadomość lub klucz sesji. Dobry algorytm mieszania to taki, w którym zmiana danych wejściowych może spowodować zmianę każdego bitu w wartości hasza, dlatego algorytmy tego typu służą do wykrywania modyfikacji w dużych obiektach danych, takich jak wiadomości. Ponadto dobry algorytm mieszania w praktyce uniemożliwia skonstruowanie dwóch niezależnych danych wejściowych, dla których hasz byłby identyczny. Typowe algorytmy mieszania to: MD2, MD4, MD5 i SHA-1. Algorytm mieszania jest nazywany także funkcją haszującą.

amerykański standardowy kod służący do wymiany informacji (ASCII)

Standardowy schemat kodowania znaków przy użyciu pojedynczych bajtów, stosowany do przetwarzania danych tekstowych. W standardzie ASCII wyznaczone 7-bitowe lub 8-bitowe kombinacje liczb są wykorzystywane do reprezentowania 128 lub 256 znaków. W podstawowym standardzie ASCII 7 bitów jest używanych do reprezentowania wszystkich dużych i małych liter, cyfr od 0 do 9, znaków interpunkcyjnych i specjalnych znaków sterujących, używanych w języku angielskim obowiązującym w Stanach Zjednoczonych. Najnowsze systemy oparte na procesorach typu x86 obsługują rozszerzony standard ASCII. Rozszerzony standard ASCII pozwala na używanie ośmiu bitów do reprezentowania dodatkowych 128 symboli specjalnych, liter używanych w językach obcych i symboli graficznych.

Zobacz też: Unicode

antyaliasing

Programowa technika wygładzania linii krzywych i skośnych, które pojawiają się jako „schodkowe” ze względu na słabą rozdzielczość ekranu. Metody antyaliasingu polegają na otaczaniu określonych pikseli pikselami o pośrednich odcieniach oraz manipulowaniu rozmiarem i poziomym wyrównaniem pikseli.

API

Zobacz definicję: interfejs programowania aplikacji (API)

APIC

Skrót nazwy Advanced Programmable Interrupt Controller (zaawansowany programowalny kontroler przerwań). Rozproszony zestaw urządzeń, które tworzą kontroler przerwań.

aplikacja RunOnce

Aplikacja, którą skonfigurowano do uruchomienia po następnym uruchomieniu komputera. Ta aplikacja nie jest uruchamiana po żadnym kolejnym rozruchu systemu.

AppleTalk

Zobacz definicję: protokół AppleTalk

asynchroniczność

Brak zależności od taktowania. Wszystkie aplikacje i polecenia są uruchamiane w określonej kolejności, ale dany element nie czeka na zakończenie jakiegokolwiek uprzednio uruchomionego procesu przed uruchomieniem aplikacji lub polecenia.

atrybut

W odniesieniu do plików są to informacje wskazujące, czy plik jest tylko do odczytu, ukryty, gotowy do archiwizacji (wykonania kopii zapasowej), skompresowany lub zaszyfrowany oraz czy zawartość pliku powinna być poindeksowana w celu umożliwienia szybkiego wyszukania pliku.

W usłudze Active Directory jest to właściwość obiektu. Dla każdej klasy obiektów schemat określa, jakie atrybuty musi, a jakie dodatkowe atrybuty może mieć wystąpienie danej klasy.

Zobacz też: obiekt

autologowanie

Automatyczne logowanie do komputera przy użyciu konta administratora podczas uruchamiania komputera.

automatyczne prywatne adresowanie IP (APIPA)

Funkcja protokołu TCP/IP w systemie Windows XP i produktach z rodziny Windows Server 2003, która automatycznie konfiguruje unikatowy adres IP z zakresu od 169.254.0.1 do 169.254.255.254 i maskę podsieci 255.255.0.0, jeśli dla protokołu TCP/IP jest skonfigurowane adresowanie dynamiczne, a serwer DHCP jest niedostępny. Zakres APIPA adresów IP jest zarezerwowany przez organizację Internet Assigned Numbers Authority (IANA) i adresy IP z tego zakresu nie są używane w Internecie.

Zobacz też: adres IP ; protokół dynamicznej konfiguracji hosta (DHCP) ; serwer DHCP ; Transmission Control Protocol/Internet Protocol (TCP/IP)

autoryzowany dystrybutor

Niezależna firma posiadająca licencję firmy Microsoft Licensing, Inc. na wytwarzanie produktów Windows XP OEM i rozpowszechnianie ich wśród konstruktorów systemów. Każdy, kto nabywa oprogramowanie firmy Microsoft od innego podmiotu niż autoryzowany dystrybutor firmy Microsoft, ponosi ryzyko nabycia oprogramowania fałszywego, w przypadku którego zazwyczaj występują następujące problemy: brakujące sterowniki, brakująca dokumentacja, wirusy, usterki i inne defekty. Instalowanie legalnych produktów firmy Microsoft eliminuje te problemy, a czasem również konieczność korzystania z pomocy technicznej.

autoryzowany replikator

Niezależna firma posiadająca licencję firmy Microsoft Licensing, Inc. na wytwarzanie produktów Microsoft OEM i rozpowszechnianie ich wśród sygnatariuszy OEM. Firma Microsoft Licensing, Inc. zaopatruje autoryzowanego replikatora w podstawowe składniki, specyfikacje dotyczące wytwarzania i składania produktów końcowych oraz inne potrzebne instrukcje. Autoryzowany replikator wytwarza i składa oryginalne produkty firmy Microsoft zgodnie z dokładnymi specyfikacjami. Korzystanie z usług autoryzowanego replikatora zapewnia ochronę przed piractwem komputerowym, zgodne, wysokiej jakości oprogramowanie i konkurencyjne ceny.

B

bajt końcowy

Wartość bajtu stanowiącego drugą połowę znaku dwubajtowego.

bezpieczne zamknięcie

Zakończenie procesu, które umożliwia systemowi operacyjnemu lub procesowi nadrzędnemu przejęcie normalnej kontroli. Nie powoduje awarii komputera i nie generuje ogólnych błędów ochrony (GPF) ani błędów typu „niebieski ekran”. Użytkownik nie musi zamykać aplikacji i może nadal korzystać z innych funkcji.

bezpośredni producent OEM

Zobacz definicję: sygnatariusz OEM

biblioteka dołączana dynamicznie (DLL)

Funkcja systemu operacyjnego umożliwiająca oddzielne przechowywanie procedur wykonywalnych (zazwyczaj służących jako określone funkcje lub zestawy funkcji) w postaci plików z rozszerzeniem dll. Procedury te są ładowane tylko wówczas, gdy są potrzebne programowi, który je wywołuje.

biblioteka sterowników systemu Windows (WDL)

Punkt dystrybucji w witrynie www.microsoft.com dla sterowników innych firm, które spełniają wymagania programu Windows Logo Program.

bidi

Tekst dwukierunkowy. Tekst zawierający zarówno znaki czytane od lewej do prawej, jaki i znaki czytane od prawej do lewej. Na przykład większość znaków w językach arabskim, hebrajskim farsi i urdu to znaki czytane od prawej do lewej, ale liczby i cytowane w tekście terminy w językach zachodnich są czytane od lewej do prawej.

BIOS

Zobacz definicję: podstawowy system wejścia/wyjścia (BIOS)

bit (cyfra binarna)

Najmniejsza jednostka informacji przetwarzana przez komputer. Pojedynczy bit reprezentuje cyfrę 1 lub 0 w zapisie binarnym albo wartość Prawda lub Fałsz warunku logicznego. Grupa 8 bitów tworzy bajt, który może reprezentować informacje różnego typu, takie jak litery alfabetu, cyfry dziesiętne lub inne znaki. Zwany także cyfrą binarną.

bity na sekundę (b/s)

Liczba bitów transmitowanych w ciągu jednej sekundy, używana jako miara szybkości, z jaką urządzenie, na przykład modem, może przesyłać dane.

Zobacz też: modem

buforowanie

Proces tymczasowego przechowywania w specjalnym podsystemie pamięci niedawno używanych informacji, aby były szybciej dostępne.

Zobacz też: pamięć podręczna

C

CAL

Zobacz definicję: licencja dostępu klienta (CAL)

CD-ROM

Skrót nazwy Compact Disc Read-Only Memory (dysk kompaktowy tylko do odczytu). Rodzaj urządzenia magazynującego, które charakteryzuje się dużą pojemnością (około 650 MB) i używaniem do odczytywania danych wiązki laserowej, a nie metod magnetycznych.

Centrum pomocy i obsługi technicznej

Pojedyncze miejsce, z którego użytkownik może uzyskać dostęp do całej zawartości i wszystkich usług Pomocy i obsługi technicznej dostarczonej przez firmę Microsoft i producenta OEM.

certyfikat

Dokument cyfrowy, który jest powszechnie używany do uwierzytelniania i do zabezpieczania informacji w sieciach otwartych. Certyfikat w bezpieczny sposób wiąże klucz publiczny z podmiotem posiadającym odpowiedni klucz prywatny. Certyfikaty zawierają podpisy cyfrowe urzędów certyfikacji i mogą być wydawane dla użytkownika, komputera lub usługi. Najszerzej akceptowany jest format certyfikatów zdefiniowany przez międzynarodowy standard X.509 w wersji 3, opracowany przez organizację ITU-T.

Zobacz też: klucz prywatny ; klucz publiczny ; urząd certyfikacji (UC) ; usługa

certyfikat autentyczności (COA)

Etykieta z zaawansowanymi funkcjami zapobiegającymi fałszerstwu, która ułatwia użytkownikowi końcowemu sprawdzenie, czy na komputerze jest zainstalowana legalna kopia systemu Microsoft Windows. Na tej etykiecie jest umieszczona nazwa produktu i unikatowy klucz produktu. Producent OEM musi fizycznie przymocować etykietę COA do obudowy komputera i etykiety tej nigdy nie należy usuwać.

certyfikat główny

Własny certyfikat urzędu certyfikacji, podpisany przez ten urząd. Jest on nazywany certyfikatem głównym, ponieważ jest wystawiony dla głównego urzędu certyfikacji. Główny urząd certyfikacji musi podpisać własny certyfikat, ponieważ z definicji w hierarchii certyfikacji nie ma urzędu certyfikacji wyższej instancji.

Zobacz też: certyfikat ; główny urząd certyfikacji ; urząd certyfikacji (UC)

ClearType

Technologia wyświetlania czcionek, która znacznie zwiększa rozdzielczość ich wyświetlania, dzięki czemu litery na ekranie komputera pojawiają się jako gładkie, a nie postrzępione. Technologia ClearType znacznie zwiększa czytelność tekstu na kolorowych monitorach ciekłokrystalicznych z interfejsem cyfrowym, takich jak monitory laptopów i wysokiej jakości monitory o płaskim ekranie dla komputerów typu desktop.

Cmdlines.txt

Plik tekstowy, którego Instalator używa w trybie graficznym przy instalowaniu składników opcjonalnych, takich jak aplikacje.

COA

Zobacz definicję: certyfikat autentyczności (COA)

czcionka

Projekt graficzny stosowany do kolekcji cyfr, symboli i znaków. Czcionka opisuje określony krój oraz inne właściwości, takie jak rozmiar, odstępy i szerokość.

Zobacz też: czcionki OpenType

czcionki OpenType

Czcionki konturowe, które są renderowane przy użyciu poleceń służących do kreślenia linii prostych i krzywych, a ponadto mogą być skalowane i obracane. Czcionki typu OpenType są wyraźne i czytelne we wszystkich rozmiarach i na wszystkich urządzeniach wyjściowych obsługiwanych przez system Windows. Czcionka OpenType jest rozszerzeniem czcionki TrueType.

Zobacz też: czcionka

czytnik kart inteligentnych

Urządzenie instalowane w komputerach, które umożliwia korzystanie z kart inteligentnych w środowisku z rozszerzonymi funkcjami zabezpieczeń.

Zobacz też: karta inteligentna

Ć

W słowniku nie ma haseł zaczynających się na tę literę.

D

debugowanie

Wykrywanie, lokalizowanie i naprawianie błędów logicznych i składniowych w programie.

DHCP

Zobacz definicję: protokół dynamicznej konfiguracji hosta (DHCP)

Dial-Up Networking (DUN)

Połączenie telefoniczne, na przykład za pomocą modemu, z siecią zdalną lub z Internetem.

diskpart.exe

Narzędzie wiersza polecenia do formatowania partycji dysku i woluminów oraz zarządzania nimi.

długa nazwa pliku

Nazwa folderu lub pliku dłuższa niż standardowa nazwa pliku 8.3 (maksymalnie osiem znaków, po których następuje kropka i maksymalnie trzyznakowe rozszerzenie). Większość wersji systemu Windows, w tym Windows XP, Windows 2000, Window NT, Windows 95 i Windows 98, obsługuje długie nazwy plików o maksymalnej długości 255 znaków.

dodatek Service Pack

Programowe uaktualnienie istniejącego oprogramowania zawierające zaktualizowane pliki składające się z poprawek.

dokowanie

Podłączanie laptopa lub komputera przenośnego do stacji dokującej.

Zobacz też: stacja dokująca

dołączenie

Uruchomienie programu instalacyjnego dla aplikacji, która jest już umieszczona na komputerze docelowym.

Zobacz też: komputer docelowy ; odłączenie ; umieszczenie

domena

W usłudze Active Directory jest to zdefiniowana przez administratora kolekcja obiektów typu komputer, użytkownik lub grupa. Obiekty te współużytkują tę samą bazę danych katalogów, zasady zabezpieczeń i relacje zabezpieczeń z innymi domenami.

W systemie DNS jest to dowolne drzewo lub poddrzewo w obszarze nazw DNS. Nazwy domen DNS często odpowiadają domenom usługi Active Directory, ale należy odróżniać domeny DNS od domen usługi Active Directory.

Zobacz też: Active Directory ; obiekt

dostawca podnoszący jakość towaru (VAR)

Firma, która sprzedaje pakiety sprzętu i oprogramowania deweloperom i/lub użytkownikom końcowym.

dostęp zdalny

Część zintegrowanej usługi Routing i dostęp zdalny, która umożliwia zdalną obsługę sieci telekomuterom, pracownikom mobilnym i administratorom systemów, którzy monitorują serwery i zarządzają nimi w biurach obejmujących wiele wydziałów. Użytkownicy mogą użyć usługi Połączenia sieciowe i telefonu w celu zdalnego uzyskania dostępu do swoich sieci i skorzystania z takich usług, jak udostępnianie plików i drukarek, poczta elektroniczna, planowanie i dostęp do baz danych SQL.

Zobacz też: serwer dostępu zdalnego ; usługa

Driver.cab

Plik zawierający wszystkie sterowniki urządzeń dostarczane z systemem Windows XP.

drzewo domen

W systemie DNS drzewo domen jest odwróconą, hierarchiczną strukturą drzewa używaną do indeksowania nazw domen. Zastosowanie i koncepcja drzew domen jest podobna do drzew katalogów używanych przez systemy komputerowe do magazynowania danych na dyskach. Jeśli na przykład na dysku jest przechowywanych wiele plików, to katalogi mogą być używane do organizowania plików w logiczne kolekcje. Jeśli drzewo domen ma jedną lub kilka gałęzi, to poszczególne gałęzie mogą organizować w logiczne kolekcje nazwy domen używane w obszarze nazw.

W wypadku usługi Active Directory jest to hierarchiczna struktura jednej lub większej liczby domen, połączonych przechodnimi i dwukierunkowymi relacjami zaufania, która tworzy ciągły obszar nazw. Do tego samego lasu może należeć wiele drzew domen.

Zobacz też: Active Directory ; domena ; las ; nazwa domeny

drzewo konsoli

Lewe okienko w programie Microsoft Management Console (MMC), w którym są wyświetlane elementy zawarte w konsoli. Elementy w drzewie konsoli i ich organizacja hierarchiczna określają możliwości konsoli.

Zobacz też: Microsoft Management Console (MMC)

drzewo sprzętu

Rekord w pamięci RAM bieżącej konfiguracji systemu oparty na informacjach dotyczących wszystkich urządzeń w gałęzi sprzętu w rejestrze. Drzewo sprzętu jest tworzone przy każdym uruchamianiu systemu i za każdym razem, gdy w konfiguracji systemu zachodzi dynamiczna zmiana.

Zobacz też: gałąź sprzętu

DUN

Zobacz definicję: Dial-Up Networking (DUN)

duplikacja dysku

Użycie sprzętu lub oprogramowania innej firmy do skopiowania pełnej instalacji wzorcowej systemu Windows XP na dyskach twardych wielu komputerów docelowych. Komputer wzorcowy i komputery docelowe muszą mieć zgodne warstwy abstrakcji sprzętowej (HAL). Komputer docelowy może być bezpośrednio dostarczony klientom lub może wymagać dodatkowego procesu produkcyjnego.

Zobacz też: warstwa abstrakcji sprzętowej (HAL)

DVD

Skrót nazwy Digital Video Disk (cyfrowy dysk wideo). Rodzaj urządzenia magazynującego, które charakteryzuje się dużą pojemnością (około 650 MB) i używaniem do odczytywania danych wiązki laserowej, a nie metod magnetycznych. Dysk optyczny powszechnie używany do przechowywania audio, wideo i danych komputerowych. Dyski DVD mogą mieć pojemność od 4,7 GB do 17 GB i można na nich przechowywać znacznie więcej informacji niż na dyskach CD.

DWORD

Typ danych składających się z danych szesnastkowych z maksymalną ilością przypisanego miejsca równą 4 bajtom.

dysk

Podłączone do komputera urządzenie magazynujące.

Zobacz też: dysk dynamiczny ; dysk podstawowy

dysk dynamiczny

Dysk fizyczny oferujący funkcje, których nie oferują dyski podstawowe, na przykład obsługę wolumenów obejmujących kilka dysków. Dyski dynamiczne wykorzystują ukrytą bazę danych do śledzenia informacji o woluminach dynamicznych na dysku i innych dyskach dynamicznych w komputerze. Dyski podstawowe można przekonwertować na dynamiczne przy użyciu przystawki Zarządzanie dyskami lub narzędzia wiersza polecenia DiskPart. Po przekonwertowaniu dysku podstawowego na dynamiczny wszystkie istniejące woluminy podstawowe stają się woluminami dynamicznymi.

Zobacz też: dysk podstawowy ; partycja ; wolumin aktywny ; wolumin dynamiczny ; wolumin podstawowy

dysk logiczny

Wolumin tworzony w obszarze partycji rozszerzonej na podstawowym dysku MBR. Dyski logiczne przypominają partycje podstawowe, chociaż liczba dysków logicznych, jaką można utworzyć na jednym dysku fizycznym, jest nieograniczona, a liczba partycji podstawowych wynosi maksymalnie cztery. Dysk logiczny można sformatować i można mu przypisać literę dysku.

Zobacz też: dysk podstawowy ; główny rekord rozruchowy (MBR) ; partycja podstawowa ; partycja rozszerzona ; wolumin podstawowy

dysk podstawowy

Dysk fizyczny, do którego można uzyskać dostęp za pośrednictwem wszystkich systemów operacyjnych MS-DOS i Windows. Dyski podstawowe mogą zawierać maksymalnie cztery partycje podstawowe lub trzy partycje podstawowe i partycję rozszerzoną z wieloma dyskami logicznymi. Aby utworzyć partycje obejmujące wiele dysków, należy najpierw przekonwertować dysk podstawowy na dysk dynamiczny przy użyciu narzędzia Zarządzanie dyskami lub narzędzia wiersza polecenia Diskpart.exe.

Zobacz też: dysk dynamiczny ; dysk logiczny ; partycja podstawowa ; partycja rozszerzona

dysk podstawowy

Dysk twardy zawierający partycję systemową i rozruchową, używany do uruchamiania systemu Windows.

Zobacz też: partycja rozruchowa ; partycja systemowa

dysk systemowy

Litera dysku urządzenia magazynującego (zazwyczaj dysku twardego), na którym jest zainstalowany system Windows.

dzierżawa

Czas, przez który klient DHCP może korzystać z dynamicznie przypisanej konfiguracji adresu IP. Przed wygaśnięciem dzierżawy klient musi odnowić lub uzyskać nową dzierżawę DHCP.

Zobacz też: adres IP ; protokół dynamicznej konfiguracji hosta (DHCP)

E

edytor IME (Input Method Editor)

Program służący do wprowadzania tysięcy różnych znaków w językach azjatyckich za pomocą standardowej klawiatury zawierającej 101 klawiszy. Edytor IME składa się zarówno z aparatu konwertującego naciśnięcia klawiszy na znaki fonetyczne i ideograficzne, jak i ze słownika zawierającego często używane wyrazy ideograficzne. Podczas naciskania klawiszy przez użytkownika aparat IME próbuje określić, na jakie znaki powinny być konwertowane naciśnięcia klawiszy.

EFI

Zobacz definicję: rozszerzalny interfejs oprogramowania układowego (EFI)

etykieta

Każda część pełnej nazwy domeny DNS, reprezentująca węzeł w drzewie obszaru nazw domeny. Nazwy domen składają się z ciągu etykiet; na przykład trzy etykiety (przyklad, microsoft i com) składają się na nazwę domeny DNS przyklad.microsoft.com. Długość żadnej etykiety tworzącej nazwę DNS nie może być większa niż 63 bajty.

Zobacz też: nazwa domeny ; węzeł

EULA

Zobacz definicję: Umowa Licencyjna Użytkownika Oprogramowania (EULA)

F

FAT

Zobacz definicję: tabela alokacji plików (FAT)

FAT32

System wywodzący się z systemu plików FAT (tabeli alokacji plików). System FAT32 obsługuje mniejsze rozmiary klastrów i większe woluminy niż system FAT, dlatego miejsce na woluminach systemu FAT32 jest przydzielane w bardziej efektywny sposób.

Zobacz też: tabela alokacji plików (FAT)

G

gałąź rejestru

Plik, w którym system przechowuje fragment rejestru. Gałąź rejestru jest przechowywana w pojedynczym pliku oraz pliku dziennika (.log), które znajdują się w folderze główny_katalog_systemowy\System32\Confg oraz folderze główny_katalog_systemowy\Profiles\nazwa_użytkownika.

Większość plików gałęzi rejestru (Default, SAM, Security i System) jest domyślnie przechowywanych w folderze główny_katalog_systemowy\System32\Config. Folder główny_katalog_systemowy\Profiles zawiera profil użytkownika dla każdego użytkownika komputera. Gałąź rejestru jest plikiem, więc można ją przenosić między różnymi systemami. Do edycji tego pliku niezbędny jest jednak Edytor rejestru, Regedit.exe.

Zobacz też: klucz ; rejestr ; systemowy katalog główny

gałąź sprzętu

Klucz główny archiwum sprzętu w rejestrze będący nadzbiorem rezydentnego drzewa sprzętu. Podczas gdy drzewo sprzętu zawiera informacje tylko o tych urządzeniach, które są aktualnie wykryte i uruchomione w systemie, rejestr zawiera pełną listę całego sprzętu kiedykolwiek zainstalowanego na określonym komputerze. Kluczem głównym sprzętu jest \\HKEY-LOCAL-MACHINE\Hardware.

główna nazwa użytkownika (UPN)

Nazwa składająca się z nazwy konta użytkownika (niekiedy określanej jako nazwa logowania użytkownika) i nazwy domeny identyfikującej domenę, w której znajduje się dane konto użytkownika. Nazwa ta jest standardowo używana przy logowaniu się do domeny systemu Windows. Format nazwy głównej jest następujący: osoba@fikcja.com (jak adres poczty e-mail).

Zobacz też: domena ; konto użytkownika ; nazwa domeny

główna tabela plików (MFT)

Plik systemowy NTFS, który znajduje się na woluminach sformatowanych zgodnie z systemem NTFS i zawiera informacje dotyczące poszczególnych plików i folderów na danym woluminie. Plik MFT jest pierwszym plikiem na woluminie NTFS.

Zobacz też: system plików NTFS ; tabela alokacji plików (FAT)

główny rekord rozruchowy (MBR)

Pierwszy sektor na dysku twardym, który rozpoczyna proces uruchamiania komputera. Rekord MBR zawiera tabelę partycji dla dysku i niewielki kod wykonywalny nazywany głównym kodem rozruchowym.

Zobacz też: konsola odzyskiwania ; sektor rozruchowy partycji

główny urząd certyfikacji

Najbardziej zaufany urząd certyfikacji (UC), który znajduje się na najwyższym poziomie w hierarchii certyfikacji. Główny urząd certyfikacji wystawia certyfikat, który sam podpisuje. Nazywany także urzędem głównym.

Zobacz też: katalog główny ; urząd certyfikacji (UC)

gniazdo do rozbudowy

Gniazdo w komputerze przeznaczone do instalowania kart rozszerzeń i łączenia ich z magistralą systemową.

Zobacz też: magistrala

GPT

Zobacz definicję: tabela partycji GUID (GPT)

graficzny interfejs użytkownika (GUI)

Format wyświetlania, na przykład systemu Windows, który reprezentuje funkcje programu za pomocą obrazów graficznych, takich jak przyciski i ikony. Interfejs GUI umożliwia użytkownikowi przeprowadzanie operacji i dokonywanie wyborów przez wskazywanie i klikanie myszą.

grupa języków

Termin używany do opisu obsługiwanych w systemie Microsoft Windows rodzin zapisów języków.

grupa robocza

Prosta grupa komputerów, której zadaniem jest tylko ułatwienie użytkownikom znajdowania takich elementów, jak drukarki i foldery udostępnione w danej grupie. Grupy robocze w systemie Windows nie oferują scentralizowanych kont użytkowników ani uwierzytelniania zapewnianego przez domeny.

Zobacz też: domena ; konto użytkownika ; uwierzytelnianie

grupy wbudowane

Domyślne grupy zabezpieczeń instalowane z systemem operacyjnym. Grupom wbudowanym przyznawane są użyteczne kolekcje praw i wbudowanych możliwości.

W większości wypadków grupy wbudowane zapewniają wszystkie możliwości potrzebne określonemu użytkownikowi. Na przykład członkowie wbudowanej grupy Operatorzy kopii zapasowych mogą tworzyć kopie zapasowe plików i folderów oraz przywracać je z kopii zapasowych. Aby zapewnić kontu użytkownika potrzebny zestaw możliwości, należy przypisać to konto odpowiedniej grupie wbudowanej.

H

HAL

Zobacz definicję: warstwa abstrakcji sprzętowej (HAL)

hasło

Metoda zabezpieczeń używana w celu ograniczenia nazw logowania do kont użytkowników oraz uzyskiwania dostępu do systemów komputerowych i zasobów. Hasło to ciąg znaków, którego podanie jest wymagane do uwierzytelnienia nazwy logowania lub udzielenia dostępu. Hasło może składać się z liter, liczb i symboli. Przy jego rozpoznawaniu jest uwzględniana wielkość liter.

Zobacz też: konto użytkownika

hasło użytkownika

Hasło przechowywane na każdym koncie użytkownika. Zazwyczaj każdy użytkownik ma unikatowe hasło i musi je podać podczas logowania się lub przy próbie uzyskania dostępu do serwera.

Zobacz też: hasło ; konto użytkownika

hasz

Wynik o stałym rozmiarze uzyskany przez zastosowanie jednokierunkowej funkcji matematycznej (określanej niekiedy jako algorytm mieszania) do dowolnej liczby danych. Zmiana danych wejściowych pociąga za sobą zmiany związane z haszowaniem. Mieszanie można stosować w wielu operacjach, takich jak uwierzytelnianie i podpisywanie cyfrowe. Nazywany także skrótem wiadomości.

Zobacz też: algorytm mieszania ; uwierzytelnianie

HCL

Zobacz definicję: lista zgodności sprzętu (HCL)

HCT

Testy zgodności sprzętu. Zestaw testów WHQL służący do sprawdzania działania sprzętu i sterowników urządzeń w określonym środowisku operacyjnym. Testy te są przeprowadzane w kontrolowanych warunkach na różnych kombinacjach urządzeń, sterowników i systemów operacyjnych w celu sprawdzenia, czy wszystkie składniki działają poprawnie.

Zobacz też: Windows Hardware Quality Labs (WHQL)

hipertekstowy język wykorzystujący znaczniki (HTML)

Prosty język wykorzystujący znaczniki, używany do tworzenia dokumentów hipertekstowych, które mogą być przenoszone między platformami. Pliki HTML to proste pliki tekstowe ASCII z osadzonymi kodami (wskazywanymi przez tagi znaczników) określającymi formatowanie i łącza hipertekstowe.

Zobacz też: amerykański standardowy kod służący do wymiany informacji (ASCII)

I

IA-PC

Komputer osobisty o architekturze Intel. Ogólna, opisowa nazwa komputerów o standardowej architekturze PC i z procesorami zgodnymi z architekturą określoną przez rodzinę procesorów firmy Intel opartych na zestawie instrukcji 486.

IDE

Zobacz definicję: zintegrowane układy elektroniczne urządzenia (IDE)

identyfikator języka

Wartość 16-bitowa, która składa się z głównego i podrzędnego identyfikatora języka. Bity 0-9 tworzą główny identyfikator języka, a bity 10-15 — podrzędny identyfikator języka.

identyfikator sprzętu

Zdefiniowany przez dostawcę ciąg, używany przez Menedżera Plug and Play do znalezienia poprawnego pliku .inf potrzebnego do zainstalowania określonego urządzenia.

Zobacz też: plik .inf ; Plug and Play

identyfikator urządzenia

Unikatowy ciąg ASCII dla urządzenia, tworzony przez numeratory, służący do identyfikowania urządzenia sprzętowego i odwoływania się do danych o urządzeniu przechowywanych w rejestrze. Odróżnia każde logiczne urządzenie i magistralę od wszystkich innych w systemie.

identyfikator ustawień regionalnych

Wartość 32-bitowa, która składa się z identyfikatora języka w niższym słowie (bity 0-15) oraz identyfikatora sortowania (bity 16-19) i wartości rezerwowej (bity 20-31) w wyższym słowie.

identyfikator zabezpieczeń (SID)

Struktura danych o zmiennej długości, która identyfikuje konta użytkowników, grup i komputerów. Podczas tworzenia poszczególnych kont w sieci są im przydzielane unikatowe identyfikatory SID. Wewnętrzne procesy w systemie Windows odwołują się do identyfikatorów SID kont zamiast do nazw kont użytkowników lub grup.

Zobacz też: konto grupy ; konto użytkownika ; nazwa użytkownika

identyfikator zgodny

Identyfikator używany przez Menedżera Plug and Play. Jeśli Menedżer Plug and Play nie zlokalizuje pasującego identyfikatora sprzętu, instaluje plik .inf sterownika skojarzony z identyfikatorem zgodnym.

IEEE

Skrót nazwy organizacji Institute of Electrical and Electronics Engineers (Instytut Inżynierów Elektryków i Elektroników) założonej w 1963 roku. IEEE jest organizacją zrzeszającą inżynierów, naukowców i studentów, znaną z opracowywania standardów dla przemysłu komputerowego i elektronicznego.

IEEE 1394

Standard urządzeń szeregowych o dużej szybkości, takich jak wyposażenie służące do edycji cyfrowego wideo i audio.

Zobacz też: urządzenie

IHV

Zobacz definicję: niezależny dostawca sprzętu (IHV)

IIS

Zobacz definicję: Internetowe usługi informacyjne (IIS)

infrastruktura kluczy publicznych (PKI)

Prawa, zasady, standardy i programy służące do regulowania certyfikatów oraz kluczy publicznych i prywatnych lub operowania nimi. W praktyce jest to system certyfikatów cyfrowych, urzędów certyfikacji i innych urzędów rejestracyjnych, które weryfikują i uwierzytelniają poszczególne strony uczestniczące w transakcji elektronicznej. Standardy infrastruktury PKI wciąż się rozwijają , mimo że są powszechnie implementowane jako niezbędny element handlu elektronicznego.

Zobacz też: certyfikat ; klucz publiczny ; urząd certyfikacji (UC)

instalacja nienadzorowana

Zautomatyzowana, bezobsługowa metoda instalacji systemu Windows. Podczas instalacji nienadzorowanej używany jest plik odpowiedzi dostarczający Instalatorowi danych, które w innym wypadku musiałby podać administrator lub użytkownik końcowy.

instalacja w trybie graficznym

Trzeci z trzech etapów instalacji, podczas którego konfigurowany jest sprzęt komputerów oraz ustawienia sieci, pojawia się monit o hasło administratora i można spersonalizować instalację.

instalacja w trybie tekstowym

Drugi z trzech etapów instalacji, podczas którego jest określany podstawowy sprzęt komputera (procesor, płyta główna, kontrolery dysku twardego, systemy plików i pamięć), jest instalowany podstawowy system operacyjny niezbędny do kontynuowania instalacji i są tworzone określone foldery.

instalacja wzorcowa

Dostosowana instalacja systemu Windows, którą producent OEM planuje zduplikować na jednym lub wielu komputerach docelowych.

Instalator systemu Windows

Program, który instaluje system operacyjny Windows.

Instalator Windows

Usługa systemu operacyjnego, która umożliwia systemowi operacyjnemu zarządzanie procesem instalacji. Technologie Instalatora Windows są podzielone na dwie części, które działają razem: usługa instalatora po stronie klienta (Msiexec.exe) i plik pakietu (plik .msi). Instalator Windows używa informacji zawartych w pliku pakietu do zainstalowania aplikacji.

instalowanie

W przypadku oprogramowania termin ten oznacza dodanie plików i folderów programu do dysku twardego i pokrewnych danych do rejestru, po którym oprogramowanie działa poprawnie. Instalowanie różni się od uaktualniania, które polega na aktualizowaniu istniejących plików i folderów programu oraz wpisów w rejestrze do najnowszej wersji.

W wypadku urządzenia termin ten oznacza fizyczne podłączenie urządzenia do komputera, załadowanie odpowiednich sterowników urządzenia oraz skonfigurowanie właściwości i ustawień urządzenia.

Zobacz też: rejestr ; sterownik urządzenia

Instrumentacja zarządzania Windows (WMI)

Infrastruktura zarządzania w systemie Windows, która obsługuje monitorowanie i kontrolowanie zasobów systemowych przy użyciu wspólnego zestawu interfejsów oraz udostępnia logicznie zorganizowany, spójny model działania, konfiguracji i stanu systemu Windows.

Zobacz też: zasób

interakcyjne szkolenie Step-by-Step Interactive (SBSI)

Interakcyjne materiały szkoleniowe, opublikowane przez wydawnictwo Microsoft Press i zintegrowane z Centrum pomocy i obsługi technicznej systemu Windows XP.

interfejs API telefonii (TAPI)

Interfejs programowania aplikacji (API) używany przez programy komunikacyjne do pracy z usługami telefonicznymi i sieciowymi. Programy komunikacyjne, takie jak HyperTerminal i Telefon, wykorzystują interfejs TAPI do wybierania numerów, odpowiadania na wywołania i routingu połączeń telefonicznych na konwencjonalnych urządzeniach telefonicznych, łącznie z urządzeniami PBX, modemami i urządzeniami do przesyłania faksów. Interfejs TAPI 3.0 oferuje również obsługę telefoniczną protokołu IP używaną przez program Telefon i inne programy do transmitowania, routowania oraz kontrolowania sygnałów audio i wideo przesyłanych w czasie rzeczywistym za pośrednictwem sieci opartych na protokole IP, takich jak Internet.

Zobacz też: interfejs programowania aplikacji (API) ; Internet Protocol (IP) ; modem ; usługa

interfejs kontrolera wbudowanego

Zdefiniowany przez specyfikację ACPI standard sprzętowo-programowego interfejsu komunikacyjnego między sterownikiem systemu operacyjnego a kontrolerem wbudowanym, na przykład bateria inteligentna z kodem AML. Umożliwia on dowolnemu systemowi operacyjnemu dostarczenie standardowego sterownika, który może bezpośrednio komunikować się z kontrolerem wbudowanym w systemie, co pozwala innym sterownikom na komunikowanie się z systemowymi kontrolerami wbudowanymi i korzystanie z ich zasobów.

Zobacz też: sterownik ; system zarządzania oszczędzaniem energii (ACPI)

interfejs małych systemów komputerowych (SCSI)

Standardowy interfejs równoległy o dużej szybkości, zdefiniowany przez Amerykański Narodowy Instytut Normalizacji (ANSI). Interfejs SCSI jest używany do łączenia mikrokomputerów z urządzeniami peryferyjnymi, takimi jak dyski twarde i drukarki, oraz z innymi komputerami i sieciami lokalnymi (LAN).

Zobacz też: sieć lokalna (LAN) ; urządzenie

interfejs programowania aplikacji (API)

Zestaw procedur, których używa aplikacja, żądając i korzystając z usług niższego poziomu wykonywanych przez system operacyjny komputera. Procedury te dotyczą zwykle zadań konserwacji, na przykład zarządzania plikami i wyświetlania informacji.

internet

intersieć. Dwa lub więcej segmentów sieci połączonych przy użyciu routerów. Inna nazwa sieci złożonych.

Internet. Ogólnoświatowa sieć komputerów. Jeśli użytkownik ma dostęp do Internetu, to może pobierać informacje z milionów źródeł, takich jak szkoły, instytucje państwowe, firmy i osoby prywatne.

Zobacz też: World Wide Web (sieć Web)

Internet Protocol (IP)

Protokół wchodzący w skład zestawu protokołów TCP/IP, odpowiedzialny za adresowanie IP, routing oraz fragmentowanie i ponowne łączenie pakietów IP.

Zobacz też: Transmission Control Protocol/Internet Protocol (TCP/IP)

Internetowe usługi informacyjne (IIS)

Usługi programowe obsługujące tworzenie i konfigurowanie witryn sieci Web, zarządzanie nimi oraz inne funkcje dotyczące Internetu. Internetowe usługi informacyjne (IIS) obejmują: protokół NNTP (Network News Transfer Protocol), protokół FTP (protokół transferu plików) i protokół SMTP (Simple Mail Transfer Protocol).

Zobacz też: Network News Transfer Protocol (NNTP) ; protokół transferu plików (FTP) ; Simple Mail Transfer Protocol (SMTP)

Internetwork Packet Exchange (IPX)

Macierzysty protokół sieciowy systemu NetWare, który steruje adresowaniem i routingiem pakietów w sieciach lokalnych (LAN) i między tymi sieciami. Protokół IPX nie gwarantuje, że przesłana wiadomość będzie kompletna (przesyłania bez utraty pakietów).

Zobacz też: Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX) ; sieć lokalna (LAN)

Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX)

Protokoły transportu używane w sieciach Novell NetWare, które razem odpowiadają kombinacji protokołów TCP i IP w zestawie protokołów TCP/IP. System Windows implementuje protokół IPX przy użyciu protokołu NWLink.

Zobacz też: Internetwork Packet Exchange (IPX) ; NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) ; Transmission Control Protocol/Internet Protocol (TCP/IP)

inżynier systemów

Pracownik firmy Microsoft, który pomaga jednemu lub kilku sygnatariuszom OEM w przygotowaniu do produkcji komputerów, na których będzie zainstalowana wersja systemu Microsoft Windows będąca w fazie projektowania.

IRP

Zobacz definicję: pakiet żądania We/Wy (IRP)

IRQ

Zobacz definicję: żądanie przerwania (IRQ)

ISP

Zobacz definicję: usługodawca internetowy (ISP)

ISV

Zobacz definicję: niezależny dostawca oprogramowania (ISV)

Itanium

Mikroprocesor firmy Intel, który przetwarza dane równolegle i zapewnia 64-bitowe adresowanie pamięci.

izolacja

Proces Plug and Play, w którym karty podłączone do magistrali ISA są odróżniane od siebie po uruchomieniu systemu.

J

jądro

Rdzeń architektury warstwowej, który zarządza większością podstawowych operacji systemu operacyjnego i procesora komputera. Jądro planuje wykonywanie różnych bloków kodu, nazywanych wątkami, tak aby maksymalnie wykorzystać czas procesora, a ponadto koordynuje współpracę wielu procesów w celu zoptymalizowania wydajności systemu. Jądro synchronizuje również działanie podskładników na poziomie wykonawczym, takich jak Menedżer We/Wy i Menedżer procesów, i obsługuje wyjątki sprzętowe oraz inne funkcje zależne od sprzętu. Jądro blisko współpracuje z warstwą abstrakcji sprzętowej.

jednostka alokacji

Najmniejsza ilość miejsca na dysku, która może być przeznaczona do przechowywania pliku. Wszystkie systemy plików używane przez system Windows organizują dyski twarde na podstawie jednostek alokacji. Im mniejszy rozmiar jednostki alokacji, tym efektywniej przechowywane są informacje na dysku twardym. Jeśli podczas formatowania dysku użytkownik nie określi rozmiaru jednostki alokacji, system Windows wybiera rozmiary domyślne na podstawie rozmiaru woluminu. Rozmiary domyślne są wybierane w celu zredukowania ilości traconego miejsca i stopnia fragmentacji na woluminie. Nazywana także klastrem.

Zobacz też: system plików

Język

Ustawienie apletu Opcje regionalne i językowe określające kombinację języka, w którym ma być wprowadzany tekst, oraz układu klawiatury, edytora Input Method Editor (IME), konwertera mowy na tekst lub innego urządzenia używanego do wprowadzania tekstu. Dawna nazwa to ustawienia regionalne.

Zobacz też: edytor IME (Input Method Editor)

Język dla programów nie obsługujących kodu Unicode

Ustawienie apletu Opcje regionalne i językowe określające domyślne strony kodowe i skojarzone z nimi pliki map bitowych czcionek dla danego komputera, które dotyczy wszystkich użytkowników komputera. Domyślne strony kodowe i czcionki umożliwiają poprawne uruchamianie aplikacji, które nie obsługują kodu Unicode i są napisane dla jednej wersji językowej systemu operacyjnego, w innej wersji językowej systemu operacyjnego. Dawna nazwa to ustawienia regionalne systemu.

język interfejsu użytkownika

Język, w którym system operacyjny wyświetla swoje menu, pliki Pomocy i okna dialogowe.

K

karnacja

Dostosowany interfejs użytkownika, który jest „nakładany” na istniejący interfejs użytkownika.

karta

Zobacz definicję: urządzenie

karta inteligentna

Urządzenie o rozmiarze karty kredytowej, które wraz z kodem dostępu jest używane do uwierzytelniania opartego na certyfikatach i rejestracji uproszczonej w przedsiębiorstwie. Karty inteligentne zapewniają bezpieczne przechowywanie certyfikatów, kluczy publicznych i prywatnych, haseł oraz innych informacji osobistych. Karta inteligentna jest odczytywana przez podłączony do komputera czytnik kart inteligentnych.

Zobacz też: czytnik kart inteligentnych ; rejestracja uproszczona ; uwierzytelnianie

karta interfejsu sieciowego (NIC)

Karta rozszerzenia lub inne urządzenie umożliwiające dostęp do sieci komputerowi lub innemu urządzeniu, na przykład drukarce. Karta interfejsu sieciowego pośredniczy między komputerem i nośnikiem fizycznym, na przykład kablem, przez który odbywa się transmisja. Zwana też kartą sieciową lub kartą NIC.

karta PC

Urządzenie wymienne o rozmiarze zbliżonym do rozmiaru karty kredytowej, które można podłączyć do gniazda PCMIA (Personal Computer Memory Card International Association) komputera przenośnego. Urządzeniami PCMCIA mogą być modemy, karty sieciowe i dyski twarde.

Zobacz też: modem

karta sieciowa

Zobacz definicję: karta interfejsu sieciowego (NIC)

katalog główny

Najwyższy poziom w hierarchicznie zorganizowanym zestawie informacji. Katalog główny jest punktem, z którego rozgałęziają się dalsze podzestawy, zgodnie z logiczną sekwencją od elementów ogólniejszych do bardziej szczegółowych.

Zobacz też: certyfikat główny ; główny urząd certyfikacji

klaster

W przypadku magazynu danych jest to najmniejsza ilość miejsca na dysku, która może być przeznaczona do przechowywania pliku. Wszystkie systemy plików używane przez system Windows organizują przestrzeń na dyskach twardych na podstawie klastrów, które składają się z jednego sektora lub większej liczby sąsiadujących ze sobą sektorów. Im mniejszy rozmiar klastra, tym efektywniej są przechowywane informacje na dysku. Jeśli rozmiar klastra nie zostanie określony podczas formatowania, system Windows wybiera rozmiar domyślny na podstawie rozmiaru woluminu. Rozmiary domyślne są wybierane w celu zredukowania ilości traconego miejsca i stopnia fragmentacji na woluminie. Zwany też jednostką alokacji.

W kontekście sieci komputerowych jest to grupa niezależnych komputerów, które współpracują ze sobą w celu udostępniania klientom określonego zestawu usług i są przez nich postrzegane jako jeden system. Wykorzystanie klastrów zwiększa dostępność usług i skalowalność oraz możliwości zarządzania systemu operacyjnego udostępniającego te usługi.

Zobacz też: klient ; system plików

klaster serwerów

Grupa niezależnych systemów komputerowych, nazywanych węzłami, pracujących razem jak pojedynczy system, aby zawsze zapewniać klientom dostęp do aplikacji i zasobów o podstawowym znaczeniu. Klaster serwerów to typ klastra implementowany przez usługę klastrowania.

Zobacz też: klaster ; węzeł

klient

Dowolny komputer lub program nawiązujący połączenie z usługami lub żądający usług od innego komputera lub programu. Termin „klient” może również odnosić się do oprogramowania, które umożliwia komputerowi lub programowi ustanowienie połączenia.

W odniesieniu do sieci lokalnej (LAN) lub Internetu jest to komputer, który korzysta z zasobów sieciowych udostępnionych przez inny komputer (nazywany serwerem).

Zobacz też: serwer

klient (odbiorca)

Nabywca nowego komputera.

klucz

W przypadku Edytora rejestru jest to folder, który pojawia się w lewym okienku okna Edytora rejestru. Klucz może zawierać podklucze i wpisy wartości. Na przykład Environment jest kluczem w folderze HKEY_CURRENT_USER.

W wypadku zabezpieczeń protokołu IP (IPSec) jest to wartość używana w połączeniu z algorytmem szyfrowania lub odszyfrowywania danych. Ustawienia kluczy dla protokołu IPSec mogą być konfigurowane w celu zapewnienia wyższego poziomu zabezpieczeń.

Zobacz też: podklucz ; rejestr

klucz produktu

25-znakowy ciąg alfanumeryczny. Klienci muszą wprowadzić ten ciąg, aby uaktywnić swoją instalację systemu Windows. Klucz produktu znajduje się w certyfikacie autentyczności, który jest przyklejony do obudowy komputera.

klucz prywatny

Poufny klucz z pary kluczy kryptograficznych, który jest używany z algorytmem klucza publicznego. Klucze prywatne są zazwyczaj używane do odszyfrowywania symetrycznego klucza sesji, cyfrowego podpisywania danych lub odszyfrowywania danych zaszyfrowanych przy użyciu odpowiedniego klucza publicznego.

Zobacz też: klucz publiczny ; szyfrowanie oparte na kluczu publicznym

klucz publiczny

Jawny klucz z pary kluczy kryptograficznych, który jest używany z algorytmem klucza publicznego. Klucze publiczne są zazwyczaj używane do szyfrowania klucza sesji, weryfikowania podpisu cyfrowego lub szyfrowania danych, które mogą być odszyfrowane przy użyciu odpowiedniego klucza prywatnego.

Zobacz też: klucz ; klucz prywatny ; szyfrowanie oparte na kluczu publicznym

klucz rejestru

Identyfikator rekordu lub grupy rekordów w rejestrze.

klucz wstępnie zdefiniowany

Klucz reprezentujący jedną z głównych części rejestru. Poszczególne klucze wstępnie zdefiniowane są wyświetlane w oddzielnym oknie Edytora rejestru, a nazwy tych kluczy pojawiają się na pasku tytułu okna. Na przykład kluczem wstępnie zdefiniowanym jest HKEY_CLASSES_ROOT.

Zobacz też: gałąź rejestru ; klucz ; rejestr

kodek

Sprzęt, który konwertuje sygnały audio lub wideo z formy analogowej na cyfrową lub na odwrót (koder/dekoder); sprzęt lub program, który kompresuje i dekompresuje dane audio lub wideo (kompresor/dekompresor); również kombinacja kodera/dekodera i kompresora/dekompresora. Zazwyczaj kodek kompresuje nieskompresowane dane cyfrowe, tak aby zajmowały mniej pamięci.

Kolejkowanie wiadomości

System kolejkowania i routowania wiadomości przeznaczony dla systemu Windows, pozwalający uruchamianym w różnym czasie aplikacjom rozproszonym komunikować się za pośrednictwem sieci heterogenicznych i komputerów, które mogą pracować w trybie offline. Kolejkowanie wiadomości zapewnia dostarczanie wiadomości, efektywny routing, zabezpieczenia i obsługę wiadomości opartą na priorytetach. Dawna nazwa to MSMQ.

Zobacz też: MSMQ

komputer docelowy

Komputer, na którym jest preinstalowany system Windows przeznaczony do dystrybucji wśród klientów. Na komputerze docelowym można uruchomić Instalatora lub można skopiować na ten komputer instalację wzorcową.

komputer docelowy

Zobacz definicję: komputer docelowy

komputer jednoprocesorowy

Komputer z jednym procesorem.

Zobacz też: multiprocesor

komputer odniesienia

Zobacz definicję: komputer produkcyjny

komputer produkcyjny

Komputer, na którym jest instalowany Menedżer instalacji. Zazwyczaj na tym komputerze znajdują się również zestawy konfiguracyjne i udział dystrybucyjny.

Zobacz też: Menedżer instalacji ; udział dystrybucyjny ; zestaw konfiguracyjny

komputer wzorcowy

Całkowicie zmontowany komputer zawierający instalację wzorcową.

Zobacz też: instalacja wzorcowa

koncentrator

Wspólny punkt podłączenia urządzeń w sieci. Koncentrator jest zazwyczaj używany do łączenia segmentów sieci lokalnej (LAN) i zawiera wiele portów. Dane odebrane przez jeden z portów są kopiowane do innych portów, tak aby były widoczne we wszystkich segmentach sieci LAN.

Zobacz też: port ; sieć lokalna (LAN)

konfiguracja na zamówienie

Wytwarzanie komputera zgodnie ze specyfikacjami klienta przez dostosowanie istniejącego obrazu instalacji wzorcowej.

konsola odzyskiwania

Interfejs wiersza polecenia udostępniający ograniczony zestaw poleceń administracyjnych użytecznych podczas napraw komputera.

Zobacz też: system plików NTFS

konstruktor systemów

Każdy, kto nabywa pakiet dystrybucyjny OEM systemu Windows (udostępniany przez dystrybutorów) i preinstaluje system Windows na nowych komputerach. Konstruktorzy systemów podlegają warunkom umowy Microsoft OEM System Builder Agreement umieszczonej na opakowaniu pakietu dystrybucyjnego OEM.

Zobacz też: Microsoft OEM System Builder Agreement

kontekst systemowy

Stan systemu Windows po jego pierwszym uruchomieniu, gdy niektóre usługi systemowe są załadowane, ale żaden użytkownik nie jest zalogowany i nie są dostępne ustawienia specyficzne dla użytkownika.

konto grupy

Kolekcja kont użytkowników. Jeśli konto użytkownika jest członkiem grupy, użytkownik ma wszystkie prawa i uprawnienia udzielone danej grupie.

Zobacz też: konto użytkownika

konto użytkownika

W usłudze Active Directory jest to obiekt, który obejmuje wszystkie informacje określające użytkownika domeny, takie jak nazwa użytkownika, hasło i grupy, do których należy konto użytkownika. Konta użytkowników mogą być przechowywane w usłudze Active Directory lub na komputerze lokalnym.

W wypadku komputerów z systemem Windows XP Professional i serwerów członkowskich z systemem Windows Server 2003 do zarządzania lokalnymi kontami użytkowników służy narzędzie Użytkownicy i grupy lokalne. W wypadku kontrolerów domeny z systemem Windows Server 2003 do zarządzania kontami użytkowników w domenie służy narzędzie Użytkownicy i komputery usługi Active Directory.

Zobacz też: Active Directory ; hasło ; nazwa użytkownika ; obiekt

kontroler domeny

Serwer w lesie usługi Active Directory, który zawiera zapisywalną kopię bazy danych usługi Active Directory, uczestniczy w replikacji usługi Active Directory i steruje dostępem do zasobów sieciowych. Administratorzy mogą zarządzać kontami użytkowników, dostępem do sieci, zasobami udostępnionymi, topologią lokacji i innymi obiektami katalogowymi z dowolnego kontrolera domeny w lesie.

Zobacz też: Active Directory ; las ; uwierzytelnianie

kontroler magazynowania masowego

Urządzenie, z którego korzystają urządzenia magazynowania masowego, uzyskując dostęp do podsystemu komputerowego. Na przykład karta SCSI lub układ IDE wbudowany w płytę główną jest kontrolerem magazynowania masowego; fizyczny dysk twardy jest urządzeniem magazynowania masowego.

kontroler wbudowany

Ogólna klasa mikrokontrolerów używana do obsługi implementacji specyficznych dla producentów OEM, głównie w środowiskach mobilnych. Kontroler wbudowany przeprowadza złożone operacje niskiego poziomu za pośrednictwem prostego złącza z mikroprocesorem lub mikroprocesorami hosta.

kopiowanie plików

Pierwszy z trzech etapów instalacji, w którym pliki programów systemu Windows i wszelkie pliki dodatkowe są kopiowane na dysk twardy komputera.

Kreator nowego połączenia

Narzędzie, które ułatwia użytkownikom zapisanie się do usługi internetowej i automatycznie wykonuje procedurę konfiguracji oprogramowania niezbędną do uzyskania dostępu do Internetu.

L

LAN

Zobacz definicję: sieć lokalna (LAN)

las

Jedna lub więcej domen usługi Active Directory, które współużytkują te same definicje klas i atrybutów (schemat), informacje o lokacjach i replikacji (konfigurację) oraz możliwości wyszukiwania na poziomie lasu (wykaz globalny). Domeny w tym samym lesie są połączone dwukierunkowymi, przechodnimi relacjami zaufania.

Zobacz też: Active Directory ; domena

Layer Two Tunneling Protocol (L2TP)

Internetowy protokół tunelowania, standard przemysłu komputerowego, który zapewnia hermetyzację ramek PPP (Point-to-Point Protocol) przesyłanych przez ośrodek zorientowany na pakiety. W przypadku sieci IP ruch L2TP jest przesyłany jako wiadomości UDP (User Datagram Protocol). W systemach operacyjnych firmy Microsoft protokół L2TP jest używany w połączeniu z zabezpieczeniami protokołu IP (IPSec) jako technologia wirtualnej sieci prywatnej (VPN), umożliwiając dostęp zdalny lub połączenia VPN router-router. Protokół L2TP opisano w specyfikacji RFC 2661.

Zobacz też: Point-to-Point Protocol (PPP)

LBA

Skrót nazwy Logical Block Addressing (logiczne adresowanie blokowe). Metoda używana w przypadku dysków SCSI i IDE do tłumaczenia specyfikacji cylindrów, głowic i sektorów dysku na adresy, które mogą być używane przez rozszerzony system BIOS. Adresowanie LBA jest używane dla dysków o rozmiarze większym niż 528 MB.

licencja

Prawo osoby lub firmy do korzystania z oprogramowania w określony sposób, opisany przez warunki umowy licencyjnej. Sposób korzystania z oprogramowania dodatkowo ograniczają prawa autorskie. Umowa licencyjna jest wymagana dla każdego używanego programu.

licencja dostępu klienta (CAL)

Licencja określająca liczbę użytkowników lub urządzeń mających prawo połączyć się z serwerem i używać znajdującego się na nim oprogramowania.

Lightweight Directory Access Protocol (LDAP)

Podstawowy protokół dostępu dla usługi Active Directory. Protokół LDAP jest standardowym protokołem przemysłu komputerowego, ustanowionym przez organizację Internet Engineering Task Force (IETF), który pozwala użytkownikom na znajdowanie i aktualizowanie informacji w usłudze katalogowej. Usługa Active Directory obsługuje protokoły LDAP w wersji 2 i LDAP w wersji 3.

Zobacz też: Active Directory ; protokół

linie żądań przerwań (IRQ)

Linie sprzętowe, przez które urządzenia mogą przesyłać sygnały w celu poinformowania procesora o gotowości do odebrania lub wysłania informacji. Każde urządzenie musi korzystać z oddzielnej linii IRQ.

Zobacz też: urządzenie ; żądanie przerwania (IRQ)

lista MFU

Lista najczęściej używanych aplikacji. Lista aplikacji, których użytkownik niedawno używał.

lista odwołania certyfikatów (CRL)

Dokument przechowywany i publikowany przez urząd certyfikacji, zawierający listę odwołanych certyfikatów.

Zobacz też: certyfikat ; urząd certyfikacji (UC)

lista zaufanych certyfikatów (CTL)

Podpisana lista certyfikatów wydanych przez główne urzędy certyfikacji, których reputację administrator uważa za wystarczającą do określonych celów, takich jak uwierzytelnianie klientów lub zabezpieczanie poczty e-mail.

Zobacz też: certyfikat ; certyfikat główny ; urząd certyfikacji (UC)

lista zgodności sprzętu (HCL)

Lista sprzętu, którą firma Microsoft tworzy dla określonego produktu. Lista HCL systemu Windows, która jest ogłaszana w sieci Web, jest listą urządzeń sprzętowych i systemów komputerowych zgodnych z określonymi wersjami systemu Windows.

Zobacz też: urządzenie

Ł

łącze OEM

Łącze w menu Start, gdzie producenci OEM mogą umieszczać żądane łącza lub skróty.

M

magistrala

Linia komunikacyjna używana do transferu danych między składnikami systemu komputerowego. Magistrala umożliwia różnym częściom systemu współużytkowanie danych. Łączy na przykład kontroler dysku, pamięć i porty wejścia/wyjścia z mikroprocesorem.

Zobacz też: gniazdo do rozbudowy ; uniwersalna magistrala szeregowa (USB)

magistrala lokalna

Termin ten zazwyczaj odnosi się do magistrali systemowej bezpośrednio połączonej z mikroprocesorem na płycie głównej. Potocznie termin magistrala lokalna jest używany w odniesieniu do magistrali na płycie głównej umieszczonej bliżej mikroprocesora niż zwykłe magistrale rozszerzeń (i dlatego w mniejszym stopniu wymagającej buforowania), co zapewnia jej większą przepustowość.

mapa bitowa

Format plików obrazów używany do dostosowywania grafiki w pakiecie Internet Explorer Administration Kit (IEAK).

materiały dodatkowe

Podręcznik użytkownika i wszelkie inne elementy, które producent OEM pakuje z nowych komputerem.

Menedżer instalacji

Narzędzie służące do tworzenia i modyfikowania plików odpowiedzi i zestawów konfiguracyjnych.

Zobacz też: plik odpowiedzi ; zestaw konfiguracyjny

Menedżer konfiguracji

Składnik Plug and Play systemu Windows, który przeprowadza proces lokalizowania urządzeń i konfigurowania ich węzłów w drzewie sprzętu oraz uruchamia proces przydzielania zasobów. Każda z trzech faz zarządzania konfiguracją — rozruch, tryb rzeczywisty i tryb chroniony — ma swojego własnego menedżera konfiguracji.

menedżer odpowiedzialny za kontakty z firmą

Pracownik firmy Microsoft, który jest podstawowym kontaktem w relacjach między producentem OEM a firmą Microsoft.

menedżer odpowiedzialny za pomoc techniczną (TAM)

Pracownik firmy Microsoft, który zapewnia pomoc techniczną jednemu lub kilku sygnatariuszom OEM przy produkcji komputerów, na których jest instalowana wydana wersja systemu Microsoft Windows.

Menedżer połączeń

Program kliencki typu telefon, używany przy uzyskiwaniu dostępu do Internetu.

Menedżer urządzeń

Narzędzie administracyjne, które może być używane do zarządzania urządzeniami na komputerze. Korzystając z Menedżera urządzeń, można przeglądać i zmieniać właściwości urządzeń, aktualizować ich sterowniki, konfigurować ustawienia i odinstalowywać urządzenia.

Zobacz też: urządzenie

Microsoft Management Console (MMC)

Struktura obsługująca narzędzia administracyjne zwane przystawkami. Konsola może zawierać narzędzia, foldery lub inne kontenery, strony sieci Web oraz inne elementy administracyjne. Są one wyświetlane w lewym okienku konsoli, nazywanym drzewem konsoli. Konsola ma jedno lub kilka okien, w których mogą być wyświetlane widoki drzewa konsoli. Główne okno programu MMC udostępnia polecenia i narzędzia autorskie konsoli. Funkcje autorskie programu MMC i drzewo konsoli mogą być ukryte, gdy konsola działa w trybie użytkownika.

Zobacz też: drzewo konsoli ; przystawka

Microsoft OEM System Builder Agreement

Umowa licencyjna między konstruktorem systemów a firmą Microsoft Licensing Inc., umieszczona na opakowaniu każdego pakietu dystrybucyjnego OEM. Otwarcie pakietu jest równoznaczne z wyrażeniem zgody na wszystkie warunki umowy Microsoft OEM System Builder Agreement. W przypadku nieakceptowania wszystkich warunków umowy należy skontaktować się z autoryzowanym dystrybutorem Microsoft OEM, od którego nabyto produkt, i uzgodnić warunki zwrotu oprogramowania.

MIDI

Skrót nazwy Musical Instrument Digital Interface (interfejs cyfrowy dla instrumentów muzycznych). Standardowy interfejs przemysłu komputerowego służący do komputerowego sterowania instrumentami i urządzeniami muzycznymi. Standard sprzętu i danych dla komunikacji między urządzeniami. Większość odwołań dotyczy tylko standardu danych, który jest strumieniem bajtów używanym do sterowania instrumentami muzycznymi i przechowywania danych wyjściowych tych instrumentów.

miniinstalacja

Część instalacji w trybie graficznym. Miniinstalacja jest programem początkowym dla rodziny produktów Windows Server. Miniinstalacja monituje o informacje specyficzne dla użytkownika, wykrywa sprzęt i ponownie generuje identyfikatory systemu.

MIPS

Skrót wyrażenia „millions of instructions per second” (miliony instrukcji na sekundę). Popularna miara szybkości procesora.

modem

Urządzenie umożliwiające przesyłanie i odbieranie informacji z komputera przez linię telefoniczną. Modem transmitujący przetwarza cyfrowe dane komputerowe na sygnały analogowe, które mogą być przenoszone przez linię telefoniczną. Modem odbiorczy przetwarza sygnały analogowe z powrotem na dane cyfrowe.

Zobacz też: interfejs API telefonii (TAPI) ; port

modem kablowy

Modem, który wysyła i odbiera dane za pośrednictwem sieci telewizyjnej (kabli koncentrycznych), a nie linii telefonicznych.

monitor monochromatyczny

Monitor, który wyświetla obrazy tylko w jednym kolorze lub wyświetla tylko zmienne poziomy jednego koloru, na przykład skalę szarości.

MP3

Skrót nazwy MPEG Audio Layer-3. Cyfrowy schemat kodowania dźwięku używany do rozpowszechniania zarejestrowanej muzyki w Internecie. Technologia MP3 zmniejsza rozmiar pliku audio od 10 do 12 razy bez pogorszenia jakości dźwięku (poziom rejestrowania na dyskach CD).

MPEG Audio Layer-3

Cyfrowy schemat kodowania dźwięku używany do rozpowszechniania zarejestrowanej muzyki w Internecie. Technologia MP3 zmniejsza rozmiar pliku audio od 10 do 12 razy bez pogorszenia jakości dźwięku (poziom rejestrowania na dyskach CD).

MSDN

Sieć dla deweloperów firmy Microsoft.

MSMQ

System kolejkowania i routowania wiadomości przeznaczony dla systemów Windows NT 4.0, Windows 95 i Windows 98. W systemach Windows 2000 i Windows XP oraz w rodzinie systemów Windows Server 2003 ta funkcja nazywa się Kolejkowanie wiadomości.

Zobacz też: Kolejkowanie wiadomości

multimedia

Termin ten odnosi się do dostarczania informacji, które obejmują różne formaty zawartości, takie jak wideo, audio, obrazy nieruchome, grafika, animacje i tekst.

multiprocesor

Dwa lub więcej połączonych i w przybliżeniu jednakowych procesorów, z których każdy może przeprowadzać jeden lub wiele procesów (programów lub zestawów instrukcji) zespołowo.

N

nazwa domeny

Nazwa nadawana przez administratora kolekcji komputerów połączonych w sieć i współużytkujących wspólny katalog. Nazwy domen są częścią struktury systemu nazw domen (DNS) i składają się z sekwencji etykiet nazw oddzielonych kropkami.

Zobacz też: domena ; etykieta

nazwa furigana

Małe japońskie znaki kana pisane powyżej lub obok znaków kanji. Znaki kana wskazują, jaka jest poprawna wymowa wyrazu w zapisie kanji.

nazwa użytkownika

Unikatowa nazwa identyfikująca konto użytkownika w systemie Windows. Nazwa użytkownika musi być unikatowa w stosunku do innych nazw grup i użytkowników w tej samej domenie lub grupie roboczej.

Zobacz też: domena ; grupa robocza ; konto użytkownika

NCW

Zobacz definicję: Kreator nowego połączenia

NetBEUI

Zobacz definicję: rozszerzony interfejs użytkownika NetBIOS (NetBEUI)

Network News Transfer Protocol (NNTP)

Element zestawu protokołów TCP/IP używany do dystrybucji wiadomości grup dyskusyjnych między serwerami NNTP i klientami NNTP (przeglądarkami grup dyskusyjnych) w Internecie. Protokół NNTP jest tak zaprojektowany, że artykuły grup dyskusyjnych są przechowywane na serwerze w centralnej bazie danych, co pozwala użytkownikom na wybieranie i czytanie określonych tematów.

Zobacz też: Transmission Control Protocol/Internet Protocol (TCP/IP)

NIC

Zobacz definicję: karta interfejsu sieciowego (NIC)

nieprzydzielone miejsce

Miejsce dostępne na dysku, które nie jest przydzielone żadnemu woluminowi. Typ woluminu, który można utworzyć na nieprzydzielonym miejscu, zależy od typu dysku. Nieprzydzielone miejsce na dyskach podstawowych może być wykorzystane do utworzenia partycji podstawowych lub rozszerzonych. Nieprzydzielone miejsce na dyskach dynamicznych może być wykorzystane do utworzenia woluminów dynamicznych.

Zobacz też: dysk dynamiczny ; dysk logiczny ; dysk podstawowy ; obiekt ; partycja ; partycja podstawowa ; partycja rozszerzona

niezależny dostawca oprogramowania (ISV)

Deweloper oprogramowania — osoba prywatna lub organizacja, która niezależnie tworzy oprogramowanie komputerowe.

niezależny dostawca sprzętu (IHV)

Firma, która produkuje urządzenia sprzętowe i skojarzone z nimi sterowniki urządzeń.

nośnik zapasowy

Nośnik dostarczany klientowi przez producenta OEM, umożliwiający naprawienie instalacji lub ponowne zainstalowanie systemu Windows.

numerator BIOS

Moduł w systemie Plug and Play niezgodnym z ACPI odpowiedzialny za identyfikację wszystkich urządzeń sprzętowych na płycie głównej komputera. System BIOS obsługuje interfejs API, który pozwala na skanowanie wszystkich komputerów Plug and Play w taki sam sposób.

NWLink

Zobacz definicję: NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

Implementacja protokołów Internetwork Packet Exchange (IPX), Sequenced Packet Exchange (SPX) i NetBIOS używana w sieciach Novell. NWLink jest standardowym protokołem sieciowym, który obsługuje routing i może obsługiwać aplikacje klient-serwer systemu NetWare, gdzie rozpoznające system NetWare aplikacje oparte na interfejsie Sockets mogą komunikować się z aplikacjami opartymi na interfejsie IPX/SPX Sockets.

Zobacz też: Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX) ; podstawowy sieciowy system wejścia/wyjścia (NetBIOS)

O

obiekt

Pewna całość, na przykład plik, folder, folder udostępniony, drukarka lub obiekt usługi Active Directory, opisana przez oddzielny, nazwany zestaw atrybutów. Na przykład do atrybutów obiektu Plik należy nazwa, lokalizacja i rozmiar, a do atrybutów obiektu Użytkownik usługi Active Directory — imię, nazwisko i adres e-mail użytkownika.

W wypadku technologii OLE i ActiveX obiektami nazywane są również dowolne informacje, które mogą być połączone z innymi obiektami lub w nich osadzone.

Zobacz też: atrybut ; obiekt nadrzędny ; obiekt podrzędny

obiekt nadrzędny

Obiekt, w którym znajduje się inny obiekt. Na przykład folder jest obiektem nadrzędnym, w którym znajduje się plik (obiekt podrzędny). Obiekt może być zarówno obiektem nadrzędnym, jak i podrzędnym. Na przykład podfolder zawierający pliki jest zarówno obiektem podrzędnym folderu nadrzędnego, jak i folderem nadrzędnym wobec plików.

Zobacz też: obiekt ; obiekt podrzędny

obiekt podrzędny

Obiekt znajdujący się w innym obiekcie. Obiekt podrzędny określa charakter relacji. Na przykład plik jest obiektem podrzędnym znajdującym się w folderze, który jest obiektem nadrzędnym.

Zobacz też: obiekt ; obiekt nadrzędny

obraz

Kolekcja plików i folderów (czasem skompresowana w jeden plik), która jest duplikatem oryginalnej struktury plików i folderów systemu operacyjnego. Często zawiera on inne pliki, dodane przez producenta OEM lub firmę.

Ochrona plików systemowych

Zobacz definicję: Ochrona plików systemu Windows (WFP)

Ochrona plików systemu Windows (WFP)

Funkcja, która działa w tle i chroni pliki systemowe przed zastąpieniem. Gdy zmodyfikowany zostanie plik w folderze chronionym, funkcja WFP sprawdza, czy nowy plik jest poprawną wersją pliku firmy Microsoft lub czy jest podpisany cyfrowo. Jeśli nie, zmodyfikowany plik zostaje zastąpiony prawidłową wersją.

ochronny rekord MBR

Pierwszy sektor dysku z tablicą partycji GUID (GPT), którego struktura jest tożsama ze strukturą pierwszego sektora dysku MBR, co zapobiega zniszczeniu partycji GPT przez narzędzia dyskowe oparte na procesorze x86. Ochronny rekord MBR zawiera jedną partycję, dla której rezerwowane jest całe miejsce na dysku zajęte przez partycje GPT.

Zobacz też: główny rekord rozruchowy (MBR) ; rozszerzalny interfejs oprogramowania układowego (EFI) ; tabela partycji GUID (GPT) ; x86

odłączenie

Usunięcie plików odinstalowanej aplikacji z komputera docelowego.

Zobacz też: dołączenie ; komputer docelowy ; umieszczenie

odłączenie

Zobacz definicję: odłączenie

odporność na uszkodzenia

Zdolność sprzętu lub oprogramowania komputera do zapewnienia integralności danych w przypadku wystąpienia awarii sprzętu. Funkcje zwiększające odporność na uszkodzenia są dostępne w wielu systemach operacyjnych serwerów i obejmują woluminy dublowane, woluminy typu RAID-5 i klastry serwerów.

Zobacz też: klaster ; wolumin dublowany ; wolumin RAID-5

OEM

Zobacz definicję: oryginalny producent sprzętu (OEM)

Oem.chm

Plik Pomocy HTML, który można dostosować, aby dołączyć informacje o pomocy technicznej producenta OEM do Pomocy systemu Windows.

Oeminfo.ini

Plik używany do podawania wymaganych informacji o producencie OEM, takich jak nazwa firmy, model komputera, numer telefonu firmy oraz informacje o pomocy technicznej.

oferta OEM zapisania się do usługodawcy internetowego

Zestaw stron HTML utworzonych przez producenta OEM lub inną firmę, który umożliwia użytkownikowi zapisanie się do usługodawcy internetowego w celu uzyskania dostępu do Internetu. Strony te można dołączyć do programu System Windows — Zapraszamy! albo można udostępnić skrót do pierwszej strony w łączu OEM w menu Start.

Zobacz też: łącze OEM ; System Windows — Zapraszamy!

oferta zapisania się do usługodawcy internetowego

Zestaw stron HTML, który umożliwia użytkownikowi zapisanie się do usługodawcy internetowego w celu uzyskania dostępu do Internetu. Aby wyświetlić tę ofertę, użytkownik musi kliknąć odpowiednie łącze z łącza OEM w menu Start.

oferta zapisania się do usługodawcy internetowego

Zestaw stron HTML, który umożliwia użytkownikowi zapisanie się do usługodawcy internetowego w celu uzyskania dostępu do Internetu.

OnNow

Zobacz definicję: system zarządzania oszczędzaniem energii (ACPI)

OOBE

Zobacz definicję: System Windows — Zapraszamy!

OPK

Zobacz definicję: Zestaw preinstalacyjny OEM (OPK)

oprogramowanie fałszywe

Oprogramowanie, którego konstruktor systemów nie uzyskał od autoryzowanego dystrybutora lub którego sygnatariusz OEM nie uzyskał od autoryzowanego replikatora. W przypadku oprogramowania fałszywego zazwyczaj występują następujące problemy: brakujące sterowniki, brakująca dokumentacja, wirusy, usterki i inne defekty. Instalowanie legalnych produktów firmy Microsoft pomaga zapewnić odpowiednią jakość używanych produktów, eliminuje wymienione problemy, a czasem również konieczność korzystania z pomocy technicznej.

oprogramowanie układowe

Procedury programowe i instrukcje wejścia/wyjścia niskiego poziomu, przechowywane w pamięci tylko do odczytu (ROM). W odróżnieniu od pamięci o dostępie swobodnym (RAM), pamięć tylko do odczytu pozostaje niezmieniona nawet po wyłączeniu zasilania.

Zobacz też: pamięć o dostępie swobodnym (RAM) ; pamięć tylko do odczytu (ROM)

oryginalny producent sprzętu (OEM)

Firma, która zazwyczaj nabywa składniki komputera od innych producentów, używa tych składników do zbudowania komputera osobistego, preinstaluje na tym komputerze system Windows, a następnie sprzedaje komputer na rynku.

Out-Of-Box Experience (OOBE)

Zobacz definicję: System Windows — Zapraszamy!

Ó

W słowniku nie ma haseł zaczynających się na tę literę.

P

pakiet żądania We/Wy (IRP)

Struktura danych, której sterowniki używają do komunikowania się między sobą.

pamięć o dostępie swobodnym (RAM)

Pamięć, która może być odczytywana lub zapisywana przez komputer lub inne urządzenia. Informacje przechowywane w pamięci RAM są tracone po wyłączeniu komputera.

pamięć podręczna

Specjalny podsystem pamięci, w którym są duplikowane często używane wartości danych, aby były szybciej dostępne.

Zobacz też: plik pamięci podręcznej

pamięć tylko do odczytu (ROM)

Obwód półprzewodnikowy zawierający informacje, które nie mogą być modyfikowane.

partycja

Część dysku fizycznego, która działa jak oddzielny dysk fizyczny. Po utworzeniu partycji należy ją sformatować i przypisać jej literę dysku. Dopiero wówczas można przechowywać na niej dane.

W wypadku dysków podstawowych partycje są nazywane woluminami podstawowymi; obejmują one partycje podstawowe i dyski logiczne. W przypadku dysków dynamicznych partycje są nazywane woluminami dynamicznymi; obejmują one woluminy proste, rozłożone, dublowane, łączone i RAID-5.

Zobacz też: dysk podstawowy ; partycja podstawowa ; partycja rozszerzona ; partycja systemowa ; wolumin dynamiczny ; wolumin podstawowy

partycja aktywna

Partycja, z której jest uruchamiany komputer z procesorem x86. Partycja aktywna musi być partycją podstawową umieszczoną na dysku podstawowym. Jeśli jest używany wyłącznie system Windows, partycja aktywna może być równoważna woluminowi systemowemu.

Zobacz też: dysk podstawowy ; partycja podstawowa ; partycja systemowa ; x86

partycja MSR (Microsoft Reserved)

Partycja wymagana na każdym dysku z tabelą partycji GUID (GPT). Składniki systemu mogą na własny użytek przydzielać fragmenty partycji MSR jako nowe partycje. Na przykład podczas konwersji podstawowego dysku GPT na dysk dynamiczny system przydziela fragment partycji MSR jako partycję z metadanymi Menedżera dysków logicznych. Rozmiar partycji MSR zależy od rozmiaru dysku GPT. W przypadku dysków mniejszych niż 16 GB partycja MSR ma rozmiar 32 MB. W przypadku dysków większych niż 16 GB partycja MSR ma rozmiar 128 MB. Partycja MSR nie jest widoczna w oknie narzędzia Zarządzanie dyskami, a użytkownik nie może jej usunąć ani przechowywać w niej danych.

Zobacz też: partycja ; tabela partycji GUID (GPT)

partycja podstawowa

Rodzaj partycji, które można tworzyć na dyskach podstawowych. Partycja podstawowa to część dysku fizycznego, która działa jakby była fizycznie oddzielnym dyskiem. Na podstawowych dyskach MBR można utworzyć maksymalnie cztery partycje podstawowe lub trzy partycje podstawowe i partycję rozszerzoną z wieloma dyskami logicznymi. Na podstawowych dyskach GPT można utworzyć maksymalnie 128 partycji podstawowych. Znany także jako wolumin.

Zobacz też: dysk logiczny ; dysk podstawowy ; główny rekord rozruchowy (MBR) ; partycja ; partycja rozszerzona ; tabela partycji GUID (GPT)

partycja rozruchowa

Partycja zawierająca system operacyjny Windows i jego pliki pomocnicze. Partycja rozruchowa może, choć nie musi, być partycją systemową.

Zobacz też: dysk podstawowy ; partycja ; partycja systemowa

partycja rozszerzona

Rodzaj partycji, którą można utworzyć tylko na podstawowym dysku MBR. Partycje rozszerzone są przydatne, gdy trzeba utworzyć więcej niż cztery woluminy na podstawowym dysku MBR. W przeciwieństwie do partycji podstawowych, partycji rozszerzonych nie formatuje się przy użyciu systemu plików i nie przypisuje się im liter dysków. Zamiast tego w obszarze jednej partycji rozszerzonej można utworzyć jeden lub kilka dysków logicznych. Po utworzeniu dysku logicznego można go sformatować i przypisać mu literę dysku. Dysk MBR może zawierać maksymalnie cztery partycje podstawowe albo trzy partycje podstawowe, jedną partycję rozszerzoną i wiele dysków logicznych.

Zobacz też: dysk logiczny ; dysk podstawowy ; główny rekord rozruchowy (MBR) ; nieprzydzielone miejsce ; partycja ; partycja podstawowa

partycja systemowa

Partycja zawierająca pliki specyficzne dla sprzętu, potrzebne do załadowania systemu Windows (na przykład pliki Ntldr, Osloader, Boot.ini, Ntdetect.com). Partycja systemowa może, choć nie musi, być partycją rozruchową.

Zobacz też: partycja ; partycja rozruchowa

partycja systemowa EFI

W przypadku komputerów z procesorem Itanium jest to fragment dysku z tabelą partycji GUID (GPT), sformatowany przy użyciu systemu plików FAT i zawierający pliki potrzebne do uruchomienia komputera. Każdy komputer z procesorem Itanium musi być wyposażony w co najmniej jeden dysk GPT z partycją systemową EFI. Partycja systemowa EFI pełni tę samą funkcję, co wolumin systemowy w komputerach z procesorem x86.

Zobacz też: Itanium ; partycja MSR (Microsoft Reserved) ; rozszerzalny interfejs oprogramowania układowego (EFI) ; tabela partycji GUID (GPT) ; x86

partycja ukryta

Partycja, która nie jest widoczna dla użytkownika. Aby utworzyć partycję ukrytą, należy ustawić typ partycji na typ, który nie jest rozpoznawany przez system Windows.

paszport

Pojedyncza usługa rejestracyjna, która pozwala na używanie jednej nazwy użytkownika i hasła przy odwiedzaniu wielu rozpoznających tę usługę witryn sieci Web.

PC Health

Zestaw technologii i funkcji mający na celu rozszerzenie oferowanej użytkownikom pomocy technicznej przez zastosowanie rozwiązań opartych na sieci Web. Program PC Health zapewnia również większą niezawodność systemu operacyjnego i większą wygodę użytkownika, ułatwiając dostęp do zawartości Pomocy i usług pomocy technicznej.

PIC

Skrót nazwy Programmable Interrupt Controller (programowalny kontroler przerwań). Ten typ sprzętu nie może być używany w komputerach z wieloma procesorami, a szybkość przetwarzania jest mniejsza niż w przypadku podobnego sprzętu APIC.

pieczęć

Zobacz definicję: ponowne opieczętowanie

piksele

Skrót pochodzący od nazwy „picture elements” (elementy obrazu). Najmniejszy element obrazu rastrowego reprezentowany przez punkt o określonym kolorze i poziomie intensywności koloru. Jednym z mierników rozdzielczości obrazu jest liczba pikseli użytych do utworzenia obrazu.

piktogram

Graficzna reprezentacja znaku, części znaku lub sekwencji znaków.

piractwo komputerowe

Nieupoważnione kopiowanie, dystrybucja i używanie oprogramowania lub kradzież oprogramowania.

plik .cab

plik cabinet. Jeden plik, w którym jest przechowywanych wiele plików skompresowanych. Pliki .cab są powszechnie używane przy instalowaniu oprogramowania i zmniejszają rozmiar plików oraz związany z nim czas pobierania w przypadku zawartości sieci Web.

plik .dll

Zobacz definicję: biblioteka dołączana dynamicznie (DLL)

plik .inf

Plik informacyjny. Plik utworzony dla określonej karty, który dostarcza systemowi operacyjnemu informacji wymaganych do skonfigurowania urządzenia, takich jak lista prawidłowych konfiguracji logicznych urządzenia, nazwy plików sterowników skojarzonych z urządzeniem itp. Plik .inf jest zazwyczaj dostarczany na dysku przez producenta urządzenia, ale może być również dołączony do systemu operacyjnego.

plik .ini

Plik inicjujący. Pliki .ini, powszechnie używane w systemach Windows 3.x i starszych, były używane zarówno przez system operacyjny, jak i pojedyncze aplikacje do przechowywania stałych ustawień związanych z aplikacją, sterownikiem lub urządzeniem. W 32-bitowych systemach operacyjnych Windows pliki .ini są obsługiwane ze względu na zgodność ze starszymi systemami, ale preferowanym miejscem przechowywania tych ustawień jest rejestr.

plik .ins

Plik ustawień internetowych. Plik dostarczający Instalatorowi aktualizacji systemu Windows ustawień internetowych, które konfigurują przeglądarkę i skojarzone z nią składniki. Możliwe jest utworzenie wielu wersji pakietu przeglądarki przez zmianę pliku .ins używanego dla każdego pakietu. Do tworzenia, zapisywania i ładowania plików .ins służy Menedżer profili.

plik cookie

Blok danych, które serwer sieci Web przechowuje w systemie klienckim. Gdy użytkownik powraca do tej samej witryny sieci Web, przeglądarka wysyła kopię pliku cookie z powrotem na serwer. Pliki cookie identyfikują użytkownika, instruują serwer, aby wysłał dostosowaną wersję żądanej strony sieci Web, i przesyłają informacje o koncie użytkownika.

plik odpowiedzi

Plik tekstowy, w którym są zapisane odpowiedzi na pytania wyświetlane w serii okien dialogowych graficznego interfejsu użytkownika. Plik odpowiedzi dla Instalatora zazwyczaj nosi nazwę Unattend.txt, ale w przypadku preinstalacji sieciowej można mu nadać dowolną nazwę. W przypadku instalacji z dysku CD nazwą pliku odpowiedzi musi być Winnt.sif. Plikami odpowiedzi dla narzędzia Sysprep są Sysprep.inf i Winbom.ini. Pliki odpowiedzi można tworzyć lub modyfikować w edytorze tekstów lub przy użyciu Menedżera instalacji.

Zobacz też: Unattend.txt

plik pamięci podręcznej

Plik używany przez serwery i klientów systemu nazw domen (DNS) do przechowywania odpowiedzi na kwerendy DNS. W przypadku serwerów DNS systemu Windows domyślną nazwą pliku pamięci podręcznej jest Cache.dns.

Zobacz też: pamięć podręczna

plik stronicowania

Plik ukryty na dysku twardym, używany przez system Windows do przechowywania części plików programów i danych, które są zbyt duże i nie mogą być umieszczone w całości w pamięci. Plik stronicowania i pamięć fizyczna (lub pamięć RAM) tworzą pamięć wirtualną. System Windows przenosi dane z pliku stronicowania do pamięci, gdy to konieczne, oraz z pamięci do pliku stronicowania w celu zwolnienia miejsca dla nowych danych. Znany także jako plik wymiany.

Plug and Play

Zestaw specyfikacji opracowanych przez firmę Intel Corporation, pozwalających komputerowi na automatyczne wykrywanie i konfigurowanie urządzeń oraz instalowanie odpowiednich sterowników urządzeń.

Zobacz też: uniwersalna magistrala szeregowa (USB)

Plug and Play BIOS

System BIOS, który podczas uruchamiania systemu odpowiada za konfigurowanie kart Plug and Play i urządzeń na płycie głównej. Po uruchomieniu systemu udostępnia usługi konfiguracyjne czasu wykonania dla urządzeń na płycie głównej.

Zobacz też: BIOS ; płyta systemowa ; system zarządzania oszczędzaniem energii (ACPI)

płyta główna

Główna płyta z układami scalonymi mikrokomputera. Płyta główna zawiera złącza służące do podłączania płyt dodatkowych.

płyta systemowa

Zwana także płytą główną lub płytą komputera. Główna płyta z układami scalonymi komputera, która zawiera większość podstawowych składników systemu.

poddrzewo

Dowolny węzeł w drzewie wraz z dowolnym wyborem połączonych węzłów podrzędnych.

Najwyższy poziom rejestru (na przykład HKEY_LOCAL_MACHINE).

Zobacz też: klucz ; podklucz ; rejestr ; węzeł

Podgląd zdarzeń

Składnik używany do wyświetlania dzienników zdarzeń i zarządzania nimi, zbierania informacji o problemach ze sprzętem i oprogramowaniem oraz monitorowania zdarzeń zabezpieczeń. Podgląd zdarzeń prowadzi dzienniki zdarzeń związanych z programami, zabezpieczeniami i systemem.

Zobacz też: zdarzenie

podklucz

Element rejestru zawierający wpisy lub inne podklucze. Warstwa rejestru znajdująca się bezpośrednio poniżej klucza lub poddrzewa (jeśli poddrzewo nie ma kluczy).

Zobacz też: klucz ; poddrzewo ; rejestr

podpis

Zobacz definicję: podpis cyfrowy

podpis cyfrowy

Sposób umieszczania danych dotyczących nadawcy w wiadomości, pliku lub innych cyfrowo zakodowanych informacjach. Proces cyfrowego podpisywania informacji wymaga ich przekształcenia oraz umieszczenia pewnych tajnych, znanych nadawcy, informacji w tagu nazywanym podpisem. Podpisy cyfrowe są używane w środowiskach, w których wykorzystywane są klucze publiczne, i zapewniają usługi wyłączności podpisu i integralności danych.

Zobacz też: sygnatura czasowa ; usługa

podstawowy sieciowy system wejścia/wyjścia (NetBIOS)

Interfejs programowania aplikacji (API), który może być używany przez programy w sieci lokalnej (LAN). System NetBIOS zapewnia programom jednolity zestaw poleceń służących do zgłaszania żądań dotyczących usług niskiego poziomu, które są wymagane do zarządzania nazwami, prowadzenia sesji i przesyłania datagramów między węzłami w sieci.

Zobacz też: interfejs programowania aplikacji (API) ; podstawowy system wejścia/wyjścia (BIOS) ; sieć lokalna (LAN) ; usługa ; węzeł

podstawowy system wejścia/wyjścia (BIOS)

W przypadku komputerów z procesorem x86 jest to zestaw podstawowych procedur programowych, które testują sprzęt podczas uruchamiania komputera, uruchamiają system operacyjny i obsługują transfer danych między urządzeniami sprzętowymi. System BIOS jest przechowywany w pamięci tylko do odczytu (ROM), dzięki czemu działa po włączeniu komputera. Ma on podstawowe znaczenie dla wydajności, ale zazwyczaj jest niewidoczny dla użytkowników komputerów.

Zobacz też: pamięć tylko do odczytu (ROM) ; rozszerzalny interfejs oprogramowania układowego (EFI) ; x86

Point-to-Point Protocol (PPP)

Standardowy zestaw protokołów stosowanych dla łączy typu point-to-point do transportowania datagramów wieloprotokołowych. Protokół PPP opisano w specyfikacji RFC 1661.

Zobacz też: dostęp zdalny ; Transmission Control Protocol/Internet Protocol (TCP/IP)

Point-to-Point Tunneling Protocol (PPTP)

Technologia sieciowa obsługująca wirtualne sieci prywatne (VPN) wykorzystujące wiele protokołów, która pozwala użytkownikom zdalnym uzyskać dostęp do sieci firmowych w bezpieczny sposób za pośrednictwem Internetu lub innych sieci przez wybranie numeru usługodawcy internetowego (ISP) lub ustanowienie bezpośredniego połączenia z Internetem. Protokół PPTP tworzy tunele, czyli hermetyzuje ruch sieciowy IP, IPX lub NetBEUI wewnątrz pakietów IP. Oznacza to, że użytkownicy mogą zdalnie uruchamiać aplikacje, które są zależne od określonych protokołów sieciowych.

Zobacz też: Internet Protocol (IP) ; Internetwork Packet Exchange (IPX) ; rozszerzony interfejs użytkownika NetBIOS (NetBEUI)

połączenie telefoniczne

Połączenie nawiązane z siecią za pomocą urządzenia wykorzystującego sieć telefoniczną. Przykładem mogą być połączenia przy użyciu modemów i standardowej linii telefonicznej czy połączenia przy użyciu kart ISDN i linii ISDN o dużej szybkości lub sieci typu X.25.

Typowi użytkownicy mogą korzystać z jednego lub dwóch połączeń telefonicznych, na przykład z Internetem i siecią firmową. W bardziej złożonych systemach serwerów wiele połączeń modemowych może być używanych do implementowania zaawansowanego routingu.

Zobacz też: modem

ponowne opieczętowanie

Przygotowanie systemu operacyjnego do przekazania użytkownikowi końcowemu po przeprowadzeniu dodatkowego przetwarzania i testowania w fabryce. Aby opieczętować komputer, na zakończenie przetwarzania fabrycznego należy uruchomić narzędzie Sysprep z opcją -reseal.

ponowny rozruch

Ponowne uruchomienie komputera przez ponowne załadowanie systemu operacyjnego. Można przeprowadzić tzw. rozruch zimny, wyłączając i ponowne włączając komputer, lub rozruch gorący, bez wyłączania komputera, na przykład naciskając klawisze CTRL+ALT+DELETE, klikając przycisk Zamknij system, a następnie klikając opcję Uruchom ponownie.

poprawka

Aktualizacja mająca na celu usunięcie problemu zidentyfikowanego po wprowadzeniu oprogramowania na rynek. Dystrybucja poprawek jest ograniczona warunkami licencji.

port

Punkt połączenia w komputerze, w którym można podłączyć urządzenia przekazujące dane do komputera i z komputera. Na przykład drukarka jest zazwyczaj podłączona do oddzielnego portu równoległego (nazywanego również portem LPT), a modem do portu szeregowego (nazywanego również portem COM).

Zobacz też: uniwersalna magistrala szeregowa (USB)

port wejścia/wyjścia (We/Wy)

Kanał, przez który dane są przesyłane między urządzeniem i mikroprocesorem. Port jest postrzegany przez mikroprocesor jako jeden lub kilka adresów pamięci, które mogą być używane do wysyłania lub odbierania danych.

Zobacz też: adres pamięci ; port ; urządzenie

POST

Zobacz definicję: wewnętrzny test po włączeniu (POST)

postać agenta

Interakcyjna, animowana postać, która prowadzi użytkowników przez proces System Windows — Zapraszamy!. Postać ta komunikuje się z użytkownikiem w sposób przypominający zwykłe sposoby porozumiewania się ludzi. Może ona odpowiadać na pytania użytkownika przy użyciu syntezowanej mowy, zarejestrowanego dźwięku lub tekstu w dymku.

Zobacz też: System Windows — Zapraszamy!

postać ikony

Animowana postać z Centrum pomocy i obsługi technicznej, która prowadzi użytkowników przez program początkowy System Windows — Zapraszamy!.

Zobacz też: System Windows — Zapraszamy!

postać Qmark

Animowana postać aplikacji Microsoft Agent w aplecie System Windows — Zapraszamy!.

prawa użytkownika

Zadania, które użytkownik może wykonywać w systemie komputerowym lub domenie. Istnieją dwa typy praw użytkownika: przywileje i prawa logowania. Przykładem przywileju jest prawo do zamykania systemu. Przykładem prawa logowania jest prawo do lokalnego logowania się na komputerze. Obydwa typy praw są przypisywane użytkownikom i grupom użytkowników przez administratorów i stanowią fragment systemu zabezpieczeń komputera.

Zobacz też: domena

Preboot Execution Environment (PXE)

Oparta na protokole DHCP technologia rozruchu zdalnego, używana do rozruchu lub zainstalowania systemu operacyjnego na komputerze klienckim z serwera zdalnego. Przykładem serwera PXE jest serwer RIS.

preinstalacja

Akt zainstalowania i skonfigurowania systemu Windows XP na nowych komputerach, które są następnie rozprowadzane wśród użytkowników końcowych.

preinstalacja z zablokowanym systemem (SLP)

Technologia powiązana z aktywacją produktu Windows, która pomaga ograniczyć używanie legalnie nabytego oprogramowania systemu operacyjnego do systemu komputerowego, na którym zostało ono oryginalnie zainstalowane przez sygnatariusza OEM, zgodnie z uprawnieniami licencjobiorcy określonymi w odpowiedniej Umowie Licencyjnej Użytkownika Oprogramowania. Szczegóły dotyczące preinstalacji z zablokowanym systemem są dostępne dla sygnatariuszy OEM w odrębnych wytycznych.

preinstalowanie

Instalowanie i konfigurowanie systemu Windows XP na nowych komputerach, które są następnie rozprowadzane wśród użytkowników końcowych.

proces izochroniczny

Proces zależny od czasu. Termin ten odnosi się do procesów, w których dane muszą być dostarczone w określonym czasie. Strumienie multimedialne wymagają izochronicznego mechanizmu transportu, który zapewnia, że dane są dostarczane tak szybko, jak są wyświetlane, i że dźwięk jest zsynchronizowany z obrazem.

produkcja na zamówienie

Wytwarzanie komputera zgodnie ze specyfikacjami klienta.

produkcja planowa

Wytwarzanie komputerów zgodnie ze specyfikacjami ogólnymi.

program ładujący bootstrap

Program, który jest uruchamiany automatycznie po włączeniu komputera (podczas rozruchu). Po początkowym przeprowadzeniu kilku podstawowych testów sprzętu program ładujący bootstrap ładuje większy program ładujący, który przejmuje kontrolę i zazwyczaj ładuje system operacyjny. Program ładujący bootstrap jest zazwyczaj przechowywany w pamięci tylko do odczytu (ROM) komputera.

Zobacz też: pamięć tylko do odczytu (ROM)

program początkowy

Oprogramowanie, które użytkownik końcowy widzi po pierwszym uruchomieniu nowego komputera. Program początkowy to System Windows — Zapraszamy! w systemie Windows XP oraz miniinstalacja w rodzinie systemów operacyjnych Windows Server.

Zobacz też: System Windows — Zapraszamy!

program uruchomiony na pierwszym planie

Program uruchomiony w oknie aktywnym, czyli w oknie wyświetlanym na wierzchu, którego pasek tytułu jest wyróżniony. Program uruchomiony na pierwszym planie reaguje na polecenia użytkownika.

protokół

Zestaw reguł i konwencji dotyczących wysyłania informacji przez sieć. Reguły te rządzą zawartością, formatem, kontrolą błędów oraz czasem i kolejnością przesyłania komunikatów wymienianych między urządzeniami sieciowymi.

Zobacz też: Internet Protocol (IP) ; Transmission Control Protocol/Internet Protocol (TCP/IP)

protokół AppleTalk

Zestaw protokołów sieciowych, na którym jest oparta architektura sieci AppleTalk. Protokół AppleTalk jest instalowany wraz z usługami dla komputerów Macintosh, aby ułatwić użytkownikom dostęp do zasobów w sieci.

Zobacz też: protokół ; zasób

protokół dynamicznej konfiguracji hosta (DHCP)

Protokół usługowy TCP/IP, który oferuje dynamicznie dzierżawioną konfigurację adresów IP hostów i rozsyła inne parametry konfiguracji wśród uprawnionych klientów sieci. Protokół DHCP zapewnia bezpieczną, niezawodną i prostą konfigurację sieci TCP/IP, zapobiega konfliktom adresów i pomaga zmniejszyć wykorzystanie puli adresów IP klientów w sieci.

Protokół DHCP korzysta z modelu klient/serwer, w którym serwer DHCP centralnie zarządza adresami IP używanymi w sieci. Klienci obsługujący protokół DHCP mogą zażądać dzierżawionego adresu IP i uzyskać go z serwera DHCP w trakcie rozruchu sieci.

Zobacz też: adres IP ; dzierżawa ; Transmission Control Protocol/Internet Protocol (TCP/IP) ; usługa

protokół PXE

Rozszerzenie protokołu DHCP pozwalające na przesyłanie informacji do systemów, których rozruch odbywa się za pośrednictwem sieci, i umożliwiające znajdowanie serwerów RIS przez te systemy.

protokół transferu plików (FTP)

Element zestawu protokołów TCP/IP używany do kopiowania plików między dwoma komputerami w Internecie. Oba komputery muszą obsługiwać odpowiednie role protokołu FTP: jeden z nich musi być klientem FTP, a drugi serwerem FTP.

Zobacz też: Transmission Control Protocol/Internet Protocol (TCP/IP)

przeglądarka

Oprogramowanie, które interpretuje oznakowanie plików w języku HTML, formatuje je, tworząc strony sieci Web, i wyświetla te strony na komputerze użytkownika. Niektóre przeglądarki umożliwiają również wysyłanie i odbieranie poczty e-mail, odczytywanie wiadomości grup dyskusyjnych oraz odtwarzanie plików audio i wideo osadzonych w dokumentach sieci Web.

Zobacz też: World Wide Web (sieć Web)

przepustowość

W przypadku komunikacji analogowej jest to różnica między najwyższą i najniższą częstotliwością w danym zakresie. Na przykład analogowa linia telefoniczna jest przystosowana do obsługi przepustowości równej 3 000 herców (Hz), tzn. różnicy między najniższą (300 Hz) i najwyższą (3 300 Hz) częstotliwością, którą może przenosić. W przypadku komunikacji cyfrowej przepustowość jest wyrażana w bitach na sekundę (b/s).

Zobacz też: bity na sekundę (b/s)

przetwarzanie z użyciem zredukowanego zestawu instrukcji (RISC)

Typ projektu mikroprocesora, którego podstawą jest błyskawiczne i wydajne przetwarzanie względnie małego zestawu instrukcji. Architektura RISC ogranicza liczbę instrukcji, które są wbudowane w procesor, ale optymalizuje każdą z nich, tak aby były one wykonywane bardzo szybko — zazwyczaj w ciągu jednego cyklu zegara.

przypisana konfiguracja

Zasoby zawarte w węźle urządzenia, które są przydzielone temu urządzeniu. W przypadku kart Plug and Play zasoby przypisane urządzeniu mogą zmieniać się dynamicznie lub przy każdym uruchomieniu systemu.

przystawka

Typ narzędzia, które można dodać do konsoli, obsługiwany przez program Microsoft Management Console (MMC). Przystawka autonomiczna może być dodana niezależnie od innych przystawek. Przystawka rozszerzenia może być dodana tylko w celu rozszerzenia funkcji innej przystawki.

Zobacz też: Microsoft Management Console (MMC)

Przywracanie systemu

Narzędzie, które monitoruje zmiany wprowadzane na komputerze i tworzy punkt przywracania, gdy wykryje początek zmiany. Kreator przywracania systemu umożliwia wybranie punktu przywracania w celu przywrócenia wcześniejszego stanu komputera, w którym działał on poprawnie.

pulpit

Obszar roboczy na ekranie, na którym są wyświetlane okna, ikony, menu i okna dialogowe.

punkt instalacji

Zobacz definicję: punkt instalacji woluminu

punkt instalacji woluminu

Punkt dostępu do woluminu, którego użytkownicy i aplikacje mogą używać do unifikowania różnych systemów plików w jeden system logiczny.

punkt kontrolny

Identyfikator określonej strony lub zestawu pojęciowo powiązanych stron, który śledzi nawigację użytkownika w programie System Windows — Zapraszamy!.

PXE

Zobacz definicję: Preboot Execution Environment (PXE)

Q

QFE

Skrót nazwy Quick-Fix Engineering. Zazwyczaj używa się równoważnego terminu poprawka.

Zobacz też: poprawka

R

RAM

Zobacz definicję: pamięć o dostępie swobodnym (RAM)

ranking

System Windows XP szereguje sterowniki w celu określenia, który jest najlepszy dla urządzenia. Im niższa pozycja sterownika w tym rankingu, tym lepiej nadaje się on dla urządzenia.

rejestr

Baza danych przeznaczona do przechowywania informacji dotyczących konfiguracji komputera. Rejestr zawiera informacje, do których nieustannie odwołuje się system Windows podczas wykonywania operacji, dotyczące takich elementów, jak:

  • profile poszczególnych użytkowników;
  • programy instalowane na komputerze i typy dokumentów, które mogą być tworzone przez poszczególne aplikacje;
  • ustawienia właściwości folderów i ikon programów;
  • sprzęt istniejący w systemie;
  • wykorzystywane porty.

Rejestr jest zorganizowany hierarchicznie jako drzewo, składa się z kluczy i ich podkluczy, gałęzi oraz wpisów.

Zobacz też: gałąź rejestru ; klucz ; podklucz

rejestracja

Podanie przez użytkownika nazwiska, adresu i innych informacji demograficznych firmie Microsoft albo firmie Microsoft i producentowi OEM. Informacje rejestracyjne są zazwyczaj używane do celów marketingowych. Rejestracja nie jest tym samym, co aktywacja; użytkownik może uaktywnić swoją instalację systemu Windows bez podawania żadnych informacji identyfikacyjnych ani demograficznych.

Zobacz też: aktywacja produktu Windows (WPA)

rejestracja uproszczona

Proces, który pozwala użytkownikowi z kontem w domenie zalogować się do sieci przy użyciu hasła lub karty inteligentnej i uzyskać dostęp do dowolnego komputera w domenie.

Zobacz też: domena ; karta inteligentna

rejestracja z pulpitu

Możliwość zarejestrowania się oferowana użytkownikowi przez firmę Microsoft i producenta OEM, jeśli użytkownik nie zarejestrował się w trakcie procesu System Windows — Zapraszamy!.

replika

W przypadku funkcji replikacji usługi Active Directory jest to jedno wystąpienie logicznej partycji usługi Active Directory, synchronizowane za pomocą replikacji między kontrolerami domeny, na których są przechowywane kopie tej samej partycji katalogu. Termin replika może również odnosić się do wystąpienia obiektu lub atrybutu w katalogu rozproszonym.

W wypadku usługi replikacji plików (FRS) jest to komputer uwzględniony w konfiguracji określonego zestawu replik.

RIS

Zobacz definicję: serwer instalacji zdalnej (RIS)

RISC

Zobacz definicję: przetwarzanie z użyciem zredukowanego zestawu instrukcji (RISC)

routing

Proces przesyłania dalej pakietu z hosta źródłowego do hosta docelowego za pośrednictwem sieci.

rozdzielczość obrazu

Ziarnistość obrazu po jego zdygitalizowaniu, mierzona w punktach na cal (DPI); zazwyczaj należy do zakresu od 200 do 400 DPI.

rozpoznawanie nazw

Proces tłumaczenia nazw, które są wygodne dla użytkowników, na liczbowe adresy IP, które są niewygodne dla użytkowników, ale niezbędne do komunikacji TCP/IP. Rozpoznawanie nazw może być udostępniane przez składniki oprogramowania, takie jak usługa DNS lub WINS.

Zobacz też: Transmission Control Protocol/Internet Protocol (TCP/IP) ; Windows Internet Name Service (WINS)

rozruch z dysku CD

Uruchomienie komputera z handlowego dysku CD produktu, a następnie zainstalowanie systemu Windows na dysku twardym przy użyciu Instalatora znajdującego się na tym dysku CD. Ta metoda jest dużo wolniejsza niż zainstalowanie systemu Windows z sieci i nie jest zalecana. Do przeprowadzenia instalacji nienadzorowanej przy zastosowaniu metody rozruchu z dysku CD potrzebny jest plik Unattend.txt o nazwie Winnt.sif. Użytkownik może ręcznie wybrać partycję w pliku Winnt.sif albo określić, że ma ona zostać wybrana automatycznie.

rozszerzalny interfejs oprogramowania układowego (EFI)

W komputerach z procesorem Itanium firmy Intel interfejs między oprogramowaniem układowym komputera, sprzętem i systemem operacyjnym. Interfejs EFI definiuje nowy rodzaj partycji, nazywany tabelą partycji GUID (GPT). W komputerach z procesorem Itanium interfejs EFI pełni te same funkcje, co system BIOS w komputerach z procesorami x86. Oferuje również pewne funkcje rozszerzone, które umożliwiają jednolite uruchamianie dowolnych zgodnych systemów operacyjnych oraz dodawanie sterowników EFI nowych urządzeń bez konieczności aktualizowania oprogramowania układowego komputera.

Zobacz też: Itanium ; podstawowy system wejścia/wyjścia (BIOS) ; tabela partycji GUID (GPT) ; x86

rozszerzony interfejs użytkownika NetBIOS (NetBEUI)

Macierzysty protokół sieciowy sieci Microsoft Networking. Jest on zazwyczaj używany w niewielkich, wydziałowych sieciach lokalnych (LAN), obsługujących od 1 do 200 klientów. Może używać routingu źródłowego Token Ring jako jedynej metody routingu. Protokół NetBEUI jest implementacją firmy Microsoft standardu NetBIOS.

Zobacz też: podstawowy sieciowy system wejścia/wyjścia (NetBIOS) ; protokół ; sieć lokalna (LAN)

S

SBSI

Zobacz definicję: interakcyjne szkolenie Step-by-Step Interactive (SBSI)

SCSI

Zobacz definicję: interfejs małych systemów komputerowych (SCSI)

sektor rozruchowy partycji

Część partycji dysku twardego zawierająca informacje o systemie plików na dysku, oraz krótki program w języku maszynowym, który ładuje system operacyjny Windows.

Zobacz też: partycja

serwer

Ogólnie jest to komputer udostępniający zasoby użytkownikom sieci.

Zobacz też: klient

serwer autonomiczny

Komputer z systemem Windows 2000 Server, który nie należy do domeny. Serwer autonomiczny zawiera tylko swoją własną bazę danych użytkowników końcowych i sam przetwarza żądania logowania. Nie udostępnia on informacji o kontach żadnym innym komputerom i nie umożliwia dostępu do kont domeny.

Zobacz też: domena

serwer DHCP

Komputer z uruchomioną usługą DHCP firmy Microsoft, oferujący dynamiczną konfigurację adresów IP i informacji pokrewnych dotyczących klientów obsługujących protokół DHCP.

Zobacz też: adres IP ; protokół dynamicznej konfiguracji hosta (DHCP)

serwer dostępu zdalnego

Komputer z systemem Windows i usługą Routing i dostęp zdalny, który skonfigurowano pod kątem zapewniania dostępu zdalnego.

Zobacz też: dostęp zdalny

serwer instalacji zdalnej (RIS)

Składnik opcjonalny, który zdalnie instaluje system Windows XP Professional. Serwer RIS instaluje system operacyjny na komputerach klienckich, które obsługują rozruch zdalny, przez połączenie się z komputerem za pośrednictwem sieci, uruchomienie komputera klienckiego, zalogowanie się przy użyciu ważnego konta użytkownika i skopiowanie obrazu systemu operacyjnego na komputer kliencki.

serwer proxy

Serwer zapory i pamięci podręcznej zawartości, który zapewnia zabezpieczenia internetowe i zwiększa wydajność sieci.

serwer sieci Web

Komputer obsługiwany przez administratora systemu lub usługodawcę internetowego (ISP), który odpowiada na żądania przesyłane przez przeglądarki użytkowników.

Zobacz też: usługodawca internetowy (ISP)

serwer zapisywania się od usługodawcy internetowego

Serwer HTTP, który automatyzuje zadanie dodawania nowych klientów do bazy danych klientów usługodawcy internetowego. Serwer zapisywania się od usługodawcy internetowego zbiera informacje od każdego klienta, dodaje te informacje do bazy danych klientów usługodawcy internetowego, a następnie przekazuje pakiet konfiguracyjny z powrotem na komputer klienta. Pakiet konfiguracyjny zawiera informacje, które są używane do skonfigurowania przeglądarki internetowej klienta przy kolejnym połączeniu z usługodawcą internetowym.

Setupapi.log

Plik dziennika zawierający cenne informacje, przydatne przy rozwiązywaniu i debugowaniu problemów z Instalatorem, instalacją urządzeń itp. Informacje przechowywane w tym pliku dziennika obejmują błędy, ostrzeżenia i inne informacje Instalatora systemu Windows, w tym informacje o czasie wystąpienia różnych zdarzeń.

Setupcl.exe

Program wykonywalny wywoływany przez narzędzie Sysprep.exe, który rozpoznaje identyfikatory zabezpieczeń (SID). Musi znajdować się w tym samym folderze, co narzędzie Sysprep.exe.

Zobacz też: identyfikator zabezpieczeń (SID) ; Sysprep.exe

sieć lokalna (LAN)

Sieć komunikacyjna łącząca komputery, drukarki i inne urządzenia działające na względnie małym obszarze (na przykład w tym samym budynku). Sieć lokalna umożliwia interakcję między dowolnymi urządzeniami w sieci.

Zobacz też: grupa robocza ; podstawowy sieciowy system wejścia/wyjścia (NetBIOS) ; rozszerzony interfejs użytkownika NetBIOS (NetBEUI)

sieć rozległa (WAN)

Sieć komunikacyjna łącząca komputery, drukarki i inne urządzenia pracujące daleko od siebie. Sieć WAN umożliwia interakcje między dowolnymi urządzeniami w sieci.

Zobacz też: sieć lokalna (LAN) ; urządzenie

Simple Mail Transfer Protocol (SMTP)

Element zestawu protokołów TCP/IP odpowiedzialny za wymianę poczty elektronicznej między agentami transferu wiadomości.

Zobacz też: protokół ; Transmission Control Protocol/Internet Protocol (TCP/IP)

skrypt

Rodzaj programu zawierający zestaw instrukcji przeznaczonych dla aplikacji lub programu narzędziowego. Skrypt zazwyczaj wyraża instrukcje przy użyciu reguł i składni aplikacji lub narzędzia oraz prostych struktur sterujących, takich jak pętle i wyrażenia if/then. W środowisku systemu Windows termin „skrypt” jest używany zamiennie z terminem „program wsadowy”.

SKU

Skrót angielskiego wyrażenia „shelf keeping unit”. Określony produkt; w tym wypadku określone wydanie systemu Windows XP.

specyfikacje bitowe

Liczby kolorów lub poziomów szarości, które mogą być wyświetlane jednocześnie. Określane są przez rozmiar pamięci karty kontrolera grafiki komputera. Kontroler 8-bitowy może wyświetlać 256 kolorów lub poziomów szarości, kontroler 16-bitowy – 64 000 kolorów, a kontroler 24-bitowy – 16,8 miliona kolorów.

stacja dokująca

Jednostka, w której jest mocowany komputer przenośny, zawierająca łącze zasilania, gniazda rozszerzeń i łącza przeznaczone dla urządzeń peryferyjnych, takich jak monitor, drukarka, pełnowymiarowa klawiatura i mysz. Stacja dokująca umożliwia zamianę komputera przenośnego w komputer typu desktop.

Zobacz też: dokowanie

stan ponownego wiązania

Stan używany przez klientów DHCP do rozszerzania i odnawiania dzierżawy adresu, gdy zbliża się czas wygaśnięcia bieżącej dzierżawy. W tym stanie klient emituje do sieci sygnały mające na celu zlokalizowanie jakiegokolwiek serwera DHCP, który może odnowić lub zastąpić bieżącą konfigurację dzierżawioną przez klienta. Stan ponownego wiązania rozpoczyna się po upływie 87,5 procent czasu dzierżawy klienta.

Zobacz też: dzierżawa ; protokół dynamicznej konfiguracji hosta (DHCP)

Standardy i formaty

Ustawienie apletu Opcje regionalne i językowe określające formaty używane do wyświetlania dat, godzin, walut i liczb oraz porządek sortowania tekstu. Dawna nazwa to ustawienia regionalne użytkownika.

starsze funkcje

Wszelkie funkcje w systemie komputerowym oparte na starszych technologiach, dla których jest utrzymywana zgodność w innych składnikach systemu.

sterownik

Kod trybu jądra używany do sterowania urządzeniem sprzętowym lub emulowania go.

sterownik gotowy

Sterownik zawarty w pliku Driver.cab, który znajduje się w folderze i386 na dysku CD z systemem Windows. Identyfikatory sprzętu typu Plug and Play dla sterowników gotowych są określone w plikach Machine.inf, Scsi.inf, Pnpscsi.inf i Mshdc.inf.

sterownik karty sieciowej

Sterownik urządzenia współpracujący bezpośrednio z kartą sieciową i pośredniczący między kartą a sterownikiem protokołu.

sterownik monolityczny

Sterownik, który zawiera wiele różnych klas funkcji.

sterownik podpisany

Sterownik, który spełnia kryteria programu Windows Logo Program. Firma Microsoft stanowczo zaleca, aby ze względu na wydajność i stabilność używać tylko podpisanych sterowników, zarówno w przypadku sterowników nowych, jak i zaktualizowanych.

sterownik trybu jądra

Sterownik dla urządzenia logicznego, wirtualnego lub fizycznego.

sterownik urządzenia

Program, który umożliwia komunikację między konkretnym urządzeniem, na przykład modemem, kartą sieciową lub drukarką, a systemem operacyjnym. Pomimo zainstalowania urządzenia, system Windows nie może go używać do momentu zainstalowania i skonfigurowania odpowiedniego sterownika.

Jeśli urządzenie znajduje się na liście zgodności sprzętu (HCL), sterownik stanowi zwykle element systemu Windows. Sterowniki urządzeń są zwykle ładowane automatycznie (dla wszystkich włączonych urządzeń) podczas uruchamiania komputera, a później działają w sposób niewidoczny.

Zobacz też: lista zgodności sprzętu (HCL)

sterownik warstwowy

Jedna z kolekcji sterowników, które odpowiadają na te same pakiety IRP. Sterownik warstwowy opisuje sterowniki najwyższego i najniższego poziomu oraz wszystkie sterowniki pośrednie w łańcuchu sterowników, które przetwarzają te same pakiety IRP.

sterowniki innych firm

Sterowniki urządzeń, których nie ma w pliku Driver.cab.

Zobacz też: Driver.cab

strona kodowa

Sposób udostępniania obsługi zestawów znaków i układów klawiatury w różnych krajach lub regionach. Strona kodowa to tabela wiążąca używane przez program binarne kody znaków z klawiszami na klawiaturze lub znakami na monitorze.

SVGA

Super VGA. Standard wideo ustanowiony przez stowarzyszenie BESA, zapewniający wysoką rozdzielczość obrazu kolorowego na komputerach zgodnych z IBM. Najczęściej implementowanym standardem SVGA jest rozdzielczość 1024x768 pikseli.

sygnatariusz OEM

Oryginalny producent sprzętu komputerowego, który podpisał umowę licencyjną bezpośrednio z firmą Microsoft Licensing, Inc. Sygnatariusze OEM otrzymują od firmy Microsoft „złotą” kopię wzorcową systemu Windows. Sygnatariusz OEM może dostosować system Windows zgodnie z opisem w zestawie OPK, umową licencyjną lub podpisanym aneksem.

sygnatura czasowa

Certyfikat wydawany przez zaufaną inną firmę, który potwierdza istnienie danej wiadomości w określonym dniu i o określonej godzinie. W kontekście cyfrowym zaufane inne firmy generują zaufaną sygnaturę czasową dla danej wiadomości, zlecając usłudze stemplującej dołączenie daty i godziny do wiadomości, a następnie umieszczając w wyniku podpis cyfrowy.

Zobacz też: podpis cyfrowy ; usługa

synchroniczność

Tryb, w którym wszystkie aplikacje i polecenia są uruchamiane w określonej kolejności i każdy element musi zostać zamknięty przed uruchomieniem następnego.

Syspart

Proces, który jest wykonywany przez użycie parametru opcjonalnego programu Winnt32.exe. Jest używany w przypadku czystych instalacji na różnych komputerach z niepodobnym sprzętem. Ta zautomatyzowana metoda instalacji skraca czas wdrażania, eliminując fazę kopiowania plików Instalatora.

Sysprep

Narzędzie, które przygotowuje dysk twardy w komputerze źródłowym do duplikacji na komputerach docelowych, a następnie uruchamia proces tworzenia obrazu dysku. Proces ten nie jest obsługiwany przez firmę Microsoft. Ta metoda instalacji zautomatyzowanej jest używana, gdy dysk twardy komputera wzorcowego jest identyczny z dyskami twardymi komputerów docelowych.

Zobacz też: identyfikator zabezpieczeń (SID) ; komputer docelowy ; program początkowy

Sysprep.exe

Narzędzie przygotowania systemu, które używa pliku odpowiedzi Sysprep.inf w celu przygotowania obrazu dysku systemowego do duplikacji.

Sysprep.inf

Opcjonalny plik odpowiedzi używany przez narzędzie Sysprep, który automatyzuje miniinstalację i dodatkowo dostosowuje zainstalowany system operacyjny.

Zobacz też: plik odpowiedzi

system czysty

Instalacja systemu Windows, która nie była modyfikowana ani nie zawiera żadnego zainstalowanego oprogramowania dodatkowego.

system plików

W systemie operacyjnym jest to ogólna struktura, w której pliki są zapisywane i organizowane oraz są im nadawane nazwy. NTFS, FAT i FAT32 to rodzaje systemów plików.

Zobacz też: FAT ; FAT32 ; system plików NTFS

system plików NTFS

Zaawansowany system plików zapewniający wydajność, zabezpieczenia, niezawodność i zaawansowane funkcje niespotykane w żadnej wersji systemu FAT. Na przykład dzięki standardowemu rejestrowaniu transakcji i technikom odzyskiwania danych system NTFS gwarantuje spójność woluminów. W przypadku awarii system NTFS wykorzystuje informacje pliku dziennika i punktów kontrolnych do przywrócenia spójności systemu plików. System plików NTFS oferuje również funkcje zaawansowane, takie jak uprawnienia plików i folderów, szyfrowanie, przydziały dysku i kompresja.

Zobacz też: FAT32 ; system plików ; tabela alokacji plików (FAT)

System Windows — Zapraszamy!

Program początkowy, który użytkownik końcowy widzi po pierwszym uruchomieniu komputera z systemem Windows XP Home Edition lub Windows XP Professional. Wyświetlając serię ekranów i stron HTML, program System Windows — Zapraszamy! szybko i łatwo prowadzi użytkownika końcowego przez ostatnie kroki procesu konfigurowania komputera. Użytkownik końcowy jest monitowany o wszelkie dodatkowe informacje, które są wymagane do spersonalizowania ustawień, takich jak ustawienia regionalne, konfiguracja sieci (jeśli dotyczy) i ustawienia połączenia internetowego. Program System Windows — Zapraszamy! był wcześniej znany jako Out-Of-Box Experience (OOBE).

system zarządzania oszczędzaniem energii (ACPI)

Otwarta specyfikacja przemysłu komputerowego definiująca zarządzanie energią w przypadku wielu typów komputerów przenośnych, komputerów typu desktop, serwerów i urządzeń peryferyjnych. Specyfikacja ACPI jest podstawą inicjatywy OnNow, opracowanej dla przemysłu komputerowego, która pozwala producentom systemów na dostarczanie komputerów uruchamianych przez dotknięcie klawiatury. Specyfikacja ACPI została tak zaprojektowana, aby umożliwić pełne wykorzystanie zalet funkcji zarządzania energią i technologii Plug and Play.

Zobacz też: Plug and Play

systemowy katalog główny

Nazwa ścieżki i folderu, w którym znajdują się pliki systemowe systemu Windows. Zazwyczaj jest to katalog C:\Windows, ale podczas instalacji systemu Windows można wybrać inny dysk lub folder. Aby zmienić faktyczną lokalizację folderu zawierającego pliki systemowe systemu Windows, można użyć wartości %systemroot%. Aby zidentyfikować główny folder systemowy, kliknij przycisk Start, kliknij polecenie Uruchom, wpisz polecenie %systemroot%, a następnie kliknij przycisk OK.

szablon certyfikatu

Konstrukcja systemu Windows określająca format i zawartość certyfikatu na podstawie jego przeznaczenia. Osoby żądające certyfikatu od urzędu certyfikacji (UC) przedsiębiorstwa systemu Windows mają możliwość wyboru różnych typów certyfikatów opartych na szablonach certyfikatów.

Zobacz też: certyfikat ; urząd certyfikacji (UC)

szerokie pasmo

Termin związany z systemami komunikacyjnymi, w których nośniki transmisyjne (takie jak przewody lub światłowody) umożliwiają przenoszenie wielu wiadomości naraz, a każda wiadomość jest modulowana przez modem przy użyciu innej częstotliwości nośnej.

szyfrowanie

Proces maskowania wiadomości lub danych w celu ukrycia ich znaczenia.

Zobacz też: szyfrowanie oparte na kluczu publicznym

szyfrowanie oparte na kluczu publicznym

Metoda szyfrowania wykorzystująca dwa klucze powiązane ze sobą pod względem matematycznym. Jeden z kluczy, nazywany kluczem prywatnym, jest poufny. Drugi klucz, nazywany kluczem publicznym, jest rozpowszechniany wśród potencjalnych korespondentów. W typowym scenariuszu nadawca używa klucza publicznego adresata do zaszyfrowania wiadomości. Tylko adresat ma odpowiedni klucz prywatny, dzięki któremu może odszyfrować wiadomość. Ze względu na złożone zależności między kluczem publicznym i prywatnym jest praktycznie niemożliwe obliczenie jednego klucza na podstawie drugiego, pod warunkiem, że oba klucze są dostatecznie długie. Metoda ta jest zwana także szyfrowaniem asymetrycznym.

Zobacz też: klucz prywatny ; klucz publiczny ; szyfrowanie

Ś

środowisko preinstalacji systemu Windows (WinPE)

Minimalny system operacyjny Win32 z ograniczonym zestawem usług, oparty na jądrze systemu Windows XP Professional. Środowisko WinPE jest używane tylko do preinstalowania i wdrażania systemu Windows.

T

tabela alokacji plików (FAT)

System plików używany w systemie MS-DOS i innych systemach operacyjnych Windows do organizowania plików i zarządzania nimi. Tabela alokacji plików (FAT) to struktura danych, którą system Windows tworzy w trakcie formatowania woluminu przy użyciu systemu plików FAT lub FAT32. System Windows przechowuje w niej informacje o wszystkich plikach, dzięki czemu można je później pobierać.

Zobacz też: FAT32 ; system plików ; system plików NTFS

tabela partycji GUID (GPT)

Schemat tworzenia partycji dysku wykorzystywany przez interfejs EFI na komputerach z procesorem Itanium. Schemat GPT ma więcej zalet niż schemat MBR, ponieważ umożliwia utworzenie na jednym dysku maksymalnie 128 partycji, zapewnia obsługę woluminów o maksymalnej pojemności 18 eksabajtów, umożliwia korzystanie z podstawowych i zapasowych tabel partycji oraz obsługuje unikatowe identyfikatory dysków i partycji (identyfikatory GUID).

Zobacz też: główny rekord rozruchowy (MBR) ; Itanium ; rozszerzalny interfejs oprogramowania układowego (EFI)

tablica niezależnych dysków twardych (RAID)

Metoda używana do standaryzacji i klasyfikacji systemów dysków odpornych na uszkodzenia. Poziomy RAID zapewniają różne kombinacje wydajności, niezawodności i kosztów. Niektóre serwery udostępniają trzy poziomy RAID: Poziom 0 (rozkładanie), Poziom 1 (dublowanie) i Poziom 5 (RAID-5).

Zobacz też: odporność na uszkodzenia ; wolumin RAID-5

taksonomia

System klasyfikacji w Centrum pomocy i obsługi technicznej systemu Windows XP, który organizuje tematy Pomocy w określone kategorie.

TAM

Zobacz definicję: menedżer odpowiedzialny za pomoc techniczną (TAM)

TAPI

Zobacz definicję: interfejs API telefonii (TAPI)

TCP/IP

Zobacz definicję: Transmission Control Protocol/Internet Protocol (TCP/IP)

telefonia

Technologia telefoniczna; transmisje głosowe, faksowe lub modemowe, oparte na konwersji dźwięku na sygnały elektryczne lub na łączności bezprzewodowej za pomocą fal radiowych.

topologia

W systemie Windows topologia oznacza relacje między zestawem składników sieci. W kontekście replikacji usługi Active Directory termin topologia odnosi się do zestawu połączeń używanych przez kontrolery domeny do replikowania informacji między sobą.

Zobacz też: Active Directory ; kontroler domeny

Transmission Control Protocol/Internet Protocol (TCP/IP)

Zestaw protokołów sieciowych często używanych w Internecie i zapewniających komunikację w połączonych sieciach tworzonych przez komputery o różnych architekturach sprzętowych i systemach operacyjnych. Protokół TCP/IP obejmuje standardy komunikowania się komputerów oraz konwencje dotyczące łączenia sieci i routowania ruchu sieciowego.

Zobacz też: Internet Protocol (IP) ; protokół

tryb cichy

Uruchomienie aplikacji wiersza polecenia w taki sposób, aby nie były wyświetlane komunikaty potwierdzające ani żadne inne elementy interfejsu użytkownika, które normalnie pojawiają się na ekranie. Przełącznikiem dla trybu cichego jest zazwyczaj /q.

tryb fabryczny

Tryb uruchomienia narzędzia Sysprep, który odkłada uruchomienie programu początkowego i pozwala producentom OEM na zainstalowanie dodatkowych sterowników i aplikacji, uwzględnienie informacji klienta związanych z produkcją na zamówienie i przetestowanie instalacji systemu Windows. Aby uruchomić narzędzie Sysprep w trybie fabrycznym, należy użyć wiersza polecenia Sysprep -factory.

tryb inspekcji

Sprawdzanie, przed dostarczeniem użytkownikowi końcowemu, czy wyprodukowany komputer działa prawidłowo. Po inspekcji należy zawsze ponownie opieczętować system operacyjny w celu zresetowania programu początkowego.

tryb jądra

Tryb o wysokim priorytecie, w którym kod programu ma bezpośredni dostęp do całej pamięci, w tym przestrzeni adresowych wszystkich procesów i aplikacji trybu użytkownika, oraz sprzętu. Znany także jako tryb nadzoru, tryb chroniony lub Ring 0.

tryb macierzysty

Tryb domeny systemu Windows 2000, w którym na wszystkich kontrolerach domeny w domenie jest uruchomiony system Windows 2000 i administrator domeny przełączył tryb działania domeny z mieszanego na macierzysty. Tryb macierzysty obsługuje grupy uniwersalne i zagnieżdżanie grup. W trybie macierzystym kontrolery domeny z systemem Windows NT 4.0 lub starszym nie są obsługiwane.

W domenach systemu Windows Server 2003 tryb mieszany jest określany jako tryb macierzysty systemu Windows 2000 i jest jednym z trzech dostępnych poziomów funkcjonalnych domeny.

Zobacz też: Active Directory ; tryb mieszany

tryb mieszany

Domyślne ustawienie trybu domeny w domenie systemu Windows 2000. Tryb mieszany pozwala na współistnienie zapasowych kontrolerów domeny systemu Windows NT i kontrolerów domeny systemu Windows 2000. Tryb mieszany nie obsługuje grup uniwersalnych ani zagnieżdżania grup. Tryb domeny można zmienić na macierzysty po usunięciu z domeny wszystkich zapasowych kontrolerów domeny systemu Windows NT.

W domenach systemu Windows Server 2003 tryb mieszany jest określany jako tryb mieszany systemu Windows 2000 i jest jednym z trzech dostępnych poziomów funkcjonalnych domeny.

Zobacz też: Active Directory ; tryb macierzysty

tryb użytkownika

Tryb przetwarzania, w którym są uruchamiane aplikacje.

Txtsetup.oem

Plik tekstowy identyfikujący obsługiwane składniki sprzętowe, pliki skojarzone ze składnikiem sprzętowym, które mają być skopiowane z dysku dystrybucyjnego, oraz listę kluczy i wartości rejestru, które mają być utworzone dla składnika sprzętowego. Jest on używany tylko podczas instalacji w trybie tekstowym.

typ sprzętu

Klasyfikacja podobnych urządzeń. Na przykład urządzenie do przetwarzania obrazów to typ sprzętu obejmujący cyfrowe aparaty fotograficzne i skanery.

Zobacz też: urządzenie

U

UCS Transformation Format 8 (UTF-8)

Zestaw znaków dla protokołów, którym nie wystarcza zestaw znaków ASCII. Protokół UTF-8 zapewnia obsługę rozszerzonego zestawu znaków ASCII oraz tłumaczenie zestawu znaków UCS-2, międzynarodowego zestawu znaków 16-bitowych Unicode. Protokół UTF-8 pozwala na używanie szerszego zakresu nazw niż w przypadku kodowania ASCII lub rozszerzonego kodowania ASCII danych znakowych.

Zobacz też: amerykański standardowy kod służący do wymiany informacji (ASCII) ; Unicode

udział dystrybucyjny

Folder sieciowy, który zawiera pliki źródłowe preinstalowanych produktów Windows. Może on również zawierać narzędzia zestawu OPK i zestawy konfiguracyjne. Ten folder może być utworzony ręcznie lub przez Menedżera instalacji.

umieszczenie

Skopiowanie na komputer docelowy katalogów i plików, które mają być zainstalowane, bez konfigurowania żadnych ustawień rejestru.

Zobacz też: dołączenie ; komputer docelowy ; odłączenie

Umowa Licencyjna OEM

Umowa prawna między firmą Microsoft Licensing, Inc. a producentem OEM określająca warunki preinstalacji, dostosowywania i dystrybucji systemu Microsoft Windows. W przypadku konstruktorów systemów odpowiednia umowa jest umieszczona na opakowaniu każdego pakietu dystrybucyjnego OEM. Otwarcie pakietu jest równoznaczne z wyrażeniem zgody na wszystkie warunki umowy Microsoft OEM System Builder Agreement. W przypadku sygnatariuszy OEM umowa licencyjna jest podpisanym kontraktem. Określone wymagania i opcje dostosowania dotyczące wymienionych umów licencyjnych udokumentowano w podręczniku użytkownika zestawu OPK.

Zobacz też: konstruktor systemów ; Microsoft OEM System Builder Agreement; sygnatariusz OEM

Umowa Licencyjna Użytkownika Oprogramowania (EULA)

Umowa prawna między producentem oprogramowania lub sprzętu a użytkownikiem końcowym, określająca warunki używania i transferu oprogramowania.

Unattend.txt

Ogólna nazwa dla pliku odpowiedzi Instalatora systemu Windows. W przypadku metody instalacji polegającej na rozruchu z dysku CD nazwą pliku Unattend.txt musi być Winnt.sif.

Zobacz też: Instalator systemu Windows ; plik odpowiedzi ; rozruch z dysku CD ; Winnt.exe

UNC

Zobacz definicję: uniwersalna konwencja nazewnictwa (UNC)

Unicode

Opracowany przez konsorcjum Unicode Consortium standard kodowania znaków, w którym są reprezentowane prawie wszystkie języki świata. Zestawy znaków Unicode mają wiele postaci, na przykład UTF-8, UTF-16 i UTF-32. Większość interfejsów systemu Windows korzysta z postaci UTF-16.

Zobacz też: amerykański standardowy kod służący do wymiany informacji (ASCII) ; UCS Transformation Format 8 (UTF-8)

uniwersalna konwencja nazewnictwa (UNC)

Konwencja nadawania plikom i innym zasobom nazw zaczynających się od dwóch kresek ułamkowych odwróconych (\), które wskazują, że zasób istnieje na komputerze sieciowym. Nazwy UNC mają składnię \\nazwa_serwera\nazwa_udziału, gdzie nazwa_serwera jest nazwą serwera, a nazwa_udziału jest nazwą udostępnionego zasobu. Nazwa UNC katalogu lub pliku może również zawierać ścieżkę katalogu po nazwie udziału, zgodnie z następującą składnią: \\nazwa_serwera\nazwa_udziału\katalog\nazwa_pliku.

uniwersalna magistrala szeregowa (USB)

Zewnętrzna magistrala obsługująca instalację typu Plug and Play. Używając magistrali USB, urządzenia można podłączać i odłączać bez wyłączania ani ponownego uruchamiania komputera. Jeden port USB może być wykorzystany do podłączenia maksymalnie 127 urządzeń peryferyjnych, takich jak głośniki, telefony, stacje CD-ROM, joysticki, stacje taśm, klawiatury, skanery i aparaty fotograficzne. Port USB znajduje się zazwyczaj z tyłu komputera, obok portu szeregowego lub równoległego.

Zobacz też: magistrala ; Plug and Play ; port

uprawnienie

Reguła skojarzona z obiektem w celu określenia, którzy użytkownicy i w jaki sposób mogą uzyskać do niego dostęp. Uprawnienia są udzielane lub odbierane przez właściciela obiektu.

Zobacz też: obiekt

urząd certyfikacji (UC)

Jednostka odpowiedzialna za ustanowienie i zagwarantowanie autentyczności kluczy publicznych należących do podmiotów (zazwyczaj użytkowników lub komputerów) albo innych urzędów certyfikacji. Działania urzędu certyfikacji mogą polegać na wiązaniu kluczy publicznych z nazwami wyróżniającymi przy użyciu podpisanych certyfikatów, zarządzaniu numerami seryjnymi certyfikatów i odwoływaniu certyfikatów.

Zobacz też: certyfikat ; główny urząd certyfikacji ; klucz publiczny

urządzenia dodatkowe

Urządzenia, które są tradycyjnie dodawane do podstawowego systemu komputerowego w celu rozszerzenia jego funkcji, takie jak karta dźwiękowa, karta sieciowa, karta graficzna lub kontroler SCSI. Urządzenia dodatkowe dzielą się na dwie kategorie: urządzenia wbudowane w płytę główną oraz urządzenia na kartach rozszerzeń, dodawane do systemu za pośrednictwem złącza płyty głównej, na przykład PCI.

urządzenia systemowe

Urządzenia na płycie głównej, takie jak kontrolery przerwań, kontroler klawiatury, zegar czasu rzeczywistego, rejestry stron DMA, kontrolery DMA, kontrolery pamięci, kontroler dyskietek, porty IDE, porty szeregowe i równoległe, mosty PCI itd. W dzisiejszych komputerach urządzenia te są zazwyczaj zintegrowane w dodatkowym układzie scalonym.

urządzenie

Dowolny sprzęt, który można podłączyć do sieci lub komputera, na przykład komputer, drukarka, joystick, karta, modem lub dowolne inne wyposażenie peryferyjne. Zazwyczaj do działania w systemie Windows urządzenia wymagają sterowników urządzeń.

Zobacz też: sterownik urządzenia

urządzenie LPT

Zobacz definicję: urządzenie równoległe

urządzenie magazynujące

Ogólny termin odnoszący się do dysku, dysku optycznego lub innego urządzenia, które umożliwia trwałe przechowywanie danych komputerowych.

urządzenie PCMCIA

Urządzenie wymienne o wymiarach zbliżonych do rozmiaru karty kredytowej, które można podłączyć do gniazda PCMCIA komputera przenośnego. Urządzeniami PCMCIA mogą być modemy, karty sieciowe i dyski twarde.

Niektóre karty PCMIA można podłączać do komputera i odłączać od niego bez konieczności ponownego uruchomienia komputera. Przed usunięciem karty PCMCIA należy jednak użyć Kreatora dodawania sprzętu, aby powiadomić system Windows o tej operacji. System Windows powiadamia następnie, kiedy karta może zostać usunięta.

urządzenie równoległe

Urządzenie, które korzysta z połączenia równoległego.

urządzenie szeregowe (COM)

Ciąg o maksymalnej długości 256 znaków z pięcioma polami obowiązkowymi i dziesięcioma polami opcjonalnymi, zdefiniowanymi w sekcji 3 specyfikacji Plug and Play External COM Device Specification, v. 1.0.

USB

Zobacz definicję: uniwersalna magistrala szeregowa (USB)

usługa

Program, procedura lub proces, który pełni określone funkcje systemowe, obsługując inne programy, zwłaszcza na niskim poziomie (zbliżonym do poziomu sprzętowego). Usługi udostępniane za pośrednictwem sieci mogą być publikowane w usłudze Active Directory, która ułatwia administrację i użytkowanie zorientowane na usługę. Przykładami usług są: Menedżer kont zabezpieczeń, usługa replikacji plików oraz Routing i dostęp zdalny.

usługi Simple TCP/IP

Cztery usługi TCP/IP: Character Generator, Daytime Discard, Echo i Quote of the Day.

Zobacz też: Transmission Control Protocol/Internet Protocol (TCP/IP) ; usługa

usługodawca internetowy (ISP)

Firma zapewniająca osobom indywidualnym lub firmom dostęp do Internetu i sieci Web. Usługodawca internetowy udostępnia numer telefonu, nazwę użytkownika, hasło i inne informacje dotyczące połączenia, które umożliwiają łączenie się z komputerami usługodawcy. Usługodawca internetowy zazwyczaj pobiera opłatę zryczałtowaną lub zależną od czasu połączenia.

Zobacz też: serwer sieci Web

ustawienia regionalne

Zobacz definicję: Język

Ustawienia regionalne

Grupa informacji dotyczących preferencji użytkownika, takich jak formatowanie daty i godziny, reprezentowana przez listę wartości związanych z językiem i odmianą języka użytkownika.

ustawienia regionalne systemu

Zobacz definicję: Język dla programów nie obsługujących kodu Unicode

ustawienia regionalne użytkownika

Zobacz definicję: Standardy i formaty

UTF-8

Zobacz definicję: UCS Transformation Format 8 (UTF-8)

uwierzytelnianie

Proces sprawdzania wiarygodności informacji identyfikujących obiekt lub osobę. Może on polegać na potwierdzeniu źródła i integralności informacji, jak w przypadku sprawdzania podpisu cyfrowego albo tożsamości użytkownika lub komputera.

Zobacz też: karta inteligentna

Użytkownicy i komputery usługi Active Directory

Narzędzie administracyjne używane przez administratora do wykonywania codziennych zadań administracyjnych usługi Active Directory. Do zadań tego typu należy m.in. tworzenie, usuwanie, modyfikowanie, przenoszenie i ustawianie uprawnień dotyczących obiektów przechowywanych w katalogu. Przykładami obiektów w usłudze Active Directory są jednostki organizacyjne, użytkownicy, kontakty, grupy, komputery, drukarki i pliki udostępnione.

Zobacz też: Active Directory ; obiekt ; uprawnienie

użytkownik końcowy

Osoba, która ostatecznie odbiera w celu użytkowania komputer wyprodukowany przez producenta OEM.

V

VAR

Zobacz definicję: dostawca podnoszący jakość towaru (VAR)

VGA

Skrót nazwy Video Graphics Array. Karta wideo, która obsługuje rozdzielczość koloru 640 x 480 pikseli. VGA jest standardem wyświetlania wideo dla urządzeń rozruchowych w systemach operacyjnych Windows, który zapewnia średnią rozdzielczość tekstu i grafiki.

W

warstwa abstrakcji sprzętowej (HAL)

Cienka warstwa oprogramowania, dostarczana przez producenta sprzętu, która ukrywa różnice sprzętowe występujące w wyższych warstwach systemu operacyjnego. Dzięki wykorzystaniu filtru warstwy HAL, różne typy sprzętu stają się podobne do reszty systemu operacyjnego. Pozwala to na przenoszenie systemu operacyjnego między różnymi platformami sprzętowymi. Warstwa HAL zawiera również procedury, które umożliwiają jednemu sterownikowi urządzenia obsługę tego samego urządzenia na wszystkich platformach.

warstwa adaptacji ATM (AAL)

Warstwa stosu protokołu ATM analizująca dane i przekształcająca je w ładunek komórki ATM w celu przesłania przez sieć ATM.

WDL

Zobacz definicję: biblioteka sterowników systemu Windows (WDL)

We/Wy

Zobacz definicję: port wejścia/wyjścia (We/Wy)

wewnętrzny test po włączeniu (POST)

Zestaw procedur przechowywanych w pamięci tylko do odczytu (ROM), które testują różne składniki systemu, takie jak pamięć RAM, stacje dysków i klawiatura, w celu sprawdzenia, czy są one właściwie podłączone i czy działają prawidłowo. Jeśli występują problemy, procedury te alarmują użytkownika serią sygnałów dźwiękowych lub komunikatem, któremu często towarzyszy diagnostyczna wartość liczbowa. Jeśli test POST powiedzie się, kontrola zostaje przekazana programowi ładującemu bootstrap.

Zobacz też: program ładujący bootstrap

węzeł

W odniesieniu do struktur drzewa jest to lokalizacja w drzewie, która może zawierać łącza do jednego lub wielu elementów poniżej niej.

W wypadku sieci lokalnych (LAN) — urządzenie podłączone do sieci i zdolne do komunikowania się z innymi urządzeniami sieciowymi.

W wypadku klastrów serwerów — system komputerowy, który jest aktywnym lub nieaktywnym członkiem klastra.

Zobacz też: klaster serwerów ; sieć lokalna (LAN)

WHQL

Zobacz definicję: Windows Hardware Quality Labs (WHQL)

wielojęzyczny interfejs użytkownika (MUI)

Osobna, autonomiczna wersja systemu Windows, która zawiera zasoby interfejsu użytkownika dla każdego obsługiwanego języka. Interfejs MUI pozwala użytkownikom na ustawienie języka interfejsu użytkownika zgodnie z ich preferencjami, pod warunkiem, że na komputerze znajdują się wymagane pliki językowe. Zaprojektowano go, aby umożliwić wielkim korporacjom wdrożenie jednej wersji systemu w różnych miejscach na świecie przez umożliwienie użytkownikom i grupom lokalnym wybranie języka interfejsu użytkownika. Następujące elementy nie są lokalizowane w wersjach MUI: cały kod 16-bitowy, mapy bitowe, klucze i wartości rejestru, nazwy folderów i plików oraz pliki .inf.

Windows Hardware Quality Labs (WHQL)

Laboratorium oferujące usługi testowania zgodności sprzętu i sterowników z systemami operacyjnymi Windows.

Windows Internet Name Service (WINS)

Usługa programowa dynamicznie mapująca adresy IP na nazwy komputerów (nazwy NetBIOS). Dzięki mapowaniu adresów użytkownicy mogą uzyskać dostęp do zasobów, korzystając z nazw zamiast adresów IP, które trudno jest rozpoznać i zapamiętać.

Zobacz też: adres IP ; podstawowy sieciowy system wejścia/wyjścia (NetBIOS) ; usługa ; zasób

Windows Logo Program

Program certyfikacyjny ułatwiający klientom identyfikację systemów, sprzętu i oprogramowania, które są zgodne z podstawową definicją funkcji platformy, spełniają kryteria jakości i zapewniają poprawne działanie systemu Windows.

Winnt.exe

Narzędzie wiersza polecenia używane do uruchomienia nienadzorowanej instalacji systemu Windows XP z komputera z systemem MS-DOS, Windows 3.1 lub Windows for Workgroups.

Winnt.sif

Plik odpowiedzi zawierający informacje używane przez Instalatora przy instalowaniu systemu Windows metodą rozruchu z dysku CD.

Zobacz też: plik odpowiedzi ; rozruch z dysku CD

Winnt32.exe

Narzędzie wiersza polecenia używane do uruchomienia nienadzorowanej instalacji systemu Windows XP z komputera z systemem Windows 95, Windows 98, Windows NT, Windows 2000 lub Windows XP.

WinPE

Zobacz definicję: środowisko preinstalacji systemu Windows (WinPE)

WINS

Zobacz definicję: Windows Internet Name Service (WINS)

Winsock

Windows Sockets. Standard interfejsu programowania aplikacji (API) dla oprogramowania, które w systemie Windows używa interfejsu TCP/IP.

Zobacz też: interfejs programowania aplikacji (API) ; Transmission Control Protocol/Internet Protocol (TCP/IP)

WMI

Zobacz definicję: Instrumentacja zarządzania Windows (WMI)

wolne miejsce

Dostępne miejsce używane do tworzenia dysków logicznych na partycji rozszerzonej.

Zobacz też: dysk logiczny ; nieprzydzielone miejsce ; partycja rozszerzona

wolumin aktywny

Wolumin, z którego jest uruchamiany komputer. Wolumin aktywny musi być woluminem prostym na dysku dynamicznym. Nie można oznaczyć istniejącego woluminu dynamicznego jako woluminu aktywnego, ale można uaktualnić do dysku dynamicznego dysk podstawowy zawierający partycję aktywną. Po uaktualnieniu dysku do dysku dynamicznego partycja staje się aktywnym woluminem prostym.

Zobacz też: dysk dynamiczny ; dysk podstawowy ; partycja aktywna ; wolumin dynamiczny ; wolumin prosty

wolumin dublowany

Odporny na uszkodzenia wolumin zawierający duplikaty danych na dwóch dyskach fizycznych. Wolumin dublowany zapewnia redundancję danych, duplikując informacje znajdujące się na woluminie przy użyciu dwóch identycznych woluminów (nazywanych kopiami lustrzanymi). Kopia lustrzana znajduje się zawsze na innym dysku. Jeśli jeden z dysków fizycznych ulegnie awarii, dane na uszkodzonym dysku będą niedostępne, ale system będzie kontynuował pracę dzięki kopii lustrzanej na drugim dysku. Woluminy dublowane można tworzyć tylko na dyskach dynamicznych na komputerach z systemem Windows 2000 Server lub systemem z rodziny Windows Server 2003. Woluminów dublowanych nie można rozszerzać.

Zobacz też: dysk dynamiczny ; odporność na uszkodzenia ; wolumin dynamiczny ; wolumin RAID-5

wolumin dynamiczny

Wolumin na dysku dynamicznym. System Windows obsługuje pięć typów woluminów dynamicznych: proste, łączone, rozłożone, dublowane i RAID-5. Wolumin dynamiczny jest formatowany przy użyciu systemu plików (takiego jak FAT lub NTFS) i ma przypisaną literę dysku.

Zobacz też: dysk dynamiczny ; dysk podstawowy ; wolumin dublowany ; wolumin łączony ; wolumin podstawowy ; wolumin prosty ; wolumin RAID-5 ; wolumin rozłożony

wolumin łączony

Wolumin dynamiczny utworzony z miejsca dostępnego na kilku dyskach fizycznych. Rozmiar woluminu łączonego można zwiększyć, rozszerzając go na dodatkowe dyski dynamiczne. Woluminy łączone można tworzyć tylko na dyskach dynamicznych. Nie są one odporne na uszkodzenia i nie mogą być dublowane.

Zobacz też: dysk dynamiczny ; odporność na uszkodzenia ; wolumin dublowany ; wolumin dynamiczny ; wolumin prosty

wolumin podstawowy

Partycja podstawowa lub dysk logiczny na dysku podstawowym.

Zobacz też: dysk logiczny ; dysk podstawowy ; partycja podstawowa

wolumin prosty

Wolumin dynamiczny utworzony z miejsca dostępnego na pojedynczym dysku dynamicznym. Wolumin prosty może składać się z pojedynczego obszaru lub kilku połączonych obszarów tego samego dysku. Jeśli wolumin prosty nie jest woluminem systemowym ani rozruchowym, można go rozszerzyć na tym samym dysku lub na dyski dodatkowe. Wolumin prosty rozszerzony na kilka dysków staje się woluminem łączonym. Woluminy proste można tworzyć tylko na dyskach dynamicznych. Nie są one odporne na uszkodzenia, ale mogą być dublowane w celu utworzenia woluminów dublowanych na komputerach z systemem z rodziny Windows 2000 Server lub Windows Server 2003.

Zobacz też: dysk dynamiczny ; odporność na uszkodzenia ; wolumin dublowany ; wolumin dynamiczny ; wolumin łączony

wolumin RAID-5

Wolumin odporny na uszkodzenia, na którym dane i parzystość są rozłożone w sposób nieciągły na trzech lub większej liczbie dysków fizycznych. Parzystość jest wartością obliczaną, używaną do rekonstruowania danych po awarii. Jeśli część dysku twardego zostanie uszkodzona, to system Windows może odtworzyć znajdujące się na niej dane na podstawie pozostałych danych i parzystości. Woluminy RAID-5 można tworzyć tylko na dyskach dynamicznych na komputerach z systemem Windows 2000 Server lub systemem z rodziny Windows Server 2003. Woluminów RAID-5 nie można rozszerzać ani dublować. W systemie Windows NT 4.0 woluminy RAID-5 były określane jako zestawy paskowe z parzystością.

Zobacz też: dysk dynamiczny ; odporność na uszkodzenia ; wolumin dynamiczny

wolumin rozłożony

Wolumin dynamiczny, który przechowuje dane w paskach na przynajmniej dwóch dyskach fizycznych. Dane znajdujące się na woluminie rozłożonym są alokowane naprzemiennie i równomiernie (w paskach) między dyskami. Woluminy rozłożone oferują większą wydajność niż wszystkie woluminy, które są dostępne w systemie Windows, ale nie zapewniają odporności na uszkodzenia. Jeśli jeden z dysków należących do woluminu rozłożonego ulegnie awarii, utracone zostają dane całego woluminu. Woluminy rozłożone można tworzyć tylko na dyskach dynamicznych. Woluminów rozłożonych nie można dublować ani rozszerzać.

Zobacz też: dysk dynamiczny ; odporność na uszkodzenia ; wolumin dublowany ; wolumin dynamiczny

World Wide Web (sieć Web)

System eksplorowania Internetu przy użyciu hiperłączy. Podczas używania przeglądarki sieci Web, sieć Web pojawia się jako kolekcja tekstów, obrazów, dźwięków i filmów cyfrowych.

Zobacz też: internet

współczynnik proporcji

Stosunek szerokości obrazu do jego wysokości. Gdy obraz jest wyświetlany na różnych ekranach, współczynnik proporcji musi być za każdym razem zachowany, aby uniknąć pionowego lub poziomego zniekształcenia.

wstępnie buforowana oferta zapisania się do usługodawcy internetowego

Zobacz definicję: oferta OEM zapisania się do usługodawcy internetowego

wstępnie skonfigurowane zapisanie do usługodawcy internetowego

Skonfigurowanie systemu operacyjnego, w trakcie procesu produkcji, do używania określonego konta w celu uzyskania dostępu do Internetu.

wypełnianie

Importowanie przygotowanych danych przy użyciu procedury programowej w przeciwieństwie do wprowadzania informacji przez użytkownika końcowego.

wzorzec nazw domen

Kontroler domeny pełniący rolę wzorca operacji nazw domen w usłudze Active Directory. Wzorzec nazw domen steruje dodawaniem i usuwaniem domen w lesie. Rola wzorca nazw domen może być w danej chwili przypisana tylko jednemu kontrolerowi domeny w lesie.

Zobacz też: Active Directory ; kontroler domeny

X

x86

Termin ten odnosi się do mikroprocesorów o architekturze 32-bitowego procesora firmy Intel lub emulujących ją.

Y

W słowniku nie ma haseł zaczynających się na tę literę.

Z

zarządzanie energią

Mechanizmy oprogramowania i sprzętu, które minimalizują pobór energii przez system, zarządzają limitami termicznymi systemu i wydłużają czas użytkowania baterii systemu. Zarządzanie energią polega na znalezieniu kompromisu między szybkością systemu, poziomem hałasu, czasem użytkowania baterii, szybkością przetwarzania i poborem energii.

zasady grupy

Infrastruktura w usłudze katalogowej Active Directory, która pozwala na oparte na katalogu zarządzanie zmianami i konfiguracją ustawień użytkowników i komputerów, w tym zabezpieczeniami i danymi użytkowników. Zasady grupy służą do określania konfiguracji grup użytkowników i komputerów. Korzystając z zasad grupy, można określić ustawienia zasad dotyczących zasad opartych na rejestrze, zabezpieczeń, instalacji oprogramowania, skryptów, przekierowywania folderów, usług instalacji zdalnej i obsługi programu Internet Explorer. Utworzone ustawienia zasad grupy są zawarte w obiekcie zasad grupy. Kojarząc obiekt zasad grupy z wybranymi systemowymi kontenerami usługi Active Directory — lokacjami, domenami i jednostkami organizacyjnymi — ustawienia zasad danego obiektu zasad grupy można zastosować do użytkowników i komputerów w tych kontenerach usługi Active Directory. Do tworzenia pojedynczych obiektów zasad grupy służy Edytor obiektów zasad grupy.

Zobacz też: Active Directory

zasób

Ogólny termin odnoszący się do dowolnej części systemu komputerowego lub sieci, takiej jak dysk, drukarka lub pamięć, która może być przydzielona uruchomionemu programowi lub procesowi.

W wypadku Menedżera urządzeń zasób jest dowolnym z czterech składników systemu, które sterują sposobem działania urządzeń w komputerze. Te cztery zasoby systemowe to linie żądań przerwań (IRQ), kanały bezpośredniego dostępu do pamięci (DMA), porty wejścia/wyjścia (We/Wy) i adresy pamięci.

W wypadku klastrów serwerów zasób jest fizyczną lub logiczną jednostką, która może być zarządzana przez klaster, przełączana do trybu online i offline oraz przenoszona między węzłami. W danym momencie właścicielem zasobu może być tylko jeden węzeł.

Zobacz też: adres pamięci ; klaster serwerów ; linie żądań przerwań (IRQ) ; port wejścia/wyjścia (We/Wy) ; węzeł

zdarzenie

Każde ważne zdarzenie w systemie lub aplikacji, które wymaga powiadomienia użytkowników lub dodania wpisu do dziennika.

zestaw konfiguracyjny

Zobacz definicję: zestaw konfiguracyjny

zestaw konfiguracyjny

Struktura plików lub folderów zawierająca niezbędne ustawienia konfiguracji, która steruje procesem preinstalacji i określa niestandardowe informacje producenta.

Zestaw preinstalacyjny OEM (OPK)

Zestaw narzędzi, dokumentacja i przykłady, które umożliwiają producentom OEM efektywną preinstalację systemu Windows na nowych komputerach, zgodnie z Umową Licencyjną OEM.

zestaw właściwości

Metoda ustawiania i pobierania właściwości sterownika. Każdy zestaw właściwości ma unikatowy identyfikator, który reprezentuje typy pokrewnych informacji i jest używany w celu uzyskania dostępu do zestawu właściwości.

zestaw woluminowy

Wolumin, który obejmuje miejsce na jednym lub kilku dyskach fizycznych. Zestaw woluminowy jest tworzony przy użyciu dysków podstawowych i jest obsługiwany tylko w systemie Windows NT 4.0 lub starszym. Zestawy woluminowe zostały zastąpione przez woluminy łączone, które korzystają z dysków dynamicznych.

Zobacz też: dysk dynamiczny ; dysk podstawowy ; partycja ; wolumin łączony

zestaw znaków jednobajtowych

Kodowanie znaków, w którym każdy znak jest reprezentowany przez 1 bajt. Zestawy znaków jednobajtowych są matematycznie ograniczone do 256 znaków.

zestaw znaków wielobajtowych (MBCS)

Zestaw znaków o różnej szerokości, w którym rozmiar niektórych znaków przekracza 1 bajt. Zestaw znaków dwubajtowych (DBCS), który jest rodzajem zestawu znaków wielobajtowych, obejmuje znaki o rozmiarze 1 bajta i znaki o rozmiarze 2 bajtów.

zintegrowane układy elektroniczne urządzenia (IDE)

Typ interfejsu dysku, w którym układy elektroniczne kontrolera są wbudowane w dysk i stosowanie oddzielnej karty nie jest konieczne. Standard IDE ma wiele zalet, umożliwia na przykład buforowanie danych z wyprzedzeniem, co zwiększa ogólną wydajność systemu.

znak

Najprostszy element używany do reprezentowania języków pisanych. Wygląd znaku nie jest niezmienny; zależy on od użytej czcionki, a także od kontekstu otaczającego go tekstu.

znak diakrytyczny

Znak umieszczony nad lub pod znakiem albo przecinający go, który zazwyczaj wskazuje na zmianę fonetycznej wartości znaku nieoznaczonego. Znak, do którego jest on dołączony, nazywa się znakiem podstawowym. Większość znaków diakrytycznych to znaki nierozciągłe, które nie zwiększają szerokości znaku podstawowego.

znak nierozciągły

Znak, na przykład znak diakrytyczny, który sam nie ma znaczenia, ale jest nakładany na znak podstawowy w celu modyfikacji tego znaku. Czasem nazywany jest „znakiem dołączonym”.

znak podstawowy

Znak, którego znaczenie jest niezależne od innych znaków, albo dowolny znak graficzny, który nie jest znakiem diakrytycznym.

znak rozciągły

Znak o szerokości większej od zera.

znak usługi

Znak używany przy sprzedawaniu lub reklamowaniu usług, identyfikujący daną usługę i odróżniający ją od usług oferowanych przez inne firmy.

znak złożony

Element tekstowy składający się ze znaku podstawowego i znaku diakrytycznego lub znaku akcentu. Chociaż najczęściej występuje on w zapisie łacińskim, w innych zapisach (na przykład greckim, devanagari i tamilskim) również występują znaki złożone.

znak złożony

Jeden znak, który reprezentuje sekwencję znaków, zazwyczaj kombinacja znaku podstawowego i jednego lub kilku znaków diakrytycznych.

znaki dwubajtowe

Zestaw znaków, w którym każdy znak jest reprezentowany przez dwa bajty. Niektóre języki, takie jak japoński, chiński i koreański, wymagają zestawów znaków dwubajtowych.

znakowanie

Dołączanie nazwy firmy, logo, informacji o pomocy technicznej i plików Pomocy do instalacji systemu Microsoft Windows.

znakowanie OEM

Dołączanie nazwy firmy, logo, informacji o pomocy technicznej i plików Pomocy do instalacji systemu Microsoft Windows.

Ź

W słowniku nie ma haseł zaczynających się na tę literę.

Ż

żądanie przerwania (IRQ)

Sygnał wysyłany przez urządzenie w celu poinformowania procesora o gotowości do odebrania lub wysłania informacji. Każde urządzenie wysyła swoje żądania przerwań przez określoną linię sprzętową. Każde urządzenie musi mieć przypisany unikatowy numer przerwania.


Uwagi prawne

Zastrzega się prawo zmiany bez uprzedniego powiadomienia informacji zawartych w niniejszym dokumencie, włącznie z adresami URL i innymi odniesieniami do internetowej sieci Web. Wszystkie firmy, organizacje, produkty, nazwy domen, adresy e-mail, logo, osoby, miejsca i zdarzenia używane w przykładach są fikcyjne i nie mają żadnego związku z jakimikolwiek rzeczywistymi firmami, organizacjami, produktami, nazwami domen, adresami e-mail, logo, osobami, miejscami lub zdarzeniami, o ile nie zaznaczono, że jest inaczej. Odpowiedzialność za dostosowanie się do wszystkich stosownych praw autorskich spoczywa na użytkowniku. Bez ograniczania praw objętych prawem autorskim, niniejszego dokumentu lub jego części nie wolno w żadnej formie powielać, przechowywać ani wprowadzać do żadnego systemu umożliwiającego odtworzenie, ani przekazywać za pomocą jakichkolwiek nośników (elektronicznych, mechanicznych, fotokopii, nagrania itp.) z wyjątkiem przypadków, w których uzyskano na to pisemną zgodę firmy Microsoft Corporation.

Firma Microsoft może mieć patenty lub rozpoczęte postępowania patentowe, znaki towarowe, prawa autorskie lub inne prawa związane z własnością intelektualną, które odnoszą się do treści zawartej w niniejszym dokumencie. Otrzymanie tego dokumentu nie oznacza udzielenia licencji na te patenty, znaki towarowe, prawa autorskie lub inne prawa związane z własnością intelektualną, z wyjątkiem wyraźnie określonych przypadków zawartych w pisemnych Umowach Licencyjnych firmy Microsoft.

© 2004 Microsoft Corporation. Wszelkie prawa zastrzeżone.

Active Desktop, ActiveX, Authenticode, BackOffice, ClearType, DirectX, FrontPage, Hotmail, JScript, Microsoft, Microsoft Press, MS-DOS, MSDN, MSN, Visual Basic, Win32, Win64, Windows, logo Windows, Windows Media, Windows NT oraz logo Windows Start są zastrzeżonymi znakami towarowymi lub znakami towarowymi firmy Microsoft Corporation w USA i/lub innych krajach.

Ten produkt zawiera oprogramowanie filtru grafiki; to oprogramowanie jest częściowo oparte na pracy firmy Independent JPEG Group.

TrueType jest zastrzeżonym znakiem towarowym firmy Apple, Inc.

Nazwy rzeczywistych firm i produktów wymienione w niniejszym dokumencie mogą być znakami towarowymi zarejestrowanymi przez ich właścicieli.